1. Click Video Demo on the Welcome screen. Or, click File > Record New Video Demo.

    The recording window, marked by a red box, and the recording options appear.

  2. Click Screen Area or Application based on what you want to record and specify the associated options:

    Screen Area

    Select this option when you want to capture all events that occur within an area on the screen.

    Custom Size

    Select this option if you want to customize the dimensions of the recorded project. You can choose from a list of standard sizes, or define a custom size. The selected application is automatically resized to fit inside the boundaries of the recording area. Best practice is to have a clear idea of the dimensions of the project before you start recording it.

    Full Screen

    Select this option if you want to set the size of the recording window to the size of your computer monitor. The entire computer screen is treated as the recording window. If you work on dual monitors, you can choose the monitor that you want to use for recording. Recording in this mode can potentially produce very large projects and output file sizes due to the large screen resolution on monitors.

    Application

    Select this option to specify the application which you want to record. The Select The Window To Record drop-down lists all the open applications on your computer. Click the required application from this list.

    Application Window

    Select this option if you want to record the entire application window. The dimensions of the application are not altered. The recording rectangle is resized to fit the application.

    Application Region

    Select this option if you want to record defined areas in an application. For example, if you are recording a window that has three frames, the recording window snaps to individual frames when the mouse moves over them. The dimensions of the application are not altered. The recording rectangle is resized to fit the defined area in the application.

  3. Do one or all of the following:

    • Select a panning mode if you want the recording window to follow your movements across the screen. For more information, see Panning.

    • If you are adding narration during recording, select the type of audio input. In the patch for subscription and Adobe Software Assurance customers, you can select System Audio to record audio from your computer's speakers, for example, the sound you hear when error messages pop-up. For more information, see System Audio.

      System audio is not supported on Windows XP.

    • To change the default settings that Adobe Captivate uses when recording a video demo, click Settings. For more information on customizing recording preferences, see Set video recording preferences.

  4. Click Record.

  5. Press End key (in Windows) or Cmd + Enter (Mac OS) when you have completed the recording.

    Note:

    Alternatively, on Windows, click the task icon or the system tray icon to stop recording. On Mac, click the dock icon or the status bar icon.

The preview of the recorded video appears and starts playing. You can do one or all of the following:

  • Publish the recorded video as an MP4 file and save it on your computer. To do so, click . For more information, see Publish video as an MP4 file.

  • Directly publish the video to YouTube, Twitter, or Facebook. To do so, click . For more information, see Publish video to YouTube.

  • Edit the video in Adobe Captivate and enhance it by adding captions, PIP videos, and pan and zoom effect. You can then publish the video to YouTube, Twitter, Facebook, or save it as an MP4 file.

    To edit the video, click Edit. See Edit videos for more information.

Edit videos

You can enter the video editing mode by clicking Edit in the video preview window.

Edit button in the video preview window

A .CPVC file opens in Adobe Captivate. You can now edit the video to split or trim it, add effects, audio, and the following objects:

  • Text captions

  • Highlight boxes

  • Images

  • Smart shapes

  • Mouse

  • Animation

  • Picture-In-Picture videos (PIP video)

See Noninteractive Objects and Media for information on adding these objects.

A .CPVC file is slightly different from the regular Adobe Captivate project or a CPTX file. The following table summarizes these differences:

CPTX file

CPVC file

Is based on a 'slide' paradigm. After recording, you can see the individual slides in the Filmstrip.

Is not based on the 'slide' paradigm. After recording, the file contains a single video clip that you can see in the Timeline.

You can edit every slide in the Filmstrip by clicking them.

You can edit the video clip to cut, copy, or trim it between two points using the Video Editing options in the Properties.

You can insert both interactive and non-interactive objects.

You can insert only the non-interactive objects, text captions and highlight boxes.

You can insert quizzes.

You cannot add quizzes directly. You can create a separate CPTX project with assessments, publish the CPVC files as MP4 files, and insert into the CPTX project.

You can preview the whole project, the current slide, or specific slides.

You can preview either the whole project or the current frame on stage.

Properties of a video demo project

Click anywhere on the stage outside the recorded video to view the properties of the video demo in the Property Inspector.

Stage

Click to change the fill color of the project background. You can also apply gradient fills or pattern fills for the background. For more information on gradient fills, see Apply gradient fillsand Apply texture fills.

Background

Click <<browse icon>> to select an image as the background. This background is visible on the frames that do not contain the recorded video. For example, you split the video and insert objects such as a text caption between the video clips. The background is applied to the frame with the text caption.

note: If the image you choose is larger than the dimensions of the video frame, the Resize/Crop Image dialog box appears. Choose appropriate options to continue.

Start Time

Indicates from which point in Timeline the video is published. By default, the value is set to the beginning of the video clip.

End Time

Indicates until which point in Timeline the video is published. By default, the value is set to the end of the video clip.

Use Start Time and End Time options to publish a portion of the video. For example, if the total length of the video is 60 seconds, you can publish a portion of the video from 10 to 45 seconds.

Properties of recorded video clips

Name

Type a unique name for the video clip.

Audio

Specify the transition, edit, or remove the audio associated with the video clip. See Add audio to a video project for more information.

Properties of PIP videos

Name

Type a unique name for the video clip.

Shadow

Click to apply shadow to the video clip. Choose the direction and a preset or customize the shadow effect by clicking Custom. For more information, see Apply shadows to objects.

Reflection

Click to apply reflection to the video clip. Click the required preset. For more information, see Add reflection to objects.

Transform

Resize the dimensions of the video clip or modify the position of the clip by specifying X and y values. You can also rotate the clip by specifying an angle.

Click Video Demo on the Welcome screen. Or, click File > Record New Video Demo.

The recording window, marked by a red box, and the recording options appear.

Audio

Specify the transition, edit, or remove the audio associated with the video clip. See Add audio to a video project for more information.

Timeline in video projects

The Timeline in video projects is different from CPTX projects in terms of how objects and videos are grouped:

  • In video projects, unlike CPTX projects, all objects are placed in a single layer in the Timeline

  • PIP videos and recorded video clips are placed in different layers

  • Audio and recorded video clips are placed in the same layer

Add pan and zoom effect

The pan and zoom effect helps you draw users' attention to a specific area or an action in the video. For example, in a software simulation, you can pan the screen to a group of icons and then zoom in closer to a specific icon.

  1. Play the video file using the Play button in the Timeline.

  2. Pause (click the play button again) at the point where you require the pan and zoom effect.

  3. Click Pan & Zoom in the Timeline. The Pan and Zoom icon appears in the video clip and the Pan & Zoom panel appears.

    The Pan & Zoom panel displays the frame at the point you chose in the video.

    Pan &amp; Zoom icons in Timeline

    Note:

    To move the pan and zoom point to a different location on the video clip, drag-and-drop the icon.

  4. To specify the area to be magnified, resize the blue box around the frame using the handles. Then, drag-and-drop the box to the required position on the frame. The smaller the box, the greater is the magnification.

    You can also specify the magnification value in terms of percentage using the Scale slider or box.

  5. Use the Speed slider to specify how fast Adobe Captivate has to zoom in.

To delete a pan and zoom point, click the icon in the timeline and press the Delete key.

Apply transitions to video

  1. Click the transition icon that appears at the beginning and end of the video clip.

    Transition icons in Timeline

  2. Choose a transition effect from the Transitions panel. To see a preview of a transition effect, hover your mouse over the effect.

  3. In the Speed list at the top of the Transition panel, click the required speed for the transition.

To remove the transition effect, click the transition icon, and click No Transition from the Transitions panel.

Split recorded video clips

You can split the video clip to insert separator text or videos (PIP). For example, you can split the video clip to insert a summary of what users learnt until that point in the video.

When you split a video clip, the resultant clips continue to exist on the same layer in the Timeline.

Here's an example of how you can insert separator text between two parts of a video clip:

  1. Click the video clip in the Timeline.

  2. Click to play the video and click the icon again to pause at the point where you want to split the video.

  3. Click Split in the Timeline. The Timeline now shows two video clips.

    Note:

    Other objects, such as, text captions or highlight boxes in the project are also split along with the video clip. Preview the video to adjust the timing of these objects.

  4. Drag-and-drop the second clip to create space for the text that you want to insert.

  5. Click Insert > Text Caption. The default text caption appears on a separate layer on the Timeline.

  6. Drag-and-drop the text caption in the Timeline and position it so that it corresponds to the space between the two parts of the video clip.

  7. Preview the project to check the timing of the text caption.

    Note:

    The text caption appears as a separate frame or a slide. The background of this screen is the one that you set for the video project. To change the background, drag-and-drop the stage anywhere outside the video, and then click Stage in the Property Inspector.

You can make the transition between the video clips interesting by adding effects. When you split a video clip, a transition icon appears at the split point in the Timeline. Click the icon to choose an effect from the Transitions panel.

Note:

Each video clip has a transition icon at the beginning and end. If you move the second video clip, another transition icon appears at the beginning of the clip. When you merge the transition icons by placing the video clips adjacent to each other, the transition effect used in the subsequent video clip is retained.

Trim video clips

You can trim video clips to cut unwanted portions of the video.

  1. Click the video clip in the Timeline.

  2. Click to play the video and click the icon again to pause at the point where you want to trim the video.

  3. Click Trim in the Timeline. Start and end markers that define the region for trimming appear on the video clip.

  4. Click or to move the start and end trim markers to the current playhead position. You can also click and drag the trim markers left or right to choose the portion of the video clip for trimming.

    Note:

    Objects, such as, text captions or highlight boxes that are within the cross section of the trim markers are also cut along with the video clip.

  5. Click Trim in the Timeline.

Two separate video clips appear with transition icons. Click the icon to choose a transition effect.

Add audio to a video project

You can record or import an audio clip (WAV or mp3 files):

  • As background audio for the entire project (Audio > Import to > Background; Audio > Record to > Background).

  • As background or narration for any PIP in the project. Click the PIP in the Timeline, and then click Audio > Import To > PIP, or Audio > Record To > PIP.

  • As video narration to individual video clips in the project. Click the video clip, and then click Audio > Import To > Video Narration, or Audio > Record To > Video Narration.

    If you have split a video clip into multiple clips, you can add separate audio clips to each video clip. To do so, right-click the video clip, and choose Record To or Import To.

You can record audio as narration for the entire project at once using Audio > Record To > Project Narration.

For information on editing audio, see Edit audio.

Edit mouse points

Click the mouse icon and modify the properties in the Property Inspector:

  1. Click Edit > Edit Mouse Points. The mouse icons appear on the video clip in the Timeline indicating the frames that have mouse actions.

    Mouse point icons in the Timeline

  2. Click the mouse icon and modify the properties in the Property Inspector:

    Options

    Choose the required pointer. Click Browse for any pointers stored on your local disk.

    Double Mouse Size

    Choose to double the size of the pointer.

    Show Mouse

    Toggle to show or hide the mouse action. When you hide the mouse action, the mouse icon is still visible on the video clip. However, when you play the video, the action from the previous mouse point to the hidden one is not visible.

    Smoothen Mouse Path

    By default, the mouse path is rough, traced by the actual movement of the mouse during recording. Select this option to make the mouse path smooth either using a straight line or a curve.

    Reduce Speed Before Click

    Select this option to slow the mouse movement down before the click occurs. This option is useful for a long mouse path that moves quickly and stops suddenly.

    note: This option appears only if you have selected Smoothen Mouse Path.

    Show Mouse Click

    Adds a visual click effect to the mouse movement.

    Default

    Displays a quick, small burst of color when the user clicks the slide. You can select a color for the color burst.

    Custom

    Select this option to use a SWF file as a visual click effect. Adobe Captivate includes two effects you can use. Test them by clicking the pop-up menu, selecting one, and then clicking Play. View the effect in the small preview window on the right.

  3. To apply the modified properties to multiple mouse points in the video, click and click one of the options.

Insert mouse actions

In addition to the mouse actions that you capture while recording the video, you can insert new mouse actions into the video.

  1. Click the video clip in the Timeline.

  2. Click to play the video and click the icon again to pause at the point where you want to insert a mouse action.

  3. Click Insert > Mouse. A pointer appears on the frame at the playhead point. Adobe Captivate plots the mouse position based on the coordinates derived from the previous and the subsequent mouse points.

  4. Drag-and-drop the pointer to the required place on the frame.

  5. Edit the properties using the Property Inspector. For details on the different properties you can edit, see Change mouse properties.

Recording additional video

  1. In the CPVC file, click Insert > Video Recording.

    For information on recording video from within CPTX files, see Insert videos in CPTX files.

  2. Select the recording options and the area you want to record, and click Record.

The new video clip appears after the existing video clips on the Timeline.

Publish video projects

Publish video as an MP4 file

  1. In the full screen mode, click . In the CPVC file, click File > Publish.

  2. Specify a title for the project.

  3. Specify a folder in which the project must be published. By default, the project is published in the folder specified in the project preferences.

  4. Click one of the options in the Select Preset list.

    Adobe Captivate automatically sets the video settings based on the option you select. If necessary, you can customize the settings by selecting the Customize Video Settings check box.

After publishing a project as an MP4 file, you can do the following:

  • Upload it to the device stores or to YouTube. You can also share the video over social media, such as Twitter and Facebook. See Publish projects as MP4 files for information.

  • Distribute the file to your users as a stand-alone video over email or host it on your web server.

  • Stream or embed the MP4 file using Flash.

Publish video to YouTube

In the full screen mode, click . In the CPVC file, click File > Publish to YouTube.

See Upload projects to YouTube directly from Adobe Captivate for more information.

Publish a specific portion of the video

  1. Drag-and-drop the black start and end markers to define the portion of the video you want to publish.

    You can also specify the Start and End time in the Property Inspector. Click anywhere on stage outside the video to view the Start and End time.

  2. Do one of the following actions:

Insert videos in CPTX files (Cp 6)

Click the Record additional slides icon (), and then click Video Demo in the recording options.

The recording video appears in the Filmstrip with the webcam icon.

Webcam icon with the video slide

To edit the video, click the slide, and then click Edit Video Demo in the Property Inspector. For information on editing videos, see Edit videos.

Click Exit at the upper-left corner to save the changes to the video file and return to the CPTX file.

Insert video demonstrations in CPTX files (Cp 7)

  1. Save your video demonstration as a CPVC file.

  2. Open the CPTX file in which you want to insert the video demonstration.

  3. Click the slide after which you want to insert the video demo, click Insert, and click CPVC Slide.

  4. Browse and select the CPVC file you want to insert.

The Property Inspector displays all the properties of the CPVC file. To edit the video, click Edit Video Demo. The CPVC file is opened for editing. After completing the edits, click Exit to return to the CPTX file.

If you edit the CPVC file by directly opening the file in Adobe Captivate, you can update the video included in all CPTX projects. To do so, right-click the CPVC file name in Adobe Captivate Library (Media > Video), and click Update.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy