問題

Microsoft Office 2003、XP 或 2000 應用程式 (例如 Access、Excel、Word) 遺失PDFMaker 圖示 (「轉換為 Adobe PDF」) 與 Acrobat 功能表。

解決方法

執行下列一或多個解決方法:

解決方法 1: 將 Adobe PDF 從 Microsoft Office 應用程式「停用的項目」清單中移除。

  1. 開啟 Microsoft Office 程式 (Word、Excel、Publisher 或 Excel)。
  2. 前往「說明 > 關於 [程式名稱]」。
  3. 按一下「停用的項目」。
  4. 選取該清單中的 Adobe PDF,然後按一下「啟用」。
  5. 結束 Microsoft Office 程式,然後重新啟動該程式。

注意: 如果該應用程式提前終止 (例如系統未正確關機或應用程式當機),Microsoft Office 應用程式會停用增益集,以進行故障保護。

解決方法 2: 確認已安裝 PDFMaker 元件。

  1. 選擇「開始 > 執行」,在「開啟」文字方塊中鍵入 appwiz.cpl,然後按一下「確定」,開啟「新增或移除程式」對話方塊。
  2. 找到並選取 Adobe Acrobat 7 或 Adobe Acrobat 8,然後按一下「變更/移除」。
  3. 精靈出現時,按一下「下一步」。
  4. 選取「修改」,再按一下「下一步」。
  5. 展開「建立 Adobe PDF」樹狀檢視,然後按一下 Acrobat PDFMaker 物件上的向下鍵。
  6. 選取「此功能將會安裝至本機硬碟」,接著按一下「下一步」,然後按一下「更新」。

解決方法 3: 在 Office 應用程式中啟用 COM 增益集檔案。

  1. 啟動 Office 應用程式。
  2. 選擇「說明 > 關於 [應用程式]」。
  3. 按一下「停用的項目」。
  4. 查看清單中是否有 PDFMakerOfficeAddin:
    • 如果列出該項目,請加以選取,並按一下「啟用」。關閉所有對話方塊,然後重新啟動 Office 應用程式。
    • 如果未列出該項目,請確認 PDFMOfficeAddin.dll 位於 Acrobat 7.0/PDFMaker/Office (Acrobat 7、Acrobat 3D) 或 Acrobat 8.0/PDFMaker/Office (Acrobat 8) 資料夾。如果找不到該檔案,請重新安裝 Acrobat。

解決方法 4: 重新命名 Normal.dot 檔案。

為了避免儲存於通用範本 (Normal.dot) 的調整格式、自動圖文集和巨集,受 Microsoft Word 的行為與其他應用程式影響,請重新命名通用範本 (Normal.dot)。重新命名時,您可以快速判斷是否因該通用範本,而造成此問題。

重要: 重新命名 Normal.dot 範本時,您可以將多個選項重新設定為預設設定,包含自訂樣式、自訂工具列、巨集和自動圖文集項目。因此,Microsoft 強烈建議您不要刪除 Normal.dot 檔案。

特定組態可能會建立多個 Normal.dot 檔案。例如,電腦執行多個 Word 版本,或者相同電腦上安裝多個工作站時,便可能發生此問題。

若要重新命名 Normal.dot 檔案:

注意: 下列步驟針對 Microsoft Word,但略微修改後,也可能適用於其他 Microsoft Office 應用程式。完成下列步驟後,請勿使用「/a」參數重新啟動 Word 或其他應用程式。

在 Windows 2000 上:

  1. 結束所有 Word 執行個體,如果 Word 是您的電子郵件編輯器,也請關閉 Outlook。
  2. 選取「開始 > 搜尋 > 搜尋檔案或資料夾」。
  3. 在「搜尋名稱如下的檔案或資料夾」方塊中,鍵入: Normal.dot
  4. 在「查詢」方塊中,選取本機硬碟。
  5. 按一下「立即搜尋」,搜尋該檔案。
  6. 請針對每個顯示於「搜尋結果」對話方塊中的 Normal.dot 檔案項目,執行下列操作:
    • 以右鍵按一下該檔案,然後選取「重新命名」。
    • 重新命名該檔案 (例如 OldNormal.dot 或 Normal-1.dot),然後按 Enter 鍵。
  7. 按一下「檔案」功能表的「關閉」以結束「搜尋」,然後重新啟動 Word。

在 Windows XP 上:

  1. 結束所有 Word 執行個體,如果 Word 是您的電子郵件編輯器,也請關閉 Outlook。
  2. 選取「開始 > 搜尋」。
  3. 在「您想要搜尋什麼」下,選取「所有檔案和資料夾」。
  4. 在「部分或完整的檔案名稱」文字方塊中,鍵入: Normal.dot
  5. 在「查詢」方塊中,選擇本機硬碟,或者若您從網路伺服器執行 Word,請選擇其他使用者範本位置。
  6. 按一下「搜尋」。
  7. 請針對每個顯示於「搜尋結果」對話方塊中的 Normal.dot 檔案項目,執行下列操作:
    • 以右鍵按一下該檔案,然後選取「重新命名」。
    • 重新命名該檔案 (例如 OldNormal.dot 或 Normal-1.dot),然後按 Enter 鍵。
  8. 按一下「檔案」功能表的「關閉」,然後重新啟動 Word。

如果重新命名通用範本可解決此問題,則問題出自 Normal.dot 範本毀損。

解決方法 5: 變更 Office 應用程式的巨集安全性等級。

若為載入至 Windows 的 COM 增益集檔案,「受信任的發行者」標籤必須列出 Adobe Inc.,或者您必須變更安全性設定。

在 Office 2000、XP 或 2003 應用程式中:

  1. 選擇「工具」功能表的「巨集 > 安全性」。
  2. 按一下「受信任的發行者」標籤:
    1. 若列出 Adobe Inc.,則不需進行變更。

    2. 若未列出 Adobe Inc.,請繼續執行步驟 3。

  3. 選擇下列任一設定:
    • 在「安全性」標籤中,將安全性等級設為「非常高」;在「受信任的發行者」標籤中,選取「信任所有安裝的增益集和範本」。
    • 在「安全性」標籤中,將安全性等級設為「高」;在「受信任的發行者」標籤中,取消選取「信任所有安裝的增益集和範本」。
  4. 關閉所有對話方塊,然後重新啟動該應用程式。

解決方法 6: 將 COM 增益集檔案新增至 Windows 登錄。

  1. 在 Windows 檔案總管中,找到 COM 增益集檔案 (PDFMOfficeAddin.dll),並記下確切的路徑 (其中可能包含空格)。
  2. 選擇「開始 > 執行」。
  3. 鍵入 regsvr32,並加上空格,然後在英文引號中,鍵入您在步驟 1 中記下的路徑。例如:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. 按一下「確定」,然後啟動 Office 應用程式。

解決方法 7: 未執行其他應用程式時,執行「偵測與修復功能」。

  1. 結束所有應用程式,並重新啟動 Windows。
  2. 啟動 Acrobat。
  3. 選擇「說明 > 偵測與修復功能」,然後依照畫面上的指示進行操作。
  4. 修復完成後,請重新啟動電腦。

解決方法 8: 移除 Acrobat,並在簡化模式中重新安裝。

自動載入 Windows 的裝置驅動程式和軟體 (如螢幕保護裝置與防毒公用程式等),可能會與 Acrobat 安裝程式衝突,並造成問題。若要避免衝突,請在 Windows 簡化模式中重新安裝 Acrobat。在簡化模式中,系統會停用非標準裝置驅動程式和啟動軟體。

若要移除 Acrobat:

  1. 移出 Acrobat 應用程式資料夾與子資料夾中的所有個人檔案。
  2. 選擇「開始 > 設定 > 控制台」,然後按兩下「新增或移除程式」。
  3. 選取 Adobe [Acrobat 產品],然後按一下「移除」。依照畫面上的指示移除應用程式。
  4. 重新啟動電腦。

若要在簡化模式重新安裝 Acrobat:

  1. 結束開啟的應用程式。
  2. 在 Windows 檔案總管中,將下列資料夾中所有圖示與捷徑移至其他資料夾:
    • Documents and Settings/All Users/Start Menu/Programs/Startup
    • Documents and Settings/ [使用者設定檔] /Start Menu/Programs/Startup
  3. 重新啟動 Windows。
  4. 在工作列上按一下滑鼠右鍵,然後選擇「工作管理員」。
  5. 按一下「應用程式」標籤。
  6. 選取所有執行中的應用程式,然後按一下「結束工作」。
  7. 按兩下安裝媒體中的 Setup.exe 檔案,並依照畫面上的指示完成安裝。
  8. 完成安裝時,若要重新啟用啟動項目,請將步驟 2 中移動的圖示和捷徑,放回各自的 Startup 資料夾。

解決方法 9: 移除 Word 的巨集。

  1. 選擇「工具 > 範本與增益集」。
  2. 選取各個項目,然後按一下「移除」。
  3. 結束並重新啟動 Word。



    注意:
    如果仍找不到「轉換為 PDF」圖示,請選擇「工具 > 範本與增益集」,確認未顯示已移除的項目。如果顯示已移除的項目,請移除 Word 的巨集,或移除將巨集安裝至 Word 的應用程式。

解決方法 10: 移除 Word 的其他 COM 增益集檔案。

  1. 啟動 Word。
  2. 選擇「工具 > 自訂」。
  3. 按一下「命令」標籤,然後選取「類別」清單中的「工具」。
  4. 選取「COM 增益集」,並拖曳至 Word 的工具列。
  5. 按一下 Word 工具列上的「COM 增益集」功能表。
  6. 選取並移除「網頁精靈」與「Microsoft Word 字型工具」以外的其他增益集。
  7. 結束並重新啟動 Word。

解決方法 11: 修復 Access。(僅限 Access)

如果在安裝 Office XP 或 Office 2003 後安裝 Access 2000,您必須執行「修復」Office,才能顯示 PDFMaker 功能表。

  1. 選擇「開始 > 設定 > 控制台 > 新增/移除程式」(Windows 2000),或「開始 > 控制台 > 新增或移除程式」(Windows XP)。
  2. 選取 Microsoft Office,然後按一下「變更」。
  3. 在「設定」對話方塊中,選擇「重新安裝」(Office 2003) 或「修復」(Office XP),然後按一下「下一步」。
  4. 選擇「偵測並修復 Office 中的安裝錯誤」,然後按一下「安裝」。

解決方法 12: 自訂工具列選項。(僅限 Access)

  1. 選取「檢視 > 工具列 > 自訂」。
  2. 選取「工具列」標籤的「公用程式 1」和「功能表列」選項。
  3. 按一下「內容」。
  4. 選取「允許顯示/隱藏」。

解決方法 13: 移除系統中的舊版 PDFMaker 檔案。

  1. 選取「開始 > 搜尋」。
  2. 選取「所有檔案和資料夾」。
  3. 在標示「部分或完整的檔案名稱:」的文字方塊中,鍵入 PDFMaker.*
  4. 按一下「搜尋」。

    注意: 這項搜尋視您系統的速度,可能需要幾分鐘。
  5. 刪除所有為系統檔案的結果 (例如 PDFMaker.DOT 或 PDFMaker.XLA)。您不須刪除已建立且名為 PDFMaker 的文件 (例如 PDFMaker.doc 或 PDFMaker.pdf)。

解決方法 14: 移除 Microsoft Works。

Adobe 已證實 Microsoft Works 與 Microsoft Word 衝突,且讓「轉換為 Adobe PDF」功能表無法在 Word 中顯示。許多電腦會預先安裝 Microsoft Works。

若要移除 Microsoft Works:

  1. 選擇「開始 > 執行」,在「開啟」文字方塊中鍵入 appwiz.cpl,然後按一下「確定」,開啟「新增或移除程式」對話方塊。
  2. 找到並選取 Microsoft Works,然後按一下「變更/移除」。
  3. 精靈出現時,按一下「下一步」。
  4. 選取「移除」,接著按一下「下一步」,然後依照後續畫面上的提示進行操作。

其他資訊

Acrobat 7.0 至 8.0 會將 COM 增益集檔案安裝至 Acrobat 7.0/PDFMaker/Office 或 Acrobat 8.0/PDFMaker/Office 資料夾。此檔案具備適用於 Word、Excel、PowerPoint、Access、Publisher 和 Project 的 PDFMaker 圖示與功能表命令。必須在應用程式顯示此 COM 增益集檔案前,將其簽入至 Windows 登錄。

Office 應用程式當機,以及停用此 COM 增益集檔案時,PDFMaker 圖示不會顯示在工具列中。

其他 COM 增益集檔案和巨集可能會與 PDFMaker 的 COM 增益集檔案衝突,並使「轉換為 PDF」圖示無法顯示在工具列中。

在 Access 中,如果未啟用「公用程式 1 工具列」以進行檢視,則不會顯示 PDFMaker 圖示。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策