Creative_Cloud_mnemonic_RGB_128px

The 2015 release of Photoshop CC is now available!

For more information, see the New Features Summary.


The 2013 releases of Adobe Photoshop CC rolled out several new features and enhancements to enrich your digital imaging experience. Read on for a quick introduction to features and links to resources offering more information about these releases.

Note: If you're upgrading from Photoshop CS5, see What's New in Photoshop CS6 for an overview of new features in Photoshop CS6 and Photoshop 13.1 for Adobe Creative Cloud.

Photoshop CC | January 2014

Perspective Warp

New in Photoshop CC | January 2014

Photoshop lets you easily adjust perspective in images. This feature is particularly useful for images having straight lines and flat surfaces—for example, architectural images and images of buildings. You can also use this feature to composite objects having different perspectives in a single image.

For more information, see Perspective Warp.

Photoshop Perspective warp
A. Define planes in the Layout mode B. Adjust perspective in the Warp mode 

Print 3D objects

New in Photoshop CC | January 2014

With Photoshop, you can print any compatible 3D model without worrying about 3D printer limitations. In preparation for printing, Photoshop automatically makes 3D models watertight. Photoshop also generates the necessary support structures—scaffolding and rafts—to ensure that your 3D prints are successful.

For details, see Print 3D objects.

Photoshop Printing a 3D model
Printing a 3D model

A. 3D model B. Print plate C. Printer volume overlay 

3D imaging

Enhanced in Photoshop CC | January 2014

  • You can now share 3D layers using Sketchfab, a Web service to publish and display interactive 3D models. In Photoshop, select 3D > Share 3D Layer On Sketchfab.
  • You can now regenerate UV maps for objects and materials in the selected 3D layer. This option is particularly useful for reparameterizing 3D objects downloaded from the Internet. In Photoshop, select 3D > Regenerate UVs.
  • You can now easily group all objects in a scene. In Photoshop, select 3D > Group All Objects In Scene.
  • You can now apply a cross section to a 3D model. For details, see this FAQ.
  • The 3D menu now features a handy option to unify all elements of a 3D scene and make the scene watertight. Select 3D > Unify Scene For 3D Printing.

Linked Smart Objects

New in Photoshop CC | January 2014

You can now create linked smart objects whose contents are referenced from external image files. The contents of a linked smart object are updated when its source image file changes. With linked smart objects, you can use a shared source file across multiple Photoshop documents. Linked smart objects are particularly useful for teams or in cases where assets must be reused across designs.

Linked smart objects are displayed in the Layers panel with a link icon ().

For more information, see Create linked smart objects.

Photoshop Linked Smart Object in Layers panel
A linked smart object in the Layers panel

Adobe Camera Raw

Enhanced in Photoshop CC | January 2014

Adobe Camera Raw now offers the following enhancements:

  • Automatic straightening of an image through one of the following three interactions:
    • Double-click the Straighten tool () in the toolbar.
    • With the Straighten tool selected, double-click anywhere in the preview image.
    • With the Crop tool selected, press the Command key (Mac OS) or Ctrl key (Windows) to temporarily switch to the Straighten tool. Now, double-click anywhere within the preview image.
  • Whites and Blacks now support Auto Levels-like functionality when you double-click the sliders while keeping the Shift key pressed (Shift-double-click).
  • Auto Temperature and Auto Tint functionality. Shift-double-click within the image preview to invoke this functionality.
  • Option to choose a background color for the work area and toggle the visibility of the hairline frame around the image. Right-click outside the image in the work area and select an option from the pop-up menu.
  • Option-click shortcut support for the Synchronize, New Preset, Save Settings, and Copy/Paste (Bridge) dialog boxes. When you option-click a checkbox, it is selected exclusively. You can Option-click again to toggle to the previous checkbox state.

See What's new in ACR 8.x.

Other enhancements

  • Improved font transformations
  • Stability improvements to the Photoshop Generator feature
  • Improved selection of shapes using the Direct Selection tool ()
  • A single click on the Lock icon () now unlocks a background layer
  • You can now set a custom background color in the New Document dialog
  • Better negative number support while making curve adjustments
  • You can now see recent colors in the Swatches panel
  • Clear All option for the Color Sampler tool
  • 10 color samplers instead of 4. You can now change all color samplers in the Info palette at the same time 
  • The Missing Fonts dialog has a Do Not Show Again option now
  • Share On Behance is now available for more languages
  • Improved history states for editing text, and editing and applying character/paragraph styles
  • Mercury Graphics Engine performance boost (Smart Sharpen on GPU)
  • Enhanced scripted patterns and fills (trees, previews, and other improvements)
  • Photoshop Generator can now export padding in image assets using layer masks
  • Layer names can now be as long as 255 characters
  • Narrow Options Bar for small displays 
  • Bug fix: Photoshop Generator now rescales Adobe Illustrator Smart Objects exported after scaling up

Video | Scripted patterns and fills

Video | Scripted patterns and fills
Scripted Patterns and Fills provide an array of creative options for generating custom backdrops, amazing picture frames, and even generating life-like trees.
Andy Anderson

Video | Photoshop 14.2 JDI features

Video | Photoshop 14.2 JDI features
JDI features are series of small improvements made by Adobe at the request of its users. This video covers the major JDI enhancements with this update to Photoshop CC.
Andy Anderson

Photoshop CC | September 2013

Generate image assets from layers

New in Photoshop CC | September 2013

You can generate JPEG, PNG, or GIF image assets from the contents of a layer or layer group in a PSD file. Assets are automatically generated when you append a supported image format extension to a layer name or a layer group name. Optionally, you can also specify quality and size parameters for the generated image assets.

Generating image assets from a PSD file is particularly useful for multidevice web design.

For more information, see Generate image assets from layers.

Photoshop Image assets generated from layers
Image assets generated from layers/layer groups

Camera shake reduction improvements

Enhanced in Photoshop CC | September 2013

  • User interface enhancements for productivity gains
  • Option to disable artifact suppression
  • HiDPI preview support for retina display
  • Improved performance on large screens

For more information, see Reduce camera shake blurring.

Photoshop Camera shake reduction UI improvements
Camera shake reduction UI improvements

Other enhancements

  • Increased stability while saving files to network locations
  • Photoshop-Behance integration is now available for several languages. See Share your work on Behance.
  • Native read-only PSDX file format support
  • New controls to modify the range and fuzziness for Shadows, Highlights, and Midtones
  • Improved performance and stability while using content-aware features
  • Increased limit for number of measurements: 700 to 10,000
  • Improved anchor point selection: Clicking a selected anchor point now selects that anchor point and deselects other anchor points
  • 32-bit support for 24 filters. See Filter effects reference.
  • Crash prevention through improved GPU detection and disabling
  • New option to select All Layers/Active Layers for Path and Direct Selection tools
  • Isolation mode changes:
    • Custom keyboard shortcut support for entering/exiting the Isolation mode
    • Option to enter the Isolation mode by double-clicking is now unavailable in the Active Layers mode
    • Instead of turning filtering off, exiting the Isolation mode now resets the Layer Filter to default values
  • New option in the Properties panel flyout menu to control the display of the panel during shape layer creation
  • Path point selection is now no longer retained while switching between layers

Photoshop CC | June 2013

Video | Photoshop CC Overview

Video | Photoshop CC Overview
Photoshop Product Manager, Zorana Gee, provides a quick overview of some exciting new features in Photoshop CC...
Zorana Gee

Reduce camera shake blurring

New in Photoshop CC

Photoshop features an intelligent mechanism to automatically reduce image blurring caused by camera motion. If necessary, you can adjust advanced settings to further sharpen the image. The camera shake reduction feature can reduce blurring resulting from several types of camera motion, including linear motion, arc-shaped motion, rotational motion, and zigzag motion. 

Photoshop Reduce camera shake
Camera shake reduction | A before/after example

Images suitable for camera shake reduction

The camera shake reduction feature works best with decently lit still camera images having low noise. The following types of still images are particularly suitable for shake reduction:

  • Indoor or outdoor images captured using a lens with a long focal length
  • Indoor images of a static scene taken with a slow shutter speed and no flash

In addition, shake reduction can help sharpen blurred text in images affected by camera motion.

For more information, see Reduce camera shake blurring.

Image resizing improvements

Enhanced in Photoshop CC

The Image Size command now includes a method to Preserve Details and provide better sharpness while enlarging images. In addition, the Image Size dialog box has been updated for ease of use:

  • A window displays the preview image from the resizing parameters. Resizing the dialog box resizes the preview window.
  • The Scale Styles option is turned on and off from inside the gear menu in the upper-right corner of the dialog box.
  • From the Dimensions pop-up menu, choose different units of measurement to display the dimensions of the final output.
  • Click the link icon to toggle the constrain proportions option on and off.
  • The resample menu options are arranged by usage, including the new edge-preserving method.

For more information, see Resizing images.

Photoshop Original uncropped photo
Original uncropped image

Photoshop Sharp resized photo
Sharp resized image with details preservation

Share your work on Behance

New in Photoshop CC

Photoshop Share your work in Behance

You can upload your creative images as work-in-progress to Behance directly from within Photoshop. Behance is the leading online platform to showcase and discover creative work. Using Behance, you can create a portfolio of your work and broadcast it widely and efficiently to get feedback. You can upload fresh images as well as revisions of images you've uploaded earlier.

Note:

Behance integration with Photoshop CC is not available in France and Japan for now.

Photoshop Uploading revisions to Behance
Uploading revisions to Behance

 

Share your work from within Photoshop in one of the following ways:

  • With a document open, select File > Share On Behance.
  • With a document open, click the Share On Behance button () in the lower-left corner of the document window.

You can either start a new Behance portfolio using your Adobe ID or link your existing Behance account with your Adobe ID.

For more information about Photoshop-Behance integration, see Share your work on Behance. For more information about using Behance, see this FAQ.

Note:

You must be 13 years of age or older to sign up for Behance.

Note:

You can share images of dimensions 320 x 320 pixel or higher.

Sync settings using Adobe Creative Cloud

New in Photoshop CC

When you work on multiple computers, managing and syncing preferences across the computers can be time-consuming, complex, and prone to error.

The new Sync Settings feature enables you to sync preferences and settings via Creative Cloud. If you use two computers, the Sync Settings feature makes it easy for you to keep those settings synchronized across the two computers. The syncing happens via your Adobe Creative Cloud account. Settings are uploaded to your Creative Cloud account and are then downloaded and applied on the other computer.

Choose Edit > Sync Settings and then select the relevant options. For more information, see Sync settings using Adobe Creative Cloud.

3D imaging

Enhanced in Photoshop CC

Note:

Also see 3D features | Creative Cloud-only for Creative Cloud-only features added to Photoshop CS6. These features are also available in Photoshop CC.

Video | Photoshop CC 3D features

Video | Photoshop CC 3D features
3D features in Photoshop CC
Zorana Gee

3D painting

Photoshop CC features several enhancements that let you paint 3D models with finer control and greater accuracy. When you paint in the default Live 3D Painting mode, you can see your brush strokes update in real time in both the 3D model view and the texture view. The Live 3D Painting mode also offers significant performance gains and minimizes distortion.

Projection Painting, the default 3D painting method in Photoshop CS5 and CS6, remains available in Photoshop CC. You can switch to this 3D painting method by selecting 3D > Use Projection Painting.

Besides Live 3D Painting, Photoshop CC features the following enhancements to 3D painting functionality:

  • When you target different texture types for painting, you can see the paint target in both the 3D model and the target texture view.
  • You can choose to paint your 3D objects in the unlit mode. This mode ignores any lighting in your scene and wraps raw texture data of the appropriate type around your 3D objects. Painting in the unlit mode lets you paint without shading and with greater color accuracy.

Available 3D painting methods

Different painting methods are appropriate for different use cases. Photoshop CC provides the following 3D painting methods:

Live 3D Painting: (Default in Photoshop CC) Brush strokes made in the 3D model view or the texture view are reflected in real time in the other view. This 3D painting method offers high performance and minimum distortion.

Layer Projection Painting: (Enhanced in Photoshop CC) The Gradient tool and filters use this painting method. The Layer Projection Painting method involves merging a painted layer with the underlying 3D layer. During the merge operation, Photoshop automatically projects the paint onto the appropriate target textures.

Projection Painting: (Only method in Photoshop CS6) Projection Painting is suitable for painting multiple textures simultaneously or for painting the seam between two textures. However, in general, it is a lower-performance painting method and may result in cracks when you’re painting complex 3D objects.

Texture Painting: You can open the 2D texture and paint it directly.

For more information, see 3D painting.

Photoshop Live 3D painting
Live 3D painting in Photoshop

3D panel

Photoshop CC features a revamped 3D panel that makes it easier for you to work with 3D objects. Modeled after the Layers panel, the redesigned 3D panel is structured as a scene graph/tree having root objects and child objects.

You can interact with 3D objects in the scene graph in several ways:

  • Delete objects
  • Reorder objects
  • Reverse object order
  • Insert objects
  • Duplicate objects
  • Make instances of objects (linked instances or decoupled instances)
  • Group objects

You can access these interactions from the context menu associated with a 3D object. Right-click an object to access its context menu on Windows. To access the context menu on Mac OS, Control-click the object.

Some interactions are not available for certain types of 3D objects.

For more information, see 3D panel enhancements in Photoshop CC.

Photoshop Linked instance
Linked instance: Changes made to the object reflect on the instance

Photoshop Instance decoupled from original
Instance decoupled from the original object

Filters

Enhanced in Photoshop CC

Smart Sharpen filter enhancements

The enhanced Smart Sharpen filter empowers you to produce high-quality results through adaptive sharpening technology that minimizes noise and halo effects.

The streamlined UI design for this filter offers optimized controls for targeted sharpening. Use the sliders for quick adjustments and advanced controls to fine-tune your results.

For more information, see Filter effects reference and Adjusting image sharpness and blur.

Photoshop Smart Sharpen dialog box
Smart Sharpen dialog box

Minimum and Maximum filter enhancements

The Maximum and Minimum filters have been updated. You can now choose from the Preserve menu to favor squareness or roundness as you specify the radius value. Radius values can now be entered as decimals.

For more information, see Filter effects reference.

Photoshop Preserve squareness or roundness
Preserve squareness or roundness

Adobe Camera Raw as a filter

New in Photoshop CC

In Photoshop CC, Adobe Camera Raw is available as a filter as well. When you process an image in Photoshop, you can choose to apply the Camera Raw Filter (Filter > Camera Raw Filter) on images that are already open in Photoshop. This means that you can apply Camera Raw adjustments to more file types like PNG, video clips, TIFF, JPEG, and more. The images processed with the Camera Raw Filter can be on any layer.

Photoshop Camera Raw filter
Camera Raw Filter (Shift+Ctrl/Cmd+A) in Photoshop

For more information, see this video on using Camera Raw as a filter in Photoshop.

Adobe Camera Raw

For information on the recent improvements in Camera Raw, see the video overview of Adobe Camera Raw 8.

JPEG and TIFF file-handling preferences

New in Photoshop CC

New preferences are available to determine how Photoshop handles JPEG and TIFF files. These settings are particularly useful if your workflows include the use of Camera Raw each time you process an image, or would like to call Camera Raw selectively. For example, a photographer may want to process each image with the Camera Raw dialog before opening it in Photoshop. However, a retoucher or a compositor may want to open the Camera Raw dialog only for images that have previously been processed using Camera Raw.

To modify the preferences in Photoshop, click Preferences > File Handling > File Compatibility section > Camera Raw Preferences > JPEG and TIFF Handling section. You can choose if opening a JPEG or TIFF automatically calls the Camera Raw dialog or not. For example, choose from the JPEG dropdown:

  • Disable JPEG support. When you open a JPEG file in Photoshop, the Camera Raw dialog does not open.
  • Automatically open JPEGs with settings. When you open a JPEG file in Photoshop, the Camera Raw dialog is opened only if the JPEG file has previously been processed using Adobe Camera Raw
  • Automatically open all supported JPEGs. The Camera Raw dialog is opened each time you open a JPEG file.

Use the TIFF dropdown to make a similar choice for TIFF files.

Spot Removal tool

Enhanced in Photoshop CC

The new behavior of the Spot Removal tool (Camera Raw dialog > Spot Removal tool, or keyboard shortcut B) is similar to the Healing Brush in Photoshop. Use the Spot Removal tool to paint over an element in your photo, select a source area that could be used on your selected area, and the tool does the rest for you. You can press the forward slash (/) key to let Camera Raw pick the source area for you.

Photoshop Removing zip line
A zip-line that needs to be cleaned up (left), is identified, selected, and matched with a source area (center), and then removed (right)

While the Spot Removal tool enables you to remove visible imperfections, some flaws in the photo may not be visible in the normal view (for example, sensor dust, or spots or blemishes on a portrait). The Visualize Spots option in the Spot Removal tool enables you to see smaller and less-visible imperfections. When you select the Visualize Spots checkbox, the image appears inverted. You can vary the contrast levels of the inverted image to see imperfections more clearly. You can then use the Spot Removal tool in this view to remove any imperfections.

For more information, see the article on the enhanced Spot Removal tool in Photoshop CC.

Radial Filter

New in Photoshop CC

The new Radial Filter tool (Camera Raw dialog > Radial Filter tool, or keyboard shortcut J) enables you to define elliptical marquees, and then apply localized corrections to these areas. The corrections can be applied within or outside the marquee areas. You can place multiple Radial Filters on an image, and apply a different set of adjustments to each Radial Filter.

Photoshop Subject focused with Radial Filter
The image as shot (left), and the subject brought into focus using a vignette-like effect using Radial Filters (right)

 

For example, a vignette-like effect has been simulated in the image above. Two overlapping Radial Filter areas were defined over the face of the subject, one slightly larger than the other. Using the larger Radial Filter area, adjustments were made to subdue the regions behind the face. The second, smaller Radial filter area was adjusted to brighten and highlight the face.

For more information, see the article on the Radial Filter tool.

Upright modes

New in Photoshop CC

The Upright feature (Camera Raw dialog > Lens Correction > Manual tab) in Camera Raw enables you to automatically straighten image content. The Upright mode automatically corrects the perspective of the elements in a photograph. The feature has four settings that you can choose from:

  • Auto: Balanced perspective corrections
  • Level: Perspective corrections are weighted toward horizontal details
  • Vertical: Perspective corrections are weighted toward vertical details
  • Full: Combination of Level, Vertical, and Auto perspective corrections

You can apply one setting, cycle through the others, and then choose the setting that is best for your photograph.

Photoshop Upright feature
Sample image before applying perspective correction (left) and after using the Auto setting in the Upright feature (right)

Also, an Aspect slider has been added to the existing set. The Aspect slider lets you modify the aspect of the image horizontally or vertically. Sliding the control left modifies the horizontal aspect, and sliding it right modifies the vertical aspect of the photo.

For more information, see the article on Automatic perspective correction in Camera Raw.

Multiple selection of paths

Enhanced in Photoshop CC

New enhancements in Photoshop CC let you work with multiple paths. You can apply commands to multiple paths from the Paths panel menu. Specifically users will be happy to hear they can select more than one path and delete them all at once.

You can now perform the following actions:

  • Shift-click to select multiple paths in the Paths panel.
  • Ctrl-click (Windows) or Command-click (Mac OS) to select non-contiguous paths.
  • Drag either the Path Selection tool and the Direct Selection tool over multiple paths to manipulate them, even if the paths are on different layers.
  • Alt-drag (Windows) or Option-drag (Mac OS) a path in the Paths panel duplicates it.
  • Reorder a path by dragging in the Paths panel. You can only reorder paths that are not shape, type, or vector mask paths.
  • Delete multiple selected paths at once.

For more information, see Editing paths.

Modify rectangles and rounded rectangles

Enhanced in Photoshop CC

You can adjust dimensions, placement, and the corner radii of a rectangle or rounded rectangle shape after it has been created. Each corner can be adjusted independently and adjustments can be simultaneously made to rectangles on multiple layers.

For more information, see Modify shapes.

Video | Design improvements in Photoshop CC

Video | Design improvements in Photoshop CC
Rafael Concepcion goes over several design improvements in Photoshop CC, including multiple path selection, rounded corner editing for shapes, and Behance integration...
Rafael Concepcion

Support for Indic languages

New in Photoshop CC

You can now type text in 10 Indic languages into your Photoshop documents: Bengali, Gujarati, Hindi, Kannada, Malayalam, Marathi, Oriya, Punjabi, Tamil, and Telugu.

To enable Indic language support, select Preferences > Type > Middle Eastern And South Asian. Changes take effect for the next document you create.

When you enable Indic support, two additional composers are enabled in the flyout menu of the Paragraph panel:

• Single-line Composer
• Every-line Composer

Note:

You can enable either Middle Eastern And South Asian support or East Asian support in a document.

System anti-aliasing option for type

Enhanced in Photoshop CC

The new system anti-aliasing option for type gives you a realistic preview of how your type will appear on the web. This new option closely matches the anti-aliasing options in popular browsers for both Windows and Mac-based rendering.

Other enhancements

  • Significantly improved performance for the Blur Gallery. The Blur Gallery now uses OpenCL for previews as well as the final result.
  • Several enhancements to the preset migration functionality:
    • Presets are now migrated from the user library folder as well as the application presets folder.
    • Active presets are now migrated along with non-loaded presets.
    • Only presets for the immediate past version are migrated. For example, CS6 presets are migrated while CS5 presets are ignored from a migration standpoint.
    • A system restart is not required after migrating presets.
  • Changes to Windows Open/Save dialog boxes:
    • Changes to the ordering and placement of some controls.
    • The Use Lower Case option has been removed. You can change file extension upper/lower case setting in the Preferences dialog box.
    • Warning icons and the warning text info box have been replaced with the Warning button appearing next to the Save and Cancel buttons. When you click this Warning button, Photoshop displays a message capturing the reason for the warning. If a document has no warnings, the Warning button is hidden.
Photoshop Warning button
The Warning button

  • An angle control widget for brushes is now available from the options bar as well as the context menu.
  • The View Print Size option has been restored.
  • The gamma value for text is now automatically set for new system options.
  • Improved performance when you save your work to network shares on Mac OS X
  • Metadata and ICC profiles are now included when you save a document as PNG.
  • You can now export CSS (Cascading Style Sheet) code directly from layers or groups. Select Layer > Copy CSS.
  • Copy CSS improvements:
    • Copy CSS units are now always pixel (px)
    • Copy CSS transparency now works in gradients
    • Improved placement of transformed text
    • Width is no longer generated for non-paragraph text
  • You can now select and delete multiple type styles
  • You can now use the Shift key modifier while creating paths.

Video | Type rendering in Photoshop CC

Video | Type rendering in Photoshop CC
Photoshop CC includes a new type rendering option for sub pixel text...
Rafael Concepcion


Product-level changes

  • All features in Photoshop Extended CS6 are now available in Photoshop CC. Photoshop CC does not have a separate Extended offering.
  • The following applications are no longer installed by default with Photoshop CC:
    • Bridge CC; to see a list of new features, see What's New in Adobe Bridge CC
    • Extension Manager
    • ExtendScriptToolkit
      Note:
      To download Bridge CC, Extension Manager, or ExtendScriptToolkit; log in to Adobe Creative Cloud, navigate to Apps, and then download the desired application.
  • New system requirements for Photoshop CC:
    • Support for Mac OS X 10.7 (Lion) and 10.8 (Mountain Lion)
    • Mac OS X 10.6 (Snow Leopard) is not officially supported. In particular, you cannot work with video files on Mac OS X 10.6. You can create a timeline with stills and add effects like transitions. However, you can export this work only using the File > Export > Render Video > Photoshop Image Sequence option.
Photoshop Choose Photoshop Image Sequence from menu
  • The Lighting Effects filter (Filter > Render > Lighting Effects) works only with 8-bit RGB images in Photoshop CC.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy