Update to Photoshop CC available!

For more information, see the New Features Summary.


To highlight new features throughout Photoshop menus, choose Window > Workspace > New in CS6.

Adobe Creative Cloud only

If you're a subscriber to Adobe Creative Cloud, the following additional features are available. For new CS6 features that are not Adobe Creative Cloud only, scroll down the page.

Liquify filter enhancements

In the Creative Cloud update for Photoshop, the Liquify filter is significantly faster than previous versions. The Liquify filter now supports Smart Objects, including Smart Object video layers, and is applied as a smart filter.

Another enhancement to the Liquify filter is an added behavior for the Reconstruct tool. If you hold down the Alt (Windows) or Option (Mac OS) key while dragging the tool across a warp, the Reconstruct tool smooths a warp rather than scaling back or removing it.

For more information, see Liquify filter.

Apply Blur gallery effects as smart filters

The photographic blur effects in the Blur gallery now support Smart Objects and can be applied non-destructively as smart filters. This feature also supports Smart Object video layers.

For more information, see Photographic blur gallery CS6, About Smart Filters.

Copy CSS properties from shape or text layers

Copy CSS generates Cascading Style Sheet (CSS) properties from shape or text layers. It captures values for size, position, fill color (including gradients), stroke color, and drop shadow.  For text layers, Copy CSS also captures values for font family, font size, font weight, line height, underline, strikethrough, superscript, subscript, and text alignment. The CSS is copied to the clipboard and can be pasted into a style sheet.

For more information, see Copy CSS from layers and view a video on New CSS Support in Photoshop.

Conditional actions

Conditional actions let you build actions that choose what to do based on one of several different conditions. First, you choose a condition and then, optionally specify an action that plays if the document meets the condition. Then, you optionally specify an action that plays if the document does not meet the condition.

High dpi display support

Photoshop adds support for high dpi displays such as Retina Displays. Among the enhancements for working with higher resolution displays, documents can be quickly viewed at 200%. To view a document at 200%, do any of the following:

  • Choose View > 200%.
  • Ctrl-double click (Windows) or Cmd-double click (Mac OS) the Zoom tool icon.
  • Shift-Ctrl-double click (Windows) or Shift-Cmd-double click (Mac OS) the Zoom tool icon to view all open documents at 200%.

Changes in view options

In the Zoom tool options bar and the Hand tool options bar, the button for viewing an image at its actual size has been renamed as 100%. Additionally, both tool options bars no longer have a Print Size button. Additionally, the Actual Pixels command in the View menu has been changed to 100%.

Crop tool changes and enhancements

Updates to the Crop tool include numerous bug fixes and enhancements, including:

  • Front Image and new presets in the Aspect Ratio menu.
  • Clicking the double-arrow icon changes the crop orientation by swapping the Width and Height values. This replaces the Rotate Crop Box button.
  • Choosing W x H x Resolution from the Aspect Ratio menu displays a Resolution field in the options bar and auto-fills the Width and Height values.
  • Clicking the Clear button clears the values in the Width and Height fields in the option bar. If displayed, the value in the Resolution field is also cleared.
  • The keyboard shortcut for Front Image has changed from F to I for both the Crop tool and the Perspective Crop tool.
Photoshop Crop tool options bar
CS6 Creative Cloud Crop tool options bar

A. Aspect Ratio menu B. Swap Width and Height values C. Overlay Options 

For more information, see Using the new crop tool and Crop and straighten photos.

Default type styles

The character and paragraph styles of a document can be saved as the default type styles. These default styles are automatically loaded in the Character Style and Paragraph Style panels when a new Photoshop document is created. The default styles can also be loaded into any existing document using the Load Type Styles command.

For more information see Specifying default type styles, Character styles, and Paragraph styles. You can also watch a video about Type Styles in Photoshop.

Face detection enhancements in Color Range

The Color Range selections command now saves Skin Tones selections as a preset. It can also save the setting for the Detect Faces option when Skin Tones or Sampled Colors are selected.

For more information, see Saving Skin Tones settings as a preset, Selecting a color range in an image, or watch the video, Selecting Skin Tones in Photoshop CS6, with Photoshop expert Matt Kloskowski.

Read swatches from HTML, CSS, and SVG files

You can add colors specified in an HTML, CSS, or SVG document to the Swatches panel. If a color value is repeated in a document, only one instance of the color is added not duplicates. This feature recognizes the following HTML/CSS color syntax: #112233, #123, rgb(1,2,3), rgba(1,2,3,4), hsb(1,2,3), and hsba(1,2,3,4).

3D enhancements and changes

There are numerous new 3D features and enhancements in the Creative Cloud version of Photoshop CS6. For information about the updates, see 3D workflow and view a video on New Possibilities in 3D.

Support for big JPEGs

Photoshop can now open and save JPEG documents up to 65,535 pixels in width or height.

Resizable Color panel

The Color panel is now resizable.

New features for all Photoshop CS6 users

The following new features are available to all Photoshop CS6 users and are not Adobe Creative Cloud only.

Retouching and transforming

Content-Aware Move tool

The Content-Aware Move tool lets you quickly recompose images without complex layering or slow, precise selections. Extend mode convincingly expands or contracts objects such as hair, trees, or buildings. Move mode lets you place objects in different locations (most effectively when the background remains similar). In the toolbar, hold down the Spot Healing Brush and select the Content-Aware Move tool .

For more information, see Content-Aware Move.

Content-Aware Patch tool

The updated Patch tool includes a Content-Aware option that seamlessly replaces unwanted image elements by synthesizing nearby content. The natural-looking results are similar to Content-Aware Fill, but the Patch tool lets you select the area from which the fill is drawn. In the toolbar, hold down the Spot Healing Brush and select the Patch tool .

For more information, see Content-Aware Patch.

Redesigned Crop tools

The redesigned Crop tool provides an interactive preview so you can better visualize results. A streamlined set of toolbar options includes a helpful Straighten tool, and aspect ratio controls you can adjust while a crop is active in the image window. (To maintain the current aspect ratio or resolution, right-click the image to access additional options.)

  • To crop an image, click the Crop tool in the toolbar. Then either adjust default crop borders in the image window, or drag in the window to start with specific borders.
  • To correct image perspective, hold down the Crop tool and select the Perspective Crop tool 

For more information, see Crop and straighten photos or watch Crop tool video tutorial.


Correcting wide-angle lenses

Choose Filter > Adaptive Wide Angle to quickly straighten lines that appear curved in panoramas or photos shot with fisheye and wide-angle lenses. The filter uses the physical characteristics of individual lenses to automatically correct images.

For more information, see Adaptive Wide-Angle Filter or watch Lens Aware Adjustments video tutorial by RC Concepcion.

Photographic blur gallery

Choose Filter > Field Blur, Iris Blur, or Tilt-Shift to quickly create three distinct photographic blur effects with intuitive on-image controls. Use the Blur Effects controls to add Bokeh effects to the images.

For more information, see Blur gallery.

Lighting Effects gallery

Get better performance and results with the new, 64-bit Lighting Effects gallery. A dedicated workspace provides on-canvas controls and previews that make it easier to visualize your lighting enhancements.

For more information, see Add lighting effects.

Oil Paint filter

Choose Filter > Oil Paint to easily create the look of a classic painting.

For more information, see Oil Paint filter.


The redesigned, clip-based Timeline panel includes transitions and effects that give finished videos professional polish. Easily change clip duration and speed, and apply motion effects to text, still images, and Smart Objects.

Video Groups combine multiple video clips and content such as text, images, and shapes on a single Timeline track. Separate audio tracks allow for easy editing and adjusting.

The redesigned video engine also supports a wider range of import formats. When you're ready to export final video, Photoshop provides helpful presets and options for the DPX, H.264, and QuickTime formats.

Note: In Windows, you install QuickTime separately.

For detailed instructions, see Video editing. For a quick video overview, watch Intuitive video workflow by RC Concepcion.

Color and tonal adjustments

Skin tone selection and face detection

Choose Select > Color Range. Then, from the Select pop-up menu in the Color Range dialog box, choose Skin Tones to isolate those tones. For more accurate skin tone selection, select Detect Faces and then, adjust Fuzziness to specify how low or high the range of colors will be in the selection.

Watch Color range changes in CS6 for a video overview. For more information, see Select a Color Range.

Improved auto corrections

Perfectly enhance your images in a single step with improved Auto options for the LevelsCurves, and Brightness/Contrast adjustments.


To customize Auto corrections, Alt-click (Windows) or Option-click (Mac OS) the Auto button. For details about each setting, see Set Auto adjustment options. For a video overview, see Auto Corrections.

3D (Photoshop Extended only)

Intuitively create 3D artwork with a simplified interface that offers on-canvas scene editing. Easily drag shadows into place, animate 3D objects, give 3D objects the look of sketches or cartoons, and more.

For detailed instructions, see 3D workflow.


Photoshop CS6 lets you record tools such as the brush tool in your action. To enable this feature, choose Allow Tool Recording from the Actions panel menu.

For more information, see Recording tools in actions.

Painting and patterns

Erodible brush tips

Erodible pencils and pastels wear down naturally with use. Customize Brush Tip Shape options: Softness controls the rate of wear, Shape provides settings from flat to round, and Sharpen Tip returns to original crispness. As you paint, watch the amount of wear with the Live Brush Tip Preview to the upper left of the image.

Choose Window > Brush Presets to quickly access new erodible tips, or Window > Brush to customize them. For more information, see Erodible tip options.

Airbrush tips

Airbrush tips replicate spray cans with a 3D conical spray. Customize Brush Tip Shape options like GranularitySpatterHardness, and Distortion controls. With a stylus, alter the spread of sprayed strokes by changing pen pressure.

Choose Window > Brush Presets to quickly access new airbrush tips, or Window > Brush to customize them. For more information see, Airbrush tip options.

Brush pose

Specify the stylus tilt, rotation, and pressure. Choose Window > Brush, and select Brush Pose to paint with a specified tilt, rotation, and pressure. Use a stylus to change the stroke relative to the default pose, or select Override options to maintain a static pose. For more information, see Brush pose options.

Brush projection

Use Brush Projection to apply stylus tilt and rotation to tip shapes. Choose Window > Brush, and select Shape Dynamics from the list at left. At the bottom of the options at right, select Brush Projection. As you paint with a stylus, changes to tilt and rotation alter the tip shape. See Brush shape dynamics options.

Brush color dynamics

Color Dynamics remain consistent for each stroke by default. Color Dynamics settings automatically vary color as you paint. In previous versions of Photoshop, dynamics settings changed color for each distinct tip stamp in a stroke. In Photoshop CS6, however, dynamic changes occur once at the beginning of each stroke. This feature lets you vary color between strokes, rather than within each individual stroke.


To revert to the behavior of previous versions, choose Window > Brush, and select Color Dynamics from the list at left. At the top of the options at right, select Apply Per Tip. See Color Dynamics brush options.


Scripted patterns

Select Edit > Fill, choose Pattern from the Use menu, and then select Scripted Patterns to choose from several geometric options. Build sophisticated designs by combining these scripts with Custom Pattern presets and blending modes.


Vector layers

The Line and Shape tools now create fully vector-based objects. Apply strokes and fills using the options bar. Stroke objects with dashed lines and other designs. Fill objects with preset or user-defined gradients, colors, and patterns.

To later revise stroke and fill settings, simply select the object layer, and then select the Path Selection or Direct Selection tool.

Learn More: Vector based shape layers video.

Intuitive path editing  By default, dragging with the Direct Selection tool adjusts multiple related segments, letting you quickly transform path shapes. To edit only segments between selected anchor points, reflecting previous Photoshop versions, select Constrain Path Dragging in the options bar.


To reduce anti-aliased edges, ensuring that vector objects look as sharp as possible, select Align Edges in the options bar.

Workspace and workflow

Numerous enhancements help you complete common tasks more efficiently.

Mercury Graphics Engine

Experience blazing-fast interactions with processor-intensive commands such as LiquifyWarpPuppet Warp, and Crop.

Fresh new look


Work with a fresh, elegant interface with design enhancements like the following:



  • Select from four different brightness levels: Choose Edit > Preferences (Windows) or Photoshop > Preferences (Mac OS). In the Interface section, select a Color Theme swatch.

Note: To quickly decrease interface brightness, press Shift+F1. To increase brightness, press Shift+F2. (Mac laptop users must also press the FN key.)

  • On-image displays keep you informed as you use your favorite tools, showing dimensions for selections, angles for transformations, and more. To adjust the placement of these values, in the Interface preferences, choose an option from the Show Transformation Values menu.
  • A new Mini Bridge gallery offers easier access to images and documents. Choose Window > Extensions > Mini Bridge.
  • To maximize screen space, functions formerly in the application bar have moved elsewhere. To switch between Standard and Full Screen display modes, click the button at the bottom of the toolbar.


Layers enhancements 

At the top of the Layers panel, new filtering options help you find key layers in complex documents quickly. Display subsets of layers based on name, kind, effect, mode, attribute, or color label. You can use the Properties panel to quickly modify the layer components selected in the Layers panel.

Migrate and share Presets

Choose Edit > Presets > Migrate to easily move presets, workspaces, preferences, and settings from Photoshop CS3 and later to Photoshop CS6. Choose Edit > Presets > Export/Import Presets to share a custom setup across all computers in a workgroup.

For more information, see Migrate presets from earlier versions of Photoshop.

Background save

Background saving lets you keep working after you choose Save commands, instead of waiting for saving to complete.

Note: If you regularly save large files and want the most consistent performance from Photoshop, disable Save In Background in the File Handling preferences.

Auto recover

Auto-recover stores crash-recovery information at specified intervals. The default is ten minutes. In case the application crashes, your work is recovered the next time you start the application.

To customize the time intervals between auto-recovery storage, choose Edit > Preferences > File Handling (Windows) or Photoshop > Preferences > File Handling (Mac OS).
Select Save In Background, and then select an interval from the Automatically Save Recovery Information menu.


Paragraph and character styles

In the Window > Paragraph Styles panel, create, store, and reapply the characteristics of groups of highlighted sentences. In the Window > Character Styles panel, specify the look of selected letters, words, or phrases.

For more information, see Paragraph styles and Character styles.

For a video overview, see Paragraph and Character Styles in Photoshop CS6 by Julieanne Kost.

Type menu

A new Type menu has been added, and most of the text and type related functionality is available from the Type menu. For example, you can access the Character and Paragraph panels from the Type > Panels menu.

Compatibility with Adobe Touch and Photoshop companion apps

Extend your creativity beyond Photoshop CS6 with Adobe Touch and Photoshop companion apps (sold separately). Design, edit, and elegantly present your work using six Adobe Touch apps designed for your tablet, including Photoshop Touch, Adobe Kuler, and Adobe Debut. Transfer files through Adobe Creative Cloud for further refinement in Photoshop CS6—or to view, access, and share from almost anywhere. Or, interact directly with Photoshop CS6 wirelessly with Photoshop companion apps from Adobe and the developer community.

Camera Raw 7

Simplified Basic controls in the Develop tab improve highlight and shadow rendering. New local corrections are available for white balance, highlights, shadows, noise reduction, and moiré.

The new Basic sliders and new local adjustments options appear when you process new images or convert previously processed images to Process Version 2012 (PV2012). To convert an image, click the exclamation-point icon in the lower-right corner of the image preview area.

For more information, see Make color and tonal adjustments in Camera Raw and Make local adjustments in Camera Raw.

For a video overview, see this tutorial from Iceflow Studios.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy