Примечание.

Полный список статей о безопасности см. в разделе Обзор функций безопасности в приложении Acrobat DC и файлах PDF.

Зачем исправлять или удалять конфиденциальное содержимое?

Перед рассылкой документа PDF вы можете проверить его на наличие конфиденциального содержимого или личной информации, по которой можно отследить отправителя. Используйте инструменты Исправить, чтобы удалить или исправить конфиденциальные изображения и текст, которые отображаются в PDF.

Для поиска и удаления скрытого содержимого в документах в формате PDF используйте функцию Удалить скрытую информацию. Например, при создании документа PDF в метаданных обычно указывается имя автора. Кроме того, иногда нужно бывает удалить содержимое, случайное изменение которого может привести к изменению внешнего вида документа. К изменяемым типам содержимого относятся сценарии JavaScript, действия и поля форм.

Исправление конфиденциального содержимого (Acrobat Pro DC)

Исправлением здесь называется процесс необратимого удаления видимого текста и графики из документа. Для удаления содержимого используйте инструменты Исправить. Вместо удаленных элементов можно подставлять метки исправления, отображаемые в виде цветных прямоугольников, либо оставлять соответствующие области пустыми. Над метками исправления можно настроить отображение пользовательского текста или кодов исправления.

Примечание.

Если необходимо найти и удалить конкретные слова, символы или фразы, используйте инструмент Найти текст.

Редактирование конфиденциального содержимого
Текст, помеченный для исправления (слева), и исправленный (справа).

  1. Выберите Инструменты Исправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов выберите Пометить для исправления > Текст и изображения.

  3. (Необязательно) Чтобы задать оформление меток исправления, нажмите Свойства на дополнительной панели инструментов.  (См. Изменение вида знаков исправлений.)

  4. Отметьте элементы для удаления. Для этого выполните одно из следующих действий:
    • Двойным щелчком выберите нужное слово или изображение.
    • Перетащите указатель, чтобы выбрать линию, блок текста, объект или область.
    • Нажмите «Ctrl» при перетаскивании, чтобы выбрать области страницы в сканированном документе.

    Примечание.

    Для отображения меток исправления удерживайте указатель над помеченной областью.

  5. Чтобы применить несколько записей кода к одному исправлению, щелкните метку исправления правой кнопкой мыши и выберите нужный параметр. Дополнительные сведения см. в разделе Применение нескольких записей кода к исправлению.

  6. (Необязательно) Чтобы повторить метку исправления, щелкните ее правой кнопкой мыши и выберите Повторять пометку на страницах. Этот параметр удобно использовать, если верхний/нижний колонтитул или водяной знак размещается на одном и том же месте на разных страницах.

  7. Завершив пометку элементов, которые требуется исправить, нажмите кнопку Применить на дополнительной панели инструментов, чтобы удалить эти элементы, затем нажмите кнопку OK.

    Элементы не будут окончательно удалены из документа, пока вы не сохраните его.

  8. Если необходимо найти и удалить из документа скрытую информацию, используя функцию «Удалить скрытую информацию», нажмите «Да» в диалоговом окне. В противном случае нажмите Нет.

  9. Выберите Файл > Сохранить, затем укажите имя файла и расположение. Суффикс «_Redacted» добавляется к имени файла. Если вы не хотите, чтобы оригинальный файл был перезаписан, сохраните новый файл с другим именем или в другом месте либо сделайте и то, и другое одновременно.

Поиск и удаление текста (Acrobat Pro DC)

С помощью инструмента Найти текст можно находить и удалять слова или фразы в одном или нескольких документах PDF, содержащих текст с возможностью поиска.

Примечание.

С помощью инструмента «Найти текст» нельзя выполнять поиск в защищенных (зашифрованных) файлах PDF.

  1. Выберите ИнструментыИсправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов выберите Пометить для исправления > Найти текст.

  3. В диалоговом окне Поиск укажите, нужно ли выполнить поиск в текущем PDF или во всех документах PDF в другом расположении.

  4. Выполните одно из следующих действий.
    • Чтобы найти отдельное слово или фразу, выберите параметр поиска Одно слово или фраза и введите искомое слово или фразу в текстовом поле.
    • Чтобы найти несколько слов, выберите параметр Несколько слов или фраз, затем нажмите кнопку Выбрать слова. Введите каждое слово в текстовом поле Новое слово или фраза и нажмите кнопку Добавить. Можно также импортировать текстовый файл со списком искомых слов или фраз.
    • Чтобы выполнить поиск по шаблонам (например, телефонных номеров, номеров кредитных карт, адресов электронной почты, номеров карт социального страхования или дат), нажмите кнопку Шаблоны. Выберите один из доступных шаблонов. Вы можете изменить язык шаблонов (См. Выбор версии на другом языке для шаблонов.)
  5. Нажмите кнопку Найти и удалить текст.

  6. После отображения результатов поиска нажмите знак «плюс» рядом с именем документа для просмотра списка всех вхождений слова или фразы. Затем выберите те вхождения, которые нужно отметить для исправления:
    • Чтобы выбрать все вхождения элементов в списке, нажмите Установить все флажки.
    • Чтобы выбрать отдельные вхождения, установите флажок напротив каждого вхождения, которое нужно исправить. Чтобы увидеть вхождение на странице, щелкните текст напротив соответствующего флажка.
    • Чтобы не отмечать вхождения, закройте диалоговое окно Поиск или нажмите кнопку Новый поиск, чтобы повторить поиск сначала.
    • Чтобы пометить для исправления целые слова или части слов (символы), выберите нужный параметр в разделе Параметры меток исправлений. Для частей слов выберите Помечать части слов, появится диалоговое окно Настройки. В диалоговом окне Настройки укажите количество и положение символов для исправления. Исправление символов полезно, если требуется найти какой-либо шаблон, например, номера кредитных карт, и при этом необходимо оставить часть номеров видимой для идентификации.
  7. Если выбранные вхождения нужно отметить для исправления, нажмите Отметить результаты для редактирования.

    Элементы, выбранные в списке, отмечаются для дальнейшего исправления.

    Примечание.

    Если файл не был сохранен, то можно выделить в документе метки исправления и убрать их с помощью кнопки «Удалить». После сохранения файла метки исправления становятся постоянными.

  8. Для удаления отмеченных элементов, нажмите кнопку Применить на дополнительной панели инструментов, затем нажмите кнопку ОК.

    Элементы не будут окончательно удалены из документа, пока вы не сохраните его.

  9. Если необходимо найти и удалить в документе скрытую информацию, используя функцию «Удалить скрытую информацию», нажмите Да. В противном случае нажмите Нет.

  10. Выберите Файл > Сохранить, затем укажите имя файла и расположение. Если вы не хотите, чтобы оригинальный файл был перезаписан, сохраните новый файл с другим именем или в другом месте либо сделайте и то, и другое одновременно.

Поиск и удаление скрытого содержимого

Функция «Удалить скрытую информацию» используется для поиска и удаления из документа конфиденциального или ненужного содержимого, такого как скрытый текст, метаданные, комментарии и вложенные файлы. При удалении таких элементов из документа автоматически удаляются и дополнительные элементы. К удаляемым элементам относятся цифровые подписи, сведения о документе, добавленные плагины и программы сторонних производителей, а также специальные функции, которые используются пользователями Adobe Reader для проверки, подписи и заполнения документов в формате PDF.

Примечание.

Для проверки всех файлов в формате PDF на наличие скрытого содержимого укажите этот параметр в меню «Документы» диалогового окна «Установки» перед закрытием файла и отправкой его по электронной почте.

  1. Выберите ИнструментыИсправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов, нажмите Удалить скрытую информацию.

    Найденные элементы отображаются в виде списка на панели «Удалить скрытую информацию» с установленным флажком напротив каждого элемента.

  3. Убедитесь, что отмечены только те элементы, которые действительно нужно удалить из документа (См. Параметры «Удаление скрытой информации».)
  4. Для удаления выбранных элементов из файла нажмите Удалить, затем нажмите кнопку OK.

  5. Выберите Файл > Сохранить, затем укажите имя файла и расположение. Если вы не хотите, чтобы оригинальный файл был перезаписан, сохраните новый файл с другим именем или в другом месте либо сделайте и то, и другое одновременно.

При сохранении файла выделенное содержимое удаляется без возможности восстановления. При попытке закрытия файла без сохранения повторите эти действия, что позволит гарантировать сохранение файла.

Параметры удаления скрытой информации

Метаданные

Метаданные содержат сведения о документе и его содержимом, такие как имя автора, ключевые слова и сведения об авторских правах. Для просмотра метаданных выберите Файл > Свойства.

Вложенные файлы

К документу PDF можно присоединить в качестве вложения файл любого формата. Чтобы просмотреть вложения, выберите Просмотр > Показать/Скрыть > Области навигации > Вложенные файлы.

Закладки

Закладки – это ссылки с поясняющим текстом, с помощью которых можно открывать заданные страницы документа PDF. Чтобы просмотреть закладки, выберите Просмотр > Показать/Скрыть > Области навигации > Закладки.

Комментарии и пометки

Этот элемент включает все комментарии, добавленные в файл PDF с помощью инструментов комментирования и разметки, в том числе файлы, вложенные как комментарии. Для просмотра комментариев выберите Инструменты > Комментарии.

Поля форм

К этому типу элементов относятся поля форм (в том числе поля подписей), а также все действия и расчеты, связанные с полями форм. При удалении этого элемента все поля формы объединяются, и их нельзя будет заполнять, изменять или подписывать.

Скрытый текст

Этот элемент соответствует прозрачному тексту документа PDF, тексту, закрытому другим содержимым, либо тексту того же цвета, что и фон документа.

Скрытые слои

Документ PDF может содержать несколько слоев, которые могут быть видимыми или скрытыми. При удалении из документа PDF скрытых слоев оставшиеся слои объединяются в один. Чтобы просмотреть слои, выберите Просмотр > Показать/Скрыть > Области навигации > Слои.

Встроенный поисковый индекс

Встроенный поисковый индекс позволяет ускорить поиск в файле PDF. Чтобы определить, содержит ли файл PDF поисковый индекс, выберите Инструменты > Указатель, затем на дополнительной панели инструментов нажмите Управление встроенным указателем. Удаление индексов позволяет уменьшить размер файла, но увеличивает время поиска в документе PDF.

Удаленное или обрезанное содержимое

В документах PDF иногда содержится информация, которая была удалена и теперь невидима, например удаленные изображения и усеченные или удаленные страницы.

Ссылки, операции и JavaScript

Этот элемент включает в себя веб-ссылки, операции, добавленные с помощью мастера операций и сценарии JavaScript во всем документе.

Перекрывающиеся объекты

Этот элемент включает объекты, наложенные друг на друга. Объекты могут быть изображениями (состоят из пикселей), векторной графикой (состоят из контуров), градиентами или узорами.

Выбор версии на другом языке для шаблонов (Acrobat Pro DC)

Локализованные шаблоны отображаются на панели «Поиск» (Исправить > Пометить для исправления > Найти текст).

  1. Выберите Редактирование > Установки (ОС Windows) или Acrobat > Установки (Mac OS).

  2. В области Категории, расположенной в левой части окна, выберите Документы.

  3. В области Исправление выберите нужный язык в меню «Выбрать локализацию для шаблонов функции «Найти и удалить текст». Затем нажмите кнопку OK.

Изменение оформления меток исправлений (Acrobat Pro DC)

По умолчанию вокруг изображений и текста, который отмечен для исправления, отображаются красные контуры, а вместо исправленных изображений и текста – черные прямоугольники. Перед тем как пометить элементы для исправления, вы можете задать оформление меток по умолчанию. Кроме того, вы можете изменить оформление меток перед применением исправлений.

Установка оформления всех меток по умолчанию

  1. Нажмите ИнструментыИсправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов выберите Свойства.

    Отобразится диалоговое окно «Свойства инструмента "Исправления"».

  3. На вкладке Внешний вид выберите параметры, которые необходимо изменить, и нажмите кнопку OK:

    • Щелкните значок Цвет заливки области исправлений и выберите в палитре «Цвет» нужный цвет заливки полей, которые будут отображаться вместо удаленных элементов. Чтобы оставить исправленную область пустой, выберите вариант Нет цвета.
    • Чтобы выделить пользовательский текст или параметры кода исправления, выберите Использовать перекрытие текстом. Задайте шрифт, размер и выравнивание текста.
    • Выберите Заказной текст и введите текст, который должен отображаться в области исправлений.
    • Выберите Код исправления, затем либо выберите нужный код из существующего набора, либо нажмите Редактировать Код, чтобы указать новый код или набор кодов. (См. Создание кодов исправлений и наборов кодов.)
    • В области Оформление меток исправлений нажмите значок Цвет контура, значок «Цвет заливки» или оба значка. В палитре цветов выберите цвет для изображений и текста, который помечается для исправления. Переместите ползунок, чтобы корректировать непрозрачность цвета. Чтобы оставить выделенную область пустой, выберите вариант Нет цвета.

Свойства для исправления текста (Acrobat Pro DC)

Пользовательский текст

Текст, введенный в поле Заказной текст, отображается сверху метки исправления.

Шрифт

Пользовательский текст отображается выбранным шрифтом.

Размер шрифта

Пользовательский текст отображается выбранным размером (в пунктах).

Авторазмер для текста по размеру области исправления

Подгоняет размер пользовательского текста под размер области исправления. Данный параметр имеет приоритет перед параметром Размер шрифта для перекрытия текстом.

Цвет шрифта

Отображает пользовательский текст выбранным цветом, который можно выбрать, щелкнув образец цвета.

Повторить перекрытие текстом

Заполняет исправленную область нужным количеством вхождений пользовательского текста без изменения размера шрифта. Например, если буква x или дефис (-) определены в качестве пользовательского текста, эти символы будут повторяться по всей области исправления.

Выравнивание текста

Выравнивает текст по левому краю, правому краю или по центру.

Коды исправлений (Acrobat Pro DC)

Для вымарывания выделенных областей в программе Acrobat используется перекрытие текстом. Один из примеров перекрытия текстом — код исправления, который состоит из одной или нескольких записей кода из набора кодов В Acrobat включены наборы кодов Закона США о свободе информации и Закона США об охране прав личности. Для создания перекрытия текстом можно использовать либо коды, либо пользовательский текст. Различие заключается в том, что коды исправления представляют собой текстовые записи, которые можно сохранять, экспортировать и импортировать. Один набор кодов может содержать несколько кодов.

Примечание.

Текущие атрибуты текста перекрытия не сохраняются в кодах в качестве таких элементов определения кода, как цвет и шрифт, повтор или размер текста. Коды позволяют повторно использовать в будущих сеансах только сам текст перекрытия и только тем пользователям, совместно с которыми используются наборы кодов. Другие атрибуты кода задаются в диалоговом окне «Свойства инструмента «Исправление»».

Создание кодов исправления и наборов кодов

  1. Нажмите Инструменты > Исправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов выберите Свойства.

    Отобразится диалоговое окно «Свойства инструмента "Исправление"».

    Свойства инструмента «Исправление» в Acrobat
    Создайте коды исправления с помощью диалогового окна «Свойства инструмента Исправления».

  3. Выберите Использовать перекрытие текстом.

  4. Выберите Код исправления.

    • Чтобы добавить в код исправления несколько записей кода, выберите запись в списке Записи кодов и нажмите Добавить выбранную запись. Повторяйте это действие для выбора всех нужных записей. Выберите Удалить выбранную запись, чтобы удалить запись кода из списка Код исправления.
    • Нажмите Редактировать коды, чтобы внести в них дополнительные изменения.
  5. В диалоговом окне Редактор кодов исправлений выберите Добавить набор.

  6. (Необязательно) Введите имя нового набора в текстовом поле, расположенном под списком наборов кодов, затем нажмите Переименовать набор.

  7. Нажмите Добавить код и введите текст, который должен отображаться как наложенный в текстовом поле, расположенном под списком кодов, затем нажмите Переименовать код.

  8. Повторите предыдущий шаг, чтобы добавить в набор кодов запись для нового кода, либо повторите предыдущие три операции для создания дополнительных наборов кодов и самих кодов.

Редактирование кодов исправления и наборов кодов (Acrobat Pro DC)

  1. Нажмите Инструменты > Исправить.

    На дополнительной панели инструментов отобразится набор инструментов «Исправить».

  2. На дополнительной панели инструментов выберите Свойства.

    Отобразится диалоговое окно «Свойства инструмента "Исправление"».

  3. Выберите Использовать перекрытие текстом, затем Код исправления.

  4. Выберите набор кодов в списке слева и нажмите Редактировать коды.

  5. В диалоговом окне Редактор кодов исправлений выполните одно из следующих действий.

    • Чтобы удалить набор кодов и все записи кодов этого набора, выберите запись в поле Набор кодов и нажмите Удалить набор.
    • Чтобы экспортировать набор кодов в отдельный XML-файл, который можно повторно использовать в других документах формата PDF или совместно использовать с другими пользователями, выберите набор кодов. Затем нажмите Экспортировать набор, укажите имя и расположение файла, затем нажмите кнопку Сохранить.
    • Чтобы импортировать ранее сохраненный набор кодов, нажмите Импортировать набор, укажите файл и нажмите кнопку Открыть.
    • Чтобы переименовать набор кодов, выберите запись в поле Набор кодов, введите новое имя в текстовом поле под списком и нажмите Изменить набор.
  6. Выбрав Набор кодов, укажите запись кода, которую нужно исправить, и выполните одно из следующих действий.

    • Чтобы удалить запись кода, нажмите кнопку Удалить код.
    • Чтобы переименовать запись кода, введите новое имя в текстовом поле, расположенном под списком, и нажмите кнопку Переименовать код.

Применение нескольких записей кода к одному исправлению

  1. Щелкните маркер исправления правой кнопкой мыши.

  2. Выберите Набор кодов из списка в нижней части контекстного меню, затем выберите запись кода в раскрывающемся меню. После применения кода рядом с записью кода появляется флажок.

  3. Повторно выполните предыдущие шаги, чтобы добавить еще одну запись кода для исправления.

Чтобы отобразить записи кода, разделенные запятыми, наведите указатель на метку исправления.

Примечание.

Чтобы применить один и тот же код к нескольким исправлениям, установите Свойства исправлений перед пометкой содержимого. На дополнительной панели инструментов нажмите Свойства. Выберите Использовать перекрытие текстом, а затем Код исправления. Выберите Набор кодов и запись кода, затем нажмите кнопку Добавить выбранную запись.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет