Cinema 4D is a popular 3D modeling and animation tool from Maxon (www.maxon.net).

Closer integration with Cinema 4D allows you to use Adobe After Effects and Maxon Cinema 4D together. You can create a Cinema 4D file (.c4d) from within After Effects and you can work with complex 3D elements, scenes, and animations.

To enable interoperability, CineRender, the Maxon Cinema 4D rendering engine, is integrated with Adobe After Effects. After Effects can render Cinema 4D files, and you can control some aspects of rendering, camera, and scene content on a per-layer basis. This streamlined workflow does not require you to create intermediate pass or image sequence files.

Maxon Cinema 4D Lite

Maxon Cinema 4D Lite application gets installed along with After Effects. You can create, import, and edit Cinema 4D files. However, if you have another edition of Cinema 4D, such as Cinema 4D Prime, you can use it instead. The Cinema 4D Lite application gives you the ability to edit, create, and work with native Cinema 4D files. The features in the Lite version are similar to Cinema 4D Prime.

The default behavior uses the higher version of the installed Cinema 4D application.  

See this tutorial to learn to use Cinema 4D Lite with After effects cameras and lights.

Watch this video Overview of Cinema 4D Lite by Chris Meyer.

c4d-logo

Cineware effect
Cinema 4D window

Working with Cinema 4D files

There are several options available to create, import, and edit Cinema 4D files from within After Effects.

Import Cinema 4D files

To import Cinema 4D files into After Effects, do the following:

  1. Choose File > Import > File.
  2. Select the Cinema 4D file and click Import. The file is placed in the Project panel as a footage item. You can place the footage item on an existing composition, or create a matching composition.

Note:

When you place the footage on a new composition using the new composition icon in the project panel, a composition is created that matches the Cinema 4D file settings and then a Cinema 4D layer is created and the 3D scene is placed on it. If you drop the footage in an existing composition, the footage picks up the composition size/aspect instead.

Note:

Before importing, enable Save Polygons For Melange and Save Animation For Melange preferences in Cinema 4D application preferences. These settings are especially useful in cases where Cinema 4D frames depend on previous frames.

Edit Cinema 4D files

You can edit Cinema 4D files placed in compositions or Cinema 4D source items in the Project. The files open in the Cinema 4D Lite application. If you have a different version of Cinema 4D installed, that is used to edit the file instead. See Edit footage in its original application.

You can choose the version of Cinema 4D you want to use with Edit Original. See Working with different instances of Cinema 4D in Cineware Effect.

For more information, see the video by Jeff Sengstack on Importing and editing Cinema 4D files.

Create Cinema 4D files

You can create a Cinema 4D file from within After Effects.

  1. Choose File > New > Maxon Cinema 4D File or Layer > New > Maxon Cinema 4D File.
  2. Specify a name and location of the file.
  3. The Cinema 4D application opens.
  4. Create a C4D scene and choose File > Save to save the file.
For more information, see this video by Jeff Sengstack on Creating Cinema 4D files.

Export to Maxon Cinema 4D and round-trip your edits

You can export your compositions with 3D animated text and shape layers to Maxon Cinema 4D using the After Effects' Live 3D pipeline for round-tripped 3D workflow.

3D Shape layers are exported as extruded spline objects, and includes animation of shape layer properties.

The Extrude Text as Shapes option exports 3D text layers as extruded spline objects in the .c4d file. This option retains the fidelity of the layer: character and paragraph formatting, and animation of text layer properties. You cannot modify the font and text content in Cinema 4D.

The Preserve Editable Text option exports 3D text layers as extruded text objects in the .c4d file. In this option, you can modify the font and text in Cinema 4D. However, this option has limited support for character and paragraph formatting, and animation of text layer properties. Text animation features that are not supported include: text animators, kerning, tracking, vertical text, paragraph text, and text on path.

Strokes are exported for 3D text and shape layers into the .c4d file. While the Ray-traced 3D renderer in After Effects does not render strokes for 3D text layers, strokes are still exported when enabled. To view 3D text layer strokes before exporting, make sure that the composition renderer is set to Classic 3D.

Export to Maxon Cinema 4D

To export to Maxon Cinema 4D:

  1. Choose File > Export > Maxon Cinema 4D Exporter and save the C4D file.
  2. In the Export to Maxon Cinema 4D dialog box, select one of the following:
  • Extrude Text as Shapes: Creates a .c4d file with basic extrusion.
  • Preserve Editable Text: Exports 3D text layers as extruded text objects in the .c4d file, allowing you to modify the font and text in Cinema 4D.

Note:

 
  • If your text is unlikely to change after export, it is recommended to choose Cinema 4D: Extrude Text as Shapes option in the Text Exporting dialog box. 
  • When you export, the scene coordinates for the parent null object is shifted so that the center of an After Effects composition matches Cinema 4D’s center at 0,0,0. 
  • The exported .c4d files are saved in Cinema 4D version 17.0.

Import the .c4d file and edit it in Maxon Cinema 4D

You can import the .c4d file that you have created in to your After Effects composition for editing. Choose Edit > Edit Original to edit the .c4d file in Cinema 4D.

When you import and add a .c4d file that was created by the Cineware 3.1 version of the Exporter to your composition, you can view the scene through an After Effects camera by first adding a camera and then setting the Camera setting in the Cineware effect to Centered Comp Camera.

Any After Effects 3D layers that you add to the composition line up with the Cinema 4D scene layer after export. The extracted 3D Scene data from the .c4d file such as nulls, cameras, and lights also line up, provided that any new objects added to the .c4d file are grouped under the same parent null object as created in the exported .c4d file.

To open the exported Cinema 4D file in After Effects and Cinema 4D for advanced 3D edits:

  1. Choose File > Import and select the .c4d file to import it to your composition.
  2. To customize the 3D elements using Cinema 4D, select the Cineware layer and choose Edit > Edit Original (or press the keyboard shortcut Command + E on Mac OS or Control + E on Windows). The C4D file opens in Cinema 4D, which is included in After Effects CC.
  3. Make changes and save the file. Your After Effects composition is automatically updated with all the changes. 

Cineware effect

The integration of CineRender, which is based on the Cinema 4D render engine, enables rendering of layers based on Cinema 4D files directly in After Effects. The Cineware effect lets you control the render settings, and provides some control over the render quality-speed tradeoff. You can also specify cameras, passes, or C4D layers used for a render. The Cineware effect is automatically applied when you create a layer based on C4D footage on the composition. Each Cinema 4D layer has its own render and display settings.

For more information, see Understanding the Cineware effect and render engine.

Synchronize Layer

When adding multiple instances of a Cinema 4D scene layer in a composition, including adding Multi-Pass layers, you can select the Cinema 4D layers that are to be synchronized with the rest of the layers in the composition.

When you check the Synchronize AE Layer option at the top of the Effect Controls panel, the Render Settings and Camera options on all instances of the layer automatically synchronize, but Cinema 4D layers can be set independently. If the check box is disabled for a specific Cinema 4D scene layer, none of that layer’s settings synchronize with the rest of the layers in the composition.

Live Link synchronizes the timelines of Cinema 4D and After Effects.

To work with Live Link, click the Enable button for Live Link. The specified Cinema 4D version opens the current file. To enable Live Link in Cinema 4D, choose Edit > Preferences > Communication > Live Link, and then select Live Link Enabled At Startup. The timelines are synchronized when switching between After Effects and Cinema 4D. When you select a different C4D layer in After Effects, press Enable to synchronize that layer.

Note: To use Live Link, ensure that the Cinema 4D paths in the CINEWARE Options dialog box is set to a version of Cinema 4D that supports Live Link (Cinema 4D R17.048 or later). 

Render settings

The Cineware render settings determine how to render the scene inside After Effects. These settings can help you speed up the rendering process while you're working.

Renderer

Determines which renderer to use. The following options are available:

  • Standard (Final): Uses the Standard renderer as specified in the C4D file. Use the Cinema 4D application to edit these settings.
  • Standard (Draft): Uses the Standard renderer but turns off slower settings like anti-aliasing for better interactivity.
  • Software: Uses the settings to provide the fastest rendering, by letting you choose Display settings. Shaders and multi-passes are not displayed. Use the Software renderer to preview while you continue to work on the composition.
  • OpenGL: Hardware-accelerated rendering for better quality and higher speed as compared to the software render option. The OpenGL renderer in CINEWARE supports the same level of enhanced OpenGL quality as Cinema 4D for the Transparency, Shadows, Post effects, and Noises properties.

Note:

When you save your .c4d file in a full retail version of Cinema 4D (not Cinema 4D Lite, which is bundled with After Effects) with Render Settings set to the Physical or Hardware renderer, your file is rendered with those settings when the CINEWARE renderer is set to Standard (Final) or Standard (Draft). 

Display

This option is only enabled when you choose the Software renderer. The available options are Current Shading, Wireframe, and Box. The wireframe and box modes provide a simplified representation of the scene.

No Textures/Shader

Check this option to speed up your render by not rendering textures and shaders.

No pre-calculation

Check this option to speed up your render by disabling pre-calculations for computing motion dynamics or particle simulations. Do not check this option for final rendering.

Keep Textures in RAM

Check this option to cache textures in the RAM so that they are not reloaded from disk and can be accessed more quickly. On the other hand, if you cache large textures, it may lead to reduction in available RAM.

Render Server

Purge Memory: Clears the memory of the render server. Over a period, the response of the render server might degrade as it continues to store the scenes being processed. Clearing the up memory that the render server uses for internal caches can help After Effects extend the length of previews of complex scenes.

Project Settings

The following project settings are available in the Cineware effect:

  • Camera
  • Cinema 4D Layers
  • Multi-Pass (Linear Workflow)
  • Commands

Camera

Choose the camera to use for rendering.

Cinema 4D Camera: Uses the camera that is defined as the render view camera in Cinema 4D, or the default camera if none is defined.

Select Cinema 4D camera: Use this option to choose a camera. When this option is enabled, click Set Camera.

Centered Comp Camera: Use this option to use the After Effects camera, and recalculate the Cinema 4D co-ordinates to adapt to the After Effect co-ordinates. When you import an existing C4D file (typically modeled around 0,0,0) to be rendered with a new After Effects camera (which is centered on the composition), use this option to render the C4D model in the After Effects center. Otherwise the model may be unexpectedly shifted due to origin difference.

Comp Camera: Use this option to use the active After Effects camera. For this option to work, you must have added an After Effects camera. For example, use this option for a camera that has been added by extracting it from a Cinema 4D project (since those cameras reference Cinema 4D's coordinate system with 0,0,0 at the center of the Cinema 4D viewport). This option is suited for cameras that are added to After Effects by using the Layer > New > Camera command.

Set Camera: If a Cinema 4D scene contains cameras other than the default camera, click this button and select the camera. 

Set Take: This option is enabled if your c4d file contains takes. You can create multiple takes of your scene and modify any parameter in a take. If the current renderer does not support take selections, the main take is used.

Cinema 4D Layers

Enable and select the Cinema 4D layers to render.

Set Layers

Click to choose layers. Click the Set Layers button to choose one or more layers. In Cinema 4D, layers let you organize multiple elements. You can use Cinema 4D layers to composite between elements in the After Effects comp.

Multi-Pass (Linear Workflow)

Use the Cinema 4D Multi-Pass option to specify which pass to render. The multi-pass features are only available when using the Standard renderer.

Multi-passes give you the ability to quickly make fine adjustments to a C4D scene by compositing different kinds of passes together in After Effects, such as adjusting just the shadows or reflections in the scene. For the results to match Cinema 4D's default Linear Workflow project setting, you must work in a project in which colors are blended in linear light (either in a color-managed linear working space or with Blend Colors Using 1.0 Gamma set in the Project Settings dialog box).

Set Multi-Pass

Click to select which pass to render on this layer. This option is only available if Cinema 4D Multi-Pass option is enabled.

Defined Multi-Passes

When enabled, adds the passes explicitly added in the .c4d file. This can include passes other than Image Layers.

Add Image Layers

Use this option to create multiple pass layers with proper blending modes depending on the setting of Defined Multi-Passes. When the Defined Multi-Passes option is enabled, Add Image Layers restricts you to just adding the passes defined in the Cinema 4D render settings rather than adding all supported types.

Note:

When adding image layers, the layer that was originally selected are placed at the bottom of the Timeline stack, and renamed with RGBA Image appended to the layer name to reflect its multi-pass type.

Commands

Use the following commands.

Comp Camera into Cinema 4D

Click Merge to add the current After Effects camera as a C4D camera in the C4D file. This modifies the C4D file. Use File > Revert to Saved in C4D to see the newly added After Effects camera. This command is especially useful to transfer camera data created by the 3D Camera Tracker effect. AE is prefixed to the camera name.

Note: If you merge again, the previous camera is not updated. A new copy is created instead.

Cinema 4D Scene Data

Click Extract to create 3D data such as cameras, lights, solids, or nulls for objects that have an External Compositing tag applied in the Cinema 4D project.

Note:

Always enable Save Polygons for Melange option and Save Animation for Melange option in the Cinema 4D preferences to avoid problems extracting scene data in After Effects.

Note:

Depending on your computer's security settings, you may see some warnings about TCP communication. This is because After Effects and the background Cinema 4D renderer communicate using TCP which some security software may interpret as dangerous malware communication. For example, Mac OS may require you to confirm if you want to run this software "downloaded from the Internet". Confirm that you want to run this software.

If you are able to import a .c4d file, but it fails to render, check if your Mac OS Gatekeeper or your firewall has blocked the background Cinema 4D renderer from functioning and communicating with After Effects. For Mac users, set Allow Applications Downloaded From (under the General tab of Security and Privacy system preferences) to Anywhere.

The TCP port used is defined in the Options in the Cineware effect, and this value is stored in the After Effects preferences file.

Working with different instances of Cinema 4D in Cineware Effect

You can specify the instance of Cinema 4D that you want to use in the Cineware effect.

Cineware settings
Cinema 4D settings

Cineware Render path and Executable path
Cinema 4D Render path and Executable path


Click Cineware Effect > Options and choose from the following settings:

  • Cinema 4D Render Path - Choose the version of Cinema 4D (R14 or later) for rendering in After Effects. For example, you can choose to use Cinema 4D Studio, Broadcast, Prime, or Visualize if you have it installed.
  • Cinema 4D Executable Path - Choose the version of Cinema 4D to use when opening a .c4d file with Edit Original or when creating a Cinema 4D file from After Effects. The default Cinema 4D Lite application is located at :
    • C:\Program Files\Adobe\Adobe After Effects CC\Support Files\Plug-Ins\MAXON CINEWARE AE\(CINEWARE Support)\lite\CINEMA 4D Lite.exe (Windows)
    • /Applications/Adobe After Effects CC/Plug-ins/MAXON CINEWARE AE/(CINEWARE Support)/Lite/CINEMA 4D Lite.app (Mac OS).

Note:

After using a full retail version of Cinema 4D as renderer, if you want to switch back to the default Cineware renderer, click the Defaults button in the Cineware-Settings dialog box.

Switch render paths

Follow the steps below to switch render paths (such as changing Cinema 4D rendering application):

  1. Options > Browse To Set Render Path
  2. Select the new application
  3. Exit After Effects
  4. Launch After Effects
  5. Click Edit > Purge > All Memory & Disk Cache for the new settings to take effect.

Note:

If you experience a connection failure after switching the renderer, exit After Effects, wait for 20-30 seconds, and then relaunch the application again.

Rendering capabilities

When you choose Cinema 4D versions R14 and above as the renderer, you can use various rendering capabilities within the After Effects Cineware plug-in other than the default renderer, such as Physical renderer and Sketch and Toon.

To use the Physical renderer, do the following:

  1. Choose the Physical renderer in the Cinema 4D Render Settings dialog.
    1. From the Render menu, choose Render > Edit Render Settings.
    2. In the Render Settings dialog, set the pop-up to Renderer: Physical.
    3. Click Physical and set other settings such Depth of Field or Motion Blur options.
  2. Save the .c4d file with the renderer settings.
  3. The renderer specified in Cinema 4D is the one that will be used by the Cineware effect when the Renderer Settings option in the effect is set to Standard (Final) and Standard (Draft).

To render Sketch and Toon, do the following:

  1. From the Create menu in the Cinema 4D application, choose Create > Material > Sketch Material.
    1. In the Render Settings dialog, set the pop-up to Renderer: Standard.
    2. In the Render Settings dialog, ensure that Sketch and Toon post effects are added and checked.
  2. Save the .c4d file with Sketch and Toon enabled.
  3. Sketch and Toon is rendered by the Cineware effect when the renderer settings in the effect is set to Standard (Final).

Note: You can control Sketch and Toon for individual objects in the Object manager by adding Tags > Sketch Tags > Sketch Style (see the Maxon Cinema 4D Help documentation for more information about Sketch and Toon).

Note:

The following versions of Cinema 4D are compatible with Cineware:

  • R14.042 or above. Use the Cinema 4D online updater to install the current version.
  • R15.037 or above
  • R16
  • R17

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy