编辑 Character Animator 中人偶的构造和外观需在“人偶”面板中完成。在此对人偶所做的更改将影响所有添加到场景的人偶实例。

要编辑人偶,请执行以下操作之一:
  • 在“项目”面板中双击人偶。
  • 在“人偶”面板的右侧栏中双击人偶的图层。
  • 在“时间轴”面板中双击人偶的轨道项或轨道标题(左侧)。

此时将在“人偶”面板中打开人偶。面板在左侧(侧栏)显示图层结构,在右侧显示图层的外观和任何关联的手柄。面板底部是命令和工具,用于处理图层和手柄。“属性”面板也有用于所选图层的设置。

导航

“人偶”面板包含许多与“场景”面板相同的控件,用于平移和缩放面板内容以及更改背景颜色。此外,它还有用于选择对象(选择工具)、平移(手形工具)和缩放(缩放工具)的工具。

人偶面板控件
人偶面板控件

人偶网格轮廓

当您在“人偶”面板中选择一个图层时,网格会出现一个黄色的轮廓。此黄色轮廓表示由图层列表中具有黄色垂直线且具有“网格形状”“网格扩展”设置的图层标识的网格。此轮廓可以帮助您确认网格是您想要的形状,而不是由于不重叠的图层导致的意外形状。

人偶网格轮廓
人偶网格轮廓

要隐藏或显示网格轮廓和自动附加的手柄,请在“人偶”面板左下角切换“显示网格形状”“自动手柄”( )。

人偶图层副本

可以在“人偶”面板中复制图层和组。要复制,请选择“编辑”>“复制”菜单。可以修改复制图层或组而不影响原始对象。

选中或取消选中图层

  • 单击左侧栏中的图层。所选内容都高亮显示为灰色。
  • 要将选择项扩展到图层的范围,请按住 Shift 键并单击图层。
  • 要切换图层选择项,请按住 Cmd/Ctrl 键并单击左侧栏中的某个图层,或按住 Shift 键单击。
  • 选择所有图层,请按住 Cmd/Ctrl+A。
  • 要取消选中所有图层,按 Shift+Cmd/Ctrl+A 或在左侧栏中的任何图层之外单击。

用于交换集中触发器的“隐藏组中的其他图层”图层

有多个重叠的键盘触发图层被设为“隐藏组中的其他图层”时,使用“人偶”面板可更轻松地切换到其中某一个图层。如果您打开某个图层的眼球,且该图层与交换集中的某个触发器相关联,则与同一交换集中的其他触发器相关联的图层所对应的眼球将关闭。

注意:

如果选中多个“隐藏组中的其他图层”图层和它们对应的一个眼球,将无法单独操作“隐藏组中的其他图层”图层。当选中“非隐藏组中的其他图层”图层时,会打开或关闭选中的所有图层。

要在单击“隐藏组中的其他图层”眼球的情况下打开选中的所有图层,请按住 Option/Alt 键并单击眼球开关。

所有图层(而不仅仅是分配了触发器键的图层)都可以使用“隐藏组中的其他图层”。您可将此孤选功能用于不包含任何触发键的其他互斥同级图层。这些可以是“嘴部”组中的同级图层,也可以是通过“头部转动工具”控制的同级图层。

“控件”面板:人偶触发器和行为参数的自定义布局

使用“控件”面板可获得一个可视界面或功能板,您可在其中访问人偶触发器或支持的行为参数。选择您希望轻松访问的触发器和行为参数(数字和角度值),并从一个位置控制它们。随后这些自定义控件会与人偶相关联。这些控件还能作为导出的人偶的一部分,与他人共享。

默认情况下,“控件”面板会在“录制”和“流”工作区中打开,但您可以使用“窗口”>“控件”菜单命令打开。面板在“项目”“时间轴”面板中显示与所选人偶相关联的控件,在“人偶”面板中显示与打开的人偶相关联的控件。

“控件”面板有两种模式:

  • “布局”模式:您可以在此处自定义控件的内容和外观。
“布局”模式
“布局”模式
  • “执行”模式:使用此模式时可通过单击面板顶部的链接使用各种控件。
“执行”模式
“执行”模式

“布局”模式

可将人偶的触发器可视化,变成可点击的按钮,并为各个触发器配上对应的图稿。触发器上还可设置关联的各种键或 MIDI 音符。您可以将人偶行为参数可视化为可调整的滑块或角度控件,以及与其相关联的任何 MIDI 音符。布局与人偶一起存储,包括导出为 .puppet 文件时,使您能与他人共享触发器布局。

“布局”模式下可用的控件如下。

将控件添加到面板中:选择人偶,然后选择下列选项之一:

  • 如果面板为空,请在面板中单击为“人偶名称”生成控件链接,以基于人偶触发器创建按钮控件。
  • 如果触发器最近刚添加到“触发器”面板中或您之前删除了部分触发器控件,请单击“刷新控件”按钮。此操作会为新增的触发器或之前已删除的触发器控件添加按钮。
  • “时间轴”面板中选择了人偶轨道后,将任意数字行为参数的名称从“属性”面板拖动到“控件”面板中。您也可以右键单击上面这些参数的名称,然后选择添加到“控件”面板

选择或取消选择多个控件:请执行以下任一操作:

  • 按住 Shift 键并单击或按住 Cmd/Ctrl 键并单击控件。
  • 在控件周围拖动(选框)并选择。按住 Shift 或 Cmd/Ctrl 可切换选择选框选择的控件。
  • 按 Cmd/Ctrl+A 可选择所有控件。
  • 按 Shift+Cmd/Ctrl+A 可取消选择所有控件。

重新排列控件:执行以下任一操作

  • 在面板中拖动所选控件。拖动的控件可以贴靠到网格布局。
  • 按住 Option/Alt 键并单击“刷新布局”按钮,以根据面板的当前大小重排当前这些控件。

要创建用于特定触发器的控件,请执行以下操作之一:

  • 在“触发器”面板中选择触发器或交换集,然后将它们拖动到“控件”面板中。
  • 右键单击触发器或交换集,然后在上下文菜单中选择“添加到‘控件’面板”

要分配其他键或 MIDI 控件:选择控件并点击要使用的键或触摸要使用的 MIDI 控件(按钮、滑块或旋钮)。此控件等效于在“触发器”面板中更改键或 MIDI 音符。与 MIDI 控件关联的控件在“布局”模式中显示为绿色叠加。

要轻松备录或取消备录参数而不在“属性”面板中查找控件,对行为参数使用滑块和旋钮控件以使用“录制准备”按钮。

注意:只有在选择了人偶轨道后才能使用该控件。

取消为控件分配键或 MIDI 音符/控制器:执行以下任一操作:

  • 右键单击控件并选择“删除触发器键”、“删除 MIDI 音符”或“删除 MIDI 控制器”(适用于行为参数控件)。
  • “触发器”面板中删除“MIDI 音符”字段的内容。

更改与多个人偶图层相关联的触发器按钮上的图稿:右键单击按钮控件,然后单击图层名称。

更改控件的背景颜色(用于改进与深色图稿的对比),右键单击控件,然后选择“浅色”或“深色”。

更改滑块或角度参数控件的值范围:单击或划动控件上的蓝色最小值(左侧)和最大值(右侧)。例如,如果添加了“变换”>“缩放”参数,但无需负值缩放,请将最小值设置为 0。

删除控件:选中控件,然后选择“编辑”>“删除”(Delete 或 Backspace)或单击面板底部的“删除选定的控件”按钮。

 

按钮控件的自定义图稿

您可以通过在人偶的图稿文件任何位置创建按钮控件来使用它的自定义图稿。要为已将多个图层分配给其触发器的按钮选择不同的图稿,请右键单击按钮并在上下文菜单顶部选择图层名称。

如果它影响人偶在场景中的外观,请关闭它的眼球。

  • 要将自定义图稿分配给按钮,请将图层从“人偶”面板拖放到按钮控件上。

从布局模式切换到执行模式

要切换回“执行”模式,“布局”模式下在任何控件之外双击。
您还可以指定一个快捷键来在布局和执行模式之间快速切换。在键盘快捷键编辑器中使用“切换控件面板布局模式”命令的“窗口”类别以分配快捷键。

“执行”模式

当您要使用控件时,请单击“执行”以切换到“执行”模式。您可以单击该按钮或按分配的键或触摸所分配的 MIDI 控件以执行操作。

平移内容

可以平移“控件”面板的內容以查看可视区域外的控件。
要在“控件”面板中平移,请执行以下任一操作:

  • 使用垂直或水平滚动条。
  • 请在面板中拖动的同时按住 Option/Alt 键或鼠标中键。
  • 要水平滚动,旋转鼠标滚轮可垂直滚动,或者在旋转鼠标滚轮的同时按住 Shift 键。

重命名行为参数控件

在“控件”面板中,行为参数包含根据参数命名的控件。这些控件可重命名。请执行以下步骤:

  1. “控件”切换到“布局”模式。

  2. 您可选择行为参数控件,然后按 Return 键 (macOS) 或 Enter 键 (Windows);或右键单击某个行为参数控件,然后选择“重命名”

  3. 请键入欲使用的名称,然后按 Return/Enter 键,或单击编辑栏以外的任意位置。

触发器行为和“触发器”面板

默认情况下,触发器行为将应用于新人偶。它允许您触发图稿和设置可以引用不同组中的图层的自定义命名触发器。这些命名触发器列在“触发器”面板中,您可以在此面板中为触发器分配键,查看触发器控制的图层列表,甚至使用连接的 MIDI 设备关联 MIDI 音符以触发图稿。

注意:

触发器行为替换了键盘触发器行为。

“触发器”面板
“触发器”面板

有两种类型的触发器:
• 单个触发器 - 默认情况下,这些触发器会隐藏图层,但按住某个键或 MIDI 音符/控件运行时会显示图层,例如,按 H 键在角色上显示一顶帽子。 
• 交换集 – 其中一次只显示一个触发器,例如不同的手势。这组触发器与人偶中的一组图层相关联。组合中的每个触发器都有其自己的触发器键或 MIDI 音符,并且其中一个触发器可以是默认值。

单击与触发器关联的图层的名称可以将该图层显示在“人偶”面板中。如果您想要显示人偶中的某个图层或组,而不影响任何其他图层或组,请使用单独的触发器。如果您希望该图层或组还隐藏其他图层或组(例如,按 B 以显示还拥有“瞳孔”和“眼球”图层的组中的“眨眼”图层),请使用交换集。

注:已过时的“键盘触发器”行为仍可使用,但如果要使用新的“触发器”面板,且没有任何必须保留的旧版“键盘触发器”录制内容,请将其替换为“触发器”。

创建和编辑触发器

“操纵”工作区中的“触发器”面板默认为打开状态。您也可以使用“窗口”>“触发器”菜单命令打开或关闭此面板。

创建显示人偶图层的单个触发器

执行以下任一操作:
• 为尚未分配触发器的人偶图层(其触发器列中无任何图标)单击其触发器列 (  ),然后选择“创建触发器”

• 在“人偶”面板中右键单击图层,然后选择“创建触发器”

• 将图层从“人偶”面板拖放到“触发器”面板。

将该图层放置到某个交换集上,以将其添加到该交换集。将其放置到任意其他位置以创建一个单独的触发器。

• 在“触发器”面板中单击“添加”(+) 按钮,然后选择“创建触发器”以创建一个空触发器。之后,现在将人偶图层拖动或添加到该触发器中。

有问题的触发器(键位冲突、无图层等等)会显示为橙色。将鼠标指针悬停在触发器上可查看详情。工具提示也会说明缺少图层。

创建触发器交换集

执行以下任一操作:
• 为其图层尚未分配触发器交换集的人偶组(其触发器列中无任何图标)单击其触发器列 (  ),然后选择“创建交换集”

• 在“人偶”面板中右键单击一组图层,然后选择“创建交换集”

• 在“触发器”面板中单击“添加”(+) 按钮,选择“创建交换集”,然后向其中拖动单个触发器或(希望用作单个触发器的)人偶图层。

在“触发器”面板中创建一组新的触发器,每个触发器均以所选图层的名称命名。如果组中的任何人偶图层都可见,则最上面的图层会变成交换集中的默认触发器。您可以重命名交换集,并选择不拥有默认触发器。

创建触发器和交换集
创建触发器和交换集

设置默认触发器

要将交换集中的特定触发器设置为默认触发器,请执行以下任一操作:
• 选择该触发器,然后选择面板底部的“默认”选项。
• 单击触发器名称旁边的触发器图标。
• 双击触发器名称。
默认触发器将使用较亮的实心图标和较亮的名称进行标识。如果您不想在默认情况下触发任何图层,请重复以上步骤来切换“默认”选项。

向现有触发器分配图层或组

要向现有触发器分配图层或组,请执行以下任一操作:
• 在“人偶”面板中右键单击图层或组,选择“添加到触发器”,然后从上下文菜单中选择特定触发器。
• 在“触发器”面板中将图层或组拖到触发器上。

配置调用触发器设置

要更改触发器的启动方式:在“触发器”面板中选择触发器,然后执行以下任一操作:

  • 在键盘列中输入一个键位。
  • 单击“MIDI 音符”字段,然后在 MIDI 设备上点击该键或输入其 MIDI 音符编号。
  • 要锁存触发器,以便无需按住键盘或 MIDI 键即可保持触发状态,可启用面板底部的“门栓”选项。
  • 现在,向现有触发器添加图层或重放,会选中“触发器”面板中的目标触发器。

还可以更直接地在“控件”面板的布局模式下执行向触发器分配键和 MIDI 音符的操作。有关更多信息,请参阅布局模式

重命名、重新排列或组合触发器或交换集

要重命名触发器或交换集,请在“触发器”面板中将其选中,然后按 Enter 键(在主键盘而不是数字小键盘上)并输入新名称。要接受更改,按 Enter 键或在文本字段外单击。相反,按 Esc 键可取消编辑。

要重新排列触发器并在交换集中移动它们、将它们移动到交换集中或将它们移出交换集,请选择一个或多个触发器,然后在面板中拖动它们。将一个交换集拖动到另一个交换集上可将它们的触发器合并到一个交换集中。当您想要基于列出的顺序设置触发器的优先级时,重新排列交换集中的触发器也很有用。

要合并触发的图层,请将一个触发器拖动到另一个触发器上。已放下的触发器的图层将重新分配给目标触发器。随后将删除已放下的触发器。

要将一个交换集中的触发器合并到另一个交换集中,请将该交换集拖动到另一个交换集之上或之中。已放下的交换集的触发器将添加到目标交换集。目标交换集的默认触发器仍为默认触发器。

 

注意:

如果将人偶组设为可共享,则分配给组图层的任何触发器将移动到共享人偶。这些触发器的任何控件(显示在“控件”面板中)仍与父级人偶(而不是共享的人偶)相关联。您可以为共享人偶的触发器生成控件。

查看或显示触发器

要查看或显示与人偶中的图层相关联的触发器,请执行以下任一操作:

• 在“人偶”面板中,在图层行中将鼠标悬停在“触发器”图标上。显示图层的触发器(以及所有触发器键)的列表显示在“工具提示”中。
• 在图层行中单击“触发器”图标以在“触发器”面板中显示触发器。
・如果一个图层分配给了多个触发器,在图层行中单击带有箭头的“触发器”图标,然后选择要在“触发器”面板中显示的特定触发器。

提示:单击打开与交换集中的某个触发器相关联的图层(在“人偶”面板中)所对应的眼球,将自动关闭该交换集中触发的其他图层所对应的眼球。按住 Option/Alt 键并单击可覆盖眼球自动切换。

调用了多个触发器时配置触发器的行为

要在同时调用了多个触发器时更改交换集中的触发器行为,请选择交换集,然后将“优先级”设置为“最近”以使最近使用过的触发器优先,或者设置为“列出的顺序”以使列在“触发器”面板最上面的触发器优先。将会显示优先的触发器的图层。

删除图层

要删除与触发器相关联的图层,请在“触发器”面板中选择触发器,然后在面板底部单击要删除的图层旁边的“x”。

注:删除与触发器相关联的所有图层不会自动删除触发器。

删除触发器或交换集

要删除触发器或交换集,请将其选中,然后选择“编辑”>“删除”(Delete 或 Backspace 键)。

注意:

头部转动、嘴形同步、运动触发器和面部(适用于眨眼)触发器图层等行为独立于触发器行为。若要在相同人偶组中通过触发器触发的图层使用这四种行为,请将“隐藏组中的其他图层”选项设置为不由这四种行为触发的图层。使用该选项,图层顺序将决定优先级。否则,更改图稿文件的结构。

在人偶之间复制触发器

注意:

您可以从一个人偶复制触发器并将其粘贴到具有交换集和触发器并匹配相同名称的另一个人偶。在录制这些触发器的镜头之前,从原始人偶复制这些交换集和触发器。否则,粘贴的触发器不起作用。

要设置人偶之间的触发器兼容性,请执行以下步骤:

  1. 选择要从中复制触发器的人偶。从“触发器”面板中,选择交换集和触发器进行复制。

  2. 要复制触发器,请选择“编辑”>“复制”。要在人偶之间移动切换集或触发器,请选择“编辑”>“剪切”。

  3. 选择希望将这些交换集或触发器复制到的人偶

  4. 关注“触发器”面板后,选择“编辑”>“粘贴”

粘贴的交换集和触发器出现在触发器列表的底部。您可根据自己的意愿移动它们。您现在可以在这两个人偶之间复制任何触发器录制。

将旧的或过时的键盘触发器转换为触发器

如果您在 2017 年 10 月版之前创建了键盘触发器,则可以将键盘触发器转换为触发器,以便利用更灵活的触发功能和使用“控件”面板。请注意,使用键盘触发器行为的现有项目和 .puppet 文件将继续工作。

对于基于触发器的人偶,可以使用“触发器”或“控件”面板查看分配给某个人偶的所有触发器键。

注意:

“人偶”面板中的旧键盘列不再存在。在“属性”面板的“键盘触发器(过时)”部分中编辑过时触发器的键。您还可以更改“门栓”和“隐藏组中的其他图层”设置。“隐藏组中的其他图层”设置仍适用于触发器行为所使用的触发器键。

要将人偶从键盘触发器转换为触发器,请执行以下步骤:

重要说明:以下过程将删除现有的键盘触发器录制。

  1. 在“项目”面板中选择人偶。

  2. 选择“人偶”>“转换过时的触发器键”

    触发器行为替换键盘触发器行为。现有的触发器键将转换为“触发器”面板中的等效触发器。

  3. (可选)通过将一个触发器拖动到另一个触发器的上方来整合“触发器”面板中的所有无关紧要的触发器。

    如果您转换了导入的 .puppet 文件,请将人偶导出为新 .puppet 文件以保留这些更改。

衰减器:通过触发器淡入和淡出组

您可以使用键盘触发器控制人偶的不透明度。您可以使用此行为显示或隐藏人偶的特定部位,方法是使用触发器(例如键盘触发器)淡入或淡出该部位(组)的不透明度。

设置

将此行为添加到您要淡入和淡出的人偶的特定组。默认情况下,此行为不会应用于人偶。要获得最佳结果,请避免在同一组中应用“衰减器”“变换”。您还可以为组分配触发器键。如果要通过点击键而不是按住它来切换淡入和淡出,可将键设置为栓上。

注意:

当包含重叠图层的组设置为“正常”混合模式且人偶正在使用“组不透明度”时,分别淡化图层直至达到最终的不透明度级别。解决方法:将组的不透明度设置为 99.9%。

控制

使用“持续时间”参数控制不透明度增大或减小的速度(以秒为单位)。

编辑触发器镜头

通过启动触发器所录制的镜头会作为触发器栏显示在“时间轴”面板中。您可以采用编辑发音嘴型栏的方式来进行编辑。

您可以缩小“时间轴”面板中的垂直空间,该空间用于触发器和发音嘴型的镜头栏以实现更简洁的用户界面

可编辑的触发器镜头
可编辑的触发器镜头

各种参数如下所示。

  • 选择触发器栏:单击栏的中间或左边缘。要选择多个栏,请按住 Shift 键并单击、按住 Cmd/Ctrl 键并单击或在栏上拖动选框。
  • 更改触发器栏的时间:水平拖动中间或其左边缘以调整其开始时间,或拖动其右边缘调整结束时间。左边缘贴靠到播放指示器或镜头栏的开始或结束时间。
  • 切换到交换集中的其他触发器:在触发器栏上右键单击,然后在交换集中选择其他触发器。

提示:如果播放指示器停放在触发器栏上方,则可以取消备录人偶或其触发器行为以查看对触发器的更改。您还可以在时间中划动播放指示器以查看更改。

  • 插入触发器镜头:在触发器栏之前、之后或之间的间隙上单击右键,然后选择可用触发器。新触发器栏在您单击的时间位置启动。
  • 将触发器栏拆分为两部分:选择触发器栏,然后选择“编辑”>“拆分”(Cmd/Ctrl+Shift+D),以在播放指示器处拆分;或按正斜杠 (/),将其拆分为两半。
  • 删除触发器栏:选择触发器栏,然后选择“编辑”>“删除”(Delete 或 Backspace 键);或在其中一个触发器栏上右键单击,然后选择“删除”
     

要隐藏触发器和发音嘴型的镜头栏,请取消选择“显示触发器”“发音嘴型的镜头栏”菜单命令。

重放:可重复使用且可触发的录制内容

使用重放触发人偶的已录制镜头,用于直播或重新录制。例如,可创建这些可重复使用的镜头,以便在视频直播期间重复不同的表演,或在录制的同时重复特定的眼睛注视动作或手臂姿态。部分需使用循环人偶的场景,可通过重放已录制的表演来代替。

重放代表专门选定的镜头,且可以与触发器关联,您可为关联的触发器分配键或 MIDI 音符以调用这些镜头。导出人偶时也会包含重放,这样其他人也能触发您共享的录制表演内容。

在 Character Animator CC 中重放

创建和编辑重放

要创建重放和触发器,请执行以下步骤:

  1. 在“时间轴”面板中选择一个或多个镜头栏。

  2. 右键单击选定的镜头,然后使用命令创建重放并为其分配触发器(新触发器、现有交换集中的新触发器或现有的触发器)。

为人偶创建的重放显示在“属性”面板的“重放”部分中,并显示重放的持续时间。默认情况下,创建的重放及其触发器均根据这些镜头的行为来命名。如果重放中某个行为包含多个镜头,则镜头的数量会显示在行为名称之后的括号中。

创建的重放
创建的重放

重放的触发器显示在“触发器”面板中,例如显示人偶图层的触发器。选定触发器后,面板底部的“图层和重放”部分会列出相关的人偶图层和重放。单击某个重放的名称,可在“属性”面板中显示该重放。

重放中包含创建该重放时所用镜头的副本,因此需要时可删除原始镜头。

有问题的重放会以橙色显示。将鼠标指针悬停在橙色图标或名称上,可通过工具提示查看更多信息。

选择或取消选择重放

  • 要选择单个重放,对其单击即可。
  • 要选择一系列重放,请单击系列中的首个重放,然后按住 Shift 键并单击系列中最后一个重放。
  • 要选择或取消选择单个重放,请按住 Command 键单击 (macOS) 或按住 Ctrl 键单击 (Windows) 重放。
  • 要选择所有重放,请按 Command+A (macOS) 或 Ctrl+A (Windows)。
  • 要取消选择所有重放,请按 Command+Shift+A (macOS) 或 Ctrl+Shift+A (Windows)。

重命名、重新排序和删除重放以及将重放添加到触发器

  • 要重命名某个重放,请在“属性”面板中将其选中,之后按 Return 键 (macOS) 或 Enter 键 (Windows) 或从上下文菜单中选择“重命名”,更改其名称后,按 Return/Enter 键或单击文本栏以外的任意位置。
  • 要对重放列表中的重放进行重新排序,请将其选中,然后垂直拖动选定的重放。
  • 要删除重放请在“属性”面板中将其选中,然后按 Delete 键。不会删除选定重放中所包含的原始镜头。
  • 要将重放添加到触发器,请在“属性”面板中将其选中,然后将选定的重放拖放到“触发器”面板中。可将重放置于现有的触发器上;也可将重放置于空白位置上,从而为每个选定的重放创建一个新的触发器;还可将重放置于交换集中,以将其添加为交换集的触发器。

回放和录制重放

创建重放时通常会附带相关的触发器(通过键、MIDI 音符或按钮控件调用),但也可直接使用重放。

要回放某个重放,请执行以下操作之一:

• 按下与该重放的触发器关联的键、MIDI 音符或按钮控件(位于“控件”面板中)。

• 在“属性”面板中,单击该重放名称旁边的“播放”按钮。

录制的镜头在重放的回放中,但播放指示器不移动。“属性”面板中重放名称旁边有个小型计量器可显示进度。

提示:要取消重放的回放,请将播放指示器移动至不同的时间。

要录制某个重放,可在开始录制之前或之后调用该重放。完成后停止录制。

注意:

使用“录制 1 帧的镜头”和“录制 2 帧的镜头”命令时,重放会被忽略。
但是,可复制“属性”面板中选定的“重放”并将其粘贴到时间轴中。

在交换集中使用重放触发器

重放可以与任何触发器相关联,包括交换集中的触发器。如果与交换集中的默认触发器相关联,则这些重放将立即回放。

停止和持续重放

默认情况下,回放重放将会全程播放所有已录制镜头,但您可通过“触发时回放”的方式控制回放。

注意:

此功能不适用于使用 Cmd+1、2 或 3 命令创建的、尚未编辑其发音嘴型/触发器值的镜头。这些常数的镜头默认用于“停止/持续”。

要控制某个重放的回放方式,请将其选中,然后将“触发结束的时间”选项设置为以下选项之一:

待重放结束:全程回放该重放的所有已录制镜头,无论其时长。

停止/持续重放:持续回放重放中的镜头,直到您停止触发为止。如果触发的持续时间超过了重放的持续时间,则最后一个混合出点的时间会自动延长。如果您在混合出点的某个镜头期间停止,则触发停止后,该镜头将混合出点。

人偶图层信息

“人偶”面板左侧栏中列出的图层表示:

  • 与键盘触发器关联的字母(如果已为图层指定)。
  • 应用的行为数量和人偶图层源人偶中的手柄数量。

这些详细信息可以帮助您确定行为和手柄在人偶层级中的位置、可用来按下以触发各种操作(显示或隐藏图层、循环图层等)的字母。

人偶图层信息
人偶图层信息

图层和手柄匹配数

当选中“项目”或“人偶”面板中的某个人偶时,“属性”面板中某个行为的图层或手柄参数表示匹配和特定匹配(当旋转打开此参数时)的数量。

针对图层和手柄参数(例如针对“面部”行为的“视图”参数)的多个匹配值在参数工具提示的单独行中显示每个值。

隐藏或显示图层

单击图层的眼球图标。隐藏的图层用一个暗淡的眼球指示,并且不能渲染。

重命名图层

在左侧栏中选择它,按 Enter 键(在主键盘而非数字小键盘上),输入新名称,然后按 Enter 键或在文本字段之外单击以接受更改。相反,按 Esc 键可取消编辑。如果图层有自定义名称,您可以看到图层名称右侧颜色更暗的原始/源名称。

注意:

与“项目”面板中的项目项不同,相同级别层级中的图层可以有相同的名称。

添加内容到人偶

将人偶或图层从“项目”面板拖到在“人偶”面板中打开的人偶上。如果未打开人偶,会将放下的项添加到新人偶。

如果放在左侧栏上,您可以控制将它们添加到层级中的什么位置;当放在面板右侧时,会始终将它们添加到人偶的顶层。放下的项变为图层,并且处于选中状态。与人偶图层不同,图层是其内容的“扁平”再现。

注意:

将人偶添加为图层时,您可以旋转打开图层,以显示所添加人偶中的图层,并在当前人偶的上下文中修改人偶的图层。修改时请小心,因为您在修改所添加人偶的主定义。

混合模式

混合模式控制图层与其下方图层的互动方式。Character Animator 提供一组混合模式,可用于人偶中的任何图层或组。您可以设置不透明度和尝试各种混合模式,以达到不同的效果。

要调整混合模式,请执行以下步骤:

  1. “人偶”面板中选择图层或组。

  2. “属性”面板中,选择“图层”部分,然后调整“不透明度”“混合模式”。

     

    以下说明使用这些术语:

    • 源颜色是指应用混合模式的图层的颜色。
    • 基础颜色是指位于源图层下方的合成图层的颜色。
    • 结果颜色是混合操作的输出;合成的颜色。

    注意:

    您可以为 Photoshop 或 Illustrator 中创建的人偶编辑混合模式和不透明度设置。Character Animator 不支持混合模式和对 Illustrator 图稿文件进行不透明度更改。图稿文件中不支持的混合模式在“人偶”面板中默认为“普通”

    混合模式 描述 示例
    通过 仅对组而言,它允许对组内的图层进行混合模式调整和不透明度调整,以影响组下的图层。
    “普通”优先级 要防止混合和不透明度影响组中图层之外的图层,请将组的混合模式更改为“普通”。
    “普通”优先级 未应用特定混合模式。结果颜色为源颜色。“普通”是默认模式。
    变暗 读取每个通道中的颜色信息,以识别源颜色和基础颜色之间较暗的颜色。较暗的颜色为结果颜色。
    相乘 读取每个通道中的颜色信息,并将源颜色与基础颜色相乘。结果颜色是一种较暗的颜色。将任何颜色与较暗颜色中的黑色结果相乘,以及将任何颜色与较暗颜色中的白色结果相乘。例如,将多个凝胶放在灯光前方。
    颜色加深 读取每个通道中的颜色信息,并且调暗源颜色,以通过提高对比度来反映基础颜色。与白色混合后不产生变化。 
    线性加深 读取每个通道中的颜色信息,并且调暗源颜色,以通过降低亮度来反映基础颜色。与白色混合后不产生变化。
    较暗的颜色 较暗的颜色与调暗类似,但较暗的颜色读取合成颜色通道,而不是单个 RGB 颜色通道。这种混合模式从源颜色和基础颜色中提取最低值,以创建结果颜色。 
    变亮 读取每个通道中的颜色信息,以识别源颜色和基础颜色之间较亮的颜色。较亮的颜色为结果颜色。

    滤色 读取每个通道中的颜色信息,并将源颜色的多个相反颜色与基础颜色相乘。结果颜色是一种较亮的颜色。使用“滤色”模式类似于同时将多个照片幻灯片投影到单个屏幕上。 
    颜色减淡 读取通道中的颜色信息,并且调亮源颜色,以通过降低对比度来反映基础颜色。如果源颜色为纯黑色,结果颜色为基础颜色。 
    线性减淡(添加) 读取通道中的颜色信息,并且调亮源颜色,以通过提高亮度来反映基础颜色。与黑色混合则不发生变化。 
    浅色 较亮的颜色与调亮类似,但较亮的颜色读取合成颜色通道,而不是单个 RGB 颜色通道。这种混合模式从源颜色和基础颜色中提取最高值,以创建结果颜色。

    叠加 源颜色比基础颜色更暗则相乘,源颜色比基础颜色更亮则滤色。得到饱和的颜色。与 50% 灰色混合后不产生变化。
    柔光 使基础图层的颜色通道值变暗或变亮,具体取决于源颜色。结果类似于漫射聚光灯照在基础图层上。如果源颜色比 50% 灰色亮,则结果颜色比基础颜色浅,就好像减淡一样。如果源颜色比 50% 灰色暗,则结果颜色比基础颜色暗,就好像加深了一样。
    强光 基础颜色比 50% 灰色暗则相乘,基础颜色比 50% 灰色亮则滤色。结果类似于耀眼的聚光灯照在图层上。 
    亮光 通过增加或减小对比度来加深或减淡颜色,具体取决于基础颜色。如果基础颜色比 50% 灰色浅,则图层变亮,因为对比度减小。如果基础颜色比 50% 灰色深,则图层变暗,因为对比度增加。

    线性光 通过减小或增加亮度来加深或减淡颜色,具体取决于基础颜色。如果基础颜色比 50% 灰色浅,则图层变亮,因为亮度增加。如果基础颜色比 50% 灰色深,则图层变暗,因为亮度减小。
    点光 根据基础颜色替换颜色。如果基础颜色比 50% 灰色浅,则替换比基础颜色深的像素,而不改变比基础颜色浅的像素。如果基础颜色比 50% 灰色深,则替换比基础颜色浅的像素,而不改变比基础颜色深的像素。
    差值 查看每个颜色通道中的颜色信息,并从较深颜色中减去较浅颜色。与白色混合将反转背景色;与黑色混合则不产生变化。
    排除
    结果类似于“差值”模式,但对比度比差值混合模式低。如果源颜色是白色,则结果颜色为基础颜色的补色。如果源颜色是黑色,则结果颜色为基础颜色。
    相减 从基础颜色中减去源颜色。如果源颜色是黑色,则结果颜色为基础颜色。
    相除 基础颜色除以源颜色。如果源颜色是白色,则结果颜色是基础
    颜色。

重复使用组

  1. 在“人偶”面板的图层列表(左侧)中的组上方单击右键(上下文),然后选择“设为可共享”。此时将显示该图层的源组项,并在“项目”面板中选定。如果已经可以在“人偶”面板中看到源项目,则会禁用此菜单命名。
  2. 在“人偶”面板中打开不同的人偶。

注意:

如果通过导入 Photoshop 或 Illustrator 图稿创建目标人偶,您可关闭人偶的“与图稿自动同步”选项(在“属性”面板中),以避免图稿结构内容变化导致在“人偶”面板中对图层所做的修改丢失。或者,创建一个新的空人偶并将其打开。

  1. 将显示的源项拖动到“人偶”面板中。

更改图层的顺序

要更改图层的顺序,请在侧栏中相对于同级图层垂直拖动它。

注意:

您无法拖动人偶之外的图层,也无法将图层拖入另一组。

修改图层属性

要更改图层的属性(例如位置、比例和旋转),请执行以下操作:
  1. 在左侧栏中选择图层。
  2. 在“属性”面板中,调整以下图层特定的属性:
    • X 和 Y(针对位置)、X 比例和 Y 比例(针对大小)、不透明度以及图层相对于原始变换的旋转(针对旋转)。也可以通过在灰色高亮显示区域内拖动来重新定位所选图层。
    • “独立变形”控制组是否在与人偶中其他图层相同的橡胶板上变形。
    • “附着点”控制保持附着状态的手柄(例如,如果您有一个想与手臂一起移动的手部组)。
    • 触发器部分:指定用来显示图层或启动图层循环的触发器键。有关更多信息,请参阅编辑键盘触发器部分。
  3. 要修改与图层关联的变形网格,请在“图层网格”部分中调整以下属性:
    • “网格形状”控制源人偶变形网格的形状。“矩形”使用内容的矩形定界框、“等高线”遵循内容的轮廓、“自动”(默认)自动使用针对大多数情况的“等高线”或“矩形”(如果检测到断开连接的内容)。
    • “网格扩展”指定将网格从图层边界(等高线或矩形的边界)扩展的像素数。较高的扩展值可以降低曲线边缘出现分割的可能性,但是可导致独立变形(例如,角色的腿部)的区域一起变形。
  4. 如果选中一个人偶图层,请在“行为”部分调整为源(主)人偶应用的行为。您可以添加或删除行为,或者调整行为参数值,就像选中了“项目”面板中的人偶项那样操作。有关更多信息,请参阅使用行为控制人偶

注意:

因为您正在更改源,场景中此人偶的所有实例和其他人偶都将受到影响。

  1. 如果在选中图层的情况下,要想使用更准确的图稿再现,请启用“渲染为矢量”选项。

注意:

因为您正在更改源项,该图层中的所有实例和其他人偶都会受到影响。

从人偶中删除图层

选中它,然后按 Delete 或 Backspace 键,或者选择“编辑”>“删除”。

注意:

删除图层不影响磁盘上的原始图稿。

人偶中的变形会影响它的图层,但是键触发替换之类的功能则需要组。可以将任意数量的图层分为一组。

使用剪切蒙版遮蔽图层

剪切蒙版可让您使用图层内容来遮蔽其上方的图层。遮蔽效果由底部或基础图层的内容决定。基础图层的非透明内容将在剪切蒙版中剪切(显示)其上方的图层的内容。剪切的图层中的所有其他内容将被遮蔽。

可以在剪切蒙版中使用多个图层,但它们必须是连续的图层。蒙版中的基础图层的名称将加下划线,覆盖图层的名称将缩进。覆盖图层会显示一个剪切蒙版图标。

要创建剪切蒙版,请执行以下步骤:

  1. “人偶”面板中,将包含蒙版的图层放在要遮蔽的图层下方,以此方式排列图层。

  2. 选择要遮蔽的图层,然后选择“人偶”>“创建剪切蒙版”(Cmd+Option+G (MAC) 或 Ctrl+Alt+G (Windows))。如果选定的多个图层在图层列表中相邻且不包括组中的最后一个图层,则可以对其进行遮蔽。

    注意:

    如果在剪切蒙版中的图层之间插入一个图层,则该图层将成为其上方的图层的基础图层,不会被剪切。

    “人偶”面板中,蒙版中的基础图层的名称将加下划线,覆盖图层的名称将缩进。覆盖图层还会显示一个剪切蒙版图标。

    使用剪切蒙版掩蔽图层
    使用剪切蒙版掩蔽图层

在剪切蒙版中释放图层

要从图层中释放剪切蒙版,请执行以下步骤:

  1. 请选择基础图层上方的所有连续剪切蒙版图层(带有 图标)。

  2. 选择“人偶”>“释放剪切蒙版”(Cmd+Option+G (MAC) 或 Ctrl+Alt+G (Windows))。

注意:

您在 Photoshop 图稿中创建并导入到 Character Animator 中的剪切蒙版将转换为“人偶”面板中的剪切蒙版。使用 Illustrator 图稿创建的剪切蒙版(<剪切组>)不会转换为“人偶”面板中的剪切蒙版。但是,您可以在“人偶”面板中从来自 Illustrator 的图层创建剪切蒙版。

将一组图层分组

  1. 选择图层并选择“人偶”>“将图层分组”(Cmd/Ctrl+G)。
  2. (建议)将新组重命名为更具描述性的名称。它可以在场景中直接用作一个单独的人偶。最好重命名创建的“组”项目项这样,新的人偶图层将默认使用新的名称。直接重命名人偶图层不会更新源人偶项的名称。

自动附着独立组

操纵带有独立部位的人偶的操作通过将这些独立组自动附着到它们的父级(例如胳膊、腿、与躯干重叠的其他部位或角色的其他部位)而得到简化。对于新导入的图稿,将组的原点定位到您希望它附着的位置。您不必手动装订或使用额外的装订手柄。“人偶”面板中还有一些有用的可视化效果,用于显示这些独立组如何附着到其父组的网格。

要使独立组自动附着到人偶父组的网格,请执行以下步骤:

  1. “人偶”面板中,选择“独立组”。

  2. 在“属性”面板中,在“图层”部分下将“附着点”设置为“自动”

    对于图稿文件中没有特定“附着点”设置的新导入的图稿,“自动”是默认设置。此外,默认“附着样式”设置现在为“粘接”,除非人偶只有一个顶级独立组(例如,图稿文件中的“+Character”),在这种情况下,其顶级组将设置为“自由”。
    提示:将鼠标悬停在“附着点”下拉列表上方,即可暂时显示人偶上所有可用的附着点。

  3. 调整组的位置,使其与父组的网格重叠,然后将组的原点手柄移动到要将组附着到父组的位置。

    自动附着组
    自动附着组
  4. 现在,将组的原点手柄移动到要将组附着到父组的位置。

  5. 组会自动附着到父组。

    注意:

    不会转换 Beta6 或更低版本的项目和 .puppet 文件。如果您拥有包含“摆动”手柄的独立组,并且使用“自由”附着样式附着了组,则在人偶首次出现在场景中时,该组将坠落。根据需要切换到“铰链”“粘接”

在剪切蒙版中释放图层

要从图层中释放剪切蒙版,请执行以下步骤:

  1. 请选择基础图层上方的所有连续剪切蒙版图层(带有图标)。

  2. 选择“人偶”>“释放剪切蒙版”(Cmd+Option+G (MAC) 或 Ctrl+Alt+G (Windows))。

注意:

您在 Photoshop 图稿中创建并导入到 Character Animator 中的剪切蒙版将转换为“人偶”面板中的剪切蒙版。使用 Illustrator 图稿创建的剪切蒙版 () 不会转换为“人偶”面板中的剪切蒙版。但是,您可以在“人偶”面板中从来自 Illustrator 的图层创建剪切蒙版。

图层附着样式选项

当您在“人偶”面板中选择一个图层并选中“独立变形”选项时,“附着点”控件将随新的“附着样式”控件一起启用。提供以下附着样式:

  • 粘接:图层无法移动、旋转或围绕原点缩放。
  • 铰链:图层可以旋转,但无法移动或围绕原点缩放。
  • 自由:图层可以移动、旋转和围绕原点自由缩放。

附着样式

附着样式

图层手柄

可以使用“人偶”面板中的工具创建其行为控件可操纵人偶的手柄。

查看人偶的手柄

取消选中所有图层(或者选中“人偶”面板左侧的顶部标题)或者选中一个组图层。打开或选中的组以及参与相同可变形网格的手柄会显示为黄色圆圈。

“人偶”面板中创建的手柄在圆圈的中间有一个圆点;可以删除、移动和重命名这些手柄。图稿文件中指定的手柄没有圆点,不能移动或重命名。如果轮廓是实心的,则可以删除。如果是虚线,它表示原点手柄,无法删除。

手柄标记

“人偶”面板在人偶右侧显示手柄标记,在“属性”面板中显示基于文字的标记。手柄标记以大号文字显示在手柄右侧。手柄下方正中间的小号文字为手柄名称。命名类似于标记的图稿参考线不会在“人偶”面板中默认拥有名称。

选中或取消选中手柄

要选中或取消选中手柄,请切换到“选择”工具,然后执行以下操作之一:
  • 单击手柄以将其选中。
  • 按住 Shift 键并单击手柄,以延长选择项。
  • 拖动手柄周围的选择框(选框)。按住 Shift 键并拖动,以延长选择项。
  • 在手柄之外单击可取消选中所有手柄。

重新放置手柄

要重新放置手柄,请选中它,然后将它拖到所需的位置。

注意:

无法移动来自图稿文件和圆圈中间未显示黄色圆点的只读位置。

要为人偶重新放置原点手柄,请选中用人偶命名并且默认情况下显示为带网格圆圈的手柄,然后将它拖到所需的位置。您不必在 Photoshop 或 Illustrator 图稿文件中更新原点位置。为组使用“焊接”或“铰接”附着样式时,您可能想将组的原点放在所需的锚点或枢纽位置。

:要将原点手柄的位置重置为人偶边界的中心或图稿文件中的特定位置,请选中手柄,然后按 Delete 键。

重命名手柄

要重命名手柄,请选中它,按 Enter 键(在主键盘而非数字小键盘上),输入新名称,然后按 Enter 键或在文本字段之外单击,以接受更改。相反,按 Esc 键可取消编辑。

使用“人偶”面板中的工具

要在“人偶”面板中创建手柄,请使用以下工具之一:

  • 手柄工具:在所需的位置单击。您可以更改手柄的标记,以供特殊行为使用或用作组的附着点。
  • “骨架”工具:单击一个图层来指定骨架一端,然后拖动到预期骨架的另一端。此时将创建一个带“骨架”标记的骨架手柄。例如,弯曲手臂或腿。避免穿越骨架。
  • “固定”工具:在图层上方的位置单击以防止变形。此时将创建一个带“已固定”标记的手柄。
  • “拖动器”工具:在可变形图层上方的位置单击,以使用“拖动器”行为进行控制。此时将创建一个带“可拖动”标记的手柄。
  • “摆动”工具:在可变形图层上方的位置单击,以使用“摆动”行为进行摇摆。此时将创建一个带“摆动”标记的手柄。

“固定”、“拖动器”、“摆动”和“骨架”工具不仅是与“手柄”工具作用相同的专业工具,也针对特定用途标记创建的手柄。

将标记应用于手柄

您可以将标签应用到原点手柄。例如,为了能通过鼠标或手指在触摸屏上拖动人偶,可选中原点手柄并分配“可拖动”手柄标记。

要为图层或手柄编辑标记,请执行以下操作:

  1. 在“人偶”面板中,选中图层或手柄。
  2. 在“属性”面板的“标记”部分中,选中或取消选中要与选择项关联的功能。

  • 所选标记仍要求在人偶层级中的相关级别或更高级别应用使用这些标记的相应行为。例如,为手柄选择“胸部”标记不会做任何事情,除非也将“呼吸”行为应用到了父人偶。
  • 图稿文件中层级和图层名称的更改将重置与受影响图层关联的所有标记。但是,图层内容的更改会保留在“人偶”面板中更改的所有标签。

当选中图层时,您可以应用图层或手柄标记,将手柄标记应用到所选组的原点手柄,或者在图层的父人偶中这么做。当选中手柄时,只可以应用手柄标记。

以文本形式查看标记时,应用的图层标记为蓝色,手柄标记为黄色。将标记视为图片时,应用的标记是蓝色的。

注意:

通过为骨架手柄指定一个“可拖动”手柄,可以像其他手柄一样修改骨架手柄。

删除手柄

要删除手柄,请选中它,然后按 Delete 或 Backspace 键,或者选择“编辑”>“删除”

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略