用户指南 取消(C)

触发和控制人偶

创建触发器以实现通过按键控制组和图层功能的显示或隐藏。您可以创建各种不同的触发器(包括“手位置”、“循环火球”和“眨眼周期”)以控制您的人偶。 

如需使用触发器控制角色的教程,请单击此处

触发器行为和“触发器”面板

默认情况下,触发器行为将应用于新人偶。利用该行为可触发图稿,也可设置自定义名称的触发器用于引用不同组中的图层。这些命名触发器列在“触发器”面板中,您可以在此面板中为触发器分配按键,查看触发器控制的图层列表,甚至可使用连接的 MIDI 设备关联 MIDI 音符以触发图稿。 

“触发器”面板
“触发器”面板

有两种类型的触发器:
• 单个触发器 - 默认情况下,这些触发器会隐藏图层,但按住某个键或 MIDI 音符/控件运行时会显示图层,例如,按 H 键在角色上显示一顶帽子。
• 交换集 – 其中一次只显示一个触发器,例如不同的手势。这组触发器与人偶中的一组图层相关联。组合中的每个触发器都有其自己的触发器键或 MIDI 音符,并且其中一个触发器可以是默认值。

单击与触发器关联的图层的名称可以将该图层显示在“人偶”面板中。如果您想要显示人偶中的某个图层或组,而不影响任何其他图层或组,请使用单独的触发器。如果您希望该图层或组同时还隐藏其他图层或组(例如,按 B 以在另外还拥有“瞳孔”和“眼球”图层的组中显示“眨眼”图层),请使用交换集。

注:已弃用的键盘触发器行为仍可以继续使用,但如果要使用新的触发器面板,且没有任何必须保留的较低版本键盘触发器录制内容,请将其替换为“触发器”。

创建和编辑触发器

“操纵”工作区中的“触发器”面板默认为打开状态。您也可以使用“窗口”>“触发器”菜单命令打开或关闭此面板。

创建显示人偶图层的单个触发器

执行以下任一操作:
• 为尚未分配触发器的人偶图层(其触发器列中无任何图标)单击其触发器列 (),然后选择“创建触发器”

• 在“人偶”面板中右键单击图层,然后选择“创建触发器”

• 将图层从人偶面板拖放到触发器面板。

将该图层放置到某个交换集上,以将其添加到该交换集。将其放置到任意其他位置以创建一个单独的触发器。

• 在“触发器”面板中单击“添加”(+) 按钮,然后选择“创建触发器”以创建一个空触发器。之后,将人偶图层拖动或添加到该触发器中。

有问题的触发器(键位冲突、无图层等等)会显示为橙色。将鼠标指针悬停在触发器上可查看详情。工具提示也会说明缺少图层。

创建触发器交换集

执行以下任一操作:
• 针对其图层尚未分配触发器交换集的人偶组(其触发器列中无任何图标),单击其触发器列 (),然后选择“创建交换集”

• 右键单击人偶面板中的一组图层,然后选择“创建交换集”

• 在触发器面板中单击“添加”(+) 按钮,选择“创建交换集”,然后将单个触发器或(希望用作单个触发器的)人偶图层拖放到其中。

在“触发器”面板中创建一组新的触发器,每个触发器均以所选图层的名称命名。如果组中的任何人偶图层都可见,则最上面的图层会变成交换集中的默认触发器。您可以重命名交换集,并选择不拥有默认触发器。

为触发器分配标签

为触发器分配标签颜色,以便在触发器面板中轻松识别相关的触发器或交换集。您甚至可以对“触发器”面板进行筛选,以显示具有匹配颜色的触发器和交换集。

具有已分配标签的触发器

选择一个或多个触发器或交换集,然后右键单击其中一个项,最后从标签颜色列表中选择所需选项。无标签的情况,会设置为“无”。默认情况下不分配标签。

右键单击具有标签颜色的触发器或交换集,然后选择“选择标签组”。

在触发器面板的搜索筛选器字段中,键入“label:颜色”(例如“label:re”可显示具有“Red”或“Green”标签的项)。

设置默认触发器

要将交换集中的特定触发器设置为默认触发器,请执行以下任一操作:
• 选择该触发器,然后选择面板底部的“默认”选项。
• 单击触发器名称旁边的触发器图标。
• 双击触发器名称。
默认触发器将使用较亮的实心图标和较亮的名称进行标识。如果您不想在默认情况下触发任何图层,请重复以上步骤来切换“默认”选项。

向现有触发器分配图层或组

要向现有触发器分配图层或组,请执行以下任一操作:
• 在“人偶”面板中右键单击图层或组,选择“添加到触发器”, 然后从上下文菜单中选择特定触发器。
• 在触发器面板中将图层或组拖到触发器上。

配置调用触发器设置

要更改触发器的启动方式:在触发器面板中选择触发器,然后执行以下任一操作:

  • 在键盘列中输入一个键位。
  • 单击“MIDI 音符”字段,然后在 MIDI 设备上点击该键或输入其 MIDI 音符编号。
  • 要锁存触发器,以便无需按住键盘或 MIDI 键即可保持触发状态,可启用面板底部的“门栓”选项。
  • 向现有触发器添加图层或重放,会选中触发器面板中的目标触发器。

还可以更直接地在“控件”面板的布局模式下执行向触发器分配键和 MIDI 音符的操作。有关更多信息,请参阅布局模式

重命名、重新排列或组合触发器或交换集

要重命名触发器或交换集,请在“触发器”面板中将其选中,然后按 Enter 键(在主键盘而不是数字小键盘上)并输入新名称。要接受更改,按 Enter 键或在文本字段外单击。相反,按 Esc 键可取消编辑。

要重新排列触发器并将触发器在交换集内部移动、移入交换集或移出交换集,请选择一个或多个触发器,然后在面板中拖动它们。将一个交换集拖动到另一个交换集上可将它们的触发器合并到一个交换集中。当您想要基于列出的顺序设置触发器的优先级时,重新排列交换集中的触发器也很有用。

要合并触发的图层,请将一个触发器拖动到另一个触发器上。已放下的触发器的图层将重新分配给目标触发器。随后将删除已放下的触发器。

要将一个交换集中的触发器合并到另一个交换集中,请将该交换集拖动到另一个交换集之上或之中。已放下的交换集的触发器将添加到目标交换集。目标交换集的默认触发器仍为默认触发器。

 

注意:

如果将人偶组设为可共享,则分配给组图层的任何触发器将移动到共享人偶。这些触发器的任何控件(显示在“控件”面板中)仍与父级人偶(而不是共享的人偶)相关联。您可以为共享人偶的触发器生成控件。

查看或显示触发器

要查看或显示与人偶中的图层相关联的触发器,请执行以下任一操作:

• 将鼠标悬停在人偶面板中图层行的“触发器”图标上。显示图层的触发器(以及所有触发器键)的列表显示在“工具提示”中。
• 在图层行中单击“触发器”图标以在“触发器”面板中显示触发器。
• 如果一个图层分配给了多个触发器,在图层行中单击带有箭头的“触发器”图标,然后选择要在“触发器”面板中显示的特定触发器。

提示:单击打开与交换集中的某个触发器相关联的图层(在“人偶”面板中)所对应的眼球,将自动关闭该交换集中触发的其他图层所对应的眼球。按住 Option/Alt 键并单击可覆盖眼球自动切换。

调用了多个触发器时配置触发器的行为

要在同时调用了多个触发器时更改交换集中的触发器行为,请选择交换集,然后将“优先级”设置为“最近”以使最近使用过的触发器优先,或者设置为“列出的顺序”以使列在“触发器”面板最上面的触发器优先。将会显示优先的触发器的图层。

删除图层

要删除与触发器相关联的图层,请在触发器面板中选择触发器,然后在面板底部单击要删除图层旁边的“x”。

注:删除与触发器相关联的所有图层不会自动删除触发器。

删除触发器或交换集

要删除触发器或交换集,请将其选中,然后选择“编辑”>“删除”(Delete 或 Backspace 键)。

注意:

头部和身体转动、嘴形同步、运动触发器和面部(适用于眨眼)触发器图层等行为独立于触发器行为。若要在相同人偶组中通过触发器触发的图层使用这四种行为,请将“隐藏组中的其他图层”选项设置为不由这四种行为触发的图层。使用该选项,图层顺序将决定优先级。除此之外,也可更改图稿文件的结构。

在人偶之间复制触发器

注意:

您可以从一个人偶复制触发器并将其粘贴到具有交换集和触发器并匹配相同名称的另一个人偶。在录制这些触发器的镜头之前,从原始人偶复制这些交换集和触发器。否则,粘贴的触发器不起作用。

要设置人偶之间的触发器兼容性,请执行以下步骤:

  1. 选择要复制其触发器的源人偶。从“触发器”面板中,选择要复制的交换集和触发器。

  2. 要复制触发器,请选择“编辑”>“复制”。要在人偶之间移动切换集或触发器,请选择编辑 > 剪切。

  3. 选择希望将这些交换集或触发器复制到的至九个常见的位置。

  4. 聚焦“触发器”面板后,选择编辑 > 粘贴

粘贴的交换集和触发器会显示在触发器列表的底部。您可根据自己的意愿移动它们。您现在可以在这两个人偶之间复制任何触发器录制。

如果您使用 2017 年 10 月版或之前的版本创建了键盘触发器,则可以将键盘触发器转换为触发器,以便充分利用更灵活的触发功能和使用控件面板。请注意,使用键盘触发器行为的现有项目和 .puppet 文件仍可继续使用。

对于基于触发器的人偶,可以使用触发器或控件面板查看分配给某个人偶的所有触发器键。

“控件”面板:人偶触发器和行为参数的自定义布局

使用“控件”面板可获得一个可视界面或功能板,您可在其中访问人偶触发器或支持的行为参数。选择您希望轻松访问的触发器和行为参数(数字和角度值),并从一个位置控制它们。随后这些自定义控件会与人偶相关联。这些控件还能作为导出的人偶的一部分,与他人共享。

默认情况下,“控件”面板会在“录制”“流”工作区中打开,但您也可使用“窗口”>“控件”菜单命令打开。此面板可显示与“项目”“时间轴”面板所选人偶相关联的控件,或与“人偶”面板中所打开人偶相关联的控件。

“控件”面板有两种模式:

  • “布局”模式:您可以在此处自定义控件的内容和外观。
“布局”模式
“布局”模式

  • “执行”模式:使用此模式时可通过单击面板顶部的链接使用各种控件。
“执行”模式
“执行”模式

“布局”模式

可将人偶的触发器可视化,变成可点击的按钮,并为各个触发器配上对应的图稿。触发器上还可设置关联的各种键或 MIDI 音符。您可以将人偶的行为参数可视化为可调滑块或角度控件,以及与之关联的任何 MIDI 注释。布局随人偶一起存储(包括导出为 .puppet 文件时),以便您与他人共享触发器布局。

“布局”模式下可用的控件如下。

将控件添加到面板中:选择人偶,然后选择下列选项之一:

  • 如果面板为空,请在面板中单击为“人偶名称”生成控件链接,以基于人偶触发器创建按钮控件。
  • 如果最近曾将触发器添加到触发器面板中或您之前删除了部分触发器控件,请单击“刷新控件”按钮。这会为新增的触发器或之前已删除的触发器控件添加按钮。
  • 在时间轴面板中选择了人偶轨道后,将任意数字行为参数的名称从属性面板拖动到控件面板中。您可以在这些参数名称上右键单击并选择“添加到控件面板”。

要创建用于特定触发器的控件,请执行以下操作之一:

  • 在触发器面板中选择触发器或交换集,然后将它们拖动到控件面板中。
  • 右键单击触发器或交换集,然后在上下文菜单中选择“添加到控件面板”。

选择或取消选择多个控件:请执行以下任一操作:

  • 按住 Shift 键并单击或按住 Command/Ctrl 键并单击控件。 
  • 在控件周围拖动(选框)并选择。按住 Shift 或 Command/Ctrl 可切换选择选框选择的控件。 
  • 按 Command/Ctrl+A 可选择所有控件。
  • 按 Shift+Command/Ctrl+A 可取消选择所有控件。

重新排列控件:执行以下任一操作

  • 在面板中拖动所选控件。拖动的控件可以贴靠到网格布局。 
  • 按住 Option/Alt 键并单击“刷新布局”按钮,以根据面板的当前大小重排当前这些控件。

要分配其他键或 MIDI 控件:选择控件并点击要使用的键或触摸要使用的 MIDI 控件(按钮、滑块或旋钮)。此控件等效于在“触发器”面板中更改键或 MIDI 音符。与 MIDI 控件关联的控件在“布局”模式中显示为绿色叠加。

要轻松备录或取消备录参数而不在“属性”面板中查找控件,对行为参数使用滑块和旋钮控件以使用“录制准备”按钮。

注意:只有在选择了人偶轨道后才能使用该控件。

取消为控件分配键或 MIDI 音符/控制器:请执行以下任一操作:

  • 右键单击控件并选择“删除触发器键”、“删除 MIDI 音符”或“删除 MIDI 控制器”(适用于行为参数控件)。
  • “触发器”面板中删除“MIDI 音符”字段的内容。

更改与多个人偶图层相关联的触发器按钮上的图稿:右键单击按钮控件,然后单击图层名称。

更改控件的背景颜色(用于改进与深色图稿的对比),右键单击控件,然后选择“浅色”或“深色”。

更改滑块或角度参数控件的值范围:单击或划动控件上的蓝色最小值(左侧)和最大值(右侧)。例如,如果添加了“变换”>“缩放”参数,但无需负值缩放,请将最小值设置为 0。

删除控件:选中控件,然后选择“编辑”>“删除”(Delete 或 Backspace)或单击面板底部的“删除选定的控件”按钮。

 

按钮控件的自定义图稿

您可以通过在人偶的图稿文件任何位置创建按钮控件来使用它的自定义图稿。要为已将多个图层分配给其触发器的按钮选择不同的图稿,请右键单击按钮并在上下文菜单顶部选择图层名称。

如果它影响人偶在场景中的外观,请关闭它的眼球。

  • 要将自定义图稿分配给按钮,请将图层从“人偶”面板拖放到按钮控件上。

从布局模式切换到执行模式

要切换回“执行”模式,“布局”模式下在任何控件之外双击。
选项卡是默认分配的在版面和执行模式之间快速切换的快s捷键。您还可以使用窗口类别为键盘快捷方式编辑器中的切换控件面板版面模式命令指定快捷方式。

“执行”模式

当您要使用控件时,请单击“执行”以切换到“执行”模式。您可以单击该按钮或按分配的键或触摸所分配的 MIDI 控件以执行操作。

平移内容

可以平移“控件”面板的內容以查看可视区域外的控件。
要在“控件”面板中平移,请执行以下任一操作:

  • 使用垂直或水平滚动条。
  • 请在面板中拖动的同时按住 Option/Alt 键或鼠标中键。
  • 要水平滚动,旋转鼠标滚轮可垂直滚动,或者在旋转鼠标滚轮的同时按住 Shift 键。

重命名行为参数控件

在“控件”面板中,行为参数包含根据参数命名的控件。这些控件可重命名。请执行以下步骤:

  1. “控件”面板切换到“布局”模式。

  2. 您可选择行为参数控件,然后按 Return 键 (macOS) 或 Enter 键 (Windows);或右键单击某个行为参数控件,然后选择“重命名”

  3. 请键入想要使用的名称,然后按 Return/Enter 键,或单击编辑栏以外的任意位置。

触发音频

使用可触发音频让人偶更加生动。通过将音频添加到触发器,可在调用触发器时,播放或录制音频。例如,您可以让某个角色在触发了叫喊面部表情时,发出叫喊的声音。

要使用某个音频文件创建可触发音频,请执行以下步骤:

  1. 将该音频文件导入项目。如需一些示例音频文件,请单击此处
  2. 将音频文件拖动到项目面板中的人偶上。

这样即可创建一个分配给新触发器的音频重放。您可以为此触发器分配某个按键,并将其用作触发器或重放。音频重放(在属性面板的“重放”部分中)的波形图标位于播放按钮旁,而其特定音频的设置位于面板的底部。

要在新的重放和触发器中包含场景音频,请执行以下步骤:

  1. 选择音轨以及要在重放中包含的人偶镜头。
  2. 右键单击所选镜头轨道或音轨,然后选择“创建重放和触发器”或“在交换集内创建重放和触发器”命令。

回放音频触发器

使用音频触发的触发器,能够与其他使用分配按键的触发器一样,进行回放和录制。录制后,它们会显示为时间轴面板中的触发器条,而不是单独的音轨。当回放这些触发器条时,也会回放触发器重放中的关联音频。

注意:

在时间轴中拖动时(即拖动音频)不会回放与所录制触发器相关联的音频,在从场景音频创建镜头时也不会使用该音频(例如“使用场景音频计算唇形同步”命令)。此外,如果您拆分包含音频重放的触发器条,则音频会从每个触发器条的开头开始播放 - 拆分触发器条不会拆分音频。

提示:如果您导入的人偶所附带的音频重放当前不在项目中,您可以通过从音频重放的上下文菜单中选择“开始共享此音频”以将其添加到项目中

衰减器:通过触发器淡入和淡出组

您可以使用键盘触发器控制人偶的不透明度。您可以使用此行为显示或隐藏人偶的特定部位,方法是使用触发器(例如键盘触发器)淡入或淡出该部位(组)的不透明度。

设置

将此行为添加到您要淡入和淡出的人偶的特定组。默认情况下,此行为不会应用于人偶。要获得最佳结果,请避免在同一组中应用“衰减器”“变换”。您还可以为组分配触发器键。如果要通过点击键而不是按住它来切换淡入和淡出,可将键设置为栓上。

注意:

当包含重叠图层的组设置为“正常”混合模式且人偶正在使用“组不透明度”时,分别淡化图层直至达到最终的不透明度级别。解决方法:将组的不透明度设置为 99.9%。

控制

使用“持续时间”参数控制不透明度增大或减小的速度(以秒为单位)。

编辑触发器镜头

通过启动触发器所录制的镜头会作为触发器栏显示在“时间轴”面板中。您可以采用编辑发音嘴型时间。

您可以缩小“时间轴”面板中的垂直空间,该空间用于触发器和发音嘴型的镜头栏以实现更简洁的用户界面。

可编辑的触发器镜头
可编辑的触发器镜头

各种参数如下所示。

  • 选择触发器栏:单击栏的中间或左边缘。要选择多个栏,请按住 Shift 键并单击、按住 Command/Ctrl 键并单击或在栏上拖动选框。
  • 更改触发器栏的时间:水平拖动中间或其左边缘以调整其开始时间,或拖动其右边缘调整结束时间。左边缘贴靠到播放指示器或镜头栏的开始或结束时间。 
  • 切换到交换集中的其他触发器:在触发器栏上右键单击,然后在交换集中选择其他触发器。

提示:如果播放指示器停放在触发器栏上方,则可以取消备录人偶或其触发器行为以查看对触发器的更改。您还可以在时间中划动播放指示器以查看更改。

  • 插入触发器镜头:在触发器栏之前、之后或之间的间隙上单击右键,然后选择可用触发器。新触发器条在您单击的时间位置启动。
  • 将触发器栏拆分为两部分:选择触发器栏,然后选择“编辑”>“拆分”(Command/Ctrl+Shift+D),以在播放指示器处拆分;或按正斜杠 (/),将其拆分为两半。
  • 删除触发器栏:选择触发器栏,然后选择“编辑”>“删除”(Delete 或 Backspace 键);或在其中一个触发器栏上右键单击,然后选择“删除”
     

要隐藏触发器和发音嘴型的镜头栏,请取消选择“显示触发器”“发音嘴型的镜头栏”菜单命令。

重放:可重复使用且可触发的录制内容

使用重放触发人偶的已录制镜头,用于直播或重新录制。例如,可创建这些可重复使用的镜头,以便在视频直播期间重复不同的表演,或在录制的同时重复特定的眼睛注视动作或手臂姿态。部分需使用循环人偶的场景,可通过重放已录制的表演来代替。 

重放代表专门选定的镜头,且可以与触发器关联,您可为关联的触发器分配键或 MIDI 音符以调用这些镜头。导出人偶时也会包含重放,这样其他人也能触发您共享的录制表演内容。 

录制过程中触发的重播显示为多个镜头栏。使用智能重播时触发的重播显示为触发器栏,从而实现了更简单、更紧凑且更易于重播的时间轴。有关更多信息,请参阅智能重播

在 Character Animator 中重播

创建和编辑重放

要创建重放和触发器,请执行以下步骤:

  1. 在“时间轴”面板中选择一个或多个镜头栏。

  2. 右键单击选定的镜头,然后使用命令创建重放并为其分配触发器(新触发器、现有交换集中的新触发器或现有的触发器)。

为人偶创建的重放显示在“属性”面板的“重放”部分中, 并显示重放的持续时间。默认情况下,创建的重放及其触发器均根据这些镜头的行为来命名。如果重放中某个行为包含多个镜头,则镜头的数量会显示在行为名称之后的括号中。使用属性面板中的搜索筛选器来搜索之前创建的重放。

创建的重放
创建的重放

重放的触发器显示在“触发器”面板中,例如显示人偶图层的触发器。选定触发器后,面板底部的“图层和重放”部分会列出相关的人偶图层和重放。单击某个重放的名称,可在“属性”面板中显示该重放。 

重播中包含创建该重播时所用镜头的副本,因此需要时可删除原始镜头。 

有问题的重播会以橙色显示。要在工具提示中查看更多信息,请将鼠标悬停在橙色图标或名称上。未分配触发器的重播也会显示为橙色。将鼠标悬停在其上方时,工具提示会显示“重播没有触发器”。

您还可以创建定格重放并与行为参数的多种其他动作创建混合定格重放。了解更多信息,请参阅行为参数菜单

选择或取消选择重放

  • 要选择单个重放,对其单击即可。
  • 要选择一系列重放,请单击系列中的首个重放,然后按住 Shift 键并单击系列中最后一个重放。
  • 要选择或取消选择单个重放,请按住 Command 键单击 (macOS) 或按住 Ctrl 键单击 (Windows) 重放。
  • 要选择所有重放,请按 Command+A (macOS) 或 Ctrl+A (Windows)。
  • 要取消选择所有重放,请按 Command+Shift+A (macOS) 或 Ctrl+Shift+A (Windows)。

重命名、重新排序和删除重放以及将重放添加到触发器

  • 要重命名某个重播,请在属性面板中将其选中,之后按 Return 键 (macOS) 或 Enter 键 (Windows) 或从上下文菜单中选择“重命名”,更改其名称后,按 Return/Enter 键或单击文本栏以外的任意位置。
  • 要对重播列表中的重播进行重新排序,请将其选中,然后垂直拖动选定的重播。
  • 要删除重放请在“属性”面板中将其选中,然后按 Delete 键。不会删除选定重放中所包含的原始镜头。
  • 要将重播添加到触发器, 请在“属性”面板中将其选中,然后将选定的重播拖放到“触发器”面板中。可将重放置于现有的触发器上;也可将重放置于空白位置上,从而为每个选定的重放创建一个新的触发器;还可将重放置于交换集中,以将其添加为交换集的触发器。

回放和录制重放

创建重放时通常会附带相关的触发器(通过键、MIDI 音符或按钮控件调用),但也可直接使用重放。

要回放某个重放,请执行以下操作之一:

• 按下与该重放的触发器关联的键、MIDI 音符或按钮控件(位于“控件”面板中)。

• 在“属性”面板中,单击该重放名称旁边的“播放”按钮。

录制的镜头在重放的回放中,但播放指示器不移动。“属性”面板中重放名称旁边有个小型计量器可显示进度。

提示:要取消重放的回放,请将播放指示器移动至不同的时间。

要录制某个重放, 可在开始录制之前或之后调用该重放。完成后停止录制。

注意:

使用“录制 1 帧的镜头”和“录制 2 帧的镜头”命令时,重放会被忽略。
但是,可复制“属性”面板中选定的“重放”并将其粘贴到时间轴中。

在交换集中使用重放触发器

重放可以与任何触发器相关联,包括交换集中的触发器。如果与交换集中的默认触发器相关联,则这些重放将立即回放。

停止和持续重放

默认情况下,回放重放将会全程播放所有已录制镜头,但您可通过“触发时回放”的方式控制回放。

注意:

此功能不适用于使用 Command+1、2 或 3 命令创建的、尚未编辑的镜头发音嘴型/触发器值的镜头。这些常数的镜头默认用于“停止/持续”。

要控制某个重放的回放方式,请将其选中,然后将“触发结束的时间”选项设置为以下选项之一:

待重放结束:全程回放该重放的所有已录制镜头,无论其时长。

停止/持续重放:持续回放重放中的镜头,直到您停止触发为止。如果触发的持续时间超过了重放的持续时间,则最后一个混合出点的时间会自动延长。如果您在混合出点的某个镜头期间停止,则触发停止后,该镜头将混合出点。

智能重放:创建更简单、更紧凑且更易于修改的重放

智能重放简化了在时间轴中查看和编辑重放的方式。 在新场景中,录制期间触发的重播现在显示为触发器栏,而不是多个拍摄栏,实现更简单、更紧凑且更易于修改的时间轴。

注意:

默认情况下,新场景将启用智能重播。现有场景将不会自动启用智能重放,因为“智能重放”会更改现有触发器使用重放处理动画的方式。

使用智能重放

请按照以下步骤创建智能重放:

  1. 时间轴面板中选择一个或多个镜头栏。

  2. 在其中一个选定的镜头栏上单击右键,然后选择创建重播和触发器

  3. 分配一个触发键 (在触发器面板中)或 一个"控制" 按钮(在控件面板中)。

  4. 要确认为场景启用了智能重播,请在项目面板中选择场景,然后在属性面板中,确保选中了智能重播选项。

  5. 启用智能重播后,请按照以下步骤,使用新的重播来记录性能:

    • 取消备录(红色圆圈按钮)除触发器外的所有行为。选择录制。按下触发器的键或控制按钮以进行重播。选择停止

您的录制会以合并智能重播形式显示在时间轴上。

将旧的或过时的键盘触发器转换为触发器

注意:

“人偶”面板中的旧键盘列不再存在。在“属性”面板的“键盘触发器(过时)”部分中编辑过时触发器的键。您还可以更改“门栓”和“隐藏组中的其他图层”设置。“隐藏组中的其他图层”设置仍适用于触发器行为所使用的触发器键。

要将人偶从键盘触发器转换为触发器,请执行以下步骤:

重要说明:以下过程将删除现有的键盘触发器录制。

  1. 在“项目”面板中选择人偶。

  2. 选择人偶 > 转换过时触发器键

    触发器行为替换键盘触发器行为。现有的触发器键将转换为“触发器”面板中的等效触发器。

  3. (可选)通过将一个触发器拖动到另一个触发器的上方来整合“触发器”面板中的所有无关紧要的触发器。

    如果您转换了导入的 .puppet 文件,请将人偶导出为新 .puppet 文件以保留这些更改。

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]