人偶是创建自 Photoshop 或 Illustrator图稿并受控以创建表演的对象/角色。您随时可以切换到 Photoshop 或 Illustrator 进行图稿更改,或者使用 Character Animator 中的标记来控制行为。

人偶包含图层,其中一些图层是组。带有旋转向下箭头的图层被称作“组”。您可以选择图层来修改其属性、从“项目”面板中的部件组装人偶(包含来自多个人偶或图稿文件的部件)、重新排列和重新放置图层,以及隐藏或显示图层。

您可以从结构合理的图稿文件创建人偶,或者从空人偶开始,借助其他人偶的片段或导入的图稿文件来打造人偶。您还可以复制人偶,以创建其他工作需要的不同版本。

然后,可以选择图层和手柄并为它们分配标记,以控制其行为。有关分配标记的信息,请参阅准备图稿

Adobe Sensei 提供的角色工具可快速生成具有一定样式的 Character Animator 人偶。可使用网络摄像头拍摄的用户图像和任意参考图稿来生成人偶。有关更多信息,请参阅使用角色工具创建人偶

在 Character Animator 中从图稿创建人偶

要从 PSD 或 AI 文件创建人偶,请执行以下操作:
  1. 选择“文件”>“导入”(Cmd/Ctrl+I)。

  2. 选择一个或多个 .ai 或 .psd 文件,然后单击“打开”

    对于每个所选图稿文件,会在“项目”面板中创建一个人偶(用图稿的文件名命名)。

从模板创建人偶

要从模板 PSD 或 AI 文件创建一个人偶,请在“开始”工作区中使用 Chloe 人偶链接。可以将模板 PSD 或 AI 文件的副本复制到项目文件夹、导入到项目、添加到新场景,以及在 Photoshop 或 Illustrator 中打开 PSD 或 AI 文件进行更改。将所做的更改保存到文件后,切换回 Character Animator。人偶将更新以进行匹配。

创建空人偶

要创建空人偶,请选择“人偶”>“新建空人偶”,然后为人偶项命名。

注意:

空人偶未应用任何默认行为。

复制人偶

要复制人偶,请选中它,然后选择“编辑”>“复制”(Cmd/Ctrl+ D)。

在“项目”面板中复制某个人偶项,会为人偶中的所有组和图层创建一个单独的副本。这样,您可以防止一个人偶中的更改影响复制的人偶。

共享人偶

将某个人偶导出为 .puppet 文件,可与其他 Character Animator 用户共享该人偶。人偶文件是随时可导入的自包含文件,其中包括与人偶关联的所有图稿。

  1. 在“项目”面板中,选择或打开人偶。

  2. 选择“文件”>“导出”>“人偶”,然后为 .puppet 文件命名。

  3. 通过共享链接或任何其他共享方法可将 .puppet 文件发送给其他用户。

  4. 要打开共享人偶,请通过“文件”>“导入”或将其拖入“项目”面板来导入 .puppet 文件。

    注意:

    • 您可以将人偶重新链接到图稿的共享实例。
    • 在时间轴或人偶轨道的任何录制镜头中选定人偶时,对人偶所做的参数更改不会包含在 .puppet 文件中。
    • 对导入人偶上的行为进行了更新,以使用当前项目适用的行为版本。

循环人偶

从要与循环图层行为配合使用的图像(PNG 格式)序列中创建启用循环的人偶。此行为按可用于重复图案的顺序显示人偶的每个图层。

创建循环人偶

  1. 在“人偶”面板中打开人偶,单击“添加循环”或选择“文件”>“导入循环”

  2. 若要使用“添加循环”选项创建循环人偶,请从序列中选择一个 PNG 或 JPEG 文件。

    注意:

    序列是拥有相同基本名称和数字后缀(例如 Flap001.png、Flap002.png 等)的多个 PNG 文件。

    此时会在“项目”面板中创建已应用循环图层并在创建 PNG 或 JPEG 序列后命名的人偶,然后在“人偶”面板中添加到当前所选的图层上。

  3. 若要使用“导入 PNG 循环”选项创建循环人偶,请从“项目”面板将创建的循环人偶拖入“人偶”面板中的人偶。

    注意:

    • 使用“导入循环”菜单命令创建的循环人偶会将“循环图层”行为的“开始”参数设置为“立即”,这样添加人偶到场景时会自动显示循环。
    • 使用“添加循环”按钮创建的循环人偶会将“开始”参数设置为“触发时”。如果将通过按键触发循环,这非常有用。
    • 默认情况下,除了循环人偶中的第一个图层,其他所有图层都会关闭,所有图层将会设置为“隐藏组中的其他图层”,这样,单击图层的眼球图标会自动隐藏上一个显示的图层。

将人偶放在场景中

首先将人偶放在场景中,以此来查看和控制人偶。您可以在场景中放置多个人偶。

要将人偶放在场景中,请执行下列操作之一:

  • 在“项目”面板中选择人偶,然后单击“添加到新场景”,或者选择“对象”>“添加到新场景”
  • 将人偶从“项目”面板拖入在“场景”或“时间轴”面板中打开的场景。
  • 如果“场景”和“时间轴”面板为空(即,未打开场景),拖动的人偶则会添加到新场景。
  • 将人偶拖入“项目”面板中列出的现有场景。

人偶会显示场景中,人偶的轨道项也会显示并且在“时间轴”面板中选定。通过此轨道项,您可以调整此人偶实例特有的参数。

:默认情况下,导入的人偶会放置在场景中心。使用“变换”行为选项可在场景中重新放置人偶。

编辑人偶的原始图稿

无需重新创建人偶、应用任何行为以及从头更改行为参数,即可更新与人偶关联的图稿。

要编辑人偶图稿,请执行以下步骤:

  1. 在“项目”面板中选择人偶,或者在“人偶”面板中选择人偶图层,然后选择“编辑”>“编辑原稿”(Cmd/Ctrl+E)。若在 Photoshop 或 Illustrator 中打开了人偶文件,可以直接在其中对文件进行编辑,所做的更改会自动同步。此时将启动与人偶图稿关联的默认应用程序(例如,用于 .psd 文件的 Photoshop 和用于 .ai 文件的 Illustrator)。打开图稿。

  2. 按需修改图稿,然后保存更改。保存在图稿文件中所做的更改非常重要,以便这些更改显示在 Character Animator 中。

  3. 切换回 Character Animator。此时应该会自动检测和更新修改后的文件。

  4. 如果 Character Animator 未检测到更新的图稿,请等待几秒钟。

视频:从头开始构建人偶

视频:从头开始构建人偶
Dave Werner

注:从头开始创建人偶视频教程可帮助您学习如何在 Photoshop 中从头开始创建人偶,并且在 Adobe Character Animator 中观看栩栩如生的人偶。

在“项目”面板中选择人偶或在“人偶”面板中打开人偶时,“属性”面板的“人偶”部分会显示源图稿的路径,工具提示会显示完整路径。如果无法找到图稿文件,文件名会显示为黄色,工具提示前缀为“缺少”

要重新链接或更换源图稿,请在“属性”面板中单击文件名,然后选择要使用的图稿文件。

替换人偶轨道的源人偶

可以在时间轴中更新或替换人偶,即使为其录制镜头之后也是如此。这允许您保留现有录制内容,同时向人偶添加新内容,只要保留普通的人偶结构即可。

要替换人偶轨道的源人偶,请执行以下任一操作:

  • 在时间轴中选择人偶轨道。然后,在将该人偶拖到“时间轴”面板中选定的人偶轨道上时,请按住 Option (Mac) 或 Alt (Win)。
  • “项目”面板中选择替换人偶。然后,右键单击人偶轨道的轨道头(左侧)区域,并选择“项目”面板中的“使用所选人偶替换”

删除不再存在于替换人偶的原始源人偶部分的所有录制镜头。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略