录制期间可以捕捉场景人偶的表演。人偶的特定备录行为参数的每次录制称为一个镜头。

场景的时间轴(在“时间轴”面板中显示)将每个人偶实例表示为可选的轨道项。当选中时,“属性”面板会显示用于人偶的源(主定义)的行为,以及针对此特定实例的所有覆盖行为参数值。例如,可以将相同的人偶多次添加到一个场景,并且每个人偶的轨道项都有不同的位置变换,以放置在场景中。

场景有三种模式:

  • 停止:场景以这种模式打开。行为(呼吸、循环图层、物理学、手柄固定器、变换和摇动器除外)不影响人偶,除非准备进行录制。未备录时,将使用在当前时间指示器(播放指示器)处为某个行为录制的最新镜头。当停止时,将不回放导入的音频包括镜头中的音频)。您可以在此模式中排练行为 - 不录制任何内容。
  • 播放:此模式可回放镜头和音频。当前时间指示器随时间移动。如果在给定的某个时间存在相同参数的镜头,更改行为参数值不会影响结果;如果不存在镜头数据,将使用该参数的值但不进行录制。
  • 录制:录制时,系统将捕捉备录行为参数的值作为每个参数的镜头,并回放任何现有镜头。您还能以较慢的速度进行录制,以便更精细地捕捉表演。回放速度始终正常。

有多个传输控件用于这些模式。通过使用这些模式,您可以执行对表演的基本录制、回放以及查看已录制的镜头以及重新录制表演以更正错误。这样,您就可以进行不同输入的多轨道录制以及为多个镜头分层。

“跳转到开头”按钮将当前时间移回场景的开头(如果停止)或回放的开头(如果当前处于“播放”模式)。“转到上一帧”“转到下一帧”按钮随时间向后或向前移动帧(当停止时)。

当您打开操纵工作区时,传输控件不显示为默认面板控件的一部分。要查看传输控件,请选择“总是显示播放录制控件”选项(在操纵工作区菜单中)。

 

注意:

音频输入和输出硬件必须共享采样率。

录制镜头

移动您的头部以控制人偶脸部、拖动角色的手以让它挥手以及捕捉表演的其他动作都通过录制镜头来完成。可以在“录制”工作区中执行这些任务。

录制倒计时

录制开始前会开始 3 秒倒计时。请使用此时间准备录制或捕获人偶的特定姿势。要启用或禁用倒计时,请执行以下步骤:

  • 打开“时间轴”并启用“录制之前的倒计时”选项。
录制之前的倒计时
录制之前的倒计时

录制人偶的表演

  1. 根据需要校准视频或音频输入:

    • 要通过网络摄像头控制人偶,请确保启用了“摄像机和麦克风”面板中的“摄像机输入”按钮(蓝色图标)。此外,为了改善脸部跟踪结果,请使用“设置静止姿势”按钮设置您的静止姿势。
    • 要在表演期间录制音频,请确保启用了“摄像机和麦克风”面板中的“麦克风输入”按钮(默认设置)。当启用时,音频电平表会监视 –48 dB 到 0 dB 的音频输入电平。0 dB 时此表变为红色。如果电平表显示“音频电平过低”,请尝试在操作系统的“声音控制”面板中提高麦克风电平,或者离麦克风更近些。
  2. 要备录轨道以进行录制,请选择人偶(面板左侧的轨道头中的轨道项或人偶名称)。

    选中/备录的人偶可让您隔离录制以调整其轨道。默认情况下,单击人偶轨道项或轨道头,或将人偶添加到场景中,将取消选择/取消备录场景中的其他人偶。要选择多个人偶以进行录制准备,请按 Cmd/Ctrl 键并单击。备录人偶轨道在轨道标题中显示一个红色背景。

  3. 在“属性”面板中,针对您要为人偶录制的所有行为启用“录制准备”按钮(行为名称旁边的小圆圈)。还要针对要在镜头中捕捉的单个行为参数启用“录制准备”按钮。

    备录行为用一个红色实心圆圈(像一个小的录制按钮)显示。对于备录行为,其备录参数也将用参数名称旁边的一个红色实心圆圈显示。系统会捕捉备录轨道上针对备录行为参数的值。您可以通过选中(备录)人偶的轨道项或标题,在要捕捉的不同人偶之间进行切换,而无需在其他人偶上取消备录行为。

    当行为的“录制准备”按钮为暗红色时,表示未备录任何参数。取消备录的行为不会包含在下一个录制中。

  4. (可选)要捕捉“拖动器”或其他行为的详细运动,请将“录制速度”设置为低于正常速度。例如,选择半速 (0.5x)。

    录制速度较慢,但回放速度正常。

    注意:

    请禁用“麦克风输入”,除非您想声音听起来像金花鼠那样。

  5. 设置录制的开始时间。

    您可以单击“跳转到开头”按钮从场景开头处开始,播放,然后在特定时间停止。还可以单击或沿着时间标尺(位于“时间轴”面板的顶部)拖动。

    注意:

    要在回放期间“插入”,您可以开始录制(如下所述)而无需先暂停。

  6. 通过在“场景”面板中单击“录制”按钮开始录制。

    注意:

    如果重新录制场景,但不想包含以前的音频镜头,请在录制期间使用耳机。

  7. 使用网络摄像头、麦克风、键盘和鼠标输入进行表演,并且调整备录行为参数值。

    注意:

    如果针对行为准备了“摄像机输入”或“音频输入”参数,但禁用了各自的“摄像机输入”和“麦克风输入”按钮(在“摄像机和麦克风”面板中),将不会为这些参数捕捉镜头。同样,如果备录了“鼠标输入”和“键盘输入”参数,但没有实际单击“场景”面板或按住一个键,则不会捕捉镜头。

  8. 通过再次单击“录制”或单击“停止”停止录制。

     

此时会将录制的镜头保存到磁盘上的“录制”文件夹(在当前项目文件夹的“通道媒体”子文件夹中)。还会将“录制”文件夹中的镜头导入“项目”面板并添加到场景中。如果录制了麦克风输入,它的 WAV 文件会显示为一个音频轨道项。

默认情况下,人偶的轨道是折叠的。沿人偶轨道项栏底部显示一个浅色的镜头摘要栏,表示存在录制的镜头。

注意:

要选择某个摄像机, 请从“摄像机和麦克风”面板的面板菜单中将其选中。该处按名称列出了可用的摄像机源。

  • 如果没有可用的兼容摄像机,则面板菜单将显示消息:“未检测到摄像机”
  • 如果在接收视频第一帧时存在延迟,面板菜单消息将会显示“等待摄像机”
  • 如果需要从面板菜单中选择某个摄像机,或如果没有可用的摄像机,则面板菜单消息将显示“未选择摄像机”
  • 如果 Character Animator 启动时,另一个应用程序正在使用该摄像机,则会显示消息“所选摄像机不可用”
  • 如果所选摄像机不再可用(例如,摄像机连接已中断),则会显示消息“摄像机断开连接”

 

如果“摄像机输入”按钮因出现问题而被禁用,请单击(启用)该按钮,尝试从所选摄像机重新获取视频。

为录制备录人偶

每个人偶轨道都有其自己的“录制准备”按钮,此按钮可以从选择的人偶轨道单独控制。

准备录制人偶轨道
准备录制人偶轨道

单击人偶轨道项或轨道头仍会转为备录该人偶。通过在人偶轨道之外单击(例如,通过在其他人偶轨道上编辑镜头或发音嘴型栏)来取消选择人偶轨道不会取消备录之前备录的人偶轨道。
您可以按住 Shift 键并单击或按住 Cmd/Ctrl 键并单击这些轨道的“录制准备”按钮来备录多个人偶轨道。要确保不会取消备录人偶轨道,请仅选择人偶轨道或音频轨道上的镜头或发音嘴型

摄像机选项

要选择某个摄像机, 请从“摄像机和麦克风”面板的面板菜单中将其选中。该处按名称列出了可用的摄像机源。

从选项中选择摄像机
从选项中选择摄像机

如果没有可用的兼容摄像机,则面板菜单将显示消息“未检测到摄像机”。如果存在摄像机输入问题,则面板将显示以下错误之一:

  • 如果在接收视频第一帧时存在延迟,则会显示错误消息“等待摄像机”
  • 如果需要从面板菜单中选择某个摄像机,或如果没有可用的摄像机,则会显示消息“未选择摄像机”
  • 如果 Character Animator 启动时,另一个应用程序正在使用该摄像机,则会显示消息“所选摄像机不可用”
  • 如果所选摄像机不再可用(例如,摄像机连接已中断),则会显示错误消息“摄像机断开连接”

如果“摄像机输入”按钮因出现问题而被禁用,请单击(启用)该按钮,尝试从所选摄像机重新获取视频。

录制速度

要捕捉更细微的运动,您可以用比场景帧速率更慢的速度录制和运行。

要更改场景的录制速度,请执行下列操作之一:

  • 在“场景”面板中打开场景,然后在面板底部更改“录制速度”设置。

这些场景设置将用于创建的下一个场景。

时间轴工作区域

场景的时间轴包含一个工作区域,您可启用该区域以隔离对场景中某组帧进行的操作。该工作区域可在需要时启用、在不需要时禁用。

要启用或禁用该工作区域,请执行以下步骤:

  • 单击时间标尺顶部的工作区域栏、使用“时间轴”菜单或工作区域栏上下文菜单中的“启用工作区域”命令。
  • 拖动已禁用工作区域栏的任何部分将其启用。
A) 工作区域已禁用 B) 工作区域已启用
A) 工作区域已禁用 B) 工作区域已启用

启用时,工作区域是浅灰色的长条,其时间范围会在轨道区域中突出显示。禁用时,工作区域栏的颜色是一种微妙的暗灰色。

设置工作区域

要更改工作区域的开始或结束时间,请执行以下操作之一:

• 拖动工作区域栏的左边缘(开头)或右边缘(结尾)。

• 将播放指示器放置在时间轴中的特定帧处,然后从“时间轴”菜单或工作区域栏的上下文菜单中选择“将工作区域开头设置到播放指示器”(Option/Alt+I) 或“将工作区域结尾设置到播放指示器”(Option/Alt+O)。

注:不能将开头时间设置到工作区域结尾之后,反之亦然。

要设置工作区域以匹配选定的轨道或镜头栏,请执行以下操作:

“时间轴”菜单或工作区域栏的上下文菜单中选择“将工作区域设置为选区”(Option/Alt+/)。工作区域就是选区中最早时间到最晚时间的跨距。

要变换时间轴上的工作区域,请执行以下操作:

水平拖动工作区域栏的中心。拖动工作区域栏的边缘或中心,可将工作区域栏的开头或结尾与人偶轨道栏、镜头栏和标记的边缘对齐。同样,拖动人偶轨道栏、镜头栏和标记的边缘,也可将它们与工作区域栏的开头或结尾对齐。

跳转至工作区域的开头或结尾

要跳转至工作区域的开头或结尾,请执行以下操作:

  • 右键单击工作区域栏,然后在上下文菜单中选择“转至工作区域的开头”“转至工作区域的结尾”
  • 使用键盘快捷键“Option/Alt+向左箭头键”和“Option/Alt+向右箭头键”。

使用工作区域编辑选定的镜头

工作区域启用后,可以执行以下编辑:

  • 要删除工作区域内选定镜头的区段,请选择“时间轴”>“清除”以留出间隙(工作区域内无录制内容),或选择“时间轴”>“波纹删除”以通过将原先在工作区域后方的选定镜头移动到工作区域的开头来弥合间隙。
A) 之前 B) 清除 C) 波纹删除
A) 之前 B) 清除 C) 波纹删除
  • 要在时间轴中插入一段时长等于选定镜头工作区域持续时间的间隙,请选择“时间轴”>“插入时间”
A) 之前 B) 插入时间
A) 之前 B) 插入时间

工作区域栏的上下文菜单中也提供了“清除”“波纹删除”“插入时间”命令。

在工作区域中循环回放

启用工作区域后,工作区域内的场景将会自动循环回放。回放将于当前时间开始,并在播放指示器到达工作区域的结尾时进行循环。如果播放指示器在工作区域的后方,则回放后不会循环。

使用工作区域录制镜头

如果已启用工作区域,请使用“时间轴”>“录制工作区域的镜头”命令 (Cmd/Ctrl+3) 以创建新的镜头。新的镜头将涵盖已准备行为参数的工作区域持续时间。

导出工作区域

启用工作区域后,场景导出命令(“文件”>“导出”>“通过 Adobe Media Encoder 导出视频”“文件”>“导出”>“PNG 序列和 WAV”)只会使用工作区域内的时间段。

注:场景内有使用物理模拟(摆动、碰撞、粒子)的人偶时,为了让工作区域内的帧导出时能获得预期的结果,仍然需要对工作区域开头之前的帧进行渲染(即预备阶段)。

工作区域被禁用后,使用这些命令会导出完整持续时间的场景。

注:将场景拖动到 After Effects 或 Premiere Pro 中时,工作区域会被忽略。场景的持续时间将被用在这些 Dynamic Link 工作流程中

将场景修剪至适应工作区域

启用工作区域后,可通过选择“时间轴”>“将场景修剪到工作区域”或在工作区域栏的上下文菜单中选择相同的命令,对场景进行修剪以调整工作区域内的时间段。

回放速度

“回放速度”设置可让您用更慢的速度回放场景,以查看表演中的更细微的运动或更改。您可以将此控件与可控制的录制速度配合使用。

要更改场景的回放速度,请在“场景”面板中打开场景,从“回放和录制速度”控件更改“回放速度”设置。此选项位于面板的底部。

当回放速度和录制速度不同时,这两个值都会显示出来,且录制速度用红色显示。如果相同,则仅显示该值。

新场景始终默认采用正常 (1.0x) 回放速度,而不是上次使用的回放速度。这一点与其他场景属性不同,但与录制速度相同。

回放表演

录制镜头之后,回放录制的内容以检查工作。

要从场景中的特定时间开始,请执行以下操作:

单击或沿着时间标尺(位于“时间轴”面板的顶部)拖动。拖动也可以在场景中划动音频。

要开始回放,请执行以下操作:

单击“播放”或者按空格键。此时会回放录制的镜头,也会相应地更新显示的时间码。

要控制场景的回放速度,请执行以下操作:

在“场景”面板中打开场景,然后在面板底部的“回放和录制速度”控件中更改“回放速度”设置。

当回放速度和录制速度不同时,这两个值都会显示出来,且录制速度用红色显示。当两种速度相同时,则只显示这个值。

要停止回放,请执行以下操作:

单击“停止”或再次按空格键。

默认情况下,播放头会贴靠到帧边界。在“时间轴”面板中放大时间时,您可以看到一帧的持续时间带有浅蓝色阴影(与在 After Effects 和 Photoshop 中看到的阴影类似)。

注意:

“场景”面板显示此帧持续时间的中间时间,但音频仍可以跨帧持续时间播放。录制、拆分和贴靠等轨道和镜头操作仍在红线处(左侧边缘)发生。

要取消播放头与帧边界的贴靠,以便更精确地定位或划动音频,请按住 Cmd 键 (Mac) 或 Ctrl 键 (Windows) 并拖动播放头。

重播相同的时间范围

默认情况下,停止回放会使播放指示器留在停止的位置,但您可以使播放指示器返回到之前的开始时间,这样您可以通过按空格键重复相同的时间范围。为单词或短语优化发音嘴型的时间时,此选项非常有用。
要在回放停止时将播放指示器返回到之前的开始时间,请执行以下步骤:

  • 选择“时间轴”>“停止时返回到开始位置”选项。

通过键盘滚动时间

要在场景中滚动时间,您可以使用以下键盘快捷键。

  • Page Up 或 Page Down:在可见的时间范围内一次向左或向右滚动一个“页面”。
  • Command/Control + Page Up 或 Command/Control + Page Down:一次向左或向右滚动不到一页。

在回放和录制期间滚动“时间轴”面板的内容

为了保持播放指示器可见,在回放或录制期间“时间轴”面板的内容会滚动。

要防止在回放和录制期间滚动时间,请执行以下步骤:

  • 取消选择“时间轴”>“播放时滚动”选项。

定格镜头

如果您想要延长角色录制的表演(镜头)在当前时间的姿势,请创建定格镜头。定格镜头复制播放指示器处所选镜头的值,允许您将它们延长到所需的持续时间,并视情况将它们与早期录制的镜头混合。要创建定格镜头,请执行以下步骤:

  1. 播放指示器移动至显示您想要定格的姿势的帧。

    提示:取消备录人偶轨道可查看录制的镜头的结果。

  2. 选择您想要定格其在当前时间的值的一个或多个镜头。

  3. 选择“时间轴”>“新建定格镜头”(Command+Shift+Option+D/Ctrl+Shift+Alt+D)。

每个选定的镜头上方都有一个持续一秒钟的新定格镜头。您可以根据需要延长和移动定格镜头,甚至可以将它们混合到其下方的镜头中,以实现更平滑的过渡。沿着每个定格镜头底部边缘的刻度线指示时间上延长得更早和更晚时,值都是恒定的。

注意:

“嘴形同步”或“触发器”镜头的定格镜头可以从任一端延长,但发音嘴型或触发器栏的起始位置不会自动延长。您仍然可以根据需要手动对其进行拖动。

显示或隐藏录制的人偶镜头

要显示或隐藏人偶的录制内容,请在“时间轴”面板中,单击轨道标题中人偶名称旁边的提示三角符号。每个已录制的行为参数将显示为单独的投影栏,并提供其内部镜头的概述。如果在人偶的轨道项下未看到任何投影栏,请核实您至少为录制准备了一个行为参数,并且在录制前选中/准备了此轨道。

您可以从投影栏修改参数的所有镜头,或者通过单击投影栏对应的三角形更精细地调整特定镜头。

注意:

如果针对一个参数录制了多个镜头,将使用任何给定时间处最上面的镜头栏,而忽略其下方镜头栏的所有信息(不带颜色显示,好像处于阴影中)。对于一个参数,各镜头之间的过渡点用参数投影栏上的一条垂直线表示。

要在场景开头处开始,请执行以下操作:

单击“跳转到开头”按钮或按 Home 键。

重放:可重复使用且可触发的录制内容

利用“重放”,可触发人偶的已录制镜头,用于直播或再次录制。此功能可让录制和重放更加轻松快捷。有关重放的信息,请参阅“重放:可重复使用且可触发的录制内容”

在镜头组中录制行为

镜头组可将针对特定手柄的多个表演组合在一起,而不影响拖动的其他手柄的表演。“拖动器”行为可为您移动的每个可拖动手柄录制单独的镜头组。按照所拖动的手柄对“拖动器”镜头进行编组,无需使用多个“拖动器”行为即可捕捉多个拖动的手柄。“时间轴”面板将按照手柄名分组的每个“拖动器”镜头显示为“手柄(手柄名称)”。

分步录制以捕捉一帧或两帧镜头

您可以将角色的当前姿势(特别是为录制准备的行为参数)录制为一帧或两帧镜头,以便制作“一帧”或“两帧”动画。例如,如果将“拖动器”行为的“移动后”参数设置为“留在原位”,您可以让角色的手臂摆姿势、录制一个一帧镜头,改变姿势、录制另一个一帧镜头等。与所有录制的镜头一样,您可以延长它的持续时间,之后将姿势保持更长时间。

要针对备录参数录制一帧或两帧镜头,请选择“时间轴”>“录制 1 帧镜头”(Cmd/Ctrl+1) 或“录制 2 帧镜头”(Cmd/Ctrl+2)。

可以在镜头开头和结尾混合表演,以便在现有镜头或默认外观之间平稳过渡。您也可以自定义混合持续时间或快速设置一个镜头与默认持续时间混合。有关更多信息,请参阅将表演混合在一起

调整时间和重新排列场景内容

您可以更改人偶、录制的镜头和音频的时间和顺序,以便微调工作。人偶和音频显示为轨道项(更大的栏),录制的镜头显示为人偶轨道项下方更短的栏。您还可以放大或缩小时间,以便更轻松地访问轨道栏或场景的临时概述。

在“时间轴”面板中缩放到某一帧的持续时间时,该帧的水平中心用虚线表示,以表明轨道项或镜头被采样的确切时间。

拖动“缩放时间轴”滑块或在“时间轴”面板右下角单击“放大时间轴”、“缩小时间轴”或“缩放时间轴以适应整个场景”按钮。这些按钮有键盘快捷键(–、= 和 \)。

放大时滚动时间

使用“时间轴”面板的可滚动区域下方的水平滚动条,或者在触控板上水平轻扫。

滚动人偶堆栈和音频轨道

使用垂直滚动条或者在触控板上垂直轻扫。

选中或取消选中轨道项

  • 单击轨道名称(针对人偶)或轨道项的栏来选中它。
    为人偶选中一个轨道项,以便在场景中修改人偶实例的行为参数值,从而覆盖人偶的源(主)定义中的值。
    自动选择人偶轨道可为录制备录人偶。
  • 要切换人偶选择,请按住 Shift 键单击或按住 Cmd/Ctrl 键单击人偶的轨道项或轨道的名称(面板左侧的轨道头)。切换选择可以让您同时选择多个人偶。
  • 在任何轨道项栏之外单击,可取消选择所有内容。

层级式选择

所选轨道项在“时间轴”面板中显示为实心蓝色。当选择人偶的镜头或投影条时(直接选择或录制镜头后选择),此条变为实心蓝,人偶轨道的轮廓变为蓝色,表示选择了人偶层级中的某项内容。这种层级式选择还允许在“属性”面板中查看人偶的行为参数,并在调整镜头之后立即修改。

选中或取消选中镜头

  • 单击一个镜头以选中它和同一录制过程中捕捉的其他镜头。默认情况下会链接这些镜头,并且可以一起拖动和修剪。
  • 按住 Shift 键并单击或按住 Cmd/Ctrl 键并单击一个镜头可切换选择链接的镜头。
当同时录制多个参数时,会链接镜头。默认情况下,选中一个镜头不会选中或影响它链接的镜头,但是您可以在“时间轴”菜单中单击“已链接的选择项”命令来同时管理链接的所有镜头。
当选中一个镜头时,摘要栏的对应部分(沿人偶轨道项的底部)用蓝色高亮显示,当轨道项折叠起来并且您无法看到镜头栏时,它可以提供信息。

拆分轨道项和镜头

通过在播放头(当前时间)处拆分来缩短人偶、音频轨道项或镜头。此操作的实质是复制选择项和修剪原始栏和新栏。

要拆分轨道项或镜头,请执行以下操作:

  1. 选中项目并将播放头放在拆分时间处。
  2. 选择“编辑”>“拆分”(Shift+Cmd/Ctrl+D)。

复制轨道项和镜头

创建轨道项或镜头副本供以后使用。

要复制轨道项或镜头,请执行以下操作:

  1. 选中项目或镜头。
  2. 选择“编辑”>“复制”(Cmd/Ctrl+D)。

调整轨道项或镜头的时间

  • 要使其时间偏移,请水平拖动此栏的中间部分。
  • 要修剪其开始或结束时间,请拖动此栏的左端或右端。

从两端扩展镜头栏,将镜头的录制值保持在镜头的原始入点之前和原始出点之后。

注意:

如果拆分一个镜头,从拆分点扩展只会显示已修剪的部分。

覆盖贴靠到边缘并进行更精细的控制

按住 Cmd/Ctrl 键的同时拖动一个轨道项或镜头栏。

重新排序轨道

要重新排序轨道,例如要更改人偶的渲染顺序,请选中轨道,然后选择“时间轴”>“排列”>“向上移动”“向下移动”,或者按 Cmd + 向上/向下箭头或 Ctrl + 向上/向下箭头。

删除轨道项

选中一个轨道项,然后选择“编辑”>“删除” 或按 Delete 或 Backspace 键。删除音频轨道项不会删除它的轨道。

移动镜头

通过“时间轴”>“上移”或“下移”命令,可将选定的镜头以同样的参数上移或下移。该命令仍可用于选定轨道。

删除镜头

选中镜头栏并按 Delete 键,或者选择“编辑”>“删除”

  • 要删除人偶的镜头,请选择所有镜头并按 Delete 键。
  • 要删除人偶轨道,请在删除场次之后且选择项位于人偶轨道时按 Delete 键。

在人偶和项目之间重复使用镜头

可以在人偶和项目之间剪切、复制和粘贴所有类型的镜头。要重复使用镜头,请按以下步骤操作:

  1. 选择要重复使用的镜头。

    • 要从人偶中移除它们,请选择“编辑”>“剪切”(Command/Ctrl+X)。
    • 要保留并复制原始镜头,请选择“编辑”>“复制”(Command/Ctrl+C)。
  2. 在当前项目或其他项目中,在“时间轴”中选择其他人偶轨道项。将播放指示器重新定位到您想要镜头开始的位置,然后选择“编辑”>“粘贴”(Command/Ctrl+V)。

将相对于播放指示器粘贴选定的镜头。与被复制的镜头相关的任何行为将应用于目标人偶(如果目标人偶没有这些行为)。如果人偶有多个行为(对于镜头),则其中每个行为都会获得一个镜头副本。您还可以复制多个镜头。这些镜头将按选择时的顺序进行粘贴。

有关将 Character Animator发音嘴型放入 After Effects 以用于不同角色的更多信息,请参阅嘴形同步:为 After Effects 导出镜头

注意:

  • 粘贴默认处于隐藏状态但在复制时未隐藏的行为(循环图层),会将新实例粘贴为隐藏状态。
  • 粘贴的行为将始终添加到人偶的顶层,即使复制的镜头用于人偶结构中层级较低的行为也是如此。
  • 粘贴的行为不会保留任何自定义行为名称。
  • 为同一行为的多个实例复制的镜头(人偶结构中脸部不同位置的两个实例)将粘贴到单个行为实例中。

将表演混合在一起

您可以在镜头的开头和结尾混合表演,以便在人偶的默认外观和录制的表演之间平稳过渡。您还可以自定义混合持续时间或快速设置默认持续时间。

混合行为参数的镜头

1. 展开包含可混合镜头的人偶和投影栏。

您可以混合以下镜头:

  • 摆动风强度或变换比例之类的数字参数
  • 变换旋转之类的角度参数
  • 脸部的“摄像机输入”参数
  • 拖动器的“鼠标和触控输入”参数

2. 执行以下操作之一:

  • 要使用自定义混合持续时间,请向内拖动镜头栏两个顶角处的小正方形;当处于正方形上方时,光标会变为两侧带箭头的手指。您从此栏的边缘拖动得越远,就越能逐步渐进或渐出录制的表演。
  • 要使用默认(半秒)混合持续时间,请选中投影栏或镜头栏,然后选择“时间轴”>“混合镜头”子菜单。您可以只混合镜头的入侧(混合入点)、出侧(混合出点)或混合两侧(混合入点和出点)。可以通过拖动小正方形进一步自定义持续时间。
  • 要循环可用的默认混合持续时间,请选择“时间轴”>“混合镜头”>“下一个混合”(Cmd/Ctrl+B) 或“上一个混合”(Shift+Cmd/Ctrl+B)。

当您修剪镜头时,除非镜头栏持续时间变得比混合持续时间更短,否则混合持续时间的入点(左侧)和出点(右侧)不会改变。

注意:

使用“时间轴”>“混合镜头”命令,可设置传入和传出混合的默认持续时间,但不会设置特定类型曲线的缓动。默认设置为“缓入缓出”

要设置混合缓动曲线,请执行以下操作:

1. 右键单击传入混合,然后选择“混合入点曲线”;右键单击传出混合,然后选择“混合出点曲线”;或右键单击镜头栏的中央,然后选择“混合”

2. 从子菜单中选择缓动类型:“无缓动”(线性曲线),“缓入”(缓动混合开头),“缓出”(缓动混合结尾),或“缓入缓出”(缓动混合的开头和结尾)。

删除镜头的混合

执行以下操作之一:

  • 选择“时间轴”>“混合镜头”>“删除混合”
  • 将小正方形拖向镜头栏的边缘。

标记

标记可让您在场景的时间轴中标记特定更改(例如,当角色向左看时)。“停止”标记可在到达它们时停止回放。您可以随时在常规“信息”标记和“停止”标记之间切换。

要创建标记,请将播放指示器移动到预期时间,然后执行下列操作之一:

  • 对于常规标记,选择“时间轴”>“添加标记”(Mac 上按 Ctrl+8,Windows 上按数字小键盘 *)。
  • 对于停止标记,选择“时间轴”>“添加停止标记”(Mac 上按 Ctrl+Shift+8,Windows 上按 Shift+数字小键盘 *)。停止标记的图标显示为一个小正方形符号。

:您可以将常规标记切换为停止标记,反之亦然。要切换,请右键单击标记,然后在“标记”选项中启用或禁用“停止回放”

  • 要重命名标记,请双击或按 Enter 键,然后输入一个新名称。
  • 要将标记移至不同时间,请水平拖动它。标记可以对齐到时间轴中的其他项,反之亦然。
  • 要删除标记,请选中它(按住 Shift 键并单击可以选择多项),然后选择“编辑”>“删除”

使用标记

使用标记
了解如何使用标记

调整音频波形和音频轨道大小

音频轨道显示音频文件的波形,这样有助于您调整人偶、镜头和发音嘴型在音频中的时间。默认情况下,音频轨道的高度显示为其他轨道的两倍,并且可以根据需要,通过垂直拖动轨道头的底部边缘来调整大小。

调整音频轨道大小
调整音频轨道大小

参数镜头的折叠视图

默认情况下,针对某个参数的多个录制内容可使用“时间轴”面板中单独的行创建镜头栏,但您可将多个镜头栏折叠成单独的一行以减少垂直滚动,且仍可单独访问各栏的内容。

单击旋转扭曲箭头可折叠或展开某个参数的镜头。只有某个参数包含多个镜头时,才会显示旋转扭曲箭头。 

折叠后的镜头视图
折叠后的镜头视图

折叠为单行后,单击该行不同的部分可选择各个镜头栏。选中后,关于该镜头的信息会显示在其镜头栏上,并会显示混合曲线和可调整的混合手柄。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略