Character Animator 中的各种导出选项。

组合场景后,可以导出它以用于其他应用程序,例如 After Effects 或 Premiere Pro。也可以导出到受 Adobe Media Encoder 监控的监视文件夹,以便自动渲染场景并将其导出为 Adobe Media Encoder 支持的任何格式。默认导出格式为带“Match Source – High bit rate”预设的 H.264。继续阅读以详细了解如何将导出的场景导入其他应用程序,导出人偶并与其他用户共享以及将嘴形同步导出到 After Effects。

使用 Dynamic Link,您可以直接在 After Effects 或 Premiere Pro 中打开场景,并且在 Character Animator 中与原始场景保持实时连线。当切换回 After Effects 或 Premiere Pro 时,在 Character Animator 中对场景所做的更改会自动反映出来。

要通过 Dynamic Link 在 After Effects 或 Premiere Pro 中导入场景,请执行以下任一操作:

  • 将场景从 Character Animator 的“项目”面板拖动到 After Effects 或 Premiere Pro 的“项目”面板中。首先可以在 Character Animator 中拖动场景,按 Alt/Command+Tab 切换到 After Effects 或 Premiere Pro,然后将场景放在“项目”面板中。
  • 从 .chproj 文件导入场景,如下所述:
  1. 通过在 After Effects 中选择“文件”>“导入”>“文件”,在 Premiere Pro 中选择“文件”>“导入”,或者在任一应用程序中使用媒体浏览器,选择一个要导入的 Character Animator 项目 .chproj 文件。

  2. 在项目内选择要导入的场景。

    场景在“项目”面板中显示为 Dynamic Link 视频素材,可以像任何其他视频素材一样将其添加到合成和序列中。当您在 After Effects 或 Premiere Pro 中使用场景时,Character Animator 不需要处于运行状态。

使用 Dynamic Link 导出

使用 Dynamic Link 导出
了解如何使用 Dynamic Link 导出项目

导出为可以导入其他应用程序的文件格式

您可以通过 Adobe Media Encoder 直接导出为影片格式 (H.264),或者导出为 PNG 序列和 WAV 文件。可以立即回放导出的影片文件,或者像 PNG/WAV 文件一样,将其导入其他应用程序供日后使用。与 After Effects 和 Premiere Pro 配合使用时,单个影片文件比 PNG 图像序列和单独的音频文件更容易导入和管理。您也可以选择导出场景帧作为 PNG。

通过 Adobe Media Encoder 将场景导出为影片文件

您可以通过 Adobe Media Encoder 将来自 Character Animator 的场景直接导出为影片格式。默认影片格式为 H.264。

  1. 选中或打开场景,然后调整场景的持续时间(在“属性”面板中),从而限制要导出的帧。

    场景持续时间可视化为“时间轴”面板中的浅色背景。

  2. 选择“文件”>“导出”>“通过 Adobe Media Encoder 导出视频”,然后指定文件位置和文件名。

    Adobe Media Encoder 启动并将场景的一个条目添加到队列中。Adobe Media Encoder 首次启动可能需要几秒钟时间。此外,Adobe Media Encoder 窗口不会移动到前面,所以您需要手动切换。

  3. 在 Adobe Media Encoder 中,为排队的项目调整任意设置,然后单击“启动队列”(绿色播放)按钮。

    默认导出格式为带“Match Source – High bit rate”预设的 H.264,但可以根据需要进行更改。

    可以立即播放渲染后的影片文件,或将其导入其他应用程序供日后使用。

将场景导出为 PNG 序列和 WAV 文件

  1. 选中或打开场景。

  2. 选择“文件”>“导出”>“PNG 序列和 WAV”(Cmd+Opt+M/Ctrl+Alt+M),然后为录制的场景指定位置和基本文件名。基本文件名默认为场景的名称。

    在 Mac 中,如果您指定现有子文件夹的名称,系统会要求您将其替换。在 Windows 上,指定现有子文件夹名称只会导航到这个子文件夹。

    导出期间将禁用摄像机和麦克风输入。

    为您创建基于指定名称的子文件夹,并且会将文件(PNG 序列和立体声 48 kHz WAV 文件)放在其中。此时将自动打开子文件夹。系统将在子文件夹旁边创建一个 .xml 文件,该文件可用于将子文件夹的内容导入到可导入此类文件的应用程序。

导出场景帧

可以在“场景”面板中将当前时间的场景内容导出为 PNG 图像文件。
要导出当前场景帧,请选择“文件”>“导出”>“帧”(Command+Option+S/Ctrl+Alt+S)。您可以指定PNG 文件的位置和名称。

注意:

请注意,不会保存“场景”面板的背景颜色,并且 PNG 文件将具有透明背景。此外,人偶网格(如果显示)不会出现在文件中。

将导出的场景导入其他应用程序

将场景导入 After Effects

您需要手动将 PNG 文件和 WAV 文件从 Character Animator 导入 After Effects。当您导入 PNG 序列时,解释素材以匹配 Character Animator 场景的帧速率。

将场景导入 Premiere Pro

将导出的 .xml 文件导入“项目”面板。创建一个包含 PNG 序列和 WAV 文件的序列。

将场景导入 Adobe Media Encoder

将导入的 .xml 文件添加到“队列”面板,然后调整格式设置并输出文件。

注意:

您还可以设置一个监视文件夹,将导出的 .xml 文件的 PNG 序列与 WAV 文件自动编码为影片或静止图像格式。

导出并与其他用户共享人偶

如果要将人偶发送给其他 Character Animator 用户,或者要存档人偶的结构以便在其他项目中重复使用,请创建一个可共享人偶,其中包含全部所需图稿的自含式文件。

要共享人偶,请执行以下操作:

  1. 在“项目”面板中选择人偶,或者在“人偶”面板中打开人偶(来自“项目”面板)。
  2. 选择“文件”>“导出”>“人偶”,然后命名 .puppet 文件,或者在“项目”面板中右键单击人偶,然后选择“导出人偶”
  3. 通过共享链接或其他方法将 .puppet 文件发送给其他用户。
  4. 要打开共享人偶,请通过“文件”>“导入”或将人偶拖入“项目”面板来导入 .puppet 文件。

注:可共享人偶是自含式的,含有与人偶关联的图稿。如果需要,您可以将人偶重新链接到共享图稿实例。在时间轴中选定人偶时对人偶所做的更改,或者用于人偶轨道的任何录制镜头,都不包含在 .puppet 文件中。此外,已导入的人偶上的行为会更新,以使用当前项目中可用行为的各个版本。

将实时场景流传输到其他设备或应用程序

使用“实时流”选项,可在外部监视器或第三方视频设备上显示您的屏幕。也可以使用实时流将您的场景发送到其他应用程序(例如 Facebook Live 和 YouTube)来广播实时动画。有关流的信息,请参阅流传输实时场景。如果要查找与流相关的提示、技巧和解决方法,请参阅流传输的提示和技巧

嘴形同步:为 After Effects 导出镜头

通过执行以下步骤,将 Character Animator发音嘴型放入 After Effects 以用于不同的角色。

  1. “时间轴”面板中,右键单击“嘴形同步”镜头 >“为 After Effects 复制发音嘴型”。所有发音嘴型数据都作为“时间重映射”关键帧数据复制到系统剪贴板,以供在 After Effects 中使用。

  2. 在 After Effects 中,可设置包含多个不同发音嘴型(一秒时间间隔)的合成,其中的发音嘴型顺序与Character Animator 中“发音嘴型”上下文菜单中的顺序一致。在 0 秒时,嘴形应该为“中性”(即无发音嘴型),在第 1 秒时,使用 Aa 发音嘴型,第 2 秒时使用 D 发音嘴型,以此类推。

  3. 现在,将合成嵌套到包含您的角色面部的另一个合成中。确保您为此合成设置的帧速率与 Character Animator 项目中的场景的帧速率相同。

  4. 要将在第一步中复制的“时间重映射”关键帧粘贴到嵌套的发音嘴型合成中,请选择“编辑”>“粘贴”

  5. 现在,选择所有“时间重映射”关键帧,然后将其关键帧插值设置为“定格”

    提示:您还可以将数据复制到电子表格程序中,根据需要微调值,然后将数据复制回系统剪贴板以便粘贴到 After Effects。

将场景导出为带 Alpha 通道的视频格式

如要将某个场景导出为带 Alpha 通道的影片文件(以便在 After Effects 或其他应用程序中将其合成到其他素材上时,使场景的透明或半透明区域可以显示背景),可使用单独的菜单命令以将场景发送至 Adobe Media Encoder。

  • 要将场景导出为带 Alpha 通道的视频格式,请选择场景,然后选择“文件”>“导出”>“带 Alpha 通道的视频(通过 Adobe Media Encoder)”

该场景会被添加到 Adobe Media Encoder队列,并被设置为使用“具有 Alpha 的 GoPro CineForm RGB 12 位”预设的 QuickTime 格式。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略