Las aplicaciones PDF creadas con VB6 no funcionan con Acrobat 11.0.07.

La actualización 11.0.07 es compatible con el entorno de 64 bits mediante DLL de 32 bits y 64 bits por separado; asimismo, la implementación sigue las directrices de Microsoft. Debido a que VB 6.x no proporciona compatibilidad con 64 bits, las aplicaciones creadas con VB6 ya no funcionan.

Soluciones alternativas

Están disponibles las siguientes opciones:

  • Actualice a un IDE más reciente o a la versión posterior de Visual Basic que admita DLL de 64 bits.
  • Si había creado aplicaciones de 32 bits porque AcroPDF.dll era de 32 bits y utiliza Visual Studio 2005 o una versión posterior, verifique que la opción Destino de la plataforma Visual Studio esté definida en Cualquier CPU (valor predeterminado). Cualquier CPU significa que el ensamblado se ejecuta de forma nativa en la CPU que está en ejecución. Es decir, como 64 bits en un equipo de 64 bits y como 32 bits en un equipo de 32 bits. 
  • Si controla el entorno de usuario final, no actualice los equipos a la versión 11.0.07 hasta haber vuelto a crear la aplicación con la configuración pertinente.
  • Cree la aplicación de forma que el navegador web controle la carga del plugin de Acrobat o de Reader en vez de llamar directamente a la DLL. Para recopilar algunas ideas, consulte el hilo de foro.

Información adicional

El entorno de los programas de software tiende con rapidez a las aplicaciones de 64 bit; cada vez resultan más frecuentes las situaciones en las que se necesita compatibilidad con plugins de 64 bits. Tenga en cuenta lo siguiente:

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea