Guía del usuario Cancelar

Publicación de formularios web PDF interactivos

  1. Guía del usuario de Acrobat
  2. Introducción a Acrobat
    1. Acceder a Acrobat desde equipos de escritorio, dispositivos móviles, páginas web
    2. Novedades de Acrobat
    3. Métodos abreviados de teclado
    4. Requisitos del sistema
  3. Espacio de trabajo
    1. Conceptos básicos del espacio de trabajo
    2. Abrir y ver archivos PDF
      1. Abrir archivos PDF
      2. Navegar por páginas PDF
      3. Visualización de preferencias de PDF
      4. Ajuste de vistas de PDF
      5. Habilitar vista previa en miniatura de archivos PDF
      6. Mostrar PDF en explorador
    3. Trabajar con cuentas de almacenamiento en línea
      1. Acceder a los archivos desde Box
      2. Acceder a los archivos desde Dropbox
      3. Acceder a archivos desde OneDrive
      4. Acceder a archivos desde SharePoint
      5. Acceder a archivos desde Google Drive
    4. Acrobat y macOS
    5. Notificaciones de Acrobat
    6. Cuadrículas, guías y mediciones en archivos PDF
    7. Asiático, cirílico y texto de derecha a izquierda en PDF
  4. Crear archivos PDF
    1. Descripción general de la creación de archivos PDF
    2. Crear PDF con Acrobat
    3. Crear archivos PDF con PDFMaker
    4. Uso de la impresora Adobe PDF
    5. Convertir páginas web a PDF
    6. Crear documentos PDF con Acrobat Distiller
    7. Configuración de conversión de Adobe PDF
    8. Fuentes PDF
  5. Editar PDF
    1. Editar texto en archivos PDF
    2. Editar objetos o imágenes en un archivo PDF
    3. Rotar, mover, eliminar y volver a numerar las páginas de un PDF
    4. Editar archivos PDF digitalizados
    5. Mejorar fotografías de documentos capturadas con una cámara móvil
    6. Optimización de archivos PDF
    7. Propiedades y metadatos de archivos PDF
    8. Vínculos y adjuntos en archivos PDF
    9. Capas de PDF
    10. Miniaturas y marcadores de página en PDF
    11. Asistente de acciones (Acrobat Pro)
    12. PDF convertidos a páginas web
    13. Configuración de archivos PDF para una presentación
    14. Artículos PDF
    15. Archivos PDF geoespaciales
    16. Aplicar acciones y secuencias de comandos a archivos PDF
    17. Cambiar la fuente predeterminada para añadir texto
    18. Eliminar páginas de un PDF
  6. Digitalizar y OCR
    1. Digitalizar documentos a PDF
    2. Mejorar las fotografías del documento
    3. Solución de problemas de digitalización al digitalizar con Acrobat
  7. Formularios
    1. Introducción a los formularios PDF
    2. Cree un formulario desde cero en Acrobat
    3. Crear y distribuir formularios PDF
    4. Rellenar formularios PDF
    5. Propiedades de los campos de formulario PDF
    6. Rellenar y firmar formularios PDF
    7. Ajuste de botones de acción en los formularios PDF
    8. Publicación de formularios web PDF interactivos
    9. Introducción a los campos de los formularios PDF
    10. Campos de formulario de códigos de barras PDF
    11. Recopilación y administración de datos de formulario PDF
    12. Acerca del rastreador de formularios
    13. Ayuda de formularios PDF
    14. Enviar formularios PDF a los destinatarios mediante el correo electrónico o un servidor interno
  8. Combinar archivos
    1. Combinar archivos en un único PDF
    2. Rotar, mover, eliminar y volver a numerar las páginas de un PDF
    3. Adición de encabezados, pies de página y numeración Bates a archivos PDF
    4. Recortar páginas PDF
    5. Añadir marcas de agua a documentos PDF
    6. Agregar fondos a archivos PDF
    7. Uso de archivos componentes en una cartera PDF
    8. Publicar y compartir carteras PDF
    9. Descripción general de las carteras PDF
    10. Creación y personalización de carteras PDF
  9. Uso compartido, revisiones y comentarios
    1. Compartir archivos PDF y realizar su seguimiento en línea
    2. Marcar texto con ediciones
    3. Preparar una revisión de PDF
    4. Iniciar una revisión de PDF
    5. Alojar revisiones compartidas en sitios de SharePoint o de Office 365
    6. Participación en una revisión de PDF
    7. Agregar comentarios a archivos PDF
    8. Añadir un sello a un PDF
    9. Flujos de trabajo de aprobación
    10. Administrar comentarios | ver, responder, imprimir
    11. Importación y exportación de comentarios
    12. Rastrear y administrar revisiones de PDF
  10. Guardar y exportar archivos PDF
    1. Guardar PDF
    2. Convertir un archivo PDF a Word
    3. Convertir PDF a JPG
    4. Convertir o exportar documentos PDF a otros formatos de archivo
    5. Opciones de formato de archivo para exportación de PDF
    6. Reutilización del contenido PDF
  11. Seguridad
    1. Configuración de seguridad mejorada para archivos PDF
    2. Protección de archivos PDF con contraseñas
    3. Administrar ID digitales
    4. Protección de archivos PDF con certificados
    5. Abrir archivos PDF protegidos
    6. Eliminar contenido confidencial de archivos PDF
    7. Configuración de normativas de seguridad para archivos PDF
    8. Selección de un método de seguridad para archivos PDF
    9. Advertencias de seguridad cuando se abre un archivo PDF
    10. Proteger archivos PDF con Adobe Experience Manager:
    11. Función de modo protegido para archivos PDF
    12. Información general sobre la seguridad en Acrobat y archivos PDF
    13. JavaScripts en archivos PDF como riesgo de seguridad
    14. Archivos adjuntos como riesgos de seguridad
    15. Descripción general de las herramientas de producción para imprimir"Permitir o bloquear enlaces en PDF
  12. Firmas electrónicas
    1. Firmar documentos PDF
    2. Capturar la firma en el móvil y usarla en todas partes
    3. Enviar documentos para su firma electrónica
    4. Acerca de las firmas de certificado
    5. Firmas basadas en certificados
    6. Validación de firmas digitales
    7. Adobe Approved Trust List
    8. Administrar identidades de confianza
  13. Impresión
    1. Tareas de impresión de PDF básicas
    2. Imprimir folletos y carteras PDF
    3. Configuración avanzada de impresora de PDF
    4. Impresión en PDF
    5. Imprimir archivos PDF en color (Acrobat Pro)
    6. Imprimir archivos PDF en tamaños personalizados
  14. Accesibilidad, etiquetas y reflujo
    1. Crear y verificar la accesibilidad de archivos PDF
    2. Funciones de accesibilidad en archivos PDF
    3. Herramienta Orden de lectura para PDF
    4. Lectura de documentos PDF con funciones de redistribución y accesibilidad
    5. Editar la estructura de un documento con los paneles Contenido y Etiquetas
    6. Crear documentos PDF accesibles
  15. Búsqueda e indexación
    1. Creación de índices de PDF
    2. Búsqueda en documentos PDF
  16. Contenido multimedia y modelos en 3D
    1. Agregar audio, vídeo y objetos interactivos a archivos PDF
    2. Agregar modelos 3D a archivos PDF (Acrobat Pro)
    3. Visualización de modelos 3D en archivos PDF
    4. Interacción con modelos 3D
    5. Medición de objetos 3D en archivos PDF
    6. Ajuste de vistas 3D en archivos PDF
    7. Activar contenido 3D en PDF
    8. Agregar contenido multimedia a archivos PDF
    9. Comentarios en diseños 3D en archivos PDF
    10. Reproducir formatos de vídeo, audio y contenido multimedia en archivos PDF
    11. Agregar comentarios a vídeos
  17. Herramientas de producción de impresión (Acrobat Pro)
    1. Descripción general de las herramientas de producción para imprimir
    2. Marcas de impresora y líneas
    3. Previsualización de salida
    4. Acoplado de transparencias
    5. Conversión de color y administración de tinta
    6. Reventado de colores
  18. Comprobación preliminar (Acrobat Pro)
    1. Archivos compatibles con PDF/X, PDF/A y PDF/E
    2. Perfiles de comprobaciones
    3. Inspecciones avanzadas de comprobaciones
    4. Informes de comprobaciones
    5. Visualización de los resultados de las comprobaciones, los objetos y los recursos
    6. Calidades de salida en archivos PDF
    7. Corrección de áreas problemáticas con la herramienta Comprobaciones
    8. Automatización del análisis de documentos con droplets o acciones de comprobaciones
    9. Análisis de documentos con la herramienta Comprobaciones
    10. Otras comprobaciones con la herramienta Comprobaciones
    11. Bibliotecas de comprobación preliminar
    12. Variables de las comprobaciones preliminares
  19. Gestión de color
    1. Mantenimiento de la coherencia de los colores
    2. Configuración de color
    3. Gestión de color de los documentos
    4. Trabajar con perfiles de color
    5. Explicación de la gestión de color

En este documento se explica cómo publicar formularios web interactivos en PDF. (Para obtener más información o pregunta/respuesta en formularios PDF, haga clic en el vínculo apropiado).

 

Acerca de los formularios Web

Los formularios PDF pueden ser útiles para enviar y recopilar información a través de la Web. Para ello se ofrecen varias acciones de botón que realizan funciones similares a algunas macros de secuencias de comandos HTML. El servidor Web debe disponer de una aplicación CGI (Common Gateway Interface) para recopilar y enviar los datos a una base de datos. Se puede usar cualquier aplicación CGI existente que recopile los datos de formularios (en formato HTML, FDF o XML).

Antes de preparar los formularios para la Web, compruebe que los nombres de campo de su formulario coinciden con los especificados en la aplicación CGI.

Nota:

Las secuencias de comandos CGI deben crearse fuera de Acrobat ya que la creación no está incluida en el producto Adobe Acrobat.

Agregar la funcionalidad Enviar

Use la acción Enviar un formulario para enviar datos de formularios a una dirección de correo electrónico o a un servidor Web especificando una dirección URL. También puede usar el botón Enviar para devolver otros archivos a un servidor o a una base de datos. Por ejemplo, puede adjuntar imágenes digitalizadas o archivos a un formulario. Los archivos se envían junto con el resto de los datos del formulario al hacer clic en el botón Enviar.

Nota:

Si el formulario PDF contiene un botón de envío por correo electrónico, puede utilizar el flujo de trabajo Distribuir para facilitar la distribución del formulario a terceros.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Enviar un formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. En el cuadro de diálogo Enviar selecciones de formulario, introduzca un valor en Indique una URL para este vínculo:

    • Para enviar los datos del formulario a un servidor Web, escriba la dirección URL de destino.

    • Para enviar los datos de formulario a una dirección de correo electrónico, escriba mailto: seguido de la dirección. Por ejemplo, escriba mailto:nadie@adobe.com.

  6. Haga los cambios que desee en las opciones disponibles y, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.

    Para obtener información sobre las opciones disponibles, consulte la sección siguiente.

  7. Cambie los valores de las demás fichas del cuadro de diálogo Propiedades del botón según sea necesario y, a continuación, haga clic en Cerrar.

Opciones de Enviar selecciones de formulario

FDF

Exporta el archivo al formato FDF. Puede seleccionar una o más de las opciones disponibles: datos introducidos por el usuario, comentarios y cambios incrementales al archivo PDF. La opción Cambios incrementales en el PDF es útil para exportar una firma digital de modo que sea fácil de leer y reconstruir por un servidor.

Nota:

 Si el servidor devuelve datos al usuario en formato FDF o XFDF, la URL del servidor debe acabar con el sufijo #FDF; por ejemplo, http://miservidor/cgi-bin/miarchivo#FDF.

HTML

Exporta el archivo al formato HTML.

XFDF

Exporta el archivo al formato XML. Puede exportar los datos de los campos de formulario, los comentarios, o ambos elementos.

PDF El documento completo

Exporta el archivo PDF completo que constituye el formulario. Aunque con esta acción se crea un archivo mayor que con la opción FDF, es útil para conservar las firmas digitales.

Nota:

 Si los usuarios que rellenan el formulario PDF utilizan Adobe Reader, debe elegir FDF o XFDF para la opción de Formato de exportación.

Todos los campos

Exporta todos los campos del formulario, incluso si no contienen valores.

Sólo

Exporta sólo los campos de formulario que especifique haciendo clic en Seleccionar campos e indicando los que desea incluir y si desea incluir campos vacíos.

Convertir fechas al formato estándar

Exporta todas las fechas del formulario en un formato único, con independencia de cómo se introdujeran en él.

Agregar un botón Restablecer formulario

Un botón Restablecer formulario borra todos los datos que el usuario ha introducido en éste. Es similar a la función Herramientas > Preparar formulario > Más > Borrar formulario, que puede usar al crear y editar formularios Acrobat. Si lo desea, puede configurar el botón Restablecer para que borre sólo determinados campos.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Restablecer un formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. En el cuadro de diálogo Restablecer un formulario, realice una de las acciones siguientes y haga clic en Aceptar:

    • Haga clic en las distintas casillas de verificación para seleccionar o anular la selección de los campos que el botón debe restablecer.

    • Seleccionar todo.

    La lista de la ficha Acciones muestra ahora Restablecer un formulario anidado bajo la acción Ratón soltado.

  6. Haga clic en otra ficha del cuadro de diálogo Propiedades del botón para seguir definiendo las propiedades del botón, o haga clic en Cerrar.

Adición de un botón Importar datos

Utilice la acción Importar datos de formulario para permitir a los usuarios rellenar los campos de formulario habituales, como el nombre y la dirección de correo electrónico, con datos importados de otro formulario. Los usuarios pueden utilizar también el botón Importar datos para rellenar los campos de formulario comunes con la información de su perfil personal. Sólo se actualizan los campos de formulario que coinciden. Los campos que no coinciden se ignoran. Para poder crear una acción Importar datos de formulario, configure un formulario con campos que contengan información de uso común desde el que se exportarán los datos.

Nota:

La acción Importar datos de formulario busca el archivo de datos del que se importan los datos en distintas ubicaciones en Windows y en Mac OS. En Windows, la acción Importar datos de formulario busca en la carpeta Acrobat o Acrobat Reader, la carpeta actual, la carpeta System, la carpeta Windows, Mis documentos\Adobe\Acrobat y las carpetas que figuren en la instrucción PATH. En Mac OS, la acción Importar datos de formulario busca en la carpeta Acrobat o Acrobat Reader y la carpeta Preferencias del sistema.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Importar datos de formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. Busque y seleccione un archivo FDF y haga clic en Abrir.

  6. Haga clic en otra ficha del cuadro de diálogo Propiedades del botón para seguir definiendo las propiedades del botón, o haga clic en Cerrar.

Valores de exportación CGI

Un valor de exportación es la información que se envía a una aplicación CGI para identificar un campo de formulario seleccionado por el usuario. Es necesario definir un valor de exportación sólo si se cumplen los requisitos siguientes:

  • Los datos se recopilan electrónicamente en una base de datos a través de una intranet de empresa o de la Web.

  • Los datos no coinciden con el elemento designado por el campo de formulario, o el campo de formulario es un botón de radio.

    Cuando se definan valores de exportación, tenga en cuenta las pautas siguientes:

  • Utilice el valor de exportación predeterminado (Sí) para indicar que se ha seleccionado una casilla de verificación o un botón de radio.

  • Introduzca un valor de exportación para listas desplegables solo si desea que el valor sea diferente del elemento que aparece en la lista (por ejemplo, para que coincida con el nombre de un campo de formulario de una base de datos). El elemento seleccionado en la lista desplegable se utilizará como valor de exportación a menos que en el cuadro de diálogo Propiedades se especifique explícitamente un valor de exportación diferente.

  • Los botones de radio relacionados deben tener exactamente el mismo nombre de campo de formulario pero valores de exportación diferentes. De este modo se garantiza que los botones sólo se puedan seleccionar alternativamente y que en la base de datos se reciban los valores correctos.

Logotipo de Adobe

Inicia sesión en tu cuenta