Activación y control de marionetas

Los activadores se crean para controlar el modo en que los grupos y las capas funcionan al mostrarlas u ocultarlas cuando se pulsa una tecla. Puede crear una amplia gama de activadores, entre los que se incluyen posiciones de mano, bolas de fuego giratorias y ciclos de parpadeos para controlar sus marionetas. 

Para ver un tutorial sobre cómo controlar un personaje con activadores, haga clic aquí.

Comportamiento Activadores y panel Activador

El comportamiento Activadores se aplica a las marionetas nuevas de forma predeterminada. Permite activar ilustraciones y configurar activadores con nombres personalizados que pueden hacer referencia a capas de diferentes grupos. Estos activadores con nombres se muestran en una lista en el panel Activadores, donde puede asignar una tecla a un activador, ver una lista de capas controladas mediante un activador e incluso asociar una nota MIDI para activar una ilustración mediante un dispositivo MIDI conectado. 

Panel Activador
Panel Activador

Existen dos tipos de activadores: 
• Activadores individuales: ocultan capas de forma predeterminada, pero las muestran cuando se pulsa una tecla o se ejecuta una nota/controlador MIDI, p. ej., se puede pulsar la tecla H para que se muestre un sombrero (“hat” en inglés) sobre un personaje. 
• Conjuntos de intercambio: solo muestran un activador a la vez, como, por ejemplo, para diversos gestos de mano. El conjunto de activadores se asocia a un grupo de capas de una marioneta. Cada activador del conjunto de activadores dispone de su propia tecla de activador o nota MIDI, y uno de los activadores puede ser un valor predeterminado.

Al hacer clic en el nombre de una capa asociada a un activador se muestra la capa en el panel Marioneta. Si desea mostrar una capa o un grupo en una marioneta sin que se afecte a otras capas o grupos, use un activador individual. Si desea que la capa o el grupo también oculte otras capas o grupos (por ejemplo, presionando B para mostrar la capa Parpadeo en un grupo que también tiene capas Pupila y Ojo), utilice un conjunto de intercambio.

Nota: El comportamiento de activadores de teclado en desuso sigue funcionando, pero si desea usar el nuevo panel Activadores y no dispone de ningún registro de activadores de teclado anterior que tenga que mantener, sustitúyalo por Activadores.

Creación y edición de activadores

El panel Activadores está abierto de forma predeterminada en el espacio de trabajo Plataforma. También puede abrirlo o cerrarlo con el comando de menú Ventana > Activadores.

Creación de un activador individual que muestre una capa de marioneta

Realice una de las acciones siguientes:
• Haga clic en la columna del activador () de una capa de una marioneta que todavía no tenga ningún activador asignado (es decir, que no tenga ningún icono en dicha columna) y, después,  elija  Crear el activador.

• Haga clic con el botón derecho en la capa en el panel Marioneta y, a continuación,  elija  Crear el activador.

• Arrastre la capa desde el panel Marioneta y suéltela en el panel Activadores.

Suelte la capa sobre un conjunto de intercambio para agregarla a él. Suéltela en otra ubicación para crear un activador individual.

• Haga clic en el botón Añadir (+) en el panel Activadores y, a continuación,  elija  Crear el activador en un activador vacío. A continuación, agregue o arrastre capas de marioneta.

Los activadores con problemas (conflictos de teclas, falta de capas, etc.) se muestran en color naranja. Pase el ratón sobre el activador para ver los detalles. La información sobre herramientas también describe la falta de capas.

Creación de un conjunto de intercambio de activadores

Realice una de las siguientes acciones:
• Haga clic en la columna del activador (  ) de un grupo de marionetas que todavía no tenga ningún conjunto de intercambio de activadores asignado a sus capas (es decir, sin iconos en dicha columna) y, a continuación, elija Crear conjunto de intercambio

• Haga clic con el botón derecho en un grupo de capas en el panel Marioneta y, a continuación, elija Crear conjunto de intercambio.

• Haga clic en el botón Añadir (+) en el panel Activadores, elija Crear conjunto de intercambio y, a continuación, arrastre a él los activadores o las capas de marionetas que quiera tener como activadores individuales.

Se crea en el panel Activadores un nuevo conjunto de activadores, cada uno con el nombre de las capas seleccionadas. Si el grupo tiene alguna capa de marioneta visible, la capa superior pasa a ser el activador predeterminado del conjunto de intercambio. Puede cambiar el nombre del conjunto de intercambio y optar por no tener un activador predeterminado.

Asignación de etiquetas a activadores

Asigne colores de etiqueta a los activadores para identificar fácilmente cuáles son los activadores o conjuntos de intercambio relacionados en el panel Activadores. Incluso puede filtrar el panel Activadores para mostrar los activadores y conjuntos de intercambio con los colores que se correspondan.

Activadores con etiquetas asignadas

Seleccione uno o más activadores o conjuntos de intercambio, haga clic con el botón derecho sobre uno de ellos, seleccione una opción de la lista de colores de la etiqueta. Seleccione “Ninguno” si no desea ninguna etiqueta. No se asignan etiquetas de forma predeterminada.

Haga clic con el botón derecho sobre el activador o el conjunto de intercambio con el color de etiqueta y, a continuación, elija Seleccionar grupo de etiquetas.

Haga clic en el campo del filtro de la búsqueda del panel Activador > Tipo de etiqueta:Color (p.ej., etiqueta:re para mostrar elementos con una etiqueta roja o verde).

Definición de activadores predeterminados

Para convertir en predeterminado un activador específico en un conjunto de intercambio, realice una de las siguientes acciones:
• Seleccione el activador y, a continuación, elija la opción Predeterminado en la parte inferior del panel.
• Haga clic en el icono de activador junto al nombre del mismo.
• Haga doble clic en el nombre del activador.
El activador predeterminado se identifica por el nombre más brillante y el icono relleno y más brillante. Si no desea que ninguna capa se active de forma predeterminada, repita el paso anterior para activar o desactivar la opción Predeterminado.

Asignación de una capa o grupo a un activador existente

Para asignar una capa o un grupo a un activador existente, realice una de las acciones siguientes:
• Haga clic con el botón derecho en la capa o grupo en el panel Marioneta,  elija  Añadir a  activador  y, a continuación, elija el activador específico en el menú contextual.
• Arrastre la capa o grupo al activador en el panel Activadores.

Ajustes de invocación de activador

Para cambiar el modo de invocar el activador, seleccione el activador en el panel Activadores y, a continuación, realice una de las acciones siguientes:

  • Introduzca una clave en la columna del teclado.
  • Haga clic en el campo Nota MIDI y, a continuación, pulse la tecla en su dispositivo MIDI o introduzca el número de nota MIDI.
  • Para que el activador quede anclado, de forma que no tenga que mantener pulsada la tecla en el teclado o el control MIDI para que siga activado, habilite la opción Enclave situada en la parte inferior del panel.
  • Al agregar una capa o reproducción a un activador existente, ahora se selecciona el activador objetivo en el panel Activadores.

La asignación de teclas y notas MIDI a los activadores se puede hacer más directamente en el modo Diseño del panel Controles. Para obtener más información, consulte Modo Diseño.

Cambio de nombre, reordenación o combinación de un activador o conjunto de intercambio

Para cambiar el nombre de un activador o un conjunto de intercambio, selecciónelo en el panel Activadores > Intro (en el teclado principal, no en el teclado numérico) y escriba el nuevo nombre. Para aceptar el cambio, pulse Intro o haga clic fuera del campo de texto. Presione Esc para anular las modificaciones.

Para reordenar activadores y meterlos, sacarlos o desplazarlos dentro de conjuntos de intercambio, seleccione uno o más activadores y arrástrelos al panel. Arrastrar un conjunto de intercambio dentro de otro combina sus activadores en un único conjunto de intercambio. Reordenar activadores en un conjunto de intercambio también es útil cuando quiere establecer la prioridad de los mismos en función del orden listado.

Para combinar capas activadas, arrastre un activador sobre otro. Las capas de activador soltadas se reasignan al activador de destino. A continuación, el activador soltado se elimina.

Para combinar los activadores de dos conjuntos de intercambio, arrastre uno de los conjuntos sobre aquel donde se quiere realizar la combinación. Los activadores de conjunto de intercambio soltado se añaden al conjunto de intercambio de destino. El activador predeterminado del conjunto de destino sigue siendo el predeterminado.

 

Nota:

Si hace que un grupo de marionetas pueda compartirse, todos los activadores asignados a las capas del grupo se desplazan a la marioneta compartida. Cualquier control para esos activadores (como se muestra en el panel Controles) permanece asociado a la  marioneta principal, no a la compartida. Es posible generar controles para estos activadores de marioneta compartida.

Visualización o revelación de activadores

Para ver o revelar los activadores asociados a una capa en una marioneta, realice una de las siguientes acciones:

• Pase el puntero sobre el icono del activador en la fila de la capa del panel Marioneta. La lista de activadores (y todas las teclas de activador) que muestra la capa  aparece  en una información sobre herramientas.
• Haga clic en el icono de activador en la fila de la capa para revelar el activador en el panel Activadores.
• Si una capa se asigna a varios activadores, haga clic en el icono del activador con  una flecha  en la fila de la capa y, a continuación, seleccione el activador específico para mostrarlo en el panel Activadores.

Sugerencia: Hacer clic en el ojo en una capa (en el panel Marioneta) asociada al activador de un conjunto de intercambio desactiva automáticamente los ojos de las demás capas activadas del conjunto. Haga clic con la tecla Opción/Alt presionada para anular el cambio automático del icono de ojo.

Configuración del comportamiento de activadores cuando se invocan varios activadores

Para cambiar el comportamiento de los activadores en un grupo de intercambio cuando se invocan varios activadores a la vez, seleccione el conjunto de intercambio y, a continuación, establezca Prioridad en Más reciente, para favorecer el activador usado más recientemente, o en Orden listado para favorecer el activador indicado más arriba en el panel Activadores. Se muestran las capas del activador favorecido.

Eliminación de capas

Para eliminar capas asociadas a un activador, seleccione este en el panel Activadores y, a continuación, haga clic en la “x” junto a las capas que desea eliminar en la parte inferior del panel.

Nota: Eliminar todas las capas asociadas a un activador no elimina el activador automáticamente.

Eliminación de un activador o un conjunto de intercambio

Para eliminar un activador o un conjunto de intercambio, selecciónelo y, a continuación, elija Editar > Eliminar (Suprimir o Retroceso).

Nota:

Los comportamientos como Rotador de la cabeza, Sincronización de labios, Activador de movimiento y Cara (para el parpadeo de los ojos) activan capas separadas del comportamiento de activadores. Si desea utilizar estos cuatro comportamientos con capas activadas por activadores en el mismo grupo de marionetas, establezca la opción Ocultar otros en los ajustes de Grupo para las capas que no se activen con estos cuatro comportamientos. Con esta opción, el orden de la capa determina la prioridad. Si no es así, cambie la estructura del archivo de ilustración.

Copia de activadores entre marionetas

Nota:

Puede copiar activadores de una marioneta y pegarlos en otra marioneta con conjuntos de intercambio y activadores que coincidan con los mismos nombres. Copie estos conjuntos de intercambio y activadores desde la marioneta original antes de que se graben las tomas para estos activadores. De lo contrario, los activadores pegados no funcionarán.

Para configurar la compatibilidad de activador entre marionetas, siga estos pasos:

  1. Seleccione la marioneta desde la cual desea copiar los activadores. En el panel Activadores, seleccione los conjuntos de intercambio y los activadores que desea copiar.

  2. Para copiar los activadores, elija Editar > Copiar. Para mover conjuntos de intercambio o activadores entre marionetas, elija Editar > Cortar.

  3. Seleccione la marioneta a la cual desea copiar estos conjuntos de intercambio  to .

  4. Con el panel Activadores ampliado, elija Editar > Pegar.

Los conjuntos de intercambio y los activadores pegados aparecen en la parte inferior de la lista de activadores. Puede moverlos, si lo desea. Ahora puede copiar cualquier grabación de activadores entre estas dos marionetas.

Si tiene creados activadores de teclado anteriores a la versión de octubre de 2017, puede convertirlos en activadores para aprovechar la mayor flexibilidad de activación y el uso del panel Controles. Tenga en cuenta que los proyectos existentes y los archivos .puppet que utilizan el comportamiento Activadores de teclado siguen funcionando.

Para las marionetas basadas en activadores, utilice el panel Activadores o Controles para ver todas las teclas de activación asignadas a una marioneta.

Panel Controles: diseño personalizado de parámetros de comportamiento y activadores de marionetas 

Utilice el panel Controles para que se muestre un panel o una interfaz visual en la que pueda acceder a parámetros de comportamiento compatibles o activadores para una marioneta. Elija los parámetros de comportamiento y los activadores (valores numéricos y angulares) a los que desea acceder fácilmente y contrólelos desde una única ubicación. Estos controles personalizados se asocian a la marioneta. Estos controles también se pueden compartir con otras personas como parte de una marioneta exportada.

El panel Controles está abierto de forma predeterminada en los espacios de trabajo Grabar y trasmitir, pero también puede abrirlo mediante los comandos de menú Ventana > Controles. El panel muestra los controles asociados a la marioneta seleccionada en el panel Proyecto o Línea de tiempo, o la marioneta abierta en el panel Marioneta.

Existen dos modos en el panel de control:

  • Modo Diseño: aquí puede personalizar el contenido y el aspecto de los controles.
Modo Diseño
Modo Diseño

  • Modo Realizar: use el modo para utilizar distintos controles haciendo clic en los vínculos de la parte superior del panel.
Modo Realizar
Modo Realizar

Modo Diseño

Los activadores de una marioneta se pueden visualizar como botones activos con ilustraciones para cada activador en ellos. También tienen teclas o notas MIDI asociadas a ellos. Puede visualizar los parámetros de comportamiento para una marioneta como controles angulares o como un regulador deslizante, y cualquier nota MIDI asociada a ellos. El diseño se guarda con la marioneta y se incluye al exportar a un archivo .puppet, lo que le permite compartir diseños de activadores con otras personas.

A continuación se indican los controles disponibles en el modo Diseño.

Añadir controles al panel: seleccione la marioneta y, a continuación, elija una de las siguientes acciones: 

  • Si el panel está vacío, haga clic en el vínculo Generar controles para “nombre de la marioneta” del panel para crear controles con forma de botón en función de los activadores de la marioneta.
  • Si los activadores se han añadido recientemente al panel Activadores o había eliminado con anterioridad algunos controles de activación, haga clic en el botón Actualizar controles . Este añade botones para los activadores adicionales o los controles de activación eliminados previamente.
  • Si hay una marioneta seleccionada en el panel Línea de tiempo, arrastre el nombre de cualquier parámetro de comportamiento numérico desde el panel Propiedades hasta el panel Controles. También puede hacer clic con el botón derecho del ratón en los nombres de parámetros y elegir añadir al panel Controles.

Para crear controles para activadores específicos, realice una de las acciones siguientes:

  • Seleccione los activadores o los conjuntos de intercambio en el panel Activadores y, a continuación, arrástrelos en el panel Controles.
  • Haga clic con el botón derecho sobre un conjunto de activadores o de conjuntos de intercambio y, a continuación, seleccione añadir al Panel de Controles en el menú contextual.

Para seleccionar o anular la selección de varios controles, realice una de las siguientes acciones: 

  • Pulse Mayús y haga clic o utilice Cmd/Ctrl y haga clic sobre los controles. 
  • Arrastre y seleccione (con el recuadro) los diferentes controles. Mantenga pulsadas las teclas Mayús o Cmd/Ctrl para cambiar la selección (de recuadro) de los controles. 
  • Pulse Cmd/Ctrl + A para seleccionar todos los controles.
  • Pulse Mayús + Cmd/Ctrl + A para anular la selección de todos los controles.

Reorganizar controles: realice una de las siguientes acciones

  • Arrastre los controles seleccionados en el panel. El control que se arrastra se puede ajustar a un diseño de cuadrícula. 
  • Pulse Opción/Alt y haga clic en el botón Actualizar diseño para redistribuir los controles actuales según el tamaño actual del panel.

Para asignar una tecla o un control MIDI diferente: seleccione el control y pulse la tecla o toque el control MIDI (botón, regulador o mando) que desea usar. Se trata del mismo control que el de cambiar la tecla o nota MIDI en el panel Activadores. Los controles asociados a un control MIDI se muestran en una capa verde superpuesta en el modo Diseño.

Para preparar o anular la preparación de los parámetros fácilmente, sin buscar los controles en el panel Propiedades, utilice el botón Preparar para grabar utilizando los controles del regulador y el mando de los parámetros de comportamiento.

Nota: El control solo está disponible cuando se selecciona una pista de marioneta.

Anular la asignación de una tecla o un controlador/nota MIDI a un control: realice una de las siguientes acciones:

  • Haga clic con el botón derecho en un control y seleccione Eliminar tecla del activador, Eliminar nota MIDI o Eliminar controlador MIDI (disponible para los controles del parámetro de comportamiento). 
  • Elimine el contenido del campo de nota MIDI del panel Activadores

Cambiar la ilustración de un botón de un activador asociado a varias capas de marioneta: haga clic con el botón derecho en el control del botón y, a continuación, en el nombre de la capa.

Cambiar el color de fondo del control (para mejorar el contraste con las ilustraciones oscuras): haga clic con el botón derecho en el control y, a continuación, seleccione Claro u Oscuro. 

Cambiar el rango de valores para un regulador o un control de parámetro angular: haga clic o arrastre los valores azules mínimo (lado izquierdo) y máximo (lado derecho) del control. Por ejemplo, si ha añadido un parámetro Transformar > Escala, pero no tiene una escala negativa, ajuste el valor mínimo a 0. 

Eliminar controles: selecciónelos y, a continuación, elija Editar > Eliminar (Suprimir o barra espaciadora) o haga clic en el botón Eliminar controles seleccionados, situado en la parte inferior del panel. 

 

Ilustración personalizada para el control de botón

Puede utilizar ilustraciones personalizadas para los controles de botón creándolas en cualquier lugar del archivo de ilustración para una marioneta. Para seleccionar distintas ilustraciones para los botones que tienen varias capas asignadas a sus activadores, haga clic con el botón derecho en un botón y seleccione el nombre de la capa en la parte superior del menú contextual.

Si afecta al aspecto de la marioneta en la escena, desactive su globo ocular.

  • Para asignar una ilustración personalizada a un botón, arrastre la capa desde el panel Marioneta y suéltela en el botón de control.

Cambio del modo Diseño al modo Realizar

Para cambiar de nuevo al modo Realizar, haga doble clic fuera de cualquier control en el modo Diseño. La tecla
Tabulador es el método abreviado predeterminado para cambiar rápidamente entre los modos Diseño y Realizar. También puede asignar un método abreviado utilizando la categoría Ventana para el comando Modo intercambiar controles del panel Diseño en el editor de métodos abreviados de teclado.

Modo Realizar

Haga clic en Realizar para cambiar al modo Realizar cuando desee usar los controles. Puede pulsar el botón o la tecla asignada, o bien pulsar el control MIDI asignado para realizar acciones. 

Realización de panorámicas de contenido

Se puede realizar una panorámica del contenido del panel Controles para ver los controles que quedan fuera del área visualizable.
Para realizar una panorámica del panel Controles, realice una de las siguientes acciones:

  • Utilice las barras de desplazamiento verticales u horizontales.
  • Mantenga pulsada la tecla Opción/Alt o el botón medio del ratón a medida que arrastra en el panel.
  • Para desplazarse horizontalmente, haga girar la rueda del ratón para desplazarse verticalmente o mantenga pulsada la tecla Mayús mientras gira la rueda del ratón.

Cambie el nombre de los controles de parámetros de comportamiento

En el panel Controles, los parámetros del comportamiento tienen controles con nombre tras sus parámetros. Se les puede cambiar el nombre. Siga estos pasos:

  1. Cambie al panel Controles al modo Diseño.

  2. Puede seleccionar el control de parámetro de comportamiento y pulsar Retorno (macOS) o Intro (Windows) o hacer clic con el botón derecho sobre el control de parámetro de comportamiento y, a continuación, elija la opción Cambiar nombre.

  3. Escriba el nombre que desea darle y pulse Retorno/Intro o haga clic fuera del campo de edición.

Activación de audio

Consiga que las marionetas tengan más vida con audio activable. Puede reproducir o grabar audio al invocar un activador añadiendo audio al activador. Por ejemplo, puede hacer que un personaje grite cuando se active una expresión facial de grito.

Para crear audio activable a partir de un archivo de audio, siga estos pasos:

  1. Importe el archivo de audio al proyecto. Para algunos archivos de audio de muestra, haga clic aquí.
  2. Arrastre el archivo de audio en una marioneta en el panel Proyecto.

De este modo, se crea una reproducción de audio que se asigna a un activador nuevo. Puede asignar una tecla a este activador y utilizarla como activador o como repetición. Una repetición de audio (en la sección Repeticiones del panel Propiedades) tiene un icono de forma de onda junto al botón reproducir y una configuración específica de audio en la parte inferior del panel.

Para incluir el audio de la escena en una nueva repetición y activación, siga estos pasos:

  1. Seleccione las pistas de audio y las tomas de la marioneta para incluirlas en la repetición.
  2. Haga clic con el botón derecho del ratón en una pista de audio o toma seleccionada y, a continuación, seleccione el comando Crear repetición y activador o Crear repetición y activador en un conjunto de intercambio.

Activadores de audio de reproducción

Los activadores con audio se pueden reproducir y grabar como cualquier otro activador al asignarles una clave. Cuando se graban, aparecen como barras del activador en el panel Cronología, no como pistas de audio independientes. Cuando las barras del activador se reproducen, también se reproduce el audio asociado al activador.

Nota:

El audio asociado con activadores grabados no se reproduce al realizar desplazarse por la cronología y no se utiliza cuando se crean tomas del audio de la escena (p. ej., el comando Calcular sincronización de labios con la toma de audio de la escena). Además, si divide la barra del activador que contiene una repetición de audio, el audio comienza desde el principio para cada barra del activador; no divide el audio.

Sugerencia: Si importa una marioneta con una repetición de audio en la que el audio de origen no se encuentra actualmente en el proyecto, puede agregarla al proyecto seleccionando la opción Habilitar uso compartido del audio en el menú contextual de la repetición de audio.

Atenuador: atenúe o deje de atenuar un grupo mediante el activador

Puede utilizar activadores del teclado para controlar la opacidad de la marioneta. Puede usar el comportamiento para mostrar u ocultar una parte determinada de la marioneta al aumentar o reducir la opacidad de esa parte (un grupo) mediante un activador (p. ej., un activador de teclado).

Configuración

Añada el comportamiento a un grupo específico de una marioneta en el que desee aumentar o reducir la atenuación. El comportamiento no se aplica de forma predeterminada a las marionetas. Para obtener los mejores resultados, evite tener Atenuador y Transformar en el mismo grupo. También puede asignar una tecla del activador al grupo. Configure la tecla para que se enclave si desea cambiar el nivel de atenuación al pulsar la tecla en lugar de al mantenerla pulsada. 

Nota:

Cuando un grupo que contiene capas superpuestas está configurado en el modo de fusión Normal y la marioneta usa Opacidad grupal, las capas se atenúan independientemente hasta el nivel final de opacidad. Alternativa: ajuste la opacidad grupal al 99,9 %.

Control

Use el parámetro Duración para controlar la velocidad (en segundos) con la que aumenta o desciende la opacidad.

Edición de tomas del activador

Las tomas grabadas a partir de activadores se muestran en el panel Línea de tiempo como barras del activador. Puede modificar fácilmente la forma de editar  barras de  de la toma.

Puede reducir el espacio vertical en el panel Línea de tiempo utilizado para  las barras de la toma  de activadores y  visemas  para tener una interfaz de usuario más compacta.

Tomas editables del activador
Tomas editables del activador

A continuación se detallan los diferentes parámetros.

  • Seleccionar una barra del activador: haga clic en el centro o los bordes de la barra. Para seleccionar varias barras, pulse las teclas Mayús o Cmd/Ctrl y haga clic, o bien arrastre un recuadro por las barras. 
  • Cambio de la temporización de una barra del activador: arrastre el borde izquierdo horizontalmente para ajustar el tiempo inicial, o el borde derecho para ajustar el tiempo final. El borde izquierdo se ajusta al  cabezal de reproducción  o a los tiempos inicial y final de  las barras  de la toma. 
  • Cambiar a otro activador en un conjunto de intercambio: haga clic con el botón derecho sobre la barra del activador y, a continuación, seleccione entre los demás activadores del conjunto. 

Sugerencia: Si el  cabezal de reproducción  se encuentra sobre una barra del activador, desarme la marioneta o su comportamiento Activadores para ver los cambios realizados en un activador. También puede desplazar el  cabezal de reproducción  en el tiempo para ver el cambio.

  • Insertar una toma del activador: haga clic con el botón derecho sobre el espacio que hay antes, después o entre las barras del activador y, a continuación, seleccione entre los activadores disponibles. La nueva barra del activador comienza en el tiempo en el que haya hecho clic. 
  • Dividir una barra del activador en dos: elija la barra del activador y, a continuación, elija Editar > Dividir (Cmd/Ctrl + Mayús + D), que realiza una división en el  cabezal de reproducción , o bien pulse la barra diagonal (/), que realiza la división por la mitad. 
  • Eliminar barras del activador: seleccione las barras del activador y elija Editar > Eliminar (Suprimir o barra espaciadora), o bien haga clic sobre una de ellas y, a continuación, seleccione Eliminar.
     

Para ocultar las barras de toma para los activadores y los visemas, anule la selección del comando del menú Mostrar activador y Barras de toma de visema.

Reproducciones: Grabaciones reutilizables y detonantes

Active las tomas grabadas por una marioneta, en directo o para volver a grabar, mediante las reproducciones. Por ejemplo, estas tomas reutilizables se pueden crear para repetir distintas actuaciones durante un flujo dinámico o una mirada o gesto del brazo específico mientras se graba. Algunos usos de una marioneta en ciclo pueden hacerse en su lugar, mediante la reproducción de una actuación grabada. 

Una reproducción representa tomas seleccionadas específicamente  y  se asocia a un activador que se puede asignar a una tecla o nota de MIDI para invocarlo. Las reproducciones también se incluyen al exportar una marioneta, así que esto le permite compartir una actuación grabada que otros pueden activar. 

Reproducciones en Character Animator

Creación y edición de reproducciones

Para crear una reproducción y un activador, siga estos pasos:

  1. Seleccione una o varias barras de toma en el panel Línea de tiempo.

  2. Haga clic con el botón derecho del ratón en una toma seleccionada y, a continuación, seleccione un comando que cree una reproducción y la asocie a un activador (un activador nuevo, un activador nuevo en un conjunto de intercambio existente o un activador existente).

Las reproducciones creadas de una marioneta aparecen en la sección Reproducciones del panel  Propiedades  y muestran la duración de las reproducciones. Las reproducciones creadas y los activadores reciben, de forma predeterminada, el nombre del comportamiento de las tomas. Si hay varias tomas para un comportamiento en una reproducción, el número de tomas aparece entre paréntesis después del nombre del comportamiento. Utilice el filtro de búsqueda del panel Propiedades para buscar reproducciones creadas.

Reproducciones creadas
Reproducciones creadas

El activador para la reproducción aparece en el panel de Activadores, como los activadores que muestran las capas de una marioneta. Cuando se selecciona un activador, la sección de Capas y Reproducciones en la sección inferior de las  listas de panel  muestra las capas y las reproducciones de una marioneta que se encuentran asociadas. Al hacer clic en el nombre de una reproducción, esta se mostrará en el panel Propiedades. 

Una reproducción contiene copias de las tomas utilizadas para crearlo, por lo que puede eliminar las tomas originales si es necesario. 

Las reproducciones que tienen problemas se muestran en color naranja. Para obtener más información sobre una herramienta, pase el puntero del ratón por encima del icono naranja o del nombre. Las reproducciones que no tienen un activador asignado también aparecen en color naranja. Al pasar el puntero del ratón por encima de ellas, la información sobre herramientas indica que “la reproducción no tiene activador”.

También puede crear reproducciones de control y reproducciones de control combinadas, además de otras operaciones para parámetros de comportamiento. Para obtener más información, consulte el menú de parámetros de comportamiento.

Selección o anulación de la selección de reproducciones

  • Para seleccionar una sola reproducción, haga clic en ella.
  • Para seleccionar un rango de reproducciones, haga clic en la primera reproducción del rango y, a continuación, mantenga presionada la tecla Mayús y haga clic en la última reproducción del rango.
  • Para seleccionar o deseleccionar reproducciones, presione la tecla Comando y haga clic (macOS) o presione la tecla Ctrl y haga clic (Windows) en la reproducción.
  • Para seleccionar todas las reproducciones, presione Comando + A (macOS) o Ctrl + A (Windows).
  • Para anular la selección de todas las reproducciones, presione Comando + Mayús + A (macOS) o Ctrl + Mayús + A (Windows).

Cambiar nombre, reordenar, eliminar y añadir reproducciones a un activador

  • Para cambiar el nombre de una reproducción, selecciónela en el panel Propiedades y pulse la tecla Retorno (macOS) o Intro (Windows) o seleccione Cambiar nombre en el menú contextual, cambie el nombre y, a continuación, pulse Retorno/Intro o haga clic fuera del campo de texto.
  • Para reordenar las reproducciones dentro de la lista de Reproducciones, selecciónelas y, a continuación, arrastre verticalmente una reproducción seleccionada.
  • Para eliminar reproducciones, selecciónelas en el panel Propiedades y pulse Suprimir. Las tomas originales incluidas en las reproducciones seleccionadas no se eliminan.
  • Para añadir reproducciones a un activador, selecciónelas en el panel Propiedades y, a continuación, arrastre una reproducción seleccionada y suéltela en el panel Activadores. Puede colocar reproducciones sobre un activador existente, lejos de un activador para crear un activador nuevo para cada reproducción seleccionada o en un conjunto de intercambio para agregarlas como activadores en el mismo conjunto.

Volver a reproducir y grabar reproducciones

Las reproducciones normalmente se crean con los activadores asociados (que puede invocarse a través de teclas, notas de MIDI o el botón control), pero también puede utilizar reproducciones directamente.

Para volver a reproducir una reproducción, realice una de las acciones siguientes:

• Pulse la tecla, la nota de MIDI o el botón de control (en el panel controles) asociada al activador de la reproducción.

• Haga clic en el botón Reproducir junto al nombre de la reproducción en el panel Propiedades.

Las tomas grabadas se vuelven a reproducir, pero el  cabezal de reproducción  no se mueve. Un pequeño medidor junto al nombre de la reproducción en el panel Propiedades muestra el progreso.

Sugerencia: Para cancelar una reproducción, mueva el  cabezal de reproducción  a un momento diferente.

Para grabar una reproducción, invoque la reproducción antes o después de empezar la grabación. Detenga la grabación al terminar.

Nota:

Las reproducciones se omiten cuando se utilizan los comandos Grabar toma de un fotograma y Grabar toma de dos fotogramas. 
Sin embargo, puede copiar las reproducciones seleccionadas en el panel de propiedades y pegarlas en la línea de tiempo.

Uso de activadores de reproducción en conjuntos de intercambio

Las reproducciones se pueden asociar a cualquier activador, incluidos los de un conjunto de intercambio. Si están asociadas con el activador predeterminado en un conjunto de intercambio, las reproducciones se reproducirán a la vez.

Detener y mantener las reproducciones

De forma predeterminada, se ejecutará la reproducción durante toda la duración de las tomas grabadas, pero puede hacer que la reproducción se produzca durante el tiempo en el que mantenga activada la reproducción.

Nota:

Esto no se aplica a las tomas creadas con Cmd+1, 2 o 3 y que no tengan valores de visema o activador editados. Esas tomas constantes se ajustan en Parar o Mantener de forma predeterminada.

Para controlar cómo se reproduce una reproducción, selecciónela y, a continuación, establezca la opción Cuando finaliza el activador a una de las siguientes:

Permitir fin de reproducción: Se muestra toda la duración  de la reproducción  grabada, sin importar durante cuánto tiempo ha activado la reproducción.

Detener / Mantener reproducción: Esta función incorpora la reproducción hasta que se detiene la activación de la misma. Si continúa pulsando el activador más allá de la duración de la reproducción, se amplían automáticamente las tomas con el último tiempo de fusión. Si se detiene durante una toma que se fusiona, la toma se fusionará una vez haya detenido el activador.

Conversión de activadores de teclado obsoletos en activadores

Nota:

La antigua columna de teclado del panel Marioneta ya no existe. Edite la tecla para un activador obsoleto en la sección “Activadores de teclado (obsoleto)” del panel Propiedades. También puede cambiar Bloquear y ocultar otros en los ajustes de Grupo. El ajuste Ocultar el resto del grupo puede seguir funcionando para teclas de activación empleadas por el comportamiento Activadores.

Para convertir una marioneta de activadores de teclado a activadores, siga estos pasos:

IMPORTANTE: El siguiente procedimiento elimina grabaciones existentes de activadores de teclado.

  1. Seleccione la marioneta en el panel Proyecto.

  2. Elija Marioneta > Convertir teclas de activación obsoletas.

    El comportamiento Activadores sustituye al comportamiento Activadores de teclado. Las teclas de activador existentes se convierten en los activadores equivalentes en el panel Activadores.

  3. (Opcional) Consolide cualquier activador no esencial en el panel Activadores arrastrando un activador sobre otro.

    Si ha convertido un archivo .puppet importado, exporte la marioneta a un nuevo archivo .puppet para conservar estos cambios.

Logotipo de Adobe

Inicia sesión en tu cuenta