Asignación de formato al código

Se puede aplicar formato al código y sangrarlo de forma automática mientras lo escribe. La utilización de asignación dinámica de fuentes garantiza el uso de las fuentes correctas cuando se trabaja con textos multilingües.

Establecimiento de las opciones de Formato automático

  1. Realice uno de los siguientes pasos:
    • En el menú Panel  (en la esquina superior derecha del panel Acciones), seleccione Preferencias.

    • En la ventana Script, seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh).

  2. En el cuadro de diálogo Preferencias, seleccione Formato automático.
  3. Seleccione cualquiera de las opciones de Formato automático.

    Una vez establecidas las opciones de Formato automático, la configuración se aplicará automáticamente al código que escriba, pero no al código que ya exista; deberá aplicar manualmente la configuración al código ya existente.

Aplicación de formato en función de las opciones de Formato automático

  • Haga clic en Formato automático  del panel Acciones o en la barra de herramientas de la ventana Script.
  • En el menú Panel (en la esquina superior derecha del panel Acciones), seleccione Formato automático.
  • Presione Ctrl+Mayús+F (Windows) o Comando+Mayúsculas+F (Macintosh).
  • En la ventana Script, seleccione Herramientas > Formato automático.

Utilización de asignación dinámica de fuentes

  1. Para activar o desactivar la asignación dinámica de fuentes, seleccione o anule la selección de Utilizar asignación dinámica de fuentes en el cuadro de diálogo Preferencias.

    La asignación dinámica de fuentes se encuentra desactivada de forma predeterminada, ya que así aumenta el tiempo de rendimiento al crear scripts. Si está trabajando con textos multilingües, deberá activar la asignación dinámica de fuentes, ya que de este modo, se asegura de que se utilizan las fuentes correctas.

Utilización de sangría automática

  1. Para activar y desactivar la sangría automática, seleccione o anule la selección de Sangría automática en el cuadro de diálogo Preferencias.

    Cuando la sangría automática está activada, el texto que se escribe después del paréntesis de apertura “(“ o llave inicial “{“ se sangra de forma automática según el valor de Tamaño de tabulación establecido en las preferencias de ActionScript.

    En los scripts, puede aplicar sangría a una línea seleccionándola y pulsando la tecla Tabulador. Para quitar la sangría, seleccione la línea y presione Mayús+Tab.

Comentarios de secciones de código

Los comentarios de código son partes del código que el compilador de ActionScript ignora. Una línea de comentario explica lo que hace el código, o desactiva temporalmente código que no desea eliminar. Para aplicar un comentario a una línea de código, iníciela con una barra diagonal (//). El compilador omite todo el texto de esa línea que sigue a la barra diagonal. También puede aplicar comentarios a bloques de código más grandes colocando una barra y un asterisco (/*) al principio del bloque, y un asterisco y una barra (*/) al final del mismo.

Puede escribir estos marcadores de comentario de forma manual o utilizar los botones de la parte superior del panel Acciones o de la ventana Script para añadirlos.

Comentario de una línea de código

  1. Sitúe el punto de inserción al principio de la línea o en el carácter donde desea que comience el comentario.
  2. Haga clic con el botón derecho y seleccione Comentar. También puede utilizar los métodos abreviados de teclado Ctrl + M (Windows) o Comando + M, o bien ir a Editar > Comentar selección.

Se coloca una barra diagonal (//) en el punto de inserción.

Comentario de varias líneas de código

  1. Seleccione las líneas a las que desea aplicar un comentario. (La primera y la última línea de la selección pueden ser líneas parciales.)
  2. Haga clic con el botón derecho y seleccione Comentar. También puede utilizar los métodos abreviados de teclado Ctrl + M (Windows) o Comando + M, o bien ir a Editar > Comentar selección.

Los caracteres del comentario de bloque se sitúan al principio (/*) y al final (/*) de la selección.

Nota:

si hay comentarios entre las líneas de texto seleccionadas, se aplicará un comentario de línea a todas las líneas seleccionadas.

Eliminación de un comentario

  1. Sitúe el punto de inserción en la línea que contiene el comentario o seleccione el bloque de código que tiene aplicado un comentario.
  2. Haga clic con el botón derecho y seleccione Quitar comentarios. También puede utilizar los métodos abreviados de teclado Ctrl + Mayús + M (Windows) o Comando + Mayús + M, o bien ir a Editar > Quitar comentarios de la selección.

Utilización de colores para la sintaxis

En ActionScript, como en cualquier lenguaje, la sintaxis es la manera en la que los elementos se agrupan para crear un significado. Si utiliza una sintaxis de ActionScript incorrecta, los scripts no funcionarán.

Para resaltar errores de sintaxis, establezca un código de color para partes de los scripts. Por ejemplo, supongamos que establece la preferencia de coloreado de la sintaxis de tal modo que las palabras clave se muestren en color azul. Cuando escriba var, la palabra var aparecerá en azul. No obstante si, por error, escribe vae, la palabra vae permanecerá de color negro, con lo cual usted sabrá inmediatamente que la ha escrito incorrectamente.

Realice uno de los siguientes pasos:

  • Seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh), haga clic en Editor de código en la lista Categoría y especifique la configuración de Colores de sintaxis.

  • Con el puntero del ratón en el panel Script, presione Control-U (Windows) o Comando-U (Macintosh).

Nota:

cuando escribe scripts en el panel Acciones, los comandos que no admite la versión del reproductor de destino aparecen en amarillo en la caja de herramientas Acciones. Por ejemplo, si la versión del archivo SWF de Flash Player está establecida en Flash 7, el código de ActionScript que sólo se admite en Flash Player 8 aparece en color amarillo en la caja de herramientas Acciones.

Utilización de la lista de identificadores y palabras clave en tiempo de ejecución

Al abrir Animate, las listas de identificadores y palabras clave se leen desde el archivo de recursos y se almacenan en la memoria caché. Además de leer las listas predeterminadas desde el recurso, también se buscan nuevas listas de palabras clave y de identificadores en la carpeta de preferencias. Es posible añadir palabras clave e identificadores adicionales si agrega "archivos .txt" en las siguientes carpetas:

  • C:\Users\<nombre de usuario>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<nombre de usuario>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<nombre de usuario>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<nombre de usuario>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Utilización de números de línea y ajuste de texto

Cuando edita o modifica código, los números de línea facilitan el desplazamiento y el análisis. El ajuste de texto ayuda a evitar tener que desplazarse horizontalmente por largas líneas de código (especialmente cuando trabaja en el entorno de edición o con resoluciones de pantalla bajas).

Activación y desactivación de números de línea

  • En la ventana Script, seleccione Ver > Números de línea.
  • Presione Ctrl+Mayús+L (Windows) o Comando+Mayúsculas+L (Macintosh).

Resaltado de una línea específica

  • En la ventana Script, seleccione Herramientas > Ir a la línea.

Activación o desactivación del ajuste de texto

  • En la ventana Script, seleccione Ver > Ajustar texto.
  • Presione las teclas Ctrl+Mayús+W (Windows) o Comando+Mayúsculas+W (Macintosh).

Visualización de caracteres ocultos

Los caracteres ocultos como espacios, tabuladores y saltos de línea están ocultos en el código ActionScript. Es posible que necesite visualizarlos; por ejemplo, debe buscar y quitar los espacios de doble byte que no forman parte de un valor de cadena, ya que éstos provocan errores del compilador.

  • Presione Ctrl+Mayús+8 (Windows) o Comando+Mayúsculas+8 (Macintosh).

Los siguientes símbolos se utilizan para mostrar cada uno de los caracteres ocultos.

Carácter oculto

Símbolo

Espacio de un solo byte

.

Espacio de doble byte

l

Tabulador

>>

salto de línea


Búsqueda de texto en un script

La herramienta Buscar le permite localizar y reemplazar cadenas de texto en los scripts.

Nota:

Para hacer una búsqueda en todos los scripts de un documento de Animate, utilice el explorador de películas.

Búsqueda de texto

  1. En el panel Acciones o en la ventana Script, haga clic en Buscar  o presione Ctrl+F (Windows) o Comando+F (Macintosh).
  2. Introduzca la cadena de búsqueda.
  3. Haga clic en Buscar siguiente.

Búsqueda y sustitución de texto en un script

  1. En el panel Acciones o en la ventana Script, haga clic en Buscar  o presione Ctrl+F (Windows) o Comando+F (Macintosh).
  2. Introduzca la cadena de búsqueda.
  3. En el cuadro de texto Reemplazar, introduzca la nueva cadena.
  4. Haga clic en Buscar siguiente.
  5. Para reemplazar la cadena, haga clic en Reemplazar; para reemplazar la cadena cada vez que aparezca, haga clic en Reemplazar todo.

(No se usa en Animate CC) Repetición de una búsqueda en el panel Acciones

  1. En el menú del panel  (en la esquina superior derecha del panel Acciones), seleccione Buscar otra vez.

(No se usa en Animate CC) Repetición de una búsqueda en la ventana Script

  1. Elija Edición > Buscar de nuevo.

(No se usa en Animate CC) Revisión de la sintaxis y la puntuación

Puede realizar una comprobación rápida del código ActionScript sin publicar el archivo FLA.

Cuando se revisa la sintaxis, se comprueba el script actual. Si el script activo llama a clases de ActionScript, éstas también se revisarán. Los demás scripts que puedan encontrarse en el archivo FLA no se revisan.

En el caso de archivos de ActionScript 2.0, la comprobación de sintaxis ejecuta el código en el compilador, por lo que se generan errores de sintaxis y de compilador.

En archivos de ActionScript 3.0, la comprobación de sintaxis genera únicamente errores de sintaxis. Para poder generar errores de compilador, como discordancias de tipos, valores devueltos no válidos y nombres de métodos o de variables mal escritos, utilice el comando Control > Probar.

Revisión de la sintaxis

Para comprobar la sintaxis, realice una de las acciones siguientes:

  • Haga clic en Revisar sintaxis en el panel Acciones o en la ventana Script .
  • Haga clic en el panel Script y, a continuación, presione Control+T (Windows) o Comando+T (Macintosh). Si hace clic o escribe en el panel Script le transferirá la selección. Si un objeto del escenario está seleccionado, se abre el panel Transformar en su lugar.

Los errores de sintaxis se muestran en el panel de errores del compilador.

Nota:

en un archivo de clase de ActionScript externo de la ventana Script, la ruta de clases global (AS2) o ruta de origen (AS3) afecta a la revisión de la sintaxis. Algunas veces podría generar errores a pesar de que la ruta de clases global o ruta de origen estén correctamente configuradas, ya que el compilador no tiene constancia de que se esté compilando esta clase.

Comprobración de emparejamiento de puntuación

  1. Haga clic entre las llaves {}, los corchetes [] o paréntesis () del script.
  2. En Windows, presione Control+' (comilla simple); en Macintosh, presione Comando+' (comilla simple). El texto entre llaves, corchetes o paréntesis se resalta y puede comprobar que la puntuación de apertura dispone de su correspondiente puntuación de cierre.

(No se usa en Animate CC) Importación y exportación de scripts

Se puede importar un script al panel Acciones o a la ventana Script. De igual forma se pueden exportar los scripts desde el panel Acciones o desde archivos ActionScript externos. (Cuando esté utilizando la ventana Script, la exportación es innecesaria, ya que puede guardar el archivo AS.)

Si el texto de los scripts no tiene el aspecto esperado al abrir o al importar un archivo, cambie la preferencia de codificación de importación.

Importación de un archivo AS externo

  1. En el panel Script, sitúe el punto de inserción donde desea situar la primera línea del script externo.
  2. Realice uno de los siguientes pasos:
    • En el panel Acciones, seleccione Importar script del menú Panel o presione Ctrl+Mayús+I (Windows) o Comando+Mayús+I (Macintosh).

    • En la ventana Script, seleccione Archivo > Importar script o presione Ctrl+Mayús+I (Windows) o Comando+Mayús+I (Macintosh).

Exportación de un script desde el panel Acciones

  1. Seleccione el script que desea exportar. A continuación elija Exportar script en el menú del panel Acciones o presione Ctrl+Mayús+I (Windows) o Comando+Mayús+I (Macintosh).
  2. Guarde el archivo de ActionScript (AS).

Establecimiento de las opciones de codificación del texto

  1. Seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh) y luego seleccione ActionScript en la lista Categoría.

  2. Defina cualquiera de las siguientes opciones:

    Abrir/importar

    Seleccione Codificación UTF-8 para abrir o importar con la codificación Unicode o bien Codificación predeterminada para abrir o importar con la codificación del idioma que utilice el sistema.

    Guardar/exportar

    Seleccione Codificación UTF-8 para guardar o exportar con la codificación Unicode o bien Codificación predeterminada para guardar o exportar con la codificación del idioma que utilice el sistema.

Activación o desactivación del mensaje de advertencia de la codificación de exportación

  1. Seleccione Edición > Preferencias (Windows) o Animate> Preferencias (Macintosh) y luego seleccione Advertencias en la lista Categoría.

  2. Seleccione o anule la selección de Avisar acerca de conflictos de codificación al exportar archivos ActionScript.

(No se usa en Animate CC) Codificación de script importados y exportados

Puede definir en las preferencias de ActionScript el tipo de codificación que se debe utilizar al importar o exportar archivos de ActionScript. La codificación UTF-8 es el formato Unicode de 8 bits, que permite incluir texto en varios idiomas en el archivo; la Codificación predeterminada es la codificación admitida por el idioma del sistema, que utiliza también se denomina página de códigos tradicional.

Nota:

si utiliza una aplicación en lengua no inglesa en un sistema en lengua inglesa, el comando Probar película dará un error si una parte cualquiera de la ruta del archivo SWF incluye caracteres que no pueden representarse mediante el esquema de codificación MBCS (Juegos de caracteres multibyte, Multibyte Character Sets). Por ejemplo, las rutas en japonés, que funcionan en un sistema en lengua japonesa, no funcionan en un sistema en inglés. Asegúrese de utilizar nombres de ruta solamente en inglés en sistemas en inglés. Esta limitación se aplica a todas las áreas de la aplicación que utilizan el reproductor Probar película.

Fijación de scripts en el panel Acciones

Utilice la función Fijar script para fijar fichas de scripts individuales en el panel Script y para moverlas como desee. Esta función es útil si no ha organizado el código del archivo FLA en una única ubicación central o si utiliza varios scripts.

También puede fijar un script para mantener la ubicación abierta del código en el panel Acciones y conmutar entre los distintos scripts abiertos. Esto puede resultar especialmente útil al depurar. 

También puede liberar un script o todos ellos desde el panel Acciones.

En la figura siguiente, el script asociado con la ubicación actual de la línea de tiempo se encuentra en el fotograma 1 de la capa llamada Simplificar. La ficha del extremo izquierdo siempre indica la ubicación a lo largo de la línea de tiempo. El script también se fija como se muestra en la ficha de la derecha. Se han fijado los dos scripts siguientes:

  • En el fotograma 1 
  • En el fotograma 15 de la capa llamada Intro

Utilice los métodos abreviados de teclado o haga clic en las fichas para desplazarse entre los scripts fijados. Desplazarse entre los distintos scripts fijados no cambia la posición actual en la línea de tiempo.Si se selecciona un script nuevo en el navegador de ActionScript, la selección se desplaza al primer fotograma, es decir, el fotograma 1.

Nota:

Si el contenido que muestra el panel Script no cambia de acuerdo con la ubicación que seleccione en la línea de tiempo, probablemente el panel Script está mostrando un script fijado. Haga clic en la ficha de fotograma actual de la parte superior izquierda del panel Script para mostrar el script asociado a su ubicación a lo largo de la línea de tiempo.

Un script fijado

Fijación de un script

  1. Haga clic en la línea de tiempo de manera que el script aparezca en la ficha de fotograma actual en la parte superior izquierda del panel Script del panel Acciones.

  2. Realice uno de los siguientes pasos:
    • Haga clic en el icono de la chincheta situado a la derecha de la ficha.
    • Seleccione Ver > Fijar script para fijar el script.

     

Liberar todos los scripts

  1. Seleccione el script fijado en el panel Acciones.

  2. Seleccione Ver > Liberar script para liberar el script seleccionado en el panel Acciones.

  3. Seleccione Ver > Liberar todos los script para liberar todos los scripts del panel Acciones.

Opciones de liberar

Métodos abreviados de teclado para scripts fijados

Cuando el punto de inserción está en el panel Script, utilice los siguientes métodos abreviados de teclado para trabajar con scripts fijados.

Acción

Windows 

Macintosh

Fijar script

Control + Mayús + = (signo igual)

Comando + Mayús + =

Liberar script

Control+Mayús+- (signo menos)

Comando+Mayús+-

Inserción de rutas de destino

Muchas acciones que se crean en el script afectan a clips de película, botones y otras instancias de símbolos. En el código, puede incluir referencias a instancias de símbolos en una línea de tiempo mediante la inserción de una ruta de destino, es decir, la dirección de la instancia a la que quiere hacer referencia. Puede establecer una ruta de destino absoluta o relativa. Una ruta absoluta contiene la dirección completa de la instancia. Una ruta relativa sólo contiene la parte de la dirección que difiere de la dirección del propio script en el archivo FLA, y dejará de funcionar si el script se desplaza a otra ubicación.

  1. En el panel Acciones, haga clic en una acción del script.
  2. Haga clic en Insertar una ruta de destino .
  3. Introduzca la ruta a la instancia de destino o seleccione el destino de la lista.
  4. Seleccione la opción de ruta Relativo o Absoluto.

Uso de sugerencias para el código

Al trabajar en el panel Acciones o en la ventana Script, el software puede detectar la acción que está introduciendo y mostrar una sugerencia para el código. Existen dos tipos de sugerencias sobre códigos: una sugerencia que contiene sintaxis completa de la acción y un menú emergente en el que se enumeran posibles elementos de ActionScript, como nombres de métodos o propiedades (lo que en ocasiones se denomina la funcionalidad de completar código).

Las sugerencias para el código están activadas de forma predeterminada. Al definir las preferencias, puede desactivar las sugerencias para el código o determinar la rapidez con la que aparecen. Aunque las sugerencias para el código estén desactivadas en las preferencias, puede mostrar de forma manual una sugerencia para un comando específico.

Nota:

si no puede ver sugerencias para el código de una variable u objeto que ha creado en ActionScript 2.0, pero las sugerencias están activadas en las preferencias de ActionScript, asegúrese de que ha asignado a la variable u objeto el sufijo adecuado o de que utiliza tipos de datos estrictos para la variable u objeto.

Activación de sugerencias para el código

Las sugerencias para el código se pueden activar de varias maneras.

Utilización de tipos estrictos para objetos

Cuando se utiliza ActionScript 2.0 y puede emplean tipos estrictos para una variable basada en una clase incorporada (como Button, Array, etc.), el panel Script muestra sugerencias de código para la variable. Por ejemplo, suponga que escribe las dos líneas de código siguientes:

var foo:Array = new Array(); 
foo.

Tan pronto como introduzca el punto (.), Animate muestra la lista de métodos y propiedades disponibles para objetos Array en el menú emergente, ya que escribió la variable como un conjunto.

Sufijos y sugerencias para el código

Si utiliza ActionScript 1.0 o desea visualizar las sugerencias para el código de los objetos que crea sin tipos de datos estrictos, debe añadir un sufijo especial al nombre de cada objeto cuando lo cree. Por ejemplo, el sufijo que activa las sugerencias para el código para la clase Camera es _cam. Suponga que escribe el código siguiente: var my_array = new Array(); var my_cam = Camera.get();

Si introduce my_cam seguido de un punto, aparecen las sugerencias de código para el objeto Camera.

Para los objetos que aparecen en el escenario, utilice el sufijo del cuadro de texto Nombre de instancia del inspector de propiedades. Por ejemplo, para ver las sugerencias para el código de objetos MovieClip, utilice el inspector de propiedades para asignar nombres de instancia con el sufijo _mc a todos los objetos MovieClip. Así, siempre que escriba el nombre de instancia seguido de un punto, se mostrarán las sugerencias para el código.

var my_array = new Array(); 
var my_cam = Camera.get();

Nota:

Aunque los sufijos no son necesarios para activar las sugerencias para el código cuando se utilizan tipos estrictos en un objeto, su utilización ayuda a comprender los scripts.

En la siguiente tabla se enumeran los sufijos que activan sugerencias para el código en ActionScript 2.0:

Tipo de objeto

Sufijo de la variable

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Vídeo

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Comentarios y sugerencias para el código

También puede utilizar comentarios de ActionScript para especificar una clase de objeto para las sugerencias para el código. En el ejemplo siguiente, un comentario indica a ActionScript que la clase de la instancia theObject es Object y así sucesivamente.

// Object theObject;// Array theArray;// MovieClip theMC;

Si especificara theMC seguido de un punto después de estos comentarios, aparecerían las sugerencias para el código que muestran la lista de métodos y propiedades de MovieClip. Si especificara theArray seguido de un punto después de estos comentarios, aparecerían las sugerencias para el código que muestran la lista de métodos y propiedades de MovieClip.

No obstante, Adobe recomienda que, en lugar de esta técnica, se utilicen tipos de datos estrictos o sufijos, ya que dichas técnicas activan automáticamente las sugerencias para el código y hacen que el código sea más comprensible.

Especificación de las preferencias para sugerencias de código automáticas

  • En el panel Acciones o en la ventana Script, seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh), haga clic en Editor de código en la lista Categoría y luego active o desactive Sugerencias de código.

(No se usa en Animate CC) Especificación de una demora en las sugerencias para el código

  1. En el panel Acciones o en la ventana Script, seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh).

  2. Haga clic en ActionScript de la lista Categoría.
  3. Utilice el deslizador para seleccionar una demora en segundos.

Utilización de sugerencias para el código con formato de información sobre herramientas

  1. Visualice las sugerencias para el código escribiendo un paréntesis de apertura “(“ después de un elemento que requiere paréntesis (por ejemplo, después de un nombre de método, un comando del tipo if o do..while, etc.).
    El paréntesis de apertura invoca las sugerencias para el código

  2. Introduzca un valor para el parámetro.

    Si va introducir varios parámetros, separe los valores con comas. En el caso de funciones o sentencias, como el bucle for, separe los parámetros con punto y coma.

    Los comandos sobrecargados (funciones o métodos que pueden invocarse con diferentes conjuntos de parámetros), como gotoAndPlay() o for, muestran un indicador que permite seleccionar el parámetro que desea establecer. Para seleccionar el parámetro, haga clic en las flechas pequeñas o presione Ctrl+Flecha izquierda o Ctrl+Flecha derecha.

    Una sugerencia para el código para varios conjuntos de parámetros

  3. Para cerrar la sugerencia para el código, utilice uno de los procedimientos siguientes:
    • Escriba un paréntesis de cierre “)”.

    • Haga clic fuera de la sentencia.

    • Presione Esc.

Utilización de sugerencias para el código con formato de menú

  1. Visualice la sugerencia para el código escribiendo un punto después del nombre de objeto o variable.
    Utilización de sugerencias para el código con formato de menú

  2. Para desplazarse por las sugerencias para el código, utilice las teclas de flecha arriba y flecha abajo.
  3. Para seleccionar un elemento del menú, presione Intro o el tabulador, o haga doble clic en el elemento.
  4. Para cerrar la sugerencia para el código, utilice uno de los procedimientos siguientes:
    • Seleccione uno de los elementos del menú.

    • Haga clic por encima o por debajo de la ventana de menú.

    • Escriba un paréntesis de cierre “)” si ya ha utilizado un paréntesis de apertura “(“.

    • Presione Esc.

Visualización manual de una sugerencia para el código

  1. Haga clic en una ubicación de código en la que puedan aparecer sugerencias de código, como en las siguientes ubicaciones:
    • Detrás del punto (.) que aparece a continuación de una sentencia o comando, donde debe especificarse una propiedad o un método

    • Entre paréntesis [()] en un nombre de método

  2. Realice uno de los siguientes pasos:
    • Para activar manualmente las sugerencias para el código, seleccione Ver > Mostrar sugerencia para el código.

    • Presione Ctrl+barra espaciadora (Windows) o Comando+barra espaciadora (Macintosh).

Sugerencias de código para clases personalizadas

Cuando se crean clases personalizadas de ActionScript 3.0, Animate las analiza y determina los objetos, las propiedades y los métodos que contienen. Luego Animate puede proporcionar sugerencias de código cuando se escribe código que hace referencia a las clases personalizadas. La finalización de código de clases personalizadas es automática en cualquier clase que vincule a otro código con el comando import.

Las sugerencias de código permiten a los desarrolladores trabajar más rápido al no tener que recordar todos los objetos, métodos y propiedades utilizados por la clase. Los diseñadores pueden trabajar con clases que no han escrito ellos mismos porque no necesitan tener información de primera mano para poder trabajar con ellas.

Las sugerencias de código incluyen lo siguiente:

  • Sugerencias de código para referencias de clases anidadas

    Cuando se escriben referencias anidadas, la ayuda de las sugerencias de código resulta muy útil.

  • Sugerencia de código para “this”

    Cuando escribe “this” en un archivo de clase, las sugerencias de código son las de dicha clase.

  • Sugerencia de código para “new+<espacio>”

    Al escribir “new+<espacio>”, Animate muestra una lista con las clases y los paquetes disponibles.

  • Sugerencia de código para “import”

    Al escribir “import+<espacio>”, Animate muestra una lista con los paquetes integrados y los personalizados.

  • Sugerencia de código para bibliotecas SWC

    Cuando se añade una biblioteca SWC a la ruta de biblioteca de la ruta de biblioteca externa, Animate activa las sugerencias de código para todas las clases incluidas en el archivo SWC.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea