Texto en varios idiomas

Puede configurar un archivo FLA para que muestre texto en distintos idiomas, en función del idioma del sistema operativo en el que se reproduzca el contenido de Animate.

Nota:

en nuestra página web dispone de ayuda completa y actualizada. La aplicación no ha detectado ninguna conexión a Internet. Para leer la versión íntegra de este tema, haga clic en el vínculo siguiente o revise la ayuda completa en http://helpx.adobe.com/es/support.html.

Puede configurar un archivo FLA para que muestre texto en distintos idiomas, en función del idioma del sistema operativo en el que se reproduzca el contenido de Animate.

Consulte los temas sobre texto en varios idiomas en la ayuda en línea para saber más sobre cómo trabajar con texto en varios idiomas en Animate.

Texto en varios idiomas en Animate

Puede incluir texto en varios idiomas en su documento de las siguientes formas:

  • (Ya no se usa en Animate CC) El nuevo panel Cadenas permite a los localizadores editar cadenas de una ubicación central en Animate o en archivos XML externos con su aplicación o memoria de traducción preferida. Animate admite líneas múltiples tanto en el panel Cadenas como en los archivos XML.

  • Puede seleccionar qué juegos de caracteres desea incorporar en sus aplicaciones, con lo cual limitará el número de glifos en el archivo SWF publicado y reducirá el tamaño.

  • Utilice un teclado occidental para crear texto en el escenario en chino, japonés y coreano.

  • Si tiene instaladas fuentes Unicode en su sistema, introduzca texto directamente en un campo de texto. Las fuentes no están incorporadas, y por lo tanto los usuarios deben tener también fuentes Unicode.

    A continuación se describen otros métodos menos comunes para incluir texto en varios idiomas en un documento de Animate:

  • Puede incluir un archivo externo de texto en un campo de texto dinámico o de entrada, utilizando la acción #include.

  • Cargar texto externo o archivos XML en una aplicación de Animate en tiempo de ejecución mediante las acciones loadVariables o getURL, o con los objetos LoadVars o XML.

  • Puede introducir caracteres de escape Unicode en el valor de cadena de una variable de campo de texto dinámico o de entrada.

  • Puede crear una fuente incorporada como símbolo en la biblioteca.

    Para que se muestre correctamente el texto Unicode, los usuarios deben tener acceso a las fuentes que contienen los glifos (caracteres) utilizados en ese texto.

Para obtener un ejemplo de contenido en varios idiomas, visite la página de ejemplos de Animate en www.adobe.com/go/learn_fl_samples_es. Descargue y descomprima el archivo zip de ejemplos y vaya a la carpeta Text\MultilingualContent para acceder al ejemplo.

Fuentes para texto codificado con Unicode

Si utiliza archivos externos codificados con Unicode, los usuarios deben tener acceso a las fuentes que contienen todos los glifos utilizados en los archivos de texto. De forma predeterminada, Animate almacena los nombres de las fuentes que se utilizan en los archivos de texto dinámico o de entrada. Durante la reproducción de un archivo SWF, Flash Player 7 (y versiones anteriores) busca estas fuentes en el sistema operativo en el que se ejecuta el reproductor.

Si el texto de un archivo SWF contiene glifos que no son compatibles con la fuente especificada, Flash Player 7 y Flash Player 8 intentan localizar una fuente en el sistema del usuario que sea compatible con esos glifos. El reproductor no siempre puede localizar una fuente adecuada. Este comportamiento depende de las fuentes disponibles en el sistema del usuario y en el sistema operativo en el que se ejecuta Flash Player.

Tabla de incorporación de fuentes XML

Cuando se seleccionan rangos de fuentes para incorporarlas en un archivo FLA, Animate utiliza el archivo UnicodeTable.xml para determinar los caracteres que se incorporan. El archivo UnicodeTable.xml contiene rangos de caracteres necesarios para distintos idiomas y se ubica en la carpeta de configuración del usuario del equipo. El archivo se encuentra en los siguientes directorios:

  • Windows: <unidad de arranque>\Documents and Settings\<usuario>\Local Settings\Application Data\Adobe\Flash<versión>\<idioma>\Configuration\FontEmbedding\

  • Macintosh: <usuario>/Library/Application Support/Adobe/Flash <versión>/<idioma>/Configuration/FontEmbedding/

La agrupación de conjuntos de fuentes se hace de acuerdo con los bloques Unicode que define el Consorcio de Unicode. Para simplificar el flujo de trabajo, cuando selecciona un idioma concreto, se incorporan todos los rangos de glifos relacionados aunque estén dispersos en grupos separados.

Por ejemplo, si selecciona coreano, se incorporan los siguientes rangos de caracteres Unicode.

Símbolos hangul 3131-318E

Especiales hangul 3200-321C

Especiales hangul 3260-327B

Símbolos coreanos 327F-327F

Símbolos hangul AC00-D7A3

Si selecciona coreano + CJK, entonces se incorpora un conjunto de fuentes más grande:

Símbolos hangul 3131-318E

Especiales hangul 3200-321C

Especiales hangul 3260-327B

Símbolos coreanos 327F-327F

Símbolos CJK 4E00-9FA5

Símbolos hangul AC00-D7A3

Símbolos CJK F900-FA2D

Para obtener información sobre los rangos Unicode específicos para distintos sistemas de escritura, consulte la especificación de Unicode 5.2.0 (en inglés).

La tabla siguiente da más detalles sobre la selección de las fuentes incorporadas:

Rango

Descripción

Mayúsculas [A–Z]

Glifos de Latin básico en mayúsculas, más el carácter de espacio 0x0020.

Minúsculas [a–z]

Glifos de Latin básico en minúsculas, más el carácter de espacio 0x0020.

Numerales [0–9]

Glifos de Latin básico numerales

Puntuación [!@#%...]

Puntuación de Latin básico

Latin básico

Glifos de Latin básico en el rango Unicode 0x0020 a 0x007E.

Japonés Kana

Glifos Hiragana y Katakana (incluidos los caracteres de medio ancho)

Japonés Kanji: nivel 1

Caracteres japonés Kanji

Japonés (Todo)

Japonés Kana y Kanji (puntuación y caracteres especiales incluidos)

Hangul básico

Caracteres coreanos, caracteres romanos, puntuaciones y caracteres y símbolos especiales más comunes

Hangul (todo)

11.720 caracteres coreanos (ordenados por sílabas hangul), caracteres romanos, puntuaciones y caracteres y símbolos especiales

Chino tradicional: nivel 1

Los 5000 caracteres del chino tradicional más utilizados en Taiwán

Chino tradicional (todo)

Todos los caracteres y puntuaciones del chino tradicional utilizados en Taiwán y Hong Kong

Chino simplificado: nivel 1

Los 6000 caracteres y puntuaciones del chino simplificado más utilizados en China

Chino (Todo)

Todos los caracteres y puntuaciones del chino tradicional y del chino simplificado

Tailandés

Todos los glifos del tailandés

Devanagari

Todos los glifos del devanagari

Latin I

Rango suplementario 0x00A1 a 0x00FF de Latín 1 (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Latin extendido A

Rango 0x0100 a 0x01FF de Latin extendido A (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Latin extendido B

Rango 0x0180 a 0x024F de Latin extendido B (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Latin extendido adicional

Rango 0x1E00 a 0x1EFF de Latin extendido adicional (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Griego.

Griego y cóptico, además de griego extendido (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Cirílico

Cirílico (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Armenio

Armenio con ligaduras

Árabe

Árabe con formatos de presentación A y formatos de presentación B

Hebreo

Hebreo con formatos de presentación (incluyen puntuación, superíndices y subíndices, símbolos de moneda y símbolos parecidos a letras)

Archivos externos no Unicode

Si carga archivos externos de texto o XML en una aplicación de Flash Player 7 que no está codificada con Unicode, el texto de los archivos externos no se mostrará correctamente cuando Flash intente mostrarlos como Unicode. Para que Flash Player utilice la página de códigos tradicional del sistema operativo en el que se ejecuta el reproductor, añada el siguiente código como la primera línea de código del primer fotograma de la aplicación de Animate que esté cargando los datos:

system.useCodepage = true;

Establezca la propiedad system.useCodepage sólo una vez en un documento; no la utilice varias veces en un mismo documento para que el reproductor interprete algunos archivos externos como Unicode y otros como otro tipo de codificación, ya que esto podría conllevar resultados inesperados.

Si establece la propiedad system.useCodepage en true, la página de códigos tradicional del sistema operativo en el que se ejecuta el reproductor debe incluir los glifos utilizados en su archivo de texto externo para que se muestre el texto. Por ejemplo, si carga un archivo de texto externo que contiene caracteres chinos, dichos caracteres no se visualizarán en un sistema que utilice la página de códigos CP1252, ya que dicha página de códigos no contiene caracteres chinos. Para garantizar que los usuarios de todas las plataformas puedan ver los archivos de texto externos que se utilizan en sus aplicaciones de Animate, debe codificar todos los archivos de texto externos como Unicode y establecer la propiedad system.useCodepage en false de forma predeterminada. De este modo, Flash Player interpretará el texto como Unicode. Para obtener más información, consulte useCodepage (propiedad System.useCodepage) Referencia del lenguaje ActionScript 2.0.

Codificación de texto

Todo el texto de un ordenador está codificado en una serie de bytes. El texto está representado por varias formas de codificación (y por lo tanto por varios bytes). Sistemas operativos diferentes utilizan diferentes tipos de codificación de texto. Por ejemplo, normalmente, los sistemas operativos Windows occidentales utilizan codificación CP1252; los sistemas operativos Macintosh occidentales utilizan codificación MacRoman; los sistemas Windows y Macintosh japoneses utilizan codificación Unicode.

Unicode puede codificar la mayoría de los idiomas y caracteres del mundo. Los otros formatos de codificación de texto utilizados en los ordenadores son subconjuntos del formato Unicode, adaptados para cada zona del mundo. Algunos de estos formatos son compatibles en algunas zonas e incompatibles en otras, de modo que es esencial utilizar la codificación correcta.

Hay varios tipos de Unicode. Las versiones 6 y 7 de Flash Player (y posteriores) son compatibles con archivos externos y de texto en el formato Unicode de 8 bits UTF-8 y con los formatos Unicode de 16 bits UTF-16 BE (Big Endian) y UTF-16 LE (Little Endian).

Unicode y Flash Player

Flash Player 6 y las versiones posteriores son compatibles con la codificación de texto Unicode. Cualquier usuario con Flash Player 6 o versiones posteriores puede ver texto en varios idiomas si tiene instaladas las fuentes apropiadas, independientemente del idioma que utilice el sistema operativo en el que se ejecuta el reproductor.

Flash Player presupone que todos los archivos de texto externos asociados con una aplicación Flash Player están codificados con Unicode, a no ser que se especifique lo contrario.

Para aplicaciones de Animate de Flash Player 5 o versiones anteriores que se editan en Flash MX o anteriores, Flash Player 6 y las versiones anteriores muestran el texto utilizando la página de códigos tradicional del sistema operativo en el que se ejecuta el reproductor.

Para información general sobre Unicode, consulte Unicode.org.

Codificación de texto en Flash Player

De forma predeterminada, Flash Player 7 y versiones posteriores presuponen que todo el texto que encuentra está codificado con Unicode. Si su documento carga archivos externos de texto o archivos XML, el texto de estos archivos debe estar codificado con UTF-8. Puede crear estos archivos utilizando el panel Cadenas o en un editor de texto o de HTML en el que se puedan guardar los archivos en formato Unicode.

Formatos de codificación Unicode admitidos por Flash Player

Cuando lee datos de texto con Animate, Flash Player examina los dos primeros bytes del archivo para detectar una marca de orden de byte (BOM), una convención de formato estándar que se utiliza para identificar el formato de codificación Unicode. Si no se detecta BOM, se interpreta la codificación del texto como UTF-8 (un formato de codificación de 8 bits). Es recomendable que utilice codificación UTF-8 en sus aplicaciones.

Si Flash Player detecta uno de los siguientes BOM, el formato de codificación de texto se interpreta de la siguiente manera:

  • Si el primer byte del archivo es OxFE y el segundo es OxFF, la codificación se interpreta como UTF-16 BE (Big Endian). Esta codificación se utiliza para sistemas operativos Macintosh.

  • Si el primer byte de un archivo es OxFF y el segundo es OxFE, la codificación se interpreta como UTF-16 LE (Little Endian). Esta codificación se utiliza para sistemas operativos Windows.

    la mayoría de los editores de texto que pueden guardar archivos como UTF-16BE o LE añaden automáticamente los BOM a los archivos.

    nota: si establece la propiedad system.useCodepage en true, el texto se interpreta utilizando la página de códigos tradicional del sistema operativo en el que se ejecuta el reproductor; no se interpreta como Unicode.

Codificación en archivos XML externos

No puede cambiar la codificación de un archivo XML cambiando la etiqueta de codificación. Flash Player identifica la codificación de un archivo XML externo utilizando las mismas reglas que se aplican a todos los archivos externos. Si no se encuentra marca de orden de byte al principio del archivo, se presupone que el archivo está codificado en UTF-8. Si se encuentra una marca de orden de byte, se interpreta el archivo como UTF-16BE o LE.

Creación de texto en varios idiomas

Puede configurar un archivo FLA para que muestre texto en distintos idiomas, en función del idioma del sistema operativo en el que se reproduzca el contenido de Animate.

Nota:

en nuestra página web dispone de ayuda completa y actualizada. La aplicación no ha detectado ninguna conexión a Internet. Para leer la versión íntegra de este tema, haga clic en el vínculo siguiente o revise la ayuda completa en http://helpx.adobe.com/es/support.html.

Puede configurar un archivo FLA para que muestre texto en distintos idiomas, en función del idioma del sistema operativo en el que se reproduzca el contenido de Animate.

Consulte los temas sobre creación de texto en varios idiomas en la ayuda en línea para saber más sobre el modo de añadir texto en varios idiomas a los archivos FLA.

Flujo de trabajo para la creación de texto en varios idiomas con el panel Cadenas

El panel cadenas le permite crear y mantener contenido multilingüe. Puede especificar diferente contenido para los campos de texto que abarcan varios idiomas y que Animate determine automáticamente el contenido que debe mostrar en función del idioma del equipo en el que se ejecuta Flash Player.

A continuación se describe el flujo de trabajo general:

Cree un archivo FLA en un idioma.

Cualquier texto que desee introducir en otro idioma debe estar en un campo de texto dinámico o de entrada.

En el cuadro de diálogo Configuración del panel Cadenas, seleccione los idiomas que desea incluir y designe uno de ellos como idioma predeterminado.

Se añadirá una columna del idioma en el panel Cadenas. Al guardar, probar y publicar la aplicación, se crea para cada idioma una carpeta con un archivo XML.

En el panel Cadenas, codifique cada cadena de texto con un ID.

Publique la aplicación.

Se crea una carpeta para cada idioma que selecciona, y dentro de cada carpeta de idioma hay un archivo XML para ese idioma.

Envíe el archivo FLA publicado y las carpetas y archivos XML a sus traductores.

Cree el texto en su propio idioma y deje que los traductores lo traduzcan. Se puede utilizar software de traducción directamente en los archivos XML o en el archivo FLA.

Cuando reciba las traducciones de los traductores, vuelva a importar los archivos XML traducidos al archivo FLA.

Nota:

los archivos de Flash Pro CS4 con campos de texto dinámicos con suavizado clásico rellenados desde el panel cadenas pueden no visualizarse correctamente al actualizar a Flash Pro CS5. Esto se debe a cambios realizados en la incorporación de fuentes en Flash Pro CS5. Para solucionar el problema, incorpore manualmente las fuentes empleadas en los campos de texto. Para obtener instrucciones, consulte Incorporación de fuentes para obtener un aspecto de texto uniforme.

Selección y eliminación de idiomas de traducción

Puede seleccionar hasta 100 idiomas diferentes que pueden aparecer en el escenario y en el panel Cadenas para su traducción. Cada idioma que seleccione se convierte en una columna en el panel Cadenas. Puede cambiar el idioma de escenario para que el texto del escenario aparezca en cualquiera de los idiomas que seleccione. El idioma seleccionado aparece cuando se publica o se prueba el archivo.

Al seleccionar idiomas, puede utilizar cualquiera de los idiomas disponibles en el menú, además de cualquier otro idioma compatible con Unicode.

Selección de un idioma

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Configuración.
  2. Añada un idioma realizando uno de los procedimientos siguientes:
    • En el cuadro Idiomas, señale el idioma que desea seleccionar y haga clic en Añadir.

    • Si el idioma no aparece en el cuadro Idiomas, escriba el código de lenguaje en el campo vacío situado debajo de él en formato xx. (El código de idioma se toma de la norma ISO 639‑1.) Haga clic en Añadir.

  3. Repita el paso anterior hasta que haya añadido todos los idiomas necesarios.
  4. Seleccione un idioma predeterminado en el menú Idioma predeterminado en tiempo de ejecución. Este idioma se muestra en los sistemas que no tienen uno de los idiomas activos que ha seleccionado.
  5. Si desea cargar un archivo XML para los idiomas de una URL diferente en tiempo de ejecución, introduzca la URL en el campo de texto URL y haga clic en Aceptar.

    En el panel Cadenas aparece una columna para cada idioma seleccionado. Las columnas aparecen en orden alfabético.

  6. Guarde el archivo FLA. Al guardar el archivo FLA, se crea una carpeta para cada uno de los idiomas seleccionados en la misma carpeta indicada en la ruta de publicación de SWF. Si no se ha seleccionado ninguna ruta de publicación de SWF, dicha ruta se creará en la carpeta en la que se encuentre el archivo FLA. En cada uno de los archivos de idioma se creará un archivo XML que se utilizará para cargar texto traducido.

Eliminación de un idioma

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Configuración.
  2. En el campo Idiomas activos, señale el idioma y haga clic en el botón Quitar.
  3. Repita el paso 3 hasta que haya quitado todos los idiomas que no se necesitan.
  4. Cuando haya acabado de quitar idiomas, haga clic en Aceptar.

    Ya no aparecen columnas para los idiomas eliminados en el panel Cadenas.

Nota:

cuando se elimina un idioma del panel Cadenas, el archivo XML del idioma no se elimina del sistema de archivos local. Esto le permite añadir nuevamente el idioma al panel Cadenas utilizando el archivo XML original y así se evita que quede eliminado por error. Para eliminar el idioma por completo, debe eliminar o sustituir el archivo XLM de idioma.

Adición de cadenas al panel Cadenas

Se pueden asignar cadenas de texto en el panel Cadenas del modo siguiente:

  • Se puede asignar un ID de cadena a un campo de texto dinámico o de entrada.

  • Se puede añadir un ID de cadena al panel Cadenas sin asignarlo a un campo de texto.

  • Se puede asignar un ID de cadena existente a un campo de texto dinámico o de entrada existente.

Asignación de un ID de cadena a un campo de texto

  1. Seleccione Ventana > Otros paneles > Cadenas.
  2. Seleccione la herramienta Texto. En el escenario, cree un campo de texto dinámico o de entrada.
  3. Mientras el campo de texto esté seleccionado, introduzca un ID único en el campo ID del panel Cadenas.
  4. Haga clic en el botón Configuración y seleccione uno o varios idiomas de la lista en el cuadro de diálogo Configuración. Los idiomas que seleccione deben incluir el idioma predeterminado que quiera utilizar y otros idiomas en los que desee publicar su trabajo.
  5. Haga clic en Aplicar.

Nota:

si se selecciona un campo de texto estático en el escenario, la sección de selección de texto del escenario del panel Cadenas muestra el mensaje “El texto estático no puede tener un ID asociado". Si se ha seleccionado un elemento que no es de texto o múltiples elementos, muestra el mensaje “La selección actual no puede tener un ID asociado”.

Se puede añadir un ID de cadena al panel Cadenas sin asignarlo a un campo de texto.

  1. Seleccione Ventana > Otros paneles > Cadenas.
  2. Haga clic en el botón Configuración y seleccione uno o varios idiomas de la lista en el cuadro de diálogo Configuración. Los idiomas que seleccione deben incluir el idioma predeterminado que quiera utilizar y otros idiomas en los que desee publicar su trabajo.
  3. Introduzca un nuevo ID de cadena y una cadena nueva en el panel Cadenas y haga clic en Aplicar.

Asignación de un ID existente a un campo de texto

  1. Seleccione la herramienta Texto. En el escenario, cree un campo de texto dinámico o de entrada.
  2. Introduzca el nombre de un ID existente en la sección ID del panel Cadena y haga clic en Aplicar.

Nota:

puede utilizar Mayús+tecla Intro para aplicar el ID al campo de texto, o Intro si el campo ID está activo.

Edición de texto en el panel Cadenas

Después de introducir cadenas de texto en el panel Cadenas, puede editarlo siguiendo uno de los métodos siguientes:

  • Directamente en las celdas del panel Cadenas.

  • En el escenario, con el idioma seleccionado como idioma del escenario utilizando las funciones de edición como buscar y reemplazar o la corrección ortográfica. El texto modificado mediante estas funciones se modifica en el escenario y en el panel Cadenas.

  • Editando directamente el archivo XML.

Cambio del idioma que se muestra en el escenario

  1. Seleccione Ventana > Otros paneles > Cadenas.
  2. En el menú Idioma de escenario, seleccione el idioma que desea usar como idioma de escenario. Debe ser uno de los idiomas que añadió como idioma disponible.

    Después de cambiar el idioma del escenario, el texto que introduzca en el escenario se mostrará en ese idioma. Si previamente ha introducido cadenas de texto para el idioma del panel Cadenas, el texto del escenario se mostrará en el idioma seleccionado. Si no, los campos de texto que ya están en el escenario están en blanco.

Entrada de caracteres asiáticos en un teclado occidental

Con Animate, puede introducir caracteres asiáticos en el escenario con un teclado occidental estándar utilizando editores de método de entrada (IME). Animate es compatible con más de veinte IME.

Por ejemplo, si desea crear un sitio web al que puedan acceder usuarios asiáticos, puede utilizar un teclado occidental estándar (QWERTY) y cambiar el editor de método de entrada para crear el texto en chino, japonés y coreano.

Nota:

esta función afecta solamente al texto introducido en el escenario, y no al texto introducido en el panel Acciones. Esta función está disponible para todos los sistemas operativos Windows y Mac OS X.

  1. Seleccione Edición > Preferencias (Windows) o Animate > Preferencias (Macintosh) y haga clic en Texto en la lista Categoría.

  2. En Método de entrada, seleccione una de las opciones de entrada de caracteres con un teclado occidental. El valor predeterminado es el chino y el japonés; también debe seleccionarse para los idiomas occidentales.

Publicación de archivos FLA en varios idiomas

Cuando se guarda, publica o prueba un archivo FLA, se crea una carpeta con un archivo XML para cada idioma disponible que se selecciona en el panel Cadenas. La ubicación predeterminada de los archivos y las carpetas XML es la carpeta indicada como ruta de publicación de SWF. Si no se ha seleccionado ninguna ruta de publicación de SWF, los archivos y las carpetas XML se guardan en la carpeta en la que se encuentra el archivo FLA. Por ejemplo, si tiene un archivo llamado Test en el directorio mystuff y ha seleccionado inglés (en), alemán (de) y español (es) como idiomas activos, pero no ha seleccionado una ruta de publicación de SWF, al guardar el archivo FLA se creará la estructura de carpetas siguiente:

\mystuff\Test.fla 
\mystuff\de\Test_de.xml 
\mystuff\en\Test_en.xml 
\mystuff\es\Test_es.xml

Si inicia un archivo SWF, también deberá iniciar los archivos XML asociados con las traducciones de la cadena en el servidor. El primer fotograma que contiene texto no puede mostrarse hasta que se descargue el archivo XML entero.

Reemplazo manual de cadenas en el momento de la publicación

Cuando publique el archivo SWF de Animate puede reemplazar cadenas manualmente utilizando el idioma del escenario. Este método utiliza el idioma del escenario para sustituir todas las instancias de texto dinámico y de introducción de texto con un ID de cadena asociado. En este caso, las cadenas sólo se actualizan cuando se publica el archivo SWF; la detección de idioma no es automática y deberá publicar un archivo SWF por cada idioma que desee.

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Configuración.
  2. Seleccione la casilla de verificación Reemplazar cadenas automáticamente en tiempo de ejecución.

Utilización de la detección automática de idiomas con el idioma predeterminado

Puede cambiar el idioma en tiempo de ejecución predeterminado por cualquier idioma que haya seleccionado como idioma activo. Cuando la detección automática de idiomas está activada y visualiza el archivo SWF del sistema que utiliza el idioma, todos los sistemas definidos con un idioma distinto de los idiomas activos utilizarán el idioma predeterminado. Por ejemplo, si su idioma predeterminado es Inglés, y ha seleccionado ja, en y fr como idiomas activos, los usuarios cuyos sistemas sean en japonés, inglés o francés automáticamente verán las cadenas de texto en su idioma seleccionado. Sin embargo, los usuarios cuyos sistemas sean en sueco, que no es uno de los idiomas que usted ha seleccionado, automáticamente verán las cadenas de texto en el idioma predeterminado que seleccionó (en este caso, el inglés).

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Configuración.
  2. En el menú Idioma predeterminado, seleccione el idioma predeterminado. Debe ser uno de los idiomas que añadió como idioma disponible.
  3. Para activar la detección automática de idiomas, seleccione Reemplazar cadenas automáticamente en tiempo de ejecución y haga clic en Aceptar.

Animate genera el siguiente código de ActionScript ®, que almacena las rutas de acceso a los archivos XML de idioma. Puede utilizar este código como base para crear su propio script de detección de idioma.

import mx.lang.Locale; 
Locale.setFlaName("<flaFileName>"); 
Locale.setDefaultLang("langcode"); 
Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

Nota:

el código ActionScript generado por el panel Cadenas no utiliza la función Locale.initialize. Debe decidir cómo efectuar la llamada a esta función basándose en las personalizaciones de detección de idioma que su proyecto exige.

Utilización de la detección personalizada de idiomas

Para acceder a los archivos XML de idioma que controlan la sustitución de texto en el momento de designarlo, cree un componente personalizado o utilice código ActionScript. Por ejemplo, puede crear un menú emergente que permita a los usuarios seleccionar el lenguaje en que prefieren ver el contenido.

Para obtener información sobre cómo codificar ActionScript para crear detección de idioma personalizado, consulte Panel Cadenas Aprendizaje de ActionScript 2.0.

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Configuración.
  2. En el menú Idioma predeterminado, seleccione el idioma predeterminado.

    Debe ser uno de los idiomas que añadió como idioma disponible.

  3. Seleccione la casilla de verificación Reemplazar cadenas mediante ActionScript y haga clic en Aceptar.

    Animate genera el siguiente código de ActionScript que almacena las rutas de acceso a los archivos XML de idioma. Puede utilizar este código como base para crear su propio script de detección de idioma.

    import mx.lang.Locale; 
    Locale.setFlaName("<flaFileName>"); 
    Locale.setDefaultLang("langcode"); 
    Locale.addXMLPath("langcode", "url/langcode/flaname_langcode.xml");

Nota:

el código ActionScript generado por el panel Cadenas no utiliza la función Locale.initialize. Debe decidir cómo efectuar la llamada a esta función basándose en las personalizaciones de detección de idioma que su proyecto exige.

Recursos adicionales

Formato de archivo XML para texto en varios idiomas

Cuando se utiliza texto en varios idiomas en Animate, se almacena en archivos XML.

Nota:

en nuestra página web dispone de ayuda completa y actualizada. La aplicación no ha detectado ninguna conexión a Internet. Para leer la versión íntegra de este tema, haga clic en el vínculo siguiente o revise la ayuda completa en http://helpx.adobe.com/es/support.html.

Cuando se utiliza texto en varios idiomas en Animate, se almacena en archivos XML.

Consulte los temas sobre el formato de archivo XML en la ayuda en línea para saber más sobre cómo trabajar con estos archivos XML y cómo importarlos a un archivo FLA.

Información sobre el formato de archivo XML

El XML que se exporta está en formato UTF-8 y sigue el estándar del formato de archivo de intercambio de localización XML (XLIFF) 1.0. Se utiliza para definir una especificación para un formato de intercambio de localización extensible que permita a cualquier proveedor de software producir un formato de intercambio único que pueda recibir y entender cualquier proveedor de servicios de localización. Para obtener más información sobre XLIFF, consulte www.oasis-open.org/committees/xliff/.

Ejemplos de XLIFF

Si se introduce alguno de los caracteres siguientes en el panel Cadenas, se sustituyen por los elementos correspondientes al escribirlos en archivos XML:

Carácter

Sustituido por

&

&amp;amp;amp;

'

&apos;

"

&quot;

<

&lt;

>

&gt;

Muestra de archivo XML exportado

Los ejemplos siguientes ilustran el aspecto que tiene un archivo XML generado por el panel Cadenas en el idioma origen (en este ejemplo, inglés) y en otro idioma (en este ejemplo, francés).

Muestra de idioma origen en inglés:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="en"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>welcome to our web site!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Would you like to be on our mailing list?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>see you soon!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

Ejemplo de versión de origen en francés:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE xliff PUBLIC "-//XLIFF//DTD XLIFF//EN" 
"http://www.oasis-open.org/committees/xliff/documents/xliff.dtd" > 
<xliff version="1.0" xml:lang="fr"> 
<file datatype="plaintext" original="MultiLingualContent.fla" source-language="EN"> 
        <header></header> 
        <body> 
            <trans-unit id="001" resname="IDS_GREETINGS"> 
                <source>Bienvenue sur notre site web!</source> 
            </trans-unit> 
            <trans-unit id="002" resname="IDS_MAILING LIST"> 
                <source>Voudriez-vous être sur notre liste de diffusion?</source> 
            </trans-unit> 
            <trans-unit id="003" resname="IDS_SEE YOU"> 
                <source>A bientôt!</source> 
            </trans-unit> 
            <trans-unit id="004" resname="IDS_TEST"> 
                <source></source> 
            </trans-unit> 
        </body> 
    </file> 
</xliff>

Traducción de texto en el panel Cadenas o en un archivo XML

Al enviar archivos a los traductores, debe incluir, además del archivo FLA, las carpetas de los archivos XML y el archivo XML de cada idioma.

Los traductores pueden trabajar directamente en las columnas de idioma del panel Cadenas o bien trabajar en los archivos XML de cada idioma para traducir el archivo FLA a los idiomas seleccionados. Si traduce directamente en el archivo XML, debe importar el archivo XML al panel Cadenas o guardarlo en el directorio predeterminado de ese idioma.

Traducción de texto en el panel Cadenas

  1. Seleccione Ventana > Otros paneles > Cadenas.
  2. Seleccione la columna de idioma adecuada para cada idioma al que se va a traducir el texto, e introduzca el texto traducido en ese idioma para asociarlo con cada ID de cadena.
  3. Para mostrar el texto del escenario en el idioma seleccionado, seleccione el idioma en el campo Idioma de escenario.
  4. Cuando haya terminado, guarde, publique o pruebe el archivo.

    Todos los archivos XML de todos los idiomas se sobrescriben con la información del panel Cadenas.

    Nota:

    si desea conservar la traducción de un archivo XML, guárdelo en una carpeta diferente.

Traducción de texto en un archivo XML

  1. Utilizando un editor de archivos XML o software de traducción, abra la carpeta del idioma deseado, y a continuación el archivo XML de ese idioma. El archivo XML se llena con los ID de cada cadena de texto.
  2. Introduzca la cadena de texto del idioma junto al ID.
  3. Si es necesario, importe el archivo XML traducido al panel Cadenas.

Importación de un archivo XML al panel Cadenas

Después de modificar un archivo XML, si lo coloca en la carpeta especificada para ese idioma en el panel Cadenas, el archivo XML se carga en el documento de Animate (archivo FLA) al abrirse.

Independientemente de dónde se encontrara el archivo XML importado, cuando guarde, pruebe o publique el archivo FLA, se creará una carpeta y un archivo XML para cada idioma del panel Cadenas en la ubicación indicada para publicar archivos SWF. Si no se indica ninguna ruta de publicación, la carpeta y el archivo se guardarán en la misma carpeta en que se encuentra el archivo FLA. Los archivos XML generados por el panel Cadenas siempre se llenan con la información del panel Cadenas

También puede importar un archivo XML al panel Cadenas desde otra ubicación. Después de importarlo, al guardar, probar o publicar el archivo, se sobrescribe el archivo XML de la carpeta especificada para ese idioma. No puede importar un archivo XML para un idioma a no ser que lo haya seleccionado como un idioma disponible en el panel Cadenas. También puede añadir un idioma e importar un archivo XML con la traducción para ese idioma.

  1. Seleccione Ventana > Otros paneles > Cadenas y haga clic en Importar XML.
  2. En el menú Seleccionar un idioma, seleccione el idioma del archivo XML que desea importar y haga clic en Aceptar.
  3. Busque la carpeta y el archivo XML que desea importar.

    La información XML se carga en la columna del panel Cadenas para el idioma que ha seleccionado en el paso 3.

Nota:

seleccione el mismo idioma en los pasos 2 y 3. De lo contrario, podría, por ejemplo, importar un archivo XML de francés a la columna de alemán.

Texto en varios idiomas y ActionScript

Puede controlar el texto en varios idiomas e importar archivos XML de texto en varios idiomas con ActionScript®.

Nota:

en nuestra página web dispone de ayuda completa y actualizada. La aplicación no ha detectado ninguna conexión a Internet. Para leer la versión íntegra de este tema, haga clic en el vínculo siguiente o consulte la versión completa en http://helpx.adobe.com/es/support.html.

Puede controlar el texto en varios idiomas e importar archivos XML de texto en varios idiomas con ActionScript®.

Consulte los temas sobre creación de texto en varios idiomas en la ayuda en línea para saber más sobre cómo trabajar con texto en varios idiomas en ActionScript.

Uso de ActionScript para cargar archivos externos

Para cargar datos XML existentes, o para utilizar un formato distinto para el archivo XML, utilice las acciones loadVariables o getURL, o los objetos LoadVars o XML para crear un documento que contenga texto en varios idiomas colocándolo en un archivo externo XML o de texto y cargando el archivo en el clip de película en tiempo de ejecución.

Guarde el archivo externo en formato UTF-8 (recomendado), UTF-16BE o UTF-16LE, utilizando una aplicación que sea compatible con el formato. Si utiliza los formatos UTF-16BE o UTF-16LE, el archivo debe empezar con una marca de orden de byte (BOM) para que Flash Player identifique el formato de codificación. En la tabla siguiente se muestra el orden de byte (BOM) para identificar la codificación:

nota: la mayoría de los editores de texto que pueden guardar archivos como UTF-16BE o LE añaden automáticamente los BOM a los archivos.

Formato UTF

Primer byte

Segundo byte

UTF‑16BE

OxFE

OxFF

UTF‑16LE

OxFF

OxFE

Nota:

si el archivo externo es un archivo XML, no puede utilizar una etiqueta de codificación XML para modificar la codificación del archivo. Guarde el archivo en un formato Unicode compatible.

  1. En la aplicación de edición de Animate, cree un campo de texto dinámico o de entrada para mostrar el texto en el documento.

  2. En el Inspector de propiedades, con el campo de texto seleccionado, asigne un nombre de instancia al campo de texto.
  3. Fuera de Animate, cree un archivo de texto o XML que defina el valor de la variable del campo de texto.

  4. Guarde el archivo XML en formato UTF8 (recomendado), UTF-16BE o UTF-16LE.
  5. Utilice uno de los siguientes procedimientos ActionScript para referirse al archivo externo y cargarlo en el campo de texto dinámico o de entrada.
    • Utilice la acción loadVariables para cargar un archivo externo.

    • Utilice la acción getURL para cargar un archivo externo de una URL especificada.

    • Utilice el objeto LoadVars (un objeto predefinido de cliente-servidor) para cargar un archivo de texto externo de una URL especificada.

    • Utilice el objeto XML (un objeto predefinido de cliente-servidor) para cargar un archivo XML externo desde una determinada URL. Para obtener más información, consulte XML en Referencia del lenguaje ActionScript.

Creación de documentos con varios idiomas utilizando la acción #include

Para crear un documento con varios idiomas, utilice la acción #include.

Utilice una aplicación que admita codificación UTF‑8, como Dreamweaver, para guardar el archivo de texto en formato UTF‑8.

Para identificar el archivo como Unicode en la herramienta de edición de Animate, incluya el siguiente encabezado como primera línea del archivo:

//!-- UTF8

Nota:

incluya un espacio después del segundo guión (-).

De forma predeterminada, la aplicación de edición de Animate presupone que los archivos externos que utilizan la acción #include están codificados en la página de códigos tradicional del sistema operativo en el que se ejecuta la herramienta de edición. Mediante el encabezado //!-- UTF8 en un archivo se indica a la herramienta de edición que el archivo externo está codificado como UTF-8.

  1. En la herramienta de edición de Animate, cree un campo de texto dinámico o de entrada para mostrar el texto en el documento.

  2. En el Inspector de propiedades, con el campo de texto seleccionado, asigne un nombre de instancia al campo de texto.
  3. Fuera de Animate, cree un archivo de texto que defina el valor de la variable del campo de texto. Añada el //!encabezado -- UTF8 al comienzo del archivo.

  4. Guarde el archivo de texto en formato UTF-8.
  5. Para incluir el archivo externo en el campo de texto dinámico o de entrada, utilice la directiva #include. Para obtener más información, consulte XML en Referencia del lenguaje ActionScript.

Creación de documentos con varios idiomas utilizando variables de texto

Para incluir contenido con codificación Unicode en variables de texto, utilice la sintaxis \uXXXX, donde XXXX es el código hexadecimal de cuatro dígitos, o el carácter de escape para el carácter Unicode. La herramienta de edición Animate acepta caracteres de escape Unicode hasta \uFFFF. Para encontrar los códigos de los caracteres Unicode, consulte el Estándar Unicode en Unicode.org.

Puede utilizar caracteres de escape Unicode sólo en variables de campo de texto. No puede incluir caracteres de escape Unicode en archivos de texto o XML externos; Flash Player 6 no reconoce caracteres de escape Unicode en archivos externos.

Por ejemplo, para establecer un campo de texto dinámico (con el nombre de instancia myTextVar) que contenga caracteres del japonés, del coreano, del chino, del inglés, del griego y el signo del euro, introduzca la cadena siguiente:

myTextVar.text = "\u304B\uD55C\u6C49hello\u03BB\u20AC";

Cuando se reproduce el archivo SWF, aparecen los siguientes caracteres en el campo de texto:

Para obtener mejores resultados al crear un campo de texto que contenga varios idiomas, utilice una fuente que incluya todos los glifos necesarios en su texto.

Utilización del componente XMLConnector para conectarse a archivos XML externos

Utilice la versión 2 del componente XMLConnector para conectarse a un documento XML externo y vincular las propiedades del documento. Su propósito es leer o escribir documentos XML utilizando operaciones HTTP GET, operaciones POST, o ambas. Funciona como conector entre otros componentes y documentos XML externos. XMLConnector se comunica con los componentes de la aplicación utilizando funciones de vinculación de datos del entorno de creación Animate o código ActionScript. Para obtener más información, consulte el componente XML Connector en la Referencia del lenguaje de componentes ActionScript.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea