Preferences

  1. After Effects User Guide
  2. Getting started
    1. Get started with After Effects
    2. What's new in After Effects
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Planning and setup
    7. Setup and installation
  3. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  4. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. CINEMA 4D Composition Renderer
  5. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  6. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  7. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  8. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  9. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  10. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  11. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  12. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  13. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  14. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  15. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  16. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Automated rendering and network rendering
    5. Rendering and exporting still images and still-image sequences
    6. Using the GoPro CineForm codec in After Effects
  17. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  18. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

The following sections describe the Preferences dialog box and the various tasks that can be performed using this menu.

The Preferences dialog box

To open the Preferences dialog box, go to:

  • Edit > Preferences > [category name] (Windows)
  • After Effects > Preferences > [category name] (Mac OS)

Use the following keyboard shortcuts to open the Preferences > General menu:

  • Ctrl+Alt+; (semicolon) (Windows)
  • Command+Option+; (semicolon) (Mac OS)

Reset preferences

To restore the default preference settings, press and hold the following keys while the application is starting.

  • Ctrl+Alt+Shift (Windows)
  • Command+Option+Shift (Mac OS)

To restore default keyboard shortcuts, Alt-click (Windows) or Option-click (Mac OS) the OK button.

To reset background preferences, follow these steps:

MacOS

  1. Go to your desktop and click GO on the menu bar.
  2. Select Go to Folder from the drop-down and type the following path: /library/application support/adobe/.
  3. Open Documents folder and select the folder named Adobe.
  4. Rename the After Effects folder as ’OldAfterEffects’.

Windows

  1. Access the path C:\Users\”username” \AppData\Roaming\Adobe. OR
  2. In the Run command (Win key+R) dialog, type %appdata%
  3. Open the folder named Adobe.
  4. In the folder, select the After Effects folder and rename it as ’OldAfterEffects’. OR
  5. Access the path C:\Users\”username”\Documents\Adobe and rename the After Effects folder as ’OldAfterEffects’.

Watch this video to learn how you can reset preferences in After Effects.

Viewing time: 35 seconds

Reveal preferences

Preferences, including keyboard shortcuts and workspaces, are stored as files in the following locations:

  • (Windows) \Users\[user_name]\AppData\Roaming\Adobe\After Effects\[version]
  • (Mac OS) /Users/[user_name]/Library/Preferences/Adobe/After Effects/[version]

To reveal the preferences in After Effects, go to:

  • Edit > Preferences > General and click Reveal Preferences in Explorer button (Windows)
  • After Effects > Preferences > General and click Reveal Preferences in Finder button (Mac OS)

It is recommended that you do not modify the files in this directory manually; use the Preferences dialog box to modify the preferences. For information on modifying keyboard shortcuts, see Modify keyboard shortcuts. For information on managing workspaces, see Workspaces and Panels.

Note:

The Library folder in Mac OS X is hidden. See the following article to learn how to access hidden user files on Mac OS:

http://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

The following list briefly describes the different options listed under the Edit > Preferences menu, especially those options that are not self-explanatory.

General preferences

  • Dynamic Link with After Effects Uses Project File Name with Highest Number: About Dynamic Link and After Effects
  • Play Sound When Render Finishes: Enable or disable the playing of a sound when the last item in the render queue has been processed.
  • Show Warning Banner When Project Contains Expression Errors: Expression basics 
  • Show Start Screen at Startup: Select to display the Start screen when you launch After Effects.
  • Show Start Screen when Opening a Project: Select to display the Start screen dialog when you open an After Effects project (this option is not enabled by default). You can see a list of projects on the screen.
  • Opening layers with double-click (use Option/Alt to reverse):
    • On Footage Layer Opens: Select whether double-clicking a footage layer opens the Layer Panel (default) or the source footage item.
    • On Comp Layer Opens: Select whether double-clicking a pre-composition layer opens the source composition of the layer (default) or the Layer Panel.
      • Open Layer Panel when Double-clicking with Paint, Roto Brush, and Refine Edge Tools: If selected, double-clicking a precomposition layer when a Paint tool, Roto Brush, or Refine Edge tool is active opens the layer in the Layer Panel. 

For more information, see Creating layers and Precomposing, nesting, and pre-rendering.

Previews preferences

  • Adaptive Resolution Limit: Preview modes and Fast Previews preferences

    Also, see Fast Previews (CS6).

    The GPU Information dialog box is available to check the texture memory for your GPU, and to set the ray-tracing preference to the GPU, if it is available. The OptiX version number and the Copy button are available to copy the general information at the top of the dialog box to the system clipboard.

  • Viewer Quality (Zoom Quality and Color Management Quality): Viewer Quality preferences

  • Show Internal Wireframes: Shows bounding box wireframes for components of collapsed precompositions and per-character 3D text layers.

  • Mute Audio When Preview is not Real-time: Choose whether to play audio during previews when the frame rate is slower than realtime. When the frame rate is slower than realtime, audio will stutter to maintain sync.

Display preferences

Import preferences

  • Sequence Footage: Import a single still image or a still-image sequence
  • Automatic Footage Reloading: Footage that has changed is automatically reloaded when switching back from another application.

    • Auto Reload: By default, footage other than image sequence is automatically reloaded. You can change this behavior by selecting All Footage Types (to include image sequence footage as well) or by selecting Off (to turn off auto reloading of footage).

Output preferences

Grids & Guides preferences

Labels preferences

Media & Disk Cache preferences

Video Preview preferences

Appearance preferences

New Project preferences

You can create a template with your preferred project settings such as color management and folder structure, and use it as a foundation for every new project that you create. 

The New Project command provides you the option to open a project based on a template if you enable the New Project Loads Template option under Preferences > New Project and choose a template project. The template project can be an After Effects template project file (.aet), After Effects project file (.aep), or an After Effects XML project file (.aepx).  

For more information, see Save and backup projects in After Effects

Auto-Save preferences

You can use the Auto-Save feature in After Effects which automatically saves a copy of your project while you work. You can set the frequency of how often After Effects saves your work, and also the number of copies of the project it saves.

Use the following steps to enable the Auto-Save feature:

  1. In After Effects, to open the Preferences dialog, select Edit > Preferences > General (Win) or After Effects > Preferences > General (Mac OS).

  2. Select Auto-save from the menu.

  3. To allow After Effects to automatically save copies of your project, in the Preferences dialog, click the Automatically Save Projects checkbox.

  4. Click OK.

Once enabled, After Effects creates a folder named Adobe After Effects Auto-Save in the same directory as your project file. To view an return to a previous saved version of your project, select File > Open in After Effect > saved version.

For more information, see Save and back up projects in After Effects.

Memory preferences

Audio Hardware and Audio Output Mapping preferences

Sync Settings

The Sync Settings feature enables you to synchronize preferences and settings through the Creative Cloud. For detailed information, see the Sync Settings article.

Migrate settings from previous versions

After Effects prompt you to migrate settings from a previous version if it finds a preference folder from a previous version and no preference folder for the current version. This occurs when you start After Effects for the first time and when you delete the entire preferences folder.

If you want to migrate settings from your previous version of After Effects, see the Migrating your settings from a previous minor version of After Effects section.

Adobe logo

Sign in to your account