导入 SVG 文件

上次更新日期: 2026年9月21日

了解如何将 SVG 文件作为可编辑的原生形状图层直接导入,无需转换即可制作动画。

在项目面板中双击或使用文件 > 导入 > 文件来浏览并导入 SVG 文件。

注释

最新版本的 After Effects 允许您将文件导入为素材或合成。

将导入的 SVG 文件拖放到时间线面板中。

选中图层后,可在属性面板的图层内容分区查看 SVG 文件结构。

属性面板已展开,图层内容下方列出了 SVG 文件内容。
使用属性面板查看 SVG 文件内容并调整其属性。

您也可以选择图层旁边的箭头来展开它,然后展开内容分区。 您将看到所有独立元素及其属性,如路径、填充和变换。

已选中包含 SVG 文件的图层,并且内容分区已展开并显示其属性,包括路径、填充和变换。
展开 SVG 图层的内容分区以访问权限和编辑其属性,包括路径、填充和变换。

您可以像使用其他形状图层一样,利用这些属性制作动画效果。 例如:

  • 为路径制作动画以创建变形效果
  • 随时间改变填充颜色,打造动态过渡效果
  • 使用变换属性独立缩放、旋转或移动元素

如果图层具有渐变填充和描边,您可以使用缩放和旋转属性来为渐变制作动画。

已选中包含渐变元素的其中一个图层,且“渐变填充 1”处于高亮显示状态。
使用渐变填充属性调整渐变效果或为其添加动画。

将 SVG 文件作为素材或合成导入

After Effects 中的 SVG 导入功能为您的项目中 SVG 文件的导入方式提供了灵活且更好的控制。 使用最新版本,当您导入 SVG 文件时,可以选择将其作为素材或合成导入。

导入素材

导入为合成

将 SVG 作为单个、可连续栅格化的矢量图层导入。

将 SVG 作为由可编辑形状图层组成的合成导入。

保持与外部 SVG 文件的连接。

每个元素都会转换为其自己的可编辑形状。

适用于不需要将插图分解为多个部分的单图层矢量图形。

适用于需要对各个元素进行动画制作时编辑路径、形状和图层级别的细节。

您可以通过在导入偏好设置下设置将多个文件项目拖拽为选项来控制导入 SVG 文件时默认使用的导入方法。

  • macOS:After Effects > 设置 > 导入 > 将多个文件项目拖拽为
  • Windows:编辑 > 偏好设置 > 导入 > 将多个文件项目拖拽为
“首选项”对话框已打开。 在"导入"选项卡中,"将多个文件项目拖放为"下拉菜单已打开,提供用于选择导入方法的选项。
设置导入 SVG 文件的默认偏好设置,选择是将其作为素材还是合成导入。

在项目面板中双击或使用文件 > 导入 > 文件来浏览并导入 SVG 文件。

使用导入文件对话框中的导入为下拉菜单选择以下选项之一:

  • 素材
  • 合成 - 保持图层大小

选择素材会将文件作为单个扁平化图层导入,无法访问个体元素,适用于静态使用或不需要动画的情况。 选择合成 – 保留图层大小会创建新合成,其中每个来源图层单独导入,大小调整为其实际内容,使锚点更清晰,变换更易于动画处理。

macOS

导入文件对话框已打开,有将文件作为素材或合成导入的选项。

Windows

导入文件对话框已打开,有将文件作为素材或合成导入的选项。

如果适用,请选择以下选项:

  • 创建合成:使用默认设置创建新合成,并自动将导入的 SVG(作为素材或包含形状图层的合成)放置到时间线中,省去了手动创建合成并将 SVG 文件拖入其中的步骤。
  • 可缩放矢量图形序列:导入多个编号的 SVG 文件,并将其视为逐帧矢量图像序列。

如果将 SVG 文件作为合成导入,可以使用属性面板中的图层内容部分,或者时间轴中图层的内容部分,来查看和操作各个元素及其属性。如果作为素材导入,它的行为类似于常规图层,可以使用标准变换属性进行调整。

与 Illustrator 文件一样,如果矢量文件是作为素材导入的,您可以在时间轴中选择该图层,然后右键单击并选择创建 > 从矢量图层创建形状和文本将其转换为可编辑图层,从而可以为各个路径、描边和填充制作动画。在最新的 After Effects Beta 中,源文件中的文本会转化为可编辑的文本图层,保留字体、大小、填充、位置、样式、笔触和可变字体设置。 

当您将 SVG 作为素材导入时,After Effects 会保持与原始文件的实时关联,因此您在应用程序外对该 SVG 所做的任何更改都会在项目内自动更新。

将 Illustrator 文本转化为可编辑的文本图层

使用新的 Beta 版功能

来自 Illustrator 文件的可编辑文本现已可供测试和反馈。立即在 After Effects (Beta) 中试用。

在最新的 After Effects Beta 中,当 Illustrator 图层作为素材导入时,源文件中的任何文本都会转化为其独立的可编辑文本图层,而不是被平展为形状轮廓。这意味着字体、大小、填充、位置、样式(如粗体和斜体)、笔触和可变字体设置都会保留,因此您可以直接在 After Effects 中继续编辑文本,而无需从头重新创建或回到 Illustrator 中进行更改。

选择文件 > 导入 > 文件,然后选择要导入的 Illustrator 文件。

在导入文件对话框中,选择要导入的文件时,确保将导入为设置为素材。

在导入对话框中,确认将导入类型设置为素材,并根据要从 Illustrator 文件中导入的内容选择图层选项。

将导入的文件拖动到时间线面板中。

右键单击 Illustrator 图层并选择创建 > 从矢量图层创建形状和文本,或者选择图层 > 创建 > 从矢量图层创建形状和文本。

“图层”>“创建”子菜单,其中高亮显示“从矢量图层创建形状和文本”,可将矢量文本转换为可编辑的文本图层。
选择“从矢量图层创建形状和文本”,即可将 Illustrator 文本转换为可编辑的 After Effects 文本图层,而不是形状。

文本转化为可编辑的文本图层,与原始文件的字体、大小、填充和位置紧密匹配。然后您可以直接在 After Effects 中编辑和调整文本。

位于火焰图形上方的 Brightness 文本图层,“字符”面板显示已应用 Adobe Clean Italic 字体、74 像素字号并启用了“填充”。
转换后,文本仍完全可编辑——您仍可以在“字符”面板中修改字体、字形、字号和填充。

注释

仅笔触的文本仍作为路径转换,而非可编辑的文本图层。 

非文本矢量内容仍像以前一样转换为形状图层,如果 Illustrator 文件同时包含两者,您将同时获得文本图层和形状图层。

欢迎加入我们的 After Effects (Beta) 社区,参与关于支持从 Illustrator 文件生成可编辑文本的讨论。

复制和粘贴 Illustrator 和 SVG 内容

现在可以使用编辑 > 粘贴将剪贴板上的 SVG 内容粘贴到 After Effects 中。 内容作为本机可编辑形状图层导入,可随时制作动画,无需中间导入步骤。

从 Illustrator 复制内容

在 Adobe Illustrator 中打开您的插图。

确认已选择包含 SVG 代码首选项。

  • macOS:选择 Illustrator > 设置 > 剪贴板处理并选择包括 SVG 代码。
  • Windows:选择编辑 > 首选项 > 剪贴板处理并选择包括 SVG 代码。
在 Illustrator 中打开“首选项”对话框,并选择“包括 SVG 代码”选项。
启用“包含 SVG 代码”可让您的图稿在其他 Adobe 应用程序中保持可编辑性和高质量。

选择您要复制的图稿。

提示

复制前请将所有 SVG 文本转化为曲线,因为粘贴时不支持 SVG 文本。

选择编辑 > 复制。

切换到 After Effects 并根据您的项目状态执行以下操作之一:

  • 如果没有打开的项目,请选择编辑 > 粘贴以创建一个新项目,其中包含包含 SVG 内容作为形状图层的合成。
  • 如果项目已打开但未选择合成,请选择编辑 > 粘贴 在当前项目中创建包含粘贴内容的新合成。
选择“编辑”>“粘贴”选项,内容将作为本地可编辑形状图层导入,准备制作动画。
编辑 > 粘贴将内容引入为可编辑形状图层,为动画做好准备。

如果在 After Effects 中选择了合成,请选择编辑 > 粘贴以将 SVG 内容作为新形状图层添加到该合成中。

从其他应用程序粘贴 SVG

从任何将 SVG 写入系统剪贴板的应用程序复制的 SVG 内容都可以使用相同的编辑 > 粘贴工作流进行粘贴。 支持取决于源应用程序是否在剪贴板上放置有效的 SVG 数据。