通过自定义视图和布局,调整您在 Adobe After Effects 中查看和导航合成的方式,以获得更精确的预览和高效的 Workspace 控制。
合成面板可以同时显示一个、两个或四个视图。 默认情况下,查看器选项(例如网格和标尺)只会影响当前活动的视图。
- 要选择视图布局,请从合成面板底部的选择视图布局菜单中选择选项。
- 要滚动查看视图布局,请将指针置于选择视图布局菜单上并滚动鼠标滚轮。
- 要对当前布局中的所有视图应用视图设置,请从选择视图布局菜单中选择共享视图选项。 按住 Ctrl 键 (Windows) 或 Command 键 (macOS) 以暂时反转此行为。
要激活视图,而不影响合成中图层的选择,请使用鼠标中间按钮在合成面板中该视图的窗格内单击。
选择 3D 视图
您可以使用正视图、采用透视的自定义视图或者摄像机视图从多个角度查看您的 3D 图层。
3D 工作视图包括自定义视图和固定正视图(前、左、顶、后、右或底视图)。 正视图显示合成中的图层位置而不显示透视。 3D 工作视图与摄像机图层无关。 3D 工作视图用于在 3D 场景中放置和预览元素。 3D 图层显示在 3D 工作视图中;2D 图层不显示在 3D 工作视图中。
合成面板在每个视图中都显示一个标签(例如顶或右)以指示哪个视图与哪个摄像机透视关联。 要隐藏这些标签,请从合成面板菜单中选择显示 3D 视图标签。
您可以使用摄像机工具调整自定义视图的观察点和视图方向,也可以查看所选图层或所有图层。
- 从合成面板底部的 3D 视图菜单中选择视图。
- 选择视图 > 切换 3D 视图,然后从菜单中选择视图。
- 选择视图 > 切换到上一个 3D 视图。
- 要切换到上一个 3D 视图,请使用键盘上的 Esc 键。
- 要使用键盘快捷键选择其中一个 3D 视图,请按键盘上的 F10、F11 或 F12。
要更改分配给键盘快捷键的 3D 视图,请切换到视图,然后按 Shift 键和键盘快捷键。 例如,要使 F12 成为顶视图的快捷键,请切换到顶视图,然后按 Shift + F12。 您也可以使用视图 > 将快捷键分配给菜单命令。
在“合成”面板中显示或 隐藏图层控件
您可以在合成面板中为每个视图分配不同选项,以便能够显示摄像机和光线框、图层手柄、蒙版和形状路径、效果控制点以及运动路径控制的任意组合。
- 要选择在视图中显示的图层控件,请选择视图 > 视图选项,或者按 Ctrl + Alt + U (Windows) 或 Command + Option + U (macOS)。
- 要在视图中显示或隐藏图层控件,请选择视图 > 显示图层控件或按Ctrl+Shift+H (Windows) 或命令+Shift+H (macOS)。 此命令还可显示或隐藏 3D 参考轴。
- 要在视图中显示或隐藏蒙版路径和形状路径,请选择合成面板底部的按钮 。
预览时调整缩放
合成、图层或素材面板左下角的放大率控件可显示和控制当前放大率。 默认情况下,放大率被设置为适应当前面板大小。 更改放大率时,您将更改面板中预览的外观,而不是合成的实际分辨率和像素。
After Effects 在缩放(缩放以进行预览)之前会渲染矢量对象,因此当您放大某些矢量对象时这些对象可能显示为锯齿状。 缩放的这一外观上的像素不会影响图层的缩放或者渲染到最终输出。
- 要从活动视图的中心放大或缩小,请按句点 (.) 键或逗号 (,) 键。 每次按键都会进一步增大或减小放大率。
- 默认情况下,使用鼠标滚轮可对光标所在的位置进行放大或缩小。 要放大或缩小视图中心,请在按住 Alt (Windows) 或 Option (macOS) 的同时滚动鼠标滚轮。
- 要使用鼠标滚轮在特定点上放大或缩小,请将指针置于面板上并在移动滚轮时按住 Alt 键 (Windows) 或 Option 键 (macOS)。
- 要使用缩放工具 放大特定点,请选择面板中您要放大的区域。 每次单击都会进一步放大图像,并以您单击的点为中心居中显示内容。 您还可以拖动该工具来放大特定区域。
- 要使用缩放工具以特定点为中心缩小视图,请在 Windows 中按住 Alt 键并单击该点,或在 macOS 中按住 Option 键并单击该点。 每次单击都会进一步减小图像的放大率,并以您单击的点为中心居中显示内容。
- 要将活动视图缩放至 200% (macOS) 和 100% (Windows),请双击工具面板中的缩放工具按钮。
- 要缩放以适应或要缩放到预设放大率,请从放大率菜单中选择缩放级别。 要在合成面板中更改所有视图的放大率,请按住 Ctrl (Windows) 或 Command (macOS) 并从菜单中选择缩放级别。
- 选择适应以使图像适应合成面板;选择合适大小(最大 200%)以将缩放级别限制为 200% (macOS),选择合适大小(最大 100%)以将缩放级别限制为 100%
- 要在放大时在合成、图层或素材面板中平移,请拖动抓手 工具,您可通过按住空格键、H 键或鼠标中间按钮来激活该工具。 此外,按住 Shift 键可以更快速地平移。
- 了解缩放图层,而不仅仅是放大或缩小预览图像。
- 了解在 After Effects 中工作时使用鼠标滚轮缩放和滚动的其他方法。
- 了解如何使用缩放质量首选项为预览设置缩放质量。
平滑缩放可在合成、图层和素材面板中实现精确且流畅的放大,而不仅限于固定放大级别(例如 33%、50% 或 100%)。
您可以使用查看器中的热文本控件,将放大率调整到任何有效的值,精度达到小数点级别。 此外,滚轮缩放可提供更顺畅、更精确的调整。
转到首选项 > 预览 > 放大率,调整缩放类型、行为和触控板滚动的设置。 详细了解放大率首选项。
使用 After Effects 时,如果图像缓冲区大小允许,缩放范围将不受之前的限制。 例如,缩放将不受此前 3200% 固定放大率级别的限制,现在缩放最大支持 3200% 以上到下个固定级别 6400% 之间。
使用平滑缩放的放大率在预览期间调整缩放。
滚动缩放时,按住 Shift 键可加快缩放速度,按住 Ctrl (Windows) 或 Command (macOS) 可减慢速度。
在进行打印的情况下以及在具有固定线性维度的其他媒体中,分辨率是指线性像素密度:特定跨度中的像素或点数,用诸如 ppi(像素/英寸)和 dpi(点/英寸)之类的术语表示。
在视频、影片和计算机图形上下文中,图像的线性测量是可变的,因此参考每英寸的像素数或任何其他线性测量没有任何意义。 例如,考虑同一 640x480 影片可以在移动设备的微型屏幕、台式机的显示器以及巨大的运动广告牌上显示。 虽然像素数可能相同,但是对于每个演示设备,每英寸的像素数是不同的。
在此情况下,分辨率一词指的是相对数量:渲染到源图像中的像素数的像素数比例。 对于每种视图,有两个这样的比例:一个针对水平维度,一个针对垂直维度。
每个合成都有其自己的分辨率设置,这在为预览和最终输出渲染合成时会影响合成的图像质量。 每个帧的渲染时间和内存与要渲染的像素数大致成比例。
在为最终输出渲染合成时,您可以对该合成使用当前的分辨率设置,或者在渲染设置对话框中设置一个可覆盖合成设置的分辨率值。
分辨率设置
您可以从合成设置(合成 > 合成设置)对话框中的以下分辨率设置中进行选择,或者从合成面板底部的分辨率/向下采样系数菜单中进行选择。
自动
(仅用于预览)适应合成面板中视图的分辨率,以便仅渲染在当前缩放级别预览合成所必需的像素。
例如,如果视图缩小至 25%,则分辨率值将自动适应为 1/4,显示为四分之一,就像您已手动选择四分之一一样。 如果面板包含多个视图,则分辨率将适应使用最高缩放级别的视图。 此设置可提供最佳图像质量,同时还可避免渲染对于当前缩放级别不必要的像素。
对于已选择高级合成设置在嵌套时保留分辨率的合成,将忽略自动设置。
完全
渲染合成中的每个像素。 此设置可提供最佳图像质量,但是渲染所需的时间最长。
二分之一
渲染全分辨率图像中包含的四分之一像素,即列的一半和行的一半。
三分之一
渲染全分辨率图像中包含的九分之一的像素。
四分之一
渲染全分辨率图像中包含的十六分之一的像素。
自定义
以您指定的水平和垂直分辨率渲染图像。
图层查看器的分辨率(向下采样系数)与其中包含该图层的合成的合成查看器的分辨率有关。
查看颜色通道或 Alpha 通道
您可以在素材、图层或合成面板中同时或分别查看红色、绿色、蓝色和 Alpha 通道,方法是单击面板底部的显示通道 按钮,并从菜单中进行选择。 当您查看单个颜色通道时,图像将显示为灰度图像,且每个像素的颜色值将映射至黑色(颜色的 0 值)到白色(颜色的最大值)的范围内。
当您预览 Alpha 通道时,图像将显示为灰度图像,且每个像素的透明度值将映射至黑色(完全透明)到白色(完全不透明)的范围内。
当您选择 RGB 直接(显示使用 Alpha 通道对其进行遮罩(预乘)前的直接 RGB 值)时,完全透明的像素没有明确界限,且可能会包含意外的颜色。
- 要查看以通道自己的颜色而非白色显示的颜色值,请从显示通道菜单中选择着色。
- 要查看其他通道值(例如饱和度和色相),请应用通道组合器效果并从到菜单中选择亮度。
- 要切换显示 Alpha 通道以及所有 RGB 通道,请按住 Alt 键并单击 (Windows) 或按住 Option 键并单击 (macOS) 显示通道按钮。
Alpha 边界和Alpha 叠加视图模式仅在图层 面板中可用,适用于Roto 笔刷效果。
调整预览曝光度
您可以使用调整曝光度控件(位于合成、或素材面板底部的重置曝光度 按钮 右侧),调整预览的曝光度(以光圈大小为单位)。 每个查看器都具有各自的调整曝光度设置。
当调整曝光度控件被设置为零之外的其他值时,重置曝光度按钮是蓝色的。
调整曝光度控件不会影响最终输出,只会影响预览期间视频的显示方式。 使用曝光度效果,可对显示在最终输出中的图层的色调进行调整。
- 要为查看器调整曝光度,请将调整曝光度控件拖动到左侧或右侧,或者选择该控件并在框中输入一个值。
- 要重置曝光度,请选择重置曝光度按钮。 要恢复到最近的非零设置,请再次选择该按钮。
- 调整曝光度控件可用于查找图像中的黑场或白场。 例如,将值控制(正值)拖动到右侧,直到除一个区域之外整个图像都是白色的;该区域是图像中的最暗区域。
- 要检查合成的质量,请将调整曝光度控件拖动到最左侧和最右侧并寻找合成元素在颜色或亮度上差别很大的位置。 此技术(有时称为灰度系数波击)可用于确保合成外观良好,并且在您的工作环境之外的环境中具有令人信服的效果。 例如,在对暗色场景进行颜色校正以使场景变亮后,适用于该场景的合成可能缺乏说服力。
安全区域、网格、参考线和标尺
“网格和参考线”首选项
要更改安全区域边距、网格和参考线的设置,请选择编辑 > 首选项 > 网格和参考线 (Windows) 或 After Effects > 设置 > 网格和参考线指南 (macOS)。
After Effects 中的参考线是不会打印或渲染的辅助线,可用于在合成、图层和素材面板中精确对齐图层、文本和其他元素,从而获得一致、准确的布局,同时不会影响最终渲染结果。
详细了解如何创建、编辑、整理和共享参考线。
关于标题安全和动作安全区域
A. 网格 B. 中心剪切标题安全区域 C. 中心剪切动作安全区域 D. 标题安全区域 E. 动作安全区域
电视机可放大视频图像并允许屏幕边缘减掉图像外部边缘的某些部分。 这种裁剪称为过扫描。 过扫描的数量在电视机之间是不一致的,因此您应将视频图像的重要部分保留在称为安全区域的区域中的特定边距内。 安全区域边距表示未包括在安全区域中的图像尺寸的百分比。 您应始终从帧的一个边缘到另一边缘进行设计,因为计算机监视器和某些电视机可能会显示整个帧。
常规的动作安全区域是帧的宽度和高度的 90%,相当于每一侧的 5% 的边距。 保留此区域内的重要视觉元素。
常规的标题安全区域是帧的宽度和高度的 80%,相当于每一侧的 10% 的边距。 保留您打算供观众在此区域内阅读的文本。
帧长宽比等于或接近 16:9 的合成具有两个附加的中心剪切安全区域指示器。 中心剪切指示器显示,当图像在 4:3 屏幕上显示时可能会剪掉 16:9 合成的哪些部分。 在创建还可能会显示在标清电视机上的高清显示图像时,应关注此类裁剪。 默认情况下,中心剪切动作安全边距是 32.5%(每一侧 16.25%),中心剪切标题安全边距是 40%(每一侧 20%)。
仅当合成的帧长宽比等于或接近 16:9 时,才会显示中心剪切安全区域边距。