用户指南 取消(C)

效果和动画预设概述

  1. After Effects 用户指南
  2. Beta 版
    1. Beta 版项目概述
    2. After Effects Beta 版主页
    3. Beta 版中的功能
      1. “属性”面板(Beta 版)
  3. 快速入门
    1. After Effects 快速入门
    2. After Effects 的新增功能 
    3. 发行说明 | After Effects
    4. After Effects 系统要求
    5. After Effects 中的键盘快捷键
    6. 支持的文件格式 | After Effects
    7. 硬件建议
    8. 适用于 Apple Silicon 的 After Effects
    9. 规划和设置
    10. 设置和安装
  4. 工作区
    1. 常规用户界面项
    2. 了解 After Effects 界面
    3. 工作流程
    4. 工作区、面板和查看器
  5. 项目与合成
    1. 项目
    2. 合成基础知识
    3. 预合成、嵌套和预渲染
    4. 使用合成分析器查看详细的性能信息
    5. CINEMA 4D 合成渲染器
  6. 导入素材
    1. 准备并导入静止图像
    2. 从 After Effects 和 Adobe Premiere Pro 导入
    3. 导入和解释视频与音频
    4. 准备和导入 3D 图像文件
    5. 导入和解释素材项目
    6. 使用素材项目
    7. 使用“场景编辑检测”检测编辑点
    8. XMP 元数据
  7. 文本和图形
    1. 文本
      1. 设置字符格式和“字符”面板
      2. 文本效果
      3. 创建和编辑文本图层
      4. 设置段落格式和“段落”面板
      5. 凸出文本和形状图层
      6. 为文本设置动画
      7. 文本动画的示例和资源
      8. 实时文本模板
    2. 动态图形
      1. 在 After Effects 中使用动态图形模板
      2. 使用表达式在动态图形模板中创建下拉列表
      3. 使用“基本属性”创建动态图形模板
      4. 替换动态图形模板和基本属性中的图像和视频
  8. 绘图、绘画和路径
    1. 形状图层、路径和矢量图形的概述
    2. 绘画工具:笔刷、仿制图章和橡皮擦
    3. 将形状描边椎体化的方法
    4. 形状图层的形状属性、绘画操作和路径操作
    5. 使用“位移路径”形状效果更改形状
    6. 创建形状
    7. 创建蒙版
    8. 使用内容识别填充面板,移除视频中的对象
    9. Roto 笔刷和调整遮罩
  9. 图层、标记和摄像机
    1. 选择和排列图层
    2. 混合模式和图层样式
    3. 3D 图层
    4. 图层属性
    5. 创建图层
    6. 管理图层
    7. 图层标记和合成标记
    8. 摄像机、光和目标点
  10. 动画、关键帧、运动跟踪和抠像
    1. 动画
      1. 动画基础知识
      2. 使用人偶工具制作动画
      3. 管理形状路径和蒙版并对其进行动画制作
      4. 使用 After Effects 为 Sketch 和 Capture 形状制作动画
      5. 分类动画工具
      6. 使用数据驱动的动画
    2. 关键帧
      1. 关键帧插值
      2. 设置、选择和删除关键帧
      3. 编辑、移动和复制关键帧
    3. 运动跟踪
      1. 跟踪和稳定运动
      2. 人脸跟踪
      3. 蒙版跟踪
      4. 蒙版引用
      5. 速度
      6. 时间拉伸和时间重映射
      7. 时间码和时间显示单位
    4. 抠像
      1. 抠像
      2. 抠像效果
  11. 透明度与合成
    1. 合成和透明度概述及资源
    2. Alpha 通道、蒙版和遮罩
  12. 调整颜色
    1. 颜色基础知识
    2. 使用 Adobe Color Themes 扩展
    3. 色彩管理
    4. 颜色校正效果
  13. 效果和动画预设
    1. 效果和动画预设概述
    2. 效果列表
    3. 模拟效果
    4. 风格化效果
    5. 音频效果
    6. 扭曲效果
    7. 透视效果
    8. 通道效果
    9. 生成效果
    10. 过渡效果
    11. 果冻效应修复效果
    12. 模糊和锐化效果
    13. 3D 通道效果
    14. 实用效果
    15. 遮罩效果
    16. 杂色和颗粒效果
    17. 保留细节放大效果
    18. 旧版效果
  14. 表达式和自动化
    1. 表达式
      1. 表达式基础知识
      2. 了解表达式语言
      3. 使用表达式控件
      4. JavaScript 与旧版 ExtendScript 表达式引擎之间的语法差别
      5. 正在编辑表达式
      6. 表达式错误
      7. 使用表达式编辑器
      8. 使用表达式编辑和访问文本属性
      9. 表达式语言引用
      10. 表达式示例
    2. 自动化
      1. 自动化
      2. 脚本
  15. 沉浸式视频、VR 和 3D
    1. 在 After Effects 中构造 VR 环境
    2. 应用沉浸式视频效果
    3. 用于 VR/360 视频的合成工具
    4. 跟踪 3D 摄像机运动
    5. 使用 3D 设计空间
    6. 3D 变换 Gizmo
    7. 使用 3D 动画执行更多操作
    8. 使用实时引擎实时预览对 3D 设计的更改
    9. 向图形添加响应式设计 
  16. 视图和预览
    1. 预览
    2. 使用 Mercury Transmit 进行视频预览
    3. 修改和使用视图
  17. 渲染和导出
    1. 渲染和导出基础知识
    2. 将 After Effects 项目导出为 Adobe Premiere Pro 项目
    3. 转换影片
    4. 多帧渲染
    5. 自动渲染和网络渲染
    6. 渲染和导出静止图像及静止图像序列
    7. 在 After Effects 中使用 GoPro CineForm 编解码器
  18. 使用其他应用程序
    1. Dynamic Link 和 After Effects
    2. 使用 After Effects 和其他应用程序
    3. After Effects 中的同步设置
    4. After Effects 中的 Creative Cloud Libraries
    5. 增效工具
    6. CINEMA 4D 和 Cineware
  19. 协作:Frame.io 和团队项目
    1. 在 Premiere Pro 和 After Effects 中协作
    2. Frame.io
      1. 安装和激活 Frame.io
      2. 将 Frame.io 与 Premiere Pro 和 After Effects 配合使用
      3. 常见问题解答
    3. 团队项目
      1. 开始使用团队项目
      2. 创建团队项目
      3. 使用团队项目进行协作
  20. 内存、存储、性能
    1. 内存和存储
    2. 提高性能
    3. 首选项
    4. After Effects 的 GPU 和 GPU 驱动程序要求

动画预设概述和资源

借助动画预设,您可以保存和重复使用图层属性和动画的特定配置,包括关键帧、效果和表达式。例如,如果使用复杂属性设置、关键帧和表达式创建使用多种效果的爆炸,则可将以上所有设置另存为单个动画预设。随后可将该动画预设应用到任何其他图层。

许多动画预设不包含动画;而是包含效果组合、变换属性等。行为动画预设使用表达式而非关键帧来对图层属性设置动画。

用户可以保存动画预设,并将其从一台计算机传输到另一台计算机。动画预设的文件扩展名是 .ffx

After Effects 包括数百种动画预设,您可以将它们应用到图层并根据需要做出修改,其中包括许多文本动画预设。(请参阅文本动画预设。)

您可以使用“效果和预设”面板或 Adobe Bridge 在 After Effects 中浏览和应用动画预设。要在 Adobe Bridge 中打开“预设”文件夹,请从“效果和预设”面板菜单或“动画”菜单中选择“浏览预设”。

注意:

了解高级用户如何使用 After Effects 的最佳方式是,应用某动画预设,并按 U 或 UU 以仅显示经过动画处理或修改的图层属性。查看经过动画处理和修改的属性时,系统将显示动画预设的设计者为创建动画预设所做的更改。

下载、安装和移动动画预设

  • 与 After Effects 一起安装的动画预设位于“预设”文件夹中,此文件夹位于 Program Files\Adobe\Adobe After Effects CC\Support Files (Windows) 或 Applications/Adobe After Effects CC (Mac OS) 文件夹中。
  • 默认情况下,创建的动画预设保存在“预设”文件夹中,此文件夹位于
    My Documents\Adobe\After Effects CC (Windows) 或 Documents/Adobe/After Effects CC (Mac OS) 中。

您可在任一“预设”文件夹中添加一个新的动画预设,或新动画预设的整个文件夹。

在 After Effects 启动时,它会在“预设”文件夹及其子文件夹中搜索安装的动画预设,并将它们添加到“效果和预设”面板。After Effects 会忽略名称前后带括号的文件夹的内容;例如,文件夹 (archived_animation_presets) 的内容将不加载。

注意:

仅当动画预设位于其中一个“预设”文件夹或其中一个“预设”文件夹的子文件夹中时,这些动画预设才会显示在“效果和预设”面板中。如果将某预设移至新文件夹,请将该文件夹的快捷方式 (Windows) 或别名 (Mac OS) 放入“预设”文件夹。

仅当显示“效果和预设”面板时,才能加载和初始化动画预设。如果“效果和预设”面板靠近或隐藏在其他面板后面,则不会初始化这些动画预设。

保存动画预设

  1. 选择任意属性组合(例如,“位置”和“缩放”)和属性组(例如,“绘画”和“变换”)。如果仅选择效果,则可在“效果控件”面板中选择。

  2. 从“动画”菜单或“效果和预设”面板菜单中选择“保存动画预设”。

  3. 为文件指定名称和位置,然后单击“保存”。

要使动画预设显示在“效果和预设”面板中,必须将其保存在“预设”文件夹中。

注意:

如果动画预设不显示在“效果和预设”面板中,则从“效果和预设”面板菜单中选择“刷新列表”。

有关动画预设的在线资源

注意:

如果您从“动画预设”>“形状”>“背景”类别中应用动画预设,则可以在“效果控件”面板中看到自定义的动画形状控制效果。此自定义效果是特别为这些动画预设创建的专用表达式控制效果。您可以将此效果复制并粘贴到其他图层,也可以将其另存为动画预设本身以便能够在其他位置应用。

您也可以从许多 After Effects 社区网站(例如 AE Enhancers 论坛)下载动画预设。

有关 After Effects 附带的动画预设的列表,请参阅动画预设列表

Andrew Kramer 在其 Video Copilot 网站上提供了许多动画预设。

效果概述和资源

After Effects 包含多种效果,您可以应用到图层来添加或修改静止图像、视频和音频的特性。例如,某效果可以改变图像的曝光度或颜色、添加新视觉元素、操作声音、扭曲图像、删除颗粒、增强照明或创建过渡效果。

效果有时被误称为滤镜。滤镜和效果之间的主要区别是:滤镜可永久修改图像或图层的其他特性,而效果及其属性可随时被更改或删除。换句话说,滤镜有破坏作用,而效果没有破坏作用。After Effects 专门使用效果,因此更改没有破坏性。更改效果属性的直接结果是,属性可随时间改变,或进行动画处理

注意:

作用于形状图层的路径(如“波纹效果”和“收缩和膨胀”)在 Adobe Illustrator 中被称为效果,您可通过形状图层的“添加”菜单应用它们,但其作用与 After Effects 中的其他效果不同。

您可以使用“效果和预设”面板浏览和应用效果。您可以使用“效果控件”面板或“时间轴”面板修改效果属性,也可以通过在“图层”面板或“合成”面板中移动效果控制点来达到此目的。

您可以对某图层应用同一效果的多个实例,重命名每个实例,并分别设置每个实例的属性。

注意:

如果打开的项目使用 After Effects 尚未为其加载增效工具的效果,则会显示一个警告对话框,并且此效果在“时间轴”面板和“效果控件”面板中其名称的开始位置有缺失:。要在活动合成的“时间轴”面板中显示缺失效果的所有实例,请按 FF。

效果增效工具

所有效果均以增效工具形式实现,包括 After Effects 附带的效果。增效工具是一些小的软件模块,用来为应用程序增添功能,具有 .aex、.pbk 和 .pbg 等文件扩展名。并非所有增效工具都是效果增效工具;例如,某些增效工具提供导入和使用特定文件格式的功能。例如 Photoshop Camera Raw 增效工具,它为 After Effects 带来了处理摄像机原始文件的能力。(请参阅增效工具。)

由于效果是以增效工具形式实现的,因此您可以安装和使用非 Adobe 方提供的其他效果,包括您自己创建的效果。您可以将单个新效果或新效果的整个文件夹添加到“增效工具”文件夹,默认情况下,后者位于以下文件夹之一中:

  • (Windows) Program Files\Adobe\Adobe After Effects CC\Support Files

  • (Mac OS) Applications/Adobe After Effects CC

在 After Effects 启动时,它会在“增效工具”文件夹及其子文件夹中搜索所有安装的效果,并将它们添加到“效果”菜单和“效果和预设”面板中。After Effects 会忽略名称前后带括号的文件夹的内容;例如,文件夹 (archived_effects) 的内容将不加载。

After Effects 提供了几种第三方增效工具,包括 Foundry Keylight、Synthetic Aperture Color Finesse、Imagineer mocha shape、fnord ProEXR 和 CycoreFX HD 增效工具。默认情况下,这些增效工具随 Adobe After Effects 软件的完整版一同安装。(请参阅 After Effects 中附带的第三方增效工具)。

某些增效工具的安装程序会将其文档安装在与增效工具本身相同的目录中。

After Effects 包括 fnord 软件中的 EXtractoR 和 IDentifier 增效工具, 用于访问 OpenEXR 文件的多个图层和通道。请参阅 ProEXR 增效工具、IDentifier 和 EXtractoR

动画效果

您可以使用为任何其他属性设置动画的方式来为效果属性设置动画,即在属性中添加关键帧或表达式。通常,即使依赖动画才能正常使用的效果也需要您设置某些关键帧或表达式。例如,为“过渡”效果的“过渡完成”属性或“湍流杂色”效果的“演化”设置创作动画可将静态效果转变为动态效果。

颜色深度

许多效果支持在深度为 16 或 32 bpc 时处理图像颜色和 Alpha 通道数据。在 16-bpc 或 32-bpc 项目中使用 8-bpc 效果会导致颜色细节损失。如果某效果仅支持 8 bpc,而您的项目设置为 16 bpc 或 32 bpc,则在“效果控件”面板的此效果名称旁会显示警告图标 。您可以设置“效果和预设”面板,以仅列出支持当前项目颜色深度的效果。(请参阅颜色深度和高动态范围颜色。)

效果不透明度

 

每个效果的属性组都包含一个“合成选项”属性组。其中包含新的“效果不透明”属性,可为每个效果提供同“与原始图像混合”控件相似的功能。利用“效果不透明”属性,可更改全局不透明度,并会对整个效果造成影响。需单独添加蒙版。

利用“与原始图像混合”控件组,可通过蒙蔽所需的区域,将任意效果准确地应用至图像中的特定区域。

有关更多信息,请参阅与原始图像混合效果部分。

 

渲染顺序

After Effects 渲染蒙版、效果、图层样式以及变换属性的顺序称为渲染顺序,此顺序可能会影响应用效果的最终结果。默认情况下,效果按其应用顺序显示在“时间轴”面板和“效果控件”面板中。效果按此列表中从上至下的顺序进行渲染。要更改渲染效果的顺序,请将效果名称拖到列表中的新位置。(请参阅渲染顺序和折叠变换。)

调整图层

应用于调整图层的效果会影响“时间轴”面板中按图层堆积顺序位于该调整图层下的所有图层。(请参阅创建调整图层。)

表达式控制效果

表达式控制效果不会修改现有图层属性;但这些效果会添加表达式可引用的图层属性。(请参阅表达式控制效果。)

使用“范围扩散”效果防止边缘剪切

由于效果将应用到图层中,因此某些效果的结果仅限于图层范围内,这会使效果似乎突然终止。您可以将“范围扩散”效果应用到图层,以便在计算其他效果的结果时暂时扩展此图层。较新的效果(它们往往是 32-bpc 效果)不需要此过程。

通过脚本管理效果和效果属性

Paul Tuersley 在 AE Enhancers 论坛上提供了一个脚本,使用该脚本可以搜索合成中的效果,以及打开或关闭它们。

Paul Tuersley 在 AE Enhancers 论坛上提供了一个脚本,使用该脚本可以更轻松地同步对多个图层上的效果属性进行的更改。

通过工具应用的效果

某些效果(包括操控效果、绘图效果和 Roto 笔刷效果)是通过工具应用到图层,而不是以与其他效果相同的方式直接应用的。(请参阅通过操控工具设置动画绘画工具和绘画描边以及透明度、不透明度和合成。)

用于 Cycore FX HD 效果的资源

CycoreFX HD 包括在 After Effects CC 和 CS6 安装中。所有效果具有 16 bpc 支持,35 个效果具有 32 bpc(浮点)支持。CycoreFX HD 增效工具支持运动模糊、光照、更多控件和选项。

Cycore  网站上提供了有关 Cycore FX (CC) 增效工具的文档,包括教程和示例项目。

Bob Donlon 在 Adobe 网站上提供了以下有关 CC 粒子仿真系统 II 效果的教程:

Eran Stern 在其网站上提供了一个演示 CC 粒子仿真系统 II 和 CC 水银滴落效果的视频教程。

复合效果和控件图层

多种效果依赖控件图层(或图层映射)作为输入方式。这些复合效果使用控件图层的像素值来确定如何影响应用效果的图层(目标图层)的像素。有时,效果使用控件图层的亮度像素值;某些情况下,效果使用控件图层的单个通道像素值。

例如,置换图效果使用控件图层的亮度值来确定将底层图层的像素移动多远,以及移动方向。碎片效果可使用两个控件图层,一个控件图层用于自定义碎片的形状,另一个控件图层用于控制目标图层特定部分爆炸的时间。

复合效果会忽略控件图层的效果、蒙版和变换。要使用某图层上的效果、蒙版和变换的结果,请预合成此图层,并将预合成图层用作控件图层。

使用本身不可见的控制图层(即,其视频开关 已关闭)是很常见的。

大多数复合效果包括“伸缩对应图以适合”选项(或类似名称的选项),此选项可将控件图层暂时伸展或收缩到目标图层的尺寸。这样可使控件图层的像素与目标图层的每个像素一致。如果取消选择此选项,将执行复合效果计算,就好像控件图层以其原始大小居中在目标图层上一样。

您可通过在图像编辑程序(如 Adobe Photoshop)中绘画或绘图来创建控制图层。

有关创建控制图层的提示:

  • 对于许多复合效果,控件图层的中性灰色像素对应于空操作。因此,中性灰色纯色图层是创建控件图层的不错起点。

  • 将“湍流杂色”效果应用到某图层并预合成此图层,可为湍流或大气效果创建出色的控制图层。

  • 您可通过在顶层图层上预合成白色纯色图层、黑色纯色图层和蒙版来创建控件图层,以便确定哪些区域是白色和黑色。增强蒙版羽化可柔化黑白值之间的过渡。

  • 邻近像素值之间的对比度可确定这些值在控件图层表面变化的平滑度。要创建平滑的变化效果,请使用柔软的或消除锯齿的笔刷绘图,或应用渐变。要创建生硬的变化效果,请避免使用中间阴影,而是使用一些加宽阴影,如 50% 灰色、黑色和白色。

具有“合成摄像机”属性的效果

某些效果可在同一合成内使用摄像机和灯光。这些效果包括卡片动画、卡片擦除和碎片。其中某些效果总是使用合成摄像机,而其他效果将灯光和摄像机选项添加到“效果控件”面板中。

注意:

“实时 Photoshop 3D”效果的行为与带有合成摄像机属性的效果一样。仅当图层是 PSD 文件中的 3D 对象图层时,此效果才会显示在此图层上。请参阅来自 Photoshop 的 3D 对象图层

在将带有合成摄像机属性的效果应用到 2D 图层时,此效果可以在合成内跟踪摄像机和灯光位置,并在其应用到的 2D 图层上渲染 3D 图像。效果的结果看似三维;但是,应用合成摄像机属性的图层仍然是 2D 图层,因此具有以下特性:

  • 在“时间轴”面板中,该图层之上和之下的 3D 图层无法相互相交,或相互投影。

  • 该图层无法与 3D 图层相交,无法投射或接受阴影。

注意:

图像是在图层(而非合成)上渲染的,因此,需确保将这些效果应用到大小与合成相同且完全居中显示在合成中的图层。

“效果控件”面板

在将效果应用到图层时,“效果控件”面板将打开,列出应用的效果,以及用于更改效果属性值的控件。您也可以在“时间轴”面板中使用效果并更改大多数效果属性值。但对于许多种类的属性而言,“效果控件”面板具有更方便的控件,如滑块、效果控制点按钮和直方图。

“效果控件”面板是一种查看器,这表示您可以同时为多个图层打开“效果控件”面板,并可以使用面板选项卡中的查看器菜单选择图层。

  • 要为所选图层打开或关闭“效果控件”面板,请按 F3。
  • 要选择某效果,请单击它。要按堆积顺序选择下一个或上一个效果,请分别按向下箭头键或向上箭头键。
  • 要展开或折叠所选效果,请分别按向右箭头键或向左箭头键。
  • 要展开或折叠属性组,请单击效果名称或属性组名称左侧的三角形。
  • 要展开或折叠某属性组及其所有子组,请按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),并单击三角形。
  • 要展开或折叠所选效果的所有属性组,请按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),并按 `(重音标记)。
  • 要将效果的所有属性重置为默认值,请在“效果控件”面板中该效果项的顶部单击“重置”。
  • 要复制所选效果,请选择“编辑”>“复制”,或者按 Ctrl+D (Windows) 或 Command+D (Mac OS)。
  • 要将效果移至渲染顺序中的不同位置,请在效果堆栈中上下拖动效果。
  • 要将效果的属性设置为动画预设中使用的属性,请在“效果控件”面板中该效果项顶部的“动画预设”菜单中进行选择。
  • 要在“效果控件”面板中显示“动画预设”菜单,请在面板菜单中选择“显示动画预设”。
  • 要修改效果属性的范围,请右键单击 (Windows) 或按住 Control 键并单击 (Mac OS) 加下划线的控件属性值,然后从上下文菜单中选择“编辑值”。

“效果和预设”面板

使用“效果和预设”面板可浏览和应用效果和动画预设。图标按类型标识面板中的每一项。效果图标中的数字指示效果是否在最大深度为 8、16 或 32 bpc 时起作用。

您可以滚动浏览效果和动画预设列表,也可以通过在面板顶部的搜索框中键入名称的任何部分来搜索效果和动画预设。

在“效果和预设”面板菜单中选择的选项可确定显示的项目:

显示所有颜色深度的效果

显示使用所有颜色深度的效果,不只是使用当前项目的颜色深度的效果。

显示效果

显示所有可用效果。

显示动画预设

显示所有动画预设,包括您保存在“预设”文件夹中的动画预设。

此面板根据您从面板菜单选择的选项组织效果和动画预设:“类别”、“资源管理器文件夹”(Windows) 或“Finder 文件夹”(Mac OS),或“按字母顺序”。

在面板菜单中使用以下命令来管理效果和动画预设:

“在资源管理器中显示”(Windows) 或“在 Finder 中显示”(Mac OS)

打开其中包含在“效果和预设”面板中选择的效果或动画预设的文件夹。

 

刷新列表

更新效果和动画预设的列表。

应用效果或动画预设

  • 要将效果或动画预设应用到单个图层,请将效果或动画预设从“效果和预设”面板拖至“时间轴”、“合成”或“效果控件”面板中的图层。
注意:

在将效果或动画预设拖至“合成”面板中的图层时,指针下的图层的名称会显示在“信息”面板中。如果尚未选择图层,请双击动画预设创建新图层并将预设应用至该图层。未选中任何图层时,双击某个效果没有任何作用。

  • 要将效果或动画预设应用到一个或多个图层,请选择图层,然后双击“效果和预设”面板中的效果或动画预设。
  • 要将效果应用到一个或多个图层,请选择图层,然后选择“效果”> [类别] > [效果]
  • 要将最近使用或保存的动画预设应用到一个或多个图层,请选择图层,选择“动画”>“最近的动画预设”,然后从列表中选择此动画预设。
  • 要将最近应用的动画预设应用到一个或多个图层,请选择图层,然后按 Ctrl+Alt+Shift+F (Windows) 或 Command+Option+Shift+F (Mac OS)。
  • 要将最近应用的效果应用到一个或多个图层,请选择图层,然后按 Ctrl+Alt+Shift+E (Windows) 或 Command+Option+Shift+E (Mac OS)。
  • 要使用 Adobe Bridge 将动画预设应用到一个或多个图层,请选择图层,选择“动画”>“浏览预设”,导航到此动画预设,然后双击它。
  • 要将效果设置从动画预设应用到当前效果实例,请从“效果控件”面板中该效果的“动画预设”菜单选择动画预设名称。
  • 要将效果从一个图层复制到一个或多个图层,请在“时间轴”面板或“效果控件”面板中选择效果,选择“编辑”>“复制”,选择目标图层,然后选择“编辑”>“粘贴”。
注意:

将效果或动画预设应用到一个图层时会选择该图层。

默认情况下,在将效果应用到图层时,效果在图层的持续时间内处于活动状态。但是,您可以使效果在特定时间启动和停止,也可以使效果随时间变强或变弱,方法是使用关键帧或表达式,或者将效果应用到调整图层。

在当前时间应用了动画预设。

注意:

要查看将动画预设应用到图层后发生的变化,请选择图层,并按 UU 以显示修改的属性,或按 U 以显示包含关键帧或表达式的属性。

删除或禁用效果和动画预设

在将效果应用到图层后,可以暂时禁用图层上的一个或所有效果,以使您专注于合成的其他方面。不会为预览或最终输出渲染禁用的效果。但是,在“渲染队列”面板中,您可指定为最终输出渲染合成的所有效果,而不管在“合成”面板中为预览渲染哪些效果。禁用效果不会删除为任何效果属性创建的关键帧,所有关键帧均会保留到从图层中删除效果为止。

不能禁用动画预设,也不能从图层中将其作为一个单元删除。可以单独删除或禁用其包含的效果、关键帧和表达式。

  • 要从图层中删除一个效果,请在“效果控件”面板或“时间轴”面板中选择效果名称,然后按 Delete 键。
  • 要从一个或多个图层中删除所有效果,请在“时间轴”或“合成”面板中选择图层,并选择“效果”>“全部移除”,或者按 Ctrl+Shift+E (Windows) 或 Command+Shift+E (Mac OS)。
注意:

此命令会消除已删除效果的所有关键帧。如果意外选择“全部移除”,则立即选择“编辑”>“撤消删除效果”或“编辑”>“撤消移除全部效果”以恢复效果和关键帧。

  • 要暂时禁用一个效果,请在“效果控件”或“时间轴”面板中选择图层,然后单击效果名称左侧的“效果”开关
  • 要暂时禁用图层上的所有效果,请在时间轴面板中单击图层“开关”列中的效果开关

删除效果或动画预设

可以在 After Effects 搜索效果或动画预设使用的文件夹中移除这些项目,以防止其加载和显示在“效果和预设”面板或“效果”菜单中。

  1. 在“效果和预设”面板中,选择效果或动画预设。
  2. 在此面板菜单中,选择“在资源管理器中显示”(Windows) 或“在 Finder 中显示”(Mac OS)。
  3. 从“增效工具”或“预设”文件夹中移出效果 (.aex) 或动画预设 (.ffx) 文件。
  4. 从“效果和预设”面板菜单中选择“刷新列表”,以更新面板中动画预设的列表。

    仅当应用程序启动时,效果列表才更新。

注意:

与其完全移除效果或动画预设,不如考虑为很少使用的效果或动画预设在“增效工具”或“预设”文件夹中创建子文件夹。After Effects 会忽略其名称以括号开头和结尾的文件夹的内容;例如,(archive_folder)。

效果控制点

某些效果有效果控制点,后者可确定效果影响图层的方式。例如,高级闪电效果有两个效果控制点(源点和方向),用于指定闪电的开始位置和闪电所指向的方向。

效果控制点位于未连续栅格化且未折叠其变换的图层的图层空间中。如果图层已连续栅格化,或已折叠变换,则效果控制点位于合成空间中。(请参阅坐标系:合成空间和图层空间渲染顺序和折叠变换。)

矢量图层(包括形状图层和文本图层)始终已连续栅格化,因此其效果控制点始终位于合成空间中。(请参阅连续栅格化包含矢量图形的图层。)

默认情况下,空对象图层、纯色图层和其他基于源素材项目的图层的图层空间中有效果控制点。

查看效果控制点

  • 要在“图层”面板中查看效果控制点,请从“图层”面板底部的“视图”菜单中选择效果名称。
  • 要在“合成”面板中查看效果控制点,请在“时间轴”面板或“效果控件”面板中选择效果名称。
注意:

要在“合成”面板中查看效果控制点,请在“视图”菜单中选择“显示图层控件”,并在“视图选项”(“视图”>“视图选项”)中选择“效果控件”。

移动效果控制点

  • 在“合成”面板或“图层”面板中,拖动效果控制点
  • 在“效果控件”面板中,单击效果控制点按钮 ;然后,在“合成”或“图层”面板中,单击需要效果控制点的位置。
  • 在“时间轴”或“效果控件”面板中,拖动效果控制点的 x 和 y 坐标,或为其 x 和 y 坐标输入值,就像修改任何其他属性一样。

随机性和随机植入

由于真正的随机性是不可重复的,因此许多效果使用计算来模拟随机性,这些计算可为“随机植入”属性的每个值生成看似随机的结果。如果同一效果的多个实例的所有设置(包括“随机植入”属性值)均相同,则它们会提供相同的结果。这样,您可以获得可预测的确定性结果,同时仍然实现随机性的外观。

更改“随机植入”值不会使内容随机性提高或降低,只会以不同的方式使内容看似随机。

您可以使用“随机数”类别中的表达式对任何属性应用随机性。

合成效果

Adobe After Effects CC 中的效果包含合成选项,可轻松实现与任何原始剪辑的混合,只需修改剪辑的一部分,而无需额外调整图层或轨道遮罩图层。

有关更多信息,请参阅合成选项与蒙版参考

动画预设列表

与产品捆绑的各种动画预设位于“支持文件”/“预设”文件夹中。 

有关使用、浏览和预览动画预设的信息,请参阅动画预设概述和资源

背景

  • 幻影
  • 积木
  • 尘渣
  • 电路
  • 宇宙能量
  • 恐怖
  • 窗帘
  • 深层组织
  • 雾化灯
  • 细菌
  • 绿色晶体
  • 消化不良
  • 感染
  • 扭曲闪电
  • 岩浆
  • 球体
  • 像素
  • 疾行矩形
  • 红色速度
  • 河流
  • 玫瑰之光
  • 丝绸
  • 烟雾升腾
  • 曲线扫除

行为

  • 自动滚动 - 水平
  • 自动滚动 - 垂直
  • 随时间漂移
  • 在下层图层上淡入
  • 淡入淡出(帧)
  • 淡入淡出(毫秒)
  • 在下层图层上淡出
  • 不透明闪烁 - 图层标记
  • 不透明闪烁 - 随机
  • 随时间旋转
  • 缩放回弹 - 图层标记
  • 缩放回弹 - 随机
  • 摆动 - 凝结
  • 摆动 - 位置
  • 摆动 - 旋转
  • 摆动 - 缩放
  • 摆动 - 修剪
  • 摆动的罗摩

图像 - 创意

  • 开花 - 亮
  • 开花 - 亮+暗
  • 开花 - 晶格化
  • 着色 - 涂蓝色
  • 着色 - 浸金色
  • 着色 - 红外线
  • 着色 - 月影
  • 着色 - 红色手迹
  • 着色 - 蓝紫色
  • 着色 - 深褐色
  • 着色 - 天蓝色
  • 着色 - 天空橙色
  • 着色 - 夕阳余晖渐变
  • 着色 - 明亮度
  • 着色 - 饱和度
  • 尺寸 - 斜面+阴影
  • 尺寸 - 发光+阴影
  • 灰度
  • 插入视频 - 加框
  • 插入视频 - 撕边
  • 左侧三分之一 - 汲取蒙版 NTSC
  • 左侧三分之一 - 汲取蒙版 PAL
  • 下方三分之一 - 汲取蒙版 NTSC
  • 下方三分之一 - 汲取蒙版 PAL
  • 下方三分之一保持 - 变暗
  • 下方三分之一保持 - 饱和
  • 情绪照明 - 无定形
  • 情绪照明 - 数字化
  • 情绪照明 - 窄条光线
  • 晕影照明

图像 - 特殊效果

  • 不良电视信号 1 - 变形
  • 不良电视信号 2 - 老旧
  • 不良电视信号 3 - 弱

  • 碎砖块拼贴
  • 浮雕状多次曝光
  • 漏光 - 图层标记

  • 漏光 - 随机
  • 运动注册错误
  • 夜视

图像 - 实用效果

  • 压缩-扩展动态范围
  • 翻转 + 垂直翻转
  • 翻转
  • 垂直翻转
  • 反转 Alpha
  • 抠像 - 蓝色模糊
  • 抠像 - 绿色模糊
  • Keylight + 抠像清除器 + 高级溢出抑制器
  • 色阶 - 计算机到视频
  • 色阶 - 视频到计算机
  • 降低 DV 色块阻塞量
  • 样本图像表达式

 

形状

背景

  • 方框云集
  • 万花筒
  • 神经网 - 循环
  • 神经网 - 线性
  • 神经网 - 五芒星

 

元素

  • 60 年代文本栏
  • 雕刻线 - 方框
  • 雕刻线 - 点
  • 选框追踪
  • 模块框
  • 环形图表
  • 蠕动线框

精灵 - 动画

  • 异形面孔 - 动画
  • 循环 - 细胞分解
  • 舞蹈结
  • 曼陀罗 - 动画
  • 相位范围
  • 螺旋形曼陀罗
  • 星状闪烁

精灵 - 静止图像

  • 异形书法
  • 异形面孔
  • 方框 - 虚线
  • 牛眼
  • 循环 - 半圆
  • 循环 - 三段虚线
  • 十字形状 - 括号
  • 十字形状 - 圆
  • 十字形状 - 方形
  • 风扇叶片
  • 花之力量
  • 齿轮
  • 圣光
  • 印第安太阳
  • 曼陀罗
  • 星状射线 4
  • 星状射线 8
  • 圆括号 - 斜面
  • 圆括号 - 双重
  • 海边雏菊
  • 三齿轮

 

声音效果

  • 冲击波
  • 忙音
  • 呼叫 Adobe
  • 拨号音 - 美国
  • 双音多频
  • 电话公司
  • 电话铃声 - 美国

合成品

  • 蓝条
  • 单元格
  • 数字化
  • 飘渺
  • 金色环境
  • 闪电 - 水平
  • 闪电 - 垂直
  • 马赛克

  • 橙色条纹
  • 烟 - 飘游
  • 星爆旋转

 

文本

3D 文本

  • 3D 基本位置 Z 层叠
  • 3D 基本位置 Z 打字
  • 3D 基础旋转 X 层叠
  • 3D 基础旋转 Y 层叠
  • 3D 居中反弹
  • 3D 回落缩放和倾斜
  • 3D 回落混杂和模糊
  • 3D 翻转进入旋转 X
  • 3D 翻转退出旋转 X
  • 3D 向上翻转反射
  • 3D 从左侧振动进入
  • 3D 按随机顺序振动进入
  • 3D 从右侧振动退出
  • 3D 下飞和展开
  • 3D 从摄像机后下飞
  • 3D 随机下飞和旋转 Y
  • 3D 线性放大
  • 3D 下雨词和颜色
  • 3D 随机固定翻滚
  • 3D 位置解析
  • 3D 绕圆旋转
  • 3D 字符旋转进入
  • 3D 词旋转退出
  • 3D 在位置 Z 飞入
  • 3D 向下盘旋和展开
  • 3D 行盘旋进入
  • 3D 行盘旋退出
  • 3D 在路径上回摆
  • 3D 词前滚
  • 3D 字符扭曲和着色

光线和视觉

  • 蓝色闪光灯
  • 百老汇
  • 气泡脉冲
  • 浮现
  • 曝光度
  • 闪光灯
  • 闪烁曝光
  • 波动
  • 荧光灯
  • 办公室灯光
  • 叠加
  • 脉冲曝光
  • 阴影
  • 轮廓
  • 声纳
  • 旋转闪烁
  • 单词闪烁

自然模拟

  • 秋天
  • 沸腾
  • 回飞标
  • 对角线回弹
  • 口香糖
  • 爬山者
  • 下沉回弹
  • 双螺旋
  • 随机缩小入屏
  • 鱼饵
  • 振动
  • 编队飞行
  • 马蝇
  • 蜂鸟
  • 昆虫擦除
  • 昆虫
  • 拉布拉多
  • 跨越式
  • 松散线
  • 潮汐
  • 颤动
  • 波纹
  • 橡胶板
  • 橡胶
  • 晕船
  • 拖曳
  • 即将沸腾
  • 切片与骰子
  • 发芽
  • 标记组
  • 麦田
  • 风海流
  • 摇摆

动画进入

  • 居中螺旋
  • 字符拖入
  • 解码淡入
  • 字符落入
  • 蒸汽视力表
  • 淡化上升并翻转
  • 字符淡化上升
  • 行淡化上升
  • 词淡化上升
  • 从底部飞入
  • 扭转飞入
  • 弹出无意义文字
  • 下雨字符入
  • 随机淡化上升
  • 随机拖入
  • 随机单词拖入
  • 缓慢淡化打开
  • 平滑移入
  • 按字符旋转进入
  • 按单词旋转进入
  • 按字符直接进入
  • 按单词直接进入
  • 直接进入多行
  • 伸缩进入每行
  • 伸缩进入每个单词
  • 旋转每行
  • 旋转每个单词
  • 打字机
  • 划入到中央

图形

  • 闪烁条
  • 柠檬条
  • 蓝调
  • 剪切形状
  • 交换
  • 绿点
  • 危险
  • 红色圆周
  • 擦刮胶片
  • 雪花
  • 白色修剪
  • 黄色框

多行

  • 字母汤
  • 缩短 - 展开
  • 电流
  • 数据包
  • 数据流
  • 经销商
  • 加密
  • 按字符飞入
  • 按单词飞入
  • 前 - 后
  • 前面 - 后面
  • 构想
  • 引入
  • 喷气流 2
  • 喷气流
  • 多行翻转
  • 引出 - 引入
  • 气动
  • 作品
  • 左右堆积
  • 工作日
  • 单词处理程序
  • 喜悦

缩放

  • 大比例缩放
  • 跳舞
  • 逐词缩小
  • 缩小
  • 逐词放大
  • 放大
  • 摆动缩放擦除
  • 缩放拉开
  • 缩放推进

字符间距

  • 收缩
  • 减小字符间距
  • 扩展
  • 增加字符间距
  • 放大
  • 痉挛
  • 有弹性

动画离开

  • 编码器淡出
  • 按字符淡出
  • 淡出缓慢
  • 大量字符离开
  • 随机飞离
  • 随机单词飞离
  • 按字符向右滑出
  • 按单词向右滑出
  • 伸缩每行
  • 伸缩每个单词
  • 旋转出每行
  • 旋转出每个单词

表达式

  • 无意义文字
  • 当前时间格式
  • 词典
  • 显示合成时间
  • 帧编号
  • 蠕动前进
  • 文本回弹

填充和描边

  • 雕刻描边
  • 填充颜色擦除
  • 闪烁颜色 - 缩放
  • 闪烁颜色
  • 闪烁绿色
  • 燃烧
  • 蓝色脉冲
  • 橘红脉冲
  • 脉冲描边
  • 旋转色相
  • 滑行颜色闪烁
  • 向下柔缓描边
  • 按行的摆动描边宽度
  • 摆动描边宽度

杂项

  • 边角飞入
  • 后翻
  • 吹走
  • 弹入
  • 橡皮筋
  • 混乱
  • 陶土飞靶
  • Dot.Com
  • 施展空间
  • 爆炸
  • 跳跳跳
  • 钟摆
  • 吊袋
  • 问题
  • 卡嗒声
  • 滚动回弹
  • 连续跳跃
  • 六连发
  • 滑动回弹
  • 滑入滑出
  • 烟状
  • 挤压
  • 超级英雄
  • 上摆
  • 扭曲丝带
  • 消失点
  • 蠕动线
  • 溜溜球

旋转

  • 滴落
  • 上翻
  • 完全旋转
  • 一圈一圈循环
  • 随机旋转
  • 字符旋转
  • 逐词旋转
  • 旋转进入
  • 涡旋旋转
  • 旋风

模糊

  • 按单词模糊
  • 子弹列车
  • 蒸发
  • 多雾
  • 活跃
  • 运输

 

曲线和旋转

  • 花开
  • 顺时针进入
  • 逆时针旋转
  • 尘暴
  • 套索翻滚
  • 套索
  • 音乐椅子
  • 牛顿
  • 风车
  • 径向闪光
  • 倒退
  • 旋转
  • 翻跟头
  • 快速旋转
  • 螺旋出
  • 螺旋入
  • 螺旋图形
  • 俯冲入
  • 茶叶
  • 轮圈
  • 回旋入

机械

  • 算法循环
  • 算法
  • 自动化
  • 不良接收
  • 多普勒
  • 电磁铁
  • 直升机
  • 插入文本
  • 运动学
  • 机械
  • 活塞
  • 机架和齿轮
  • 道路
  • 缩放回弹
  • 屏幕滚动
  • 梯级
  • 潜水艇
  • 下划线
  • 变形 9.8

路径

  • 360 度循环
  • 羚羊
  • 蚂蚁
  • 后台
  • 平衡
  • 气球人
  • 气球
  • 跳跃
  • 冒泡
  • 碰撞并滑开
  • 蜈蚣
  • 电路板
  • 传送带
  • 双重螺旋
  • 向下向外
  • 斜向下滑出
  • 斜向下滑入
  • 疯狂
  • 障碍
  • 空手砍削
  • 循环开与关
  • 愉快
  • 有机物
  • 纸夹
  • 管状
  • 壁球
  • 鼠巢
  • 卷到卷
  • 索桥
  • 蛇状
  • 滑坡效应
  • 长螺旋
  • 螺旋形
  • 有弹性
  • 蠕动
  • 自动扶梯
  • 对称
  • 摇摆
  • 星形漫步
  • 锯齿化

变换

过渡 - 溶解

  • 块溶解 - 数字化
  • 块溶解 - 随机
  • 块溶解 - 扫描线
  • 方框 - 同轴 NTSC
  • 方框 - 同轴 PAL
  • 方框 - 随机 NTSC
  • 方框 - 随机 PAL
  • 方框 - 描边 NTSC
  • 方框 - 描边 PAL
  • 溶解 - 斑点
  • 溶解 - 仿色
  • 溶解 - 波纹
  • 溶解 - 沙粒
  • 溶解 - 凝固
  • 溶解 - 蒸汽
  • 淡化 - 下沉到黑场
  • 淡化 - 闪烁到白场
  • 淡化 - 感光过度
  • 椭圆形 - 同轴 NTSC
  • 椭圆形 - 同轴 PAL
  • 椭圆形 - 随机 NTSC
  • 椭圆形 - 随机 PAL

过渡 - 移动

  • 卡片擦除 - 2D 断裂
  • 卡片擦除 - 3D 像素风暴
  • 卡片擦除 - 3D 摇摆
  • 飞动嵌入
  • 滑动 - 下拉
  • 滑动 - 直线
  • 滑动 - 俯冲
  • 滑动 - 变量
  • 伸缩和模糊
  • 伸缩和滑动
  • 伸缩 - 下方对角线
  • 伸缩 - 上方对角线
  • 伸缩 - 水平
  • 伸缩 - 垂直
  • 伸缩超过 - 水平
  • 伸缩超过 - 垂直
  • 缩放 - 2D 旋转
  • 缩放 - 3D 翻滚
  • 缩放 - 气泡
  • 缩放 - 螺旋
  • 缩放 - 摇摆

过渡 - 擦除

  • 带形擦除 - 生成 NTSC
  • 带形擦除 - 生成 PAL
  • 带形擦除 - 交错 NTSC
  • 带形擦除 - 交错 PAL
  • 带形擦除 - 锯齿 NTSC
  • 带形擦除 - 锯齿 PAL
  • 双侧平推门
  • 方格擦除 - NTSC
  • 方格擦除 - PAL
  • 蚌壳
  • 时钟式划出
  • 边角显示
  • 网格擦除
  • 光圈 - 交叉
  • 光圈 - 菱形
  • 光圈 - 点
  • 光圈 - 圆
  • 光圈 - 方形
  • 光圈 - 星形绽开
  • 光圈 - 星形
  • 光圈 - 云隙阳光绽开
  • 光圈 - 云隙阳光
  • 线性擦除
  • 绘画 - NTSC
  • 绘画 - PAL
  • 径向擦除 - 底部
  • 径向擦除 - 顶层
  • 百叶窗
  • 楔形划出

使用 After Effects 完成更多工作

使用 Adobe After Effects 创建令人难以置信的动态图形、文本动画和视觉效果。专为影片、电视、视频和网页而设计。

Adobe 徽标

登录到您的帐户