Ongelma

Kun olet kirjautuneena tietylle käyttäjätilille Macintosh-tietokoneella tai tietokoneella, jossa on käytössä Windows 7 tai sitä uudempi käyttöjärjestelmäversio, Adobe-sovellus toimii odottamattomalla tavalla. Sovellus ei esimerkiksi käynnisty, suorittaa komentoja virheellisesti, palauttaa virheitä tai sulkeutuu odottamatta. Näitä ongelmia ei ilmene kirjauduttaessa vasta luodulle tai toiselle käyttäjätilille.

Ennen kuin aloitat

Mac OS

Tee käynnistyslevystäsi varmuuskopio ennen kuin ryhdyt tekemään tässä asiakirjassa kuvattuja toimenpiteitä.

Kun teet joitakin tässä dokumentissa kuvattuja toimenpiteitä, Finderissa näkyy vahvistusikkuna. Kun vahvistusikkuna tulee näkyviin, kirjoita järjestelmänvalvojan käyttäjätunnus ja salasana ja napsauta OK.

Käyttäjätilikohtaiseen odottamattomaan toimintaan on useita mahdollisia syitä. Tässä asiakirjassa käsitellään vain kaikkein tavallisimpia syitä. Jos tarvitset lisätukea käyttäjätilien vianmäärityksessä, ota yhteys Apple-tukeen.

Windows

Tee järjestelmäasemasta varmuuskopio ennen kuin ryhdyt tekemään tässä asiakirjassa kuvattuja toimenpiteitä.

Näiden toimenpiteiden aikana avautuu joskus käyttäjätilien valvonnan valintaikkunoita, joissa pyydetään lupaa jatkamiseen. Lue valintaikkunan sisältö ennen kuin päätät, haluatko jatkaa. Jos valitset valintaikkunassa kohdan Peruuta, et voit jatkaa toimenpiteen suorittamista.

Joissakin tämän asiakirjan toimenpiteissä mainitaan piilotetut kansiot. Windows Explorer ei oletusarvoisesti näytä piilotettuja kansioita. Jos haluat tuoda piilotetut kansiot näkyviin, lue toimintaohjeet kohdasta Näytä piilotetut tiedostot, kansiot ja tiedostopäätteet | Windows XP, Vista ja Windows 7.

Käyttäjätilikohtaiseen odottamattomaan toimintaan on useita mahdollisia syitä. Tässä asiakirjassa käsitellään vain kaikkein tavallisimpia syitä. Jos tarvitset lisäapua käyttäjätilien vianmäärityksessä, ota yhteyttä tietokoneen valmistajaan tai siirry Microsoftin ohje- ja tukisivustolle osoitteeseen http://support.microsoft.com.

Ratkaisut

Kirjaudu sille käyttäjätilille, jolla Adobe-sovellus käyttäytyy odottamattomalla tavalla. Tee sen jälkeen seuraavat toimenpiteet luettelon mukaisessa järjestyksessä:

Mac OS

1. Myönnä asianmukaisten kansioiden luku- ja kirjoitusoikeudet.

Varmista, että käyttäjätilillä on luku- ja kirjoitusoikeus seuraavissa kansioissa:

  • /Ohjelmat/Adobe
  • /Ohjelmat/.AdobePatchFiles (piilotettu, valitse Siirry > Siirry kansioon)
  • /Ohjelmat/Lisäohjelmat/Adobe
  • /Kirjasto/Ohjelmien tuki/Adobe
  • /Kirjasto/Asetukset/com.adobe
  • /Käyttäjät/[käyttäjä]/Kirjasto/Ohjelmien tuki/Adobe
  • /Käyttäjät/[käyttäjä]/Kirjasto/Välimuisti/Adobe
  • /Käyttäjät/[käyttäjä]/Kirjasto/Välimuisti/com.adobe
  • /Käyttäjät/[käyttäjä]/Kirjasto/Asetukset/Adobe
  • /Käyttäjät/[käyttäjä]/Kirjasto/Asetukset/com.adobe

Jotta käyttöoikeuksien muutokset tulevat voimaan, kirjaudu ulos käyttäjätililtä ja kirjaudu takaisin sisään tai käynnistä laite uudelleen.

2. Luo Adobe-sovelluksen käyttäjätilikohtaiset asetustiedostot uudelleen.

Adobe-sovellukset tallentavat käyttäjän mukautetut asetukset asetustiedostoihin. Jokaisella käyttäjätilillä on omat asetustiedostonsa.

Kun Adobe-sovellus toimii odottamattomalla tavalla ainoastaan tietyllä käyttäjätilillä, syynä saattaa olla se, että jokin käyttäjätilin asetustiedosto on vioittunut. Adobe-sovelluksen voi pakottaa luomaan vioittumattomia asetustiedostoja nimeämällä asetustiedostot uudelleen. Jotkin Adobe-sovellukset tallentavat useita asetustiedostoja kansioon; voit nimetä tämän sovelluskohtaisen kansion uudelleen.

Jotkin Adobe-sovellukset tallentavat asetustiedostoja sekä kansioihin että erillisiin tiedostoihin. Esimerkiksi Adobe Photoshop CS4 käyttää sekä asetustiedostoa, jonka nimi on com.adobe.Photoshop.plist, että asetuskansiota, jonka nimi on Adobe Photoshop CS4 Asetukset. Photoshop CS4 voidaan pakottaa luomaan vioittumattomia asetustiedostoja nimeämällä molemmat edellä mainitut uudelleen. Voit nimetä ne esimerkiksi nimillä Vanha com.adobe.Photoshop.plist ja Vanha Adobe Photoshop CS4 Settings.

Adobe-sovellukset tallentavat asetustiedostot ja -kansiot yhteen tai useampiin seuraavista sijainneista:

  • /Käyttäjät/[käyttäjätunnus]/Kirjasto/Asetukset
  • /Käyttäjät/[käyttäjätunnus]/Kirjasto/Asetukset/Adobe
  • /Käyttäjät/[käyttäjätunnus]/Kirjasto/Ohjelmien tuki/Adobe

Tärkeää: Apple muutti käyttäjäkirjastokansion oletusarvoisesti piilotetuksi Mac OS X 10.7 -version myötä. Jos piilotetussa käyttäjäkirjastokansiossa olevia tiedostoja tarvitaan Adoben vianmääritykseen, katso lisätietoja artikkelista Piilotettujen käyttäjäkirjastotiedostojen käyttäminen.

Lisäksi jotkin Adobe-sovellukset tallentavat muita asetustiedostoja toisiin sijainteihin. Esimerkiksi Adobe Premiere Pro CS4 tallentaa muita asetustiedostoja Asettelut-, Asetukset- ja Tyylit-kansioihin. Nämä tiedostot ovat kansiossa /Käyttäjät/[käyttäjätunnus]/Dokumentit/Adobe/Premiere Pro/4.0.

Vianmäärityksen kohteena olevan Adobe-sovelluksen asetustiedostojen ja -kansioiden tarkat nimet ja sijainnit ovat saatavilla osoitteessa www.adobe.com/fi/support. Hae tukitietokannasta antamalla hakusana "asetukset"sekä sovelluksen nimi ja versio. Tutustu sen jälkeen asiakirjaan "Järjestelmävirheet tai jumittumiset" tai muihin hakutuloksista löytyviin asiakirjoihin.

Luo Adobe-sovelluksen asetustiedostot uudelleen toimimalla seuraavasti:

  1. Lopeta Adobe-sovellus.
  2. Nimeä Adobe-sovelluksen asetustiedostot ja -kansiot uudelleen.
  3. Avaa Adobe-sovellus. Sovellus luo asetustiedostoja.

Kun olet luonut asetustiedostot ja -kansiot uudelleen, yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, vioittunut asetustiedosto ei ole ongelman aiheuttaja. Palauta käyttäjätilikohtaiset mukautetut asetukset poistamalla juuri luodut asetustiedostot ja -kansiot. Palauta sen jälkeen uudelleennimettyjen tiedostojen ja kansioiden alkuperäiset nimet.

Jos ongelmaa ei enää ilmene, vioittunut asetustiedosto oli ongelman aiheuttaja. Aiempiin asetustiedostoihin liittyneet mukautetut asetukset eivät kuitenkaan ole enää käytettävissä.

3. Tee käyttäjätilikohtaisten kirjasinten vianmääritys.

Mac OS -käyttöjärjestelmässä kirjasimet voidaan asentaa joko kaikille tai yksittäisille käyttäjätileille. Käyttäjätilikohtaiset kirjasintiedostot sijaitsevat sijaitsevat kohteessa /Käyttäjät/[käyttäjänimi]/Kirjasto/Kirjasimet.

Jos Adobe-sovellus toimii odottamattomasti vain tietyllä käyttäjätilillä, syynä voi olla vain kyseiselle tilille asennettu vahingoittunut kirjasintiedosto.

Poista kaikki tilikohtaiset kirjasimet väliaikaisesti käytöstä Mac OS X -käyttöjärjestelmän Font Book -sovelluksen avulla. Kun olet poistanut tilikohtaiset kirjasimet käytöstä, etsi ja poista Adoben kirjasinvälimuistitiedostot. Toimi seuraavasti:

  1. Sulje kaikki avoimet ohjelmat.
  2. Jos käytät jonkin toisen valmistajan kirjasinhallintasovellusta kirjasimien käyttöön ottoon tai käytöstä poistamiseen, poista kyseinen sovellus käytöstä tilapäisesti. Katso lisäohjeita sovelluksen käyttöoppaasta.
  3. Avaa Kirjasinkirja. (Kirjasinkirja sijaitsee normaalisti Ohjelmat-kansiossa.)
  4. Valitse Kokoelma-sarakkeesta Käyttäjä. Tee sitten jokin seuraavista toimista:

    • Jos kirjasinsarake on tyhjä, tälle käyttäjätilille ei ole asennettu tilikohtaisia kirjasimia. Ohita seuraavat vaiheet ja jatka suoraan tehtävään 3.
    • Jos kirjasinsarakkeessa on vähintään yksi kirjasin, valitse Muokkaa > Poista käytöstä ”käyttäjä”.
  5. Valitse Finderissa Tiedosto > Etsi. Hakuvaihtoehdot näkyvät etumaisen Finder-ikkunan yläosassa.

  6. Etsi Adoben kirjasinvälimuistitiedostoja valitsemalla seuraavat hakuasetukset:

    • Mac OS X 10.4.x: Valitse hakuvaihtoehtojen ylimmällä rivillä Koti. Valitse toisella rivillä Nimi ja kahdesta ponnahdusikkunasta vaihtoehto Alkaa. Kirjoita sitten Alkaa-kohdan oikealla puolella olevaan tekstikenttään AdobeFnt.
    • Mac OS X 10.5.x ja uudemmat: Valitse hakuvaihtoehtojen ylimmällä rivillä käyttäjätilin nimi (näkyy lainausmerkkien sisällä). Valitse toisella rivillä Nimi ja kahdesta ponnahdusikkunasta vaihtoehto Alkaa. Kirjoita sitten Alkaa-kohdan oikealla puolella olevaan tekstikenttään AdobeFnt.
  7. Poista hakutuloksista kaikki tiedostot, joiden nimen alussa on ”AdobeFnt” ja lopussa ”.lst”.

  8. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, tilikohtainen kirjasin ei ole ongelman aiheuttaja. Ota tilikohtaiset kirjasimet uudelleen käyttöön avaamalla Kirjasinkirja, valitsemalla Kokoelma-sarakkeessa Käyttäjä ja valitsemalla sitten Muokkaa > Ota käyttöön. Jatka sitten tehtävään 3.

Jos ongelmaa ei enää ilmene, tilikohtainen kirjasin oli ongelman aiheuttaja. Määritä ongelman aiheuttava kirjasintiedosto toimimalla seuraavasti:

  1. Avaa Kirjasinkirja.

  2. Valitse Kokoelma-sarakkeesta Käyttäjä.

  3. Valitse kirjasinsarakkeessa yksi käytöstä poistetuista kirjasimista.

  4. Valitse Muokkaa > Ota käyttöön [kirjasimen nimi].

  5. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen. Tee sitten jokin seuraavista toimista:

    • Jos ongelma yhä jatkuu, sulje Adobe-sovellus ja toista vaiheet 3–5.
    • Jos ongelmaa ei enää ilmene, viimeksi uudelleen käyttöönotettu kirjasin oli ongelman aiheuttaja. Jätä kyseinen kirjasin pois käytöstä, tai poista kyseinen kirjasin ja hanki korvaava kirjasintiedosto kirjasimen julkaisijalta.

4. Poista tilikohtaiset Adobe-välimuistitiedostot.

Jotkin Adobe-sovellukset luovat tilapäisiä tiedostoja (välimuistitiedostoja). Käyttäjätilin liialliset tai vahingoittuneet välimuistitiedostot saattavat aiheuttaa Adobe-sovelluksessa odottamatonta toimintaa.

Toimi seuraavasti:

  1. Lopeta kaikki Adobe-sovellukset.

  2. Siirry Finderissa kohtaan /Käyttäjät/[käyttäjänimi]/Kirjasto/Välimuistit.

  3. Poista Adobe-kansio Välimuistit-kansiosta.

  4. Poista Välimuistit-kansiosta kaikki kansiot, jotka on nimetty vianmäärityksen kohteena olevan Adobe-sovelluksen mukaan.

  5. Poista Välimuistit-kansiosta kaikki kansiot, jotka on nimetty vianmäärityksen kohteena olevan Adobe-sovelluksen komponenttien mukaan. Jos suoritat esimerkiksi Photoshop CS4:n vianmääritystä, poista tällöin myös Välimuistit-kansiossa oleva Adobe Camera Raw -kansio.

  6. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

5. Tee vianmääritys tilikohtaisille kirjautumiskohteille.

Kirjautumiskohteet ovat sovelluksia tai asiakirjoja, jotka avautuvat automaattisesti käyttäjätilille kirjauduttaessa. (Ne aukeavat automaattisesti myös tietokoneen käynnistyksen yhteydessä, jos olet ottanut automaattisen sisäänkirjautumisen käyttöön.) Jotkin kirjautumiskohteet piilotetaan niiden aukeamisen jälkeen. Kun Adobe-sovellus toimii odottamattomasti jollakin tilillä, jokin kyseisen tilin kirjautumiskohteista saattaa olla vioittunut, ei toimi kunnolla tai ei ole yhteensopiva käytetyn Adobe-sovelluksen kanssa.

Selvitä, onko jokin käyttäjätilin kirjautumiskohteista syynä Adobe-sovelluksen ongelmiin toimimalla seuraavasti:

  1. Valitse Omenavalikko > Kirjaa ulos [käyttäjänimi].

  2. Osoita vahvistusikkunassa Kirjaudu ulos. Hetken kuluttua näyttöön tulee kirjautumisikkuna.

  3. Valitse kirjautumisikkunasta vianmäärityksen kohteena oleva käyttäjätili.

  4. Kirjoita käyttäjätilin salasana salasanakenttään,muttaälä paina Rivinvaihto-näppäintä äläkä osoita Kirjaudu sisään.

  5. Pidä vaihtonäppäin painettuna ja osoita Kirjaudu sisään. Kun Dock tulee näkyviin, vapauta vaihtonäppäin. Kirjautumiskohteet ovat poissa käytöstä kunnes kirjaudut ulos (tai käynnistät tietokoneen uudelleen).

  6. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, kirjautumiskohde ei ole ongelman aiheuttaja. Ota kirjautumiskohteet uudelleen käyttöön kirjautumalla ulos (Omenavalikko > Kirjaa ulos [käyttäjätunnus]). Kirjaudu sitten takaisin samaan käyttäjätiliin (älä pidä vaihtonäppäintä painettuna). Jatka sitten tehtävään 5.

Jos ongelmaa ei enää ilmene, kirjautumiskohde on ongelman aiheuttaja. Määritä ongelman aiheuttava kirjautumiskohde toimimalla seuraavasti:

Jos ongelma ilmenee yhä, tilikohtainen kirjasin ei ole ongelman aiheuttaja. Ota tilikohtaiset kirjasimet uudelleen käyttöön avaamalla Kirjasinkirja, valitsemalla Kokoelma-sarakkeessa Käyttäjä ja valitsemalla sitten Muokkaa > Ota käyttöön. Jatka sitten tehtävään 3.

Jos ongelmaa ei enää ilmene, tilikohtainen kirjasin oli ongelman aiheuttaja. Määritä ongelman aiheuttava kirjasintiedosto toimimalla seuraavasti:

  1. Valitse Omenavalikko > Kirjaa ulos [käyttäjänimi].

  2. Kirjaudutakaisinsamalle tilille. Älä pidä vaihtonäppäintä painettuna.

  3. Valitse Omenavalikko > Järjestelmäasetukset.

  4. Osoita Järjestelmäasetukset-ikkunassa Käyttäjät.

  5. Jos ikkunan alareunassa oleva lukkokuvake on lukittuna, osoita kuvaketta ja vahvista.

  6. Valitse vianmäärityksen kohteena oleva käyttäjätili.

  7. Osoita Kirjautumiskohteet-välilehteä.

  8. Tee luettelo nykyisistä kirjautumiskohteista.

  9. Valitse kirjautumiskohde ja paina Poista.

  10. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen. Tee sitten jokin seuraavista toimista:

    • Jos ongelma yhä jatkuu, sulje Adobe-sovellus ja toista vaiheet 9 ja 10.
    • Jos ongelmaa ei enää ilmene, viimeksi poistettu kirjautumiskohde oli ongelman aiheuttaja. Ota yhteyttä kyseisen kirjautumiskohteen julkaisijaan ja pyydä lisätietoja päivitetyn version saatavuudesta. Palauta muut kirjautumiskohteet vetämällä niiden kuvakkeet Järjestelmäasetusten Kirjautumiskohteet-alueelle. Vaihtoehtoisesti voit asentaa kirjautumiskohteeseen liittyvän sovelluksen uudelleen.

6. Palauta käyttöasetukset käyttäjätilin Kirjasto-kansiossa.

Suorita tämä toimenpide vain, jos teet vianmääritystä salasanalla suojatulle järjestelmänvalvojan tilille.

Jokaisella Mac OS X -aseman tiedostolla ja kansiolla on Unix-tyyppiset omistaja- ja oikeusasetukset. Nämä asetukset määrittävät, miltä käyttäjätileiltä on pääsy tiedostoon tai kansioon ja miltä tileiltä ei ole pääsyä.

Adobe-sovellus saattaa toimia odottamattomasti jollakin tilillä, jos sen Kirjasto-kansion (tai alakansion) käyttöasetukset ovat vahingoittuneet tai väärin rajoitetut. Voit korjata nämä asetukset käyttämällä Unix-komentoja chmod ja chown. Toimi seuraavasti:

  1. Valitse Finderissa Siirry > Koti. Etumainen Finder-ikkuna vie käyttäjätilin Koti-kansioon. Huomaa kyseisen Finder-ikkunan otsikossa oleva nimi. Tämä nimi on käyttäjätilin ”lyhytkäyttäjätunnus”. (Tätä lyhyttäkäyttäjätunnustatarvitaan vaiheen 3 suorittamiseen.)

  2. Avaa Pääte-sovellus, joka sijaitsee yleensä kansiossa /Ohjelmat/Lisäohjelmat.

  3. Kirjoita komentosi Pääte-ikkunaan (käytä jotakin alla olevista komennoista mallina) ja paina sitten Enter. (Kun olet painanut Enteriä komennon lopussa, ohjelma pyytää salasanaa. Kirjoita käyttäjätilin salasana ja paina jälleen Enter. Kun näppäilet salasanan kirjaimia, näytöllä ei näy asteriskeja tai muita merkkejä. Tällainen toiminta ei ole epätavallista.)

    Tärkeää: Alla olevat komennot ovat malleja, eivät varsinaisia komentoja, joita sinun tulee käyttää. Korvaa käyttämissäsi komennoissa käyttäjätunnus vaiheessa 1 mieleen painamallasi lyhyellä käyttäjätunnuksella. Käytä lyhyen käyttäjätunnuksen kirjoittamiseen vain pieniä kirjaimia. (Kirjoita Mac OS X 10.4.x -versiossa lyhyt käyttäjätunnus kahdesti ja käytä välissä kaksoispistettä. Kirjoita Mac OS X 10.5.x -versiossa lyhyen käyttäjätunnuksen perään kaksoispiste ja sana staff.)

    Mallikomento Mac OS X 10.4.x -versioille:


    sudo chown-R käyttäjänimi:käyttäjänimi~/Kirjasto

    Mallikomento Mac OS X 10.5.x -versioille:

    sudo chown-R käyttäjänimi:staff~/Kirjasto

  4. Kirjoita alla oleva komento täsmälleen annetussa muodossa ja paina sitten Enter.

    sudo chmod -R 700 ~/Kirjasto

  5. Lopeta Pääte.

  6. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

7. Korjaa käynnistyslevy.

Vain tietyn käyttäjätilin toimintaan vaikuttava kiintolevyn vika voi saada Adobe-sovelluksen toimimaan odottamattomalla tavalla kyseisellä käyttäjätilillä.

Suorita alla olevat vaiheet jos sinulla on tietokoneesi mukana tullut Mac OS X -asennuslevy. Jos sinulla ei ole asennuslevyä, voit korjata käynnistyslevyn käyttämällä Päätteessä komentoa fsck . Vaihtoehtoisesti voit käyttää jonkin toisen valmistajan levynkorjaustyökalua. Katso lisäohjeita fsck-komennon käyttöön Apple-tukisivuston kohdasta TS1417. Toisen valmistaja levynkorjaustyökalun ohjeet ovat työkalun oppaassa.

  1. Aseta Mac OS X -asennuslevy tietokoneen optiseen asemaan.
  2. Valitse Omenavalikko > Käynnistä uudestaan.
  3. Kun kuulet käynnistysäänen, paina näppäimistön C-näppäin pohjaan ja pidä se painettuna.
  4. Kun näet aloitusikkunan ja etenemispalkin, vapauta C-näppäin.
  5. Jos Mac OS X -asennusohjelma pyytää valitsemaan kielen, valitse haluamasi kieli.
  6. Kun asennusvalikko tulee käytettäväksi (näytön oikeassa yläreunassa), valitse Asentaja > Levytyökalu.
  7. Valitse käynnistylevy Levytyökalun vasemmalta puolelta.
  8. Valitse Korjaus-välilehtioikealta.

  9. Valitse Korjaa levy.

  10. Jos korjaus valmistuu ja ohjelma ilmoittaa, että levyltä on korjattu virheitä, toista Vaihe 9. Jos korjaus valmistuu ja ohjelma ei ilmoita virheistä, käynnistä Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

8. Aloita uuden käyttäjätilin käyttö.

Jos sovelluksessa esiintyy edelleen odottamatonta toimintaa tietyllä tilillä, Adobe suosittelee, että kopioit (tai siirrät) kaikki henkilökohtaiset tiedostot uudelle käyttäjätilille. Käytä sitten tätä uutta tiliä varsinaisena tilinäsi.

Jos tarvitset apua henkilökohtaisten tiedostojen kopioimisessa uudelle tilille, ota yhteyttä Apple-tukeen.

Windows

1. Myönnä asianmukaisten kansioiden luku- ja kirjoitusoikeudet.

Varmista, että käyttäjätilillä on luku- ja kirjoitusoikeus seuraavissa kansioissa:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. Luo Adobe-sovelluksen käyttäjätilikohtaiset asetustiedostot uudelleen.

Adobe-sovellukset tallentavat käyttäjän mukautetut asetukset asetustiedostoihin. Jokaisella käyttäjätilillä on omat asetustiedostonsa.

Kun Adobe-sovellus toimii odottamattomalla tavalla ainoastaan tietyllä käyttäjätilillä, syynä saattaa olla se, että jokin käyttäjätilin asetustiedosto on vioittunut. Adobe-sovelluksen voi pakottaa luomaan vioittumattomia asetustiedostoja nimeämällä uudelleen kansion, jossa asetustiedostot sijaitsevat.

Esimerkiksi Adobe Premiere Pro CS4 tallentaa asetustiedostot kansioon, jonka nimi on 4.0 ja joka sijaitsee kohteessa C:\Käyttäjät\[käyttäjänimi]\AppData\Roaming\Adobe\Premiere Pro. Pakota Adobe Premiere Pro CS4 luomaan asetustiedostoja uudelleen nimeämällä 4.0-kansio uudelleen (anna sille nimeksi esimerkiksi Vanha 4.0).

Adobe-sovellukset tallentavat asetustiedostot ja -kansiot seuraavista sijainneista toiseen tai molempiin:

  • C:\Users\[käyttäjänimi]\AppData\Roaming\Adobe
  • C:\Users\[käyttäjänimi]\AppData\Local\Adobe

Lisäksi jotkin Adobe-sovellukset tallentavat muita asetustiedostoja toisiin sijainteihin. Esimerkiksi Adobe Premiere Pro CS4 tallentaa muita asetustiedostoja Tyylit- ja Asettelut-kansioihin, jotka sijaitsevat kohteessa C:\Käyttäjät\[käyttäjänimi]\Dokumentit\Adobe\Premiere Pro\4.0.

Vianmäärityksen kohteena olevan Adobe-sovelluksen asetustiedostojen tarkat nimet ja sijainnit ovat saatavilla osoitteessa https://helpx.adobe.com/fi/support.html. Hae tukitietokannasta antamalla hakusana ”asetukset” sekä sovelluksen nimi ja versio. Tutustu senjälkeenasiakirjaan ”Järjestelmävirheet tai jumittumiset” tai muihin hakutuloksista löytyviin asiakirjoihin.

Luo Adobe-sovelluksen asetustiedostot uudelleen toimimalla seuraavasti:

  1. Sulje Adobe-sovellus.

  2. Nimeä Adobe-sovelluksen asetuskansiot uudelleen.

  3. Käynnistä Adobe-sovellus. Sovellus luo vioittumattomia asetustiedostoja.

Kun olet luonut asetustiedostot uudelleen, yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, vioittunut asetustiedosto ei ole ongelman aiheuttaja. Palauta Adobe-sovelluksen käyttäjätilikohtaiset mukautetut asetukset poistamalla juuri luodut asetuskansiot. Palauta sen jälkeen uudelleennimettyjen kansioiden alkuperäiset nimet.

Jos ongelmaa ei enää ilmene, vioittunut asetustiedosto oli ongelman aiheuttaja. (Aiempiin asetustiedostoihin liittyneet mukautetut asetukset eivät ole enää käytettävissä tällä käyttäjätilillä.)

3. Poista käyttäjätilikohtaiset tilapäistiedostot.

Jotkin Adobe-sovellukset tallentavat tietoja tilapäisiin tiedostoihin. Adobe-sovellus saattaa toimia odottamattomalla tavalla, jos käyttäjätilikohtaisia tilapäistiedostoja on liikaa tai ne ovat vanhentuneet tai vioittuneet.

Poista tilapäiset tiedostot käyttämällä Levyn uudelleenjärjestämistyökalua. Katso lisätietoja kohdasta Tilapäisten tiedostojen poistaminen Levyn uudelleenjärjestämistyökalun avulla (Windows 7 ja Vista).

Levyn uudelleenjärjestämistyökalu ei oletusarvoisesti poista tiedostoja käyttäjätilikohtaisesta Temp-kansiosta, jota on käytetty viimeisten seitsemän päivän aikana. Tilapäiset tiedostot voidaan poistaa tehokkaasti poistamalla Temp-kansion sisältö manuaalisesti.

Vastuuvapauslauseke: Muiden julkaisijoiden kuin Adoben sovellukset saattavat vahingoittua, jos Temp-kansion sisältö poistetaan manuaalisesti. Toimi varoen, jos päätät tehdä seuraavan ylimääräisen toimenpiteen. Adobe ei tarjoa tukea ongelmiin, jotka aiheutuvat Temp-kansion tiedostojen manuaalisesta poistamisesta.

Jos haluat poistaa käyttäjätilin Temp-kansion sisällön manuaalisesti, toimi seuraavasti:

  1. Sulje kaikki sovellukset.

  2. Valitse Käynnistä > Kaikki ohjelmat > Apuohjelmat. Kaksoisnapsauta komentokehotetta ja valitse Suorita järjestelmänvalvojana.

  3. Kirjoita Komentokehote-ikkunassa seuraava komento täsmälleen samassa muodossa, jossa se on alla, ja paina sitten Enter-näppäintä:

    del %temp%\*.* /s /q

    Huomaa: del on komento, jolla poistetaan tiedostoja. %temp%\*.* on yhdistelmä, johon kuuluu käyttäjätilin Temp-kansion ympäristömuuttuja ja kaikkia tiedostoja osoittavat yleismerkit. /s laajentaa komennon koskemaan kaikkia tiedostoja kaikissa alikansioissa. /q estää Windowsia antamasta kehotetta vahvistaa kaikkien tiedostojen poistaminen.

  4. Komentorivi-ikkunaan ilmestyy luettelo poistetuista tiedostoista. (Luettelo saattaa sisältää tiedostoja, joita ei voida poistaa. Näkyviin tulee todennäköisesti ilmoitus "Käyttö estetty" tai "Prosessi ei voi käyttää tiedostoa, koska jokin toinen prosessi käyttää tiedostoa tällä hetkellä". Tällainen toiminta ei ole epätavallista.)

  5. Sulje Komentokehote-ikkuna.

Kun olet poistanut tilapäiset tiedostot, avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

4. Tee vianmääritys käyttäjätilikohtaisille käynnistyskohteille.

Käynnistyskohteet ovat sovelluksia tai asiakirjoja, jotka avautuvat automaattisesti käyttäjätilille kirjauduttaessa. Kun Adobe-sovellus toimii odottamattomasti jollakin käyttäjätilillä, jokin kyseisen käyttäjätilin käynnistyskohteista on vioittunut tai ei toimi kunnolla tai ole yhteensopiva käytetyn Adobe-sovelluksen kanssa.

Selvitä, onko käyttäjätilin jokin käynnistyskohde syynä Adobe-sovelluksen ongelmiin toimimalla seuraavasti:

  1. Siirry Resurssienhallinnassa kohteeseen C:\Käyttäjät\[käyttäjänimi]\AppData\Roaming\Microsoft\Windows\Käynnistys-valikko\Ohjelmat\Käynnistys.

  2. Tee jokin seuraavista toimista:

    • Jos Käynnistys-kansio on tyhjä tai jos Käynnistys-kansiota ei ole olemassa, käyttäjätilillä ei ole lainkaan käyttäjätilikohtaisia käynnistyskohteita. Ohita seuraavat vaiheet ja jatka suoraan kohtaan 4.
    • Jos Käynnistys-kansiossa on vähintään yksi kohde, luo työpöydälle uusi kansio. Anna uudelle kansiolle nimeksi Säilytyskansio.
  3. Siirrä seuraavaksi kaikki Käynnistys-kansion kohteet juuri luotuun Säilytyskansioon.

  4. Valitse Käynnistä > Kirjaudu ulos.

  5. Kirjaudu sen jälkeen takaisin samalle käyttäjätilille.

  6. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, käyttäjätilikohtainen käynnistyskohde ei ole ongelman aiheuttaja. Voit siirtää kaikki Säilytyskansion kohteet takaisin kohteeseen C:\Käyttäjät\[käyttäjänimi]\AppData\Roaming\Microsoft\Windows\Käynnistys-valikko\Ohjelmat\Käynnistys. Jatka kohtaan 4.

Jos ongelmaa ei enää ilmene, käyttäjätilikohtainen käynnistyskohde oli ongelman aiheuttaja. Määritä ongelman aiheuttava käynnistyskohde toimimalla seuraavasti:

  1. Sulje Adobe-sovellus.

  2. Siirrä yksi kohde Säilytyskansiosta takaisin kohteeseen C:\Käyttäjät\[käyttäjänimi]\AppData\Roaming\Microsoft\Windows\Käynnistys-valikko\Ohjelmat\Käynnistys.

  3. Valitse Käynnistä > Kirjaudu ulos.

  4. Kirjaudu sen jälkeen takaisin samalle käyttäjätilille.

  5. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen. Tee sitten jokin seuraavista toimista:

    • Jos ongelma yhä jatkuu, toista vaiheet 1–5.
    • Jos ongelmaa ei enää ilmene, viimeksi uudelleen käyttöönotettu käynnistyskohde oli ongelman aiheuttaja. Poista ongelmia aiheuttanut käynnistyskohde Käynnistys-kansiosta. Ota yhteyttä käynnistyskohteen julkaisijaan ja kysy lisätietoja päivitetyn version saatavuudesta. Siirrä kaikki Säilytyskansion jäljellä olevat kohteet takaisin kohteeseen C:\Käyttäjät\[käyttäjänimi]\AppData\Roaming\Microsoft\Windows\Käynnistys-valikko\Ohjelmat\Käynnistys.

5. Palauta käyttäjätilikohtaisten sovellustietokansioiden käyttöasetukset.

Suorita tämä toimenpide vain, jos teet vianmääritystä tilille, joka ei ole järjestelmänvalvojan tili ja joka ei oleon verkon toimialueella.

Käyttäjätilikohtaisia virheitä voi ilmetä, jos tilillä ei ole täysiä luku- ja kirjoitusoikeuksia kansioihin, joissa sijaitsevat Adobe-sovelluksen asetustiedostot ja käyttäjätilikohtaisia tietoja sisältävät tiedostot.Käyttöasetukset voidaan palauttaaicacls-komennolla. Toimi seuraavasti:

  1. Sulje kaikki sovellukset.

  2. Valitse Käynnistä > Kaikki ohjelmat > Apuohjelmat. Kaksoisnapsauta komentokehotetta ja valitse Suorita järjestelmänvalvojana. Komentorivi-ikkuna avautuu.

  3. Kirjoita komentorivi-ikkunassa seuraavat komennot täsmälleen siinä muodossa, jossa ne näkyvät alla. Paina jokaisen komennon jälkeen Enter-näppäintä. 

    Tärkeää: Lisää jokaisessa komennossa välilyönti jokaisen valitsimen – /T, /C ja /grant – molemmille puolille.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%käyttäjänimi%":F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant "%käyttäjänimi%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. Sulje komentorivi-ikkuna.

  5. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

6. Luo Windowsin rekisterissä uudelleen käyttäjätilikohtainen Adobe-avain.

Vastuuvapauslauseke: Tämä toimenpide edellyttää muutosten tekemistä Windowsin rekisteriin. Rekisteri sisältää järjestelmään liittyviä tietoja, jotka ovat kriittisiä tietokoneen ja sovellusten kannalta. Ennen kuin muokkaat rekisteriä, tee siitä varmuuskopio. Adobe ei tarjoa tukea ongelmille, jotka aiheutuvat siitä, että rekisteriä muokataan virheellisesti. Lisätietoja Windowsin rekisteristä tai rekisterieditorista on saatavilla Microsoftin ohje- ja tukisivustolta osoitteesta http://support.microsoft.com.

  1. Sulje kaikki sovellukset.

  2. Napsauta Käynnistä-painiketta. Type regedit Aloita haku -ruutuun ja paina sitten Enter. Rekisterieditori avautuu.

  3. Etsi rekisterieditorin vasemmasta reunasta seuraava rekisteriavain ja valitse se:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Valitse Tiedosto > Vie.

  5. Valitse Vie rekisteritiedosto -valintaikkunassa Vientialue-kohdasta vaihtoehto Valittu haara. Anna nimi ja sijainti varmuuskopiorekisterin avainta varten ja valitse sitten Tallenna.

  6. Napsauta Adobe-avainta hiiren kakkospainikkeella ja valitse Poista.

  7. Valitse Vahvista avaimen poisto -valintaikkunassa kohta OK.

  8. Sulje rekisterieditori.

  9. Avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen.

Jos ongelma ilmenee yhä, vioittunut rekisterimerkintä ei ole ongelman aiheuttaja. Voit palauttaa Adobe-avaimen varmuuskopion toimimalla seuraavasti:

  1. Sulje kaikki sovellukset.

  2. Napsauta Käynnistä-painiketta. Type regedit Aloita haku -ruutuun ja paina sitten Enter. Rekisterieditori avautuu.

  3. Valitse rekisterieditorissa Tiedosto > Tuo.

  4. Siirry Tuo rekisteritiedosto -valintaikkunassa sijaintiin, johon aiemmin tallensit varmuuskopiorekisterin avaimen. Valitse tiedosto ja napsauta Avaa.

7. Korjaa järjestelmän kiintolevy.

Kiintolevyn vika, joka vaikuttaa vain tietyn käyttäjätilin toimintaan, voi aiheuttaa häiriöitä Adobe-sovelluksen toimintaan kyseisellä käyttäjätilillä.

Ohjeet järjestelmän kiintolevyn korjaamiseen löytyvät kohdasta Kiintolevyjen korjaaminen ja eheyttäminen (Windows 7 ja Vista).

Kun olet korjannut kiintolevyn, avaa Adobe-sovellus ja yritä aiheuttaa ongelma uudelleen. Jos ongelma yhä jatkuu, jatka kokeilemalla seuraavaa toimenpidettä.

8. Aloita uuden käyttäjätilin käyttö.

Jos sovelluksessa esiintyy edelleen odottamatonta toimintaa tietyllä käyttäjätilillä, kopioi (tai siirrä) kaikki henkilökohtaiset tiedostot tilille, jolla sovellus toimii normaalisti. Käytä tätä uutta tiliä varsinaisena tilinäsi.

Jos tarvitset apua henkilökohtaisten tiedostojen kopioimisessa uudelle käyttäjätilille, ota yhteyttä tietokoneen valmistajaan. Voit myös siirtyä Microsoftin ohje- ja tukisivustolle osoitteeseen http://support.microsoft.com.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö