Lorsqu’un graphique ou un document est optimisé, vous pouvez l’exporter (ou l’enregistrer, selon le type de fichier d’origine).

Vous pouvez exporter (ou enregistrer) un document comme une simple image au format GIF, JPEG ou autre. Vous pouvez également exporter tout le document en tant que fichier HTML et les fichiers image associés, uniquement des tranches sélectionnées ou une zone spécifique. En outre, vous pouvez exporter des états Fireworks et des calques dans des fichiers d’image distincts.

L’emplacement par défaut dans lequel Fireworks exporte des documents est déterminé par les éléments suivants, dans l’ordre :

  1. Préférence d’exportation actuelle du document, définie si vous avez déjà exporté le document puis enregistré le PNG

  2. Emplacement actuel d’exportation/d’enregistrement, défini à chaque fois que vous modifiez l’emplacement par défaut dans la boîte de dialogue Enregistrer, Enregistrer sous ou Exporter

  3. Emplacement du fichier actif

  4. Emplacement d’enregistrement par défaut des nouveaux documents ou des nouvelles images sur le système d’exploitation

    L’emplacement par défaut d’enregistrement par Fireworks d’un document est quant à lui déterminé par des critères très différents. Pour plus d’informations, reportez-vous à la section Enregistrement de fichiers Fireworks.

Exportation de pages en tant que fichiers d’image

  1. Choisissez Fichier > Exporter.

  2. Spécifiez l’emplacement des fichiers d’exportation.

  3. Procédez de l’une des manières suivantes :

    • Choisissez Images uniquement dans le menu contextuel Exporter, puis activez ou désactivez la case Page actuelle uniquement. Les pages sont exportées au format d’image défini dans le panneau Optimisation.

    • Dans le menu contextuel Exporter, sélectionnez la commande Pages vers Fichiers, puis choisissez l’option Images dans le menu contextuel Exporter en tant que. Les pages sont exportées au format d’image défini dans le panneau Optimisation.

    • Dans le menu contextuel Exporter, cliquez sur Pages vers Fichiers, puis sélectionnez PNG Fireworks dans le menu contextuel Exporter en tant que. Chaque page est exportée sous la forme d’un fichier PNG distinct qui garantit une compatibilité descendante avec Fireworks 8.

    Remarque :

    Pour exporter toutes les pages dans le format choisi, sélectionnez-les toutes, puis optimisez les paramètres.

Exportation d’une seule image

Si vous travaillez sur une image existante ouverte dans Fireworks, vous pouvez l’enregistrer au lieu de l’exporter. Pour plus d’informations, reportez-vous à la section Enregistrement de documents dans d’autres formats.

Remarque :

Pour exporter uniquement certaines images d’un document, vous devez d’abord découper votre document en tranches, puis exporter uniquement les tranches souhaitées.

  1. Dans le panneau Optimisation, sélectionnez un format de fichier, puis définissez les options propres à ce format.

  2. Choisissez Fichier > Exporter.

  3. Définissez l’emplacement vers lequel exporter le fichier d’image.

    Pour les graphiques web, le meilleur emplacement est généralement un dossier du site web local.

  4. Saisissez un nom de fichier sans extension. Une extension est ajoutée pendant l’exportation selon le type de fichier.

  5. Dans le menu contextuel Exporter, sélectionnez Images uniquement.

  6. Cliquez sur Enregistrer.

Exportation d’un document découpé en tranches

Par défaut, lorsque vous exportez un document Fireworks découpé en tranches, il est exporté sous la forme d’un fichier HTML et de plusieurs images associées. Le fichier HTML exporté peut être affiché dans un navigateur web ou importé dans d’autres applications pour y être retouché.

Avant d’exporter le fichier, assurez-vous que le style HTML approprié est sélectionné dans la boîte de dialogue Configuration HTML. Voir la section Définition des options d’exportation du code HTML.

Exportation de toutes les tranches

  1. Choisissez Fichier > Exporter.

  2. Accédez au dossier de destination de l’exportation sur votre disque dur.

  3. Dans le menu contextuel Exporter, sélectionnez Documents HTML et Images.

  4. Entrez un nom de fichier dans le champ Nom de fichier (Windows) ou Enregistrer sous (Mac OS).

  5. Dans le menu contextuel HTML, sélectionnez Exporter le fichier HTML.

  6. Dans le menu contextuel Tranches, choisissez Exporter les tranches.

  7. (Facultatif) Sélectionnez Placer les images dans des sous-dossiers.

  8. Cliquez sur Enregistrer.

Exportation de tranches sélectionnées

  1. Tout en maintenant la touche Maj enfoncée, cliquez sur plusieurs tranches pour les sélectionner.

  2. Choisissez Fichier > Exporter.

  3. Sélectionnez un emplacement de destination des fichiers exportés (un dossier de votre site web local, par exemple).

  4. Dans le menu contextuel Exporter, sélectionnez Documents HTML et Images.

  5. Saisissez un nom de fichier sans extension. Une extension est ajoutée pendant l’exportation selon le type de fichier.

    Si vous exportez plusieurs tranches, Fireworks utilise le nom entré comme étant le nom racine de tous les graphiques exportés, à l’exception des graphiques auxquels vous avez affecté des noms personnalisés dans le panneau Calques ou dans l’inspecteur des propriétés.

  6. Dans le menu contextuel Tranches, choisissez Exporter les tranches.

  7. Pour exporter uniquement les tranches sélectionnées avant l’exportation, choisissez la commande Tranches sélectionnées uniquement, puis vérifiez que l’option Inclure les zones sans tranches est désélectionnée.

  8. Cliquez sur Enregistrer.

Mise à jour d’une tranche

Si vous avez déjà exporté un document découpé en tranches et que vous avez par la suite apporté des modifications au document original dans Fireworks, vous pouvez uniquement mettre à jour l’image ou la tranche modifiée. Pour trouver facilement la tranche de remplacement, personnalisez le nom des tranches.

  1. Masquez la tranche pour modifier la zone qu’elle recouvre.

  2. Réaffichez la tranche.

  3. Cliquez avec le bouton droit de la souris (Windows) ou tout en maintenant la touche Ctrl enfoncée (Mac OS) sur la tranche, puis sélectionnez Exporter la tranche sélectionnée.

  4. Sélectionnez le même dossier que celui de la tranche d’origine en utilisant le même nom de fichier, puis cliquez sur Enregistrer.

  5. Cliquez sur OK si un message vous demande de remplacer le fichier existant.

    Remarque :

    Dans Fireworks, évitez de redimensionner la tranche au-delà de sa taille d’exportation d’origine car vous risquez d’obtenir des résultats imprévisibles dans le document HTML après la mise à jour de la tranche.

Exportation d’une animation

Lorsque vous avez créé et optimisé une animation, elle est prête à être exportée. Vous pouvez exporter une animation sous les types de fichier suivants :

GIF animé

Ce format donne les meilleurs résultats avec les graphiques de type cliparts et dessins animés.

SWF Flash ou PNG Fireworks (aucune exportation nécessaire)

Exportez une animation en tant que fichier SWF à importer dans Flash. Vous pouvez passer l’étape d’exportation en important directement dans Flash un fichier source PNG Fireworks. Cette méthode plus directe vous permet d’importer tous les calques et tous les états de votre animation et de les peaufiner dans Flash (voir la section Utilisation de Flash).

Fichiers multiples

Il est utile d’exporter des états ou calques d’animation en tant que fichiers multiples lorsque différents calques comportent de nombreux symboles pour un même objet. Par exemple, vous pouvez exporter une bannière publicitaire sous la forme de plusieurs fichiers si chaque lettre du nom d’une société est animée dans un graphique (voir la section Exportation d’états ou de calques en tant que fichiers distincts).

Si votre document comporte plusieurs animations, vous pouvez insérer des tranches pour exporter chaque animation en utilisant différents paramètres d’animation, tels que la lecture en boucle et la cadence des états.

Exportation d’un fichier GIF animé

  1. Choisissez la commande Sélection > Désélectionner pour désélectionner tous les objets et tranches, puis, dans le panneau Optimisation, sélectionnez le format de fichier GIF animé.

  2. Choisissez Fichier > Exporter.

  3. Saisissez le nom du fichier, puis sélectionnez le dossier de destination.

  4. Cliquez sur Enregistrer.

Exportation de plusieurs fichiers GIF animés avec différents paramètres d’animation

  1. Tout en maintenant la touche Maj enfoncée, cliquez sur les animations pour toutes les sélectionner.

  2. Choisissez la commande Edition > Insérer > Tranche rectangulaire ou Tranche polygonale.

  3. Cliquez sur Multiple dans la zone de message.

  4. Sélectionnez chaque tranche individuellement, puis dans le panneau Etats, définissez les différents paramètres d’animation de chaque tranche.

  5. Sélectionnez toutes les tranches à animer, puis choisissez GIF animé comme format de fichier dans le panneau Optimisation.

  6. Cliquez avec le bouton droit de la souris (Windows) ou tout en maintenant la touche Ctrl enfoncée (Mac OS) sur chaque tranche à exporter individuellement, puis sélectionnez Exporter la tranche sélectionnée. Dans la boîte de dialogue Exporter, entrez un nom pour chaque fichier, sélectionnez une destination, puis cliquez sur Enregistrer.

Exportation d’états ou de calques en tant que fichiers distincts

Fireworks permet d’exporter chaque calque ou état d’un document sous la forme d’un fichier d’image distinct en tenant compte des paramètres d’optimisation spécifiés dans le panneau Optimisation. Le nom du calque ou de l’état détermine le nom du fichier exporté correspondant. Cette méthode d’exportation est souvent utilisée pour exporter des animations.

  1. Choisissez Fichier > Exporter.

  2. Entrez un nom de fichier, puis sélectionnez un dossier de destination.

  3. Dans le menu contextuel Exporter, sélectionnez une option :

    Etats vers fichiers

    Exporte les états comme des fichiers distincts.

    Calques vers fichiers

    Exporte les calques comme des fichiers distincts.

    Remarque : cela exporte tous les calques sur l'état actuel.

  4. Pour recadrer automatiquement chaque image exportée de manière à n’inclure que les objets sur chaque état, sélectionnez l’option Rogner les images. Sinon, pour inclure la zone de travail entière (y compris les zones vierges au-delà des objets), désactivez cette option.

  5. Cliquez sur Enregistrer.

Exportation d’une zone de document

  1. Dans le panneau Outils, cliquez sur l’outil Zone d’exportation .

  2. Faites glisser le pointeur de l’outil pour délimiter la partie du document à exporter.

    Remarque :

    vous pouvez ajuster la position du cadre de sélection à mesure que vous le délimitez. Tout en maintenant enfoncés le bouton de la souris et la barre d’espace, faites glisser le cadre de sélection vers l’emplacement approprié sur la zone de travail. Relâchez la barre d’espace pour continuer à dessiner le cadre de sélection.

    Lorsque vous relâchez le bouton de la souris, la zone d’exportation reste sélectionnée.

  3. Au besoin, redimensionnez la zone d’exportation :

    • Pour redimensionner proportionnellement le cadre de sélection de la zone d’exportation, faites glisser une poignée tout en maintenant la touche Maj enfoncée.

    • Pour redimensionner le cadre de sélection en partant de son centre, faites glisser une poignée tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

    • Pour redimensionner le cadre de sélection en partant de son centre en conservant ses proportions, faites glisser une poignée tout en maintenant les touches Alt+Maj (Windows) ou Option+Maj (Mac OS) enfoncées.

  4. Cliquez deux fois à l’intérieur du cadre de sélection de la zone d’exportation pour afficher l’aperçu de l’image.

  5. Définissez les paramètres dans l’aperçu de l’image, puis cliquez sur Exporter.

  6. Entrez un nom de fichier, puis sélectionnez un dossier de destination.

  7. Dans le menu contextuel Exporter, cliquez sur Images uniquement.

  8. Cliquez sur Enregistrer.

    Remarque :

    Pour annuler l’exportation, cliquez deux fois à l’extérieur du cadre de sélection de la zone d’exportation, appuyez sur la touche Echap ou sélectionnez un autre outil.

Exportation de code HTML

Sauf indication contraire, lorsque vous exportez un document Fireworks découpé en tranches, vous exportez un fichier HTML accompagné de ses images. Utilisez la boîte de dialogue Configuration HTML pour définir les paramètres d’exportation de code HTML Fireworks.

Fireworks génère un véritable fichier HTML qui peut être lu dans la plupart des navigateurs web et éditeurs HTML. Par défaut, l’exportation spécifie le codage UTF-8.

Il existe plusieurs façons d’exporter un fichier HTML Fireworks :

  • Exporter un fichier HTML que vous pouvez ouvrir plus tard pour le modifier dans un éditeur HTML

  • Exporter chaque page d’un fichier Fireworks dans un fichier HTML distinct

  • Copier le code HTML dans le Presse-papiers de Fireworks, puis coller directement ce code dans un document HTML existant

  • Exporter un fichier HTML, l’ouvrir dans un éditeur HTML, copier manuellement des sections de code depuis le fichier, puis coller ce code dans un autre document HTML

  • Exporter du code HTML en calques CSS (Cascading Style Sheet) et XHTML

  • Utiliser la commande Mettre à jour le code HTML pour modifier un fichier HTML créé précédemment

    Fireworks vous permet d’exporter du code HTML aux formats Générique, Dreamweaver, Microsoft® FrontPage® et Adobe GoLive®.

    Remarque : Adobe Dreamweaver est étroitement intégré à Fireworks. Fireworks gère les exportations de code HTML vers Dreamweaver différemment des exportations vers d’autres éditeurs HTML. Si vous exportez du code HTML Fireworks vers Dreamweaver, reportez-vous à la section Utilisation de Dreamweaver.

    La méthode d’exportation permettant de récupérer dans d’autres applications un code HTML généré par Fireworks est une méthode idéale pour le travail en équipe. Cette méthode fractionne le flux de production en segments, ce qui permet à une personne d’exécuter une tâche donnée dans une application, puis à une autre de prendre la suite ultérieurement dans une autre application.

Intégration de commentaires dans du code HTML exporté

Les commentaires de code HTML Fireworks sont compris entre les séquences de caractères <!-- et -->. Tout ce qui se trouve entre ces deux marqueurs n’est pas interprété comme code HTML ou JavaScript.

  1. Avant l’exportation, ouvrez la boîte de dialogue Configuration HTML, puis sélectionnez l’option Inclure les commentaires HTML sous l’onglet Général.

Résultats de l’exportation

Lorsque vous exportez ou copiez du code HTML depuis Fireworks, les éléments suivants sont générés :

  • Le code HTML nécessaire pour rassembler les images découpées et un code JavaScript, si le document contient des éléments interactifs. Le code HTML généré par Fireworks contient des liens vers les images exportées et utilise la couleur de la zone de travail pour l’arrière-plan de la page web.

  • Un ou plusieurs fichiers d’image, en fonction du nombre de tranches figurant dans votre document et du nombre d’états de boutons.

  • Un fichier de séparateurs appelé spacer.gif, si nécessaire. Le fichier spacer.gif est un fichier GIF transparent de 1 pixel sur 1 pixel, que Fireworks utilise pour corriger les problèmes d’espacement lorsque les images découpées en tranches sont rassemblées dans une table HTML. La création de ce fichier de séparateurs est facultative.

  • Si vous exportez des menus contextuels, les fichiers suivants sont exportés : un fichier mm_css_menu.js et un fichier .css contenant le code du menu contextuel CSS. Si les menus contextuels contiennent des sous-menus, l’application exporte également un fichier arrows.gif.

  • Lorsque vous exportez ou copiez du code HTML dans Dreamweaver, des fichiers de commentaires sont créés pour faciliter l’intégration entre Fireworks et Dreamweaver. Ces fichiers portent l’extension .mno.

Exportation de code HTML Fireworks

  1. Choisissez Fichier > Exporter.

  2. Accédez au dossier de destination de l’exportation sur votre disque dur.

  3. Dans le menu contextuel Exporter, sélectionnez Documents HTML et Images.

  4. Dans la boîte de dialogue Configuration HTML, cliquez sur le bouton Options, puis, dans le menu contextuel Style HTML de l’onglet Général, sélectionnez un éditeur HTML. Si votre éditeur HTML n’est pas répertorié, sélectionnez Générique.

    Remarque :

    Il est important de sélectionner votre éditeur HTML comme style HTML de sorte que les éléments interactifs, notamment les boutons et les survols, fonctionnent correctement après leur importation dans votre éditeur HTML.

  5. Cliquez sur OK.

  6. Dans le menu contextuel HTML, sélectionnez Exporter le fichier HTML.

  7. Si votre document contient des tranches, dans le menu contextuel Tranches, cliquez sur Exporter les tranches.

  8. Pour stocker des images dans un dossier séparé, sélectionnez la commande Importer les images dans des sous-dossiers. Vous pouvez sélectionner un dossier spécifique ou le dossier Images par défaut de Fireworks.

  9. Si vous exportez un document Fireworks de plusieurs pages, désactivez la case Page active uniquement de manière à exporter toutes les pages dans des documents HTML distincts.

  10. Cliquez sur Enregistrer.

    Une fois exportés, les fichiers Fireworks s’affichent sur votre disque dur. Des images et un fichier HTML sont générés à l’emplacement spécifié dans la boîte de dialogue Exporter.

Copie de code HTML dans le Presse-papiers

Il existe deux manières de copier du code HTML dans le Presse-papiers de Fireworks. Vous pouvez utiliser la commande Copier le code HTML ou, dans la boîte de dialogue Exporter, sélectionner l’option Copier dans le Presse-papiers. Vous pouvez ensuite coller ce code HTML dans un document ouvert dans votre éditeur HTML préféré.

Pour décider de la méthode à utiliser pour intégrer du code HTML Fireworks dans d’autres applications, prenez en compte les inconvénients suivants, consécutifs à la copie de code HTML dans le Presse-papiers :

  • Vous ne pouvez pas enregistrer d’images dans un sous-dossier. Elles doivent se trouver dans le même dossier que le fichier HTML dans lequel vous collez le code HTML copié, sauf si vous copiez le code HTML dans Dreamweaver.

  • Les liens ou chemins utilisés dans les menus contextuels Fireworks sont mappés au disque dur, sauf si vous copiez le code HTML dans Dreamweaver.

  • Si vous utilisez un éditeur HTML autre que Dreamweaver ou Microsoft FrontPage, le code JavaScript associé aux boutons, comportements et images survolées est copié mais ne fonctionne pas correctement.

    Si vous rencontrez ce problème, sélectionnez l’option Exporter le fichier HTML à la place de l’option Copier dans le Presse-papiers.

    Remarque : avant de copier le code HTML, assurez-vous que vous avez sélectionné le style HTML approprié et l’option Inclure les commentaires HTML dans l’onglet Général de la boîte de dialogue Configuration HTML.

Copie de code HTML Fireworks à l’aide de l’option Copier le code HTML

  1. Choisissez Edition > Copier le code HTML.

  2. Suivez les étapes proposées par l’assistant. Lorsque vous y êtes invité, indiquez un dossier de destination des images exportées. Ce dossier doit être celui dans lequel se trouve votre fichier HTML.

    Remarque :

    Si vous comptez coller le code HTML dans Dreamweaver, peu importe le dossier dans lequel vous exportez les images, pourvu qu’elles se trouvent sur le même site Dreamweaver que le fichier HTML dans lequel vous allez coller le code.

Copie de code HTML Fireworks à l’aide de la boîte de dialogue Exporter

  1. Choisissez Fichier > Exporter.

  2. Dans la boîte de dialogue Exporter, spécifiez un dossier de destination pour les images exportées. Ce dossier doit être celui dans lequel se trouve votre fichier HTML.

    Remarque :

    Si vous comptez coller le code HTML dans Dreamweaver, peu importe le dossier dans lequel vous exportez les images, pourvu qu’elles se trouvent sur le même site Dreamweaver que le fichier HTML dans lequel vous allez coller le code.

  3. Dans le menu contextuel Exporter, sélectionnez Documents HTML et Images.

  4. Dans le menu contextuel HTML, sélectionnez Copier dans le Presse-papiers.

  5. Si votre document contient des tranches, dans le menu contextuel Tranches, cliquez sur Exporter les tranches.

  6. Cliquez sur le bouton Options, sélectionnez votre éditeur HTML dans la boîte de dialogue Configuration HTML, puis cliquez sur OK.

  7. Cliquez sur Enregistrer.

Collage de code HTML copié depuis Fireworks dans un document HTML

  1. Dans votre éditeur HTML, ouvrez un document HTML existant ou créez-en un nouveau. Enregistrez le document dans le même dossier que celui des images exportées.

    Remarque :

    Si vous utilisez Dreamweaver, vous n’êtes pas tenu d’enregistrer le fichier HTML dans le même dossier que celui des images exportées. Dès lors que vous exportez des images de Fireworks vers un site Dreamweaver et enregistrez le fichier HTML dans un dossier se trouvant sur ce site, Dreamweaver résout les chemins vers les images associées.

  2. Affichez le code HTML, puis placez le point d’insertion entre les balises <BODY>.

    Remarque :

    Le code HTML copié à partir de Fireworks ne contient pas les balises d’ouverture et de fermeture <HTML> et <BODY>.

  3. Collez le code HTML.

    Si possible, lorsque vous effectuez une copie dans le Presse-papiers, exportez les images à leur emplacement sur le site web. Comme Fireworks utilise des adresses URL relatives aux documents, les liens URL seront rompus si le code HTML ou des images sont déplacés.

Copie de code depuis un fichier Fireworks exporté et collage dans un autre document HTML

  1. Dans l’éditeur HTML, ouvrez le fichier HTML Fireworks que vous avez exporté.

  2. Sélectionnez le code souhaité, puis copiez-le dans le Presse-papiers.

  3. Ouvrez un document HTML existant ou créez-en un nouveau.

  4. Collez le code dans le nouveau fichier HTML. Il n’est pas nécessaire de copier les balises <HTML> et <BODY>, qui doivent normalement déjà figurer dans le document HTML de destination.

    Si vous avez activé l’option Inclure les commentaires HTML dans la boîte de dialogue Configuration HTML de Fireworks, suivez les instructions fournies dans les commentaires pour copier/coller le code à l’emplacement approprié.

  5. Si votre document Fireworks contient des éléments interactifs, copiez le code JavaScript.

    Le code JavaScript est entouré des balises <SCRIPT> et situé dans la section <HEAD> du document. Copiez et collez l’intégralité de la section <SCRIPT>, sauf si le document de destination contient déjà une section <SCRIPT>. Dans ce cas, il vous suffit de copier le contenu de la section <SCRIPT> dans la section <SCRIPT> existante en veillant à ne pas écraser les données de cette dernière. Vérifiez également qu’aucune fonction JavaScript n’est dupliquée dans la section <SCRIPT> une fois que vous avez copié le code.

Mise à jour de code HTML exporté

La mise à jour vous permet de modifier un document HTML Fireworks déjà exporté, en particulier si vous souhaitez actualiser uniquement une partie d’un document.

Remarque :

La mise à jour du code HTML ne s’effectue pas de la même manière dans les documents Dreamweaver et les autres documents HTML. Pour plus d’informations, reportez-vous à la section Utilisation de Dreamweaver.

Lorsque vous effectuez une mise à jour, vous pouvez choisir de remplacer uniquement les images modifiées ou l’intégralité du code et des images. Si vous choisissez de remplacer uniquement les images modifiées, toutes les modifications apportées au fichier HTML en dehors de Fireworks seront conservées.

Remarque :

Si vous souhaitez apporter d’importantes modifications à la présentation du document, effectuez-les dans Fireworks, puis réexportez le fichier HTML.

  1. Sélectionnez la commande Fichier > Mettre à jour le code HTML.

  2. Sélectionnez le fichier à mettre à jour.

  3. Cliquez sur le bouton Ouvrir.

  4. Procédez de l’une des manières suivantes :

    • Si aucun code HTML généré par Fireworks n’est trouvé, cliquez sur OK pour insérer le nouveau code HTML à la fin du document.

    • Par contre, si un code HTML généré par Fireworks est trouvé, sélectionnez l’une des options suivantes, puis cliquez sur OK :

      Remplacer les images et leur code HTML

      Remplace le code HTML Fireworks précédent.

      Mettre à jour les images uniquement

      Ecrase uniquement les images.

  5. Lorsque la boîte de dialogue Sélectionnez le dossier Images s’affiche, sélectionnez un dossier, puis cliquez sur Ouvrir.

Exportation de calques CSS

Les calques CSS peuvent se chevaucher et être empilés les uns sur les autres. Sous Fireworks, les sorties en code HTML normal ne se chevauchent pas.

  1. Choisissez Fichier > Exporter.

  2. Entrez un nom de fichier, puis sélectionnez un dossier de destination.

  3. Dans le menu contextuel Exporter, sélectionnez CSS et Images.

    • Pour exporter l’état actif uniquement, sélectionnez Etat actif uniquement.

    • Pour exporter la page active uniquement, sélectionnez Page active uniquement.

    • Pour choisir le dossier devant recevoir les images, sélectionnez Placer les images dans des sous-dossiers.

  4. Pour définir les propriétés de la page HTML, cliquez sur Options.

  5. Pour définir une image d’arrière-plan et la faire apparaître en mosaïque, cliquez sur Parcourir :

    • Pour afficher l’image une seule fois, sélectionnez Pas de répétition.

    • Pour répéter, ou mettre en mosaïque, l’image à l’horizontale et la verticale, sélectionnez Répétition.

    • Sélectionnez Répéter-x pour former une mosaïque horizontale.

    • Pour former une mosaïque verticale, sélectionnez Répéter-y.

  6. Dans le navigateur, sélectionnez un alignement de page à gauche, au centre ou à droite.

  7. Cliquez sur le bouton OK, puis sur Enregistrer.

Exportation de code XHTML

Le langage XHTML est une combinaison du langage HTML, standard actuel pour la mise en forme et l’affichage de pages web, et du langage XML (eXtensible Markup Language). Le code XHTML garantit une compatibilité descendante, ce qui signifie qu’il peut être affiché dans la plupart des navigateurs web actuels et lu par tous les périphériques affichant du contenu XML, tels que les assistants numériques personnels, les téléphones portables et autres périphériques mobiles.

Fireworks peut également importer des fichiers XHTML (voir la section Création de fichiers PNG Fireworks à partir de fichiers HTML).

Pour plus d’informations sur le langage XHTML, consultez les spécifications XHTML du W3C (Web World Wide Web Consortium) sur le site www.w3.org.

  1. Choisissez Fichier > Configuration HTML, sélectionnez un style XHTML dans le menu contextuel Style HTML de l’onglet Général, puis cliquez sur OK.

  2. Exportez le document en utilisant l’une des méthodes d’exportation ou de copie de code HTML disponibles (voir la section Exportation de code HTML).

    Remarque :

    Fireworks utilise le codage UTF-8 lorsque vous exportez un document vers XHTML.

Exportation de fichiers avec ou sans codage UTF-8

Le procédé de codage de texte UTF-8 (Universal Character Set Transformation Format-8) permet aux navigateurs web d’afficher différents jeux de caractères nationaux (texte chinois ou anglais, par exemple) sur une même page HTML. Le codage UTF-8 est activé par défaut.

Fireworks peut également importer des documents utilisant le codage UTF-8 (voir la section Création de fichiers PNG Fireworks à partir de fichiers HTML).

Exportation de documents sans codage UTF-8

  1. Choisissez Fichier > Configuration HTML.

  2. Sous l’onglet Propre au document, désactivez la case Utiliser le codage UTF-8, puis cliquez sur OK.

  3. Exportez le document en utilisant l’une des méthodes d’exportation ou de copie de document HTML disponibles.

Définition des options d’exportation de code HTML

La boîte de dialogue Configuration HTML permet de définir le mode d’exportation du code HTML à partir de Fireworks. Les modifications effectuées dans l’onglet propre au document agissent uniquement sur le document actif. Les paramètres Général et Table sont des préférences globales qui affectent tous les nouveaux documents.

  1. Procédez de l’une des manières suivantes :

    • Choisissez Fichier > Configuration HTML.

    • Cliquez sur le bouton Options de la boîte de dialogue Exporter.

  2. Dans l’onglet Général, sélectionnez les options souhaitées.

    Style HTML

    Sélectionnez le style du code HTML exporté.

    Le code HTML Générique est compatible avec tous les éditeurs HTML. Cependant, si le document contient des comportements ou des contenus interactifs, sélectionnez un éditeur spécifique s’il est répertorié dans la liste.

    Pour exporter un document en appliquant le standard XHTML, sélectionnez le style XHTML approprié dans le menu contextuel.

    Extension

    Dans le menu contextuel, sélectionnez une extension de fichier ou entrez l’extension de votre choix.

    Inclure les commentaires HTML

    Sélectionnez cette option pour inclure des commentaires sur les endroits où copier et coller dans le code HTML. Elle est recommandée si le document contient des éléments interactifs tels que des boutons, des comportements ou des images survolées.

    Nom de fichier en minuscules

    Sélectionnez cette option pour vous assurer que les noms du fichier HTML et des fichiers d’image associés sont composés en minuscules lors de l’exportation.

    Remarque : cette option ne modifie pas la casse de l’extension du fichier HTML, si une extension en majuscules a été choisie dans le menu contextuel Extension.

    Utiliser une feuille de style CSS pour les menus contextuels

    Sélectionnez cette option pour utiliser une feuille de style CSS plutôt que du code JavaScript pour le menu contextuel. Vous pouvez indexer les menus à l’aide de Dreamweaver, ainsi que mettre à jour les liens dans le code.

    Ecrire les feuilles de style CSS dans un fichier externe

    Sélectionnez cette option pour que le code CSS soit écrit dans un fichier .css externe exporté dans le même emplacement que le fichier HTML. Le nom du fichier .css correspond au nom du fichier HTML (à l’exception de l’extension du fichier). Activez cette option pour exporter également un fichier nommé mm_css_menu.js dans le même emplacement que le fichier HTML.

    Remarque : cette option est disponible uniquement si vous avez sélectionné Utiliser une feuille de style CSS pour les menus contextuels.

    Créateur de fichiers (Mac OS)

    Sélectionnez une application associée dans le menu contextuel. Lorsque vous cliquez deux fois sur le fichier HTML exporté sur votre disque dur, il s’ouvre automatiquement dans l’application spécifiée.

  3. Sous l’onglet Table, sélectionnez les paramètres requis pour vos tables HTML. Pour plus d’informations, reportez-vous à la section Définition du mode d’exportation des tables HTML.

  4. Sous l’onglet Propre au document, sélectionnez l’une des options suivantes :

    Noms des fichiers de tranche

    Dans les menus contextuels correspondants, sélectionnez une formule permettant de nommer automatiquement les tranches. Vous pouvez utiliser les options par défaut ou sélectionner vos propres options.

    Remarque : si vous sélectionnez Aucune pour l’un des trois premiers menus, Fireworks exporte des fichiers de tranche qui s’écraseront mutuellement. Vous obtiendrez ainsi un seul graphique exporté et un tableau affichant ce graphique dans chaque cellule.

    Balise ALT par défaut

    Saisissez le texte qui doit apparaître à la place de toutes les images pendant leur téléchargement depuis le web et à la place de toute image ne pouvant pas être téléchargée. Dans certains navigateurs, ce texte peut également s’afficher sous forme d’info-bulle lorsque le pointeur survole l’image. Cette fonction constitue également une aide pour les utilisateurs du web malvoyants.

    Exporter plusieurs fichiers HTML de la barre de navigation (à utiliser sans jeu d’images)

    Sélectionnez cette option pour l’exportation d’une barre de navigation qui relie plusieurs pages entre elles. Fireworks exporte des pages supplémentaires pour chaque bouton de la barre de navigation.

    Inclure les zones sans tranches

    Sélectionnez cette option pour inclure les parties de la zone de travail qui ne sont pas recouvertes par des tranches.

    Codage UTF-8

    Cette option activée par défaut vous permet d’afficher des caractères provenant de plusieurs jeux de caractères dans le document exporté. Pour désactiver cette option, décochez la case.

  5. Pour enregistrer ces paramètres comme paramètres par défaut globaux, cliquez sur Paramètres par défaut.

Exportation de fichiers Adobe PDF

Lorsque vous voulez imprimer une création Fireworks ou l’envoyer en révision, exportez-la au format de fichier Adobe PDF. Les réviseurs peuvent ajouter des commentaires, répondre à d’autres commentaires dans Adobe Reader® ou Acrobat®. Pour plus d’informations sur la mise en place d’un processus de révision au format PDF, consultez l’aide Acrobat.

Les fichiers PDF exportés conservent toutes les pages et leurs liens hypertextes. Les réviseurs peuvent donc naviguer comme ils le feraient sur le web. Contrairement aux prototypes HTML, les documents Adobe PDF proposent cependant des paramètres de sécurité pour empêcher les réviseurs de modifier ou de copier vos créations.

  1. Choisissez la commande Fichier > Exporter.

  2. Dans le menu contextuel Exporter, choisissez Adobe PDF.

  3. Choisissez les pages à exporter et sélectionnez Afficher le PDF après exportation pour ouvrir automatiquement le PDF dans Adobe Reader ou Acrobat.

  4. Pour personnaliser le document PDF, cliquez sur Options, puis définissez les paramètres suivants :

    Compatibilité

    Détermine les applications Adobe PDF pouvant ouvrir le fichier exporté.

    Compression

    Détermine le type de compression des images utilisé pour réduire la taille de fichier. En général, les compressions de type JPEG et JPEG2000 sont préférables pour les images telles que des photographies comportant des transitions progressives d’une couleur à l’autre. La compression ZIP est idéale pour les illustrations qui comprennent des portions étendues de couleurs en aplat (pleines et unies).

    Qualité

    Pour les compressions de type JPEG et JPEG2000, propose des paramètres de qualité d’image. Si vous sélectionnez Qualité supérieure, vous obtenez un fichier volumineux dont la qualité d’image est bonne.

    Convertir en niveaux de gris

    Convertit toutes les images en niveaux de gris tout en réduisant la taille du fichier.

    Activer la sélection de texte

    Permet aux réviseurs de copier le texte à partir du fichier exporté. Désélectionnez cette option pour réduire la taille du fichier.

    Valeur de fond perdu

    Détermine la largeur en pixels de la bordure blanche qui délimite l’image sur chaque page. Une valeur égale à 20, par exemple, permet d’entourer chaque image d’une bordure de 20 pixels.

    Utiliser un mot de passe pour ouvrir le document

    Requiert un mot de passe pour ouvrir le fichier exporté.

    Utiliser un mot de passe pour restreindre les tâches

    Requiert un mot de passe pour effectuer les fonctions suivantes : impression, modification, copie et insertion de commentaires.

  5. Cliquez sur OK pour fermer la boîte de dialogue Options.

  6. Indiquez un nom de fichier et un emplacement, puis cliquez sur Enregistrer.

    Remarque :

    Si les pages de votre document Fireworks présentent des zones de travail transparentes, les objets auxquels des transparences ont été appliquées perdent ces caractéristiques lorsque vous exportez le document au format PDF. Pour éviter cela, définissez un arrière-plan non transparent pour la zone de travail avant l’exportation au format PDF.

Vidéo

Création d’épreuves client au format PDF ou HTML à l’aide de Fireworks (00:05:32)

Découvrez comment utiliser le menu Exporter de Fireworks pour préparer un document PDF ou HTML dans l’optique d’une approbation du client ou d’une révision par son équipe.

Par Tom Green

Lorsque vous consultez les fichiers PDF exportés dans Adobe Acrobat ou Adobe Reader, appliquez les paramètres suivants :

  1. Dans Adobe Acrobat ou Adobe Reader sélectionnez Edition > Préférences.

  2. Sélectionnez Affichage de page dans le volet gauche.

  3. Définissez Résolution personnalisée sur 72 pixels par pouce.

  4. Réglez la valeur de Zoom sur 100 %.

Exportation de fichiers FXG

Le format de fichier FXG est pris en charge par Flash Catalyst, Fireworks, Illustrator et Photoshop. Lorsque vous exportez un fichier contenant des images vectorielles et bitmap au format FXG, un dossier distinct portant le nom <nom_fichier.assets> est créé. Ce dossier contient les images bitmap associées au fichier.

L’importation échoue si ces fichiers associés sont supprimés, en tout ou en partie, du dossier.

Remarque :

Les éléments, filtres, modes de fusion, dégradés et masques qui ne sont pas associés à une balise de mappage sont exportés en tant que graphiques bitmap.

  1. Sélectionnez Fichier > Exporter et accédez à l’emplacement auquel enregistrer les fichiers.

  2. Attribuez un nom au fichier FXG.

  3. Dans la boîte de dialogue Exporter, sélectionnez FXG et images dans le menu Exporter.

  4. Cliquez sur Enregistrer.

Remarque :

Les objets qui s'étendent en dehors de la zone de travail de Fireworks s'affichent complètement lorsque le fichier FXG exporté est ouvert dans Flash Catalyst.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne