이 페이지에서는 After Effects의 [기본 그래픽] 패널 및 모션 그래픽 템플릿과 마스터 속성을 사용하여 작업하는 방법에 대해 알아봅니다.

참고:

  Typekit은 이제 Adobe Fonts로 이름이 변경되었으며 Creative Cloud 및 기타 구독에 포함됩니다. 자세히 알아보기

기본 그래픽 패널에서 모션 그래픽용 사용자 정의 컨트롤을 만들고 Creative Cloud Libraries를 통해 모션 그래픽 템플릿으로 공유하거나 로컬 파일로 공유할 수 있습니다. [기본 그래픽] 패널은 다양한 컨트롤을 추가하고 수정한 다음 공유 가능 모션 그래픽 템플릿으로 패키지할 수 있는 공간입니다. After Effects에 기본 그래픽 패널을 사용한 작업을 위한 새로운 작업 영역인 기본 그래픽이 제공됩니다. 창 > 작업 영역에서 이 작업 영역에 액세스할 수 있습니다.

After Effects의 [기본 그래픽] 패널은 주로 다음과 같은 네 가지 방법으로 사용할 수 있습니다.

  • After Effects 내에서 제어면으로 사용: [기본 그래픽] 패널을 컴포지션 제어면으로 사용합니다. 타임라인에서 [기본 그래픽] 패널로 매개 변수를 드래그하여 컴포지션에서 자주 변경하는 요소에 대한 단축키를 만듭니다.
  • 마스터 컨트롤로 작동하는 마스터 속성을 만들어 다른 컴포지션에 중첩된 컴포지션의 효과 및 레이어 속성을 수정할 수 있습니다.
  • 모션 그래픽 템플릿(.mogrt)을 내보내는 데 사용: After Effects 프로젝트를 Premiere Pro에서 바로 편집할 수 있는 모션 그래픽 템플릿으로 캡슐화합니다. 디자인을 유지하는 데 필요한 모든 소스 이미지, 비디오 및 사전 구성이 템플릿에 패키지됩니다. 사용자가 노출한 컨트롤만 Premiere Pro에서 사용자 정의가 가능하므로 디자인의 창의적 컨트롤을 유지할 수 있습니다.
  • 컨트롤을 그룹화하고, 글꼴 속성을 제어하고, CSV 및 TSV 스프레드시트 데이터 소스용 컨트롤을 모션 그래픽 템플릿에 추가할 수 있습니다. 그룹에 액세스하려면 [기본 그래픽] 패널의 [서식 추가] 메뉴를 사용합니다. [주석 추가] 명령은 이 메뉴에서 액세스할 수 있습니다.

After Effects에서 모션 그래픽 템플릿 만들기

After Effects에서 모션 그래픽 템플릿 만들기
이 비디오를 보고 After Effects에서 모션 그래픽 템플릿을 만드는 방법에 대해 자세히 알아보십시오.

기본 그래픽 패널을 사용한 작업

기본 그래픽 패널의 컴포지션

기본 그래픽 패널에서 마스터 드롭다운 메뉴를 사용하여 프로젝트의 컴포지션을 선택하고 모션 그래픽 템플릿 만들기를 시작합니다.

마스터 메뉴에서 컴포지션 보기
마스터 메뉴에서 컴포지션 보기

After Effects의 기본 그래픽 패널에서 컴포지션을 열려면 다음 중 하나를 수행합니다.

  • 현재 컴포지션을 열려면 컴포지션 > 기본 그래픽에서 열기를 선택합니다.
  • 특정 컴포지션을 열려면 프로젝트 패널에서 컴포지션을 마우스 오른쪽 버튼으로 클릭하고 기본 그래픽에서 열기를 선택합니다.
  • 프로젝트의 모든 컴포지션을 열려면 기본 그래픽 패널에서 마스터 메뉴를 클릭합니다.

마스터 컴포지션

마스터 컴포지션은 기본 그래픽 패널의 현재 컴포지션입니다. 마스터 컴포지션에서 지원되는 속성을 패널에 추가할 수 있습니다. 마스터 컴포지션 계층 구조에 있는 컴포지션의 속성을 추가할 수도 있습니다.

마스터 컴포지션 계층 구조에 없는 컴포지션의 속성은 관련 없는 속성으로 간주됩니다. 관련 없는 속성을 기본 그래픽 패널에 추가하면 경고 메시지가 표시됩니다. 속성은 패널에 추가되기는 하지만 빨간색으로 강조 표시되고 모션 그래픽 템플릿으로 내보낼 때 템플릿에 아무런 영향을 주지 않습니다. 

팁: 관련되지 않은 속성을 사용하려면 마스터 컴포지션 또는 계층 구조에 속성이 포함된 컴포지션을 중첩시켜야 합니다.

참고:

컴포지션을 모션 그래픽 템플릿으로 내보내면 관련 없는 속성은 작동하지 않습니다.

컨트롤 추가 및 수정

컨트롤 추가

변형, 마스크, 질감 옵션 같은 효과 또는 레이어 속성 그룹에서 지원되는 속성을 추가할 수도 있습니다.

지원되는 컨트롤 유형:

  • 확인란
  • 색상
  • 숫자 슬라이더 [변형] > [불투명도] 또는 [슬라이더 컨트롤] 표현식 컨트롤 효과와 같은 단일 값 숫자 속성
  • 소스 텍스트
  • [변형] > [기준점], [변형] > [위치]와 같은 2D 점 속성과 [지점 컨트롤] 표현식 컨트롤 효과
  • [변형] > [비율]과 같은 2D 비율 속성
  • [변형] > [회전] 및 [각도 컨트롤] 표현식 컨트롤 효과와 같은 각도 속성

지원되지 않는 속성을 추가할 경우 After Effects에서 'After Effects 오류: 모션 그래픽 템플릿에서 지원되지 않는 속성 유형입니다.'라는 경고 메시지가 표시됩니다.

컨트롤을 추가하려면 지원되는 하나 또는 여러 개의 속성을 타임라인에서 기본 그래픽 패널로 드래그합니다.

기본 그래픽 패널에 속성 추가 명령을 사용하여 타임라인 또는 효과 컨트롤 패널 중 하나에서 기본 그래픽 패널에 속성을 추가할 수도 있습니다. 다음 단계에 따라 속성을 추가하십시오.

  • 타임라인 패널에서 속성을 선택한 다음 애니메이션 > 기본 그래픽에 속성 추가를 선택합니다.
  • 타임라인 패널 또는 효과 컨트롤 패널에서 속성을 마우스 오른쪽 버튼으로 클릭한 다음 메뉴에서 기본 그래픽에 속성 추가를 선택합니다.

기본 그래픽 패널에 속성 추가 명령에 키보드 단축키를 할당할 수도 있습니다. 자세한 단계는 시각적 키보드 단축키 편집기를 참조하십시오.

기본 그래픽 패널에서 컨트롤 추가
기본 그래픽 패널에서 컨트롤 추가

지원되는 속성 보기

기본 그래픽 패널에서만 지원되는 속성을 보려면 패널에서 단독으로 지원되는 속성 버튼을 클릭합니다. 이 버튼은 지원되는 속성을 필터링하여 타임라인에 표시합니다.

단독으로 지원되는 속성 보기
단독으로 지원되는 속성 보기

컨트롤 수정

기본 그래픽 패널을 사용하여 다음과 같은 방법으로 컨트롤을 사용자 정의할 수 있습니다.

  • 컨트롤 이름 바꾸기: 컨트롤의 이름을 바꾸려면 다음 중 하나를 수행합니다.
    • 컨트롤의 이름 필드를 클릭하고 새 이름을 입력합니다.
    • 현재 이름을 드래그하여 강조 표시하고 새 이름을 입력합니다.
  • 소스 속성 표시: 컨트롤의 소스 속성을 타임라인에 표시하려면 컨트롤 이름을 마우스 오른쪽 버튼으로 클릭하고 문맥 메뉴에서 타임라인에 표시를 선택합니다. 표시 옵션을 선택하면 관련 컴포지션이 닫혀 있을 때에도 컴포지션이 열립니다.
  • 컨트롤 재배열: 컨트롤을 재배열하려면 패널에서 컨트롤을 위나 아래로 드래그합니다.

기본 그래픽 패널에 추가하는 컨트롤은 소스 속성에 연결됩니다. 컨트롤의 값을 변경하면 컴포지션의 속성 값도 변경됩니다. 예를 들어 패널에서 불투명도를 50%로 변경하면 컴포지션에서도 불투명도 값이 50%로 변경됩니다.

패널에서 숫자 컨트롤을 밀어서 값을 변경하면 컴포지션 값도 동시에 업데이트됩니다. 실시간 업데이트 기능을 사용하지 않도록 설정하려면 Option(Mac) 또는 Alt(Windows) 키를 누른 상태로 컨트롤을 밉니다.

컨트롤 그룹 만들기

탐색을 용이하게 만들고 번잡함을 줄이기 위해 [기본 그래픽] 패널의 컨트롤을 그룹화할 수 있습니다. 이 기능은 중첩된 컴포지션의 마스터 속성 또는 편집 가능한 컨트롤의 긴 목록을 패널에 추가하는 경우에 특히 유용합니다.

그룹을 만들려면 기본 그래픽 패널의 왼쪽 아래 모서리에서 서식 추가 패널을 클릭한 후 그룹 추가를 선택합니다.

그룹에 컨트롤을 추가하려면 컨트롤을 그룹 이름 위로 드래그합니다.

글꼴 컨트롤

[기본 그래픽] 패널에 텍스트 레이어를 추가하면 [모션 그래픽] 템플릿에서 해당 레이어의 글꼴 모음, 글꼴 스타일, 크기 및 포 스타일을 수정 및 제어할 수 있습니다. 글꼴 속성 컨트롤을 패널에 추가하려면 다음 단계를 수행하십시오.

  1. 텍스트 레이어의 소스 텍스트 속성을 기본 그래픽 패널에 추가합니다.

  2. 컨트롤 행 오른쪽에 있는 속성 편집 옵션을 클릭합니다.

     

  3. 다음 옵션 중에서 제어할 글꼴 속성을 선택합니다.

    • 사용자 정의 글꼴 선택 활성화 - 글꼴 모음 및 글꼴 스타일 컨트롤을 추가합니다.
    • 글꼴 크기 조정 활성화 - 글꼴 크기 컨트롤을 추가합니다.
    • 포 스타일 활성화 - 포 볼드체, 포 이탤릭, 모두 대문자, 작은 대문자 컨트롤을 추가합니다.

    [확인]을 클릭합니다.

참고:

글꼴 컨트롤은 중첩된 컴포지션의 마스터 속성으로 지원되지 않습니다.

기본 그래픽 패널에서 주석 추가

주석을 추가하려면 기본 그래픽 패널 아래쪽의 주석 추가 버튼을 클릭합니다. 여러 개의 주석을 추가하고 이름을 바꾸고 재배열할 수 있습니다. 또한 주석 추가를 실행 취소 및 다시 실행하고, 주석을 재배열하고, 필요한 경우 제거할 수 있습니다.

  • 이름을 바꾸려면 주석의 이름 필드를 클릭하고 새 이름을 입력합니다. 
  • 재배열하려면 주석을 패널의 위나 아래로 드래그합니다.

주석을 삭제하려면 해당 주석을 선택하고 백스페이스 키나 Delete 키를 누릅니다.

컨트롤 수정
컨트롤 수정

참고:

프로젝트 패널에서 컴포지션을 복제하면(cmd+D(Mac) 또는 Ctrl+D(Windows)) 해당 컴포지션에 대한 속성 및 주석이 [기본 그래픽] 패널에 복제됩니다.

모션 그래픽 템플릿으로 내보내기

템플릿 이름 지정

모션 그래픽 템플릿의 이름을 지정하거나 이름을 바꾸려면 템플릿의 이름 필드를 클릭하고 새 이름을 입력합니다.

템플릿의 포스터 프레임 설정

템플릿의 포스터 프레임을 설정할 수 있습니다. 포스터 프레임은 Creative Cloud Libraries 및 Premiere Pro의 기본 그래픽 패널에서 템플릿의 축소판 이미지로 사용됩니다.

포스터 프레임을 설정하려면 다음 단계를 따르십시오.

  1. 마스터 컴포지션에서 선택하려는 프레임에 현재 시간 표시기를 배치합니다.

  2. [기본 그래픽] 패널에서 포스터 시간 설정 버튼을 클릭합니다.

템플릿 내보내기

컴포지션을 모션 그래픽 템플릿으로 내보내려면 다음 단계를 따르십시오.

  1. 기본 그래픽 패널 아래쪽의 모션 그래픽 템플릿 내보내기 버튼을 클릭합니다. 마스터 컴포지션 계층 구조에 있는 컴포지션이 템플릿에 포함됩니다.

  2. 모션 그래픽 템플릿으로 내보내기 대화 상자에서 대상 메뉴를 클릭합니다. 사용 가능한 대상은 다음과 같습니다.

    • Creative Cloud Libraries: Creative Cloud Libraries에 템플릿을 추가합니다.
    • 기본 그래픽: 기본적으로 로컬 폴더에 템플릿을 추가합니다. 기본 그래픽 폴더에 저장된 템플릿은 Premiere Pro의 기본 그래픽 패널에서 직접 사용할 수 있습니다.
    • 로컬 드라이브: 로컬 디렉토리에 템플릿을 저장합니다. 사용자가 로컬 디렉토리에 템플릿을 저장하더라도 Premiere Pro의 기본 그래픽 패널에서 자동으로 사용할 수는 없습니다.
  3. 모션 그래픽 템플릿 내보내기
    모션 그래픽 템플릿 내보내기

    [호환성] 아래의 확인란을 선택합니다.

    • 모션 그래픽 템플릿에 Adobe Fonts에서 제공하지 않는 글꼴을 사용할 경우 경고 메시지 표시: 컴포지션에 사용된 글꼴이 Adobe Fonts에서 제공하지 않는 글꼴인 경우 After Effects에서 경고 메시지를 표시하도록 하려면 이 옵션을 활성화합니다.
    • After Effects를 설치해야만 이 모션 그래픽 템플릿을 사용자 정의할 수 있는 경우 경고 메시지 표시: After Effects와 독립된 기능(예: 서드 파티 플러그인)을 내보내려는 경우에만 이 옵션을 활성화합니다.

    Creative Cloud Libraries에 에셋을 추가하는 방법에 대한 자세한 내용은 After Effects의 Creative Cloud Libraries를 참조하십시오.

    참고:

    이러한 옵션을 선택해도 경고만 표시되며 모션 그래픽 템플릿의 내용은 수정되지 않습니다. 요구 사항을 충족하도록 프로젝트를 편집하려면 내보내기를 취소하고 변경을 수행한 다음 모션 그래픽 템플릿을 다시 내보내십시오.

  4. 대상 메뉴에서 내보내기 대상을 선택하고 확인을 클릭합니다.

참고:

사용자가 컴퓨터에 After Effects를 설치하지 않아도 사용자 정의할 수 있는 모션 그래픽 템플릿(.mogrt 파일)을 제작할 수 있습니다. 템플릿이 다음 요구 사항을 충족하는지 검토하여 사용자가 After Effects를 설치하지 않고도 .mogrt를 사용할 수 있는지 확인하십시오. 

  • 클래식 3D 컴포지션 렌더러만 지원되며 CINEMA 4D 및 광선 추적형 3D 렌더러는 지원되지 않습니다.
  • [카메라 흔들림으로 인한 흐림 제거], [합성 조리개 세밀한 색상], [Maxon CINEWARE], [퍼핏] 및 [비틀기 안정기]를 제외하고 After Effects에 포함된 모든 효과가 지원됩니다.
  • After Effects 컴포지션에 포함된 Premiere Pro 시퀀스 또는 Character Animator CC 장면과 같은 Dynamic Link 푸티지는 지원되지 않습니다.
  • FLV 포맷 푸티지와 서드 파티 플러그인은 지원되지 않습니다.

모션 그래픽 템플릿을 프로젝트로 열기

After Effects 모션 그래픽 템플릿(.mogrt 파일)을 편집하려는 경우 After Effects에서 프로젝트 파일로 열 수 있습니다. 템플릿을 편집한 후 .mogrt 파일로 다시 내보냅니다.

모션 그래픽 템플릿을 프로젝트로 열려면 다음 단계를 따르십시오.

  1. 파일 > 프로젝트 열기를 선택합니다.

  2. 프로젝트 열기 대화 상자에서 .mogrt 파일을 선택한 다음 열기를 클릭합니다.
  3. .mogrt를 프로젝트로 열면 프로젝트 파일과 에셋이 추출됩니다. "<filename>.mogrt" 추출 대화 상자에서 .mogrt의 컨텐츠를 추출할 위치를 선택한 다음 추출을 클릭합니다.

다음 단계에 따라 Premiere Pro 12.1에서 시퀀스에 사용된 모션 그래픽 템플릿을 수정할 수도 있습니다.

  1. After Effects에서 .mogrt 파일을 프로젝트로 엽니다. 하나 이상의 컴포지션을 수정하거나 기본 그래픽 패널에서 컨트롤을 추가 또는 변경합니다.
  2. 편집을 마친 후 기본 그래픽 패널에서 모션 그래픽 템플릿 내보내기 버튼을 클릭합니다. 원래 .mogrt 파일을 바꾸거나 업데이트된 파일의 새 위치 또는 이름을 선택할 수 있습니다.
  3. Premiere Pro에서 Option(MacOS) 또는 Alt(Windows)를 누른 채 새 .mogrt 클립 또는 업데이트된 .mogrt 클립을 기본 그래픽 패널의 찾아보기 탭에서 시퀀스의 기존 .mogrt 클립으로 드래그합니다. Premiere Pro에서 기본 그래픽 패널의 편집 탭이 새 컨트롤로 업데이트됩니다.
  1. After Effects에서 .mogrt 파일을 프로젝트로 엽니다. 컴포지션을 수정하거나 기본 그래픽 패널에서 컨트롤을 추가 또는 수정합니다.

  2. 편집을 마친 후 기본 그래픽 패널에서 모션 그래픽 템플릿 내보내기 버튼을 클릭합니다. 원래 .mogrt 파일을 바꾸거나 업데이트된 파일의 새 위치 또는 이름을 선택할 수 있습니다.

  3. Premiere Pro에 있는 기본 그래픽 패널의 찾아보기 탭에서 Option 키(Mac OS) 또는 Alt 키(Windows)를 누른 채로 새 .mogrt 또는 업데이트된 .mogrt를 시퀀스의 기존 .mogrt 클립으로 드래그합니다. Premiere Pro에서 기본 그래픽 패널의 편집 탭이 새 컨트롤로 업데이트됩니다.

데이터 중심의 모션 그래픽 템플릿을 사용한 작업

데이터 중심의 모션 그래픽 템플릿을 사용하면 일일이 수동 작업을 하거나 모션 그래픽에 대한 깊은 지식 없이도 막대 차트, 선 그래프 등을 맞춤화할 수 있습니다.

이 기능을 사용하면 CSV(Comma-Separated Value) 또는 TSV(Tab-Separated Value) 스프레드시트 데이터용 컨트롤을 [기본 그래픽] 패널에 추가할 수 있습니다. 이러한 모션 그래픽 템플릿을 데이터 컨트롤과 함께 Premiere Pro로 내보내면 Premiere Pro에서 이를 수정하거나 바꿀 수 있습니다.

또한 기본 그래픽 패널의 데이터 컨트롤을 템플릿으로 내보내지 않고 CSV 또는 TSV 데이터 레이어에 대한 데이터 브라우저 또는 편집기로 사용할 수도 있습니다. 스프레드시트 데이터가 있는 컴포지션을 패널에 추가하면 패널에 편집 가능한 모든 관련 데이터가 표시됩니다. 중첩된 컴포지션을 사용하여 작업하는 경우에는 해당 컴포지션의 마스터 속성으로 데이터 컨트롤에 액세스할 수 없습니다.

데이터 컨트롤을 [기본 그래픽] 패널에 추가하려면 다음 단계를 수행하십시오.

  1. CSV 또는 TSV 파일을 프로젝트로 가져와 컴포지션에 추가합니다.

  2. 타임라인 패널에서 데이터 레이어에 대해 레이어 속성을 돌려서 엽니다.

  3. 레이어의 데이터 속성 그룹을 선택하여 기본 그래픽 패널로 드래그합니다.

[기본 그래픽] 패널에서는 스프레드시트 데이터의 다음 속성을 수정할 수 있습니다.

  • 스프레드시트 속성: 데이터 그룹 오른쪽의 [속성 편집]을 클릭하여 다음을 수정할 수 있습니다.
    • 데이터 속성 유형: 각 열에 있는 값의 데이터 유형을 선택합니다. 이 옵션은 Premiere Pro에서 스프레드시트 값이 나타나는 방식을 변경하려는 경우에 사용합니다. After Effects 작성자는 After Effects에서 각 열의 유형을 설정합니다. Premiere Pro에서는 이러한 유형을 텍스트 문자열로 인식하며 숫자일 경우 핫 텍스트 슬라이더로, 색상일 경우 16진수 값(예: #EE0473)으로 변환합니다.
    • 최소 줄: Premiere Pro에서는 모션 그래픽 템플릿에 사용되는 행 수를 수정할 수 있습니다. 허용되는 최소 줄 수를 설정합니다.
  • 행: Premiere Pro에서는 모션 그래픽 템플릿에 사용되는 행 수를 수정할 수 있습니다. 허용되는 최대 행 수를 설정합니다.
  • 데이터 속성:
    • 열 이름: 모션 그래픽 템플릿에 표시되는 열 이름을 수정합니다.
    • 데이터 값: 스프레드시트 셀 값을 수정합니다. 편집할 행을 선택하려면 데이터 값 그룹 위쪽에서 [행] 메뉴를 변경합니다.

참고:

데이터 레이어의 데이터 속성 그룹을 패널에 추가하면 레이어의 데이터 속성을 소스 데이터 파일에 연결하는 표현식이 제거되고 정적 값으로 변경됩니다. After Effects 외부에서 소스 데이터 파일을 수정하는 경우 정적 데이터 값이 자동으로 업데이트됩니다.

Premiere Pro에서 이러한 템플릿을 사용하는 자세한 방법을 데이터 중심의 모션 그래픽 템플릿을 사용한 작업을 참조하십시오.

참고:

독일어 버전(소수점 대신 쉼표를 사용하는 모든 언어에 영향이 발생함)의 Excel 등에서 .tsv 파일로 작업하는 경우 .tsv 파일이 .txt 파일로 저장됩니다. Premiere Pro에서 모션 그래픽 템플릿에 파일 확장자를 연결하려면 먼저 파일 확장자를 .tsv로 직접 변경해야 합니다.

또는 Open Office 또는 Google Sheets 같은 다른 스프레드시트 도구를 사용할 수도 있습니다.

마스터 속성 기본 사항

마스터 컨트롤로 작동하는 마스터 속성을 만들어 다른 컴포지션에 중첩된 컴포지션의 레이어 및 효과 속성에 액세스할 수 있습니다. 이렇게 하면 해당 속성을 보기 위해 별도의 사전 컴포지션을 열 필요가 없으므로 중첩된 여러 컴포지션에서 복잡한 애니메이션을 만들 때 시간을 절약할 수 있습니다. 마스터 속성으로 컴포지션의 원래 값 및 키프레임을 재정의할 수 있으므로 동일한 컴포지션에 각기 다른 값을 지정하여 여러 인스턴스로 재사용할 수 있습니다. 소스 컴포지션은 그래도 유지되며 편집한 내용은 컴포지션 편집 후 렌더링할 수 있는 인스턴스를 만드는 데만 사용됩니다. 마스터 속성을 설명하는 데 사용되는 용어 목록은 용어 설명을 참조하십시오.

마스터 속성을 만들려면 기본 그래픽 패널에서 중첩된 컴포지션의 속성을 추가하거나 속성을 추가한 후 컴포지션을 중첩합니다(레이어 > 사전 구성). [기본 그래픽] 패널에 지원되는 속성 유형에 대한 자세한 내용은 지원되는 컨트롤 유형을 참조하십시오. 컴포지션을 중첩하면 타임라인 패널에 사전 컴포지션 레이어의 마스터 속성 그룹이 표시됩니다.

마스터 속성을 만드는 주요 작업 과정은 모션 그래픽 템플릿에 대한 컨트롤을 만드는 방법과 유사합니다. 차이점은 속성을 사용하는 방법에 있습니다. 즉, 마스터 속성을 After Effects에서는 사전 컴포지션에 사용하고 Premiere Pro에서는 모션 그래픽 템플릿에 사용한다는 점이 다릅니다.

용어 설명

컴포지션 및 마스터 속성을 사용한 작업을 수행할 때 일반적으로 사용되는 용어에 대해 알아보려면 용어 설명(기존 용어 및 새 용어)을 참조하십시오.

중첩 및 사전 구성

중첩 및 사전 구성
중첩 및 사전 구성

중첩: 한 컴포지션을 다른 컴포지션 내에 배치하는 것입니다.

사전 구성: 프로젝트의 다른 컴포지션 내에 중첩된 컴포지션입니다.

상위 컴포지션 및 하위 컴포지션

상위 컴포지션 및 하위 컴포지션 계층 구조
상위 컴포지션 및 하위 컴포지션 계층 구조

예를 들어 컴포지션 A라는 컴포지션을 컴포지션 B라는 다른 컴포지션 내에 배치하면 컴포지션 A는 상위 컴포지션이 되고 컴포지션 A에 포함된 컴포지션 B는 하위 컴포지션이 됩니다.

마스터 컴포지션 및 마스터 속성

마스터 속성 및 마스터 컴포지션
마스터 속성 및 마스터 컴포지션

[기본 그래픽] 패널에서 마스터로 설정한 컴포지션이 마스터 컴포지션입니다. 마스터 컴포지션의 경우 [타임라인] 패널의 레이어 또는 효과 속성을 [기본 그래픽] 패널에 추가하면 해당 속성을 마스터 속성이라고 합니다.

소스 속성

소스 속성
소스 속성

마스터 속성이 참조하는 레이어 또는 효과 속성입니다.

연결된 속성

연결된 속성
연결된 속성

소스 속성이 수정되지 않은 경우 사전 구성의 마스터 속성입니다.

연결 해제된 속성

연결 해제된 속성
연결 해제된 속성

소스 속성이 수정된 경우 사전 구성의 마스터 속성입니다.

재정의

사전 컴포지션의 마스터 속성 값, 키프레임 또는 표현식을 변경하는 것입니다.

마스터 속성을 사용한 작업

연결된 속성 - 마스터 컴포지션을 중첩하면 해당 사전 컴포지션의 마스터 속성이 소스 속성에 연결됩니다. 예를 들어 컴포지션 B가 컴포지션 A에 중첩된 경우 컴포지션 B의 효과 및 레이어 속성이 소스 속성입니다. 컴포지션 B의 속성을 [기본 그래픽] 패널에 추가하면 해당 속성이 마스터 속성입니다. 소스 속성을 수정하면 사전 컴포지션의 마스터 속성도 변경됩니다.

연결 해제된 속성 - 사전 컴포지션의 마스터 속성을 수정하면 속성이 연결 해제됩니다. 연결이 해제될 때 마스터 컴포지션의 인스턴스가 만들어집니다. 마스터 속성과 소스 속성 둘 다 개별적으로 수정할 수 있습니다.

마스터 속성을 수정하면 소스 속성의 값 또는 키프레임이 재정의됩니다. 사전 컴포지션은 마스터 컴포지션의 고유한 인스턴스이며 이 인스턴스만 수정된 값 또는 키프레임을 사용하여 렌더링됩니다.

당기기 및 밀어내기 버튼

마스터 속성을 수정하면 타임라인 패널의 [당기기] 및 [밀어내기] 버튼이 활성화되고 마스터 속성의 이름이 볼드체로 바뀝니다. 이는 속성이 연결 해제되었음을 나타냅니다.

[당기기] 및 [밀어내기] 버튼은 마스터 속성을 소스 속성에 다시 연결합니다. 각 마스터 속성마다, 그리고 전체 마스터 속성 그룹에 대해 [당기기] 및 [밀어내기] 버튼이 있습니다.

  • 당기기는 마스터 속성의 수정된 값, 키프레임 및 표현식을 삭제합니다.
  • 밀어내기는 마스터 속성의 수정된 값, 키프레임 및 표현식을 소스 속성에 적용합니다.

[당기기] 또는 [밀어내기] 버튼을 클릭하면 마스터 속성이 다시 해당 소스 속성에 연결되고 [당기기] 및 [밀어내기] 버튼이 비활성화됩니다.

당기기 및 밀어내기 버튼
당기기 및 밀어내기 버튼

수정된 마스터 속성을 다시 소스 속성에 밀어넣으면 동일한 마스터 속성이 연결된 경우 동일한 마스터 속성의 모든 인스턴스가 업데이트됩니다. 예를 들어 제작진 자막의 마스터 컴포지션을 만들어 여러 번 중첩하고 사전 컴포지션 중 하나에서만 색상 마스터 속성을 수정합니다. 새 색상 값을 다시 소스 값에 밀어내면 마스터 컴포지션의 모든 인스턴스가 새 색상 값을 사용하여 렌더링됩니다.

마스터 속성 다시 연결

  • 사전 컴포지션의 여러 마스터 속성을 해당 소스 속성에 다시 연결하려면

특정 마스터 속성을 선택하고 마스터 속성 그룹에서 당기기 또는 밀어내기 버튼을 클릭합니다.

여러 마스터 속성 다시 연결
여러 마스터 속성 다시 연결
  • 사전 컴포지션의 모든 마스터 속성을 해당 소스 속성에 다시 연결하려면

[타임라인] 패널에서 모든 마스터 속성을 선택 해제하고 마스터 속성 그룹에서 [당기기] 또는 [밀어내기] 버튼을 클릭합니다.

모든 마스터 속성 다시 연결
모든 마스터 속성 다시 연결

소스 텍스트 마스터 속성 수정

상위 컴포지션의 컨텍스트에서는 유형 툴을 사용하여 [컴포지션] 패널의 [소스 텍스트] 마스터 속성을 수정할 수 없습니다.

[소스 텍스트] 마스터 속성의 텍스트 문자열을 수정하려면 다음 중 하나를 수행하십시오.

  • [소스 텍스트] 마스터 속성을 마우스 오른쪽 버튼으로 클릭하고 값 편집을 선택합니다. 대화 상자에서 텍스트 문자열을 편집한 다음 확인을 클릭합니다.
  • [소스 텍스트] 마스터 속성에 표현식을 적용합니다. 새 문자열이 큰따옴표로 묶였는지 확인합니다. 예: "She sells seashells by the sea shore."

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책