렌더링 및 내보내기 개요

렌더링이란?

렌더링은 컴포지션에서 동영상 프레임을 만드는 것입니다. 프레임 렌더링은 해당 이미지의 모델을 구성하는 컴포지션에 있는 모든 레이어, 설정 및 기타 정보에서 합성된 2D 이미지를 만드는 것입니다. 동영상 렌더링은 동영상을 구성하는 각 프레임을 프레임별로 렌더링하는 것입니다. 각 프레임을 렌더링하는 방법에 대한 자세한 내용은 렌더링 순서 및 변환 축소를 참조하십시오.

흔히 렌더링이라는 용어가 최종 출력에만 적용된다고 생각하기 쉽습니다. 하지만 [푸티지], [레이어] 및 [컴포지션] 패널에 대한 미리 보기를 만드는 프로세스도 일종의 렌더링입니다. 실제로 미리 보기를 동영상으로 저장하여 최종 출력으로 사용할 수 있습니다. 비디오 및 오디오 미리 보기를 참조하십시오.

최종 출력용으로 렌더링된 컴포지션은 렌더링된 프레임을 하나 이상의 출력 파일로 인코딩하는 하나 이상의 출력 모듈을 통해 처리됩니다. 렌더링된 프레임을 출력용 파일로 인코딩하는 이 프로세스는 내보내기의 일종입니다.

참고:

  • 프로젝트 설정에서 프로젝트에서 시간을 표시하는 방법, 프로젝트에서 색상 데이터를 다루는 방법, 오디오에 사용할 샘플링 속도를 결정하는 프로젝트 설정에 대해 더 자세히 알아보십시오.
  • 컴포지션 설정에서 렌더링된 출력의 해상도, 프레임 크기 및 픽셀 종횡비와 같은 컴포지션 설정을 지정하는 방법을 알아보십시오.

컴포지션을 완료한 후에는 동영상 파일을 출력할 수 있습니다. 동영상 파일을 출력할 수 있는 두 가지 방법이 있습니다. 필요에 따라 그 중에서 한 가지를 선택하면 됩니다.

다음과 같은 이유로 동영상 파일이 필요할 수 있습니다.

  • Premiere Pro 시퀀스에 넣거나 다른 비디오 편집, 합성 또는 3D 그래픽 애플리케이션에 사용할 고화질 동영상(알파 채널 포함 또는 제외)이나 이미지 시퀀스가 필요합니다.

    고화질 동영상 파일을 만들려면 렌더링 대기열로 렌더링하십시오. 렌더링 대기열 패널로 렌더링 및 내보내기를 참조하십시오.

  • 웹에서 재생하거나 DVD 또는 블루레이 디스크에 사용할 압축된 동영상이 필요합니다.

    웹, DVD 또는 블루레이 디스크용의 압축된 고화질 동영상 파일을 만들려면 Adobe Media Encoder를 사용하여 파일을 인코딩합니다. Adobe Media Encoder를 참조하십시오.

참고:

일부 내보내기 종류는 렌더링을 포함하지 않으며 최종 출력이 아닌 워크플로의 중간 단계에 사용됩니다. 예를 들어 [파일] > [내보내기] > [Adobe Premiere Pro 프로젝트]를 선택하여 프로젝트를 Adobe Premiere Pro 프로젝트로 내보낼 수 있습니다. 프로젝트 정보는 렌더링되지 않고 저장됩니다. 일반적으로 Dynamic Link를 통해 전송되는 데이터는 렌더링되지 않습니다.

동영상을 모든 렌더링된 프레임을 포함하는 단일 출력 파일로 만들거나, 필름 레코더용 출력을 만들 때처럼 스틸 이미지 시퀀스로 만들 수 있습니다.

출력을 생성하려면 After Effects 렌더링 대기열을 사용하여 컴포지션을 렌더링하거나 렌더링 대기열 패널에서 선택한 렌더링 설정으로 Adobe Media Encoder 대기열에 컴포지션을 추가합니다.

렌더링 대기열의 경우, After Effects에서는 Adobe Media Encoder의 내장 버전을 사용하여 [렌더링 대기열] 패널을 통해 대부분의 동영상 포맷을 인코딩합니다. [렌더링 대기열] 패널을 사용하여 렌더링 및 내보내기 작업을 관리하면 Adobe Media Encoder의 내장 버전이 자동으로 호출됩니다. Adobe Media Encoder는 일부 인코딩 및 출력 설정을 지정하는 데 사용되는 내보내기 설정 대화 상자의 형태로만 나타납니다. 동영상의 인코딩 및 압축 옵션을 참조하십시오.

참고:

After Effects 출력 모듈 내의 내보내기 설정을 관리하는 데 사용되는 Adobe Media Encoder의 내장 버전은 정식 독립 실행형 Adobe Media Encoder 애플리케이션의 모든 기능을 제공하지는 않습니다.

From an expert: Using the Render Queue to export files

From an expert: Using the Render Queue to export files
Ian Robinson

렌더링 대기열 패널로 렌더링 및 내보내기

After Effects에서 동영상을 렌더링하고 내보내는 기본 방법은 [렌더링 대기열] 패널을 통하는 것입니다. 

컴포지션을 [렌더링 대기열] 패널 내에 배치하면 렌더링 항목이 됩니다. 많은 렌더링 항목을 렌더링 대기열에 추가할 수 있으며 After Effects에서 여러 항목을 자동으로 일괄 렌더링할 수 있습니다. [렌더링 대기열] 패널 오른쪽 위의 [렌더링] 버튼을 클릭하면 [대기 중] 상태의 모든 항목이 [렌더링 대기열] 패널에 나열되는 순서대로 렌더링되고 출력됩니다.

참고:

동일한 렌더링 설정을 사용하여 여러 포맷으로 내보내기 위해 동영상을 여러 번 렌더링하지 않아도 됩니다. [렌더링 대기열] 패널에서 출력 모듈을 렌더링 항목에 추가하여 동일한 렌더링된 동영상의 여러 버전을 내보낼 수 있습니다.

여러 렌더링 항목을 사용한 작업을 수행할 때 [렌더링 대기열] 패널의 [주석] 열에 주석을 추가하는 것이 유용한 경우가 많습니다. [주석] 열이 보이지 않으면 열 머리글을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태로 클릭(Mac OS)하고 [열] > [주석]을 선택합니다.

렌더링 항목 관리

[렌더링 대기열] 패널에서 각 렌더링 항목 고유의 렌더링 설정과 출력 모듈 설정을 사용하여 한 번에 여러 렌더링 항목을 관리할 수 있습니다.

렌더링 설정은 다음과 같은 특성을 결정합니다.

  • 출력 프레임 속도
  • 지속 시간
  • 해상도
  • 레이어 품질

출력 모듈 설정은 렌더링 설정 이후에 적용되며 다음과 같은 렌더링 후 특성을 결정합니다.

  • 출력 포맷
  • 압축 옵션
  • 자르기
  • 출력 파일에 프로젝트 링크 포함 여부

자주 사용하는 렌더링 설정과 출력 모듈 설정이 포함된 템플릿을 만들 수 있습니다.

[렌더링 대기열] 패널을 사용하여 같은 컴포지션을 다른 포맷으로 렌더링하거나 다른 설정을 사용하여 렌더링할 수 있는데, 이 모든 작업은 [렌더링] 버튼을 한 번 클릭하여 수행됩니다.

  • Cineon 시퀀스와 같은 스틸 이미지 시퀀스로 출력한 다음 영사를 위해 필름에 전송할 수 있습니다.

  • 무손실 압축(또는 압축 안 함)을 사용하여 QuickTime 컨테이너로 출력한 다음 비디오 편집을 위해 NLE(비선형 편집) 시스템에 전송할 수 있습니다.

레이어 및 기타 항목을 사용한 작업에 사용하는 것과 동일한 여러 가지 키보드 단축키를 사용하여 렌더링 항목을 선택, 복제 및 재배열할 수 있습니다. 자세한 내용은 일반(키보드 단축키)을 참조하십시오.

참고:

After Effects에서 렌더링된 출력을 필름이나 비디오에 전송하려면 적절한 필름 또는 비디오 전송 하드웨어가 있거나 전송 서비스를 제공할 수 있는 서비스 업체를 이용할 수 있어야 합니다.

렌더링 대기열을 사용하여 동영상 렌더링 및 내보내기

  1. [프로젝트] 패널에서 동영상을 만들 컴포지션을 선택하고 다음 중 하나를 수행하여 컴포지션을 렌더링 대기열에 추가합니다.
    • [컴포지션] > [렌더링 대기열에 추가]를 선택합니다.

    • 컴포지션을 [렌더링 대기열] 패널로 드래그합니다.

    참고:

    푸티지 항목으로 컴포지션을 만들고 해당 컴포지션을 렌더링 대기열에 즉시 추가하려면 [프로젝트] 패널에서 [렌더링 대기열] 패널로 푸티지 항목을 드래그합니다. 이 방법을 사용하면 한 포맷에서 다른 포맷으로 푸티지 항목을 간편하게 변환할 수 있습니다.

  2. [렌더링 대기열] 패널에서 [출력 위치] 머리글 옆의 삼각형을 클릭하여 이름 지정 규칙을 기반으로 출력 파일 이름을 선택하고 위치를 선택하거나, [출력 위치] 머리글 옆의 텍스트를 클릭하여 아무 이름이나 입력합니다. 렌더링된 출력의 파일 이름 및 위치 지정을 참조하십시오.
  3. [렌더링 설정] 머리글 오른쪽의 삼각형을 클릭하여 렌더링 설정 템플릿을 선택하거나, [렌더링 설정] 머리글 오른쪽의 밑줄이 있는 텍스트를 클릭하여 설정을 사용자 정의합니다. 자세한 내용은 렌더링 설정을 참조하십시오.
  4. [로그] 메뉴에서 로그 유형을 선택합니다.

    로그 파일이 기록되었으면 [렌더링 설정] 머리글과 [로그] 메뉴 아래에 해당 로그 파일의 경로가 나타납니다.

  5. [출력 모듈] 머리글 오른쪽의 삼각형을 클릭하여 출력 모듈 설정 템플릿을 선택하거나, [출력 모듈] 머리글 오른쪽의 밑줄이 있는 텍스트를 클릭하여 설정을 사용자 정의합니다. 출력 모듈 설정을 사용하여 출력 동영상의 파일 포맷을 지정합니다. 경우에 따라 포맷을 선택한 후 포맷별 설정을 선택할 수 있는 포맷별 대화 상자가 열릴 수도 있습니다. 출력 모듈 및 출력 모듈 설정동영상의 인코딩 및 압축 옵션을 참조하십시오.

    출력 이름과 위치가 설정되고 렌더링 설정과 출력 모듈이 선택되었으면 [렌더링] 열의 항목이 자동으로 선택(확인 표시로 알 수 있음)되고 상태가 [대기 중]으로 바뀝니다. [대기 중] 상태는 렌더링 항목이 렌더링 대기열에 있음을 의미합니다.

    참고:

    렌더링을 시작하기 전에 Caps Lock 키를 눌러 [컴포지션] 패널에 렌더링된 프레임이 표시되지 않도록 합니다. 그러면 [컴포지션] 패널을 업데이트하지 않게 되어 After Effects에서 프레임이 많은 단순 렌더링 항목을 처리하는 데 더 적은 시간이 소요됩니다.

  6. [렌더링 대기열] 패널 오른쪽 위의 [렌더링] 버튼을 클릭합니다.

컴포지션을 동영상으로 렌더링할 경우 해당 컴포지션의 프레임 크기, 품질, 복잡도 및 압축 방법에 따라 몇 초가 걸릴 수도 있고, 여러 시간이 걸릴 수도 있습니다. After Effects에서 항목을 렌더링할 때는 프로그램 작업을 할 수 없습니다. 렌더링이 완료되면 경고음이 울립니다.

렌더링 대기열을 사용하여 파일을 내보내는 방법에 대해서는 이 튜토리얼을 참조하십시오.

렌더링이 완료된 렌더링 항목은 [렌더링 대기열] 패널에서 해당 항목을 제거할 때까지 상태가 [완료]로 변경된 채로 [렌더링 대기열] 패널에 남아 있습니다. 완료된 항목을 다시 렌더링할 수는 없지만 해당 항목을 복제하여 대기열에 같은 설정 또는 새 설정으로 새 항목을 만들 수 있습니다.

참고:

항목이 렌더링된 후에는 [렌더링 대기열] 패널에서 [프로젝트] 패널로 해당 출력 모듈을 드래그하여 완료된 동영상을 푸티지 항목으로 가져올 수 있습니다. 푸티지 항목 가져오기를 참조하십시오.

렌더링 항목 상태

렌더링 항목마다 [렌더링 대기열] 패널의 [상태] 열에 나타나는 상태가 있습니다.

대기열에 없음

렌더링 항목이 [렌더링 대기열] 패널에 나열되지만 렌더링할 준비가 되어 있지 않습니다. 원하는 렌더링 설정과 출력 모듈 설정을 선택했는지 확인한 다음 [렌더링] 옵션을 선택하여 렌더링 항목을 대기열에 넣습니다.

대기 중

렌더링 항목이 렌더링할 준비가 되어 있습니다.

출력 필요

출력 파일 이름이 지정되지 않았습니다. [출력 위치] 메뉴에서 값을 선택하거나, [출력 위치] 머리글 옆의 밑줄이 있는 [아직 지정되지 않았습니다.] 텍스트를 클릭하여 파일 이름과 경로를 지정합니다.

실패

After Effects에서 렌더링 항목을 렌더링하지 못했습니다. 텍스트 편집기를 사용하여 로그 파일에서 렌더링이 실패한 이유에 대한 구체적인 정보를 봅니다. 로그 파일이 기록되었으면 [렌더링 설정] 머리글과 [로그] 메뉴 아래에 해당 로그 파일의 경로가 나타납니다.

사용자가 중지함

렌더링 프로세스가 중지되었습니다.

완료

항목의 렌더링 프로세스가 완료되었습니다.

렌더링 항목 관리 및 렌더링 상태 변경

  • [프로젝트] 패널에서 렌더링 항목의 소스 컴포지션을 선택: 렌더링 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태로 클릭(Mac OS)하고 문맥 메뉴에서 프로젝트에 컴포지션 표시를 선택합니다.
  • 렌더링 대기열에서 렌더링 항목을 제거하여 해당 상태를 [대기 중]에서 [대기열에 없음]으로 변경: [렌더링] 열에서 해당 항목을 선택 해제합니다. 항목은 렌더링 대기열 패널에 남아 있습니다.
  • 렌더링 항목의 상태를 [대기열에 없음]에서 [대기 중]으로 변경: [렌더링] 열에서 해당 항목을 선택합니다.
  • [렌더링 대기열] 패널에서 렌더링 항목을 제거: 항목을 선택하고 Delete 키를 누르거나 편집 > 지우기를 선택합니다.
  • [렌더링 대기열] 패널에서 항목을 다시 배열: 항목을 대기열에서 위나 아래로 드래그합니다. 렌더링 항목 사이에 두꺼운 검정 선이 나타나 항목이 놓일 위치를 보여 줍니다. 레이어 > 정렬을 선택하고 렌더링 항목을 앞으로 가져오기, 렌더링 항목을 뒤로 보내기, 렌더링 항목을 맨 앞으로 가져오기 또는 렌더링 항목을 맨 뒤로 보내기를 선택하여 선택한 렌더링 항목을 재배열할 수도 있습니다.
  • 선택한 렌더링 항목을 렌더링 대기열에서 위(이전)로 이동: Ctrl+Alt+위쪽 화살표(Windows) 또는 Command+Option+위쪽 화살표(Mac OS)를 누릅니다.
  • 선택한 렌더링 항목을 아래(이후)로 이동: Ctrl+Alt+아래쪽 화살표(Windows) 또는 Command+Option+아래쪽 화살표(Mac OS)를 누릅니다.
  • 선택한 렌더링 항목을 렌더링 대기열 맨 위로 이동: Ctrl+Alt+Shift+위쪽 화살표(Windows) 또는 Command+Option+Shift+위쪽 화살표(Mac OS)를 누릅니다.
  • 선택한 렌더링 항목을 렌더링 대기열 맨 아래(끝)로 이동: Ctrl+Alt+Shift+아래쪽 화살표(Windows) 또는 Command+Option+Shift+아래쪽 화살표(Mac OS)를 누릅니다.
  • 렌더링 항목을 복제: 렌더링 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태로 클릭(Mac OS)하고 문맥 메뉴에서 명령을 선택합니다.
    • 같은 파일 이름으로 렌더링: 같은 파일 이름을 사용하여 복제를 선택합니다.
    • 새 파일 이름으로 렌더링: 복제를 선택하고 출력 위치 옆의 밑줄이 있는 파일 이름을 클릭한 다음 새 파일 이름을 입력하고 저장을 클릭합니다.

렌더링 일시 중지 또는 중지

출력 모듈이 기록하고 있는 디스크의 공간이 부족하면 렌더링 작업이 일시 중지됩니다. 추가 디스크 공간을 확보한 다음 렌더링과 내보내기를 다시 시작할 수 있습니다.

  • 렌더링을 일시 중지하려면 [일시 중지]를 클릭합니다. 렌더링을 다시 시작하려면 [계속]을 클릭합니다.

    렌더링이 일시 중지된 동안에는 설정을 변경하거나 다른 어떤 방법으로도 After Effects를 사용할 수 없습니다.

  • 같은 렌더링을 처음부터 다시 시작할 목적으로 렌더링을 중지하려면 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태에서 [중지]를 클릭합니다.

    렌더링이 중지된 렌더링 항목에 [사용자가 중지함] 상태가 할당되고 [렌더링 대기열] 패널에 [대기 중] 상태의 새 항목이 추가됩니다. 새 항목은 같은 출력 파일 이름을 사용하며 지속 시간이 원래 렌더링 항목과 같습니다.

  • 같은 렌더링을 다시 시작할 목적으로 렌더링을 중지하려면 [중지]를 클릭합니다.

    렌더링이 중지된 렌더링 항목에 [사용자가 중지함] 상태가 할당되고 [렌더링 대기열] 패널에 [대기열에 없음] 상태의 새 항목이 추가됩니다. 새 항목은 증분된 출력 파일 이름을 사용하며 렌더링이 중단된 프레임 앞에서 렌더링을 다시 시작합니다. 따라서 새 항목의 첫 번째 프레임은 중지된 항목의 마지막 렌더링이 성공한 프레임이 됩니다.

현재 렌더링 작업에 대해 표시되는 정보

현재 일괄 처리 중인 렌더링에 대한 기본 정보가 [렌더링 대기열] 패널 아래쪽에 표시됩니다.

메시지

상태 메시지입니다. 예를 들어, 1/4 렌더링하는 중입니다.

RAM

렌더링 프로세스에 사용할 수 있는 메모리입니다.

렌더링 시작

현재 일괄 처리 중인 렌더링이 시작된 날짜 및 시간입니다.

총 경과 시간

현재 일괄 처리 중인 렌더링이 시작된 후 경과된 렌더링 시간(일시 중지는 계산에 포함하지 않음)입니다.

가장 최근에 발생한 오류

로그 파일이 있는 경로입니다.

참고:

현재 렌더링 작업에 대한 정보를 더 보려면 [현재 렌더링] 머리글 왼쪽의 삼각형을 클릭합니다. 잠시 뒤에 [현재 렌더링] 창이 축소됩니다(닫힙니다). 시간 초과 후 축소되지 않도록 하려면 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태로 [현재 렌더링] 머리글 옆의 삼각형을 클릭합니다. 완료된 렌더링의 세부 정보를 보려면 로그 파일을 검토합니다. 로그 파일이 기록되었으면 [렌더링 설정] 머리글과 [로그] 메뉴 아래에 해당 로그 파일의 경로가 나타납니다.

렌더링 완료 소리 변경

렌더링 대기열의 모든 항목이 렌더링되고 내보내기된 경우에는 차임벨 소리가, 렌더링 작업이 실패한 경우에는 다른 소리가 납니다. sounds 폴더에서 이름이 rnd_okay.wavrnd_fail.wav인 파일을 바꿔서 렌더링 완료 소리를 변경할 수 있습니다. sounds 폴더는 다음 위치에 있습니다.

  • Program Files\Adobe\Adobe After Effects CC 2015\Support Files(Windows)

  • Applications/Adobe After Effects CC/Contents/Resources(Mac OS)

렌더링 대기열로 렌더링 및 내보내기 관련 온라인 리소스

Lloyd Alvarez는 After Effects Scripts 웹 사이트에서 렌더링 대기열에서 렌더링할 준비가 된 항목을 가져와 aerender를 사용하여 백그라운드에서 렌더링되도록 전송하는 스크립트를 제공합니다.

Jeff Almasol은 redefinery 웹 사이트에서 선택한 각 레이어를 개별적으로 렌더링하고 내보내는 스크립트를 제공합니다. 이 스크립트는 여러 레이어가 한 효과의 서로 다른 버전 또는 한 효과의 서로 다른 부분을 나타내는 경우 이를 각각 별개의 "패스"로 렌더링하여 다양한 방식으로 합성하려는 경우에 유용합니다.

Christopher Green은 자신의 웹 사이트에서 여러 안내선 레이어를 사용하여 렌더링 대기열을 통해 개별적으로 렌더링하고 내보낼 여러 시간 범위를 지정하는 데 사용할 수 있는 스크립트(Queue_Comp_Sections.jsx)를 제공합니다.

Adobe Media Encoder로 렌더링 및 내보내기

From an expert: Export a composition from After Effects to Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder
Jeff Sengstack

After Effects 컴포지션을 Adobe Media Encoder로 바로 내보낼 수도 있습니다. 그러면 파일이 처리되는 동안 After Effects에서 계속 작업할 수 있습니다. Adobe Media Encoder를 사용할 때 After Effects 렌더링 대기열에서 사용할 수 없는 추가 사전 설정과 옵션을 사용할 수도 있습니다. 

다음 방법 중 하나를 사용하여 Adobe Media Encoder 대기열에 컴포지션을 추가할 수 있습니다.

  • Adobe Media Encoder에서 지정한 사전 설정과 설정을 사용하는 최종 렌더링은 Adobe Media Encoder 대기열에 추가(컴포지션 > Adobe Media Encoder 대기열에 추가 또는 파일 > 내보내기 > Adobe Media Encoder 대기열에 추가)를 사용합니다.
  • 컴포지션에서 작업을 계속하는 동안 렌더링 대기열에서 지정한 렌더링 설정을 사용하여 컴포지션의 초안 복사본을 렌더링할 때는 렌더링 대기열에서 AME의 대기열 버튼(창 > 렌더링 대기열)을 사용합니다. 

렌더링에 Adobe Media Encoder를 사용하는 방법에 대한 자세한 내용은 Adobe Media Encoder에서 비디오 또는 오디오 항목 인코딩을 참조하십시오.

참고:

포맷 설정 또는 색상 채널 선택과 같은 출력 모듈 설정은 AME의 대기열 옵션을 선택할 때 Adobe Media Encoder로 전송되지 않습니다. 출력 파일 이름 및 위치가 전송되지만 Adobe Media Encoder는 이미지 시퀀스 번호 매기기 불일치가 발생할 수 있는 파일 이름 및 위치 템플릿을 사용하지 않습니다.

Adobe Media Encoder로 컴포지션 직접 추가

컴포지션을 Adobe Media Encoder로 추가하려면 다음을 수행하십시오.

  1. 인코딩하려는 컴포지션이 들어 있는 After Effects 프로젝트를 Adobe Media Encoder의 인코딩 대기열로 드래그합니다.

    After Effects에서 Adobe Media Encoder에 컴포지션을 추가할 수 있습니다. 다음 중 하나를 수행합니다.

    • 컴포지션 > Adobe Media Encoder 대기열에 추가를 선택

    • 파일 > 내보내기 > Adobe Media Encoder 대기열에 추가를 선택

    • Ctrl+Alt+M(Windows) 또는 Command+Alt+M(Mac OS) 누르기

  2. [After Effects 컴포지션 가져오기] 대화 상자가 열립니다. 인코딩할 컴포지션을 선택합니다.

  3. Adobe Media Encoder에서 사전 설정 및 출력 위치를 선택하여 평소처럼 파일을 인코딩합니다.

렌더링 대기열에서 Adobe Media Encoder로 컴포지션 추가

초안 렌더링에 대한 렌더링 설정으로 Adobe Media Encoder에 컴포지션을 추가하려면 다음을 따르십시오.

  1. [컴포지션] > [렌더링 대기열에 추가]를 선택하거나 키보드 단축키 Ctrl + M(Windows) 또는 Command + M(Mac)을 누릅니다.

  2. 렌더링 대기열 패널에서 [AME의 대기열] 버튼을 클릭합니다. 

포맷 및 출력 설정 선택

After Effects에서는 출력을 위한 다양한 포맷 및 압축 옵션을 제공합니다. 선택하는 포맷 및 압축 옵션은 출력을 사용할 방법에 따라 다릅니다. 예를 들어 After Effects에서 렌더링하는 동영상이 시청 대상에게 직접 재생될 최종 제품인 경우 동영상을 재생할 미디어를 고려하고 파일 크기 및 데이터 속도에 대한 제한 사항도 고려해야 합니다. 반대로 After Effects에서 만드는 동영상이 비디오 편집 시스템에 대한 입력으로 사용될 중간 제품인 경우에는 압축하지 않고 비디오 편집 시스템과 호환되는 포맷으로 출력해야 합니다. 자세한 내용은 작업 계획을 참조하십시오.

Aharon Rabinowitz는 Creative COW 웹 사이트에서 프로젝트를 계획하고 최종 출력에 사용할 포맷 및 설정을 결정하는 방법에 대한 문서를 제공합니다.

워크플로의 위상마다 다른 인코딩 및 압축 스키마를 사용할 수 있다는 사실을 명심하십시오. 예를 들어 특정 샷의 색상에 대한 고객 승인이 필요할 때는 적은 수의 프레임을 전체 해상도 스틸 이미지(예: TIFF 파일)로 내보내도록 선택하고, 애니메이션 타이밍에 대한 승인이 필요할 때는 데이터 손실이 발생하는 인코딩 스키마(예: H.264)를 사용하여 동영상을 내보낼 수 있습니다.

지원되는 출력 포맷

Adobe가 아닌 서드 파티에서 제공한 플러그인이나 스크립트를 설치하여 다른 종류의 데이터를 내보내는 기능을 추가할 수 있습니다. 예를 들어 Paul Tuersley는 AE Enhancers 포럼에서 After Effects 컴포지션 데이터를 Cinema 4D 프로젝트 데이터로 내보내는 데 사용할 수 있는 스크립트를 제공합니다. Mark Christiansen은 ProVideo Coalition 웹 사이트에서 Cinema 4D, Maya, Lightwave 및 기타 3D 애플리케이션에서 사용하기 위해 After Effects의 내보내기 시 사용되는 스크립트 및 플러그인과 연결되는 문서를 제공합니다. 자세한 내용은 플러그인을 참조하십시오.

달리 지정되지 않은 경우 모든 이미지 파일 포맷을 8bpc(채널당 비트 수)로 내보냅니다.

비디오 및 애니메이션 포맷

  • QuickTime(MOV)

  • Windows용 비디오(AVI; Windows 전용)

참고:

애니메이션 GIF 동영상을 만들려면 먼저 After Effects에서 QuickTime 동영상을 렌더링하고 내보냅니다. 그런 다음 QuickTime 동영상을 Photoshop으로 가져와서 애니메이션 GIF로 내보냅니다.

비디오 프로젝트 포맷

  • Adobe Premiere Pro 프로젝트(PRPROJ)

스틸 이미지 포맷

  • Adobe Photoshop(PSD)

  • Cineon(CIN, DPX)

  • Maya IFF(IFF)

  • JPEG(JPG, JPE)

  • OpenEXR(EXR)

  • PNG(PNG)

  • Radiance(HDR, RGBE, XYZE)

  • SGI(SGI, BW, RGB)

  • Targa(TGA, VBA, ICB, VST)

  • TIFF(TIF)

오디오 전용 포맷

  • AIFF(Audio Interchange File Format)

  • MP3

  • WAV

한 위치에 파일 수집

[파일 수집] 명령은 프로젝트나 컴포지션에 있는 모든 파일의 사본을 단일 위치에 수집합니다. 이 명령을 렌더링하기 전에 사용하여 보관하거나 프로젝트를 다른 컴퓨터 시스템이나 사용자 계정으로 이동하십시오.

[파일 수집] 명령을 사용할 때 After Effects에서는 새 폴더를 생성하고 다음 정보를 새 폴더에 저장합니다.

  • 프로젝트의 새로운 복사본
  • 푸티지 파일 복사본
  • 지정된 프록시 파일
  • 프로젝트를 다시 만들고 컴포지션을 렌더링하는 데 필요한 파일, 효과 및 글꼴을 설명하는 보고서

파일을 수집한 후 계속해서 프로젝트를 변경할 수 있지만 해당 변경 내용은 새로 수집한 버전이 아니라 원래 프로젝트와 함께 저장됩니다.

  1. [파일] > [종속성] > [파일 수집]을 선택합니다.

  2. [파일 수집] 대화 상자의 [소스 파일 수집]에서 적합한 옵션을 선택합니다.

    모두

    사용되지 않은 푸티지와 프록시를 포함한 모든 푸티지 파일을 수집합니다.

    모든 컴포지션

    프로젝트에서 모든 컴포지션에 사용된 모든 푸티지 파일과 프록시를 수집합니다.

    선택한 컴포지션

    프로젝트에서 현재 선택한 컴포지션에 사용된 모든 푸티지 파일과 프록시를 수집합니다.

    대기 중인 컴포지션

    [렌더링 대기열] 패널에서 [대기 중] 상태인 컴포지션에 직접 또는 간접적으로 사용된 모든 푸티지 파일과 프록시를 수집합니다.

    없음(프로젝트만)

    소스 푸티지를 수집하지 않고 프로젝트를 새 위치에 복사합니다.

  3. 필요에 따라 기타 옵션을 선택합니다.

    보고서만 생성

    이 옵션을 선택하면 파일과 프록시가 복사되지 않습니다.

    프록시 설정 적용

    사본에 현재 프록시 설정을 포함할지 여부를 지정하려면 프록시를 포함하는 컴포지션에 이 옵션을 사용합니다. 이 옵션을 선택하면 컴포지션에 사용된 파일만 복사됩니다. 이 옵션을 선택하지 않으면 사본에 프록시와 소스 파일이 모두 포함되므로 나중에 수집된 버전에서 프록시 설정을 변경할 수 있습니다.

    참고:

    [소스 파일 수집] 대화 상자에서 [대기 중인 컴포지션]을 선택하면 컴포지션이 아니라 렌더링 설정의 프록시 설정이 사용됩니다.

    프로젝트 줄이기

    [소스 파일 수집] 메뉴에서 [모든 컴포지션], [선택한 컴포지션] 및 [대기 중인 컴포지션] 옵션을 선택한 경우 수집된 파일에서 사용되지 않은 푸티지 항목과 컴포지션을 모두 제거합니다.

    렌더링 출력을 다음으로 변경

    수집된 파일 폴더 내의 이름이 지정된 폴더로 파일을 렌더링하도록 출력 모듈을 리디렉션하려면 이 옵션을 사용합니다. 이 옵션을 사용하면 다른 컴퓨터에서 프로젝트를 렌더링하는 동안 렌더링되는 파일에 액세스할 수 있습니다. 렌더링 상태가 유효([대기 중], [대기열에 없음] 또는 [계속됨])해야 출력 모듈이 이 폴더로 파일을 렌더링할 수 있습니다.

    '감시 폴더' 렌더링 사용

    [파일 수집] 명령을 사용하여 프로젝트를 지정한 감시 폴더에 저장한 다음 네트워크를 통해 감시 폴더 렌더링을 시작할 수 있습니다. After Effects에는 감시하는 컴퓨터에 프로젝트를 렌더링할 수 있다고 알려 주는 [project name]_RCF.txt라는 렌더링 컨트롤 파일도 포함되어 있습니다. 그런 다음 After Effects와 설치된 모든 렌더링 엔진이 네트워크를 통해 프로젝트를 함께 렌더링할 수 있습니다. 감시 폴더 렌더링 설정을 참조하십시오.

    최대 시스템 수

    수집된 프로젝트를 렌더링하기 위해 할당할 렌더링 엔진 또는 사용이 허가된 After Effects 사본의 수를 지정하려면 이 옵션을 사용합니다. 이 옵션 아래에는 프로젝트에서 둘 이상의 컴퓨터를 사용하여 렌더링될 항목 수가 보고됩니다.

    참고:

    렌더링 시간이 비정상적으로 오래 걸리면 [최대 시스템 수]를 너무 높게 설정한 것일 수 있으며 모든 컴퓨터 간에 렌더링 진행률을 추적하는 데 필요한 네트워크 오버헤드가 프레임을 실제로 렌더링하는 데 걸리는 시간과 균형이 맞지 않습니다. 가장 적합한 수는 네트워크 구성 및 해당 구성에 있는 컴퓨터와 관련된 다양한 변수에 따라 다릅니다. 실험을 통해 사용 중인 네트워크에 가장 적합한 개수를 결정해야 합니다.

  4. 생성될 보고서에 사용자 고유의 정보를 추가하려면 [주석]을 클릭하고 원하는 주석을 입력한 다음 [확인]을 클릭합니다. 보고서 끝에 주석이 나타납니다.
  5. [수집]을 클릭합니다. 폴더의 이름을 지정하고 수집된 파일의 위치를 지정합니다.

    파일 수집을 시작하면 폴더가 만들어지고 지정한 파일이 해당 폴더에 복사됩니다. 폴더 계층 구조는 프로젝트에 있는 폴더 및 푸티지 항목의 계층 구조와 같습니다. 새 폴더에는 (푸티지) 폴더가 포함되며 [렌더링 출력을 다음으로 변경]을 선택한 경우 출력 폴더가 포함될 수도 있습니다.

이러한 폴더의 이름은 참여하는 모든 렌더링 엔진에 해당 폴더에서 프로젝트를 검색하면 안 된다는 것을 알려 주기 위해 괄호로 묶인 상태로 나타납니다.

Carl Larsen은 프로젝트 파일과 푸티지를 구성, 통합 및 보관하는 방법을 보여 주는 Creative COW 웹 사이트의 비디오 튜토리얼에서 파일 수집 명령과 모든 푸티지 통합 명령의 사용 방법을 설명합니다.

David Torno는 After Effects Scripts 웹 사이트에서 프로젝트와 관련된 특정 정보를 내보내는 스크립트를 제공합니다.

렌더링된 출력의 파일 이름 및 위치 지정

참고:

[렌더링 대기열] 패널에서 [출력 모듈] 그룹을 확장하고 밑줄이 있는 파일 경로를 클릭하거나, [출력 모듈] 머리글을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하여 이전에 렌더링한 항목을 찾거나 대기 중인 렌더링 항목의 대상을 확인할 수 있습니다.

단일 렌더링 항목의 파일 이름 및 위치 지정

  • 파일 이름과 대상 폴더를 수동으로 입력하려면 [출력 위치] 머리글 옆의 밑줄이 있는 텍스트를 클릭합니다.
  • 파일 이름 지정 템플릿을 사용하여 파일의 이름을 지정하려면 [출력 위치] 머리글 옆의 삼각형을 클릭하고 메뉴에서 템플릿을 선택합니다.

사용자 정의 파일 이름 지정 템플릿 만들기 및 사용

사용자 정의 템플릿을 사용하여 컴포지션 및 프로젝트 속성에 따라 출력의 이름을 지정할 수 있습니다.

참고:

파일 이름 지정 템플릿을 기본 템플릿으로 만들려면 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태로 [출력 위치] 메뉴에서 템플릿을 선택합니다.

  1. [렌더링 대기열] 패널의 [출력 위치] 메뉴에서 [사용자 정의]를 선택합니다.
  2. 기존 템플릿을 토대로 새 파일 이름 지정 템플릿을 만들려면 [사전 설정] 메뉴에서 기존 템플릿을 선택합니다.

  3. [템플릿] 상자에서 파일 이름 지정 규칙을 삽입할 위치를 클릭하고 다음 중 하나를 수행합니다.

    • 사전 설정 속성을 파일 이름에 추가하려면 [속성 추가] 메뉴에서 속성을 선택합니다.

    • [템플릿] 상자에 텍스트를 입력합니다.

    참고:

    삽입점이 사전 설정 속성의 대괄호([ ]) 외부에 있는지 확인합니다.

  4. 다음 중 하나를 수행합니다.
    • 파일 이름 지정 템플릿을 나중에 [출력 위치] 메뉴에서 사용할 사전 설정으로 저장하려면 [저장] 버튼 을 클릭합니다. [이름 선택] 대화 상자에 파일 이름 지정 템플릿의 이름을 입력하고 [확인]을 클릭합니다.

    • 선택한 파일 이름 지정 템플릿을 항상 사용하려면 [기본값]을 선택합니다.

    • 선택한 파일 이름 지정 템플릿을 현재 출력 모듈에 적용하려면 [확인]을 클릭합니다.

출력 파일 이름 자동 지정

[기본 파일 이름 및 폴더 사용] 환경 설정을 사용하면 렌더링 대기열에 추가된 모든 컴포지션에 고유한 출력 파일 이름이 자동으로 할당됩니다(여전히 컴포지션 이름을 사용하는 미리 보기를 저장하여 만든 파일 제외). 이 옵션을 선택하면 경로를 변경할 때까지 각 렌더링 항목에 이전 렌더링 항목과 같은 폴더 이름이 할당됩니다. 컴포지션을 두 번 이상 렌더링하면 파일 이름에 숫자가 추가됩니다(예: composition_name_1).

참고:

서로 다른 여러 플랫폼에서 사용하거나 감시 폴더를 사용하여 렌더링할 프로젝트의 경우 파일 이름에 high-ASCII 또는 기타 확장 문자를 사용하지 마십시오.

  1. [편집] > [환경 설정] > [출력](Windows) 또는 [After Effects] > [환경 설정] > [출력](Mac OS)을 선택합니다.
  2. [기본 파일 이름 및 폴더 사용]을 선택합니다.

템플릿에서 경로에 대한 지원

템플릿에 경로를 추가할 수 있습니다. 템플릿에서 절대 경로를 정의할 수 있습니다. 예를 들어, 렌더링된 파일을 항상 E:\Output\[compName].[extension]에 저장하는 템플릿을 정의하고 저장할 수 있습니다. After Effects CC 12.2 릴리스의 새로운 템플릿에 대한 자세한 내용은 After Effects CC 12.2의 새로운 기능에서 파일 이름 및 위치 템플릿 섹션을 참조하십시오.

렌더링 설정

렌더링 설정은 각 렌더링 항목에 적용되어 해당 특정 렌더링 항목에 대해 컴포지션을 렌더링하는 방법을 결정합니다. 기본적으로 렌더링 항목의 렌더링 설정은 해당 렌더링 항목의 기반이 되는 컴포지션의 현재 프로젝트 설정, 컴포지션 설정 및 스위치 설정을 기반으로 합니다. 그러나 각 렌더링 항목의 렌더링 설정을 수정하여 해당 설정 중 일부를 재정의할 수 있습니다.

렌더링 설정은 렌더링 항목의 루트 컴포지션과 모든 중첩된 컴포지션에 적용됩니다.

참고:

렌더링 설정은 연결된 렌더링 항목의 출력에만 영향을 주고 컴포지션 자체에는 영향을 주지 않습니다.

렌더링 설정
렌더링 설정

렌더링 설정 변경

  • 렌더링 항목의 렌더링 설정을 변경하려면 [렌더링 대기열] 패널에서 [렌더링 설정] 머리글 옆의 렌더링 설정 템플릿 이름을 클릭하고 [렌더링 설정] 대화 상자에서 설정을 선택합니다.
  • 선택한 렌더링 항목에 렌더링 설정 템플릿을 적용하려면 [렌더링 대기열] 패널에 있는 [렌더링 설정] 머리글 옆의 삼각형을 클릭하고 메뉴에서 템플릿을 선택합니다. 사용자 정의 렌더링 설정 템플릿을 선택하거나 다음 사전 설정 렌더링 설정 템플릿 중 하나를 선택할 수 있습니다.

    최고 설정: 최종 출력으로 렌더링하는 데 사용되는 경우가 많습니다.

    초안 설정: 동작 검토 또는 테스트에 적합한 경우가 많습니다.

    DV 설정: [최고 설정]과 비슷하지만 [하위 필드 우선]으로 설정된 [필드 렌더링]을 사용합니다.

    다중 시스템 설정: [최고 설정]과 비슷하지만 다중 시스템 렌더링을 사용하도록 선택된 [기존 파일 건너뛰기]를 사용합니다.

참고:

렌더링 항목이 만들어질 때 기본 렌더링 설정 템플릿이 할당됩니다. 기본 렌더링 설정 템플릿을 변경하려면 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태로 메뉴에서 렌더링 설정 템플릿을 선택합니다.

렌더링 설정 템플릿 만들기, 편집 및 관리

[렌더링 설정 템플릿] 대화 상자에서 다음 작업을 수행합니다. [렌더링 설정 템플릿] 대화 상자를 열려면 [편집] > [템플릿] > [렌더링 설정]을 선택하거나, [렌더링 대기열] 패널에 있는 [렌더링 설정] 머리글 옆의 삼각형을 클릭하고 [템플릿 만들기]를 선택합니다.

  • 새 렌더링 설정 템플릿을 만들려면 [새로 만들기]를 클릭하고 렌더링 설정을 지정한 다음 [확인]을 클릭합니다. 새 템플릿의 이름을 입력합니다.
  • 기존 렌더링 설정 템플릿을 편집하려면 [설정 이름] 메뉴에서 템플릿을 선택하고 [편집]을 클릭한 다음 렌더링 설정을 지정합니다.

참고:

기존 템플릿에 대한 변경 내용은 이미 렌더링 대기열에 있는 렌더링 항목에 영향을 주지 않습니다.

  • 동영상, 개별 프레임, 미리 렌더링된 동영상 또는 프록시를 렌더링할 때 사용할 기본 렌더링 설정 템플릿을 지정하려면 [렌더링 설정 템플릿] 대화 상자의 [기본값] 영역에 있는 메뉴에서 템플릿을 선택합니다.
  • 현재 불러온 모든 렌더링 설정 템플릿을 파일로 저장하려면 [모두 저장]을 클릭합니다.
  • 저장된 렌더링 설정 템플릿 파일을 불러오려면 [불러오기]를 클릭하고 렌더링 설정 템플릿 파일을 선택한 다음 [열기]를 클릭합니다.

렌더링 설정 참조

이러한 설정 각각은 컴포지션 설정, 프로젝트 설정 또는 레이어 스위치 설정을 재정의합니다.

로그

After Effects에서 렌더링 로그 파일에 기록하는 정보의 양을 선택할 수 있습니다. [오류만]을 선택하면 렌더링하는 동안 오류가 발생한 경우에만 파일이 생성됩니다. [플러스 설정]을 선택하면 현재 렌더링 설정을 나열하는 로그 파일이 생성됩니다. [프레임당 플러스 정보]를 선택하면 현재 렌더링 설정과 각 프레임의 렌더링 정보를 나열하는 로그 파일이 생성됩니다. 로그 파일이 기록되었으면 [렌더링 설정] 머리글과 [로그] 메뉴 아래에 해당 로그 파일의 경로가 나타납니다.

품질

모든 레이어에 사용할 품질 설정입니다. 이미지 품질 및 하위 픽셀 자릿수 표시를 참조하십시오.

해상도

렌더링된 컴포지션의 해상도로, 원래 컴포지션 치수를 기준으로 합니다. 자세한 내용은 해상도를 참조하십시오.

참고:

줄어든 해상도로 렌더링하는 경우에는 [품질] 옵션을 [초안]으로 설정합니다. 해상도를 줄인 경우 [최고] 품질로 렌더링하면 선명하지 않은 이미지가 생성되고 [초안] 품질보다 더 오랜 시간이 걸립니다.

디스크 캐시

렌더링하는 동안 디스크 캐시 환경 설정이 사용되는지 여부를 결정합니다. [읽기 전용]을 선택하면 After Effects에서 렌더링하는 동안 디스크 캐시에 새 프레임이 기록되지 않습니다. [현재 설정](기본값)을 선택하면 [미디어 및 디스크 캐시] 환경 설정에 정의된 디스크 캐시 설정이 사용됩니다. 디스크 캐시를 참조하십시오.

프록시 사용

렌더링할 때 프록시를 사용할지 여부를 결정합니다. [현재 설정]을 선택하면 각 푸티지 항목의 설정이 사용됩니다. 자리 표시자 및 프록시를 참조하십시오.

효과

[현재 설정](기본값)을 선택하면 [효과] 스위치 의 현재 설정이 사용됩니다. [모두 설정]을 선택하면 적용된 효과가 모두 렌더링됩니다. [모두 해제]를 선택하면 아무 효과도 렌더링되지 않습니다.

단독 스위치

[현재 설정](기본값)을 선택하면 레이어마다 [단독] 스위치의 현재 설정이 사용됩니다. [모두 해제]를 선택하면 모든 [단독] 스위치가 해제되어 있는 것처럼 렌더링됩니다. 자세한 내용은 레이어 단독화를 참조하십시오.

안내선 레이어

[현재 설정]을 선택하면 최상위 컴포지션의 안내선 레이어가 렌더링됩니다. [모두 해제](기본 설정)를 선택하면 안내선 레이어가 렌더링되지 않습니다. 중첩된 컴포지션의 안내선 레이어는 렌더링되지 않습니다. 안내선 레이어를 참조하십시오.

색상 심도

현재 설정(기본값)을 선택하면 프로젝트 비트 심도가 사용됩니다. 색상 심도 및 높은 동적 범위 색상을 참조하십시오.

프레임 혼합

[선택한 레이어에 대해 설정]을 선택하면 컴포지션의 [프레임 혼합 사용] 설정과 관계없이 [프레임 혼합] 스위치 가 설정된 레이어에 대해서만 프레임 혼합이 렌더링됩니다. 자세한 내용은 프레임 혼합을 참조하십시오.

필드 렌더링

렌더링된 컴포지션에 사용되는 필드 렌더링 기법을 결정합니다. 필름 또는 컴퓨터 화면 표시용으로 렌더링하는 경우에는 [해제]를 선택합니다. 인터레이스 비디오 및 필드 구분을 참조하십시오.

3:2 풀다운

3:2 풀다운 위상을 지정합니다. 3:2 풀다운 적용을 참조하십시오.

동작 흐림 효과

[현재 설정]을 선택하면 [동작 흐림 효과] 레이어 스위치와 [동작 흐림 효과 사용] 컴포지션 스위치의 현재 설정이 사용됩니다. [선택한 레이어에 대해 설정]을 선택하면 컴포지션의 [동작 흐림 효과 사용] 설정과 관계없이 [동작 흐림 효과] 레이어 스위치가 설정된 레이어에 대해서만 동작 흐림 효과가 렌더링됩니다. [모든 레이어에 대해 해제]를 선택하면 레이어 스위치 및 컴포지션 스위치 설정과 관계없이 동작 흐림 효과 없이 모든 레이어가 렌더링됩니다. 자세한 내용은 동작 흐림 효과를 참조하십시오.

시간 범위

렌더링할 컴포지션 양입니다. 전체 컴포지션을 렌더링하려면 [컴포지션 길이]를 선택합니다. 컴포지션에서 작업 영역 마커가 나타내는 부분만 렌더링하려면 [작업 영역만]을 선택합니다. 사용자 정의 시간 범위를 렌더링하려면 [사용자 정의]를 선택합니다. 작업 영역을 참조하십시오.

프레임 속도

동영상을 렌더링할 때 사용할 샘플링 프레임 속도입니다. [컴포지션 설정] 대화 상자에 지정된 프레임 속도를 사용하려면 [컴포지션의 프레임 속도 사용]을, 다른 프레임 속도를 사용하려면 [이 프레임 속도 사용]을 선택합니다. 컴포지션의 실제 프레임 속도는 변경되지 않습니다. 최종 인코딩된 동영상의 프레임 속도는 출력 모듈 설정에 의해 결정됩니다. 자세한 내용은 프레임 속도를 참조하십시오.

기존 파일 건너뛰기

이전에 렌더링한 프레임에 시간을 낭비하지 않고 파일 시퀀스의 일부를 다시 렌더링할 수 있습니다. 파일 시퀀스를 렌더링하면 After Effects에서 현재 시퀀스에 속한 파일을 찾고 누락된 프레임을 식별한 다음 시퀀스에서 해당 프레임이 속한 위치에 삽입하여 해당 프레임만 렌더링합니다. 이 옵션을 사용하여 여러 컴퓨터에서 이미지 시퀀스를 렌더링할 수도 있습니다. 여러 컴퓨터를 사용하여 스틸 이미지 시퀀스 렌더링을 참조하십시오.

참고:

현재 이미지 시퀀스는 기존 이미지 시퀀스와 이름이 같고 시작 프레임 번호, 프레임 속도 및 시간 범위도 같아야 합니다. 이전에 렌더링한 프레임이 포함된 폴더로 렌더링해야 합니다.

출력 모듈 및 출력 모듈 설정

출력 모듈 설정은 각 렌더링 항목에 적용되어 렌더링된 동영상이 최종 출력을 위해 처리되는 방법을 결정합니다. 출력 모듈 설정을 사용하여 최종 출력의 파일 포맷, 출력 색상 프로파일, 압축 옵션 및 기타 인코딩 옵션을 지정합니다.

출력 모듈 설정을 사용하여 렌더링된 동영상을 자르거나, 스트레치하거나, 축소할 수도 있는데, 단일 컴포지션에서 여러 종류의 출력을 생성하는 경우 렌더링 후 이 작업을 수행하는 것이 유용한 경우가 많습니다.

출력 모듈 설정은 렌더링 설정에 따라 생성되는 렌더링된 출력에 적용됩니다.

일부 포맷의 경우 [출력 모듈 설정] 대화 상자에서 포맷을 선택하면 추가 대화 상자가 열립니다. 이러한 설정을 수정하고 사전 설정을 사용하여 압축 옵션과 같은 포맷별 옵션을 지정할 수 있습니다.

여러 출력 모듈을 각 렌더링 항목에 적용할 수 있는데, 이는 한 번의 렌더링으로 둘 이상의 동영상 버전을 만들려는 경우에 유용합니다. 예를 들어 동영상 및 해당 알파 매트 만들기를 자동화하거나 동영상의 고해상도 버전과 저해상도 버전을 만들 수 있습니다.

참고:

렌더링하기 전에 [출력 모듈 설정] 대화 상자에서 [오디오 출력] 설정을 검토하여 설정이 올바른지 확인하십시오. 오디오를 렌더링하려면 [오디오 출력]을 선택해야 합니다. 컴포지션에 오디오가 포함되어 있지 않으면 렌더링된 파일 크기가 필요 없이 커지지 않도록 [오디오 출력]을 선택하지 마십시오.

렌더링 설정

여러 렌더링 대기열 항목의 출력 모듈을 동시에 설정할 수 있습니다. 렌더링 대기열 항목을 선택한 후에 한 항목에 대한 [출력 모듈 설정] 메뉴에서 출력 모듈 템플릿을 선택하십시오.

출력 모듈을 [프로젝트] 패널로 드래그하여 완료된 동영상이나 자리 표시자를 푸티지 항목으로 사용하기 위해 프로젝트로 가져올 수 있습니다. 푸티지 항목 가져오기를 참조하십시오.

Andrew Kramer는 Video Copilot 웹 사이트에서 프록시, 출력 모듈 및 출력 모듈 템플릿 사용에 관한 팁과 함께 비디오 튜토리얼을 제공합니다.

출력 모듈 설정 변경

  • 렌더링 항목의 출력 모듈 설정을 변경하려면 [렌더링 대기열] 패널에서 [출력 모듈] 머리글 옆의 밑줄이 있는 출력 모듈 설정 템플릿 이름을 클릭하고 [출력 모듈 설정] 대화 상자에서 설정을 선택합니다.
  • 선택한 렌더링 항목에 출력 모듈 설정 템플릿을 적용하려면 [렌더링 대기열] 패널에 있는 [출력 모듈] 머리글 옆의 삼각형을 클릭하고 메뉴에서 템플릿을 선택합니다.

    사용자 정의 출력 모듈 설정 템플릿을 선택하거나 사전 설정 출력 모듈 설정 템플릿 중 하나를 선택할 수 있습니다. 비디오, 필름 또는 NLE 시스템에 전송할 동영상을 만들기 위한 [손실 없음] 템플릿 등 여러 템플릿이 제공됩니다.

참고:

렌더링 항목을 만들 때 기본 출력 모듈 설정 템플릿이 할당됩니다. 기본 출력 모듈 템플릿을 변경하려면 Ctrl 키(Windows) 또는 Command 키(Mac OS)를 누른 상태로 메뉴에서 출력 모듈 템플릿을 선택합니다.

참고:

여러 출력 모듈에 대한 출력 모듈 설정을 한꺼번에 변경하려면 출력 모듈을 선택한 다음 출력 모듈 템플릿을 선택합니다. 템플릿이 선택된 모든 출력 모듈에 적용됩니다.

출력 모듈 템플릿 만들기, 관리 및 편집

[출력 모듈 템플릿] 대화 상자에서 다음 작업을 수행합니다. [출력 모듈 템플릿] 대화 상자를 열려면 [편집] > [템플릿] > [출력 모듈]을 선택하거나, [렌더링 대기열] 패널에 있는 [출력 모듈] 머리글 옆의 삼각형을 클릭하고 [템플릿 만들기]를 선택합니다.

  • 새 출력 모듈 설정 템플릿을 만들려면 [새로 만들기]를 클릭하고 출력 모듈 설정을 지정한 다음 [확인]을 클릭합니다. 새 템플릿의 이름을 입력합니다.
  • 기존 출력 모듈 설정 템플릿을 편집하려면 [설정 이름] 메뉴에서 템플릿을 선택하고 [편집]을 클릭한 다음 출력 모듈 설정을 지정합니다.

참고:

기존 템플릿에 대한 변경 내용은 이미 렌더링 대기열에 있는 렌더링 항목에 영향을 주지 않습니다.

  • 동영상, 개별 프레임, 미리 보기, 미리 렌더링된 동영상 또는 프록시를 처리할 때 사용할 기본 출력 모듈 설정 템플릿을 지정하려면 [출력 모듈 템플릿] 대화 상자의 [기본값] 영역에 있는 메뉴에서 템플릿을 선택합니다.
  • 현재 불러온 모든 출력 모듈 템플릿을 파일로 저장하려면 [모두 저장]을 클릭합니다.
  • 저장된 출력 모듈 템플릿 파일을 불러오려면 [불러오기]를 클릭하고 출력 모듈 템플릿 파일을 선택한 다음 [열기]를 클릭합니다.

출력 모듈을 렌더링 항목에 추가 또는 렌더링 항목에서 제거

  • 단일 렌더링 항목에 기본 설정을 사용하여 새 출력 모듈을 추가하려면 렌더링된 항목에 대한 마지막 출력 모듈의 [출력 위치] 머리글 옆에 있는 더하기(+) 기호를 클릭합니다.
  • 렌더링 항목에서 출력 모듈을 제거하려면 출력 모듈의 [출력 위치] 머리글 왼쪽에 있는 빼기(-) 기호를 클릭합니다.
  • 선택한 렌더링 항목에 기본 설정을 사용하여 새 출력 모듈을 추가하려면 [컴포지션] > [출력 모듈 추가]를 선택합니다.
  • 선택한 출력 모듈을 복제하려면 Ctrl+D(Windows) 또는 Command+D(Mac OS)를 누릅니다.

출력 모듈 설정

[출력 모듈 설정] 대화 상자의 [색상 관리] 영역에서 컨트롤을 사용하는 방법에 대한 자세한 내용은 출력 색상 프로파일 할당을 참조하십시오.

포맷

출력 파일이나 파일 시퀀스의 포맷을 지정합니다.

프로젝트 링크 포함

소스 After Effects 프로젝트에 연결된 정보를 출력 파일에 포함할지 여부를 지정합니다. Adobe Premiere Pro와 같은 다른 애플리케이션에서 출력 파일을 열 때 [원본 편집] 명령을 사용하여 After Effects의 소스 프로젝트를 편집할 수 있습니다.

소스 XMP 메타데이터 포함

렌더링된 컴포지션의 소스로 사용되는 파일에 있는 XMP 메타데이터를 출력 파일에 포함할지 여부를 지정합니다. XMP 메타데이터는 After Effects를 통해 소스 파일에서 푸티지 항목, 컴포지션 또는 렌더링하여 내보낸 파일로 이동할 수 있습니다. 모든 기본 출력 모듈 템플릿에 대해 [소스 XMP 메타데이터 포함]은 기본적으로 선택이 해제됩니다. After Effects에서 XMP 메타데이터 내보내기를 참조하십시오.

렌더링 후 작업

컴포지션이 렌더링된 후에 수행할 After Effects 작업을 지정합니다. 자세한 내용은 렌더링 후 작업을 참조하십시오.

포맷 옵션

포맷별 옵션을 지정하는 대화 상자가 열립니다.

채널

출력 동영상에 포함된 출력 채널입니다. [수백만 색상 이상]의 심도를 암시하는 [RGB+알파]를 선택하면 After Effects에서 알파 채널을 사용하여 동영상을 만듭니다. 일부 코덱에서는 알파 채널을 지원하지 않습니다.

참고:

[수백만 색상 이상], [수조의 색상 이상] 또는 [부동 소수점+]의 색상 심도를 사용하여 만든 모든 파일에는 알파 채널이라는 레이블이 지정되어 있고 알파 채널을 설명하는 정보가 파일에 저장되어 있습니다. 따라서 After Effects에서 만든 항목을 가져올 때마다 알파 해석을 지정하지 않아도 됩니다.

심도

출력 동영상의 색상 심도를 지정합니다. 특정 포맷에 따라 심도 및 색상 설정이 제한될 수도 있습니다.

색상

알파 채널을 사용하여 색상을 만드는 방법을 지정합니다. [미리 곱하기(매트화)] 또는 [스트레이트(매트 해제)]를 선택합니다. 알파 채널 해석: 미리 곱하기 또는 스트레이트를 참조하십시오.

시작 번호

시퀀스 시작 프레임의 번호를 지정합니다. 예를 들어 이 옵션을 38로 설정하면 첫 번째 프레임의 이름이 [file_name]_00038로 지정됩니다. [컴포지션 프레임 번호 사용] 옵션을 선택하면 작업 영역에 있는 시작 프레임 번호가 시퀀스 시작 프레임에 추가됩니다.

크기 조정

출력 동영상 크기를 지정합니다. 프레임 크기를 조정할 때 기존 프레임 종횡비를 유지하려면 [종횡비를 [실제 종횡비]로 잠금]을 선택합니다. 테스트를 렌더링할 때는 [크기 조정 품질]로 [낮음]을, 최종 동영상을 만들 때는 [크기 조정 품질]로 [높음]을 선택합니다. 동영상을 아래로 비율 조정동영상을 위로 비율 조정을 참조하십시오.

자르기

출력 동영상 가장자리에서 픽셀 행 또는 열을 빼거나 더하는 데 사용됩니다. 동영상 위쪽, 왼쪽, 아래쪽 및 오른쪽에 더하거나 동영상 위쪽, 왼쪽, 아래쪽 및 오른쪽에서 뺄 픽셀 행 또는 열 수를 지정할 수 있습니다. 자르려면 양수 값을, 픽셀 행 또는 열을 더하려면 음수 값을 사용합니다. [컴포지션] 또는 [레이어] 패널에서 선택한 관심 영역만 내보내려면 [관심 영역]을 선택합니다. ROI(관심 영역)를 참조하십시오.

참고:

동영상 위쪽에 픽셀 행 하나를 더하고 아래쪽에서 행 하나를 빼서 필드 순서를 변경할 수 있습니다.

오디오 출력

샘플 속도, 샘플 심도([8비트] 또는 [16비트]) 및 재생 포맷([모노] 또는 [스테레오])을 지정합니다. 출력 포맷의 기능에 맞는 샘플 속도를 선택합니다. 컴퓨터에서 재생할 경우에는 8비트 샘플 심도를, CD 또는 디지털 오디오 재생이나 16비트 재생을 지원하는 하드웨어의 경우에는 16비트 샘플 심도를 선택합니다.

참고:

일부 포맷 사양에서는 오디오 매개 변수가 제한됩니다. 이러한 경우에는 [출력 모듈 설정] 대화 상자에서 오디오 옵션을 수정할 수 없습니다. 또한 일부 포맷의 오디오 옵션은 해당 포맷의 내보내기 설정 대화 상자에서 설정됩니다. 예를 들어 Windows Media에 대한 오디오 출력 옵션을 설정하려면 [출력 모듈 설정] 대화 상자에서 [포맷 옵션]을 클릭합니다.

프레임 속도 또는 치수 불일치에 대한 경고

일부 포맷에서는 프레임 크기 및 프레임 속도가 제한됩니다.

이러한 제한된 출력 포맷을 선택한 경우, 컴포지션, 렌더링 설정 또는 출력 모듈 설정이 제한 사항과 일치하지 않으면 After Effects에서 노란색 경고 아이콘 과 함께 “설정 불일치”라는 메시지가 [출력 모듈 설정] 대화 상자의 하단에 표시됩니다.

포맷 제한을 충족하기 위한 출력 파일의 수정 방법을 설명하는 자세한 메시지를 보려면 경고 아이콘을 클릭합니다. After Effects에서 출력 모듈이 자동으로 변경되도록 하지 않으려면 이전으로 돌아가서 컴포지션 설정, 렌더링 설정 및 출력 모듈 설정을 변경할 수 있습니다.

출력 모듈 제한과 프레임 속도, 치수 및 픽셀 종횡비의 불일치와 관련된 경고에 대한 자세한 내용은 Adobe 웹 사이트를 참조하십시오.

동영상의 인코딩 및 압축 옵션

압축은 동영상이 효율적으로 저장, 전송 및 재생될 수 있도록 크기를 줄이는 데 필수적인 방법입니다. 압축은 인코더, 압축 풀기는 디코더를 통해 수행되며 이러한 인코더와 디코더를 일반적으로 코덱이라고 합니다. 상황에 따라 필요한 코덱 또는 설정 집합은 각기 다릅니다. 예를 들어 카툰 애니메이션을 압축하는 데 가장 좋은 코덱은 대개 실시간 비디오를 압축하는 데 효율적이지 않습니다. 마찬가지로 네트워크 연결이 느린 경우 재생하기에 적합한 코덱은 일반적으로 프로덕션 워크플로의 중간 단계에서는 적합하지 않습니다. 최종 출력을 염두에 두고 작업을 계획하는 방법에 대한 자세한 내용은 작업 계획을 참조하십시오.

After Effects에서는 Adobe Media Encoder의 내장 버전을 사용하여 [렌더링 대기열] 패널을 통해 대부분의 동영상 포맷을 인코딩합니다. [렌더링 대기열] 패널을 사용하여 렌더링 및 내보내기 작업을 관리하면 Adobe Media Encoder의 내장 버전이 자동으로 호출됩니다. Adobe Media Encoder는 일부 인코딩 및 출력 설정을 지정하는 데 사용되는 내보내기 설정 대화 상자의 형태로만 나타납니다.

참고:

After Effects 출력 모듈 내의 내보내기 설정을 관리하는 데 사용되는 Adobe Media Encoder의 내장 버전은 정식 독립 실행형 Adobe Media Encoder 애플리케이션의 모든 기능을 제공하지는 않습니다. 정식 독립 실행형 Adobe Media Encoder 애플리케이션에 대한 자세한 내용은 Adobe Media Encoder 도움말을 참조하십시오.

대다수 출력 포맷의 경우 포맷별 인코딩 및 압축 옵션을 지정할 수 있습니다. 내보낼 포맷을 선택하거나 [출력 모듈 설정] 대화 상자에서 [포맷 옵션] 버튼을 클릭하면 대화 상자가 열리면서 이러한 옵션이 제공되는 경우가 많습니다. 출력 모듈 및 출력 모듈 설정을 참조하십시오.

QuickTime(MOV) 인코딩 및 압축 설정

  1. [렌더링 대기열] 패널에서 밑줄이 있는 출력 모듈 이름을 클릭합니다.
  2. [포맷] 메뉴에서 [QuickTime]을 선택합니다.
  3. [비디오 출력] 섹션에서 [포맷 옵션]을 클릭합니다.
  4. [QuickTime 옵션] 대화 상자에서 코덱을 선택하고 다음과 같은 특정 코덱 및 사용자의 요구 사항에 따라 옵션을 설정합니다.

    품질

    품질 설정이 높으면 이미지 품질은 향상되지만 동영상 파일 크기가 커집니다.

    키 프레임 간격

    QuickTime에서 사용하는 키 프레임이라는 용어는 After Effects의 [타임라인] 패널에 있는, 시간이 경과함에 따라 바뀌는 키프레임과는 다릅니다. QuickTime의 키 프레임은 동영상에서 정기적으로 발생하는 프레임으로, 압축하는 동안 이러한 키 프레임은 전체 프레임으로 저장됩니다. 이들을 구분하는 각각의 중간 프레임이 이전 프레임과 비교되고 변경된 데이터만 저장됩니다. 키 프레임을 사용하면 동영상 크기는 크게 줄어들고 동영상 편집과 렌더링에 필요한 메모리는 크게 증가합니다. 키 프레임 사이의 간격을 줄이면 검색 및 역방향 재생 속도는 빨라지지만 파일 크기는 크게 증가할 수 있습니다.

    프레임 순서 변경

    일부 코덱에서는 저장 효율을 높이기 위해 프레임의 순서를 바꿔서 인코딩 및 디코딩할 수 있습니다.

    참고: QuickTime에 대한 자세한 내용은 Apple 웹 사이트를 참조하십시오.

     

  5. [확인]을 클릭합니다.
  6. [출력 모듈 설정] 대화 상자에서 다른 설정을 지정합니다.

렌더링 후 작업

렌더링 후 작업을 사용하여 컴포지션이 렌더링된 후에 발생하는 단순 작업을 자동화할 수 있습니다.

렌더링 후 작업을 사용하는 일반적인 예로는 미리 렌더링을 사용하는 경우가 있습니다. [컴포지션] > [미리 렌더링]을 선택하면 선택한 컴포지션이 렌더링 대기열에 추가되고 [렌더링 후 작업] 옵션이 [사용량 가져오기 및 바꾸기]로 설정됩니다.

참고:

[출력 모듈] 그룹에서 [렌더링 후 작업] 옵션을 선택하므로 [출력 모듈] 템플릿을 변경하면 [렌더링 후 작업] 옵션도 변경될 수 있다는 점에 유의해야 합니다. 출력 모듈 및 출력 모듈 설정을 참조하십시오.

  1. [렌더링 대기열] 패널에서 [출력 모듈] 머리글 왼쪽의 화살표를 클릭하여 [출력 모듈] 그룹을 확장합니다.
  2. [렌더링 후 작업] 메뉴에서 다음 중 하나를 선택합니다.

    없음

    렌더링 후 작업을 수행하지 않습니다. 이 옵션이 기본값입니다.

    가져오기

    렌더링이 완료되면 렌더링된 파일을 프로젝트에 푸티지 항목으로 가져옵니다.

    사용량 가져오기 및 바꾸기

    렌더링된 파일을 프로젝트에 가져와서 지정한 항목을 대체합니다. 뚝딱 툴을 [프로젝트] 패널에서 바꿀 항목으로 드래그하여 지정합니다.

    참고:

    종속 렌더링 항목 체인을 만들려면 [사용량 가져오기 및 바꾸기] 옵션을 사용합니다. 예를 들어 감시 폴더를 사용할 렌더링 항목 하나와 스틸 이미지 시퀀스를 만들 컴퓨터 여러 대를 설정하면 다음 렌더링 항목이 해당 스틸 이미지 시퀀스에서 단일 동영상 파일을 렌더링할 수 있습니다. 자세한 내용은 감시 폴더 및 렌더링 엔진을 사용한 네트워크 렌더링을 참조하십시오.

    프록시 설정

    렌더링된 파일을 지정한 항목의 프록시로 설정합니다. 뚝딱 툴을 [프로젝트] 패널에 있는 항목으로 드래그하여 지정합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책