Optimizar documentos de Animate

Cuanto mayor sea el tamaño de archivo del documento, mayor será su tiempo de descarga y su velocidad de reproducción. Puede llevar a cabo varios pasos para que el documento tenga una reproducción óptima. Como parte del proceso de publicación, Animate efectúa automáticamente una optimización en los documentos. Antes de exportar un documento, puede optimizarlo aún más con varias estrategias para reducir el tamaño del archivo. También puede comprimir un archivo SWF al publicarlo. A medida que vaya haciendo cambios, pruebe el documento ejecutándolo en distintos equipos, sistemas operativos y conexiones a Internet.

Optimización de documentos

  • Utilice símbolos, animados o de otro tipo, para cada elemento que aparezca más de una vez.

  • Al crear secuencias de animación, utilice animaciones interpoladas siempre que sea posible. Las animaciones interpoladas utilizan menos espacio de archivo que una serie de fotogramas.

  • Para secuencias de animación, utilice clips de película en vez de símbolos gráficos.

  • Limite el área de cambio de cada fotograma clave; haga que el área donde tenga lugar la acción sea lo más pequeña posible.

  • No utilice elementos de mapas de bits animados; utilice imágenes de mapas de bits como elementos de fondo o estáticos.

  • Utilice mp3, el formato de sonido más pequeño, siempre que sea posible.

Optimización de elementos y líneas

  • Agrupe los elementos.

  • Utilice capas para separar de los demás elementos los que cambian a lo largo de la animación.

  • Utilice Modificar > Curvas > Optimizar para reducir al máximo el número de líneas separadas que se utilizan para describir las formas.

  • Limite el número de tipos de línea especiales, tales como líneas discontinuas, líneas punteadas, líneas desiguales, etc. Las líneas continuas precisan menos memoria. Las líneas creadas con la herramienta Lápiz necesitan menos memoria que los trazos del pincel.

Optimización de texto y fuentes

  • Limite el número y los estilos de fuente. Utilice las fuentes incorporadas con moderación, ya que aumentan el tamaño del archivo.

  • Para las opciones de Fuentes incorporadas, seleccione solo los caracteres necesarios en lugar de incluir toda la fuente.

Optimizar colores

  • Utilice el menú Color del inspector de propiedades de símbolo para crear varias instancias de un mismo símbolo en distintos colores.

  • Utilice el panel Color (Ventana > Color) para hacer coincidir la paleta de colores del documento con una paleta específica del navegador.

  • Utilice los degradados con moderación. Para poder rellenar un área con colores degradados, se necesitan aproximadamente 50 bytes más de los necesarios para rellenar la misma área con un color uniforme.

  • Utilice la transparencia alfa con moderación, puesto que puede ralentizar la reproducción.

Aceleración de la visualización del documento

Para acelerar la visualización del documento, con los comandos del menú Ver, desactive las funciones de calidad de representación que requieren cálculos adicionales y ralentizan la visualización de los documentos.

Ninguno de estos comandos afecta a la exportación de un documento de Animate. Para especificar la calidad de visualización de los documentos de Animate en un navegador Web, utilice los parámetros object y embed. El comando Publicar puede hacerlo de forma automática.

  1. Seleccione Ver > Modo de vista previa y, a continuación, elija una de las opciones siguientes:

    Contornos

    Muestra solo los contornos de las formas de la escena y hace que todas las líneas aparezcan como líneas finas. Esto facilita la remodelación de los elementos gráficos y la presentación rápida de escenas complejas.

    Rápida

    Desactiva la visualización suavizada de líneas y muestra todos los colores y estilos de línea del dibujo.

    Suavizar

    Activa la visualización suavizada de líneas, formas y mapas de bits y muestra las formas y las líneas de tal modo que los bordes aparezcan suavizados en la pantalla. Dibuja más despacio que la opción Rápida. La visualización suavizada funciona mejor con las tarjetas de vídeo de miles (16 bits) o millones (24 bits) de colores. En la modalidad de 16 o 256 colores, las líneas negras se suavizan, pero es posible que los colores se vean mejor en el modo rápido.

    Suavizar texto

    Suaviza los bordes de todos los textos. Funciona mejor con tamaños de fuente grandes; con grandes cantidades de texto puede ser muy lento. Este es el modo de funcionamiento más frecuente.

    Completo

    Representa todo el contenido en el escenario. Puede hacer más lenta la visualización.

Optimización de gráficos y animación

Antes de crear animaciones o gráficos optimizados y reorganizados, medite y planifique el proyecto. Fije un tamaño de archivo y una duración de la animación y realice pruebas durante el proceso de desarrollo.

Siga estas directrices para optimizar los gráficos y la animación:

  • Evite la utilización de degradados, ya que requieren el procesamiento de muchos colores y cálculos y esto complica la representación por parte del procesador del equipo.

  • Por el mismo motivo, reduzca al mínimo la cantidad de transparencia alfa empleada en el archivo SWF.

    Reduzca también al mínimo los objetos animados que incluyan transparencias, ya que requieren un uso intensivo del procesador. Los gráficos animados transparentes sobre mapas de bits requieren un uso especialmente intensivo del procesador, por lo que deben reducirse al mínimo o evitarse por completo.

    nota: El mejor formato de mapa de bits para importar en Animate es PNG (formato de archivo nativo de Macromedia Fireworks de Adobe). Los archivos PNG contienen información RVA y alfa para cada píxel. Si importa un archivo PNG de Fireworks en Animate, se conserva cierta capacidad para editar los objetos gráficos en el archivo FLA.

  • Optimice los mapas de bits sin comprimirlos demasiado. Una resolución de 72 ppp se considera suficiente para la web. Al comprimir una imagen de mapa de bits se reduce su tamaño de archivo, pero si se comprime demasiado, la calidad del archivo se deteriora. Compruebe que los valores de calidad JPEG del cuadro de diálogo Configuración de publicación no comprimen la imagen en exceso. En la mayoría de los casos, es preferible representar una imagen como un gráfico vectorial. El uso de imágenes vectoriales reduce el tamaño del archivo, ya que las imágenes se crean a partir de cálculos y no de píxeles. Limite el número de colores de la imagen sin perder calidad.

    nota: evite escalar mapas de bits por encima de sus dimensiones originales, ya que se reducirá la calidad de la imagen y se hará un uso intensivo del procesador.

  • Defina la propiedad _visible en false en lugar de cambiar el nivel de _alpha a 0 o 1 en un archivo SWF. El cálculo del nivel de _alpha para una instancia del escenario requiere un uso intensivo del procesador. Si desactiva la visibilidad de las instancias, se ahorrarán ciclos de la CPU y memoria, y se obtendrán animaciones más suaves en los archivos SWF. En lugar de anular la carga y volver a cargar activos, defina la propiedad _visible como false, que hace un uso menos intensivo del procesador.

  • Reduzca el número de líneas y puntos utilizados en el archivo SWF. Utilice el cuadro de diálogo Optimizar curvas (Modificar > Forma > Optimizar) para reducir el número de vectores de un dibujo. Seleccione la opción Utilizar varias pasadas para obtener una mayor optimización. Al optimizar un gráfico se reduce su tamaño de archivo, pero si se comprime demasiado, la calidad empeora. No obstante, la optimización de curvas reduce el tamaño del archivo y mejora el rendimiento del archivo SWF. Existen opciones de terceros para conseguir una optimización especializada de curvas y puntos que dan lugar a distintos resultados.

 

Para lograr los mejores resultados, intente producir contenido animado con distintos métodos y pruebe cada una de las posibilidades.

Si se utiliza una velocidad de fotogramas mayor (medida en fotogramas por segundo o fps), se obtiene una animación más suave en el archivo SWF, pero puede requerir un uso intensivo del procesador, especialmente en equipos más antiguos. Pruebe las animaciones a distintas velocidades de fotogramas para detectar la velocidad menor posible.

Para obtener un ejemplo de animación con script, visite la página web de ejemplos de Animate en www.adobe.com/go/learn_fl_samples_es. Descargue y descomprima el archivo zip de ejemplos y vaya a la carpeta ActionScript2.0/Animation para acceder al ejemplo.

Velocidad de fotogramas y rendimiento de animaciones

Cuando añada animaciones a una aplicación, tenga en cuenta la velocidad de fotogramas a la que establece el archivo FLA. La velocidad de fotogramas puede afectar al rendimiento del archivo SWF y al equipo en el que se reproduce. Si la establece en un valor muy alto pueden darse problemas en el procesador, sobre todo cuando se emplean muchos elementos o se utiliza código ActionScript para crear la animación.

Sin embargo, también debe tener en cuenta la configuración de la velocidad de fotogramas, ya que afecta a la suavidad con la que se reproduce la animación. Por ejemplo, una animación establecida a 12 fotogramas por segundo (fps) en el inspector de propiedades reproduce 12 fotogramas cada segundo. Si la velocidad de fotogramas del documento se establece en 24 fps, la animación parece reproducirse con mayor suavidad que si se ejecuta a 12 fps. No obstante, la animación a 24 fps también se reproduce más rápidamente que a 12 fps, por lo que la duración total (en segundos) es más corta. Por tanto, para crear una animación de 5 segundos con una velocidad de fotogramas mayor, debe añadir fotogramas adicionales para rellenar esos cinco segundos en comparación con una velocidad de fotogramas menor (lo que aumenta el tamaño de archivo total de la animación). Una animación de 5 segundos a 24 fps normalmente presenta un tamaño de archivo mayor que una animación de 5 segundos a 12 fps.

Nota:

cuando se utiliza un controlador de eventos onEnterFrame para crear animaciones mediante scripts, la animación se ejecuta a la velocidad de fotogramas del documento, de forma similar a si hubiera creado una interpolación de movimiento en una línea de tiempo. Una alternativa al controlador de eventos onEnterFrame es setInterval (consulte la Referencia del lenguaje ActionScript 2.0). En lugar de depender de la velocidad de fotogramas, se llama a las funciones a un intervalo especificado. Al igual que onEnterFrame, cuanto más frecuentemente se utilice setInterval para llamar a una función, mayor número de recursos del procesador utilizará la animación.

Utilice la menor velocidad de fotogramas posible que reproduzca la animación con suavidad durante la ejecución; esto contribuirá a reducir la carga en el procesador del usuario final. Las velocidades mayores (más de 30-40 fps) generan mucha carga en los procesadores y no cambian demasiado o en absoluto la apariencia de las animaciones durante la ejecución.

Seleccione una velocidad de fotogramas lo antes posible en el proceso de desarrollo. Cuando pruebe el archivo SWF, compruebe la duración y el tamaño de archivo SWF de la animación. La velocidad de fotogramas afecta enormemente a la velocidad de la animación.

Filtros y rendimiento de archivos SWF

Si utiliza demasiados filtros en una aplicación, corre el riesgo de utilizar grandes cantidades de memoria y esto podría afectar al rendimiento de Flash Player. Dado que un clip de película con filtros asociados cuenta con dos mapas de bits de 32 bits, si emplea muchos mapas de bits, puede hacer que la aplicación utilice gran cantidad de memoria. El sistema operativo del equipo puede generar un error de memoria insuficiente. En los equipos modernos, este tipo de errores son poco comunes, a menos que se empleen muchos efectos de filtro en una aplicación (por ejemplo, si tiene cientos de mapas de bits en el escenario).

Sin embargo, si encuentra un error de memoria insuficiente ocurre lo siguiente:

  • El conjunto de filtros se omite.

  • El clip de película se dibuja con el procesador de vectores normal.

  • No se almacena en caché ningún mapa de bits para el clip de película.

    Cuando se produce un error de memoria insuficiente, el clip de película ya no intenta utilizar el conjunto de filtros o la caché de mapa de bits. Otro factor que afecta al rendimiento del reproductor es el valor que utilice para el parámetro quality de cada filtro que aplique. Los valores mayores requieren más memoria y CPU para que el efecto se muestre, mientras que si el parámetro quality se establece en un valor menor, se requieren muchos menos recursos del equipo. Debe evitar utilizar un número excesivo de filtros y establecer el parámetro quality en un valor menor siempre que sea posible.

    nota: si se acerca con el zoom una vez un objeto de 100 por 100 píxeles, este utiliza cuatro veces más memoria, ya que las dimensiones del contenido son de 200 por 200 píxeles. Si lo acerca otras dos veces, la forma se dibuja como objeto de 800 por 800 píxeles que emplea 64 veces más memoria que el objeto de 100 por 100 píxeles original. Siempre que utilice filtros en un archivo SWF, desactive las opciones de menú de zoom del menú contextual del archivo SWF.

    Pueden producirse errores si emplea tipos de parámetros no válidos. Algunos parámetros de filtro tienen un rango válido concreto. Si establece un valor no incluido en el rango válido, el valor cambiará a un valor válido que se encuentre dentro del rango. Por ejemplo, para un funcionamiento normal, el valor del parámetro quality debe oscilar entre 1 y 3, y solo puede establecerse entre 0 y 15. Cualquier valor por encima de 15 se reduce a 15.

    Algunos constructores presentan restricciones en la longitud de los conjuntos necesarios como parámetros de entrada. Si se crea un filtro de convolución o de matriz de colores con un conjunto no válido (que no sea del tamaño correcto), se produce un error en el constructor y el filtro no se crea correctamente. A continuación, el objeto de filtro se omite si se utiliza como entrada en un conjunto de filtros de un clip de película.

    Sugerencia: cuando se utiliza un filtro de desenfoque, los valores de blurX y blurY que sean potencias de 2 (como 2, 4, 8, 16 y 32) se procesan más rápidamente y ofrecen una mejora del rendimiento de entre el 20 % y el 30 %.

Caché de mapa de bits y rendimiento de archivos SWF

La caché de mapa de bits permite mejorar el rendimiento de los clips de película que no cambian en las aplicaciones. Cuando se establecen las propiedades MovieClip.cacheAsBitmap o Button.cacheAsBitmap en true, Flash Player almacena en caché una representación de mapa de bits interno de la instancia de clip de película o de botón. Esto puede mejorar el rendimiento de los clips de película que tienen contenido vectorial complejo. Todos los datos vectoriales de un clip de película con un mapa de bits en caché se dibujan en el mapa de bits, no en el escenario principal.

Nota:

el mapa de bits se copia en el escenario principal como píxeles no expandidos ni rotados, pero ajustados a los límites del píxel más cercano. Los píxeles se asignan de 1 a 1 con el objeto principal. Si los límites del mapa de bits cambian, el mapa de bits se vuelve a crear en lugar de expandirse.

Para obtener información detallada sobre el botón de caché o las instancias de clips de película, consulte los temas siguientes:

  • Información sobre el almacenamiento en caché y el desplazamiento de clips de película con ActionScript en Aprendizaje de ActionScript 2.0

  • Almacenamiento en caché de un clip de película en Aprendizaje de ActionScript 2.0

    Utilice la propiedad cacheAsBitmap con clips de película que tienen sobre todo contenido estático y que no cambian de escala ni giran con frecuencia. Con estos clips, la propiedad cacheAsBitmap puede mejorar el rendimiento cuando se convierte el clip de película (cuando se modifican sus posiciones x e y).

    La activación de la caché para un clip de película crea una superficie, lo que presenta varias ventajas, como es la mayor velocidad de representación de animaciones vectoriales complejas. Hay situaciones en las que la activación de la caché no mejora el rendimiento e incluso lo reduce.

    El rendimiento global de los datos almacenados en caché depende de la complejidad de los datos vectoriales de las instancias, de la cantidad de datos que cambie y de si ha establecido la propiedad opaqueBackground. Si cambia zonas pequeñas, la diferencia entre el uso de una superficie y el uso de datos vectoriales puede ser insignificante. Pruebe ambas situaciones antes de desarrollar la aplicación.

Cuándo es conveniente utilizar la caché de mapa de bits

A continuación se incluyen situaciones típicas en las que pueden apreciarse ventajas significativas al activar la caché de mapa de bits mediante la optimización de gráficos vectoriales.

Imagen de fondo compleja

Una aplicación que contiene una imagen de fondo compleja y detallada de datos de vectoriales. Para mejorar el rendimiento, seleccione el contenido, almacénelo en un clip de película y establezca la propiedad opaqueBackground como true. El fondo se representa como mapa de bits y puede volverse a dibujar rápidamente, por lo que la animación se reproduce con mayor velocidad.

Campo de texto con desplazamiento

una aplicación que muestra una gran cantidad de texto en un campo de texto con desplazamiento. Coloque el campo de texto en un clip de película que establezca como desplazable con límites con desplazamiento (la propiedad scrollRect) para permitir un desplazamiento rápido por los píxeles de la instancia especificada. Cuando el usuario se desplaza por la instancia del clip de película, los píxeles desplazados se mueven hacia arriba y se genera la región recién expuesta en lugar de regenerar todo el campo de texto.

Sistema de ventanas

una aplicación con un complejo sistema de ventanas superpuestas. Cada ventana puede abrirse o cerrarse (por ejemplo, las ventanas de un navegador Web) Si marca cada ventana como una superficie (establece la propiedad cacheAsBitmap como true), cada ventana se aísla y se almacena en caché. Los usuarios pueden arrastrar las ventanas para que se puedan superponer y cada ventana no necesita regenerar el contenido vectorial.

Cuándo es conveniente evitar utilizar la caché de mapa de bits

La utilización inadecuada de la caché de mapa de bits puede afectar negativamente al archivo SWF. Al desarrollar un archivo FLA que utilice superficies, tenga en cuenta las siguientes directrices:

  • No haga un uso abusivo de las superficies (clips de película para los que está activada la caché). Cada superficie utiliza más memoria que un clip de película normal; utilice solo las superficies para mejorar el rendimiento de la representación.

  • Un mapa de bits en caché utiliza bastante más memoria que una instancia de clip de película normal. Por ejemplo, si el clip de película del escenario tiene un tamaño de 250 por 250 píxeles, al almacenarse en caché podría utilizar 250 KB en lugar de 1 KB cuando se trata de una instancia de clip de película normal (no está en caché).

  • Evite aplicar zoom a las superficies en caché. Si utiliza en exceso la caché de mapa de bits, se consume una gran cantidad de memoria (consulte el apartado anterior), especialmente si aumenta el contexto.

  • Utilice superficies para instancias de clips de película que sean principalmente estáticas (sin animación). Puede arrastrar o mover la instancia, pero el contenido de la instancia no debe incluir demasiada animación ni cambiar mucho. Por ejemplo, si gira o transforma una instancia, esta cambia entre la superficie y los datos vectoriales, lo que dificulta el procesamiento y afecta de forma negativa al archivo SWF.

  • Si mezcla superficies con datos vectoriales, aumentará la cantidad de procesamiento que debe llevar a cabo Flash Player (y, a veces, el equipo). Agrupe las superficies; por ejemplo, al crear aplicaciones de ventanas.

Trabajo con componentes en Flash Player

La arquitectura de componentes permite añadirles funcionalidad, pero también puede hacer que el tamaño de los archivos de la aplicación aumente considerablemente. Los componentes heredan entre sí. Un componente aumenta el tamaño del documento de Animate, pero los siguientes componentes que utilizan la misma arquitectura no tienen por qué aumentar el tamaño. A medida que va añadiendo componentes en el escenario, el tamaño del archivo aumenta, pero llegado a un punto, deja de aumentar porque los componentes comparten clases y no necesitan volver a cargar copias de dichas clases.

Si utiliza varios componentes que no comparten la misma arquitectura, podrían aumentar sustancialmente el tamaño del archivo SWF. Por ejemplo, el componente XMLConnector añade 17 K al archivo SWF y los componentes TextInput añaden 24 K al documento. Si añade el componente ComboBox, añadirá 28 K, ya que no forma parte de ninguna arquitectura de los componentes anteriores. Como el componente XMLConnector utiliza vinculación de datos, las clases añaden 6 K al archivo SWF. Un documento que utilice todos estos componentes ocupará 77 K antes de añadirle nada más. Analice con detenimiento el tamaño del archivo SWF cuando añada un nuevo componente al documento.

Los componentes deben estar presentes en la biblioteca del archivo SWF principal. Por ejemplo, una aplicación debe tener una copia de los componentes que utilice en su biblioteca, incluso aquéllos requeridos solo por archivos SWF secundarios que se cargan en tiempo de ejecución. Esto es necesario para garantizar que el funcionamiento correcto de los componentes y reduce sensiblemente el tiempo de descarga del archivo SWF principal. Sin embargo, la biblioteca principal no se hereda ni se comparte en los archivos SWF cargados en la biblioteca principal. Cada archivo SWF secundario se debe descargar en la aplicación con su propia copia de los mismos componentes.

Si planifica publicar un archivo SWF con compatibilidad retroactiva debe conocer bien los componentes que ofrecen esta capacidad. La tabla siguiente contiene información sobre la disponibilidad de componentes en diferentes versiones de Flash Player:

Componentes

Flash Player 6 (6.0.65.0) y versiones anteriores

Flash Player 6 (6.0.65.0)

Flash Player 7 y 8

Flash Player 9

ActionScript 3.0

No se admite

No se admite

No se admite

Se admite

ActionScript 2.0

Se admite

Se admite

Se admite

Se admite

Conjunto de componentes V2 UI

No se admite

Se admite

Se admite

Se admite

Componentes multimedia

No se admite

No se admite

Se admite

Se admite

Componentes Data

No se admite

No se admite

Se admite

Se admite

Desactive la opción Optimizar para Flash Player 6r65 en Configuración de publicación para que funcionen los componentes V2 UI.

Optimización de estilos de componentes y rendimiento

Cuando se utiliza ActionScript 2.0, una de las llamadas que más recursos consume del procesador en una arquitectura de componentes es setStyle. La llamada setStyle se ejecuta de forma eficaz, pero consume recursos por el modo en que se implementa. Esta llamada setStyle no siempre se necesita en todas las aplicaciones, pero si la quiere utilizar, debe tener en cuenta cómo afecta al rendimiento.

Para mejorar el rendimiento puede cambiar estilos antes de cargarlos, calcularlos y aplicarlos a los objetos del archivo SWF. Si cambia los estilos antes de cargarlos y calcularlos, no tendrá que llamar a setStyle.

Se recomienda establecer las propiedades en cada objeto, ya que se crean instancias de los objetos para mejorar el rendimiento cuando se utilizan estilos. Cuando añada dinámicamente instancias al escenario, establezca las propiedades en el parámetro initObj en la llamada que realice a createClassObject(), como muestra el siguiente código ActionScript:

createClassObject(ComponentClass, "myInstance", 0, {styleName:"myStyle", color:0x99CCFF});

En el caso de instancias que coloque directamente en el escenario, puede utilizar onClipEvent() para cada instancia, o puede utilizar subclases (recomendado). Para obtener información sobre las subclases, consulte la sección sobre la escritura de subclases en Aprendizaje de ActionScript 2.0.

Si debe volver a aplicar estilos a los componentes, puede utilizar el componente Loader para mejorar la eficacia de la aplicación. Para implementar varios estilos en distintos componentes, coloque cada componente en su propio archivo SWF. Si cambia los estilos del componente Loader y vuelve a cargar el archivo SWF, los componentes del archivo SWF se vuelven a crear. Tras crear de nuevo el componente, se vacía la caché de los estilos y el estilo del componente se restablece para volver a hacer referencia a él.

Nota:

para aplicar un solo estilo a todas las instancias de un componente del archivo SWF, cambie el estilo de forma global mediante _global.styles.ComponentName.

Utilización de bibliotecas compartidas en tiempo de ejecución

A veces es posible mejorar el tiempo de descarga mediante el uso de bibliotecas compartidas en tiempo de ejecución. Estas bibliotecas suelen ser necesarias en aplicaciones más grandes o si muchas aplicaciones de un sitio utilizan los mismos componentes o símbolos. Mediante la externalización de los activos comunes de los archivos SWF, no se descargan las clases de forma repetida. El primer archivo SWF que utiliza una biblioteca compartida tiene un tiempo de descarga mayor, ya que se carga tanto el archivo SWF como la biblioteca. La biblioteca se almacena en la caché del equipo del usuario y el resto de archivos SWF utilizan la biblioteca. Este proceso puede mejorar significativamente el tiempo de descarga en aplicaciones más grandes.

Visualización de caracteres especiales

Los sistemas informáticos disponen de páginas específicas de código regional. Por ejemplo, un equipo japonés y un equipo británico tienen páginas de codificación distintas. En Flash Player 5 y versiones anteriores, se utilizaba la página de codificación para mostrar texto; en Flash Player 6 y versiones posteriores, se utiliza Unicode. Unicode es un método más fiable y estandarizado para mostrar texto, ya que es un conjunto de caracteres universales con caracteres para todos los idiomas. Las aplicaciones más habituales utilizan Unicode.

Se pueden utilizar secuencias de escape de Unicode para mostrar caracteres especiales en Flash Player 6 y versiones posteriores. Sin embargo, no todos los caracteres se muestran correctamente si no se carga texto con codificación UTF‑8 o UTF‑16 (Unicode) o si no se utiliza una secuencia de escape de Unicode para mostrar los caracteres especiales. Para consultar tablas de código Unicode, visite el sitio web de Unicode en Unicode.org. Para obtener una lista de las secuencias de escape más utilizadas, consulte la tabla que se incluye en esta sección.

Una aplicación que no utilice Unicode recurre a la página de códigos del sistema operativo para representar los caracteres. En ese caso, la página de códigos especifica los caracteres que se ven, por lo que estos se mostrarán correctamente solo si la página de códigos del sistema operativo del usuario coincide con la página de códigos de la aplicación. La página de códigos utilizada para crear el archivo SWF debe coincidir con la página de códigos del equipo del usuario final. No es buena idea utilizar páginas de código para aplicaciones destinadas a un público internacional; en ese caso, se recomienda utilizar Unicode.

El uso de System.useCodepage en el código obliga al archivo SWF a utilizar la página de códigos del sistema en lugar de Unicode.

Utilice este proceso solamente si está cargando texto con codificación distinta de Unicode desde una ubicación externa y si el texto está codificado con la misma página de códigos que el equipo del cliente. Si se cumplen ambas condiciones, el texto se mostrará sin problemas. Si no se cumple ninguna de las condiciones, utilice codificación Unicode y una secuencia de escape de Unicode para aplicar formato al texto. Para utilizar una secuencia de escape, añada el siguiente código ActionScript 2.0 en el fotograma 1 de la línea de tiempo:

this.createTextField("myText_txt", 99, 10, 10, 200, 25); 
myText_txt.text = "this is my text, \u00A9 2004";

Este código ActionScript crea un campo de texto y escribe texto con un símbolo de copyright (©) en el campo de texto.

Puede hacer que un archivo SWF utilice la página de códigos del sistema operativo, controlada por la propiedad useCodepage. Cuando Animate exporta un archivo SWF, exporta de forma predeterminada texto Unicode ySystem.useCodepage se establece en false. Surgirán problemas para mostrar texto especial o texto en sistemas internacionales, y recurrir a la página de códigos del sistema puede parecer la solución a la visualización incorrecta del texto. No obstante, el uso de System.useCodePage siempre debe tomarse como último recurso.

Para utilizar la página de códigos del sistema, coloque la siguiente línea de código ActionScript 2.0 en el fotograma 1 de la línea de tiempo:

System.useCodepage = true;
<< need an AS3 example here as well. See
dev/qa. >>

Nota:

aparecerá un carácter especial únicamente si el equipo del usuario tiene el carácter incluido en la fuente que se esté utilizando. Si no está seguro, incorpore el carácter o la fuente en el archivo SWF.

La tabla siguiente contiene diversas secuencias de escape de Unicode que se utilizan con frecuencia.

Descripción del carácter

Secuencia de escape de Unicode

guión largo ()

\u2014

símbolo registrado (®)

\u00AE

símbolo de copyright (©)

\u00A9

símbolo de marca comercial (™)

\u2122

símbolo de euro ()

\u20AC

barra invertida (\)

\u005C

barra diagonal (/)

\u002F

llave inicial ({)

\u007B

llave final (})

\u007D

mayor que (<)

\u003C

menor que (>)

\u003E

asterisco (*)

\u002A

Comprobación del rendimiento de descarga de documentos

Flash Player intenta alcanzar la velocidad de fotogramas establecida por el usuario (la velocidad de fotogramas real durante la reproducción puede variar según el equipo). Si un documento que se está descargando llega a un fotograma determinado antes de que se hayan descargado los datos necesarios para ese fotograma, el documento efectúa una pausa hasta que lleguen los datos.

Para ver una representación gráfica del rendimiento de la descarga, utilice el Visor de anchos de banda, que muestra el volumen de datos que se envía para cada fotograma de acuerdo con la velocidad de módem especificada.

nota: (Solo Animate CC) El Visor de anchos de banda no está disponible con Animate CC. Ahora puede usar Adobe Scout con Animate. Consulte Uso de Adobe Scout con Animate para obtener más información.

Para simular la velocidad de descarga, Animate utiliza cálculos que se basan en rendimientos de Internet típicos en lugar de la velocidad exacta del módem. Por ejemplo, si opta por simular una velocidad de módem de 28,8 Kbps, Animate establece la velocidad real en 2,3 Kbps para reflejar un rendimiento de Internet típico. El visor también compensa el soporte de compresión suplementaria para los archivos SWF, lo que reduce el tamaño del archivo y mejora el rendimiento del flujo.

Cuando los archivos SWF externos, los archivos GIF y XML y las variables fluyen a un reproductor mediante llamadas de ActionScript, como por ejemplo loadMovie y getUrl, los datos fluyen a la velocidad establecida para el flujo. La velocidad de flujo para el archivo SWF principal se reduce de acuerdo con la reducción de ancho de banda provocado por las peticiones de datos adicionales. Pruebe el documento para cada velocidad y equipo que desee utilizar para asegurarse de que el documento no sobrecargará la conexión y el equipo más lento para el que está diseñado.

También puede generar un informe de los fotogramas que ralentizan la reproducción y luego optimizar o eliminar parte del contenido de estos fotogramas.

Para cambiar la configuración del archivo SWF creado con los comandos Probar película y Probar escena, elija Archivo > Configuración de publicación.

Comprobación del rendimiento de descarga

  1. Realice uno de los siguientes pasos:
    • Seleccione Control > Probar escena, o bien Control > Probar.

      Si prueba una escena o un documento, Animate publicará la selección activa como archivo SWF utilizando las configuraciones en el cuadro de diálogo Configuración de publicación. El archivo SWF se abre en una nueva ventana y empieza a reproducirse de inmediato.

    • Seleccione Archivo > Abrir y seleccione un archivo SWF.

  2. Seleccione Ver > Configuración de descarga y seleccione una velocidad de descarga para determinar la velocidad del flujo de datos simulada por Animate. Para introducir una configuración de usuario, seleccione Personalizar.

  3. Cuando vea el archivo SWF, seleccione Ver > Visor de anchos de banda para mostrar un gráfico del rendimiento de descarga.

    El lado izquierdo del visor muestra información sobre el documento, la configuración, el estado y los flujos, si se han incluido en el documento.

    En la sección derecha del visor aparece el encabezado y el gráfico de la línea de tiempo. En el gráfico, cada barra representa un fotograma individual del documento. El tamaño de la barra corresponde al tamaño de ese fotograma en bytes. La línea roja situada debajo del encabezado de la línea de tiempo indica si un fotograma determinado fluye en tiempo real o no con la velocidad de módem configurada en el menú Control. Si una barra sobrepasa la línea roja, el documento debe esperar a que se cargue dicho fotograma.

    nota: (Solo Animate CC) El Visor de anchos de banda no está disponible con Animate CC. Ahora puede usar Adobe Scout con Animate. Consulte Uso de Adobe Scout con Animate para obtener más información.

     

  4. Elija Ver > Simular descarga para activar o desactivar el flujo.

    Si desactiva el flujo, el documento empieza de nuevo sin simular una conexión Web.

    nota: (Solo Animate CC) La opción de Simular descarga no está disponible en Animate CC.

     

  5. Haga clic en una barra del gráfico para mostrar la configuración para el fotograma correspondiente en la ventana izquierda y detener el documento.
  6. En caso necesario, ajuste la vista del gráfico por uno de estos procedimientos:
    • Seleccione Ver > Gráfico de flujo para mostrar los fotogramas que provocan pausas.

      Esta vista predeterminada muestra bloques gris claro y oscuro que representan a cada fotograma. En el lateral de cada bloque se indica su tamaño en bytes relativo. El primer fotograma guarda el contenido del símbolo y suele ser más grande que otros fotogramas.

    • Seleccione Ver > Gráfico fotograma por fotograma para mostrar el tamaño de cada fotograma.

      Esta vista le ayudará a ver los fotogramas que contribuyen a las demoras de flujo. Si algún bloque de fotograma se extiende por encima de la línea roja en el gráfico, Flash Player detendrá la reproducción hasta que se descargue todo el fotograma.

  7. Cierre la ventana de prueba para regresar al entorno de edición.

    Una vez que haya configurado un entorno de prueba mediante el Visor de anchos de banda, podrá abrir cualquier archivo SWF directamente en el entorno de prueba. El archivo se abre en una ventana de Flash Player utilizando el Visor de anchos de banda y otras opciones de visualización seleccionadas.

    nota: (Solo Animate CC) El Visor de anchos de banda no está disponible con Animate CC. Ahora puede usar Adobe Scout con Animate. Consulte Uso de Adobe Scout con Animate para obtener más información.

     

Generación de un informe final

  1. Seleccione Archivo > Configuración de publicación y haga clic en la ficha Animate.

  2. Seleccione Generar informe de tamaño.
  3. Haga clic en Publicar.

    Animate generará un archivo de texto con la extensión .txt. (Si el archivo del documento es myMovie.fla, el archivo de texto será myMovie Report.txt.) En el informe se indica el tamaño, forma, texto, sonido, vídeo y script de ActionScript de cada fotograma.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea