Las interpolaciones clásicas son un método habitual de crear animaciones en Animate. Estas interpolaciones son parecidas a las interpolaciones de movimiento más recientes, aunque resultan algo más complicadas de crear y ofrecen menos flexibilidad. No obstante, las interpolaciones clásicas proporcionan algunos tipos de control en la animación que las interpolaciones de movimiento no ofrecen. La mayoría de los usuarios prefieren trabajar con las interpolaciones de movimiento más nuevas, pero algunos siguen queriendo usar las interpolaciones clásicas. Para obtener más información sobre las diferencias, consulte Diferencias entre interpolaciones de movimiento e interpolaciones clásicas.

Antes de comenzar:

Para poder trabajar con interpolaciones clásicas, debe tener en cuenta lo siguiente:

  • Las interpolaciones clásicas son una forma más antigua de crear animaciones interpoladas en Animate. La forma más nueva y sencilla de hacerlo es usar las interpolaciones de movimiento. Consulte Animación de interpolación de movimiento.

  • No es posible interpolar propiedades 3D con interpolaciones clásicas.

Para ver ejemplos de animación de interpolación clásica, consulte la página de ejemplos de Animate en www.adobe.com/go/learn_fl_samples_es. Están disponibles los siguientes ejemplos:

  • Sombras animadas: descargue y descomprima el archivo ZIP de ejemplos y vaya a la carpeta Graphics\AnimatedDropShadow para acceder al ejemplo.

  • Animación y degradados: descargue y descomprima el archivo ZIP de ejemplos y vaya a la carpeta Graphics\AnimationAndGradients para acceder al ejemplo.

Nota:

Como la mayoría de las cosas en Animate, la animación no requiere ActionScript. Sin embargo, puede crear animaciones con ActionScript si lo desea.

Creación y edición de fotogramas clave para interpolaciones clásicas de movimiento

Los cambios realizados en una animación de interpolación clásica se definen en un fotograma clave. En la animación interpolada, se definen fotogramas clave en puntos significativos de la animación y Animate crea el contenido de los fotogramas intermedios. Los fotogramas interpolados se muestran en azul claro con una flecha entre los fotogramas clave. Como los documentos de Animate guardan las formas en cada fotograma clave, solamente hay que crear fotogramas clave en los puntos de las ilustraciones en los que se produzca alguna modificación.

Los fotogramas clave se indican en la línea de tiempo. Un círculo sólido representa un fotograma con contenido y un círculo vacío delante del fotograma representa uno vacío. Los fotogramas siguientes añadidos a la misma capa tendrán el mismo contenido que el fotograma clave.

Únicamente los fotogramas clave se pueden editar en una interpolación clásica. Puede ver fotogramas interpolados, pero no editarlos directamente. Para editar fotogramas interpolados, cambie uno de los fotogramas clave de definición o inserte un nuevo fotograma clave entre el inicial y el final. Arrastre un elemento desde el panel Biblioteca hasta el escenario y añada elementos al fotograma clave actual.

Para ver y editar varios fotogramas a la vez, consulte Utilización de papel cebolla.

Nota:

Este tema trata de la creación de fotogramas clave para interpolaciones clásicas antiguas. Para obtener más información acerca de los fotogramas clave de propiedades de interpolaciones de movimiento más nuevas, consulte Creación de una animación de interpolación.

Creación de fotogramas clave

  1. Realice uno de los siguientes pasos:
    • Seleccione un fotograma en la línea de tiempo y elija Insertar > Línea de tiempo > Fotograma clave.

    • Haga clic con el botón derecho del ratón (Windows) o con la tecla Control presionada (Macintosh) en un fotograma de la línea de tiempo y elija Insertar fotograma clave.

Inserción de fotogramas en la línea de tiempo

  • Para insertar un fotograma nuevo, seleccione Insertar > Línea de tiempo > Fotograma.

  • Para crear un fotograma clave, seleccione Insertar > Línea de tiempo > Fotograma clave, o haga clic con el botón derecho (Windows) o con la tecla Control presionada (Macintosh) en el fotograma para colocar el fotograma clave. Seleccione Insertar fotograma clave.

  • Para crear un fotograma clave en blanco, seleccione Insertar > Línea de tiempo > Fotograma clave en blanco, o haga clic con el botón derecho (Windows) o con la tecla Control presionada (Macintosh) en el fotograma para colocar el fotograma clave. Seleccione Insertar fotograma clave en blanco.

Eliminación o modificación de un fotograma o un fotograma clave

  • Para eliminar un fotograma, fotograma clave o secuencia de fotograma, selecciónelo y haga clic con el botón derecho (Windows) o con la tecla Control presionada (Macintosh) y seleccione Quitar fotogramas. Los fotogramas de alrededor permanecen intactos.

  • Para mover un fotograma clave o una secuencia de fotograma y su contenido, selecciónelo y arrástrelo hasta la ubicación deseada.

  • Para extender la duración de un fotograma clave, con la tecla Alt (Windows) o la tecla Opción (Macintosh) presionada, arrástrelo hasta el fotograma final de la nueva secuencia.

  • Para copiar y pegar un fotograma o una secuencia de fotogramas, selecciónelo y elija Edición > Línea de tiempo > Copiar fotogramas. Seleccione el fotograma o la secuencia que va a sustituir y elija Edición > Línea de tiempo > Pegar fotogramas. Para pegar y sustituir el número exacto de fotogramas copiados en la línea de tiempo de destino, utilice la función Pegar y sobrescribir fotogramas.

  • Para convertir un fotograma clave en un fotograma, seleccione el fotograma clave y elija Modificar > Línea de tiempo > Borrar fotograma clave, o haga clic con el botón derecho del ratón (Windows) o con la tecla Control presionada (Macintosh) en el fotograma y seleccione Borrar fotograma clave. El fotograma clave eliminado y todos los fotogramas hasta el fotograma clave siguiente se sustituirán con el contenido del fotograma que preceda al fotograma clave eliminado.

  • Para copiar un fotograma clave o una secuencia de fotogramas arrastrando, selecciónelo y arrástrelo hasta la nueva ubicación con la tecla Alt (Windows) u Opción (Macintosh) presionada.

  • Para cambiar la longitud de una secuencia interpolada, arrastre el fotograma clave inicial o final a la derecha o la izquierda.

  • Para añadir un elemento de la biblioteca al fotograma clave actual, arrastre el elemento desde el panel Biblioteca hasta el escenario.

  • Para invertir una secuencia de animación, seleccione los fotogramas adecuados en una o varias capas y elija Modificar > Línea de tiempo > Invertir fotogramas. Los fotogramas clave deben estar al principio y al final de la secuencia.

Adición de animación de interpolación clásica a una instancia, grupo o texto

Nota:

Este tema trata de la creación de interpolaciones clásicas antiguas. Para obtener más información acerca de la creación de las nuevas interpolaciones de movimiento, consulte Creación de una animación de interpolación.

Para interpolar los cambios en propiedades de instancias, grupos y tipo, se puede usar una interpolación clásica. Animate puede interpolar la posición, el tamaño y la rotación, así como sesgar instancias, grupos y tipo. También puede interpolar el color de las instancias y el tipo para crear cambios graduales de color o para hacer aparecer o desaparecer instancias de forma paulatina.

Antes de interpolar el color de grupos o tipos, conviértalos en símbolos. Antes de animar caracteres individuales de un bloque de texto por separado, coloque cada carácter en un bloque de texto distinto.

Si aplica una interpolación clásica y cambia el número de fotogramas entre dos fotogramas clave, Animate vuelve a interpolar automáticamente entre ellos. O, si mueve el grupo o símbolo en cualquiera de los fotograma clave, Animate vuelve a interpolar automáticamente entre ellos.

 

Creación de una animación de interpolación de movimiento

  1. Para hacer que una capa sea la capa activa, haga clic en un nombre de capa y seleccione un fotograma clave vacío en la misma para comenzar. Este será el primer fotograma de la interpolación clásica.

  2. Para agregar contenido el primer fotograma de la interpolación clásica, siga uno de estos procedimientos:
    • Cree un objeto gráfico con la herramienta Pluma, Óvalo, Rectángulo, Lápiz o Pincel y conviértalo en un símbolo.

    • Cree una instancia, un grupo o un bloque de texto en el escenario.

    • Arrastre una instancia de un símbolo del panel Biblioteca.

    Nota:

    para crear una interpolación, la capa solo puede tener un elemento.

  3. Cree un segundo fotograma clave donde desee que acabe la animación y déjelo seleccionado.
  4. Para modificar el elemento en el último fotograma, realice una de las siguientes acciones:
    • Mueva el elemento a una nueva posición.

    • Modifique el tamaño, rotación o sesgo del elemento.

    • Modifique el color del elemento (solo instancia o bloque de texto). Para interpolar el color de los elementos distintos de instancias o bloques de texto, utilice interpolación de formas.

  5. Para crear la interpolación clásica, realice una de las acciones siguientes:
    • Haga clic en cualquier fotograma del grupo de fotogramas de la interpolación y seleccione Insertar > Interpolación clásica.

    • Haga clic con el botón derecho (Windows) o mantenga presionado Control y haga clic (Macintosh) en cualquier fotograma del grupo de fotogramas de la interpolación y seleccione Crear interpolación clásica en el menú contextual.

    Si creó un objeto gráfico en el paso 2, Animate lo convierte automáticamente en un símbolo y le poner el nombre tween1.

  6. Para interpolar el tamaño del elemento seleccionado, seleccione la escala en la sección de interpolación del inspector de propiedades. Como requisito previo, se modifica el tamaño del elemento en el paso 4.

  7. Para obtener un efecto de movimiento más real, aplique suavizado a la interpolación clásica. Para aplicar la aceleración a una interpolación clásica, utilice el campo Aceleración de la sección Interpolación del inspector de propiedades. Utilice el cuadro de diálogo Aceleración personalizada para controlar de forma más precisa la velocidad de la interpolación clásica.

    Para ajustar la velocidad de cambio entre fotogramas interpolados, arrastre el valor en el campo Aceleración o introduzca un valor.

    • Para iniciar la interpolación clásica lentamente y acelerar la interpolación hacia el final de la animación, indique un valor negativo entre -1 y -100.

    • Para iniciar la interpolación clásica rápidamente y desacelerar la interpolación al final de la animación, utilice un valor positivo desde 1 hasta 100.

    • Para producir un cambio de velocidad más complejo dentro del lapso de fotograma de la interpolación, haga clic en el botón Editar junto al campo Aceleración. Se abre el cuadro de diálogo Aceleración personalizada.

      De forma predeterminada, la velocidad de cambio entre los fotogramas interpolados es constante. La opción Aceleración crea una apariencia más natural de aceleración o ralentización ajustando gradualmente la velocidad de cambio.

  8. Para rotar el elemento seleccionado durante la interpolación, seleccione una opción del menú Rotar en el inspector de propiedades:
    • Para impedir la rotación, seleccione Ninguna (configuración predeterminada).

    • Para girar el objeto una vez en la dirección que requiera el mínimo movimiento, seleccione Auto.

    • Para rotar el objeto de la forma indicada, e introducir un número para especificar el número de rotaciones, seleccione Hacia la derecha o Hacia la izquierda.

    Nota:

    la rotación del paso 8 se añade a la rotación que haya aplicado al fotograma final en el paso 4.

  9. Si está utilizando un trazado de movimiento, seleccione Orientar según trazado en el inspector de propiedades para orientar la línea de base del elemento interpolado hacia dicho trazado.
  10. Para sincronizar la animación de las instancias de símbolos de gráficos con la línea de tiempo principal, seleccione la opción Sinc. del Inspector de propiedades.

    Nota:

    Tanto Sincronizar símbolos como la opción Sinc. vuelven a calcular el número de fotogramas de una interpolación para ajustar el número de fotogramas asignados. Utilice la opción Sinc. si los fotogramas en una secuencia de animación no son un múltiplo par del número de fotogramas en la instancia de gráfico.

  11. Si está utilizando un trazado de movimiento, seleccione Ajustar para asociar el elemento interpolado al trazado de movimiento por su punto de registro.

Trabajo con interpolaciones clásicas guardadas como archivos XML

Animate permite trabajar con interpolaciones clásicas como archivos XML. De forma nativa, Animate permite aplicar los siguientes comandos a cualquier interpolación clásica:

  • Copiar movimiento como XML

  • Exportar movimiento como XML

  • Importar movimiento como XML

Copiar movimiento como XML

Permite copiar las propiedades de movimiento aplicadas a cualquier objeto del escenario en un fotograma determinado. 

  1. Crear una interpolación clásica.

  2. Seleccione cualquier fotograma clave de la línea de tiempo.

  3. Vaya a Comandos > Copiar movimiento como XML.

Las propiedades de movimiento se copian en el portapapeles como datos XML. A continuación, puede utilizar cualquier editor de texto para modificar el archivo XML.

Exportar movimiento como XML

Permite exportar las propiedades de movimiento aplicadas a cualquier objeto del escenario a un archivo XML que puede guardarse.

 

  1. Crear una interpolación clásica. 

  2. Vaya a Comandos > Exportar movimiento como XML.

  3. Localice la ubicación adecuada en la que quiera guardar el archivo.

  4. Asigne un nombre al archivo XML y haga clic en Guardar.

    La interpolación clásica se exporta como archivo XML en la ubicación especificada.

Importar movimiento como XML

Permite importar un archivo XML existente con propiedades de movimiento definidas.

  1. Seleccione un objeto del escenario.

  2. Vaya a Comandos > Importar movimiento como XML.

  3. Localice la ubicación y seleccione el archivo XML. Haga clic en Aceptar.

  4. En el cuadro de diálogo Pegar movimiento especial, seleccione las propiedades que desee aplicar al objeto seleccionado.

  5. Haga clic en Aceptar.

Adición de una capa de guía de movimiento

Para controlar el movimiento de los objetos en una interpolación clásica, cree una capa de guía de movimiento.

No es posible arrastrar una capa de interpolación de movimiento ni una capa de pose de cinemática inversa hacia una capa de guía.

  1. Arrastre una capa normal hacia una capa de guía. Esta acción convierte la capa de guía en una capa de guía de movimiento y la capa normal se vincula a la nueva capa de guía de movimiento.

    Nota:

    Para evitar la conversión de forma accidental de una capa de guía, sitúe todas las capas de guía en la parte inferior del orden de las capas.

Creación de animación de interpolación clásica a lo largo de un trazado

Nota:

Este tema trata del trabajo con interpolaciones clásicas antiguas. Para obtener más información acerca de las interpolaciones de movimiento más nuevas con trazados de movimiento, consulte Edición del trazado de movimiento de una animación interpolada.

Las capas de guía de movimiento permiten dibujar trazados a lo largo de los cuales se animan instancias, grupos y bloques de texto interpolados. Puede vincular varias capas a una capa de guías de movimiento para hacer que varios objetos sigan el mismo trazado. Al vincular una capa normal a una capa de guías de movimiento se convierte en un tipo de capa con guía.

Trazado de movimiento
En este ejemplo, dos objetos de capas diferentes se asocian al mismo trazado de movimiento.

Creación de un trazado de movimiento en una animación interpolada clásica

  1. Cree una secuencia de animación interpolada clásica.

    Si selecciona Orientar según trazado en el inspector de propiedades, la línea de base del elemento interpolado se orientará hacia el trazado de movimiento. Si selecciona Ajustar, el punto de registro del elemento interpolado se ajustará en el trazado de movimiento.

  2. Haga clic con el botón derecho (Windows) o presione la tecla Control y haga clic (Macintosh) en el nombre de la capa que contiene la interpolación clásica y seleccione Añadir guía de movimiento clásico.

    Animate añade una capa de guía de movimiento sobre la capa de interpolación clásica y aplica sangría al nombre de la capa de interpolación clásica. Así representa que esta capa está vinculada a la capa de guía de movimiento.

    Nota:

    Si ya tiene una capa de guía en la línea de tiempo, puede arrastrar una capa que contenga la interpolación clásica bajo la capa de guía. Esta acción convierte la capa de guía a un guía de movimiento y asocia a ella la interpolación clásica.

    Capa de guía de movimiento
    Una capa de guía de movimiento sobre la capa que contiene la interpolación clásica.
  3. Para añadir un trazado a la capa de guía de movimiento, seleccione esta y utilice las herramientas Pluma, Lápiz, Línea, Círculo, Rectángulo o Pincel.

    También puede pegar un trazo en la capa de guía de movimiento.

  4. Arrastre el objeto que está interpolando para ajustarlo al principio del primer fotograma o al final del último fotograma.

    Gráfico ajustado al principio de un trazo de guía
    Gráfico de un coche ajustado al principio de un trazo de guía.

    Nota:

    para conseguir un ajuste óptimo, arrastre el símbolo por su punto de transformación.

  5. Para ocultar la capa de guía de movimiento y el trazado, haga clic en la columna del icono de ojo en la capa de guía de movimiento. En este caso, el movimiento de los objetos solo será visible mientras trabaja. 

    El grupo o símbolo sigue el trazado del movimiento al reproducir la animación.

Para obtener más información sobre la guía de animación basada en trazos de anchura variable y colores de trazo variable, consulte la Guía de animación

  1. Realice uno de los siguientes pasos:
    • Arrastre una capa existente bajo la capa de guías de movimiento. La capa se inserta debajo de ella. Todos los objetos de esta capa se ajustan de forma automática en el trazado del movimiento.

    • Cree una capa bajo la capa de guías de movimiento. Los objetos que interpole en esta capa se interpolan de forma automática en el trazado del movimiento.

    • Seleccione una capa debajo de una capa de guías de movimiento. Seleccione Modificar > Línea de tiempo > Propiedades de capa y elija Guía.

  1. Para desvincular, seleccione la capa y realice uno de los siguientes pasos:

    • Arrastre la capa encima de la capa de guías de movimiento.

    • Seleccione Modificar > Línea de tiempo > Propiedades de capa y elija Normal como tipo de capa.

Pegado de propiedades de animación de interpolaciones clásicas

Nota:

Este tema trata de cómo pegar propiedades de interpolaciones clásicas antiguas. Para obtener más información acerca del modo de pegar propiedades de interpolaciones de movimiento más nuevas, consulte Copiar y pegar propiedades de interpolación de movimiento.

El comando Pegar movimiento permite copiar una interpolación clásica y pegar únicamente determinadas propiedades con el fin de aplicarlas a otro objeto.

  1. Seleccione los fotogramas en la línea de tiempo que contiene la interpolación clásica que desea copiar. Los fotogramas seleccionados deben estar en la misma capa, sin embargo, no es preciso que abarquen una única interpolación clásica. La selección puede comprender una interpolación, fotogramas vacíos o dos o más interpolaciones.
  2. Seleccione Edición > Línea de tiempo > Copiar movimiento.

  3. Para recibir la interpolación clásica copiada, seleccione la instancia del símbolo.

  4. Seleccione Edición > Línea de tiempo > Pegar movimiento especial. Seleccione las propiedades específicas de la interpolación clásica que va a pegar en la instancia de símbolo. Las propiedades de interpolación clásica son:

    Posición X

    Hasta dónde se mueve un objeto en la dirección horizontal.

    Posición Y

    Hasta dónde se mueve un objeto en la dirección vertical.

    Escala horizontal

    La relación entre el tamaño actual del objeto y su tamaño natural en la dirección horizontal (X).

    Escala vertical

    La relación entre el tamaño actual del objeto y su tamaño natural en la dirección vertical (Y).

    Rotación y sesgo

    La rotación y el sesgo del objeto. Estas propiedades deben aplicarse a un objeto de forma conjunta. El sesgo es una medida de la rotación en grados. Cuando se rota y se sesga, cada propiedad afecta a la otra.

    Color

    Todos los valores de color, como tinta, brillo y alfa se aplican al objeto.

    Filtros

    Todos los valores y cambios en los filtros para el intervalo seleccionado. Si se aplican filtros a un objeto, el filtro se pega con todos los valores intactos y su estado (activado o desactivado) se aplica.

    Modo de mezcla

    Aplica el modo de mezcla al objeto.

    Suplantar propiedades de escala de destino

    Cuando no está activada esta opción, especifica que todas las propiedades se peguen en relación al objeto de destino. Si está activada, esta opción no aplica las propiedades de escala del destino.

    Suplantar propiedades de rotación y sesgo de destino

    Cuando no está activada esta opción, especifica que todas las propiedades se peguen en relación al objeto de destino. Cuando está activada, las propiedades pegadas omiten las propiedades de rotación y escala existentes del objeto.

    Se insertan los fotogramas, interpolación e información de símbolos correspondientes a la interpolación original que se ha copiado.

    Para copiar una interpolación clásica de símbolos en el panel Acciones o utilizarla en otro proyecto como ActionScript, utilice el comando Copiar movimiento como ActionScript 3.0.

Creación de ajustes preestablecidos de aceleración

Los ajustes preestablecidos de aceleración son aceleraciones preconfiguradas que se pueden aplicar a un objeto del escenario.

Hay disponible un conjunto de ajustes preestablecidos de aceleración de uso común para interpolación clásica. Podrá seleccionar el que desee en una lista de ajustes preestablecidos de aceleración y aplicarlo a la propiedad seleccionada.

  1. Haga clic en la capa que contenga una interpolación en la línea de tiempo de Animate.

  2. Para abrir las propiedades de interpolación, haga clic en la categoría Interpolación en el panel de propiedades. Puede acceder a la aceleración de propiedades utilizando la lista desplegable de tipos de aceleración.

    Propiedades de interpolación
    Propiedades de interpolación

    Puede aplicar los ajustes preestablecidos de aceleración de propiedades para las interpolaciones clásicas. En el panel de propiedades, encontrará una opción para elegir la aceleración de propiedades. Puede seleccionar Cada propiedad por separado para aplicar distintos ajustes preestablecidos de aceleración a cada propiedad. 

    ajustes preestablecidos de propiedades
    ajustes preestablecidos de propiedades

    Puede seleccionar ajustes preestablecidos de aceleración únicos para las propiedades de posición, rotación, escala, color y filtro de una interpolación clásica. 

    Posición Especifica la configuración de aceleración para la posición en el escenario de un objeto animado. 

    Rotación Especifica la configuración de aceleración para la rotación en el escenario de un objeto animado.

    Escala Especifica la configuración de aceleración para la escala en el escenario de un objeto animado.

    Color Especifica la configuración de aceleración para las transiciones de color aplicadas a un objeto animado en el escenario. 

    Filtros Especifica la configuración de aceleración para los filtros aplicada a un objeto animado en el escenario. 

  3. Si desea que la misma aceleración se aplique a todas las propiedades de la interpolación, también puede seleccionar la opción Todas las propiedades a la vez. Seleccione el ajuste preestablecido de aceleración que desee en el cuadro de diálogo emergente de tipos de aceleración y, a continuación, haga doble clic en el ajuste preestablecido para aplicarlo. 

    Si decide aplicar la aceleración clásica, también puede aumentar o disminuir la intensidad de la aceleración moviendo el regulador. 

    Lista de ajustes preestablecidos de aceleración
    Lista de ajustes preestablecidos de aceleración
  4. Haga clic en el icono Editar situado junto a Aceleración para aplicar una aceleración personalizada. 

Si utiliza el tipo de documento de HTML5 Canvas, puede obtener un archivo de salida js optimizado para los ajustes preestablecidos de aceleración. HTML5 Canvas utiliza las funciones de aceleración de la Interpolación JS al crear un archivo de salida. 

Aplicación de una aceleración personalizada a la animación de interpolación clásica

Nota:

Este tema trata de cómo añadir aceleración a interpolaciones clásicas antiguas. Para obtener más información acerca de cómo añadir aceleración a interpolaciones de movimiento más nuevas, consulte Aceleración de animaciones de interpolación.

En el cuadro de diálogo Aceleración personalizada se muestra un gráfico que representa el grado de movimiento en cada momento. El eje horizontal representa fotogramas y el eje vertical representa el porcentaje de cambio. El primer fotograma clave se representa como 0% y el último como 100%.

La pendiente de la curva en el gráfico representa la velocidad de cambio del objeto. Cuando la curva es horizontal (sin pendiente), la velocidad de cambio es cero; cuando es vertical, el cambio se produce de forma instantánea.

Gráfico de aceleración/desaceleración personalizada
Gráfico de aceleración personalizada que muestra una velocidad constante. Para abrir este diálogo, seleccione un fotograma en una interpolación clásica y haga clic en el botón Editar de la sección Aceleración del inspector de propiedades.

Guardar aceleraciones personalizadas

Puede guardar las aceleraciones personalizadas con tan solo hacer clic en un botón y reutilizarlas seleccionando la aceleración personalizada de lista personalizada. Haga clic en Guardar y aplicar en el modo de edición después de realizar los cambios. En la siguiente captura de pantalla puede ver el ajuste preestablecido personalizado de aceleración llamado MyEase1

Nota:

Solo puede reutilizar los ajustes preestablecidos de aceleración personalizados dentro del mismo tipo de documento.

Ajuste preestablecido de la aceleración personalizado
Ajuste preestablecido de la aceleración personalizado

Puede utilizar las aceleraciones preestablecidas en diversos fragmentos en la línea de tiempo, para ello seleccione los grupos correspondientes y aplicar la aceleración.

Ajuste preestablecido de la aceleración a través de varios grupos
Ajuste preestablecido de la aceleración a través de varios grupos

Más controles en el cuadro de diálogo Aceleración personalizada

Botones Reproducir y Detener

Permiten previsualizar animaciones en el escenario utilizando todas las curvas de velocidad definidas actualmente en el cuadro de diálogo Aceleración personalizada.

Supr

Elimina la aceleración personalizada actual. 

Guardar y aplicar

Guarda y aplica los cambios realizados en los ajustes preestablecidos de aceleración. 

Botón Restablecer

Devuelve la curva de velocidad a su estado lineal predeterminado.

Posición del punto de control seleccionado

En la esquina superior derecha del cuadro de diálogo, un valor numérico muestra el fotograma clave y la posición del punto de control seleccionado. Si no hay ningún punto seleccionado no se muestra ningún valor.

Para añadir un punto de control a la línea, haga clic una vez en la diagonal. Para conseguir un grado de control preciso sobre el movimiento de un objeto, arrastre las posiciones de los puntos de control.

Utilizando los indicadores de fotograma (representados mediante selectores cuadrados), haga clic en donde desee que un objeto frene o acelere. Al hacer clic en el selector cuadrado de un punto de control, este queda seleccionado y se muestran los puntos tangentes a cada lado del mismo. Los círculos huecos representan puntos tangentes. Para colocarlos, arrastre el punto de control o sus puntos tangentes con el ratón, o utilice las teclas de flecha del teclado.

Sugerencia: de forma predeterminada, los puntos de control se ajustan a la cuadrícula. Puede desactivar esta función con solo pulsar la tecla X mientras arrastra el punto de control.

Al hacer clic en una zona de la curva alejada de cualquier punto de control, se añade ahí un punto de control. Esta acción no cambia la forma de la curva. Haciendo clic lejos de la curva y de los puntos de control se anula la selección del punto de control seleccionado en ese momento.

Adición de aceleración personalizada

  1. Seleccione en la línea de tiempo una capa que tenga aplicada una interpolación clásica.

  2. En el inspector de propiedades, haga clic en el botón Editar situado junto al deslizador Aceleración.
  3. Para añadir un punto de control, haga clic con la tecla Control presionada (Windows) o con la tecla Comando presionada (Macintosh) en la línea diagonal.
  4. Para aumentar la velocidad del objeto, arrastre el punto de control hacia arriba; arrástrelo hacia abajo para reducirla.
  5. Para ajustar la curva y precisar el valor de aceleración de la interpolación arrastre los selectores de vértice.
  6. Para ver la animación en el escenario, haga clic en el botón de reproducción situado en la esquina inferior izquierda.

  7. Ajuste los controles hasta obtener el efecto que desea.

Nota:

Si utiliza el cuadro de diálogo Aceleración personalizada, el campo de edición muestra --. Si utiliza ediciones o el deslizador emergente, el gráfico de aceleración personalizada se establece en la curva equivalente. Además, se selecciona la casilla Usar una configuración para todas las propiedades.

Copiado y pegado de una curva de aceleración

  • Para copiar la curva presione Ctrl+C (Windows) o Comando+C (Macintosh).

  • Para colocar la curva copiada en otra curva de aceleración, presione Ctrl+V (Windows) o Comando+V (Macintosh).

    Puede copiar y pegar la curva de aceleración. La curva copiada está disponible hasta que se sale de la aplicación Animate.

Curvas de aceleración no admitidas

Algunos tipos de curvas no están permitidos. Ninguna parte del gráfico puede representar una curva no lineal (como un círculo, por ejemplo).

El cuadro de diálogo Aceleración/desaceleración personalizada impide mover un punto de control o un punto tangente a una posición que implique la generación de una curva no válida:

  • Todos los puntos deben estar contenidos en el gráfico. Los puntos de control no pueden prolongarse más allá de los límites del gráfico.

  • Todos los segmentos de la curva deben estar contenidos en el gráfico. La forma de la curva se aplanará para impedir que sobrepase los límites del gráfico.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea