What is a catalog?

A catalog is a database that tracks the location of your photos and information about them. When you edit photos, rate them, add keywords to them, or do other things to photos in Lightroom, all those changes are stored in the catalog. The photo files themselves are not touched.

Note: Catalogs are different from collections. Collections are an organizational tool within a catalog. See Work with photo collections.

When you start Lightroom the first time, it automatically creates an empty catalog file (for example, Lightroom 5 Catalog.lrcat) for you. To start working with this default, empty catalog, click the Import button.

For more information on catalogs, including a video tutorial, see How Lightroom catalogs work.

How do I create or open a different catalog?

  • To create a catalog: Start Lightroom and choose File > New Catalog. Specify where you want to store the catalog, enter a name, and click Create.
  • To open a different catalog: Choose File > Open Catalog, navigate to the location of the catalog you want to open, and click Open.
  • If you have multiple catalogs, tell Lightroom which one to open when you start the program: Choose Edit > Preferences (Windows) or Lightroom > Preferences (Mac OS) and then specify an option in the General panel. For more information on the choices, see Change the default catalog.
Tell Lightroom which catalog to open on startup.

Note:

Unless you're working with millions of photos and performance is a concern, using multiple catalogs is not recommended. Watch Julieanne Kost's Single or multiple catalogs? video tutorial on Adobe TV for the pros and cons of using one versus multiple catalogs in any version of Lightroom.

How do I open my old catalog in my new version of Lightroom?

When you upgrade to a new version of Lightroom and open a catalog from an older version, Lightroom upgrades the catalog automatically. The old catalog remains untouched. The new, updated catalog contains all of the metadata associated with the previous catalog and photos.

  1. Start the new version of Lightroom for the first time, or open the new version of Lightroom and choose File > Open Catalog.

  2. Navigate to the old catalog.lrcat file, and then click Open.

  3. If prompted, click Relaunch to close the current catalog and restart Lightroom.

    Tell Lightroom to relaunch with the selected catalog.
  4. Click Upgrade.

    Confirm that you want to upgrade the catalog

Note:

If you have trouble upgrading a catalog, open the old catalog in your previous version of Lightroom and export it as a new catalog. Then, import the exported catalog into the new version of Lightroom. See Export a catalog or this video tutorial.

Where is my catalog located?

By default, Lightroom saves catalogs in the following folders:

  • Windows: \Users\[user name]\Pictures\Lightroom
  • Mac OS: /Users/[user name]/Pictures/Lightroom

For the default locations of catalogs and other important Lightroom files, see:

Note:

If you've moved your catalog and can't remember where it is, search for "lrcat" in the Explorer (Windows) or Finder (Mac OS).

Can I store a catalog on a network?

No, you can't store catalogs on a network but you can store your photos on a network. Smart Previews let you edit your photos in Lightroom even when you are disconnected from the network or when your computer is disconnected from the drive that contains your photos.

How do I move a catalog?

You can move your catalog to a different location on your computer's hard drive, to an external disk, or to another computer altogether. Simply use the Explorer (Windows) or Finder (Mac OS) to drag or copy the following files to the new location:

  • Catalog: [catalog name].lrcat
  • Previews: [catalog name] Previews.lrdata
  • Smart Previews (Lightroom 5 and later): [catalog name] Smart Previews.lrdata
Notice that you're not moving any photos, nor are you moving the Lightroom application itself. If Lightroom can't find the catalog or your photos after you move a catalog, see Lightroom can't find my catalog. How do I find it? Or, My catalog can't find my photos. How do I find them?
 
To transfer a catalog between a Windows computer and a Mac, copy your catalog, preview, and image files from the original computer onto a flash or other external drive. Then, attach that drive to the second computer and copy the files to the desired location on the second computer.

Note:

For a video on how to move a catalog between two computers, watch Julieanne Kost's How to migrate Lightroom to another computer video tutorial on Adobe TV.

How do I rename a catalog?

You can rename a catalog in the Explorer (Windows) or Finder (Mac OS). If you rename a catalog, make sure to also rename its corresponding Previews and Smart Previews files.

  1. Close Lightroom.

  2. Navigate to your catalog and its preview files in the Explorer (Windows) or Finder (Mac OS). They should be in the same folder.

  3. Rename all three files, making sure to keep the word Previews in the preview cache files. For example:

Old filename New filename
Lightroom 5 Catalog.lrcat My trip catalog.lrcat
Lightroom 5 Catalog Previews.lrdata My trip catalog Previews.lrdata
Lightroom 5 Catalog Smart Previews.lrdata My trip catalog Smart Previews.lrdata

Note: Smart Preview cache files are available for Lightroom 5 and later, not earlier versions.

After you rename your catalog, you might have to help Lightroom find it. See Lightroom can't find my catalog. How do I find it?

How do I back up a catalog?

You can back up your catalog automatically when you quit Lightroom.

  1. Tell Lightroom how often to back up: choose Edit > Catalog Settings (Windows) or Lightroom > Catalog Settings (Mac OS) and specify a frequency in the Back Up Catalog option in the General panel.

  2. Quit Lightroom at the designated time.

Note:

To back up your catalog manually, go to Catalog Settings, choose Back Up Catalog > When Lightroom Next Exits, and close the window. Then, quit Lightroom.

Tell Lightroom to back up the catalog when Lightroom next exits.

Note:

On Mac, Lightroom CC/Lightroom 6.1 doesn't zip catalogs larger than 4 GB. This is because the default Mac OS unzip utility is unable to handle archives larger than 4GB and reports such zipped catalogs as "corrupted".

Important: Backing up your catalog does not back up the photos it references. For more information on backing up and restoring catalogs, see Back up a catalog.

What does optimization do to a catalog?

Catalog optimization does several things to your catalog:

  • It reorganizes the data in the catalog so it can be retrieved faster.
  • It updates the database data so the fastest retrieval method can be used.

How do I delete a catalog?

Using Explorer (Windows) or Finder (Mac OS), locate the folder that contains your catalog. Then, drag the following files to the Recycling Bin (Windows) or Trash (Mac OS):

  • Catalog: [catalog name].lrcat
  • Previews: [catalog name] Previews.lrdata
  • Smart Previews (Lightroom 5 and later): [catalog name] Smart Previews.lrdata
Notice that you're not deleting any photos, nor are you removing the Lightroom app itself. For information on those tasks, see Uninstall or remove Creative Cloud apps or Uninstall Lightroom manually, and Remove photos from catalogs.

How do I combine catalogs or move photos from one catalog to another?

To combine or merge catalogs — or to move photos from one catalog to another — you import one catalog into the other.

  1. Choose File > Open Catalog and select the catalog that you want to be the master, or primary, catalog (the one you want to add to).

  2. Choose File > Import From Another Catalog and navigate to the catalog that contains the photos you want to add from. Then, click Open (Windows) or Choose (Mac OS).

  3. In the Import From Catalog dialog box, do the following:

    1. Under Catalog Contents, select the folders that contain the photos you want to import.

    2. Specify how you want to handle new and existing photos. For more information on these options, see Import photos from a different Lightroom catalog.

  4. Click Import.

  5. Repeat steps 1 – 4 for additional catalogs or photos that you want to add to the open one.

Note:

For a video on combining catalogs, see Julieanne Kost's Merging individual catalogs into a master catalog on Adobe TV.

How do I use my catalog on multiple computers, such as a laptop and a desktop?

The easiest way to use Lightroom on more than one computer is to keep your catalog and photos together on an external drive. Then, in preferences, tell Lightroom to open that catalog by default.

How many photos can I have in a catalog?

There is no specific maximum number of photos you can store in a Lightroom catalog. If your catalog grows large and you notice Lightroom slowing, see Optimize performance for a whole toolbox of suggestions on how to speed it up.

What is the largest size photo I can have in a catalog?

Lightroom 2 - 5 supports photos up to 65,000 pixels long or wide or up to 512 megapixels, whichever is smaller.

Lightroom can't find my catalog. How do I find it?

If you move or rename your catalog, you could encounter a "Lightroom catalog was not found" error the next time you open Lightroom.

  1. In the “Lightroom catalog was not found” error window, click Choose A Different Catalog.

    Choose a different catalog to open.
  2. If the catalog you want to open isn’t listed, click Choose A Different Catalog again to open the \Pictures\Lightroom (Windows) or /Pictures/Lightroom (Mac OS) folder.

  3. Navigate to your renamed or moved catalog, select it, and click Choose.

  4. In the Select Catalog dialog box, your renamed catalog is probably the first catalog in the list. Select it and click Open.

My catalog can't find my photos. How do I find them?

If you move image files in the Finder (Mac OS) or Explorer (Windows), the Lightroom catalog could lose track of them. When a catalog can't find a photo, a Photo Is Missing icon appears in the photo thumbnail in the Library Grid view and in the Filmstrip. The icon is an exclamation point (). The error "File could not be found" appears over the photo preview in the Develop module.

  1. In the Grid view of the Library module, click the Photo Is Missing icon in a photo thumbnail.
  2. Click the Locate button and navigate to the folder that contains the photo.
  3. Click Select.
You can find the contents of missing folders in a similar way: Right-click (Windows) or Control-click (Mac OS) a folder in the Folders panel that has a Question Mark icon () and choose Find Missing Folder. Navigate to the location of the folder and click Choose.

Note:

To avoid missing images, always move photos from within Lightroom rather than in the operating system. See Move photos to a different folder and Locate missing photos.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy