Combinaison d’objets

Découvrez comment associer des objets dans Illustrator.

Vous pouvez associer des objets vectoriels pour créer des formes de différentes manières dans Illustrator. Les tracés ou formes obtenus diffèrent selon la méthode utilisée pour combiner les objets.

Méthodes de combinaison d’objets

Effets Pathfinder

Les effets Pathfinder vous permettent de combiner plusieurs objets à l’aide de modes d’interaction. Les effets Pathfinder ne permettent pas de modifier les interactions entre les objets. Voir Combinaison d’objets à l’aide des effets Pathfinder.

Formes composées

Les formes composées vous permettent de combiner plusieurs objets et de spécifier la manière dont vous souhaitez que chaque objet interagisse avec les autres objets. Les formes composées sont plus polyvalentes que les tracés transparents, car elles fournissent quatre types d’interactions : ajouter, soustraire, entrecouper et exclure. En outre, les objets sous-jacents ne sont pas modifiés. Vous pouvez donc sélectionner chaque objet d’une forme composée pour le modifier ou modifier son mode d’interaction. Voir Combinaison d’objets à l’aide de formes composées.

Tracés transparents

Les tracés transparents permettent d’utiliser un objet pour percer un autre objet. Par exemple, vous pouvez créer une forme de donut à partir de deux cercles imbriqués. Une fois que vous avez créé un tracé transparent, les tracés agissent comme des objets associés. Vous pouvez sélectionner et manipuler les objets séparément à l’aide de l’outil Sélection directe ou Sélection directe progressive, ou sélectionner et modifier le tracé combiné. Voir Combinaison d’objets à l’aide de tracés transparents.

Remarque :

Vous pouvez également ajouter des éléments à un objet à l’aide de l’outil Forme de tache. Lorsque vous utilisez ce pinceau, les tracés que vous peignez sont ajoutés aux tracés adjacents qui utilisent les mêmes attributs de fond. Voir Dessin et fusion de tracés avec l’outil Forme de tache et Création de nouvelles formes à l’aide de l’outil Concepteur de forme.

Combinaison d’objets à l’aide des effets Pathfinder

Navigation dans le panneau Pathfinder

Le panneau Pathfinder (Fenêtre > Pathfinder) permet de combiner des objets pour créer de nouvelles formes.

Lien profond Adobe Illustrator

Essayer dans l’application
Combinez des objets en quelques étapes simples.

Présentation du panneau Pathfinder
Panneau Pathfinder

Utilisez la rangée supérieure de boutons du panneau pour créer des tracés ou des tracés transparents. Pour créer des formes composées, utilisez les boutons de ces lignes tout en appuyant sur la touche Alt ou Option. 

Choisissez l’un des modes de forme suivants :

Ajouter à la zone de forme

Ajoute la zone du composant à la géométrie sous-jacente.

Soustraire de la zone de forme

Découpe la zone du composant de la géométrie sous-jacente.

Intersection des zones de forme

Utilise la zone du composant pour écrêter la géométrie sous-jacente comme le ferait un masque.

Exclure les zones de forme qui se chevauchent

Utilise la zone du composant pour inverser la géométrie sous-jacente, transformant les zones remplies en trous et inversement.

Utilisez la rangée inférieure de boutons du panneau, appelée Effets Pathfinder, pour créer des combinaisons de formes finales dès le premier clic. (Voir Application d’effets Pathfinder.)

Effets Pathfinder
Modes de forme

A. Tous les composants en mode Ajout B. Mode Soustraction appliqué aux carrés C. Mode d’intersection appliqué aux carrés D. Mode Exclure appliqué aux carrés 

Spécification des options Pathfinder

Définissez les options Pathfinder dans le menu du panneau Pathfinder ou en double-cliquant sur un effet Pathfinder dans le panneau Aspect.

Précision

Affecte la précision avec laquelle les effets Pathfinder calculent le tracé d’un objet. Plus le calcul est précis, plus le dessin est précis et plus la génération du tracé obtenu prend du temps.

Supprimer les points redondants

Supprime les points inutiles lorsque vous cliquez sur un bouton Pathfinder.

Division Et Contour Suppriment Les Illustrations Non Peintes

Supprime tous les objets sans fond de l’illustration sélectionnée lorsque vous cliquez sur le bouton Diviser ou Vectoriser.

Application d’effets Pathfinder

Les effets Pathfinder vous permettent de créer de nouvelles formes à partir d’objets qui se chevauchent. Appliquez des effets Pathfinder à l’aide du menu Effets ou du panneau Pathfinder.

  • Effets Pathfinder dans le menu Effets ne peut être appliqué qu’aux groupes, calques et objets de texte. Après avoir appliqué l’effet, vous pouvez toujours sélectionner et modifier les objets d’origine. Vous pouvez également utiliser le panneau Aspect pour modifier ou supprimer l’effet. Voir Application d’un effet Pathfinder à l’aide du menu Effets.

  • Effets Pathfinder dans le panneau Pathfinder peut être appliqué à toute combinaison d’objets, de groupes et de calques. La combinaison de formes finale est créée lorsque vous cliquez sur un bouton Pathfinder, après quoi vous ne pouvez plus modifier les objets d’origine. Si l’effet produit plusieurs objets, ils sont automatiquement regroupés. Voir Application d’un effet Pathfinder à l’aide du panneau Pathfinder.

Application d’un effet Pathfinder à l’aide du menu Effets

  1. Effectuez l’une des opérations suivantes :
    • Regroupez les objets à utiliser, puis sélectionnez le groupe.

      -ou-

    • Déplacez les objets à utiliser dans un calque séparé et ciblez le calque.

  2. Choisissez Effet > Pathfinder, puis un effet Pathfinder.
    Remarque :

    Pour réappliquer rapidement le même effet Pathfinder, choisissez Effet > Appliquer [effet].

Application d’un effet Pathfinder à l’aide du panneau Pathfinder

  1. Sélectionnez les objets auxquels vous souhaitez appliquer l’effet.

    Pour appliquer un effet Pathfinder à un groupe ou à un calque, ciblez le groupe ou le calque.

  2. Dans le panneau Pathfinder, cliquez sur un bouton Pathfinder (dans la rangée inférieure), ou cliquez sur un bouton Mode de forme (dans la rangée supérieure) tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

Résumé des effets Pathfinder

Ajouter

Trace le contour de tous les objets comme s’il s’agissait d’un seul objet fusionné. La forme obtenue adopte les attributs de peinture de l’objet supérieur.

Intersection

Trace le contour de la zone chevauchée par tous les objets.

Exclure

Trace toutes les zones non superposées des objets et rend transparentes les zones superposées. Lorsqu’un nombre pair d’objets se chevauchent, le chevauchement devient transparent. Lorsqu’un nombre impair d’objets se superposent, le chevauchement est rempli.

Soustraire

Soustrait les objets situés le plus en avant de l’objet situé le plus en arrière. Cette commande permet de supprimer des zones d’une illustration en modifiant l’ordre de superposition.

Soustraction arrière

Soustrait les objets en arrière-plan de l’objet situé le plus en avant. Cette commande permet de supprimer des zones d’une illustration en modifiant l’ordre de superposition.

Division

Sépare une illustration en ses faces élémentaires (une visage est une zone non divisée par un segment).

Remarque: lorsque vous utilisez le bouton Division du panneau Pathfinder, vous pouvez manipuler les faces obtenues avec l’outil Sélection directe ou Sélection directe progressive, indépendamment les unes des autres. Lors de l’application de la commande Division, vous avez également la possibilité de supprimer ou de conserver les objets sans fond.

Rogner

Supprime la partie masquée d’un objet avec fond. Supprime tous les contours et ne fusionne pas les objets de la même couleur.

Fusionner

Supprime la partie masquée d’un objet avec fond. Supprime tous les contours et fusionne les objets adjacents ou superposés dotés de la même couleur de fond.

Recadrer

Divise l’illustration en ses faces élémentaires, puis supprime toutes les parties de l’illustration qui se trouvent en dehors des limites de l’objet de premier plan. Elle supprime également tous les contours.

Contour

Divise un objet en segments de ligne qui le composent, ou bords. Cette commande est utile pour préparer les illustrations nécessitant un recouvrement pour la surimpression des objets. Voir Création d’un recouvrement.

Remarque: lorsque vous utilisez le bouton Contour du panneau Pathfinder, vous pouvez manipuler chaque bord indépendamment à l’aide de l’outil Sélection directe ou Sélection directe progressive. Vous pouvez également choisir de supprimer ou de conserver les objets sans fond lors de l’application de la commande Contour.

Mélange maximal

Associe les couleurs en choisissant la valeur la plus élevée de chacune des composantes de couleur. Par exemple, si la couleur 1 correspond à 20 % de cyan, 66 % de magenta, 40 % de jaune et 0 % de noir, et la couleur 2 à 40 % de cyan, 20 % de magenta, 30 % de jaune et 10 % de noir, la couleur dure obtenue correspond à 40 % de cyan, 66 % de magenta, 40 % de jaune et 10 % de noir.

Mélange pondéré

Rend les couleurs sous-jacentes visibles à travers l’illustration superposée, puis divise l’image en plusieurs faces distinctes. Vous pouvez spécifier le pourcentage de visibilité souhaité dans les couleurs superposées.

Recouvrement

Compense les éventuels décalages entre les couleurs d’une illustration en créant une petite zone de chevauchement (recouvrement) entre deux couleurs adjacentes.

Combinaison d’objets à l’aide de formes composées

A forme composée est une illustration modifiable composée d’au moins deux objets, chacun étant affecté d’un mode de forme. Les formes composées facilitent la création de formes complexes, car vous pouvez manipuler avec précision le mode de forme, l’ordre d’empilement, la forme, l’emplacement et l’apparence de chaque tracé inclus.

Les formes composées agissent comme des objets groupés et apparaissent comme <compound shape=""> dans le panneau Calques. Vous pouvez utiliser le panneau Calques pour afficher, sélectionner et manipuler le contenu d’une forme composée, par exemple pour modifier l’ordre d’empilement de ses composants. Vous pouvez également utiliser l’outil Sélection directe ou Sélection directe progressive pour sélectionner les composants d’une forme composée.

Lorsque vous créez une forme composée, elle adopte les attributs de peinture et de transparence du composant le plus élevé en mode Ajouter, Intersection ou Exclure. Vous pouvez ensuite modifier les attributs de peinture, de style ou de transparence de la forme composée. Illustrator facilite ce processus en ciblant automatiquement l’ensemble de la forme composée lorsque vous en sélectionnez une partie, sauf si vous ciblez explicitement un composant dans le panneau Calques.

Formes composées
Utilisation de formes composées

A. Objets d’origine B. Forme composée créée C. Modes de forme individuels appliqués à chaque composant D. Style appliqué à la forme composée entière 

Création d’une forme composée

  1. Sélectionnez tous les objets à inclure dans la forme composée.

    Vous pouvez inclure des tracés, des tracés transparents, des groupes, d’autres formes transparentes, des dégradés, du texte, des enveloppes et des déformations dans une forme transparente. Tout tracé ouvert que vous sélectionnez est automatiquement fermé.

  2. Effectuez l’une des opérations suivantes :
    • Dans le panneau Pathfinder, cliquez sur un bouton Modes de forme tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée. Chaque composant de la forme composée se voit attribuer le mode de forme que vous sélectionnez.

      -ou-

    • Sélectionnez Créer une forme composée dans le menu du panneau Pathfinder. Par défaut, le mode Ajouter est attribué à chaque composant de la forme composée.

  3. Modifiez le mode de forme d’un composant en le sélectionnant à l’aide de l’outil Sélection directe ou du panneau Calques, puis en cliquant sur un bouton Mode de forme.

    Remarque : Il n’est jamais nécessaire de modifier le mode du composant d’arrière-plan, car ce mode n’a aucun rapport avec la forme composée.

    Remarque :

    Pour obtenir des performances optimales, créez des formes composées complexes en imbriquant d’autres formes composées (contenant jusqu’à 10 composants chacune) au lieu d’utiliser de nombreux composants individuels.

Modification d’une forme composée

  1. Utilisez l’outil Sélection directe ou le panneau Calques pour sélectionner un composant individuel de la forme composée.
  2. Recherchez le bouton Mode de forme en surbrillance dans le panneau Pathfinder pour identifier le mode actuellement appliqué à un composant sélectionné.
    Remarque :

    Si vous avez sélectionné plusieurs composants utilisant des modes différents, des points d’interrogation s’affichent sur les boutons Mode forme.

  3. Dans le panneau Pathfinder, cliquez sur un autre bouton Mode de forme.

Annulation et développement d’une forme composée

La libération d’une forme composée la sépare en objets distincts. La décomposition d’une forme composée conserve la forme de l’objet composé, mais vous ne pouvez plus sélectionner les composants individuels.

  1. Sélectionnez la forme composée avec l’outil Sélection ou le panneau Calques.
  2. Effectuez l’une des opérations suivantes :
    • Cliquez sur Développer dans le panneau Pathfinder.

      -ou-

    • Choisissez Développer la forme composée dans le menu du panneau Pathfinder.

      La forme composée est convertie en <path> ou <compound path=""> dans le panneau Calques, selon le mode de forme utilisé.

      -ou-

    • Choisissez Annuler la forme composée dans le menu du panneau Pathfinder.

Déplacement de formes composées entre Illustrator et Photoshop

Les calques de forme et les masques vectoriels (masques d’écrêtage de calque) dans Adobe Photoshop sont des types de formes composées. Vous pouvez importer des calques de forme et des masques de calque dans Illustrator en tant que formes composées et continuer à les manipuler. En outre, vous pouvez exporter des formes composées vers Photoshop. Gardez les points suivants à l’esprit lors de l’utilisation de formes composées avec Photoshop :

  • Seules les formes composées qui se trouvent au niveau supérieur de la hiérarchie des calques sont exportées dans Photoshop en tant que calques de forme.

  • Une forme composée peinte avec un contour en utilisant un sommet autre qu’arrondi, ou avec une épaisseur en points qui n’est pas un entier, est pixellisée lors de l’exportation au format de fichier PSD.

Combinaison d’objets à l’aide de tracés transparents

A tracé transparent contient au moins deux tracés peints de sorte que des trous apparaissent là où les tracés se chevauchent. Lorsque vous définissez des objets en tant que tracé transparent, tous les objets qu’il contient adoptent les attributs de peinture et de style de l’objet d’arrière-plan dans l’ordre d’empilement.

Les tracés transparents agissent comme des objets groupés et apparaissent comme <compound path=""> dans le panneau Calques. Utilisez l’outil Sélection directe ou Sélection directe progressive pour sélectionner une partie d’un tracé transparent. Vous pouvez manipuler la forme de composants individuels d’un tracé transparent, mais vous ne pouvez pas modifier les attributs d’aspect, les styles graphiques, les effets appliqués à des composants individuels, ni manipuler les composants individuellement dans le panneau Calques.

Remarque :

Pour plus de souplesse lors de la création de tracés transparents, vous pouvez créer une forme composée, puis la développer.

Tracé d’un objet à l’aide d’un tracé transparent

  1. Sélectionnez l’objet à utiliser comme trou et positionnez-le de manière à ce qu’il chevauche l’objet à découper. Répétez l’opération pour chaque objet supplémentaire à utiliser comme trou.
  2. Sélectionnez tous les objets à inclure dans le tracé transparent.
  3. Choisissez Objet > Tracé transparent > Créer.

Application de règles de remplissage aux tracés transparents

Vous pouvez spécifier si un tracé transparent doit être un tracé intérieur/extérieur non nul ou pair/impair.

Règle de remplissage intérieur/extérieur non nul

Utilise des équations mathématiques pour déterminer si un point se trouve à l’extérieur ou à l’intérieur d’une forme. Illustrator utilise la règle d’enroulement non nul comme règle par défaut.

Règle de remplissage pair/impair

Utilise des équations mathématiques pour déterminer si un point se trouve à l’extérieur ou à l’intérieur d’une forme. Cette règle est la plus prévisible, car toutes les autres zones d’un tracé complexe pair/impair sont des trous, quelle que soit la direction du tracé. Certaines applications, telles qu’Adobe Photoshop, utilisent la règle pair/impair par défaut. Par conséquent, les tracés transparents importés à partir de ces applications utilisent la règle pair/impair.

Tracés se croisant eux-mêmes sont des tracés qui se croisent. Vous pouvez choisir de rendre ces tracés non nuls ou paires, selon l’aspect que vous souhaitez leur donner.

Tracés transparents
Tracé se croisant à plusieurs reprises avec l’option Utiliser la règle de remplissage intérieur/extérieur non nul (à gauche) et l’option Utiliser la règle de remplissage pair/impair (à droite)

Lorsque vous créez un tracé transparent avec un remplissage intérieur/extérieur non nul, vous pouvez indiquer si les tracés qui se chevauchent apparaissent perforés ou sont remplis en cliquant sur le bouton Inverser la direction des tracés dans le panneau Attributs.

Quatre tracés circulaires
Règles de remplissage

A. Quatre tracés circulaires B. Tracés circulaires sélectionnés et convertis en tracés transparents C. Inverser la direction du tracé appliqué au tracé le plus à l’intérieur 

Modification de la règle de remplissage d’un tracé transparent

  1. Sélectionnez le tracé transparent avec l’outil Sélection ou le panneau Calques.
  2. Dans le panneau Attributs, cliquez sur le bouton Utiliser la règle de remplissage intérieur/extérieur non nul  ou le bouton Utiliser la règle de remplissage pair/impair  .

Conversion d’un trou dans un tracé transparent en zone remplie

  1. Assurez-vous que le tracé transparent utilise la règle de remplissage intérieur/extérieur non nul.
  2. À l’aide de l’outil Sélection directe , sélectionnez la partie du tracé transparent à inverser. Ne sélectionnez pas l’intégralité du tracé transparent.

  3. Dans le panneau Attributs, cliquez sur le bouton Inverser le sens des tracés - Désactivé  ou le bouton Inverser la direction du tracé - Activé  .

Rétablissement des composants d’origine d’un tracé transparent

  1. Sélectionnez le tracé transparent avec l’outil Sélection ou le panneau Calques.
  2. Choisissez la commande Objet > Tracé transparent > Annuler.

 Adobe

Recevez de l’aide plus rapidement et plus facilement

Nouvel utilisateur ?