Publicar documentos de AS3

  1. Guía del usuario de Adobe Animate
  2. Introducción a Animate
    1. Novedades de Animate
    2. Glosario visual
    3. Requisitos del sistema para Animate
    4. Métodos abreviados de teclado de Animate
    5. Trabajar con varios tipos de archivo en Animate
  3. Animación
    1. Aspectos básicos de animaciones en Animate
    2. Cómo utilizar los fotogramas y fotogramas clave en Animate
    3. Animación fotograma a fotograma en Animate
    4. Uso de la animación de interpolación clásica en Animate
    5. Herramienta Pincel
    6. Guía de movimiento
    7. Interpolación de movimiento y ActionScript 3.0
    8. Acerca de la animación de interpolación de movimiento
    9. Animaciones de interpolación de movimiento
    10. Creación de una animación de interpolación de movimiento
    11. Uso de fotogramas clave de propiedad
    12. Animación de la posición con una interpolación
    13. Edición de interpolaciones de movimiento con el editor de movimiento
    14. Edición del trazado de movimiento de una animación de interpolación
    15. Manipulación de las interpolaciones de movimiento
    16. Adición de aceleraciones personalizadas
    17. Creación y aplicación de ajustes preestablecidos de movimiento
    18. Configuración de grupos de interpolación de animación
    19. Uso de interpolaciones de movimiento guardadas como archivos XML
    20. Interpolaciones de movimiento e interpolaciones clásicas
    21. Interpolación de forma
    22. Uso de la animación de la herramienta Hueso en Animate
    23. Trabajar con el rigging de personajes en Animate
    24. Uso de las capas de máscara en Adobe Animate
    25. Uso de escenas en Animate
  4. Interactividad
    1. Creación de botones en Animate
    2. Conversión de proyectos de Animate a otros formatos de documento
    3. Creación y publicación de documentos de HTML5 Canvas en Animate
    4. Adición de interactividad con fragmentos de código en Animate
    5. Creación de componentes HTML5 personalizados
    6. Uso de componentes en HTML5 Canvas
    7. Creación de componentes personalizados: Ejemplos
    8. Fragmentos de código para componentes personalizados
    9. Prácticas recomendadas - Publicidad con Animate
    10. Autoría y publicación de realidad virtual
  5. Espacio de trabajo y flujo de trabajo
    1. Creación y administración de pinceles
    2. Uso de Google Fonts en documentos HTML5 Canvas
    3. Utilización de las Bibliotecas Creative Cloud y Adobe Animate
    4. Utilización del Escenario y el panel Herramientas en Animate
    5. Flujo de trabajo y espacio de trabajo de Animate
    6. Uso de las fuentes web en documentos de HTML5 Canvas
    7. Líneas de tiempo y ActionScript
    8. Trabajo con varias líneas de tiempo
    9. Configuración de preferencias
    10. Utilización de los paneles de edición de Animate
    11. Creación de capas de la línea de tiempo en Animate
    12. Exportación de animaciones para aplicaciones móviles y motores de juegos
    13. Desplazamiento y copia de objetos
    14. Plantillas
    15. Buscar y reemplazar en Animate
    16. Deshacer y rehacer en el panel Historial
    17. Métodos abreviados de teclado
    18. Uso de la Cronología en Animate
    19. Creación de extensiones HTML
    20. Opciones de optimización para Imágenes y archivos GIF animados
    21. Configuración de exportación de imágenes y archivos GIF
    22. Panel de Recursos en Animate
  6. Multimedia y vídeo
    1. Transformación y combinación de objetos gráficos en Animate
    2. Crear y trabajar con instancias de símbolo en Animate
    3. Calco de imagen
    4. Cómo utilizar el sonido en Adobe Animate
    5. Exportación de archivos SVG
    6. Creación de archivos de vídeo para su uso en Animate
    7. Cómo añadir un vídeo a Animate
    8. Trabajo con puntos de referencia de vídeo
    9. Dibujo y creación de objetos en Animate
    10. Remodelado de líneas y formas
    11. Trazos, rellenos y degradados en Animate CC
    12. Uso de Adobe Premiere Pro y After Effects
    13. Paneles de color en Animate CC
    14. Apertura de archivos de Flash CS6 con Animate
    15. Uso de texto clásico en Animate
    16. Colocación de ilustraciones en Animate
    17. Mapas de bits importados en Animate
    18. Gráficos 3D
    19. Trabajo con símbolos en Animate
    20. Dibujo de líneas y formas en Adobe Animate
    21. Uso de bibliotecas en Animate
    22. Exportación de sonidos
    23. Selección de objetos en Animate CC
    24. Trabajo con archivos AI de Illustrator en Animate
    25. Aplicación de patrones con el pincel rociador
    26. Aplicación de modos de mezcla
    27. Organización de objetos
    28. Automatización de tareas con el menú Comandos
    29. Texto en varios idiomas
    30. Utilización de la cámara en Animate
    31. Uso de Animate con Adobe Scout
    32. Trabajo con archivos de Fireworks
    33. Filtros de gráficos
    34. Sonido y ActionScript
    35. Preferencias de dibujo
    36. Dibujo con la herramienta Pluma
  7. Plataformas
    1. Conversión de proyectos de Animate a otros formatos de documento
    2. Compatibilidad con plataformas personalizadas
    3. Creación y publicación de documentos de HTML5 Canvas en Animate
    4. Creación y publicación de un documento de WebGL
    5. Empaquetado de aplicaciones para AIR para iOS
    6. Publicación de aplicaciones de AIR for Android
    7. Publicación para Adobe AIR para escritorio
    8. Configuración de publicaciones de ActionScript
    9. Prácticas recomendadas - Organización de ActionScript en una aplicación
    10. Uso de ActionScript con Animate
    11. Prácticas recomendadas - Directrices de accesibilidad
    12. Accesibilidad en el espacio de trabajo de Animate
    13. Cómo escribir y gestionar scripts
    14. Activación de la compatibilidad con plataformas personalizadas
    15. Información general sobre compatibilidad con plataformas personalizadas
    16. Creación de contenido accesible
    17. Uso de plugins de compatibilidad con plataformas personalizadas
    18. Depuración de ActionScript 3.0
    19. Activación de la compatibilidad con plataformas personalizadas
  8. Exportación y publicación
    1. Exportación de archivos de Animate CC
    2. Publicación de OAM
    3. Exportación de archivos SVG
    4. Exportación de gráficos y vídeos con Animate
    5. Publicar documentos de AS3
    6. Exportación de animaciones para aplicaciones móviles y motores de juegos
    7. Exportación de sonidos
    8. Exportación de archivos de vídeo QuickTime
    9. Control de reproducción de vídeo externo con ActionScript
    10. Prácticas recomendadas - Sugerencias para crear contenido para dispositivos móviles
    11. Prácticas recomendadas - Convenciones de vídeo
    12. Prácticas recomendadas - Directrices de edición de aplicaciones SWF
    13. Prácticas recomendadas - Estructuración de archivos FLA
    14. Prácticas recomendadas de optimización de archivos FLA para Animate
    15. Configuración de publicaciones de ActionScript
    16. Especificación de configuración de publicación para Animate
    17. Exportación de archivos de proyector
    18. Exportar imágenes y archivos GIF animados
    19. Plantillas de publicación HTML
    20. Uso de Adobe Premiere Pro y After Effects
    21. Compartir y publicar animaciones rápidamente

Información general sobre publicación

El contenido puede reproducirse de varias formas:

  • En navegadores de Internet equipados con Flash Player.

  • Como una aplicación de vídeo autónoma llamada proyector.

  • Con el control ActiveX de Flash en Microsoft Office y otros hosts de ActiveX.

  • Con Flash Xtra en Director® y Authorware® de Adobe®.

De forma predeterminada, el comando Publicar crea el archivo SWF y un documento HTML que inserta el contenido de Flash en una ventana del navegador. El comando Publicar también crea y copia archivos de detección para Macromedia Flash 4 de Adobe y versiones posteriores. Si cambia la configuración de publicación, Flash guarda los cambios con el documento. Los perfiles de publicación creados se pueden exportar y utilizar, ya sea en otros documentos o por otros usuarios que trabajen en el mismo proyecto.

Cuando se utilizan los comandos Publicar, Probar película o Depurar película, Flash crea un archivo SWF a partir del archivo FLA. Se pueden ver los tamaños de todos los archivos SWF creados en el archivo FLA actual en el inspector de propiedades del documento.

Flash® Player 6 y las versiones posteriores son compatibles con la codificación de texto Unicode. Unicode permite a los usuarios ver el texto en varios idiomas, sea cual sea el que utilice el sistema operativo que ejecuta el reproductor.

Puede publicar el archivo FLA en formatos de archivo alternativos (GIF, JPEG y PNG) con el código HTML necesario para mostrarlos en la ventana del navegador. Los formatos alternativos permiten que un navegador muestre la interactividad y la animación de su archivo SWF a usuarios que no tengan instalado Adobe Flash Player. Cuando publique un archivo FLA en cualquiera de los formatos de archivo alternativos, la configuración para cada uno de éstos se almacenará junto con el archivo FLA.

Puede exportar el archivo FLA en distintos formatos, al igual que los archivos FLA se publican en distintos formatos de archivo, con la excepción de que la configuración de cada formato no se guarda con el archivo FLA.

También puede crear un documento HTML personalizado con cualquier editor de HTML e incluir las etiquetas necesarias para mostrar un archivo SWF.

Para comprobar cómo funciona el archivo SWF antes de publicarlo, utilice Probar película (Control > Probar película > Probar) y Probar escena (Control > Probar escena).

Envoltorio HTML para documentos de AS3

Se necesita un documento HTML para reproducir un archivo SWF en un navegador Web y especificar la configuración del navegador. Para ver un archivo SWF de Flash en un navegador Web, el documento HTML debe utilizar las etiquetas object y embed con los parámetros correspondientes.

Nota:

para generar un documento HTML con las etiquetas object y embed correctas, utilice el cuadro de diálogo Configuración de publicación y seleccione la opción HTML. Para obtener más información, consulte Configuración de publicación para documentos HTML.

 

Animate puede crear el documento HTML automáticamente al publicar un archivo SWF.

Detección de la presencia de Flash Player

Para que el contenido publicado de Animate puedan verlo los usuarios web, Flash Player debe estar instalado en su navegador web.

Los siguientes recursos y artículos proporcionan información actualizada sobre cómo añadir código a las páginas web para determinar si Flash Player está instalado y ofrecer contenido alternativo en la página si no lo está.

Consulte la Ayuda de Flash Player para determinar si Flash Player está instalado o no.

Publicación para dispositivos móviles

Adobe® AIR® for Android® y Adobe® AIR® for iOS® le permite crear contenido atractivo para dispositivos móviles con el lenguaje de scripts ActionScript®, herramientas de dibujo y plantillas. Para obtener información detallada sobre la creación para dispositivos móviles, consulte la Referencia del desarrollador de AIR.

Nota:

dependiendo del dispositivo móvil, pueden existir algunas restricciones en cuanto a los comandos de ActionScript y formatos de sonido admitidos. Para más detalles, consulte el apartado relativo a los artículos móviles en el Centro de desarrollo de dispositivos y móviles.

Prueba de contenido para móvil en el simulador de contenido para móvil

Un simulador de contenido para móvil que permite probar el contenido creado con Adobe AIR en un entorno Android o iOS emulado. Con el simulador de contenido para móvil, puede usar el comando Control > Probar película para probar el archivo de en AIR Debug Launcher para dispositivos móviles que, a su vez, iniciará el simulador.

Una vez abierta la ventana del simulador, puede enviar la entrada al documento como si se estuviese ejecutando en un dispositivo móvil. Las entradas disponibles son:

  • Acelerómetro, ejes X, Y y Z
  • Ángulo de umbral de orientación
  • Toques y gestos, incluida sensibilidad de presión
  • Geolocalización, dirección y velocidad
  • Teclas de hardware (en dispositivos Android)

Publicación de documentos de AS3 seguros

Flash Player 8 y posterior contiene las siguientes funciones que permiten garantizar la seguridad de los documentos:

Protección contra desbordamiento del búfer

Esta función, activada de forma automática, impide el mal uso intencionado de los archivos externos integrados en un documento de que podrían sobrescribir la memoria del usuario o insertar un código destructivo, como un virus. De esta forma se evita que un documento de Flash pueda leer o escribir datos fuera del espacio de memoria designado del documento en el sistema del usuario.

Coincidencia exacta de dominio para compartir datos entre documentos

Flash Player 7 y las versiones posteriores aplican un modelo de seguridad más estricto que el de versiones anteriores. El modelo de seguridad cambió de dos formas principales entre Flash Player 6 y Flash Player 7:

Coincidencia exacta de dominio

Flash Player 6 permite que los archivos SWF de dominios similares (por ejemplo, www.adobe.com y store.adobe.com) puedan comunicarse libremente entre sí y con otros documentos. En Flash Player 7, para que dos dominios puedan comunicarse es necesario que el dominio de los datos a los que se va a acceder coincida exactamente con el dominio del proveedor de los datos.

Limitación de HTTPS/HTTP

Un archivo SWF cargado mediante un protocolo no seguro (que no sea HTTPS) no podrá acceder al contenido de un archivo cargado con un protocolo seguro (HTTPS), incluso en el caso de que ambos protocolos se encuentren en el mismo dominio.

Seguridad de reproducción local y en red

Flash Player 8 y versiones posteriores incluyen un nuevo modelo de seguridad que permite determinar el nivel de seguridad para la reproducción local y en red de los archivos SWF publicados. De forma predeterminada, los archivos SWF tienen derecho de acceso en lectura a archivos locales y de redes. Sin embargo, un archivo SWF con acceso local no puede comunicarse con la red y no puede enviar archivos ni información a ninguna red.

Permita que los archivos SWF accedan a los recursos de la red, para que puedan enviar y recibir datos. En ese caso se desactiva el acceso local a fin de evitar que la información existente en el equipo local pueda cargarse en la red.

Para seleccionar el modelo de seguridad para reproducción local o en red aplicable a sus archivos SWF, utilice el cuadro de diálogo Configuración de publicación.

Flash Player

Flash Player reproduce el contenido de Flash tal como aparece en un navegador Web o en una aplicación host de ActiveX. Flash Player está instalado en la aplicación Flash. Al hacer doble clic en el contenido de Flash, el sistema operativo inicia Flash Player, que a su vez reproduce el archivo SWF. Puede utilizar el reproductor para que los usuarios que no utilicen un navegador Web o una aplicación host de ActiveX puedan ver el contenido.

Para controlar el contenido en Flash Player, utilice comandos de menú y la función fscommand()

Utilice el menú contextual de Flash Player para imprimir fotogramas con contenido de Flash Pro.

  1. Realice uno de los siguientes pasos:

    • Para abrir un archivo nuevo o existente, seleccione Archivo > Nuevo, o bien Abrir.

    • Para cambiar la vista de la aplicación, seleccione Ver > Aumentar y realice una selección.

    • Para controlar la reproducción de contenido, seleccione Control > Reproducir, Rebobinar o Reproducir indefinidamente.

Actualizar o reinstalar Flash Player

Si experimenta problemas con la instalación de Flash Player, puede actualizar o reinstalar el programa. Vaya a la página de descarga de Flash Player directamente desde Flash seleccionando Ayuda > Obtener la versión más reciente de Flash Player.

Si prefiere desinstalar primero Flash Player, siga estos pasos:

  1. Cierre el navegador.
  2. Elimine cualquier versión instalada del reproductor.

    Para recibir instrucciones, consulte la nota técnica 14157 del Centro de soporte en www.adobe.com/go/tn_14157_es.

  3. Para iniciar la instalación, visite http://www.adobe.com/go/getflashplayer_es.

    Siga las instrucciones que aparecen en pantalla para instalar el reproductor.

    También puede ejecutar uno de los siguientes archivos de instalación de la carpeta Players. Sin embargo, el archivo de instalación del sitio web de Adobe es casi siempre mucho más reciente que los de la carpeta Players.

    • Para el control ActiveX® para Windows® (Internet Explorer o AOL), ejecute el archivo Install Flash Player 9 AX.exe.
    • Para el plugin de Windows (Firefox, Mozilla, Safari, Netscape u Opera), ejecute el archivo Install Flash Player 9.exe.
    • Para el plugin de Macintosh® (AOL, Firefox, Internet Explorer para Macintosh, Netscape, Opera o Safari), ejecute Install Flash Player 10 (Mac OS® 9.x) o Install Flash Player 10 OS X (Mac OS X.x).
    Nota:

    para comprobar la instalación, vaya a la página http://www.adobe.com/shockwave/welcome/ desde el navegador Web.

Configuración de un servidor para Flash Player

Para que los usuarios puedan ver el contenido de Flash en Internet, el servidor web debe estar bien configurado para reconocer archivos SWF.

Al configurar un servidor se establecen los tipos MIME (Multipart Internet Mail Extension) adecuados para que el servidor pueda identificar los archivos con la extensión .swf como archivos de Flash.

Un navegador que reciba el tipo MIME correcto podrá cargar el complemento, control o aplicación de ayuda adecuado para procesar y mostrar correctamente los datos recibidos. Si falta el tipo MIME o el servidor no lo ha procesado de forma correcta, es posible que el navegador muestre un mensaje de error o una ventana en blanco con un icono que contiene una pieza de puzle.

  • Si el sitio está establecido a través de un proveedor de servicios de Internet (ISP), solicite al ISP que añada el siguiente tipo MIME al servidor: application/x-shockwave-flash con la extensión .swf.

  • Si administra su propio servidor, consulte la documentación del servidor web para obtener instrucciones sobre la adición y configuración de los tipos MIME.

  • Los administradores de sistemas corporativos y de empresa pueden configurar Flash para restringir el acceso de Flash Player a los recursos del sistema de archivos local. Cree un archivo de configuración de seguridad que limite las funciones de Flash Player en el sistema local.

El archivo de configuración es un archivo de texto situado en la misma carpeta que el programa de instalación de Flash Player. Este programa de instalación lee el archivo de configuración durante la instalación y sigue sus directivas de seguridad. Flash Player utiliza el objeto System para exponer el archivo de configuración a ActionScript.

Con el archivo de configuración, desactive el acceso de Flash Player a la cámara o al micrófono, limitar el espacio de almacenamiento local que Flash Player puede utilizar, controlar la función de actualización automática y bloquear Flash Player de modo que no pueda leer ningún dato del disco duro local del usuario.

Cómo añadir tipos MIME

Cuando un servidor web accede a archivos, debe identificar correctamente esos archivos como contenido de Flash para poder mostrarlos. Si falta el tipo MIME o el servidor no lo ha enviado de forma correcta, es posible que el navegador muestre mensajes de error o una ventana vacía con un icono que contiene una pieza de rompecabezas.

Si el servidor no está configurado correctamente, es necesario que el usuario (o el administrador del sistema) añada los tipos MIME del archivo SWF a los archivos de configuración del servidor y asocie los tipos MIME siguientes a las extensiones de archivo SWF:

  • La aplicación de tipo MIME /x-shockwave-flash tiene la extensión de archivo .swf.

  • La aplicación de tipo MIME/futuresplash tiene la extensión de archivo .spl.

Si se encarga de la administración de su servidor, consulte la documentación del software del servidor donde encontrará instrucciones sobre cómo añadir o configurar tipos MIME. Si no administra un servidor, póngase en contacto con el proveedor de servicios de Internet, con el Web master o el administrador del servidor y solicite que añadan la información de los tipos MIME.

Si su sitio está en un servidor Macintosh, también debe definir los parámetros siguientes: Action: Binary; Type: SWFL y Creator: SWF2.

Optimización del motor de búsqueda para contenido SWF

A mediados de 2008, Adobe anunció un avance significativo en la tecnología de Flash Player que permite que el contenido de texto de los archivos SWF pueda indexarse mediante motores de búsqueda como Google y Yahoo!. Existe una serie de estrategias que pueden emplearse para optimizar la visibilidad del contenido SWF en motores de búsqueda. Estas prácticas se denominan optimización del motor de búsqueda (SEO).

Omniture y Flash

El contenido se Flash puede integrarse con Omniture SiteCatalyst y Omniture Test&Target. SiteCatalyst ayuda a los operadores de mercado a identificar con rapidez las medidas más rentables en su sitio web, determinar el lugar donde navegan los visitantes fuera de su sitio, así como identificar sistemas de evaluación de éxito que resultan fundamentales para las campañas de marketing en línea. Test&Target proporciona a los operadores de mercado la capacidad de dotar al contenido de en línea de mayor relevancia para sus clientes. Test&Target ofrece una interfaz para diseñar y ejecutar pruebas, crear segmentos de audiencia y dirigir el contenido.

Los clientes de Omniture pueden utilizar SiteCatalyst y Test&Target con Flash para descargar e instalar el paquete Omniture Extension.

  • Para descargar las extensiones de Omniture y acceder a las instrucciones de uso, seleccione Ayuda > Omniture.

Logotipo de Adobe

Inicia sesión en tu cuenta