Импорт SVG файлов

Последнее обновление 21 сент. 2026 г.

Узнайте, как импортировать файлы SVG как собственные редактируемые слои-фигуры, готовые к анимации без необходимости преобразования.

Дважды щелкните внутри панели Проект или используйте Файл > Импорт > Файл, чтобы найти и импортировать SVG файл.

Примечание

Последняя бета-версия After Effects позволяет импортировать файл как видеоряд или композицию.

Перетащите импортированный файл SVG на панель Таймлайн.

Выберите слой, чтобы использовать раздел Содержимое слоя на панели Свойства для просмотра структуры SVG.

Панель "Свойства" открыта, и под разделом "Содержимое слоя" перечислено содержимое SVG.
Используйте панель "Свойства" для просмотра содержимого файла SVG и настройки его свойств.

Вы также можете нажать на стрелку рядом со слоем, чтобы развернуть его, затем развернуть раздел Содержимое. Вы увидите все отдельные элементы и их свойства, такие как Контур, Заливка и Трансформация.

Выбран слой с файлом SVG, и раздел "Содержимое" развернут для отображения его свойств, включая "Контур", "Заливка" и "Трансформация".
Разверните раздел "Содержимое" SVG-слоя для доступа и редактирования его свойств, включая "Контур", "Заливка" и "Трансформация".

Вы можете использовать эти свойства для анимации так же, как и любой другой слой фигуры. Например:

  • Анимируйте Контур для создания эффектов морфинга
  • Изменяйте цвет заливки со временем для динамических переходов
  • Используйте свойства Трансформация для независимого масштабирования, вращения или перемещения элементов

Если слои имеют градиентные заливки и обводки, можно использовать свойства Масштаб и Поворот для анимации градиента.

Выбран один из слоев с градиентным элементом, и выделена Градиентная заливка 1.
Используйте свойства градиентной заливки для настройки градиента или их анимации.

Импорт SVG-файла как футажа или композиции

Импорт SVG в After Effects обеспечивает гибкость и более точное управление тем, как SVG-файлы импортируются в ваш проект. В последней версии при импорте файла SVG вы можете выбрать, импортировать его как видеоряд или как композицию.

Импортировать как видеоряд

Импортировать как композицию

Импортирует SVG как единый, непрерывно растеризуемый векторный слой.

Импортирует SVG как композицию, состоящую из редактируемых слоев фигур.

Поддерживает связь с внешним SVG-файлом.

Каждый элемент преобразуется в собственную редактируемую фигуру.

Подходит для однослойной векторной графики, когда не нужно разбивать изображение на части.

Подходит для редактирования контуров, фигур и деталей на уровне слоя, когда нужно анимировать отдельные элементы.

Вы можете управлять тем, какой способ импорта используется по умолчанию при импорте SVG-файлов, установив параметр Перетаскивание нескольких элементов файла как в настройках Импорт.

  • macOS: After Effects > Настройки > Импорт > Перетаскивание нескольких элементов файла как
  • Windows: Правка > Настройки > Импорт > Перетаскивание нескольких элементов файла как
Открыто диалоговое окно «Настройки». На вкладке «Импорт» открыто выпадающее меню «Перетаскивание нескольких элементов файла как», предлагающее варианты выбора способа импорта.
Установите предпочтение по умолчанию для импорта SVG-файла, выбрав, импортировать ли его как футаж или как композицию.

Дважды щелкните внутри панели Проект или используйте Файл > Импорт > Файл, чтобы найти и импортировать SVG файл.

Используйте выпадающее меню Импортировать как в диалоговом окне Импорт файла, чтобы выбрать один из следующих вариантов:

  • Видеоряд
  • Композиция - сохранить размеры слоев

Выбор опции Видеоряд импортирует файл как единый сведенный слой без доступа к отдельным элементам, что делает его подходящим для статического использования или когда анимация не требуется. Выбор Композиция - сохранить размеры слоев создает новую композицию, где каждый исходный слой импортируется отдельно, размер которого соответствует его фактическому содержимому, делая точки привязки более четкими, а трансформации проще для анимации.

macOS

Открыто диалоговое окно «Import file» с параметрами импорта файла как видеоряда или как композиции.

Windows

Открыто диалоговое окно «Import file» с параметрами импорта файла как видеоряда или как композиции.

Выберите следующие параметры, если применимо:

  • Создать композицию. Создает новую композицию с настройками по умолчанию и автоматически размещает импортированный SVG, либо как видеоряд, либо как композицию со слоями фигур, на временной шкале, избавляя вас от необходимости вручную создавать композицию и перетаскивать в нее SVG-файл.
  • Масштабируемая последовательность векторной графики. Импортирует несколько пронумерованных файлов SVG и обрабатывает их как покадровую последовательность векторных изображений.

Используйте раздел Содержимое слоя на панели Свойства или раздел Содержимое слоя на шкале времени, чтобы просматривать отдельные элементы и их свойства и работать с ними, если вы импортировали SVG-файл как композицию. При импорте в качестве видеоряда он ведет себя как обычный слой и может быть откорректирован с помощью стандартных свойств опции Преобразовать.

Как и в случае с файлами Illustrator, если векторный файл импортирован как видеоряд, вы можете выбрать слой на временной шкале, щелкнуть по нему правой кнопкой мыши и выбрать Создать > Создать фигуры и текст из векторного слоя, чтобы преобразовать его в редактируемые слои, что позволит анимировать отдельные контуры, обводки и заливки.В последней бета-версии After Effects текст в исходном файле преобразуется в редактируемые текстовые слои, которые сохраняют шрифт, кегль, заливку, положение, стили, обводки и настройки меняющегося шрифта. 

При импорте SVG как футажа After Effects сохраняет активную связь с исходным файлом, поэтому любые изменения, внесенные в этот SVG вне приложения, автоматически обновляются внутри вашего проекта.

Преобразование текста Illustrator в редактируемые текстовые слои

Используйте новые бета-функции

Редактируемый текст из файлов Illustrator теперь доступен для тестирования и обратной связи. Попробуйте эту функцию в After Effects (бета-версия).

В последней бета-версии After Effects, когда слой Illustrator импортируется как видеоряд, любой текст в исходном файле преобразуется в отдельный редактируемый текстовый слой вместо того, чтобы быть сведенным в контуры фигур. Это означает, что шрифт, кегль, заливка, положение, стили (такие как полужирный и курсив), обводки и настройки меняющегося шрифта переносятся, поэтому вы можете продолжить редактировать текст прямо в After Effects вместо того, чтобы создавать его заново или возвращаться в Illustrator для внесения изменений.

Выберите Файл > Импорт > Файл, а затем файл Illustrator, который вы хотите импортировать.

В диалоговом окне Импортировать файл убедитесь, что для параметра Импортировать как установлено значение Видеоряд при выборе файла для импорта.

В диалоговом окне импорта убедитесь, что для параметра Тип импорта установлено значение Видеоряд, и выберите настройки в разделе Параметры слоев в зависимости от того, какие элементы файла Illustrator вы хотите импортировать.

Перетащите импортированный файл на панель Таймлайн.

Щелкните правой кнопкой мыши на слое Illustrator и выберите Создать > Создать фигуры и текст из векторного слоя или воспользуйтесь меню Слой > Создать > Создать фигуры и текст из векторного слоя.

Подменю "Слой > Создать" с выделенной командой "Создать фигуры и текст из векторного слоя"; эта команда преобразует векторный текст в редактируемые текстовые слои.
Выберите "Создать фигуры и текст из векторного слоя", чтобы преобразовать текст Illustrator в редактируемые текстовые слои After Effects вместо фигур.

Текст преобразуется в редактируемый текстовый слой, который точно соответствует шрифту, кеглю, заливке и положению исходного файла. Затем вы можете редактировать и корректировать текст прямо в After Effects.

Текстовый слой "Яркость" на графике пламени, с панелью "Символ", показывающей шрифт Adobe Clean Italic, кегль 74 пикселя и включенную заливку.
После преобразования текст остается полностью редактируемым — шрифт, стиль, кегль и заливку по-прежнему можно изменить в панели "Символ".

Примечание

Текст только с обводкой по-прежнему преобразуется в контуры, а не в редактируемый текстовый слой. 

Нетекстовый векторный контент по-прежнему преобразуется в слои-фигуры, как и раньше, и если файл Illustrator содержит и то, и другое, вы получите смесь текстовых слоев и слоев-фигур.

Присоединяйтесь к обсуждению в нашем сообществе After Effects (бета-версия) о поддержке редактируемого текста из файлов Illustrator.

Копирование и вставка контента illustrator и SVG

Контент SVG из буфера обмена теперь можно вставлять в After Effects с помощью команды Правка > Вставить. Контент импортируется как собственные редактируемые слои фигур, готовые к анимации, без промежуточного этапа импорта.

Копировать контент из Illustrator

Откройте иллюстрацию в Adobe Illustrator.

Убедитесь, что выбрана настройка Включить код SVG .

  • macOS. Выберите Illustrator > Настройки > Обработка буфера обмена и выберите Включить код SVG.
  • Windows. Выберите Правка > Настройки > Обработка буфера обмена и выберите Включить код SVG.
Диалоговое окно «Настройки» открыто в Illustrator, и выбран параметр «Включить код SVG».
Включите параметр «Включить код SVG», чтобы ваши изображения оставались редактируемыми и высокого качества в других приложениях Adobe.

Выберите графический объект, который хотите скопировать.

Совет

Преобразуйте любой текст SVG в кривые перед копированием, поскольку текст SVG не поддерживается при вставке.

Выберите пункт меню Изменить > Копировать.

Переключитесь в After Effects и выполните одно из следующих действий в зависимости от состояния вашего проекта:

  • Если проект не открыт, выберите команду Правка > Вставить, чтобы создать новый проект с композицией, содержащей контент SVG в виде слоя-фигуры.
  • Если проект открыт, но композиция не выбрана, выберите команду Правка > Вставить, чтобы создать новую композицию в текущем проекте с вставленным контентом.
Выбран параметр «Правка > Вставить», и контент импортируется как собственные редактируемые слои-фигуры, готовые к анимации.
Параметр «Правка > Вставить» импортирует контент как редактируемые слои-фигуры, готовые к анимации.

Если композиция выбрана в After Effects, выберите Правка > Вставить, чтобы добавить контент SVG как новый слой-фигуру в эту композицию.

Вставка SVG из других приложений

Контент SVG, скопированный из любого приложения, которое записывает SVG в системный буфер обмена, можно вставить, используя тот же технологический процесс Правка > Вставить. Поддержка зависит от того, помещает ли исходное приложение действительные данные SVG в буфер обмена.