В этом документе пойдет речь о CINEMA 4D и Cineware

CINEMA 4D — это популярный инструмент для 3D-моделирования и анимации от Maxon(www.maxon.net).

Тесная интеграция с CINEMA 4D позволяет использовать Adobe After Effects совместно с Maxon CINEMA 4D. В After Effects можно создать файл CINEMA 4D (C4D) и работать со сложными 3D-элементами, сценами и анимациями.

Для обеспечения совместимости в Adobe After Effects интегрирован CineRender, ядро рендеринга Maxon CINEMA 4D. After Effects позволяет выполнять рендеринг файлов CINEMA 4D. На каждом слое можно управлять некоторыми аспектами рендеринга, камерой и содержимым сцены. Этот налаженный технологический процесс не требует создания промежуточных файлов или файлов набора изображений.

Maxon CINEMA 4D Lite R19

Приложение Maxon CINEMA 4D Lite R19 устанавливается вместе с After Effects. Файлы CINEMA 4D можно создавать, редактировать и импортировать. Однако при наличии другой версии CINEMA 4D, например CINEMA 4D Prime, можно использовать и ее. Приложение CINEMA 4D Lite R19 предоставляет возможность редактировать, создавать и использовать собственные файлы Cinema 4D. Функции версии Lite аналогичны функциям CINEMA 4D Prime.

По умолчанию используется наиболее поздняя версия установленного приложения CINEMA 4D.  

Чтобы научиться использовать CINEMA 4D Lite с камерами и источниками света в After Effects, см. этот урок.


Эффект Cineware
Окно Cinema 4D

Работа с файлами CINEMA 4D

Существует несколько способов создания, импорта и редактирования файлов CINEMA 4D в After Effects.

Импорт файлов CINEMA 4D

Чтобы импортировать файлы CINEMA 4D в After Effects, выполните указанные ниже действия.

  1. Выберите Файл > Импорт > Файл.

  2. Выберите файл CINEMA 4D и нажмите Импорт. Файл будет помещен на панель Проект в качестве элемента видеоряда. Можно поместить элемент видеоряда в текущую композицию или создать соответствующую композицию.

Примечание.

При размещении на панели проекта видеоряда в новой композиции с использованием значка новой композиции создается новая композиция, которая соответствует настройкам файла Cinema 4D. Затем создается слой CINEMA 4D, и на нем — 3D-сцена. Если перенести видеоряд в существующую композицию, он будет принят с использованием размера/пропорций композиции.

Примечание.

Перед импортом включите настройки Сохранить многоугольники для меланжа и Сохранить анимацию для меланжа в настройках приложения CINEMA 4D. Эти настройки оказываются особенно полезными в случае зависимости кадров CINEMA 4D от предыдущих кадров.

Редактирование файлов CINEMA 4D

В окне «Проект» можно изменить файлы CINEMA 4D, помещенные в композиции, а также исходные элементы CINEMA 4D. Файлы открываются в приложении CINEMA 4D Lite R19. Если имеется другая версия CINEMA 4D, то для редактирования файлов будет использоваться она. См. раздел Редактирование видеоряда в исходном приложении.

Можно выбрать нужную версию CINEMA 4D для использования с командой Редактировать оригинал. См. раздел Работа с разными экземплярами CINEMA 4D в Cineware Effect.

Для получения дополнительной информации ознакомьтесь с видеороликом, который подготовил Джефф Сенгстак (Jeff Sengstack): Импорт и редактирование файлов CINEMA 4D.

Создание файлов CINEMA 4D

  1. В After Effects можно создавать файлы CINEMA 4D. Для этого выберите Файл > Создать > Файл Maxon CINEMA 4D или Слой > Создать > Файл Maxon CINEMA 4D.

  2. Укажите имя и расположение файла.

  3. Откроется приложение CINEMA 4D.

  4. Создайте сцену C4D и выберите Файл > Сохранить для сохранения файла.

Для получения дополнительной информации ознакомьтесь с видеороликом, который подготовил Джефф Сенгстак (Jeff Sengstack): Создание файлов CINEMA 4D.

Экспорт в Maxon CINEMA 4D и интегрированная обработка правок с помощью канала Live 3D

Можно экспортировать композиции с анимированным 3D-текстом и слоями-фигурами в Maxon CINEMA 4D с помощью канала After Effects Live 3D в рамках интегрированного рабочего процесса для 3D.

Слои 3D-фигур экспортируются в виде экструдированных сплайнов и включают в себя анимацию свойств слоя-фигуры.

При выборе варианта «Экструдировать текст как фигуры» трехмерные текстовые слои экспортируются как экструдированные сплайны в файл .c4d. Этот параметр сохраняет точность слоя: форматирование символов и абзацев и анимацию свойств текстового слоя. Нельзя изменить шрифт и текстовое содержимое в CINEMA 4D.

При выборе варианта «Сохранить редактируемый текст» трехмерные текстовые слои экспортируются как экструдированные текстовые объекты в файл .c4d. В этом случае можно изменять шрифт и текст в CINEMA 4D. В то же время, этот вариант обеспечивает ограниченную поддержку форматирования символов и абзацев, а также анимации свойств текстового слоя. Не поддерживаются следующие функции анимации текста: аниматоры текста, кернинг, трекинг, вертикальный текст, текст абзаца и текст по контуру.

Обводки 3D-текста и слои-фигуры экспортируются в файл .c4d. В то время как модуль 3D-рендеринга с трассировкой лучей в After Effects не преобразует обводки для слоев 3D-текста, обводки экспортируются, если они включены. Чтобы просмотреть обводки слоев 3D-текста перед экспортом убедитесь, что выбран режим рендеринга композиции «Classic 3D».

Экспорт в Maxon CINEMA 4D

Чтобы выполнить экспорт в функции CINEMA 4D, выполните следующие действия.

  1. Выберите Файл > Экспорт > Средство экспорта Maxon CINEMA 4D и сохраните файл C4D.

  2. В диалоговом окне Экспорт в Maxon CINEMA 4D выберите один из следующих вариантов:

    • «Экструдировать текст как фигуры»: создает файл .c4d с основной экструзией.
    • «Сохранить редактируемый текст»: экспортирует слои 3D-текста как экструдированные текстовые объекты в файле .c4d, что позволяет изменять шрифт и текст в CINEMA 4D.

Примечание.

  • Если маловероятно, что текст изменится после экспорта, рекомендуется выбрать вариант «CINEMA 4D: экструдировать текст как фигуры» в диалоговом окне «Экспорт текста». 
  • При экспорте координаты сцены для родительского нулевого объекта сдвигаются так, чтобы центр композиции After Effects соответствовал центру CINEMA 4D в точке с координатами 0,0,0. 
  • Экспортированные файлы .c4d, сохраняются в версии 17.0 CINEMA 4D.

Импорт и редактирование файла .c4d в Maxon CINEMA 4D

Можно импортировать созданный файл .c4d в композицию After Effects для редактирования. Выберите «Правка» > «Редактировать оригинал», чтобы отредактировать файл .c4d в CINEMA 4D.

При импорте и добавлении файла .c4d, созданного средством экспорта версии Cineware 3.1, в композицию можно просмотреть сцену через камеру After Effects, для этого сначала необходимо добавить камеру, а затем добавить настройку «Камера» в эффекте Cineware и выбрать вариант «Камера композиции по центру».

Все добавляемые к композиции слои After Effects 3D выравниваются со слоем сцены CINEMA 4D после экспорта. Извлеченные данные 3D-сцены из файла .c4d, например нулевые объекты, камеры и источники света, также выравниваются при условии, что все новые объекты, добавленные в файл .c4d, группируются под тем же родительским нулевым объектом, который создан в экспортированном файле .c4d.

Чтобы открыть экспортированный файл Cinema 4D в After Effects и CINEMA 4D для внесения дополнительных правок, выполните следующие действия:

  1. Выберите Файл > Импорт и укажите файл C4D, который требуется импортировать в композицию.

  2. Чтобы настроить 3D-элементы, используя CINEMA 4D, выберите слой Cineware, затем выберите команду Правка > Редактировать оригинал (или нажмите сочетание клавиш Command+E в Mac OS или Ctrl+E в Windows). Файл C4D откроется в приложении CINEMA 4D, входящем в состав After Effects CC.

  3. Внесите изменения и сохраните файл. Композиция After Effects автоматически обновляется в соответствии со всеми изменениями. 

Эффект Cineware

Интеграция модуля CineRender, который основано на ядре рендеринга CINEMA 4D, позволяет выполнять рендеринг слоев на основе файлов CINEMA 4D прямо в программе After Effects. Эффект Cineware позволяет управлять настройками рендеринга и обеспечивает определенный контроль над сочетанием качества/скорости рендеринга. Можно также указать камеры, проходы или слои C4D, используемые для рендеринга. Эффект Cineware автоматически применяется при создании слоя на основе видеоряда C4D в композиции. Каждый слой CINEMA 4D имеет собственные настройки рендеринга и отображения.

Дополнительные сведения см. в видеоролике Adobe TV Принципы работы эффекта Cineware и ядра рендеринга.

Синхронизация слоя

При добавлении нескольких экземпляров слоя сцены CINEMA 4D в композицию, включая многопроходные слои, можно выбрать слои CINEMA 4D, которые требуется синхронизировать с остальными слоями в композиции.

Когда установлен флажок Синхронизировать слой AE вверху на панели «Элементы управления эффектами», настройки рендеринга и параметры камеры во всех экземплярах слоя автоматически синхронизируются, но слои CINEMA 4D можно настраивать по отдельности. Если для определенного слоя сцены CINEMA 4D этот флажок снят, то ни одна из настроек этого слоя не будет синхронизироваться с остальными слоями в композиции.

Live Link обеспечивает синхронизацию таймлайнов CINEMA 4D и After Effects.

Для работы с Live Link нажмите кнопку «Включить» для Live Link. Текущий файл будет открыт в указанной версии CINEMA 4D. Чтобы включить Live Link в CINEMA 4D, введите команду «Правка» > «Установки» > «Связь» > «Live Link», затем выберите пункт «Включать Live Link при запуске». Синхронизация таймлайнов выполняется при переключении между After Effects и CINEMA 4D. Когда выбирается другой слой C4D в After Effects, нажмите кнопку Enable (Включить), чтобы синхронизировать этот слой.

Настройки рендеринга

Настройки рендеринга Cineware определяют, как следует выполнять рендеринг сцены в After Effects. Эти настройки позволяют ускорить рендеринг, позволяя при этом выполнять другие действия.

Модуль рендеринга

Определяет используемый модуль рендеринга. Возможны следующие варианты.

  • Стандарт (итоговое). Использует стандартный модуль рендеринга, указанный в файле C4D. Для редактирования этих настроек используйте приложение CINEMA 4D.
  • Стандарт (черновое). Использует стандартный модуль рендеринга, но отключает более медленные настройки, такие как сглаживание, для более быстрого взаимодействия.
  • Программное обеспечение. Использует настройки для обеспечения наиболее быстрого рендеринга, позволяя менять Настройки отображения. Шейдеры и многопроходные операции не отображаются. Используйте модуль рендеринга «Программное обеспечение», чтобы продолжить работу с композицией.
  • OpenGL: аппаратно ускоренный рендеринг обеспечивает более высокое качество и более высокую скорость по сравнению с программным рендерингом. Модуль рендеринга OpenGL в CINEWARE поддерживает тот же повышенный уровень качества OpenGL, как и CINEMA 4D в отношении таких свойств как «Прозрачность», «Тени», «Эффекты завершающей обработки» и «Шумы».

Примечание.

При сохранении файла .c4d в полной розничной версии CINEMA 4D (не CINEMA 4D Lite R19, поставляемой в комплекте с After Effects), в случае если в настройках рендеринга выбран физический или аппаратный рендеринг, файл визуализируется с этими настройками рендеринга, если в CINEWARE выбран режим рендеринга «Стандартный (окончательный)» или «Стандартный (черновое качество)». 

Показать

Этот параметр доступен только при использовании модуля рендеринга Программное обеспечение. Доступные параметры: Текущие тени, Каркас и Рамка. Режимы «Каркас» и «Рамка» предоставляют упрощенное представление сцены.

Без текстур/шейдера

Выберите этот параметр, чтобы ускорить рендеринг, исключив из него текстуры и шейдеры.

Без предрасчета

Выберите этот параметр, чтобы ускорить рендеринг, исключив из нее предварительные расчеты для вычисления динамики движения или моделирование частиц. Не включайте этот параметр для итогового рендеринга.

Хранить текстуры в ОЗУ

Выберите этот параметр для кэширования текстур в ОЗУ, чтобы они не загружались с диска повторно и более быстро открывались. С другой стороны, кэширование больших текстур снижает объем доступной памяти.

Сервер рендеринга

Очистить память: стирается память сервера рендеринга. На протяжении периода времени скорость отклика сервера рендеринга может ухудшаться, так как он продолжает хранить обрабатываемые сцены. Очистка памяти, которую сервер рендеринга использует в качестве внутреннего кэша, может увеличить продолжительность предпросмотра сложных сцен в After Effects.

Настройки проекта

Эффект Cineware поддерживает следующие настройки проекта:

  • Камера
  • Слои CINEMA 4D
  • Несколько проходов (линейный рабочий процесс)
  • Команды

Камера

Выберите камеру, которая будет использоваться для рендеринга.

Камера CINEMA 4D. Используется камера, определенная как камера представления рендеринга в CINEMA 4D, или камера по умолчанию, если определенная камера не указана.

Выбрать камеру CINEMA 4D. Используйте этот параметр для выбора камеры. Если этот параметр доступен, щелкните элемент «Задать камеру».

Камера композиции по центру: используйте этот параметр, чтобы задействовать камеру After Effects и повторно вычислитькоординатыCINEMA 4D и адаптировать их к координатам After Effects. При импорте существующего файла C4D (как правило, моделируется около 0,0,0) для рендеринга с использованием новой камеры After Effects (которая центрируется по композиции) используйте модель C4D по центру композиции After Effects.В противном случаемодель может быть неожиданно смещена в силу разницы начал.

Камера композиции. Используйте этот параметр для включения активной камеры After Effects. Чтобы этот параметр был доступен, необходимо добавить камеру After Effects. Например, используйте этот параметр для камеры, добавленной путем извлечения из проекта CINEMA 4D (поскольку такие камеры ссылаются на координатную систему CINEMA 4D, согласно которой точка 0,0,0 находится в центре окна просмотра CINEMA 4D). Этот параметр подходит для камер, добавленных в After Effects с помощью команды Слой > Создать > Камера.

Выбор камеры: если сцена CINEMA 4D содержит камеры помимо камеры по умолчанию, нажмите на эту кнопку и выберите камеру. 

Выбор дубля: данный параметр включен, если файл c4d содержит дубли. Можно создавать несколько дублей сцены и изменять любой параметр в дубле. Если текущий модуль рендеринга не поддерживает выбор дублей, используется основной дубль.

Слои CINEMA 4D

Включите и выберите слои CINEMA 4D для рендеринга.

Задать слои

Щелкните для выбора слоев. Нажмите кнопку Задать слои, чтобы выбрать один или несколько слоев. В приложении CINEMA 4D слои позволяют организовать несколько элементов. Можно использовать слои CINEMA 4D для структурирования элементов в композиции After Effects.

Несколько проходов (линейный рабочий процесс)

Используйте параметр Несколько проходов Cinema 4D для определения проходов рендеринга. Функции с несколькими проходами доступны только для стандартного модуля рендеринга.

Несколько проходов предоставляют возможность быстро вносить точные изменения в сцену C4D путем составления различных типов проходов в After Effects, например изменения теней или отражений в сцене. Чтобы результаты соответствовали настройке проекта CINEMA 4D Линейный рабочий процесс по умолчанию, необходимо работатьвв проекте с наложением цветов в линейном свете (в линейном рабочем пространстве с управлением цветами или с применением набора Смешивать цвета, используя гамму 1.0 в диалоговом окне Настройки проекта).

Установить несколько проходов

Щелкните для выбора прохода, рендеринг которого следует выбрать на этом слое. Этот параметр доступен только в том случае, если включен параметр «Несколько проходов» в CINEMA 4D.

Определенные несколько проходов

Если этот параметр включен, он напрямую добавляет проходы, добавленные в файле .c4d. В их число могут входить проходы, отличные от слоев изображений.

Добавить слои изображений

Используйте этот параметр для создания слоев с несколькими проходами с определенными режимами наложения в зависимости от настройки Определенные несколько проходов. Если параметр «Определенные несколько проходов» включен, то параметр Добавить слои изображений позволяет добавлять только проходы, заданные в настройках рендеринга CINEMA 4D, а не все поддерживаемые типы.

Примечание.

При добавлении слоев изображений первоначально выбранный слой будет помещен в нижнюю часть стека «Таймлайн», а к его названию добавится определение Изображение RGBA, обозначающее слой с несколькими проходами.

Команды

Используйте следующие команды.

Камера композиции в CINEMA 4D

Щелкните Слияние, чтобы добавить текущую камеру After Effects в качестве камеры C4D в файл C4D. Это приведет к изменению файла C4D. Используйте меню Файл > Восстановить сохраненный в C4D для отображения новой добавленной камеры After Effects. Эта команда особенно полезна для передачи данных камеры, созданных функцией 3D Camera Tracker. К имени камеры добавляется префикс AE.

Примечание. При повторном слиянии предыдущая камера не обновляется. Вместо нее создается новая копия.

Данные сцены CINEMA 4D

Нажмите Извлечь, чтобы создать данные 3D, такие как камеры, освещение, сплошные заливки или пустые объекты, к которым в проекте CINEMA 4D был добавлен тег внешнего составления.

Примечание.

Всегда включайте параметры Сохранить многоугольники для меланжа и Сохранить анимацию для меланжа в меню настроек CINEMA 4D, чтобы избежать проблем при извлечении данных сцены в After Effects.

Примечание.

В зависимости от настроек безопасности компьютера могут отображаться предупреждения об обмене данными через протокол TCP. Они связаны с тем, что After Effects и фоновый процесс рендеринга CINEMA 4Dприменяютпротокол TCP для обмена данными, а некоторые виды ПО для обеспечения безопасности могут воспринимать такие процессы как отправку данных вредоносным ПО. Например, ОС Mac OS может запросить подтверждение запуска этого программного обеспечения, «загруженного из Интернета». Подтвердите, что вы хотите выполнить данное ПО.

Если файл .c4d удалось импортировать, но не удалось выполнить рендеринг, убедитесь в том, что функция Gatekeeper в Mac OS или брандмауэр не заблокировали фоновый процесс рендеринга CINEMA 4D, закрыв для него возможность выполнения и обмена данными с After Effects. Для пользователей Mac: задайте для параметра Разрешить загрузку приложений из (на вкладке Общие в системных установках Безопасность и конфиденциальность) значение Отовсюду.

Используемый TCP-порт указывается в пункте Параметры эффекта Cineware, а выбранные значения сохраняются в файле настроек After Effects.

Работа с разными экземплярами CINEMA 4D в Cineware Effect

Можно указать экземпляр CINEMA 4D для использования в эффекте Cineware.

Параметры Cineware
Параметры Cineware

Путь к модулю рендеринга и путь к редактору Cineware
Путь к модулю рендеринга и путь к редактору CINEMA 4D


Откройте меню Эффект Cineware > Параметры и настройте следующие параметры.

  • CINEMA 4D Render Path (Путь к модулю рендеринга CINEMA 4D) — выберите экземпляр CINEMA 4D для рендеринга в After Effects, если в системе установлена платная полнофункциональная версия CINEMA 4D.
  • CINEMA 4D Editor Path (Путь к редактору CINEMA 4D) — выберите версию CINEMA 4D, которая будет использоваться при открытии файла .c4d в After Effects с помощью команды Редактировать оригинал или при создании нового файла CINEMA 4D в After Effects. В качестве редактора по умолчанию используется самая актуальная установленная версия CINEMA 4D или CINEMA 4D Lite R19.

По умолчанию приложение CINEMA 4D размещается в следующей папке:

  • C:\Program Files\Adobe\Adobe After Effects CC\Support Files\Plug-Ins\MAXON CINEWARE AE\(CINEWARE Support)\lite\CINEMA 4D Lite.exe (на компьютерах Windows)
  • /Applications/Adobe After Effects CC /Plug-ins/MAXON CINEWARE AE/(CINEWARE Support)/Lite/CINEMA 4D Lite.app (на компьютерах Mac).

Примечание.

Если после использования полной розничной версии CINEMA 4D в качестве средства рендеринга потребуется переключиться на модуль рендеринга Cineware по умолчанию, нажмите кнопку По умолчанию в диалоговом окне Выбор установки CINEMA 4D.

Переключение путей к модулю рендеринга

Чтобы переключить пути к модулю рендеринга (например, изменить приложение CINEMA 4D, используемое для рендеринга), выполните следующие действия.

  1. Выберите Параметры > Обзор для настройки пути к модулю рендеринга.

  2. Выберите новое приложение.

  3. Закройте приложение After Effects.

  4. Запустите After Effects.

  5. Нажмите Правка > Очистить > Вся память и кэш диска, чтобы новые настройки вступили в силу.

Примечание.

Если произойдет сбой подключения после переключения на другое средство рендеринга, выполните выход из After Effects, подождите 20–30 секунд, затем повторно запустите приложение.

Возможности рендеринга

При выборе CINEMA 4D R14 или более поздней версии в качестве модуля рендеринга в подключаемом модуле After Effects Cineware становятся доступны различные возможности рендеринга, помимо возможностей по умолчанию (например, модули рендеринга Physical [Физический] и Sketch and Toon [Рисунки и мультфильмы]).

Для применения модуля рендеринга Physical Renderer выполните следующие действия.

  1. Выберите модуль рендеринга Physical Renderer в диалоговом окне CINEMA 4D Render Settings (Настройки рендеринга Cinema 4D).

    1. В меню Render (Рендеринг) выберите Render > Edit Render Settings (Рендеринг > Изменить настройки рендеринга).
    2. В диалоговом окне Render Settings (Настройки рендеринга) задайте параметр Renderer: Physical (Модуль рендеринга: физический).
    3. Нажмите на параметр Physical (Физический) и задайте другие настройки, например глубину поля или размытие в движении.
  2. Сохраните файл C4D с заданными настройками рендеринга.

  3. Модуль рендеринга, заданный в CINEMA 4D, будет использоваться эффектом Cineware, если в настройках рендеринга для данного эффекта заданы параметры Standard (Final) (Стандартный (конечный)) и Standard (Draft) (Стандартный (черновик)).

Примечание.

Воздействием модуля рендеринга Sketch and Toon (Рисунки и мультфильмы) на отдельные объекты можно управлять в диспетчере объектов, добавив Tags > Sketch Tags > Sketch Style (Метки > Метки скетча > Стиль скетча) (дополнительную информацию о модуле рендеринга см. в https://help.maxon.net/справке Maxon по CINEMA 4D).

Для применения модуля рендеринга Sketch and Toon выполните следующие действия.

  1. В меню Create (Создать) приложения CINEMA 4D выберите Create > Material > Sketch Material (Создать > Материал > Материал скетча).

    1. В диалоговом окне Render Settings (Настройки рендеринга) задайте параметр Renderer: Standard (Модуль рендеринга: стандартный).
    2. Убедитесь в том, что в диалоговом окне Render Settings (Настройки рендеринга) добавлены эффекты обработки после применения модуля Sketch and Toon и установлены соответствующие флажки.
  2. Сохраните файл C4D с активированным модулем рендеринга Sketch and Toon.

  3. К результатам рендеринга Sketch and Toon будет применяться эффект Cineware, если для параметра модуля рендеринга для данного эффекта задано значение Standard (Final) (Стандартный (конечный)).

Примечание.

С Cineware совместимы следующие версии CINEMA 4D:

  • R14.042 и более поздние версии. Для установки текущей версии используйте интерактивное средство обновления CINEMA 4D.
  • R15.037 и более поздние версии.
  • R16
  • R17
  • R19

Сведения о новом модуле 3D-рендеринга, используемом для экструзии текста и фигур, см. в разделе Модуль рендеринга композиции CINEMA 4D.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет