Preview video and audio

Though it is common to speak of rendering as if this term only applies to final output, the processes of creating previews to show in the Footage, Layer, and Composition panels are also kinds of rendering.

You can preview all or part of your composition as you work, without rendering to final output. Many of the controls for previewing are in the Preview panel.

Use preview to play video and audio

After Effects allocates RAM to play video and audio in the Timeline, Layer, or Footage panel at real-time speed. The number of frames that can be stored for real-time playback depends on the amount of RAM available and the settings in the Preview panel.

The default preview behavior is configured to produce a preview that represents a real-time playback. When you press spacebar (the default keyboard shortcut), After Effects starts a preview with audio, and caches frames until the available RAM is filled.

  • To start a preview of video and audio, do any of the following:

    • Press any Preview keyboard shortcut Spacebar, Shift+spacebarNumpad-0, Shift+Numpad-0, Numpad ., or Option/Alt+Numpad . (period). Each keyboard shortcut results in a different Preview behavior, based on the Preview settings assigned to each of the keys. You can configure the Preview behavior for each keyboard shortcut by modifying settings in the Preview panel. For more information, see Configure Preview Behaviors.
    • Click the  (Play) button in the Preview panel. When you click the Play button, settings assigned for the Shortcut currently displayed in the Preview panel, are used.
    • Select Composition > Preview > Play. When you select the Play option, settings assigned for the shortcut currently displayed in the Preview panel are used.

Configure Preview behaviors

You can configure the Preview options to suit your working style. Controls in the Preview panel allow you to configure preview behaviors for each keyboard shortcut (Spacebar, Shift+spacebar, Numpad-0,Shift+Numpad-0, Numpad-, or Option/Alt+Numpad-): audio, looping, caching, range, and layer controls.

To configure settings for Preview, do the following:

  1. The Preview panel is open by default in most workspaces within After Effects. However, if the Preview panel is closed, select Window > Preview to open it.

    After Effects Preview panel
    Preview panel

  2. In the Preview panel, you can modify the following settings to configure Preview behavior:

    Shortcut

    Choose a keyboard shortcut to play/stop a preview:  Spacebar, Shift+spacebarNumpad-0, Shift+Numpad-0, Numpad . (period), or Option/Alt+Numpad . (period). The Preview behavior depends on the settings specified for the currently selected Shortcut key.

    Reset

    Restore default preview settings for all Shortcut keys.

    Note:

    To restore preview settings for all keyboard shortcuts to closely match their behaviors in previous versions (After Effects CC 2014 and earlier), hold the Option (Mac OS) or Alt (Windows) key, and click the Reset button.

    Include Video: When enabled, the preview plays video. 

    Include Audio: When enabled, the preview plays audio. 

    Include Overlays and Layer Controls: When enabled, the preview shows overlays (for example, grids and guides) and layer controls for selected layers as defined in the View > View Options dialog box. Note that this can be enabled regardless of whether Include Video is enabled.

    Viewer panel overlays include guide lines, safe margins, grids, and 3D reference axes. To choose which overlays to show for the current viewer, open the Choose Grid and Guide Options menu at the bottom of the viewer panel.

    While a preview is playing back, you can dynamically show or hide layer controls using: Cmd + Shift + H (Mac OS) or Control + Shift + H (Windows).

    Loop: Specify if you want the Preview to play in a loop.

    Note: Showing or hiding layer controls during a preview does not affect the state of the Layer controls option in the Preview panel.

    Note: You cannot simultaneously disable all the three Include buttons. At least one button must remain enabled. When you disable the third button, one of the other buttons is enabled.

    Cache Before Playback: When you enable this option, After Effects caches frames before starting playback. This option is not enabled by default for any of the preview shortcuts. If you Option- (Mac OS) or Alt- (Windows) click the Reset button in the Preview panel, Cache Before Playback is enabled for Numpad-0.

    Range

    Defines the range of frames that are previewed:

    • Work Area: Only the frames within the work area.
    • Work Area - Extended by Current Time: Work area is dynamically extended the work area with reference to the position of the current-time indicator (CTI).
      • If the CTI is placed before the work area, the length of the range is from the current time to the work area end point.
      • If the CTI is placed after the work area, the length of the range is from the work area start point to the current time; unless From Current Time is enabled, in which case the length of the range is from the work area start point to the last frame of the composition, layer, or footage.
      • If the CTI is placed inside the work area, the range is the work area with no extension.
    • Entire Duration: All frames of the composition, layer, or footage.
    • Play Around Current Time When you start a preview with Play Around Current Time enabled, the preroll value is subtracted from the current time, the postroll value is added to the current time, and the frames in-between are previewed.

      To set the preroll and postroll values:

      1. Choose Range > Play Around Current Time.
      2. In the Play Around Current Time settings dialog box, set your desired preroll and postroll values in seconds.
      3. Click OK.

    Frame Rate

    Specify a Frame Rate for the preview. Select Auto if you want the preview and composition frame rates to be equal.

    Skip

    Select the number of frames you want to skip while previewing to improve playback performance.

    Resolution

    Specify preview resolution. Value specified in the Resolution drop-down overrides resolution setting of the composition.

    Choose one or more of the following behaviors to occur when you stop a preview with the current shortcut or the Play button:
    • If caching, play cached frames: When this option is enabled and you use this shortcut to stop a preview before caching has completed, only caching is stopped. Playback of cached frames restarts from the beginning of the range. When this option is disabled, stopping a preview with this shortcut stops both caching and playback.
    • Move time to preview time: When this option is enabled and you use this shortcut to stop a preview, the Current Time moves to the position of the Preview Time.

Stop a Preview

You can stop a preview using any of the following:

  • Press any of the preview keyboard shortcuts: SpacebarShift+spacebar, Numpad 0, Shift + Numpad 0, Numpad . (period), or Option/Alt+Numpad . (period)
  • Click the Play/Stop button in the Preview panel.
  • Choose Composition > Preview > Play Current Preview.
  • Press the Esc key.

The following actions will also cause After Effects to stop a preview:  

  • Click into the previewing viewer panel. Note that clicking on the tab of the viewer panel will not stop the preview.
  • Adjust a property of time, such as the Work Area bar or Time Navigator bar.
  • Drag the current-time indicator (CTI) or click in the time ruler, without the Option (Mac OS) or Alt (Windows) key held down. This action also changes the current time.
  • Change the composition settings of a previewing composition.
  • Hide the previewing viewer panel behind another panel in the workspace. For example, click on a different panel in the same group or open a new viewer panel in the same group.
  • Start the render queue.

The Play/Stop button in the Preview panel and Composition > Preview > Play Current Preview are linked to the shortcut currently displayed in the Preview panel. Using these actions to stop a preview has the same result as pressing the currently displayed shortcut key.

Default preview settings

The following are the default preview settings for each of the preview Shortcut keys:

Spacebar Shift + Spacebar Numpad-0
  • Play video in preview: On
  • Play audio in preview: On
  • Show overlays and layer controls: Off
  • Cache before playback: Off
  • Range: Work area extended by current time
  • Play From: Current Time
  • Frame Rate: Auto.
  • Skip: 0
  • Resolution: Auto
  • Full Screen: Disabled

When the Spacebar is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Enabled
  • Play video in preview: On
  • Play audio in preview: On
  • Show overlays and layer controls: Off
  • Cache before playback: Off
  • Range: Work Area extended by current time
  • Play From: Current Time
  • Frame Rate: Auto
  • Skip: 0
  • Resolution: Auto
  • Full Screen: Disabled

When the Shift + Spacebar is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Disabled
  • Play video in preview: On
  • Play audio in preview: On
  • Show overlays and layer controls: Off
  • Cache before playback: off
  • Range: Work Area
  • Play From: Start of Range
  • Frame Rate: Auto
  • Skip: 0
  • Resolution: Auto
  • Full Screen: Disabled

When the Numpad-0 is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Disabled
Shift + Numpad 0 Numpad . Alt + Numpad .
  • Play video in preview: On
  • Play audio in preview: On
  • Show overlays and layer controls: Off
  • Cache before playback: Off
  • Range: Work Area extended by current time
  • Play From: Start of Range
  • Frame Rate: Auto
  • Skip: 1
  • Resolution: Auto
  • Full Screen: Disabled

When the Shift + Numpad 0 is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Disabled
  • Play video in preview: Off
  • Play audio in preview: On
  • Show overlays and layer controls: Off
  • Cache before playback: Off
  • Range: Work Area Extended by Current Time
  • Play From: Current Time
  • Frame Rate: Auto
  • Skip: 0
  • Resolution: Auto
  • Full Screen: Disabled

When the Numpad . is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Disabled
  • Play video in preview: Off
  • Play audio in preview: On
  • Show overlays and layer controls: On
  • Cache before playback: Off
  • Range: Work Area
  • Play From: Start of Range
  • Frame Rate: Auto
  • Skip: 0
  • Resolution: Auto
  • Full Screen: Disabled

When the Alt + Numpad . is used to stop a preview: 

  • If caching, play cached frames: Enabled
  • Move time to preview time: Disabled

Preview only audio

When you preview only audio, it plays immediately at real-time speed, unless you’ve applied audio effects other than Stereo Mixer, in which case you may have to wait for audio to render before it plays.

Set the sample rate for audio for the entire project in the Project Settings dialog box (File > Project Settings).

The Audio Hardware and Audio Output Mapping preferences determine the behavior of audio previews. The output module settings determine the quality of audio in final output. In the Audio Hardware pane of the Preferences dialog box (Edit > Preferences > Audio Hardware), you can select the device class, map the default output and change the settings, and set the latency.

Manually preview (scrub) video and audio

  • To manually preview (scrub) video in the Timeline panel or go to a specific frame, drag the current-time indicator.
  • To scrub audio in the Timeline panel, Ctrl+Alt-drag (Windows) or Command+Option-drag (Mac OS) the current-time indicator (CTI).
  • To scrub audio and video in the Timeline panel, Ctrl-drag (Windows) or Command-drag (Mac OS) the current-time indicator (CTI).

If you stop moving the current-time indicator (CTI) with the mouse button depressed while scrubbing with audio, a short section of audio loops.

Note:

To manually preview (scrub) only the frames that are already rendered and cached into the RAM cache, press Caps Lock before dragging the current-time indicator (CTI). This prevents After Effects from trying to render other frames when you drag over or past them. This technique is useful when you want to manually preview some frames that you rendered using preview settings that used an option to skip every other frame.

Audio panel options

During previews, the Audio panel volume unit (VU) meter actively displays audio volume levels. At the top of the VU meter, signals indicate when the audio is clipping—a distortion that occurs when the audio signal exceeds the maximum level that the audio device allows.

To view the VU meter and levels controls in more detail, increase the height of the Audio panel.

Audio Panel
Choose options in the Audio Panel

Choose Options in the Audio panel menu to specify the following options:

Units

Choose whether to display audio levels in decibels or in percentages. 100% equals 0 decibels (0 dB).

Slider Minimum

The minimum audio level to display in the Audio panel.

Additional tips and options for previewing

  • With all previewing methods—as with rendering to final output—a layer is visible in rendered previews only if its Video layer switch is selected.
  • The following are some of the factors that influence the speed with which previews are rendered:
    • layer switches
    • Fast Previews settings
    • preference settings
    • composition settings

Use the Resolution/Down Sample Factor settings menu which is one of the simplest and most influential of the preview settings controls. Choose a value other than Full from this menu to see all previews at a lower resolution.

 

Resolution Setting
Setting resolution for preview

Note:

To turn pixel-aspect ratio correction on or off for previews, click the Toggle Pixel Aspect Ratio Correction button  at the bottom of the panel. The quality of the pixel aspect ratio correction is determined by the Zoom Quality preference. (See Viewer Quality preferences.)

  • When possible, preview on the same kind of device that your audience use to view your final output. For example, you can preview on an external video monitor.
  • If color management is enabled, you can preview a composition, layer, or footage item as it appears in the output color space. (See Simulate how colors will appear on a different output device.)

Note:

Select Show Rendering Progress In Info Panel And Flowchart (Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS)) to see additional information in the Info panel or the project Flowchart panel during rendering, either for previews or for final output.

Move the current-time indicator (CTI)

CTI in layer window
CTI in layer window

The most basic way of previewing frames is to manually preview by moving or dragging the current-time indicator (CTI).

The time ruler visually represents the time dimension of a composition, a layer, or a footage item. In a Layer or Footage panel, the time ruler appears near the bottom of the panel. For a Composition panel, the time ruler appears in the corresponding Timeline panel. The time rulers in different panels represent different durations. The time ruler in a Layer or Footage panel represents the duration of the contents of that panel; the time ruler in the Timeline panel represents the duration of the entire composition.

On a time ruler, the current-time indicator indicates the frame you are viewing or modifying.

CTI in Timeline panel
CTI in Timeline panel

  • To go forward or backward one frame, click the Next Frame or Previous Frame button in the Preview panel, or press Page Down or Page Up.

  • To go forward or backward ten frames, Shift-click the Next Frame or Previous Frame button, or press Shift+Page Down or Shift+Page Up.

  • To go forward a specific period of time or number of frames, click the current-time display, and then enter the plus sign (+) followed by the timecode or number of frames to advance. For example, enter +20 to go forward 20 frames or 1:00 to go forward one second. Precede the value by the minus sign (-) to go backward. For example, enter +-20 to go backward 20 frames or +-1:00 to go backward one second.

  • To go to the first or last frame, click the First Frame or Last Frame button in the Preview panel, or press Home or End.

  • To go to the first or last frame of the work area, press Shift+Home or Shift+End.

  • To go to a specific frame, click in the time ruler; click the current-time display in the Footage, Layer, Composition, or Timeline panel; or press Alt+Shift+J (Windows) or Option+Shift+J (Mac OS). You can also drag the current-time display in the Timeline panel to modify the value.

  • Shift-drag the current-time indicator to snap to keyframes, markers, In and Out points, the beginning or end of the composition, or the beginning or end of the work area.

Note:

If you scrub the CTI while a preview is playing, preview stops. To scrub the CTI without stopping a preview, hold Option/Alt while scrubbing.

Zoom in or out in time for a composition

  • In the Timeline panel, click the Zoom In button or the Zoom Out button , or drag the zoom slider between the buttons.
  • On the main keyboard, press the = (equal sign) key to zoom in or press the – (hyphen) key to zoom out in time.
  • Drag the Time Navigator Start or Time Navigator End brackets to zoom in or out on a section of the composition time ruler.

Note:

When you click the Time Navigator in the Timeline panel, the Info panel shows the times of the beginning and end of the Time Navigator duration.

  • To zoom out to show the entire composition duration, press Shift+; (semicolon) with the Composition panel or Timeline panel active. Press Shift+; again to zoom back in to the duration specified by the Time Navigator.
  • To zoom out to show the entire composition duration, Shift-double-click the Time Navigator. Shift-double-click it again to zoom back in to the duration specified by the Time Navigator.
  • To zoom in to show individual frames in the time ruler, double-click the Time Navigator. Double-click the Time Navigator again to zoom out to show the entire composition duration.
  • To zoom in the Composition, Layer, Footage, and Timeline panels using multi-touch gestures using two fingers, pinch your fingers closer together to zoom out or move your fingers farther apart to zoom in.

For additional ways to zoom and scroll in time using the mouse scroll wheel, see Scroll or zoom with the mouse wheel.

Note:

When zoomed in time, press D to center the time graph on the current time.

Choose a viewer to always preview

Designating a viewer as the default panel to preview is especially useful when you have a Composition viewer that represents your final output and you always want to preview that viewer, even when you’re changing settings in other panels.

The panel that’s set to always preview appears frontmost for the duration of the preview.

  • Click the Always Preview This View  button in the lower-left corner of the panel.

    OR

  • Click the Primary Viewer  button in the lower-left corner of the panel. 

Primary Viewer Button

The Primary Viewer button is located next to the Always Preview This View button in the lower left of the Composition, Layer, and Footage viewer panels.

Primary Viewer functions similarly to Always Preview This View, except that Primary Viewer only defines which viewer or view is used for audio and external video preview.

  • Only one view can be set as Primary Viewer; enabling it for a viewer or view disables it in any other viewer or view where it had previously been enabled. 
  • When Primary Viewer is disabled, the most recently active viewer or view is used for audio and external video preview. 
  • When you switch to a different viewer or view, that viewer or view takes control of audio and external video preview.

Note:

When multiple views are open, previews use the frontmost composition view for 2D compositions and the Active Camera view for 3D compositions. To turn off the Active Camera, deselect Previews Favor Active Camera in the Preview panel menu.

Preview modes and Viewer Quality preferences

After Effects provides several options for previewing that make various tradeoffs between speed and fidelity.

Preview modes and Fast Previews preferences

Each preview mode provides a different balance between quality and speed for playback and for updating of images during interactions, such as when you drag a layer in the Composition panel or modifying a property value in the Timeline panel.

Draft 3D and Live Update modes apply to all views of a composition.

Draft 3D

Disables lights, shadows, and depth-of-field blur for cameras. To turn Draft 3D mode on or off, click the Draft 3D button at the top of the Timeline panel.

Live Update

Updates images in the Composition or Layer panel during interactions. When Live Update is deselected, After Effects displays wireframe representations during interactions.

 

Note:

To temporarily toggle Live Update mode, hold Alt (Windows) or Option (Mac OS) while dragging to move a layer, modify a property value, or move the current-time indicator (CTI).

Note:

To prevent After Effects from updating images in the Footage, Layer, and Composition panels, press Caps Lock. When you make a change that would otherwise appear in a panel, After Effects adds a red bar at the bottom of the panel with a text reminder that image refresh is disabled. After Effects continues to update panel controls such as motion paths, anchor points, and mask outlines as you move them. To resume panel updates and display all changes, press Caps Lock again. Pressing Caps Lock is a good way to prevent views from being refreshed for each frame during rendering for final output.

Note:

When you are using OpenGL to render previews and are previewing on a video monitor, the preview shown on the video monitor doesn’t update as you interact with elements of your composition until you have released the mouse at the end of an interaction. (See Preview on an external video monitor.)

Fast Previews

The Fast Previews options range from higher quality but slower performance (Off), to lower quality but higher performance (Wireframe).

Off (Final Quality)

Fast Previews is off. Use this mode when previewing the final quality of your composition.

Adaptive Resolution

Attempts to downsample footage while dragging a layer or scrubbing a property value. For the ray-traced 3D compositions, Adaptive Resolution reduces the ray-tracing quality based on the current adaptive resolution:

  • At 1/2, the ray-tracing quality value is cut in half.
  • at 1/4, it is reduced to at most 4.
  • at 1/8 or 1/16, it is reduced to at most 2.

You can change the adaptive resolution limit in Edit > Preferences > Previews (Windows) or Premiere Pro > Preferences > Previews (Mac OS).

Draft

Available in ray-traced 3D compositions only. This option reduces the ray-tracing quality (number of rays fired by the ray tracer) to 1.

Fast Draft

When laying out a complex scene, or if you are working in a ray-traced 3D composition, you can use Fast Draft mode for previewing. In ray-traced 3D compositions, Fast draft mode renders beveled, extruded, and curved 3D layers. When previewing, the scene is downsampled to speed up the loading of textures to the GPU. In Fast Draft mode, each frame of video is still read into the renderer as needed. The downsample factor is set at 1/4 resolution, and effects and track mattes are on.

Wireframe

Useful for setting up and previewing complex compositions.

  • In Draft, Fast Draft, and Wireframe modes, the Current Renderer menu button's lightning bolt appears orange. In Adaptive Resolution, it appears orange when the composition is downsampled. In these modes, the name of the mode appears in the upper-right corner of the Composition view.
  • If adjusting a property or scrubbing through the Timeline takes a long time in Final Quality mode, Adaptive Resolution, or Draft modes, the scene temporarily switches to show wireframes. The frame finishes rendering when you stop moving the mouse.
  • If you are in a ray-traced 3D composition in Draft mode, and then switch to it to a Classic 3D composition, the fast preview mode automatically switches to Adaptive Resolution.
  • If you want to update more than one active view when scrubbing while holding down the Ctrl (Windows) or Command (Mac OS) key, enable the "Share View Options" option in the Select View Layout popup menu.
  • Click the Current Renderer menu button in the upper-right corner of the Composition panel to quickly open the current renderer settings in the Composition Settings dialog box. This method is applicable to a 3D layer, camera, or light in the composition.

Note:

Changing the Fast Previews mode to match your workflow is important, especially when working with ray-traced 3D compositions.

Keyboard shortcuts for Fast Previews

Quality name

Shortcut
Off (Final Quality) Ctrl+Alt+1 (Windows) / Cmd+Option+1 (Mac OS)
Adaptive Resolution Ctrl+Alt+2 (Windows) / Cmd+Option+2 (Mac OS)
Draft Ctrl+Alt+3 (Windows) / Cmd+Option+3 (Mac OS)
Fast Draft Ctrl+Alt+4 (Windows) / Cmd+Option+4 (Mac OS)
Wireframe Ctrl+Alt+5 (Windows) / Cmd+Option+5 (Mac OS)

Viewer Quality preferences

In the Previews preferences category, you can choose the quality and speed of color management and zoom operations used in previews.

From the Zoom Quality or Color Management Quality menu, choose one of the following:

  • Faster
  • More Accurate Except Cached Preview
  • More Accurate

The Zoom Quality preference affects the quality of scaling performed for pixel aspect ratio correction in the Composition and Layer panels.

Note:

When the Show Channel menu is set to an option that shows straight colors (RGB Straight, Alpha Overlay, or Alpha Boundary), the Viewer Quality preference is ignored, and the preview is created as if the Viewer Quality settings were Faster.

Region of interest (ROI)

The region of interest (ROI) is the area of the composition, layer, or footage item that is rendered for previews. Create a smaller region of interest to use less processing power and memory when previewing, thereby improving interaction speed and increasing preview duration.

By default, changing the region of interest does not affect file output. You can change the size of your composition and select what portion is rendered by cropping to the region of interest.

 

Note:

When the region of interest is selected, the Info panel displays the horizontal and vertical distances of the top (T), left (L), bottom (B), and right (R) edges of the region from the top-left corner of the composition.

  • To draw a region of interest, click the Region Of Interest button at the bottom of the Composition, Layer, or Footage panel, and then drag to select a viewable area of the panel.

Note:

To start over with the marquee tool, hold down Alt (Windows) or Option (Mac OS) and click the Region Of Interest button.

  • To switch between using the region of interest and using the full composition, layer, or footage frame, click the Region Of Interest button.
  • To move or resize the region of interest, drag its edges or handles. Shift-drag a corner handle to resize while preserving aspect ratio.
  • To crop the composition to the region of interest, choose Composition > Crop Comp To Region Of Interest.
  • To crop the output to the region of interest, choose Use Region Of Interest in the Crop section of the Output Module Settings dialog box. (See Output module settings.)

Note:

To create the equivalent of a region of interest for a single layer, you can draw a temporary mask around the part of the layer that you are working with. The area outside of the mask is not rendered. This can make working with a small portion of a large layer much faster. Be careful, though, since not rendering the pixels outside of the mask can change the composition’s appearance significantly. (See Creating masks.)

Work area

The work area is the part of the duration of a composition that is rendered for previews or final output. In the Timeline panel, the work area appears in a lighter shade of gray.

  • To set the work area start time or end time to the current time, press B (begin) or N (end), respectively.
  • To set the work area, move the start and end work area markers in the time ruler.
Work area markers
Work area markers indicate the composition duration rendered for previews or final output.

  • To move the work area, drag the center of the work area bar left or right.
  • To expand the work area to the size of the composition, double-click the center of the work area bar.

  • To show the duration of the work and the times of its beginning and end in the Info panel, click the work area bar.

Snapshots

When you want to compare one view to another in a Composition, Layer, or Footage panel, take a snapshot. For example, you may want to compare two frames at different times in a movie.

Snapshots taken in one kind of panel can be displayed in another kind. For example, you can take a snapshot of a Layer panel and display the snapshot in a Composition or Footage panel. Displaying a snapshot does not replace the content of the panel. If the snapshot has a different size or aspect ratio than the panel in which you display it, the snapshot is resized to fit the current view.

Snapshots are for reference only and do not become part of the layer, composition, or rendered movie.

A sound is generated when you take a snapshot.

  • To take a snapshot, click the Take Snapshot button at the bottom of the panel or press Shift+F5, Shift+F6, Shift+F7, or Shift+F8.
  • To view the most recent snapshot taken with the Take Snapshot button or Shift+F5, click and hold the Show Snapshot button at the bottom of the panel.
  • To view a specific snapshot, press and hold F5, F6, F7, or F8.
  • To purge a snapshot, hold down Ctrl+Shift (Windows) or Command+Shift (Mac OS) and press F5, F6, F7, or F8.
  • To free all memory used to store snapshots, choose Edit > Purge > Snapshot.

Preview on an external video monitor

You can preview the contents of your Layer, Footage, or Composition panel on an external video monitor. Previewing on a video monitor requires additional hardware, such as a video capture card or a FireWire port.

Previews can be displayed on a second monitor connected to your video display card, such as via DVI, DisplayPort, or HDMI. If you are using a video capture card to connect an external video monitor, install the appropriate drivers and connect the monitor to view previews. If you are using a FireWire port, first connect a digital camcorder or similar device to the port; then connect the video monitor to the device. For more information on setting up FireWire previews, see the documentation for your digital camcorder, VCR, or other devices.

  1. Choose Edit > Preferences > Video Preview (Windows) or After Effects > Preferences > Video Preview (Mac OS).

  2. To enable video output to an external device, choose from the following options:

    • Adobe DV: This is the FireWire option.
    • Adobe Monitor x: These are your attached computer monitors that can receive video preview data through the graphics card.
    • Third-party video hardware: These entries differ depending on what third-party hardware you have connected. AJA Kona 3G, Blackmagic Playback, and Matrox Player are typical examples.
  3. Choose Disable video output when in the Background option to prevent video frames from being sent to the external monitor when After Effects is not the foreground application.

  4. Choose the Video preview during render queue output option to send video frames to the external monitor when After Effects is rendering frames in the render queue.

The video preview sent to an external monitor using Mercury Transmit is color-managed (treating the external video preview monitor as an HDTV Rec. 709 device). For more information, see the Video preview using Mercury Transmit article.

Note:

The Wireframe preview mode does not preview at all to the video preview monitor. (See Preview modes and Choose a working color space and enable color management.)

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy