导入 After Effects 项目

可以将一个 After Effects 项目导入另一个项目。导入项目中的所有内容(包括素材项目、合成和文件夹)显示在当前“项目”面板中的一个新建文件夹中。  

只要保持项目中所有文件的文件名、文件夹名称以及完整或相对路径(文件夹位置),就可以从不同的操作系统导入 After Effects 项目。要保持相对路径,源素材文件必须与项目文件位于相同卷上。使用“文件”>“收集文件”命令将项目或合成中所有文件的副本收集到一个位置。(请参阅跨平台项目注意事项。)

  1. 选择“文件”>“导入”>“文件”。
  2. 选择要导入的 After Effects 项目,单击“打开”。

如果您使用的操作系统不支持某种文件格式,或者该文件缺失,或者参考链接损坏,则 After Effects 会用一个包含颜色条的占位符项目取而代之。可以通过双击“项目”面板中相应条目并导航到源文件来使占位符与相应文件重新连接。大多数情况下,您只需要重新链接一个素材文件。After Effects 将定位处于同一位置的其他缺失项目。

注意:

在渲染某影片并将其导出到 QuickTime (MOV)、Video for Windows (AVI) 格式时,可以在容器文件中嵌入项目链接。要导入项目,请导入 MOV 或 AVI 文件,然后从“导入文件”对话框的“导入为”菜单中选择“项目”。如果文件包含已移走的项目的链接,您可以通过浏览找到该项目。

导入 Adobe Premiere Pro 项目

注意:

将 Adobe Premiere Pro 项目导入 After Effects 时不使用 Dynamic Link。如果 Premiere Pro 项目中的一个或多个序列已经动态链接到 After Effects,则 After Effects 无法导入此 Premiere Pro 项目。(请参阅使用 Adobe Premiere Pro 和 After Effects。)

在导入某个 Adobe Premiere Pro 项目时,After Effects 会将其作为新合成(所含每个 Adobe Premiere Pro 剪辑均为一个图层)和文件夹(所含每个剪辑均为一个素材项目)导入“项目”面板。如果您的 Adobe Premiere Pro 项目包含素材箱,After Effects 会将其转化为 Adobe Premiere Pro 项目文件夹下的文件夹。After Effects 将嵌套序列转化为嵌套合成。

在将 Adobe Premiere Pro 项目导入 After Effects 后,并不会保留该项目的所有功能。在将 Premiere Pro 项目导入 After Effects 时,只保留在 Premiere Pro 与 After Effects 之间进行复制和粘贴时所使用的相同功能。(请参阅从 After Effects 和 Adobe Premiere Pro 导入。)

After Effects 保留剪辑在时间轴中的顺序、素材持续时间(包括经过修剪的所有入点和出点)以及标记和过渡位置。After Effects 以剪辑在 Adobe Premiere Pro 的“时间轴”面板中的排列作为图层在“时间轴”面板中排列的基础。After Effects 按照 Adobe Premiere Pro 剪辑在 Adobe Premiere Pro 的“时间轴”面板中的显示顺序(从下到上,从左到右)将 Adobe Premiere Pro 剪辑作为图层添加到“时间轴”面板中。After Effects 保留对剪辑速度所做的更改(例如,通过“剪辑”>“速度”命令),而这些更改显示为 After Effects“时间轴”面板的“伸缩”列中的一个值。

After Effects 可导入 Adobe Premiere Pro 和 After Effects 共有的效果,并保留这些效果的关键帧。

Adobe Premiere Pro 项目中包括的过渡和标题(溶解除外)在 After Effects 合成中显示为包含其原始位置和持续时间的纯色图层。

将保留音频电平关键帧。

  1. 选择“文件”>“导入”>“文件”或“文件”>“导入”>“Adobe Premiere Pro 项目”。

    如果选择“导入”>“Adobe Premiere Pro 项目”,则只显示 Adobe Premiere Pro 项目。

  2. 选择一个项目,单击“确定”。
  3. 执行以下任一操作:
    • 要只导入一个序列,请从菜单中选择该序列。

    • 要导入音频,请选择“导入音频”。

    注意:

    要添加来自 Adobe Premiere Pro 项目轨道的单个项目,请在 Adobe Premiere Pro 中复制该项目,在 After Effects 中选择“编辑”>“粘贴”。

在 After Effects 和 Adobe Premiere Pro 之间复制

  • After Effects“时间轴”面板中,您可以复制基于音频或视频素材项目(包括实底)的图层,并将其粘贴到 Adobe Premiere Pro“时间轴”面板中。

  • Adobe Premiere Pro“时间轴”面板中,您可以复制资源(轨道中的任何项目),并将其粘贴到 After Effects“时间轴”面板中。

  • After EffectsAdobe Premiere Pro 中,您可以将素材项目复制并粘贴到另一个的“项目”面板中。

注意:

但是,不能将 After Effects“项目”面板中的素材项目粘贴到 Adobe Premiere Pro“时间轴”面板中。

如果要使用 Adobe Premiere Pro 项目中的所有剪辑或单个序列,请改用“导入”命令将项目导入 After Effects 中。

注意:

使用“Adobe 动态链接”可在 After EffectsAdobe Premiere Pro 中的新合成图像与现有合成图像之间创建动态链接,而无需渲染。(请参阅关于 Dynamic Link。)

从 After Effects 复制到 Adobe Premiere Pro

您可以复制基于 After Effects 合成图像中素材项目的图层,并将其粘贴到 Adobe Premiere Pro 序列中。Adobe Premiere Pro 会将这些图层转换为序列中的剪辑,并将源素材项目复制到其“项目”面板。如果图层包含 Adobe Premiere Pro 也在使用的某种效果,Adobe Premiere Pro 会将相应效果及其所有设置和关键帧进行转换。

您还可以复制嵌套合成图像、Photoshop 图层、纯色图层及音频层。Adobe Premiere Pro 会将嵌套合成图像转换为嵌套序列,将纯色图层转换为颜色遮罩。不能将形状、文本、相机、光照或调整图层复制到 Adobe Premiere Pro

  1. 启动 Adobe Premiere Pro(必须先启动 Adobe Premiere Pro 方可复制 After Effects 中的图层)。
  2. After Effects“时间轴”面板中选择一个或多个图层。

    注意:

    如果您选择了多个图层并且这些图层在 After Effects 中未发生重叠,则它们将被置于 Adobe Premiere Pro 的同一条轨道上。另一方面,如果各图层在 After Effects 中发生重叠,则这些图层在 Adobe Premiere Pro 轨道的放置顺序取决于您选择图层时的顺序。每个图层将被放置到一条单独的轨道上,最后一个选定图层显示在轨道 1 上。例如,如果您按照从上到下的顺序选择图层,则图层将以相反顺序显示在 Adobe Premiere Pro 中,其中最低的图层位于轨道 1 上。

  3. 选择“编辑”>“复制”。
  4. Adobe Premiere Pro 的“时间轴”面板中,打开一个序列。
  5. 将当前时间指示器移动到所需位置,然后选择“编辑”>“粘贴”或“编辑”>“粘贴插入”。

粘贴到 Adobe Premiere Pro 的结果

将图层粘贴到 Adobe Premiere Pro 序列时,所复制图层中的关键帧、效果和其他属性将按如下所示进行转换:

After Effects 项目

Adobe Premiere Pro 中转换为

注释

音频音量属性

声道音量滤镜

混合模式

转换 Adobe Premiere Pro 支持的混合模式

效果属性和关键帧

效果属性和关键帧(如果该效果也存在于 Adobe Premiere Pro 中)

不受支持的效果在 Adobe Premiere Pro 的“效果控件”面板中被列为脱机。一些 After Effects 效果与 Adobe Premiere Pro 中的效果同名,但实际上它们是不同的效果,因此这些效果不会被转换。

表达式

不转换

图层标记

剪辑标记

蒙版和遮罩

不转换

立体声混合器效果

声道音量滤镜

时间重映射属性

时间重映射效果

时间拉伸属性

速度属性

速度与时间拉伸之间存在逆向关系。例如,After Effects 中的 200% 拉伸将转换为 Adobe Premiere Pro 中的 50% 速度。

转换属性值和关键帧

运动或不透明度值和关键帧

将保留贝塞尔曲线、自动贝塞尔曲线、连续贝塞尔曲线或定格类型的关键帧。

R3D 源文件的源设置

R3D 源文件的源设置

从 Adobe Premiere Pro 复制到 After Effects

可以将 Adobe Premiere Pro 序列中的视频或音频资源复制并粘贴到 After Effects 合成图像中。After Effects 会将资源转换为图层,并将源素材项目复制到其“项目”面板中。如果资源包含 After Effects 也在使用的某种效果,After Effects 会将相应效果及其所有设置和关键帧进行转换。

还可以复制颜色遮罩、静止图像、嵌套序列及脱机文件。After Effects 会将颜色遮罩转换为纯色图层,将嵌套序列转换为嵌套合成图像。将 Photoshop 静止图像复制到 After Effects 中时,After Effects 会保留 Photoshop 图层信息。您不能将 Adobe Premiere Pro 标题粘贴到 After Effects 中,但是可以将 Adobe Premiere Titler 中的属性文本粘贴到 After Effects 中。

  1. Adobe Premiere Pro“时间轴”面板中选择资源。
  2. 选择“编辑”>“复制”。
  3. After Effects 的“时间轴”面板中,打开一个合成图像。
  4. 激活“时间轴”面板后,选择“编辑”>“粘贴”。该资源在“时间轴”面板中显示为最顶部图层。

    注意:

    要将资源粘贴到当前时间指示器处,请放置当前时间指示器,然后按 Ctrl+Alt+V (Windows) 或 Command+Option+V (Mac OS)。

粘贴到 After Effects 的结果

将某个资源粘贴到 After Effects 合成图像时,所复制资源中的关键帧、效果及其他属性将按如下所示进行转换:

Adobe Premiere Pro 资源

After Effects 中转换为

注释

音频轨道

音频层

不支持 5.1 环绕或大于 16 位的音频轨道。单声道和立体声音频轨道作为一个或两个图层导入。

彩条

不转换

 

混合模式

转换

 

剪辑标记

图层标记

 

颜色遮罩

纯色图层

 

裁剪滤镜

蒙版图层

 

帧定格

时间重映射属性

 

蒙版 转换 当您将蒙版复制到 After Effects 合成时,将在 After Effects 中复制 Premiere Pro 中的所有蒙版属性,例如羽化、不透明度和扩展等。

运动或不透明度值和关键帧

转换属性值和关键帧

将保留贝塞尔曲线、自动贝塞尔曲线、连续贝塞尔曲线或定格类型的关键帧。

序列标记

新纯色图层上的标记

要复制序列标记,必须复制序列本身或将整个 Adobe Premiere Pro 项目作为一个合成图像导入。

速度属性

时间拉伸属性

速度与时间拉伸之间存在逆向关系。例如,Adobe Premiere Pro 中的 50% 速度将被转换为 After Effects 中的 200% 拉伸。

时间重映射效果

时间重映射属性

 

标题

不转换

 

通用倒计时片头

不转换

 

视频和音频过渡

不透明度关键帧(仅限交叉溶解)或纯色图层

 

视频效果属性和关键帧

效果属性和关键帧(如果效果也存在于 After Effects 中)

After Effects 的“效果控件”中不显示不受支持的效果。

音量和声道音量音频滤镜

立体声混合器效果

其他音频滤镜不进行转换。

R3D 源文件的源设置

R3D 源文件的源设置

 

注意:

在将 Premiere Pro 项目导入 After Effects 时,功能的转换方式与在从 Premiere Pro 复制到 After Effects 时的转换方式相同。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略