Sikkerhedsopdateringer til Adobe Flash Player

Udgivelsesdato: 10. juni 2014

Seneste opdatering: 26. juni 2014

Id for sikkerhedsproblem: APSB14-16

Prioritet: Se tabel nedenfor

CVE-nummer: CVE-2014-0531, CVE-2014-0532, CVE-2014-0533, CVE-2014-0534, CVE-2014-0535, CVE-2014-0536

Platform: Alle platforme

Resumé

Adobe har udgivet sikkerhedsopdateringer til Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh samt Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux. Disse opdateringer vedrører sikkerhedsproblemer, der potentielt kan give en hacker mulighed for at få kontrol over det berørte system. Adobe anbefaler, at brugerne opdaterer deres produktinstallationer med de seneste versioner:

  • Brugere af Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh bør opdatere til Adobe Flash Player 14.0.0.125.
  • Brugere af Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux bør opdatere til Adobe Flash Player 11.2.202.378.
  • Adobe Flash Player 13.0.0.214, der er installeret med Google Chrome, vil automatisk blive opdateret til den nyeste Google Chrome-version, som vil medtage Adobe Flash Player 14.0.0.125 til Windows, Macintosh og Linux.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 10, opdateres automatisk til den seneste version af Internet Explorer 10, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.0.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 11, opdateres automatisk til den seneste version af Internet Explorer 11, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.1.
  • Brugere af Adobe AIR 13.0.0.111 SDK og tidligere versioner bør opdatere til Adobe AIR 14.0.0.110 SDK.
  • Brugere af Adobe AIR 13.0.0.111 SDK & Compiler samt tidligere versioner bør opdatere til Adobe AIR 14.0.0.110 SDK & Compiler.
  • Brugere af Adobe AIR 13.0.0.111 og tidligere versioner bør opdatere til Adobe AIR 14.0.0.110.
  • Brugere af Adobe 13.0.0.111 og tidligere versioner til Windows, Macintosh bør opdatere til Adobe AIR 14.0.0.110.

Berørte softwareversioner

  • Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh
  • Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux
  • Adobe AIR 13.0.0.111 SDK og tidligere versioner
  • Adobe AIR 13.0.0.111 SDK & Compiler og tidligere versioner
  • Adobe AIR 13.0.0.111 og tidligere versioner til Android
  • Adobe AIR 13.0.0.111 og tidligere versioner til Windows og Macintosh

For at kontrollere, hvilken version af Adobe Flash Player der er installeret på dit system, skal du gå ind på Om Flash Player-siden eller højreklikke på indhold, der kører i Flash Player, og vælge "Om Adobe (eller Macromedia) Flash Player" via menuen. Hvis du anvender flere webbrowsere, skal du udføre denne kontrol i hver webbrowser, der er installeret på systemet.

Du kan se, hvilken version af Adobe AIR, der er installeret på dit system ved at følge anvisningerne i Adobe AIR TechNote.

Løsning

Adobe anbefaler, at brugerne opdaterer deres software ved at følge nedenstående anvisninger:

  • Adobe anbefaler, at brugere af Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh opdaterer til den nyeste version 14.0.0.125 ved at downloade den fra Adobe Flash Player Download Center eller via opdateringsmekanismen i produktet, når man bliver spurgt.
  • Adobe anbefaler, at brugere af Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux opdaterer til Adobe Flash Player 11.2.202.378 ved at downloade den fra Adobe Flash Player Download Center.
  • Adobe Flash Player 13.0.0.214, der er installeret med Google Chrome, vil automatisk blive opdateret til den nyeste Google Chrome-version, som vil medtage Adobe Flash Player 14.0.0.125 til Windows, Macintosh og Linux.
  • Til brugere af Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh, som ikke kan opdatere til Flash Player 14.0.0.125, har Adobe gjort Flash Player 13.0.0.223* tilgængelig. Den kan downloades her:http://helpx.adobe.com/dk/flash-player/kb/archived-flash-player-versions.htmlhttp://helpx.adobe.com/dk/flash-player/kb/archived-flash-player-versions.html.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 10, opdateres automatisk til den seneste version af Internet Explorer 10, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.0.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 11, opdateres automatisk til den seneste version af Internet Explorer 11, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.1.
  • Brugere af Adobe AIR 13.0.0.111 SDK bør opdatere til Adobe AIR 14.0.0.110 SDK.
  • Brugere af Adobe AIR 13.0.0.111 SDK & Compiler samt tidligere versioner bør opdatere til Adobe AIR 14.0.0.110 SDK & Compiler.
  • Brugere af Adobe AIR 13.0.0.111 og tidligere versioner bør opdatere til Adobe AIR 14.0.0.110.
  • Brugere af Adobe 13.0.0.111 og tidligere versioner til Windows, Macintosh bør opdatere til Adobe AIR 14.0.0.110.

* Med start d. 13. maj 2014, har erstattet Adobe Flash Player 13 til Mac og Windows version 11.7 som den udvidede supportversion. Adobe anbefaler, at brugerne opgraderer til version 13 for at fortsætte med at modtage sikkerhedsopdateringer.  Se denne blogpost for at få flere oplysninger. http://blogs.adobe.com/flashplayer/2014/03/upcoming-changes-to-flash-players-extended-support-release.html

Prioritets- og alvorlighedsgrader

Adobe kategoriserer disse opdateringer med følgende prioritetsgrader og anbefaler, at brugere opdaterer deres installation til den nyeste version:

Produkt Opdateret version Platform Prioritetsgrad
Adobe Flash Player 14.0.0.125
Windows og Macintosh
1
  14.0.0.125
Internet Explorer 10 til Windows 8.0 1
  14.0.0.125
Internet Explorer 11 til Windows 8.1 1
  14.0.0.125
Chrome til Windows, Macintosh og Linux 1
  11.2.202.378 Linux 3
Adobe AIR 14.0.0.110 Windows, Macintosh og Android 3
Adobe AIR SDK og Compiler 14.0.0.110
Windows, Macintosh, Android og iOS 3
Adobe AIR SDK 14.0.0.110
Windows, Macintosh, Android og iOS
3

Disse opdateringer vedrører kritiske sikkerhedsproblemer i softwaren.

Yderligere oplysninger

Adobe har udgivet sikkerhedsopdateringer til Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh samt Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux. Disse opdateringer vedrører sikkerhedsproblemer, der potentielt kan give en hacker mulighed for at få kontrol over det berørte system. Adobe anbefaler, at brugerne opdaterer deres produktinstallationer med de seneste versioner:

  • Brugere af Adobe Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh bør opdatere til Adobe Flash Player 14.0.0.125.
  • Brugere af Adobe Flash Player 11.2.202.359 og tidligere versioner til Linux bør opdatere til Adobe Flash Player 11.2.202.378.
  • Adobe Flash Player 13.0.0.214, der er installeret med Google Chrome, vil automatisk blive opdateret til den nyeste Google Chrome-version, som vil medtage Adobe Flash Player 14.0.0.125 til Windows, Macintosh og Linux.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 10, opdateres automatisk til den seneste version af Internet Explorer 10, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.0.
  • Adobe Flash Player 13.0.0.214, som er installeret med Internet Explorer 11, opdateres automatisk til den seneste version af Internet Explorer 11, som indeholder Adobe Flash Player 14.0.0.125 til Windows 8.1.
  • Brugere af Adobe AIR 13.0.0.111 SDK og tidligere versioner bør opdatere til Adobe AIR 14.0.0.110 SDK.
  • Brugere af Adobe AIR 13.0.0.111 SDK & Compiler samt tidligere versioner bør opdatere til Adobe AIR 14.0.0.110 SDK & Compiler.
  • Brugere af Adobe AIR 13.0.0.111 og tidligere versioner bør opdatere til Adobe AIR 14.0.0.110.
  • Brugere af Adobe 13.0.0.111 og tidligere versioner til Windows, Macintosh bør opdatere til Adobe AIR 14.0.0.110.

Disse opdateringer løser sikkerhedsproblemer med scripts på tværs af websteder (CVE-2014-0531, CVE-2014-0532, CVE-2014-0533).

Disse opdateringer løser sikkerhedsproblemer med sikkerhedsomgåelser (CVE-2014-0534, CVE-2014-0535).

Disse opdateringer løser et sikkerhedsproblem med ødelæggelse af hukommelsen, der kan medføre vilkårlig kodekørsel (CVE-2014-0536).

Påvirket software   Anbefalet Player-opdatering Tilgængelighed
Flash Player 13.0.0.214 og tidligere versioner til Windows og Macintosh   14.0.0.125 Flash Player Download Center
Flash Player 13.0.0.214 og tidligere versioner (netværksdistribution)   14.0.0.125
Flash Player-licens
Flash Player 11.2.202.359 og tidligere versioner til Linux   11.2.202.378 Flash Player Download Center
Flash Player 13.0.0.214 og tidligere til Chrome (Windows, Macintosh og Linux)   14.0.0.125
Google Chrome-frigivelser
Flash Player 13.0.0.214 og tidligere i Internet Explorer 10 til Windows 8.0   14.0.0.125
Microsoft Security Advisory
Flash Player 13.0.0.214 og tidligere i Internet Explorer 11 til Windows 8.1   14.0.0.125
Microsoft Security Advisory
AIR 13.0.0.111 SDK & Compiler og tidligere versioner   14.0.0.110 AIR SDK Download
AIR 13.0.0.111 SDK og tidligere versioner   14.0.0.110
AIR SDK Download
AIR 13.0.0.111 og tidligere versioner til Windows og Macintosh   14.0.0.110 AIR Download Center
AIR 13.0.0.111 og tidligere versioner til Android   14.0.0.110 Google Play

Tak til følgende personer

Adobe vil gerne takke følgende personer og organisationer for at rapportere de relevante sikkerhedsproblemer og for at samarbejde med Adobe for at beskytte vores kunder:

  • Erling Ellingsen fra Facebook (CVE-2014-0531, CVE-2014-0532, CVE-2014-0533)
  • Masato Kinugawa og Joe Vennix fra Rapid7 (CVE-2014-0534)
  • Bas Venis (CVE-2014-0535)
  • Leong Wai-Meng fra Trend Micro (CVE-2014-0536)

Revisioner

26. juni 2014 – Har opdateret afsnittet med anerkendelser til at reflektere fælles anerkendelse vedrørende CVE-2014-0534.