Adobe Flash Playerin tietoturvapäivitykset

Julkaisupäivä: 14. maaliskuuta 2017

Viimeksi päivitetty: 13. huhtikuuta 2017

Haavoittuvuuden tunniste: APSB17-07

Prioriteetti: Katso alla oleva taulukko

CVE-numero: CVE-2017-2994, CVE-2017-2997, CVE-2017-2998, CVE-2017-2999, CVE-2017-3000, CVE-2017-3001, CVE-2017-3002, CVE-2017-3003

Ympäristö: Windows, Macintosh, Linux ja Chrome OS

Yhteenveto

Adobe on julkaissut tietoturvapäivityksiä Adobe Flash Playerin Windows-, Macintosh-, Linux- ja Chrome OS -versioihin. Nämä päivitykset ratkaisevat kriittisiä haavoittuvuuksia, jotka voivat johtaa siihen, että hyökkääjä saa altistuneen järjestelmän haltuunsa. 

Alttiit versiot

Tuote Versiot Ympäristö
Ajonaikainen Flash Player -työpöytäsovellus 24.0.0.221 ja aiemmat versiot Windows, Macintosh ja Linux
Adobe Flash Player Google Chromelle 24.0.0.221 ja aiemmat versiot Windows, Macintosh, Linux ja Chrome OS
Adobe Flash Player Microsoft Edgelle ja Internet Explorer 11:lle 24.0.0.221 ja aiemmat versiot Windows 10 ja 8.1
  • Voit tarkistaa Adobe Flash Playerin version siirtymällä About Flash Player (Tietoja Flash Playeristä) -sivulle tai napsauttamalla hiiren kakkospainikkeella Flash Player -sisältöä ja valitsemalla valikosta ”About Adobe (tai Macromedia) Flash Player (Tietoja Adobe (tai Macromedia) Flash Playeristä)”. Jos käytät useita selaimia, tarkista jokainen järjestelmään asennettu selain erikseen.  

Ratkaisu

Adobe luokittelee päivitykset seuraavan prioriteettiluokituksen mukaisesti ja suosittelee käyttäjiä päivittämään asennuksensa uusimpaan versioon:

Tuote Päivitetyt versiot Ympäristö Prioriteettiluokitus Saatavuus
Adobe Flash Player Desktop Runtime 25.0.0.127 Windows ja Macintosh 1 Flash Playerin latauskeskus
Flash Player -jakelu
Adobe Flash Player Google Chromelle 25.0.0.127  Windows, Macintosh, Linux ja Chrome OS 1 Google Chrome -versiot
Adobe Flash Player Microsoft Edgelle ja Internet Explorer 11:lle 25.0.0.127 Windows 10 ja 8.1 1 Microsoftin tietoturvatiedote
Adobe Flash Player Desktop Runtime 25.0.0.127 Linux 3 Flash Player -latauskeskus
  • Adobe suosittelee Adobe Flash Player Desktop Runtimen Windows-, Macintosh- ja Linux-käyttäjiä päivittämään versioon 25.0.0.127 joko tuotteen [1] päivitysmekanismin tai Adobe Flash Playerin latauskeskuksen avulla.
  • Google Chromen mukana asennettu Adobe Flash Player päivitetään automaattisesti uusimpaan Google Chrome -versioon, joka sisältää Windowsin, Macintoshin, Linuxin ja Chrome OS:n Adobe Flash Player -version 25.0.0.127.
  • Windows 10/8.1:een Microsoft Edgen ja Windows Internet Explorer for Windows 11:n mukana asennettu Adobe Flash Player päivitetään automaattisesti uusimpaan versioon, joka sisältää Adobe Flash Player -version 25.0.0.127.
  • Lisäohjeita Flash Playerin asentamisesta on Flash Playerin ohjesivulla.

[1] Käyttäjät, jotka ovat valinneet Salli Adoben asentaa päivitykset -asetusvaihtoehdon, saavat päivityksen automaattisesti. Käyttäjät, jotka eivät ole valinneet Salli Adoben asentaa päivitykset -asetusvaihtoehtoa, voivat asentaa päivityksen tuotteen päivitysmekanismin avulla sitä kysyttäessä.

Lisätietoja haavoittuvuuksista

  • Nämä päivitykset ratkaisevat puskurin ylivuoto-ongelman, joka voi johtaa koodin suoritukseen (CVE-2017-2997).
  • Nämä päivitykset ratkaisevat muistin vioittumisen haavoittuvuuksia, jotka voivat johtaa koodin suoritukseen (CVE-2017-2998, CVE-2017-2999).
  • Nämä päivitykset ratkaisevat tietojen jatkuvaan salaamiseen käytettävän satunnaislukugeneraattorin haavoittuvuuden, joka voi johtaa tietojen paljastumiseen (CVE-2017-3000).
  • Nämä päivitykset korjaavat vapautuksen jälkeisen käytön haavoittuvuudet, jotka voivat johtaa koodin suoritukseen (CVE-2017-2994, CVE-2017-3001, CVE-2017-3002, CVE-2017-3003).

Kiitokset

Adobe haluaa kiittää seuraavia henkilöitä ja organisaatioita, jotka ilmoittivat edellä mainituista ongelmista ja auttoivat Adobea sen asiakkaiden tietoturvan suojaamisessa:

  • Tao Yan (@Ga1ois) Palo Alto Networksista (CVE-2017-2997, CVE-2017-2998 ja CVE-2017-2999)
  • Wang Chenyu ja Wu Hongjun Nanyang Technological Universitystä (CVE-2017-3000)
  • Yuki Chen Qihoo 360 Vulcan Teamista yhdessä Chromium Vulnerability Rewards Program -ohjelman kanssa ja Anonymous yhdessä Trend Micron Zero Day Initiative -ohjelman kanssa (CVE-2017-3001)
  • Yuki Chen Qihoo 360 Vulcan Teamista yhdessä Chromium Vulnerability Rewards Program -ohjelman kanssa (CVE-2017-3002 ja CVE-2017-3003)
  • bo13oy CloverSec Labsista yhdestä Trend Micron Zero Day Initiative -ohjelman kanssa (CVE-2017-2994).

Versiot

13. huhtikuuta 2017: lisätty viittaus haavoittuvuuteen CVE-2017-2994, joka jäi vahingossa pois tiedotteesta.