Want to improve Photoshop Lightroom performance? Try some of these suggestions.

For the best results, take a holistic approach. Read all the suggestions here. Consider which ones to implement within the context of your computer setup. Also consider the types of files you use and your particular workflow. Each circumstance is unique and requires a different combination of techniques to achieve the most efficient performance from Lightroom.

Optimize your hardware and OS

Update to the most recent version of Lightroom

In Lightroom, choose Help > Check For Updates.

Exceed minimum system requirements

The minimum system requirements to run Lightroom are just that: the minimum you need for Lightroom to operate. More RAM and a faster processor, in particular, can yield significant performance benefits. The requirements vary depending on the following:

  • The types of files you work with
  • Their sizes
  • The total number of images in the catalog
  • The extent of spot healing or local (brushed) adjustments applied to images

Options that can help increase performance include:

  • 64-bit, multiple-core processor (for best performance, up to six cores; the extra power is especially important if you use multiple or high-resolution monitors, which require more power)
  • At least 4 GB of RAM, more if you use Photoshop at the same time
  • Fast hard disks, especially for the catalog and previews

Find out the system requirements for your version of Lightroom.

To see the details of your particular system configuration, in Lightroom, choose Help > System Info.

Use a fast hard drive

For the simplest workflow, a fast (7200 rpm) internal Serial-ATA drive is sufficient. For more demanding workflows, consider a RAID array.

Storing catalogs, image files, and previews on an external drive is convenient if you work with the same catalog on multiple computers. Doing so, however, can negatively affect Lightroom performance. If you must store your files externally, make sure that you have a fast connection. For example, use a Thunderbolt connection, USB 3.0 (not USB 1.0 or 2.0), or eSATA connection. For best performance, connect the external drive to a compatible port that has the highest bandwidth limit of all the available ports. The bandwidth limits for various ports are listed below:

Thunderbolt = 10GB/sec
eSATA = 600MB/sec
PCIe = 500MB/sec
USB3 = 400MB/sec
USB2 = 35MB/sec

Note:

Catalog files cannot be stored on network drives but you can store your photos on a network drive. However, network drives (hard disk accessed over a network) have slower data transfer rates. Therefore, it can take more time when switching modules or when switching from one file to another in Lightroom.

Make sure that you have a large enough hard drive and enough free space

Working with too little free hard-disk space can cause poor performance. Make sure that the hard drive that stores your Lightroom catalog, previews, and image files is at least 20% free.

See Lightroom system requirements to find out the minimum amount of free hard-disk space you need for your version of Lightroom.

Update the graphics driver

Use a compatible graphics processor (also called a graphics card, video card, or GPU). Be sure to keep the graphics driver software up to date.

If your your computer’s graphics processor is incompatible with Lightroom, uncheck the Use Graphics Processor check box in Lightroom (macOS)/Edit (Win) > Preferences > Performance.

For detailed information, see Lightroom graphics processor (GPU) troubleshooting & FAQ.

Run Lightroom in 64-bit mode (Lightroom 4 and 3)

If you run Lightroom in 64-bit mode, it has access to more than 2 GB of RAM, which is the ceiling for 32-bit operating systems. Giving Lightroom access to more than 4 GB of RAM can significantly improve performance.

Lightroom operates in 64-bit mode automatically if it is installed on a computer that is 64 bit capable and running a 64-bit OS. You can verify that it's running in 64-bit mode by doing the following:

Verify that Lightroom is running in 64-bit mode on Windows

  1. Start Lightroom and look at the title bar of the application.

  2. See if "x64" appears in the title.

Verify that Lightroom is running in 64-bit mode on Mac OS

  1. In the Finder, navigate to the Applications folder and click Adobe Lightroom 3.

  2. Press Command+I.

  3. In the General options, make sure that Open in 32-bit mode is deselected.

If you use Photoshop with Lightroom, check Photoshop's RAM setting

See the Max Out on RAM and Memory Usage sections in this TechNote to determine the best RAM settings for your computer. To change your memory settings in Photoshop, choose Apple > Preferences > Performance (Mac OS) or Edit > Preferences > Performance (Windows).

High-resolution displays

Drawing to the screen can be slow when Lightroom is using the entire screen of a high-resolution display. A high-resolution display has a native resolution near 2560 x 1600, and is found on 30-inch monitors and Retina MacBooks. To increase performance on such displays, reduce the size of the Lightroom window, or use the 1:2 or 1:3 views in the Navigator panel.

Use optimal settings in Lightroom

Render 1:1 previews intentionally

Lightroom uses previews to display photo thumbnails in the Grid view, the Loupe view, and in the Develop, Slideshow, Print, and Web modules.

When you import photos, you can choose from three types of previews of progressively higher quality:

Minimal: These previews are the small, low-resolution JPEG previews embedded in the photos, which the camera generates. They are the fastest type of preview to create. The Filmstrip and Grid view of the Library module uses minimal previews temporarily, until Lightroom renders standard-size previews for those thumbnails.

Embedded & Sidecar: These previews are larger, also camera-generated, and they take a little longer to create than minimal previews.

Standard: Lightroom creates standard previews. They use the Camera Raw engine for processing. So, they sometimes appear different from minimal or embedded previews, especially if you have applied adjustments in the Develop module. You can specify the size of the Standard preview you need, based on the display you use. Standard previews are used in Filmstrip and Grid view thumbnails, as well as in preview and content areas of the Slideshow, Print, and Web modules.

1:1: These previews are a 100% view of actual pixels and, like Standard previews, the Camera Raw engine processes them. When Lightroom generates 1:1 previews, it also generates minimal and standard previews, so all three are available to the program as needed. Because so much data is being processed, 1:1 previews can take a significant amount of time to create. Any time you zoom to 1:1 or higher in the Library module, Lightroom uses 1:1 previews.

To display and work with photos, Lightroom requires a standard or 1:1 preview, depending on the task. If, upon import, you only tell Lightroom to generate Minimal or Embedded previews, Lightroom creates Standard and 1:1 previews automatically as you’re working in the application. This process hinders performance. To increase your productivity and reduce this disruption, manage when and how you render your 1:1 previews. Render them on import, or set aside time to render them manually.

To render 1:1 previews on import, use the File Handling panel of the import window. Choose Render Previews > 1:1. Although generating high-quality, 1:1 previews on import slows the import process, it makes Lightroom more responsive when you start to work in the Library module.

An alternative, if you want a speedier import process, is to render minimal or standard previews on import. Then, at any time, select multiple photos in the Grid view of the Library module and choose Library > Previews > Render 1:1 Previews. Let Lightroom process the images before you start to work on them.

Keep standard-size previews as small as possible

Because rendering standard previews takes time, don’t make Lightroom crunch harder than it has to. Keeping standard previews small also helps reduce the size of the preview file cache, which speeds performance and saves on hard disk space.

To make standard previews small, specify the appropriate the size and quality in the Catalog Settings dialog box:

  1. Choose Edit >  Catalog Settings (Windows) or Lightroom > Catalog Settings (Mac OS), and then select File Handling.

  2. For Standard Preview Size, choose the amount that is closest to the longest edge of your screen resolution, but not shorter than it. For example, if your screen resolution is 1920 x 1200 pixels, choose Standard Preview Size > 2048 Pixels.

  3. For Preview Quality, choose Low or Medium, which equates to the low- or mid-range of the quality scale for JPEG files.

Note:

The larger the monitor you use (and the higher resolution), the more work Lightroom does to calculate previews and update pixels when you make adjustments. If you experience performance slowdowns with large monitors, try reducing resolution of the display using the Display Control Panel (Windows) or Displays System Preferences (Mac OS). 

Keep 1:1 previews as long as possible

Because 1:1 previews can quickly eat up disk space, Lightroom gives you the option of discarding them regularly—every day, week, or month. Every time you discard them, Lightroom has to re-create them the next time you need them—even if you’re just zooming in to Loupe view.

As long as disk space is not an issue, keep 1:1 previews as long as possible to optimize performance. In the File Handling area of the Catalog Settings dialog box, choose Automatically Discard 1:1 Previews > After 30 Days or Never.

Note, however, that the file that contains the previews, the [Catalog name] Previews.lrdata file can grow large if you have the option to delete previews set to Never or 30 days. This file is in the same the catalog file. If this option is set to Never, and you experience low hard disk issues, check the size of this file. Delete it if it's too large.

Keep the catalog and preview cache in the same folder

By default, Lightroom keeps the preview cache file, [Catalog name] Previews.lrdata, in the same folder as the catalog file, [Catalog name].lrcat. If you move the catalog file or store it separately from the cache, then Lightroom has to regenerate the previews. So keep them together.

For the default location of the catalog, the preview, and other Lightroom files, see Preference file and other file locations.

Leave autowrite XMP turned off

By default, changes you make to files in Lightroom—adding keywords or fixing red eye, for example—are stored with the photo in the Lightroom catalog.  However, for other applications, such as Adobe Bridge and Camera Raw, to recognize those edits, they are saved as XMP (extensible metadata platform) data. This data accompanies the image file.

In Lightroom, edits can be saved to XMP automatically or manually. If you regularly switch between Lightroom, Adobe Bridge, and Camera Raw, it’s most convenient to save changes to XMP automatically. That way, you don’t have to think about it. The applications are always in sync, always reflect the current Lightroom edits, and you don’t see metadata mismatch icons or badges in Bridge or Lightroom.

Saving changes automatically, however, can significantly degrade Lightroom performance. If you don’t work with multiple applications, consider turning off the autowrite preference. Changes are still saved in the catalog, and when you print or export photos from Lightroom, the changes appear in the output.

To turn off autowrite XMP, do the following:

  1. Choose Edit > Catalog Settings (Windows) or Lightroom > Catalog Settings (Mac OS).

  2. Click the Metadata tab, deselect Automatically Write Changes Into XMP.

Even if autowrite XMP is turned off, you can manually save metadata changes to individual files at any time. For more information, see Metadata basics and actions.

Optimize the catalog

Lightroom is constantly writing changes to the catalog file (.lrcat). When performance slows, optimize the Lightroom catalog by choosing File > Optimize Catalog. Optimizing the catalog instructs Lightroom to examine the data structure of the catalog and make sure that it is succinct.

To further optimize performance and improve catalog stability, when you exit Lightroom, and back up the catalog, choose the options Test Integrity Before Backing Up and Optimize The Catalog After Backing Up. These processes take a little time but can help keep the catalog operating smoothly. 

Increase the Camera Raw cache size

Every time you view or edit raw images in the Develop module, Lightroom generates up-to-date, high-quality previews. It uses the original image data as its foundation, and then updates the preview for any processing or adjustments that have been applied. The process is a little faster if the original image data is in the Camera Raw cache. Lightroom checks the cache for the original image data and can skip early stage processing if the image data is cached.

By default, Lightroom sets the Camera Raw cache to 1 GB. If you increase the cache size, it can store more image data, which in turn speeds the generation of previews of those images. Some Lightroom users find that increasing the Camera Raw cache to 20 GB or more can dramatically speed performance in the Develop module. To increase the Camera Raw cache size, do the following:

  1. Choose Lightroom > Preferences (Mac OS) or Edit > Preferences (Windows).

  2. Click the File Handling tab.

  3. In the Camera Raw Cache Settings area, experiment with a Maximum Size of 10.0 GB or more.

To further speed the cache, keep it on a fast hard disk. To specify the location of the Camera Raw cache, do the following:

  1. Choose Lightroom > Preferences (Mac OS) or Edit > Preferences (Windows).

  2. Click the File Handling tab.

  3. In the Camera Raw Cache Settings area, click Choose and navigate to the location where you want to store the cache.

Spot Removal tool, local corrections, and History panel

The Spot Removal Tool and Local Corrections Brush are not designed for hundreds to thousands of corrections. If your image contains many (hundreds) of localized adjustments, consider using a pixel-based editing application such as Photoshop for that level of correction.

If you have many corrections, check your History panel. The History panel has no limits, and it isn't deleted unless specified. If you've been creating many local or spot corrections, your history could be long, which can slow Lightroom's performance as a whole.

Clear the History panel by clicking the X on the right of the History panel header.

Order of Develop operations

The best order of Develop operations to increase performance is as follows:

  1. Spot healing.
  2. Geometry corrections, such as Lens Correction profiles and Manual corrections, including keystone corrections using the Vertical slider.
  3. Global non-detail corrections, such as Exposure and White Balance. These corrections can also be done first if desired.
  4. Local corrections, such as Gradient Filter and Adjustment Brush strokes.
  5. Detail corrections, such as Noise Reduction and Sharpening.

Note: Performing spot healing first improves the accuracy of the spot healing, and ensures the boundaries of the healed areas match the spot location.

Avoid corrections that you don't need

This suggestion applies especially to local corrections. Each slider you've changed when applying local corrections or the gradient filter is applied to that entire correction. And, each option uses resources and can affect performance.

When applying local corrections and gradients, make sure that you need all the corrections you've selected.

If you do not need a brush stroke or gradient to perform a certain type of correction, set its slider to zero.

Also avoid using unnecessary global corrections, especially options that use resources, such as Noise Reduction, Sharpening, and Lens Corrections.

Some sliders default to a value that turns them on by default. For the more resource-intensive options, zero does disable the slider.

Zoom options

If the Fit and Fill zoom options are slow, try using the 1:2, 1:3, or 1:4 options in the Navigator panel.

Which Process Version to use

Process Version 2012 does take more resources than Process Version 2010, so in some cases it could be slower. However, it's necessary to balance the performance gain with the editing and image quality available with Process Version 2012.

Delete the Lightroom previews cache

Although it's rare, sometimes one or more of the following issues can occur, and if they do, you may need to delete your preview cache file:

  • Your hard disk gets unexpectedly full.
  • You get an error about your cache in Lightroom.
  • You get artifacts—such as lines, dots, or unexpected colored areas—in your images.

The file that contains your thumbnail and preview data is called [Catalogname] Previews.lrdata, and is in the same folder as your catalog.

Your thumbnails, small previews, and 1:1 (full size) previews are kept in this Previews.lrdata file. Lightroom's preferences have the option of when to delete the largest previews, the 1:1 previews. When you delete the 1:1 previews, the size of the Previews.lrdata file is reduced. If you don't delete 1:1 previews, the previews file can get very large. 

The default setting for when the large 1:1 previews are deleted is one week. The size of the preview file is reduced when these large previews are deleted, but the entire file isn't deleted unless you manually delete it. The file doesn't become huge unless you rarely or never delete the 1:1 previews, but whether it affects your hard disk depends on your available hard disk space. You can change how often the 1:1 previews are deleted by choosing Edit > Catalog Settings > File Handling (Windows) or Lightroom > Catalog Settings > File Handling (Mac OS). 

Note: Do not confuse the Previews.lrdata file discussed in this technote with the [Catalogname] Smart Previews.lrdata file, which contains all your Smart Previews. In cases where there is very limited hard disk space, you may need to delete this file, but if your hard disk space is low enough that you get low hard disk errors, you should empty your trash, archive some files, and/or reorganize your data so there's more open hard disk space.

If you delete the Previews.lrdata file, previews are recreated for each folder or collection you open in Lightroom, so the first time you work in a folder, you'll experience some delay while previews are recreated.

If the option to Automatically Discard 1:1 Previews is set to Never or After 30 Days, your preview file can get very large. It can take up many GB of space. If your hard disk suddenly gets full, check the size of this file. You can then delete the file. 

You may get an error in Lightroom that indicates a problem with the cache; this is another time you'd want to delete your previews.lrdata file.

If your images display with artifacts, such as colored lines, colored dots, or areas of unexpected colors, then your preview file may be corrupted, and the only way to fix this is to delete the previews.lrdata file. 

Note that if you included previews of images in your catalog from images that you've archived, you'll lose these previews as well. 

If deleting the Previews.lrdata file does not solve your issue, try purging your Camera Raw cache file. 

  1. In Lightroom, choose Edit > Preferences > File Handling (Windows) or Lightroom > Preferences > File Handling (Mac OS).
  2. Click Purge Cache under the Camera Raw Cache Settings. 

You can also change the location of this cache by clicking Choose. Note that this cache is used only by the Develop module. 

Reduce the number of presets

Adding presets to Lightroom (whether created by you or a third-party) can reduce performance because the Develop module generates thumbnails in the Navigator panel for each preset. This is most strongly seen once you have 2,000 or more presets. Reduce the number of presets loaded into Lightroom to only those you use most often to avoid this type of slow down.

Perform regular system maintenance

Keep Lightroom up to date

Updates fix bugs and can improve performance. Make sure you're running the latest update of your version of Lightroom. Choose Help > Check For Updates.

Close unnecessary applications and startup items

Other open applications and startup items decrease the amount of memory available to Lightroom. Quit unnecessary applications, startup items, and extensions and then make more memory available to Lightroom.

When working in Lightroom, also temporarily disable antivirus or security software that performs real-time scanning or automatic backup. For instructions on disabling antivirus or security software features, see the documentation for your antivirus or security software.

Run Disk Cleanup (Windows)

When you work in an application, Windows stores a temporary copy of your data file on the hard drive. Many applications create .tmp files and then delete them when you quit the application. Crashes or system errors, however, can prevent an application from deleting these files, causing them to take up disk space and create problems. From time to time, run Disk Cleanup to remove temporary files and any other files that are not being used.

  1. Windows:  Choose Start, type Disk Cleanup in the Search text box, and choose Disk Cleanup from the Programs list.

  2. Choose a drive to clean up, if appropriate.

  3. Select Temporary Files and any other files that you want to delete.

  4. Click OK.

Defragment the hard disk

As you add, delete, and move files on a hard disk, its available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of files to different locations on the hard drive. It takes Lightroom longer to read or write a fragmented file than one saved to a contiguous location.

When defragmenting a hard disk, be sure to select options to fix drive errors and recover bad sectors. For instructions on defragmenting hard disks on Windows, see these Microsoft Help topics:

Generally speaking, Mac OS hard disks don’t need defragmenting. Mac OS X defragments small files automatically. For more robust defragmentation or to troubleshoot hard disk problems on Mac OS, use Apple Disk Utility. Or, use a third-party utility such as Micromat Tech Tool Pro. See About disk optimization with Mac OS X on the Apple support website.

Install current OS updates

Updates to the Windows or macOS operating system improve its performance and compatibility with applications.

Get Windows service packs and other updates from the Microsoft website. For assistance installing service packs and other updates, contact Microsoft technical support.

To get Mac OS X updates, choose Software Update from the Apple menu. For assistance installing updates, contact Apple technical support.

Note:

Before you install a system update, check the system requirements for the Adobe software to ensure compatibility. (Also check any third-party software or hardware you use with the Adobe software.) If the update isn’t listed, contact Adobe or the manufacturer of your third-party software or hardware.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy