In Acrobat, you can view and interact with high-quality 3D content created in professional 3D CAD or 3D modeling programs and embedded in PDFs. For example, you can hide and show parts of a 3D model, remove a cover to look inside, and turn parts around as if holding them in your hands.

A 3D model initially appears as a two-dimensional preview image. Clicking the 3D model with the Hand or Select tool enables (or activates) the model, opens the 3D toolbar, and plays any animation.

Selected 3D object
Selected 3D object

A. Model Tree B. 3D toolbar C. 3D object 

Enable playing of 3D content in PDF

When you open a PDF with 3D content, you see a yellow bar at the top with the message - "3D content has been disabled. Enable this features if you trust this document."

Autoplay of 3D content is disabled by default
Autoplay of 3D content is disabled by default

To enable 3D content in the current document:

Click the Options button and then select an appropriate option:

  • Trust this document one time only
  • Trust this document always

To enable 3D content permanently:

  • Go to Edit > Preferences > 3D & Multimedia and then select the Enable playing 3D content checkbox.

For more information, see Enable 3D content in PDF.

3D toolbar overview

The 3D toolbar appears after you click the 3D model with the Hand tool. This action activates the 3D model and plays animations that are set to play when the file is enabled. The 3D toolbar always appears in the area above the upper-left corner of the 3D model and cannot be moved. A small arrow appears to the right of the Rotate tool, which you can click to either hide or expand the toolbar.

You can use the 3D toolbar to zoom in and out, rotate, and pan across the object. Use the Model Tree to hide or isolate parts, or make parts transparent.

You manipulate a 3D model by selecting and dragging various 3D navigation tools. When you navigate in 3D, it helps to think of it as viewing the stationary 3D model from a camera’s perspective. You can rotate, pan (move up, down, or side-to-side), and zoom in or out.

3D navigation tools

Rotate 

Turns 3D objects around relative to the screen. How the objects move depends on the starting view, where you start dragging, and the direction in which you drag.

Note:

You can also use the Hand tool to rotate an object. Ensure that Enable 3D Selection For The Hand Tool is selected in the 3D panel of the Preferences dialog box.

Spin 

Turns a 3D model in parallel to two fixed axes in the 3D model, the x-axis and the z-axis.

Pan 

Moves the model vertically and horizontally only. You can also pan with the Hand tool: Ctrl-drag.

Zoom 

Moves you toward, or away from, objects in the scene when you drag vertically. You can also zoom with the Hand tool by holding down Shift as you drag.

Walk 

Pivots horizontally around the scene when you drag horizontally. Moves forward or backward in the scene when you drag vertically; maintains a constant elevation level, regardless of how you drag. The Walk tool is especially useful for architectural 3D models. To change the walking speed, change the default display units in the Preferences (3D).

Note:

The Walk tool is available when you select the Preferences setting that consolidates tools or when you right-click the 3D model and choose Tools > Walk.

Fly

Navigates through a model while maintaining the surface orientation. Right-click and drag inside the 3D window. The Fly tool moves more slowly the closer you move toward an object. Drag the pointer right or left to turn.

To rotate the camera view, click the left mouse button inside the 3D window and drag to turn the camera view. To return to the starting camera direction, move the mouse back to the initial click point.

Use the mouse scroll wheel to move rapidly backward and forward along the camera view direction. This functionality is useful if you get lost within a model or fly into the surface.

Camera properties

Defines the camera angle, alignment, and other properties that define the lens through which a 3D model is viewed. Camera properties are components of views but are set independently.

3D Measurement Tool 

Measures part sizes and distances in the 3D model.

3D toolbar view controls

Default View 

Returns to a preset zoom, pan, rotation, and projection mode of the 3D model. Use the Options menu in the View pane of the Model Tree to set a different view as the default. Or use the Manage Views command on the 3D toolbar Views menu to set a different view as the default.

Note:

If an object ever moves out of your view, you have, in essence, turned your camera away from the object. Click the Default View icon on the 3D toolbar to move the object back into view.

Views menu

Lists any views defined for the current 3D model.

Toggle Model Tree 

Opens and hides the Model Tree.

Play/Pause Animation  

Plays or pauses any JavaScript-enabled animation. The Play/Pause Animation pop-up menu opens a slider that you can drag back and forth to move to different times in the animation sequence.

Use Orthographic/Perspective Projection 

Toggles between displaying perspective and orthographic projection of the 3D object.

Model Render Mode menu 

Determines how the 3D shape appears. For an illustrated guide, see Examples of model rendering modes.

Enable Extra Lighting menu 

Lists the different lighting effects that are available to enhance the illumination of the 3D object. Experiment to get the visual effects you want.

Background Color 

Opens the color picker, which you can use to select a different color for the space surrounding the 3D object.

Toggle Cross Section 

Shows and hides cross sections of the object. Click the pop-up menu to open the Cross Section Properties dialog box. For more information, see Create cross sections.

Add Multimedia/3D Comment

Enables you to add a sticky note to any part of the 3D model. The note stays with the view. See Commenting on 3D designs in PDFs.

3D preferences

In the 3D & Multimedia panel of the Preferences dialog box, you can determine whether the 3D toolbar and Model Tree are displayed by default. You can also specify a default renderer and determine whether animations are allowed.

Enable Playing of 3D Content

The dynamic nature of 3D provides the potential for it to be subject to security vulnerabilities. Therefore, the auto-play of 3D content in PDFs is disabled by default. Select this option to enable 3D content in PDFs.

Preferred Renderer

Specifies the rendering engine used to affect both performance and quality, so it’s important to select the appropriate renderer. Depending on your system, you can change your render engine. If you select a DirectX® or OpenGL option, all rendering takes place using the graphics chip on the video adapter. If Software is selected, rendering takes more time, but the performance is often more consistent with the model rendering of the originating application.

Enable Hardware Rendering For Legacy Video Cards

Forces the use of a hardware accelerator for even video adapters that do not support a pixel shader.

Enable Double-Sided Rendering

Some model parts have two sides. To save time and space, you can deselect this option to render only the side facing the user. If the user looks inside a part rendered with only one side, the back side would be invisible.

Preferred 3D PMI Rendering Mode

Specifies the PMI mode to use for rendering. You can select one of the following options:

Use Content Setting—The rendering of the PMI uses the setting of each PMI to decide whether it uses the Z-buffer.

Always Render 3D PMI In Front Of Model—The rendering of the PMI ignores the Z-buffer regardless of the setting in the file.

Always Render 3D PMI Using Z-buffer—The rendering of the PMI always turns on Z-buffer regardless of the setting in the file.

Open Model Tree On 3D Activation

Determines whether the Model Tree is displayed when the 3D model is activated. Choose Use Annotation’s Setting to use whichever setting the author used when adding the 3D model to the PDF.

Default Toolbar State

Determines whether the 3D toolbar is shown or hidden when a 3D model is activated. Choose Use Annotation’s Setting to use whichever setting the author used when adding the 3D model to the PDF.

Enable Selection For The Hand Tool

Lets the user select and highlight parts of the 3D model using the Hand tool. If this option is not selected, use the Object Data tool (Tools > Interactive Objects > Select Object) to select the object.

Consolidate Tools On The 3D Toolbar

Selecting this option places the manipulation and navigation tools under the Rotate tool, thereby shortening the 3D toolbar.

Enable View Transitions

Some 3D models include animated transitions between views. Deselect this option if you want to prevent this 3D animation.

Show 3D Orientation Axis

Turns on or off an in-scene display of an axis that indicates the current orientation of the 3D scene.

Optimization Scheme For Low Framerate

Specifies what happens to animations of complex models when the framerate becomes low. None does not compromise the visuals and leaves the framerate low. Bounding Box shows the three-dimensional planes enclosing the parts instead of the parts themselves, which keeps the framerate high. Drop Objects does not show some parts of the model, which keeps the framerate high.

Framerate Threshold

Sets the minimum framerate, either by dragging the slider or entering a number in the value box. If the framerate drops below that number of frames per second, the Optimization Scheme For Low Framerate option goes into effect.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy