Select layers

Selected layers that also have properties selected are indicated with a hollow highlight in the Timeline panel. A selected layer that has no properties selected is indicated with a solid highlight.

Top layer selected, but no properties selected; bottom layer selected with properties selected
Top layer selected, but no properties selected; bottom layer selected with properties selected.

Note:

To scroll the topmost selected layer to the top of the Timeline panel, press X.

  • To select a layer, click the layer in the Composition panel, click its name or duration bar in the Timeline panel, or click its name in the Flowchart panel.
  • To select a layer that is obscured in the Composition panel, right-click (Windows) or Control-click (Mac OS) over the layer in the Composition panel, and choose Select > [layer name].
  • To select a layer if the layer is open in its own Layer panel, choose the layer name from the Window menu or the Layer panel viewer menu.
  • To select a layer by position number, type the layer number on the numeric keypad. If the layer number has more than one digit, type the digits quickly so that After Effects can recognize them as one number.
  • To select the next layer in the stacking order, press Ctrl+Down Arrow (Windows) or Command+Down Arrow (Mac OS). To select the previous layer, press Ctrl+Up Arrow (Windows) or Command+Up Arrow (Mac OS).
  • To extend the selection to the next layer in the stacking order, press Ctrl+Shift+Down Arrow (Windows) or Command+Shift+Down Arrow (Mac OS). To extend the selection to the previous layer in the stacking order, press Ctrl+Shift+Up Arrow (Windows) or Command+Shift+Up Arrow (Mac OS).
  • To select all layers, choose Edit > Select All while the Timeline or Composition panel is active. To deselect all layers, choose Edit > Deselect All. If the composition’s Hide Shy Layers switch is selected, using Select All when the Timeline panel is active doesn’t select shy layers. (See Show and hide layers in the Timeline panel.)
  • To deselect any currently selected layers and select all other layers; with at least one layer selected, choose Invert Selection from the context menu in the Composition or Timeline panel.
  • To select all layers that use the same color label, click the color label in the Timeline panel, and choose Select Label Group, or select a layer with that color label and choose Edit > Label > Select Label Group.
  • To select all child layers assigned to a parent layer, select the parent layer and choose Select Children from the context menu in the Composition or Timeline panel. The child layers are added to the existing selection.
  • You can select multiple layers in the Composition panel . Drag with the Selection tool to create a selection box (marquee) around the layers to select them. Hold Shift while clicking or dragging to select additional layers or to deselect layers.

Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to their tags. The tags are appended to comments in the Comments field in the Timeline panel.

Change the stacking order for selected layers

The vertical arrangement of layers in the Timeline panel is the layer stacking order, which is directly related to the render order. You can change the order in which layers are composed with one another by changing the layer stacking order.

Note:

Because of their depth properties, the stacking order of 3D layers in the Timeline panel does not necessarily indicate their spatial position in the composition.  

  • In the Timeline panel, drag the layer names to a new position in the layer stacking order.
  • To move the selected layers up one level in the layer stacking order, press Ctrl+Alt+Up Arrow (Windows) or Command+Option+Up Arrow (Mac OS); to move the selected layers down one level, press Ctrl+Alt+Down Arrow (Windows) or Command+Option+Down Arrow (Mac OS).
  • To move the selected layers to the top of the layer stacking order, press Ctrl+Alt+Shift+Up Arrow (Windows) or Command+Option+Shift+Up Arrow (Mac OS); to move the selected layers to the bottom, press Ctrl+Alt+Shift+Down Arrow (Windows) or Command+Option+Shift+Down Arrow (Mac OS).
  • Choose Layer > Arrange, and then choose Bring Layer Forward, Send Layer Backward, Bring Layer To Front, or Send Layer To Back.

Note:

When you copy (or cut) and paste layers, the layers are pasted so that they appear from top to bottom in the Timeline panel in the same order in which they were selected before the copy (or cut) operation. You can Ctrl-click (Windows) or Command-click (Mac OS) layers to select them in any arbitrary order, cut them, and then immediately paste them to reorder the layers in the order in which they were selected.

Jeff Almasol provides a script on his redefinery website with which you can change the stacking order of layers in a composition by sorting according to In point, Out point, selection order, layer name, or random order.

Coordinate systems: composition space and layer space

The coordinate system for each layer is its layer space. The coordinate system for each composition is its composition space. Property values for items that exist within a layer—such as effect control points and anchor points—exist in layer space and are measured from the origin in the layer space of that layer. The Position property of a layer, however, describes where the layer is within a composition and is therefore measured in the composition space of that composition.

As you move the pointer over the layer frame in the Layer panel, the Info panel displays the coordinates of the pixel under the pointer in layer space. The X coordinate represents position on the horizontal axis, and the Y coordinate represents position on the vertical axis. Values for these coordinates are in pixels. The X and Y coordinates are relative to the origin (0,0), which is fixed at the upper left corner of the layer.

You can modify the zero point of the rulers, but you can’t modify the origin of layer space. If the zero point differs from the origin, X' and Y' coordinates appear in the Info panel below the X and Y coordinates, indicating coordinates based on the zero point of the rulers.

When you move the pointer over the composition frame in the Composition panel, the Info panel displays coordinates in composition space. As you drag a layer, the lower portion of the Info panel displays the coordinates of the anchor point of the layer.

Move layers in space

When you move a layer in space, you modify its Position property.

You can separate the components of a Position property into individual properties—X Position, Y Position, and (for 3D layers) Z Position—so that you can modify or animate each independently. (See Separate dimensions of Position to animate components individually.)

Jeff Almasol provides a script on his redefinery website that places a new null layer on the line between the anchor points of two selected layers; you use a slider control on the null layer to reposition the null layer along this line.

Note:

To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press Ctrl+Home (Windows) or Command+Home (Mac OS).

Note:

To move a layer so that its anchor point is at the center of the composition, right-click (Windows) or Control-click (Mac OS) the Position property, choose Edit Value, choose % Of Composition in the Units menu, and enter 50 for each of the components of the Position property.

To avoid softening of an image that is not moving, make sure that a layer’s Position values are non-fractional values. This avoids resampling that is used when a layer with image quality set to Best is placed on subpixels.

Move layers by dragging in the Composition panel

Note:

To snap the edges of a layer to grids or guides as you drag, choose View > Snap To Grid or View > Snap To Guides.

  • Select one or more layers, and then drag a selected layer using the Selection tool .

    When you move a layer by dragging it in the Composition panel, the Info panel shows the change in the Position property as you drag.

Move layers by directly modifying the Position property

  1. Select one or more layers.
  2. Press P to show the Position property in the Timeline panel.
  3. Modify the Position property in the Timeline panel.

Move layers with arrow keys

  1. Select one or more layers.
  2. To move selected layers one pixel left, right, up, or down, press an arrow key. To move 10 pixels, hold Shift as you press the arrow key.

    Note:

    The arrow keys move the layer one pixel at the current magnification. To move a layer more precisely with the arrow keys, zoom in the Composition panel. (See Zoom an image for preview.)

Separate dimensions of Position to animate components individually

By default, each Position property has two or three components, with each holding the value for one of the spatial dimensions (axes). You can separate the components of a Position property into individual properties—X Position, Y Position, and (for 3D layers) Z Position. Separating dimensions allows you to modify or animate the position of a layer along the x axis, y axis, and z axis independently.

To decompose selected Position properties into individual X Position, Y Position, and (for 3D layers) Z Position properties, do one of the following:

  • Choose Animation > Separate Dimensions.
  • Right-click (Windows) or Control-click (Mac OS) a Position property and choose Separate Dimensions from the context menu.
  • Click the Separate Dimensions button at the bottom of the Graph Editor.

To recompose a set of individual Position properties into a single Position property with multiple components, use the same commands that you use to separate dimensions.  

Note:

When you recompose separate Position properties into a single Position property, some information about the motion path and speed is lost, because the multiple Bezier curves used to represent the individual components are collapsed into a single Bezier curve at each keyframe. When you separate dimensions, some information about speed is lost, but the motion path does not change. You should work with separate dimensions or without separate dimensions for each property for an entire project, rather than toggling back and forth.

The decision of whether to work with separate dimensions depends on what you’re trying to accomplish. Using one property for position has the advantage of providing smooth motion more easily. Also, using a single property for position enables the use of roving keyframes, which provides uniform speed. Working with separate dimensions for position sacrifices some of this automatic smoothing to gain greater control of spatial animation. Working with separate dimensions also makes some simulations easier, especially in cases in which the simulated forces acting on a layer are orthogonal (perpendicular) to one another.

For example, if you are animating a ball flying horizontally and bouncing vertically, you can do so more easily by separating dimensions. The X Position property can be animated with two keyframes, one for the start position and one for the end position. This horizontal animation represents the speed of the throw. The Y Position property can be animated with a single expression that simulates the acceleration due to gravity and the vertical bouncing from the floor. A similar example is a boat drifting down a river in a variable crosswind.

Note:

After Effects CS3 included a Separate XYZ Position animation preset that accomplished something similar to the Separate Dimensions feature, though the animation preset is not as robust.

Align or distribute layers in 2D space

Use the Align panel to line up or evenly space selected layers. You can align or distribute layers vertically or horizontally.

  1. Select the layers to align or distribute.
  2. Choose Selection or Composition from the Align Layers To menu.

    Selection

    Aligns selected layers according to the layer boundaries of the selected layers.

    Composition

    Aligns selected layers according to the boundaries of the composition frame.

  3. In the Align panel, click the button representing the desired type of alignment or distribution.
  • To distribute, you must select three or more layers. When Selection is chosen in the Align Layers To menu, you must select two or more layers to align. When Composition is chosen in the Align Layers To menu, you must select one or more layers to align.

  • When Selection is chosen in the Align Layers To menu, each alignment option aligns selected layers to the layer that most closely represents the new alignment. For example, for right-edge alignment, all selected layers align to the selected layer with the edge that is farthest to the right.

  • A distribution option evenly spaces selected layers between the two most extreme layers. For example, for a vertical distribution option, the selected layers are distributed between the topmost and bottommost selected layers.

  • When you distribute layers of different sizes, the spaces between layers may not be uniform. For example, distributing layers by their centers creates equal space between the centers—but different-sized layers extend by different amounts into the space between layers.

  • Alignment or distribution options cannot move locked layers.

  • The Align panel does not affect alignment of characters within a text layer.

Note:

To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press Ctrl+Home (Windows) or Command+Home (Mac OS).

Charles Bordenave (nab) provides a script on the After Effects Scripts website, with which you can distribute layers in 3D space.

Trim, extend, or slip-edit a layer

The beginning of the duration of a layer is its In point, and the end is its Out point. The duration is the span between the In point and the Out point, and the bar that extends from the In point to the Out point is the layer duration bar.

To trim a layer is to modify its In or Out point so that the layer has a different duration. When you trim a layer that is based on moving source footage, you affect which frames of the source footage item are shown in the layer; the first frame to appear is at the In point, and the last frame to appear is at the Out point. Trimming a layer doesn’t cut frames from the footage item; it only affects what frames are played for the layer.

Trimming layers in Timeline panel
Trimming layers in the Timeline panel

A. Original In point B. Negative layer time indicator for still image layer C. Original In point D. Slip-edit bar, representing excluded frames for motion footage layer E. New In points 

When you use a footage item as a source for different layers, you can trim each layer differently to show different portions of the source. Trimming a layer does not alter the footage item or the original source file.

You can trim a layer by changing the In and Out points in the Layer panel or the Timeline panel. (You can also trim a footage item before using it to create a layer. See Create layers from footage items or change layer source.)

The In point , Out point , and duration values for a layer are shown at the bottom of the Layer panel. To show this information for all layers in the Timeline panel, click the In/Out/Duration/Stretch button in the lower-left corner of the Timeline panel. The duration, In point, and Out point for the selected layer are also shown in the Info panel.

In the Layer panel, In and Out points are expressed in layer time. In the Timeline panel, In and Out points are expressed in composition time. The duration is the same in both cases (unless time-remapping or time-stretching is enabled for the layer).

You can extend many kinds of layers for any duration, extending their In points and Out points out past their original times. This capability applies to time-remapped layers, shape layers, layers based on still-image footage items, camera layers, light layers, and text layers. If you extend a layer back in time so that the layer extends into negative layer time (past layer time zero), a series of hash marks on the bottom of the layer bar indicates the portions of the layer that are in negative layer time. This indication is useful if you’ve applied effects to the layer—such as Particle Playground or Shatter—that use layer time to calculate their results.

Online resources for trimming, extending, and editing layers

Jeff Almasol provides a script on his redefinery website that creates a panel with controls for moving various combinations of items in time: layer In point, layer Out point, layer source frames, keyframes, and markers.

Trim or extend layers in the Timeline panel

Dragging the Out point of a layer duration bar
Dragging the Out point of a layer duration bar.

  1. Select one or more layers in the Timeline panel.
  2. Do one of the following:
    • Drag either end of a layer duration bar.

    • Move the current-time indicator to the time at which you want to set the In point or Out point. To set the In point to the current time, press Alt+[ (Windows) or Option+[ (Mac OS). To set the Out point to the current time, press Alt+] (Windows) or Option+] (Mac OS).

Trim or extend a layer in the Layer panel

  • Open the layer in the Layer panel and drag either end of the layer duration bar.
  • Move the current-time indicator in the Layer panel to the time at which you want the footage to begin or end, and then click the In or Out button to set the In or Out point to the current time.

Slip-edit a layer

After you’ve trimmed a layer based on moving footage, a pale slip-edit bar represents the frames of the footage item that you are excluding from the composition. This pale rectangle does not appear for a trimmed layer based on a still footage item. You can choose which frames are played within a trimmed duration by dragging the slip-edit bar. The In and Out points of the layer are not affected.

Moving only the In or Out point of a layer doesn’t move keyframes. Dragging the layer duration bar moves all keyframes. Dragging the slip edit bar moves selected keyframes, but does not move unselected keyframes.

Note:

When performing a slip edit, you probably want to move some keyframes with the source footage—such as mask keyframes. Other keyframes should stay where they are in time. Press Shift+F2 to deselect keyframes and leave the layer selected.

  • Drag the slip-edit bar to the left or right.
  • Drag the layer to the left or right with the Pan Behind (Anchor Point) tool.

Remove part of the duration of a layer

  1. In the Timeline panel, set the work area to include only the portion of the layers’ duration to remove: Move the current-time indicator to the time that the work area is to begin, and press B. Move the current-time indicator to the time at which the work area is to end, and press N.
  2. Do one of the following:
    • Select the layers from which to remove a section.

    • Select the Lock switch for layers that you do not want affected by the extraction. Press F2 to deselect all layers.

    Note:

    If no layers are selected, the following step removes the section from all unlocked layers.

  3. Do one of the following:
    • To remove the section and leave a gap of the same duration as the removed section, choose Edit > Lift Work Area.

    • To remove the section, choose Edit > Extract Work Area. The gap is closed by ripple deletion.

Place or move a layer in time

The layer duration bar represents the layer duration visually. The In, Out, and Duration columns in the Timeline panel represent the layer duration numerically.

Note:

To choose which columns are visible in the Timeline panel, choose Columns from the panel menu, or right-click (Windows) or Control-click (Mac OS) a column heading.

These procedures move the entire layer in time.

  • To set the In point or Out point numerically, click the number in the In or Out column for the layer in the Timeline panel.
  • To move the In point or Out point to the current time, Alt-click (Windows) or Option-click (Mac OS) the number in the In or Out column for the layer in the Timeline panel.
  • To move the In points of selected layers to the beginning of the composition, press Alt+Home (Windows) or Option+Home (Mac OS).
  • To move the Out points of selected layers to the end of the composition, press Alt+End (Windows) or Option+End (Mac OS).
  • To move selected layers one frame later, press Alt+Page Down (Windows) or Option+Page Down (Mac OS). To move selected layers 10 frames later, press Alt+Shift+Page Down (Windows) or Option+Shift+Page Down (Mac OS).
  • To move selected layers one frame earlier, press Alt+Page Up (Windows) or Option+Page Up (Mac OS). To move selected layers 10 frames earlier, press Alt+Shift+Page Up (Windows) or Option+Shift+Page Up (Mac OS).
  • To move the entire layer in time by dragging, drag the layer duration bar to the left or right. To snap the layer duration bar to significant points in time (such as markers, or the start or end of the composition), Shift-drag the layer duration bar.

Note:

When you drag a layer in the Timeline panel, the Info panel displays the name, duration, change in time, and In and Out points for the layer.  

Before and after dragging the duration bar
Before and after dragging the duration bar

Jeff Almasol provides a script on his redefinery website with which you can move selected layers as a group, aligning the group to a specific time in the composition.

Arrange layers in time sequentially

Use the Sequence Layers keyframe assistant to automatically arrange layers in a sequence. When you apply the keyframe assistant, the first layer you select remains at its initial time, and the other selected layers move to new times in the Timeline panel based on the order in which you selected them.

Layers selected in Timeline panel
Layers selected in Timeline panel (top), and layers arranged in sequence by applying the Sequence Layers Keyframe Assistant (bottom)

Overlapping layers
Overlapping layers can have Opacity keyframes set automatically to create a cross-dissolve.

For a layer to be put into a sequence, its duration must be less than the length of the composition so that it leaves time for other layers. (See Trim, extend, or slip-edit a layer.)

  1. In the Timeline panel, hold down Ctrl (Windows) or Command (Mac OS) and select layers in sequential order, beginning with the layer to appear first.
  2. Choose Animation > Keyframe Assistant > Sequence Layers.
  3. In the Sequence Layers dialog box, do one of the following:
    • To arrange the layers end to end, leave the Overlap option unselected.

    • To overlap layers, select Overlap, enter a Duration value for the duration of the overlap, and select a transition. Select Cross Dissolve Front And Back Layers to use the transparency of the selected layers; otherwise, choose Dissolve Front Layer.

    • To leave gaps between the layers, select Overlap and enter a negative Duration value.

Copy or duplicate a layer

When you copy a layer, you copy all of its properties, including effects, keyframes, expressions, and masks.

Duplicating a layer is a shortcut with which you copy and paste the layer with one command. Duplicating a layer with a track matte preserves the relative ordering of the layer and its track matte.

When you paste layers, they are placed in the order in which you selected them before copying. The first layer selected is the last one to be placed, so it ends up on the top in the layer stacking order. If you select layers from the top first, they end up in the same stacking order when pasted.

Note:

If you have a component of a layer—such as a mask or keyframe—selected when you copy, you copy only that component. Before copying, press Shift+F2 to deselect all of the components of a layer and leave the layer itself selected.

  • To copy selected layers and place the In points of the copies at the current time, choose Edit > Copy, and then press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS).
  • To copy selected layers and place the copies at the same times as the originals, choose Edit > Copy, and then choose Edit > Paste.

Note:

To place copies at the top of the layer stack in the Timeline panel instead of immediately above the originals, press F2 to deselect the originals before you paste.

  • To duplicate selected layers, choose Edit > Duplicate or press Ctrl+D (Windows) or Command+D (Mac OS).

Split a layer

In the Timeline panel, you can split a layer at any time, creating two independent layers. Splitting a layer is a time-saving alternative to duplicating and trimming the layer—something you might do when you want to change the stacking-order position of the layer in the middle of the composition.

Note:

To make new split layers appear above the original layer in the Timeline panel, select Create Split Layers Above Original Layer (Edit > Preferences > General (Windows) or After Effects > Preferences> General (Mac OS)). Deselect this option to make the layers appear below the original layer.

  1. Select one or more layers.
  2. Move the current-time indicator to the time at which to split the layers.
  3. Choose Edit > Split Layer.

When you split a layer, both resulting layers contain all of the keyframes that were in the original layer in their original positions. Any applied track mattes retain their order, on top of the layer.

After you split a layer, the duration of the original layer ends at the point of the split, and the new layer starts at that point in time.

If no layer is selected when you choose Edit > Split Layer, all layers are split at the current time.

Paul Tuersley provides a script on the AE Enhancers forum for splitting layers at layer markers.

Lloyd Alvarez provides a script on his After Effects Scripts website that automatically detects edits in a footage layer and splits it into a separate layer for each edit (or places a layer marker at each edit).

Auto-Orientation options

The auto-orientation options (Layer > Transform > Auto-Orient) for each layer specify how its orientation depends on motion paths, points of interest, and cameras.

Off

The layer rotates freely, independent of the motion path, point of interest, or other layers.

Orient Along Path

The layer faces in the direction of the motion path. For example, use this option for a camera to depict the perspective of a driver who is looking at the road ahead while driving.

Orient Towards Camera

The layer is always oriented so that it faces the active camera. This option is available for 3D layers; this option is not available for 2D layers, cameras, or lights. 3D text layers have an additional option, Orient Each Character Independently, which orients each character around its individual anchor point. Selecting Orient Each Character Independently enables per-character 3D properties for the text layer if they aren’t already enabled. (See Per-character 3D text properties.)

Orient Towards Point Of Interest

The camera or light always points at its point of interest. This option is not available for layers other than cameras and lights. (See Cameras, lights, and points of interest.)

Note:

If you specify an auto-orientation option for a layer, and then change its Orientation or X, Y, or Z Rotation properties, the layer orientation is offset by the new values. For example, you can set a camera with Orient Along Path, and then rotate the camera 90 degrees to the right to depict the perspective of a passenger looking out the side window of a car as it moves.

The automatic orientation to point to the point of interest occurs before the Rotation and Orientation transformations are applied. To animate a camera or light with the Orient Towards Point Of Interest option to look temporarily away from the point of interest, animate the Rotation and Orientation transform properties.

Dan Ebberts provides an expression on his MotionScript website that auto-orients a layer along only one axis. This is useful, for example, for having characters turn from side to side to follow the camera while remaining upright.

Additional resources for selecting and arranging layers

Jeff Almasol provides a script on his redefinery website that creates a panel with controls for moving various combinations of items in time: layer In point, layer Out point, layer source frames, keyframes, and markers.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy