Creative_Cloud_mnemonic_RGB_128px

Update to After Effects CC available.

For more information, see the New features summary.


This document describes the new and updated features in After Effects CC (October 2013).

See the system requirements page for After Effects CC system requirements.

Mask Tracker

The mask tracker transforms a mask so that it follows the motion of an object or objects in a movie. The tracked object must maintain the same shape throughout the movie, though it can change position, scale, and/or perspective and still be effectively tracked.
When a mask is selected, the Tracker panel switches to mask tracking mode and displays the following controls:

  • Track forward or backward either one frame at a time or to the end of the layer
  • Method with which you can choose to modify position, scale, rotation, skew, and perspective for the mask

Select Animation > Track Mask with a mask selected, or context-click a mask and choose Track Mask from the context menu to display the Tracker panel.

For more information, see the Mask Tracking article.

Detail-preserving Upscale effect

The Detail-preserving Upscale effect can scale up images by large amounts while the image details are preserved and the sharp lines and curves stay sharp. For example, you can scale up from SD frame sizes to HD frame sizes, or from HD frame sizes to digital cinema frame sizes.

For more information, see the Detail-preserving Upscale effect article.

HiDPI content viewers for Retina displays on Mac computers

After Effects makes use of the Retina Display on Mac computer so that each pixel of content in a viewer is shown as a single pixel on the display.

This affects contents of the following:

  • The Footage panel
  • The Layer panel
  • The Composition panel, including the video content and some UI elements within the content area

This does not affect pointers, buttons, or other panels of the After Effects user interface.  

Updated Cineware functionality

There are two new settings in the Cineware effect's Options dialog box. You can specify the instance of Cinema 4D to use with After Effects:
For Cinema 4D Render Path: Choose which version of Cinema 4D (R14 or R15) for rendering while working in After Effects.
Cinema 4D Executable Path: Choose which version of Cinema 4D to use when opening a .c4d file from After Effects, such as when using the Edit Original command..

For more information, see Updates to Cinema 4D section.

New OptiX library for ray-traced 3D renderer

After Effects CC now uses the new OptiX 3.0 library. The earlier version of After Effects used the OptiX 2.0 library.

The new OptiX library has the following main advantages over the Optix 2.0 library:

  • Fixes a crash on Mac OS X v10.9 (Mavericks)
  • Improved performance, including improvements with multiple GPUs

Bypassing whitelist for GPU acceleration of ray-traced 3D renderer

The GPU Information dialog box has a Ray-tracing menu from which the user can choose either GPU or CPU.

In previous versions of After Effects, if the installed hardware was not on the list of tested and supported GPUs, the GPU menu item would be disabled (grayed out) and the following text displayed below the menu: GPU not available - incompatible device or display driver".

Now, there is a new option for GPU under Edit > Preferences > Previews > GPU Information: "Enable untested, unsupported GPU for CUDA acceleration of ray-traced 3D renderer".

If the checkbox is enabled, After Effects uses the GPU-accelerated ray-traced 3D renderer with any GPU that meets minimum requirements.

List of new cards in CUDA whitelist for OptiX

The following cards have been added to CUDA whitelist for OptiX (for GPU acceleration of the ray-traced 3D renderer):

  • GTX 675MX (Windows and Mac OS)
  • GTX 680MX (Windows and Mac OS)
  • GTX 590 (Windows)
  • GT 650M (added for Windows; already present in Mac OS list)
  • GTX 760 (Windows)
  • GTX 770 (Windows)
  • GTX 780 (Windows)
  • GTX TITAN (Windows)
  • Quadro K6000 (Windows)
  • Quadro K4000 (Windows)
  • Quadro K2000 (Windows)
  • Quadro K5000M (Windows)
  • Quadro K4000M (Windows)
  • Quadro K3000M (Windows)
  • Quadro K5100M (Windows)
  • Quadro K4100M (Windows)
  • Quadro K3100M (Windows)
  • Quadro K2100M (Windows)

For a complete list of supported GPUs, see the Supported GPUs for ray-traced 3D renderer article.

Improved performance for analysis phase for 3D Camera Tracker and Warp Stabilizer

The background process that analyzes footage for the 3D Camera Tracker and Warp Stabilizer is now much faster. Depending on details of the footage and other factors, the increase in speed for the analysis (tracking) phase has been measured at 60-300%.

Enhancements and changes to properties

Reveal Properties With KeyFrames

The commands to reveal modified properties in the Timeline panel have changed; the Animation menu now has three commands to reveal properties:

  • Reveal Properties with Keyframes (keyboard shortcut U) - Reveal any property that has a keyframe. If a property has both keyframes and expressions, the property is shown but the expression itself is not shown.
  • Reveal Properties with Animation - Reveal any property that has a keyframe or an expression.
  • Reveal All Modified Properties (keyboard shortcut UU) -  Reveals keyframes, expressions, or all modified properties (including keyframes and expressions) that are not animated.

To link properties from one layer to another:

  1. Select any property or set of properties.
  2. Choose Edit > Copy With Property Links.
  3. Paste the properties on any layer in any composition.

The pasted properties now remain connected to the layer from which the properties were copied. This ensures that any change made to the original property is reflected in all of the instances of the pasted property links.

You can copy an entire layer with property links and paste it to create duplicates that follow the changes made to the original.  You can also link entire property groups in a layer. For example, copy the transform group and paste it onto another layer to link all the transform properties without selecting them individually.

 


New properties in the Expression Language Menu

The following new properties have been added to the Expression Language Menu:

  • irisShape
  • irisRotation
  • irisRoundness
  • irisAspectRatio
  • irisDiffractionFringe
  • highlightGain
  • highlightThreshold
  • highlightSaturation

See the Add and Edit expressions section for more information.

Rectified audio waveforms

In After Effects, audio waveforms are shown as "rectified" audio waveforms. This means that the magnitude of the audio is shown only in one direction from the horizontal axis on a logarithmic scale. This makes it easier to estimate the perception of the loudness of a sound.
You can switch back to the old method of showing audio waveforms by deselecting Rectified Audio Waveforms in the panel menu of the Timeline panel.

Changes to snapping to align layers in 2D and 3D

There are two new options next to the Snapping checkbox in the Tools panel:


Snap Along Edges Extending Beyond Layer Boundaries: Enables snapping to lines outside a layer’s boundaries. For example, snap to the line defined by the extension of a layer’s edge in 3D space. This makes aligning layers in 3D space much easier.

Snap To Features Inside Collapsed Compositions And Text Layers: Turns on internal wireframes for layers inside compositions with collapsed transformations and for individual characters in per-character 3D text layers. For example, this can be useful for snapping a layer’s anchor point to a different layer in the composition.

Enable Video Preview to external devices (Mac OS)

To enable video preview to external devices on Mac OS, select the new Enable QuickTime Video Preview option in the Video Preview preferences category. If this preference is checked, After Effects will request a list of external video preview devices from QuickTime.

Caution: Enabling this option may cause Adobe QT32 Server to crash, which will cause After Effects to fail.

Earlier versions of After Effects automatically requested a list of external video preview devices from QuickTime.

Changes and enhancements to layers

Center anchor point

You can set the anchor point to be in the center of the layer content in one of the following ways:

  1. Layer > Transform > Center Anchor Point In Layer Content
  2. Use the keyboard shortcut Ctrl+Alt+Home on Windows or Command+Option+Home on Mac OS.
  3. You can also use Ctrl+double-click (Windows) or Command+double-click on (Mac OS) the Pan Behind (Anchor Point) tool.

To learn about anchor points, see Anchor Point Properties.

New layer creation

In this version of After Effects, a new layer is created immediately above the topmost selected layer. If no layer is selected, then the new layer is created at the top of the layer stack.

This new behavior applies to the following layer commands:

  • Layer > New > Text 
  • Layer > New > Solid 
  • Layer > New > Light 
  • Layer > New > Camera 
  • Layer > New > Null Object 
  • Layer > New > Shape Layer 
  • Layer > New > Adjustment Layer 
  • Layer > New > Adobe Photoshop File 
  • Layer > New > MAXON CINEMA 4D File


Adjust precomposition duration

There is a new option in the Precompose dialog box: Adjust Composition Duration To The Time Span Of The Selected Layers.

Choose this option to create a new composition that has the same duration as that spanned by the selected layers.

In previous versions of After Effects, the duration of the newly created composition is the same as the duration of the original composition, regardless of the duration of the layers being precomposed.


Bicubic Sampling in the Transform effect

The Transform effect has a new Sampling option that allows you to choose between Bilinear and Bicubic.

Enable Logging  

Choose Help > Enable Logging to record details of a session. The logs are sent to a set of text files. Restart the application for logging to begin. Choose Help > Reveal Logging File to see the log files.

Note: Logging has some negative effects on performance, so if you have enabled logging through this option, it will be disabled after 24 hrs.


Project panel folders open automatically on drag

There is a change in the behavior of folders when you drag items in the Project panel. When you pause over a folder during a drag operation in the Project panel, the folder opens automatically. You can then drop the items into the folder or any subfolders under it.

Changes to mask path drawing

There is a new option in the Preferences > Appearance dialog box:

Use Contrasting Color For Mask Path

When this option is checked, After Effects chooses a label color that is different from the colors where the mask point was first drawn. At the same time, After Effects will also avoid the color of the previous mask.  

Miscellaneous New and Updated Features

New features

  • The layer index number is now shown for choosing a target for motion tracking data. Click the Edit Target button in the Tracker panel to open this setting.
  • The Create Shapes From Vector Layer command works on multiple selected layers.
  • The Cycle Mask Colors preference is enabled by default.
  • The Viewer Quality preferences are set to More Accurate Except RAM Preview by default, instead of the Faster option.
  • Freezing the segmentation for the Roto Brush & Refine Matte effect operates on all spans independently of the work area, instead of only within the work area
  • Wireframes for cameras and lights are shown by default, even when these layers not selected
  • Indexed-color PNG files and grayscale PNG files with transparency can be imported
  • Photoshop Large Document (.psb) files can be imported.
  • CMYK JPEG files can be imported.
  • Dashes and gaps are now explicitly numbered (Dash 2, Gap 2, ...) when adding multiple dashes and gaps to a shape layer stroke. This makes it easier when referring to them with expressions.
  • The Brightness & Contrast effect has been improved and now matches the filter in Photoshop. You can still choose to use the legacy algorithm, which allows HDR results.
  • You can now open a dialog box for editing values for 3D Point Control effect. Context-click the 3D Point Control effect and choose Edit Value.

Updated features

  • In the Auto-Save preferences, Edit > Preferences > Auto Save option, you can now specify the location of the auto-saved files. You can save it either next to the current Project (default) or choose a location.
  • The correct name of the 3D renderer is shown for third-party renderers such as AtomKraft.
  • There is a new Center property for the Twist path operation in the shape layer.
  • The Undo operations preference has been removed from the Preferences menu. If you want to edit the number of Undo operations, you can do so in the preferences text file. The default number of Undo operations is now always set to 99.
  • If you are installing After Effects 12.1 for the first time, the preference Write XMP IDs To Files On Import under the Media & Disk Cache preferences category is off by default. If you are upgrading to After Effects 12.1, the preference is on by default. Uncheck the preference to turn it off.
  • Snapping now accounts for magnification (zoom) level and pixel aspect ratio (PAR) in the viewer.
  • The Luma Key effect and the Color Key effect has been moved to the Obsolete Effects category and have been superseded by other effects such as the Keylight effect.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy