Huomautus:

Adobe Museen ei enää lisätä uusia ominaisuuksia ja sen tuki päättyy 26. maaliskuuta 2020. Lisätietoja ja tukea on kohdassa Adobe Musen elinkaaren päättymissivu.

Tässä artikkelissa opit käsittelemään hyperlinkkejä Adobe Musessa. Hyperlinkeillä voit linkittää esimerkiksi ulkoisiin sivustoihin, ladattaviin tiedostoihin ja sähköpostiosoitteisiin. Ladattavat tiedostot voivat olla PDF-, DOC-, PPT- tai TXT-tiedostoja, rikasta mediasisältöä sisältäviä tiedostoja tai muuntyyppisiä tiedostoja, joita haluat jakaa kävijöillesi mutta joiden lisäämistä Adobe Musen käyttöliittymän kautta ei tällä hetkellä tueta. Voit luoda linkkejä sekä omaan Adobe Muse -palveluusi ladattuihin tiedostoihin että ulkopuolisissa sivustoissa oleviin tiedostoihin.

Video | Hyperlinkin luominen

Video | Hyperlinkin luominen
Adobe Press

Ankkurilinkkien lisääminen sivulle

Tässä osiossa opit yhdistämään valikkokohteita ankkurialueiden kahteen elementtiin ja lisäämään ankkurilinkkejä manuaaliseen valikkoon. Noudata seuraavia ohjeita:

  1. Valitse sivu napsauttamalla mitä tahansa kohtaa siitä (siten, että valintaosoittimessa näkyy sana Sivu). Napsauta sitten widget-valikkokohdetta (widgetsäilöä) kahdesti. Ensimmäinen napsautus valitsee koko manuaalisen valikkowidgetin, ja toinen napsautus valitsee valikkokohteen Valintaosoittimessa näkyy sana Valikkokomento.
  2. Hyperlinkit-valikkoa napsauttamalla näet täydellisen luettelon sivuston sivuista ja ankkurinimiöistä. Etsi Työpöytä-osiosta oikea sivu. Huomaa, että luomasi ankkurinimiöt näkyvät suoraan sen alapuolella. Valitse ankkurinimiö, jotta voit linkittää sen valikkokohteeseen.
Linkittäminen ankkureihin
Lisää Breakfast-ankkurilinkki Linkit-valikon avulla Breakfast-painikkeeseen

  1. Voit lisätä ankkurilinkkejä toistamalla vaihetta 2.
  2. Valitse Tiedosto > Sivuston ominaisuudet. Varmista, että Sivuasettelu-välilehdessä valintaruutu Käytä ankkurilinkkien Aktiivinen-tilaa on valittuna. Tämä valinta on oletusarvoisesti valittuna kaikille uusille sivustoille, mutta jos muokkaat vanhaa sivustoa, valintaruutu on ehkä valittava erikseen.
  3. Valitse Tiedosto > Esikatsele sivu selaimessa.

Kun napsautat linkkejä eri sivualueille, huomaa, että navigointivalikossa näkyy vastaava aktiivinen tila. Tämän ominaisuuden avulla vierailijat hahmottavat helposti, mitä osiota he ovat katselemassa. Sulje selain ja palaa Adobe Museen.

Kokeile myös siirtyä sivulla ylös- ja alaspäin ja seurata, kuinka sivun koodi tunnistaa kunkin ankkurinimiön sijainnin ja päivittää manuaalisen valikon Aktiivinen-tilaa, kun sivua liikutetaan eri alueiden kohdalle. Tämä tekniikka toimii sekä vaaka- että pystysuunnassa vieritettävillä sivuilla.

Huomautus: Sivun on oltava riittävän korkea tai leveä, jotta kullekin alueelle voidaan siirtyä ankkurinimiöiden avulla. Jos sivualueet ovat liian lähellä toisiaan ja kaikki sisältö mahtuu vierittämättä selainikkunaan, ankkurinimiöt eivät näytä siirtyvän seuraavalle alueelle.

  1. Sulje selain ja palaa Adobe Museen.

Seuraavassa osiossa opit lisäämään latauslinkkejä, jotta vierailijat voivat ladata erilaisia tiedostomuotoja, kuten PDF-, DOC-, MP3-, MOV- ja PSD-tiedostoja sekä korkeatarkkuuksisia JPEG-tiedostoja.

Vihje: jos teet toisten suunnittelijoiden kanssa yhteistyötä sivuprojektissa, voit myös linkittää suoraan .Muse-lähdekooditiedostoihin, jotta muut tiimin jäsenet voivat ladata niitä suoraan verkkosivustostasi.

Ankkurinimiöiden alueiden ja aktiivisten tilojen käyttäminen

Ankkurialueiden luominen verkkosivulle on helppo tapa eritellä visuaalisesti sivun eri osiot. Näihin osioihin voi kätevästi siirtyä käyttämällä ankkurilinkkejä, jotka on suunniteltu helpottamaan navigointia sivustolla.

Valmiissa suunnittelussa verkkosivulla olisi hyvä olla ankkurilinkkejä, joiden avulla vierailijat pystyvät siirtymään sivulla pystysuunnassa alueelle, jossa on linkkiä vastaava ruokalista. Kuvittele, että ankkurinimiöitä lisätessäsi ikään kuin kiinnität merkin johonkin kohtaan sivua. Kun vierailijat napsauttavat kyseisen ankkurin linkkiä, pitkillä sivuilla siirrytään suoraan siihen osioon, jossa merkki sijaitsee.

  1. Lataa ankkurityökalu napsauttamalla Ankkuri-painiketta yläosan navigointialueella.
Napsauta Ankkuri-painiketta
Lataa sijoitusase ensimmäistä ankkuria varten napsauttamalla Ankkuri-painiketta työtilan yläosassa.

  1. Napsauta kerran sivun yläreunaa, aluetta ylätunnistealueen ylimmän tason sivustonavigoinnin yläpuolella. Voit halutessasi siirtää ylätunnistesuorakulmion väliaikaisesti pois tieltä. Jos liikutat ylätunnisteen sisältöä, muista siirtää se takaisin paikoilleen myöhemmin.
  2. Kirjoita Nimeä ankkuri uudelleen -valintaikkunaan ankkurin nimi.
Kirjoita ankkurin nimi
Nimeä ankkuri aamiaislistalle, joka sijaitsee sivun yläosassa.

  1. Määritä ankkurialueet toistamalla vaiheet 1–3 ja lisää ankkurilinkkejä.

Huomautus:

Välin suuruus (pikseleinä) sivun yläosassa sijaitsevan ensimmäisen ankkurin ja linkitetyn sisällön (manuaalinen valikkowidget, jonka lisäät seuraavassa osiossa) ensimmäisen instanssin välillä määrittää "aktiivisen alueen", joka saa aktiivisen tilan muuttumaan kullakin alueella. Jos esimerkiksi ensimmäinen ankkuri sijoitetaan aivan sivun yläreunaan ja valikkowidget sijoitetaan 120 pikseliä sen alapuolelle, valikkokohteiden aktiivinen tila tätä seuraavilla alueilla päivittyy niin ikään 120 pikseliä ennen ruokalistaa, kun vierailija vierittää sivua alaspäin.

Kun olet lisännyt manuaalisen valikkowidgetin seuraavassa vaiheessa, linkität painikkeet ankkurinimiöihin. Tämä luo navigoinnin, jonka avulla vierailijat voivat siirtyä haluamansa ruokalistan kohdalle.

Linkittäminen ladattaviin tiedostoihin

  1. Kun muokkaat sivua Muoto-näkymässä, luo tekstityökalulla uusi tekstikehys lähelle aamiaislistan tekstikehyksen oikeaa yläkulmaa. Kirjoita tähän Download Menu.
  2. Kun tekstikehys on yhä valittuna, määritä seuraavat asetukset Teksti-paneelissa:
    • Web-kirjasin: Kaushan Script (tai mikä tahansa valitsemasi käsialakirjasin)
    • Kirjasinkoko: 14
    • Väri: #EEE5C4 (osassa 3 annoit tälle värimallille nimen cream-menu)
    • Rivivälistys: 57 %
    • Tasaus: Keskitetty
  3. Määritä Täyttö-valikossa täyttöväriksi Ei mitään. Napsauta kansiota Kuva-osion vieressä ja määritä taustakuva valitsemalla näytetiedostojen kansiosta tiedosto nimeltä download-bg.png. Varmista, että Sovitus-valikon asetuksena on Alkuperäinen koko ja Sijainti on keskitetty.
  1. Sulje Täyttö-valikko napsauttamalla sen ulkopuolella. Muuta tarvittaessa tekstikehyksen kokoa valintatyökalulla ja sijoita se siten, että se on keskitetty aamiaislistan tekstikehyksen oikeaan yläkulmaan.
  1. Kun tekstikehys on edelleen valittuna, valitse hallintapaneelin Linkit-valikosta Linkitä tiedostoon -vaihtoehto. Etsi ja valitse tiedosto näyttöön tulevassa Tuo-valintaikkunassa ja valitse Avaa

Huomautus: Kun valitset tiedoston Linkitä tiedostoon -toiminnolla, tiedostosta tulee yksi sivustokohteista, jotka ladataan sivuston julkaisemisen yhteydessä tai sisällytetään sivuston tiedostoihin sivuston viennin yhteydessä. Parhaan käytännön mukaista on kopioida sivuston paikalliseen kansioon kaikki tiedostot, joihin haluat luoda linkkejä, kuten myös kaikki sivustossa käytettävät kuvatiedostot.

Linkki PDF-tiedostoon on nyt lisätty. Jos nyt katsot Kohteet-paneelia, huomaat, että tiedosto on sivustokohteiden luettelossa.

  1. Valitse tekstikehys valintatyökalulla. Kopioi Download Menu -tekstikehys ja liitä se siten, että se on lounaslistan oikean yläkulman päällä. Toista tämä vaihe vielä kaksi kertaa ja luo kopiot, jotka on sijoitettu päivällis- ja jälkiruokalistojen oikeiden yläkulmien päälle.

Todellisessa projektissa voisit lisätä linkit neljään erilliseen ruokalistatiedostoon, ja vierailijat voisivat ladata neljä erilaista PDF-tiedostoa katsottavaksi ja tulostettavaksi. Tässä opastusohjelmassa kunkin sivualueen Lataa-painike toimii kuitenkin linkkinä samaan PDF-tiedostoon.

  1. Valitse Tiedosto > Esikatsele sivu selaimessa. Siirry vastaavaan sivulla olevaan ruokalistaan napsauttamalla jotakin vaakasuuntaisen valikon valikkokohteista. Huomaa, että kun vierität sivua alaspäin päivällis- ja jälkiruokalistojen kohdalle, ylätunniste näkyy sivun muun sisällön päällä. Tämä johtuu siitä, että food-sivu käyttää Foreground-sivupohjaa, ja kyseisen sivun ylätunnistesisältö on siirretty etualalle.
  2. Napsauta Download Menu -linkkiä, ja PDF-tiedosto latautuu tietokoneellesi.

Toiminta riippuu käyttämästäsi selaimesta sekä selaimen asetuksista. Tietyt selaimet näyttävät PDF-tiedoston selainikkunassa, kun taas toiset yksinkertaisesti lataavat PDF-tiedoston työpöydällesi, josta voit avata sen Acrobat Pro- tai Acrobat Reader -ohjelmalla.

Linkittäminen sähköpostiosoitteisiin

Jos olet jo käyttänyt Adobe Musea jonkin aikaa, olet saattanut huomata, että Linkit-valikko on hiljattain järjestetty osioihin, jotka helpottavat sivunimien ja linkitettävien kohteiden löytämistä. Tässä osiossa perehdyt siihen, kuinka Linkit-valikko on jäsennetty ja kuinka voit suodattaa valikkolistan kohteita. Opit myös lisäämään linkkejä sähköpostiosoitteisiin.

  1. Tuo koko luettelo näkyviin napsauttamalla Linkit-valikon alaspäin osoittavaa nuolta.
Linkittäminen sähköpostiosoitteisiin
Linkit-valikon lista näkyy laajennetussa näkymässä.

  1. Linkit-valikko on jäsennetty osioihin. Viimeksi käytetyt linkit -osiossa näkyvät kaikki sivustoon lisätyt ulkoisten verkkosivustojen linkit. Voit lisätä ulkoisten verkkosivustojen linkkejä kirjoittamalla minkä tahansa URL-osoitteen suoraan Linkit-kenttään.
  2. Työpöytä-osiossa näkyvät nykyisen sivuston sisältämät sivut. Huomaa, että food-sivulle lisäämäsi ankkurinimiöt listataan aakkosjärjestyksessä food-sivun alla. Tämä tarkoittaa, että voit luoda samannimisiä ankkureita sivuston eri sivuille ja siitä huolimatta tunnistaa ne helposti, kun määrität linkkejä. Tämä esimerkkisivusto sisältää vain Työpöytä-sivuasettelun, mutta jos sivusto sisältää vaihtoehtoisia sivuasetteluja puhelimille tai tableteille, vastaava sivujoukko näkyy kyseisten osioiden yhteydessä.
  3. Lopussa näkyvä Tiedostot-osio sisältää Linkitä tiedostoon -toiminnon sekä kaikki nykyiseen sivustoon lisätyt ladattavat tiedostot. Koska olet hiljattain lisännyt linkin tiedostoon KatiesCafeMenu.pdf, tiedoston nimi näkyy tässä osiossa. Tämän ansiosta yhteisesti jaettuun kohteeseen on helppo luoda linkkejä sivuston eri sivuilta.
  4. Jos haluat lisätä sähköpostilinkin (joka napsautettaessa avaa vierailijan sähköpostiohjelman ja uuden viestin, jonka Vastaanottaja-kentässä on valmiiksi oikea sähköpostiosoite), syötä Linkit-valikkokenttään sähköpostiosoite etuliitteellä "mailto:" seuraavaan tapaan:

    mailto:sahkoposti@osoite.com

  5. Toisinaan Linkit-valikon kohdelistasta voi muodostua varsin pitkä ja vaikeasti selattava, jos kyse on suuresta verkkosivustosta. Jos etsit tiettyä sivua, ankkuria, tiedostoa tai ulkoista URL-linkkiä, syötä linkin ensimmäiset kirjaimet Linkit-valikon kenttään. Tämä näyttää hakua vastaavat tulokset. Tällä tavoin voit nopeasti suodattaa listasta ne kohteet, jotka haluat linkittää.

Ulkoisten sivustojen linkkien lisääminen

Nyt, kun yhteisöpalvelujen painikkeet ovat paikoillaan, voit lisätä ulkoiset linkit näihin sivustoihin.

  1. Valitse Facebook-kuvake ja kirjoita (tai kopioi/liitä) Linkit-valikon kenttään seuraava linkki Katie's Cafen Facebook-sivulle: http://www.facebook.com/KatiesCafeSF
  2. Valitse Google+-kuvake ja kirjoita (tai kopioi/liitä) seuraava linkki Katie's Cafen Google+-sivulle: https://plus.google.com/u/1/117800212967830061444/posts
  3. Valitse Twitter-kuvake ja kirjoita (tai kopioi/liitä) seuraava linkki Katie's Cafen Twitter-sivulle: http://twitter.com/katiescafesf
  4. Valitse Facebook-kuvake napsauttamalla sitä uudelleen. Napsauta sinistä alleviivattua sanaa "Linkit", joka sijaitsee Linkit-valikon vasemmalla puolella. Valitse esiin tulevassa valintaikkunassa Avaa linkki uuteen ikkunaan tai välilehteen -valintaruutu.
  5. Toistamalla vaihetta 4 voit määrittää myös Google+- ja Twitter-linkit avautumaan uuteen selainikkunaan.

Tämä on web-suunnittelussa yleinen käytäntö – saman sivuston sivuille ohjaavat linkit avautuvat samaan selainikkunaan (mikä tapahtuu Adobe Musessa oletuksena), ja ulkoisten sivustojen linkit avautuvat uuteen ikkunaan tai välilehteen.

Tiedoston URL-osoitteen selvittäminen valmisteltaessa linkin lisäämistä

Linkin valmistelu Adobe Muse -sivustoon lisäämistä varten edellyttää, että avaat palvelimeen ladatun julkisen tiedoston selaimella. Noudata seuraavia ohjeita.

  1. Käynnistä haluamasi selain.
  2. Siirry omaan sivustoosi tai ulkopuoliseen sivustoon, joka sisältää ladatun alitiedoston. Voit käyttää hakukonetta, kuten Googlea, tai kirjoittaa sivuston URL-osoitteen suoraan selaimen osoiteriville.
Selaimen osoiterivi
Voit kirjoittaa sivuston osoitteen suoraan selaimen osoiteriville.

  1. Kun olet avannut halutun sivuston etusivun, selaa haluttu alitiedosto esiin sivuston navigoinnin kautta tai kirjoita koko URL-osoite selaimen osoiteriville. Tämän vaiheen jälkeen selain näyttää, toistaa tai lataa haluamasi tiedoston.
  2. Kun olet varma siitä, että olet kirjoittanut ladatun tiedoston URL-osoitteen oikein, valitse selaimen osoiterivin sisältö ja valitse sitten Muokkaa > Kopioi. Voit käyttää myös pikanäppäimiä komento+C (Mac) tai Ctrl+C (Windows).
Kopioi osoite selaimen osoiteriviltä
Kopioi URL-osoite selaimen osoiteriviltä

Tässä vaiheessa alitiedoston URL-osoite on kopioitu leikepöydälle. Älä kopioi leikepöydälle muita kohteita, ennen kuin olet liittänyt alitiedoston URL-osoitteen Hyperlinkki-kenttään seuraavassa osiossa kuvatun mukaisesti.

Linkittäminen ulkoiseen tiedostoon

Kun olet onnistuneesti ladannut alitiedoston palvelimeen, käyttänyt sitä selaimella ja kopioinut tiedoston URL-osoitteen, viimeinen vaihe on linkin lisääminen Adobe Muse -sivustossa olevaan sivuun. Noudata seuraavia ohjeita:

  1. Käynnistä Adobe Muse. Avaa sivu Muoto-näkymässä kaksoisnapsauttamalla sen miniatyyriä.
  2. Valitse teksti, sijoitettu kuva tai suorakaide, jonka haluat toimivan painikkeena, josta kävijät voivat ladata alitiedoston tai käyttää sitä.
  3. Kun teksti tai sivun elementti on valittuna, napsauta avattavaa Hyperlinkki-kenttäluetteloa ja liitä aiemmin kopioimasi alitiedoston URL-osoite (absoluuttinen polku).

Jos haluat määrittää linkin avautumaan uuteen selainikkunaan, napsauta Hyperlinkki-ikkunan vasemmalla puolella olevaa Hyperlinkki-tunnistetta. Valitse avautuvassa valintaikkunassa valintaruutu Avaa linkki uuteen ikkunaan tai välilehteen seuraavan kuvan mukaisesti.

Hyperlinkkiasetukset
Valitse "Avaa linkki uuteen ikkunaan tai välilehteen".

Tallenna sivu ja julkaise sivuston muutokset.

Avaa sivu selaimessa. Napsauta linkkitekstiä tai painiketta ja varmista, että linkki toimii halutulla tavalla.

Huomautus:

Voit kokeilla avata sivun useissa eri selaimissa, kuten Chromessa, Safarissa ja Firefoxissa, ja vahvistaa, että eri selaimet toimivat oikein, kun yrität avata alitiedoston napsauttamalla julkaistun sivuston linkkiä.

Saat lisää vinkkejä Adobe Musen käyttämiseen tutustumalla Adobe Musen Ohje ja opastusohjelmat -sivuun tai Adobe Musen Tapahtumat-sivuun, jolla on käynnissä olevia tai tallennettuja verkkoseminaareja.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö