Руководство пользователя Отмена

Dynamic Link и After Effects

  1. Руководство пользователя After Effects
  2. Выпуски бета-версии
    1. Обзор программы бета-тестирования
    2. Домашняя страница бета-версии After Effects
    3. Функции бета-версии
      1. Панель «Свойства» (Бета-версия)
      2. Импорт 3D-моделей (бета-версия)
      3. Управление цветом OpenColorIO и ACES (бета-версия)
  3. Начало работы
    1. Начало работы с After Effects
    2. Новые возможности After Effects 
    3. Сведения о выпуске | After Effects
    4. Системные требования для After Effects
    5. Сочетания клавиш в After Effects
    6. Поддерживаемые форматы файлов | After Effects
    7. Рекомендации по аппаратному обеспечению
    8. After Effects для компьютеров с процессорами Apple
    9. Планирование и настройка
  4. Рабочие среды
    1. Общие элементы пользовательского интерфейса
    2. Знакомство с интерфейсом After Effects
    3. Рабочие процессы
    4. Рабочие среды, панели управления, программы просмотра
  5. Проекты и композиции
    1. Проекты
    2. Основы создания композиции
    3. Предварительная композиция, вложение и предварительный рендеринг
    4. Просмотр подробных сведений о производительности с помощью инструмента «Профайлер композиций»
    5. Модуль рендеринга композиций CINEMA 4D
  6. Импорт видеоряда
    1. Подготовка и импорт неподвижных изображений
    2. Импорт из After Effects и Adobe Premiere Pro
    3. Импорт и интерпретация видео и аудио
    4. Подготовка и импорт файлов 3D-изображений
    5. Импорт и интерпретация элементов видеоряда
    6. Работа с элементами видеоряда
    7. Определение точек редактирования с помощью функции «Определение изменения сцен»
    8. Метаданные XMP
  7. Текст и графические элементы
    1. Текст
      1. Форматирование символов и панель символов
      2. Эффекты текста
      3. Создание и редактирование текстовых слоев
      4. Форматирование абзацев и панель «Абзац»
      5. Экструзия слоев текста и слоев-фигур
      6. Анимация текста
      7. Примеры и ресурсы для текстовой анимации
      8. Шаблоны динамического текста
    2. Анимационный дизайн
      1. Работа с шаблонами анимационного дизайна в After Effects
      2. Использование выражений для создания раскрывающихся списков в шаблонах анимационного дизайна
      3. Работа с основными свойствами для создания шаблонов анимационного дизайна
      4. Замена изображений и видео в шаблонах анимационного дизайна и основных свойствах
  8. Рисование, заливка цветом и контуры
    1. Обзор слоев-фигур, контуров и векторных изображений
    2. Инструменты рисования: «Кисть», «Штамп» и «Ластик»
    3. Сглаживание обводки фигуры
    4. Атрибуты фигур, операции заливки цветом и операции с контурами для слоев-фигур
    5. Использование эффекта фигуры «Cмещение контура» для изменения фигур
    6. Создание фигур
    7. Создание масок
    8. Удаление объектов из видеоматериалов с помощью панели «Заливка с учетом содержимого»
    9. Инструменты «Кисть для ротоскопии» и «Уточнить подложку»
  9. Слои, маркеры и камера
    1. Выделение и упорядочивание слоев
    2. Режимы наложения и стили слоев
    3. 3D-слои
    4. Свойства слоя
    5. Создание слоев
    6. Управление слоями
    7. Маркеры слоя и маркеры композиции
    8. Камеры, освещение и точки обзора
  10. Анимация, ключевые кадры, отслеживание движения и прозрачное наложение
    1. Анимация
      1. Основы анимации
      2. Анимация с помощью инструментов «Марионетка»
      3. Управление и анимация контуров фигур и масок
      4. Анимация фигур Sketch и Capture с помощью After Effects
      5. Инструменты анимации
      6. Работа с анимацией на основе данных
    2. Ключевой кадр
      1. Интерполяция ключевого кадра
      2. Установка, выбор и удаление ключевых кадров
      3. Редактирование, перемещение и копирование ключевых кадров
    3. Отслеживание движения
      1. Отслеживание и стабилизация движения
      2. Отслеживание лиц
      3. Отслеживание маски
      4. Ссылка на маску
      5. Скорость
      6. Растягивание по времени и перераспределение времени
      7. Тайм-код и единицы отображения времени
    4. Прозрачное наложение
      1. Прозрачное наложение
      2. Эффекты прозрачного наложения
  11. Прозрачность и композиция
    1. Обзор композиции и прозрачности и соответствующие ресурсы
    2. Альфа-каналы и маски
    3. Подложки дорожек и перемещающиеся подложки
  12. Корректирование цвета
    1. Основы работы с цветом
    2. Управление цветом
    3. Эффекты цветокоррекции
  13. Эффекты и стили анимации
    1. Обзор эффектов и стилей анимации
    2. Список эффектов
    3. Эффекты имитации
    4. Эффекты стилизации
    5. Аудиоэффекты
    6. Эффекты искажения
    7. Эффекты перспективы
    8. Эффекты канала
    9. Эффекты создания
    10. Эффекты перехода
    11. Эффект «Устранение эффекта плавающего затвора»
    12. Эффекты «Размытие» и «Резкость»
    13. Эффекты 3D-канала
    14. Программные эффекты
    15. Эффекты подложки
    16. Эффекты «Шум» и «Зернистость»
    17. Эффект «Увеличение с сохранением уровня детализации»
    18. Устаревшие эффекты
  14. Выражения и автоматизация
    1. Выражение
      1. Основы работы с выражениями
      2. Понимание языка выражений
      3. Использование элементов управления выражениями
      4. Различия в синтаксисе между движками выражений JavaScript и Legacy ExtendScript
      5. Управление выражениями
      6. Ошибки выражения
      7. Использование редактора выражений
      8. Использование выражений для изменения свойств текста и доступа к ним
      9. Справочник языка выражений
      10. Примеры выражений
    2. Автоматизация
      1. Автоматизация
      2. Сценарии
  15. Видео с погружением, VR и 3D
    1. Создание сред VR в After Effects
    2. Применение видеоэффектов с эффектом погружения
    3. Инструменты составления композиций для видеоизображений VR/360
    4. Отслеживание движений камеры в трехмерном пространстве
    5. Пространство для работы с трехмерными объектами
    6. Инструменты 3D-преобразования
    7. Дополнительные возможности 3D-анимации
    8. Предварительный просмотр изменений в 3D-дизайнах в режиме реального времени с помощью модуля Mercury 3D
    9. Добавление гибкого дизайна в графику 
  16. Виды и предварительный просмотр
    1. Предпросмотр
    2. Предпросмотр видео с помощью Mercury Transmit
    3. Изменение и использование представлений
  17. Рендеринг и экспорт
    1. Основы рендеринга и экспорта
    2. Кодирование H.264 в After Effects
    3. Экспорт проекта After Effects как проекта Adobe Premiere Pro
    4. Преобразование фильмов
    5. Многокадровый рендеринг
    6. Автоматический рендеринг и рендеринг по сети
    7. Рендеринг и экспорт неподвижных изображений и наборов неподвижных изображений
    8. Использование кодека GoPro CineForm в After Effects
  18. Работа с другими приложениями
    1. Dynamic Link и After Effects
    2. Работа с After Effects и другими приложениями
    3. Синхронизация настроек в After Effects
    4. Библиотеки Creative Cloud Libraries в After Effects
    5. Подключаемые модули
    6. Cinema 4D и Cineware
  19. Совместная работа: Frame.io и Team Projects
    1. Совместная работа в Premiere Pro и After Effects
    2. Frame.io
      1. Установка и активация Frame.io
      2. Использование Frame.io с Premiere Pro и After Effects
      3. Часто задаваемые вопросы
    3. Team Projects
      1. Начало работы с Team Projects
      2. Создание Team Project
      3. Совместная работа с помощью Team Projects
  20. Память, хранилище, производительность
    1. Память и хранилище
    2. Как After Effects справляется с проблемами нехватки памяти при предварительном просмотре    
    3. Повышение производительности
    4. Установки
    5. Требования к графическому процессору и драйверу графического процессора для After Effects

О динамических ссылках Dynamic Link

Ранее для обмена медиаресурсами между постпроизводственными приложениями необходимо было преобразовать и экспортировать работу из одного приложения перед импортом в другое. Этот процесс был неэффективен и занимал много времени. Если пользователю требовалось внести изменения в исходный ресурс, данный ресурс необходимо было повторно преобразовать и экспортировать. Многочисленные преобразованные и экспортированные версии одного ресурса занимают дисковое пространство и могут осложнить управление файлами.

Функция Dynamic Link предлагает альтернативу данному технологическому процессу. С ее помощью можно создавать динамические ссылки между приложениями After Effects и Adobe Premiere Pro. Создать динамическую ссылку так же просто, как импортировать любой другой тип ресурсов. Ресурсы с динамическими ссылками выделяются уникальными значками и цветами маркировки, чтобы их было проще идентифицировать. Динамические ссылки сохраняются в проектах, генерированных данными приложениями.

Создание и связь композиций After Effects с помощью Dynamic Link

Можно создавать новые композиции в After Effects и динамически связывать их с Adobe Premiere Pro. Также можно динамически связывать с Adobe Premiere Pro уже существующие композиции After Effects.

Создание композиции из клипов в Adobe Premiere Pro

Выбранные клипы в Adobe Premiere Pro можно заменить динамически связанной композицией After Effects, созданной на основе этих клипов. Новая композиция наследует настройки эпизода из Adobe Premiere Pro.

  1. Откройте приложение Premiere Pro и выберите клипы, которые требуется заменить.

  2. Щелкните выделенные клипы правой кнопкой мыши.
  3. Выберите пункт «Заменить композицией After Effects».

    Приложение After Effects откроется (если оно еще не открыто), и будет создана новая связанная композиция.

Создание динамически связанной композиции в Adobe Premiere Pro

При создании новой динамически связанной композиции в Adobe Premiere Pro запустится After Effects. Затем After Effects создает проект и композицию с такими же параметрами размера, пропорций пикселя, частоты кадров и частоты дискретизации звука, как у исходного проекта. (Если приложение After Effects уже запущено, новая композиция создается в текущем проекте.) Имя новой композиции имеет вид имени проекта Adobe Premiere Pro, за которым следует обозначение Linked Comp [x].

  1. В Adobe Premiere Pro выберите Файл > Adobe Dynamic Link > Создать композицию After Effects. В версии Premiere Pro 2014 г. можно импортировать композиции с помощью браузера медиафайлов. Дополнительные сведения см. в следующих разделах Premiere Pro:

  2. Если откроется диалоговое окно After Effects «Сохранить как», введите имя и расположение проекта After Effects и нажмите кнопку «Сохранить».

    Примечание.

    При создании динамически связанной композиции After Effects для нее задается продолжительность в 30 секунд. Для изменения продолжительности композиции выберите в After Effects данную композицию и пункты «Композиция» > «Настройки композиции». Перейдите на вкладку «Базовые» и задайте новое значение для параметра «Продолжительность».

Для получения оптимальных результатов настройки композиции (такие как размеры, пропорции пикселя и частота кадров) должны совпадать с настройками в Adobe Premiere Pro.

  1. Выполните одно из следующих действий.
    • В Adobe Premiere Pro выберите Файл > Adobe Dynamic Link > Импорт композиции After Effects. Выберите файл проекта After Effects (.aep), а затем одну или несколько композиций.

    • В Adobe Premiere Pro выберите файл проекта After Effects и нажмите Открыть. Затем выберите композицию в отображаемом диалоговом окне и нажмите кнопку ОК.

    • Перетащите одну или несколько композиций из панели «Проект» в After Effects на панель «Проект» в Adobe Premiere Pro.

    • Перетащите файл проекта After Effects в панель «Проекты» приложения Premiere Pro. Если файл проекта After Effects содержит несколько композиций, откроется диалоговое окно «Импорт композиции».

Примечание.

На одну композицию After Effects можно создать несколько ссылок в одном проекте Adobe Premiere Pro.

Изменение динамически связанной композиции в After Effects

Команда «Редактировать оригинал» позволять изменять в Adobe Premiere Pro привязанную композицию After Effects. Когда композиция откроется в After Effects, ее можно будет редактировать, не применяя команду «Редактировать оригинал» повторно.

  1. Выберите композицию After Effects в Adobe Premiere Pro либо связанный клип на таймлайне, а затем выберите «Правка» > «Редактировать оригинал».

  2. Измените композицию в приложении After Effects. Затем снова переключитесь на Adobe Premiere Pro для просмотра внесенных изменений.

Изменения, внесенные в After Effects, отобразятся в Adobe Premiere Pro. Adobe Premiere Pro не будет использовать файлы предпросмотра, преобразованные для данного клипа перед внесением изменений.

Примечание.

Имя композиции можно изменить в After Effects после создания динамической ссылки на нее в Adobe Premiere Pro. Adobe Premiere Pro не обновляет имя связанной композиции в панели «Проект». Однако при этом Adobe Premiere Pro сохраняет динамическую ссылку на данную композицию.

Удаление динамически связанных композиций или клипов

Из проекта Adobe Premiere Pro связанную композицию можно удалить в любой момент, даже если она используется в проекте.

Кроме того, связанные клипы можно удалить из эпизода или таймлайна Adobe Premiere Pro в любой момент.

  1. В приложении Adobe Premiere Pro выберите связанную композицию или клип и нажмите клавишу Удалить.

Создание связанного эпизода в Adobe Premiere Pro при помощи Dynamic Link

При создании эпизода Adobe Premiere Pro в приложении After Effects открывается приложение Adobe Premiere Pro. Затем Adobe Premiere Pro создает проект и эпизод с такими же параметрами размера, пропорций пикселя, частоты кадров и частоты дискретизации звука, как у исходного проекта. (Если приложение Adobe Premiere Pro уже запущено, оно создает эпизод в текущем проекте.)

  1. В After Effects выберите «Файл» > «Adobe Dynamic Link» > «Создать эпизод Premiere Pro».

Для достижения оптимальных результатов настройки эпизода и проекта в Adobe Premiere Pro (например, размер, пропорции пикселя и частоту кадров) необходимо задать в соответствии с настройками проекта After Effects.

Выполните одно из следующих действий.

  • В After Effects выберите «Файл» > «Adobe Dynamic Link» > «Импорт эпизода Premiere Pro». Выберите проект Adobe Premiere Pro, а затем один или несколько эпизодов.

  • Перетащите один или несколько эпизодов из панели «Проект» приложения Adobe Premiere Pro в панель «Проект» приложения After Effects.

Производительность Dynamic Link

Клип может быть связан со сложной исходной композицией. Действия, выполняемые по отношению к исходной композиции, увеличивают время обработки в зависимости от их сложности. After Effects применяет действия и готовит окончательные данные для Adobe Premiere Pro, используя глобальный кэш производительности и постоянный кэш диска. Эти компоненты позволяют повысить производительность After Effects путем использования кэшированных кадров, когда их запрашивает Premiere Pro.

Чтобы сократить задержку воспроизведения, выполните одно из предложенных ниже действий:

  • переведите связанную композицию в автономный режим;

  • отключите связанный клип, чтобы он временно перестал ссылаться на композицию;

  • Замените динамически связанную композицию выходным файлом рендеринга с помощью функции «Рендеринг и замена» в Premiere Pro (Клип > Рендеринг и замена).

При регулярной работе со сложными исходными композициями рекомендуется увеличить объем ОЗУ или использовать более мощный процессор.

Экспорт в Adobe Media Encoder

Чтобы закодировать композиции After Effects, добавьте элемент в очередь кодирования Adobe Media Encoder, затем выберите шаблон настроек кодирования или задайте собственные настройки рендеринга. В After Effects можно добавить композицию в очередь Media Encoder одним из следующих способов:

  • Файл > Экспорт > Добавить в очередь Media Encoder
  • Композиция > Добавить в очередь Media Encoder

При добавлении одной композиции или проекта в очередь Adobe Media Encoder, After Effects запускает Adobe Media Encoder с композициями, перечисленными в очереди.

Процесс кодирования объясняется в следующих статьях:

Логотип Adobe

Вход в учетную запись