Säkerhetsuppdateringar för Adobe Flash Player

Releasedatum: 13 maj 2014

Sårbarhets-ID: APSB14-14

Prioritet: Se tabellen nedan

CVE-nummer: CVE-2014-0510, CVE-2014-0516, CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520

Plattform: Alla plattformar

Sammanfattning

Adobe har släppt säkerhetsuppdateringar för Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh och för Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux. Dessa uppdateringar åtgärdar sårbarheter som kan ge en angripare möjlighet att ta kontroll över den drabbade datorn. Adobe rekommenderar alla användare att uppdatera till senaste versionen:

  • Användare av Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh bör uppdatera till Adobe Flash Player 13.0.0.214.
  • Användare av Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux bör uppdatera till Adobe Flash Player 11.2.202.359.
  • Adobe Flash Player 13.0.0.206 som installerats med Google Chrome uppdateras automatiskt till den senaste Google Chrome-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows, Macintosh och Linux.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 10 uppdateras automatiskt till den senaste Internet Explorer 10-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.0.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 11 uppdateras automatiskt till den senaste Internet Explorer 11-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.1.
  • Användare av Adobe AIR 13.0.0.83 SDK och tidigare versioner bör uppdatera till Adobe AIR 13.0.0.111 SDK.
  • Användare av Adobe AIR 13.0.0.83 SDK & Compiler och tidigare versioner bör uppdatera till Adobe AIR 13.0.0.111 SDK & Compiler.

Berörda programversioner

  • Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh
  • Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux
  • Adobe AIR 13.0.0.83 SDK och tidigare versioner
  • Adobe AIR 13.0.0.83 SDK & Compiler och tidigare versioner

Om du vill kontrollera vilken version av Adobe Flash Player du har går du till sidan Om Flash Player eller högerklickar på material som körs i Flash Player och väljer ”Om Adobe (eller Macromedia) Flash Player”. Om du har flera webbläsare måste du kontrollera var och en av dem.

Följ instruktionerna i Adobe AIRTechNote för att kontrollera vilken version av Adobe AIR du har.

Lösning

Adobe rekommenderar alla användare att uppdatera sina programvaruinstallationer genom att följa instruktionerna nedan:

  • Adobe rekommenderar alla som använder Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh att uppdatera till den senaste versionen, 13.0.0.214, genom att ladda ned denna från Adobe Flash Player Hämtningscenter eller via produktens uppdateringsfunktion när meddelande om detta visas.
  • Adobe rekommenderar användare som har Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux att uppdatera till Adobe Flash Player 11.2.202.359 som kan hämtas från Adobe Flash Player Download Center.
  • Adobe Flash Player 13.0.0.206 som installerats med Google Chrome uppdateras automatiskt till den senaste Google Chrome-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows, Macintosh och Linux.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 10 uppdateras automatiskt till den senaste Internet Explorer 10-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.0.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 11 uppdateras automatiskt till den senaste Internet Explorer 11-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.1.
  • Användare av Adobe AIR 13.0.0.83 SDK bör uppdatera till Adobe AIR 13.0.0.111 SDK.
  • Användare av Adobe AIR 13.0.0.83 SDK & Compiler och tidigare versioner bör uppdatera till Adobe AIR 13.0.0.111 SDK & Compiler.

* Från 13 maj 2014 ersätter Adobe Flash Player 13 för Mac och Windows version 11.7 som den version som erbjuds med utökad support. Adobe rekommenderar alla användare att uppgradera till version 13 för att fortsätta få säkerhetsuppdateringar.  Ytterligare information finns i denna bloggpost. http://blogs.adobe.com/flashplayer/2014/03/upcoming-changes-to-flash-players-extended-support-release.html

Prioritet och allvarlighetsgrad

Adobe klassar dessa uppdateringar med följande prioritetsklassificeringar och rekommenderar användare att uppdatera till den senaste versionen:

Produkt Uppdaterad version Plattform Prioritet
Adobe Flash Player 13.0.0.214
Windows och Macintosh
1
  13.0.0.214 Internet Explorer 10 för Windows 8.0 1
  13.0.0.214
Internet Explorer 11 för Windows 8.1 1
  13.0.0.214
Chrome för Windows, Macintosh och Linux 1
  11.2.202.359 Linux 3
Adobe AIR SDK och Compiler 13.0.0.111 Windows och Macintosh 3
Adobe AIR SDK 13.0.0.111 Windows och Macintosh 3

Dessa uppdateringar åtgärdar en kritisk sårbarhet i programmet.

Detaljer

Adobe har släppt säkerhetsuppdateringar för Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh och för Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux. Dessa uppdateringar åtgärdar sårbarheter som kan ge en angripare möjlighet att ta kontroll över den drabbade datorn. Adobe rekommenderar alla användare att uppdatera till senaste versionen:

  • Användare av Adobe Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh bör uppdatera till Adobe Flash Player 13.0.0.214
  • Användare av Adobe Flash Player 11.2.202.356 och tidigare versioner för Linux bör uppdatera till Adobe Flash Player 11.2.202.359.
  • Adobe Flash Player 13.0.0.206 som installerats med Google Chrome uppdateras automatiskt till den senaste Google Chrome-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows, Macintosh och Linux.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 10 uppdateras automatiskt till den senaste Internet Explorer 10-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.0.
  • Adobe Flash Player 13.0.0.206 som installerats med Internet Explorer 11 uppdateras automatiskt till den senaste Internet Explorer 11-versionen, som kommer att innehålla Adobe Flash Player 13.0.0.214 för Windows 8.1.
  • Användare av Adobe AIR 13.0.0.83 SDK och tidigare versioner bör uppdatera till Adobe AIR 13.0.0.111 SDK.
  • Användare av Adobe AIR 13.0.0.83 SDK & Compiler och tidigare versioner bör uppdatera till Adobe AIR 13.0.0.111 SDK & Compiler.

Uppdateringarna åtgärdar ett use-after-free-problem som kan leda till exekvering av skadlig kod (CVE-2014-0510).

Uppdateringarna åtgärdar en sårbarhet som kan användas för att ta sig förbi samma-ursprung-policyn (CVE-2014-0516).

Uppdateringarna åtgärdar ett antal säkerhetsluckor (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520).

Berörda programvaror     Rekommenderad uppdatering Tillgänglighet
Flash Player 13.0.0.206 och tidigare versioner för Windows och Macintosh   13.0.0.214 Flash Player Download Center
Flash Player 13.0.0.206 och tidigare versioner (nätverksdistribution)   13.0.0.214
Flash Player – licensiering
Flash Player 11.2.202.356 och tidigare för Linux   11.2.202.359 Flash Player Download Center
Flash Player 13.0.0.206 och tidigare versioner för Chrome (Windows, Macintosh och Linux)   13.0.0.214
Google Chrome Releases
Flash Player 13.0.0.206 och tidigare versioner för Internet Explorer 10 för Windows 8.0   13.0.0.214
Microsoft Security Advisory
Flash Player 13.0.0.206 och tidigare versioner för Internet Explorer 11 för Windows 8.1   13.0.0.214
Microsoft Security Advisory
AIR 13.0.0.83 SDK & Compiler   13.0.0.111 AIR SDK Download
AIR 13.0.0.83 SDK   13.0.0.111 AIR SDK Download

Tack

Adobe tackar följande personer för att de har rapporterat problemen och för att de samarbetar med oss i säkerhetsfrågor:

  • Keen Team och Team 509 för arbetet med HP:s Zero Day Initiative (CVE-2014-0510)
  • Masato Kinugawa (CVE-2014-0516)
  • James Forshaw på Contextis (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)