Gegevensgestuurde afbeeldingen maken

Laatst bijgewerkt op 29 okt. 2026

Gebruik variabelen en gegevenssets om meerdere versies van een sjabloon te genereren met verschillende tekst en afbeeldingen.

Met datagestuurde graphics kun je meerdere afbeeldingsvariaties maken vanuit één sjabloon door te bepalen welke elementen wijzigen en vervangende content aan te leveren via gegevenssets.

Deze workflow is van toepassing wanneer je meerdere versies van een ontwerp moet genereren met variërende tekst, afbeeldingen of zichtbaarheid van lagen, zoals webbanners voor verschillende producten, gepersonaliseerde certificeringen of gelokaliseerd marketingmateriaal.Je template moet afzonderlijke lagen gebruiken voor elk element dat je wilt laten variëren. Zie voor het importeren van datasets uit externe tekstbestanden het gerelateerde artikel over dataset-Import.

Photoshop ondersteunt drie typen Variabelen waarmee verschillende aspecten van je template worden geregeld. Zichtbaarheidsvariabelen bepalen of de content van een laag zichtbaar is. Met variabelen voor Tekstvervanging vervang je tekenreeksen in tekstlagen.Met variabelen voor Pixelvervanging vervang je laagpixels door content uit afbeeldingsbestanden. Je kunt meerdere typen variabelen toepassen op één sjabloon en meerdere lagen aan dezelfde variabele koppelen voor gecoördineerde wijzigingen.

Variabelen definiëren voor template-elementen

Selecteer Afbeelding > Variabelen > Definiëren.

Kies in het menu Laag de laag met content die je wilt laten variëren.

Selecteer een of meer typen variabelen: Zichtbaarheid, Tekstvervanging of Pixelvervanging.

Voer in het veld Naam een naam in met letters, onderstrepingstekens, dubbele punten, punten of koppeltekens, zonder spaties.

Kies voor variabelen voor Pixelvervanging een schaalmethode: Passend maken, Vullen, Ongewijzigd of Aanpassen.

Selecteer een uitlijningspositie en schakel Begrenzen tot omsluitend kader in.

Herhaal dit voor extra lagen en selecteer vervolgens OK.

Lagen met variabelen krijgen in het dialoogvenster een sterretje naast hun naam.Als je de naam van een variabele wilt wijzigen, ga je terug naar Afbeelding > Variabelen > Definiëren, selecteer je de laag en voer je in het veld Naam een nieuwe naam in. Als je meerdere lagen aan dezelfde variabele wilt koppelen, kies je bij het definiëren van variabelen voor extra lagen een bestaande variabelenaam in het vervolgkeuzemenu Naam.

Gegevenssets maken en beheren

Selecteer Afbeelding > Variabelen > Datasets.

Selecteer het pictogram voor een nieuwe dataset om een dataset te maken op basis van de huidige waarden.

Kies een variabele in het menu Naam.

Bewerk de variabele gegevens:

  • Voor Zichtbaarheid-variabelen: Selecteer Zichtbaar of Onzichtbaar
  • Voor Pixelvervanging-variabelen: Selecteer Bestand en kies de vervangende afbeelding
  • Voor Tekstvervanging-variabelen: Voer tekst in bij het veld Waarde.

Herhaal dit voor elke variabele in de dataset.

Maak extra datasets voor elke ontwerpvariatie die je nodig hebt.

Selecteer OK wanneer u klaar bent.

Bekijk een voorvertoning van het effect van elke dataset op je ontwerp door naar Afbeelding > Dataset toepassen te gaan, een dataset te kiezen uit de lijst en Toepassen te selecteren. Je kunt ook het selectievakje Voorvertoning inschakelen in het dialoogvenster Datasets om wijzigingen te zien zonder het dialoogvenster te sluiten.

Gebruik de pijlpictogrammen in het dialoogvenster Datasets om tussen datasets te navigeren. Om een bestaande dataset te wijzigen, selecteer je deze in het menu Dataset en bewerk je de variabelewaarden. Om een dataset te verwijderen, selecteer je deze en kies je het verwijderpictogram.

Uitvoerbestanden genereren uit datasets

Selecteer Bestand > Exporteren > Datasets als bestanden.

Voer een basisnaam in voor de gegenereerde bestanden in het naamveld.

Selecteer Map en kies een doelmap.

Kies welke datasets je wilt exporteren uit de lijst.

Selecteer OK om de bestanden te genereren.

Photoshop maakt afzonderlijke PSD-bestanden voor elke dataset, waarbij je basisnaam wordt gecombineerd met de datasetnaam. Elk bestand bevat het sjabloon met de toegepaste waarden van de dataset.

Als je een dataset direct toepast op je sjabloon (Afbeelding > Dataset toepassen), wordt het originele document overschreven. Werk altijd met een kopie of exporteer datasets in plaats daarvan als bestanden.