Soluções para problemas comuns ao visualizar um PDF em um site.

Sintomas 

Sintomas comuns quando não for possível visualizar um PDF na Web:

  • Uma página em branco no navegador da Web
  • Um ícone X vermelho
  • Um indicador de link desfeito, como um quadrado vermelho, um triângulo azul ou um círculo azul
  • Erro: "O Adobe Acrobat/Reader que está sendo executado não pode ser usado para visualizar arquivos PDFs em um navegador da Web. É necessária a versão 8 ou 9 do Adobe Acrobat/Reader. Saia e tente novamente."

Para resolver alguns dos problemas mais comuns de exibição de PDF, siga as instruções abaixo nesta ordem: atualize o Reader ou o Acrobat, corrija problemas com o PDF, verifique as configurações do navegador, repare ou reinstale o Reader ou Acrobat.

Atualizar o Reader ou Acrobat

A Adobe lança atualizações de segurança gratuitas a cada três meses. Certifique-se de atualizar sua versão do Reader ou do Acrobat para a versão mais recente. As atualizações frequentemente incluem correções para problemas comuns. Baixe a atualização gratuita mais recente.

  1. Abra o Reader ou Acrobat.

  2. Escolha Ajuda > Verificar atualizações. 

    Acrobat 9 e versões anteriores: se uma nova atualização estiver disponível ela será automaticamente instalada.

    Acrobat X e XI: clique em Atualizar e clique em Instalar.

    Acrobat DC: Continue para a próxima etapa.

    Verificar por atualizações
  3. Quando a caixa de diálogo Updater aparecer, clique em Download.

    Atualizar o Acrobat
  4. Após a conclusão do download, clique no ícone de instalação do Acrobat. Na janela do Acrobat Updater, clique em Instalar.

    A atualização está pronta
  5. Após a instalação estiver concluída, reinicie o computador e teste o PDF novamente para ver se ele pode ser visualizado.

Soluções de PDF

Atualizar ou recarregar página

Com frequência, basta atualizar a página em seu navegador para permitir que o PDF seja completamente carregado.

  • Mantenha a tecla Shift pressionada e pressione Atualizar ou o botão Recarregar no navegador.

Tente visualizar um PDF diferente

Tente visualizar um PDF diferente. Por exemplo, veja se este formulário de amostra é exibido em seu navegador. Se o Acrobat ou Reader puder abrir o formulário de amostra, então o outro PDF pode estar danificado ou o servidor da Web pode estar tendo problemas. Se possível, entre em contato com a pessoa ou empresa que controla o site.

Tente visualizar um PDF em seu disco rígido

Determine se o seu navegador da Web pode abrir um PDF a partir de sua unidade de disco rígido local ao invés da Web. Neste teste, você precisa de um PDF salvo em seu computador.

  1. No seu navegador da Web, faça um dos seguintes:

    • Mac OS: Escolha Arquivo > Abrir (ou Abrir arquivo).
    • Windows: Pressione Ctrl + O.
  2. Clique em Procurar.

  3. (Somente Windows) No menu Arquivo do tipo, escolha Todos os arquivos.

    Selecionar todos os arquivos
  4. Localize um PDF no seu computador, selecione-o e clique em Abrir.

    Se o PDF for aberto, o site que você está exibindo pode ter um problema. Entre em contato com a pessoa ou empresa que controla o site.

Soluções do navegador das configurações do navegador

Use outro navegador da Web

Certas condições em seu computador, tais como configurações de segurança ou cookies do navegador, podem impedi-lo de visualizar um PDF. Com frequência, a solução mais rápida é tentar abrir a página usando um navegador diferente. Tente usar qualquer um dos seguintes navegadores que não ainda não tenha usado:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Para obter uma lista de navegadores compatíveis para o Reader e o Acrobat, consulte Navegadores da Web compatíveis.

Alternar para Visualização de compatibilidade (Internet Explorer)

Alguns sites são melhor exibidos na visualização de compatibilidade do Internet Explorer. A Visualização de compatibilidade exibe uma página como se estivesse em uma versão anterior do navegador.

Para obter instruções sobre como mudar para esta vista, consulte Corrigir problemas de exibição com a Vista de compatiblilidade.

Reinicie seu computador e tente abrir o PDF novamente

Reinicie seu computador e, a seguir, abra novamente a página da Web. Reiniciar limpa o cache da memória do computador e de memória. Basta reiniciar o computador o que frequentemente resolve os problemas de exibição.

Excluir arquivos temporários da Internet (Internet Explorer, Firefox e Chrome)

Limpe o cache do navegador (às vezes chamado Arquivos temporários da Internet) para garantir que você esteja visualizando uma nova versão da página. 

Tenha cuidado ao selecionar as opções. Limpe somente o cache do navegador. Se você limpar todos os arquivos temporários da Internet, poderá excluir os cookies que contêm informações de login e as preferências. A maioria dos navegadores permitem escolher o tipo de conteúdo que você desejar excluir.

Apagar histórico
A caixa de diálogo Limpar todo o histórico do Firefox somente permite excluir o cache do navegador.

Para obter mais instruções sobre como limpar o cache do navegador, consulte estes artigos: 

Firefox: excluir o histórico de navegação, procura e download

Chrome: excluir seu cache, histórico e outros dados do navegador

Internet Explorer 8 até 11: exibir e excluir seu histórico de navegação

Internet Explorer 7: excluir o histórico da página da Web

Restaurar a preferência Exibir PDF no navegador (Acrobat/Reader X ou anterior)

Tente reinicializar a preferência de exibição em seu navegador para resolver o problema.

  1. No Reader ou Acrobat, clique com o botão direito do mouse na janela do documentos, e escolha Preferências de exibição de página.

    Preferências de exibição da página
  2. Na lista à esquerda, selecione Internet.

    Selecione Preferências da Internet
  3. Desmarque Exibir PDF no navegador e, a seguir, clique em OK.

    Desmarque Exibir PDF no navegador
  4. Tente abrir o PDF de novo a partir do site.

Exibir o PDF na versão do Internet Explorer de 32 bits ou no Safari 32 (somente Windows Vista)

Esse procedimento aplica-se somente aos usuários do Windows Vista com o Internet Explorer 9 ou anterior.

Acrobat e Reader são aplicativos de 32 bits no Windows. Se você tentar abrir um PDF em uma versão de 64 bits do Internet Explorer, o PDF será aberto no Acrobat ou Reader autônomo, não no Internet Explorer.

Observação:

Somente o Reader 10.1 ou o Acrobat 10.1 e posteriores suportam o Internet Explorer 9.

Para garantir que você esteja usando uma versão 32 bits do Internet Explorer siga estas etapas:

  1. No Internet Explorer, escolha a Ajuda > Sobre o Internet Explorer. (Em algumas versões do Internet Explorer, selecione o ponto de interrogação no canto superior direito para selecionar Sobre o Internet Explorer.)

    Sobre O Internet Explorer 9

    Se você ver “Edição de 64 bits” ao lado da versão, então siga para a etapa 2.

    Internet Explorer 64 bits
  2. Para alternar para o Internet Explorer de 32 bits, primeiro saia do Internet Explorer 64 bits. Clique duas vezes no ícone do programa para a versão de 32 bits:

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    Internet Explorer 32 bits

Soluções do Reader e do Acrobat

Reparar o Reader ou Acrobat

O Reader ou Acrobat pode estar danificado. A reparação da instalação é uma proteção rápida de solução de problemas.

Reparar a partir do Reader ou Acrobat

Escolha Ajuda > Reparar a instalação.

Ajuda, reparar a instalação

Reparar usando o Painel de controle (Windows)

Você também pode reparar a instalação do Acrobat ou do Reader usando o Painel de Controle do Windows.

  1. Feche o Reader ou Acrobat.

  2. Selecione Iniciar > Painel de controle.

    Iniciar o Painel de controle
  3. Adote um dos procedimentos a seguir no Painel de controle, dependendo da versão do Windows:

    • (Windows 8/7/Vista) Clique em Programas e, a seguir, clique em Programas e Recursos.
    • (Windows XP): clique duas vezes em Adicionar ou remover programas.
  4. Na lista de programas, selecione Adobe Reader ou Adobe Acrobat.

  5. Clique em Alterar e siga as instruções para reparar o aplicativo.

    Clique em Alterar para reparar
  6. Quando o processo estiver concluído, clique em Concluir.

Soluções avançadas

Se nenhuma das soluções nas seções anteriores resolverem o problema com a visualização de PDFs, você poderá tentar as seguintes etapas avançadas.

Ativar o complemento do navegador da Adobe PDF (Internet Explorer 8 e posterior)

Certifique-se de que o complemento do navegador da Adobe PDF esteja ativado.

  1. Abra o Internet Explorer e escolha Ferramentas > Gerenciar Complementos.

  2. Em Tipos de complementos, selecione Barras de ferramentas e extensões.

  3. No menu Mostrar, escolha Todos os complementos.

    Todos os complementos
  4. Na lista de complementos, selecione Adobe PDF Reader.

    Observação:

    Se você não puder ver o complemento do Adobe PDF Reader, tente as outras opções no menu. Por exemplo, em alguns sistemas, o complemento é exibido quando você seleciona Executar sem permissão.

  5. Clique no botão Ativar.

    Observação:

    Se o botão disser Desativar, então o complemento já está ativado. Este botão alterna ente Ativar e Desativar, dependendo do status do complemento selecionado.

    Ativar ajusta o complemento Adobe PDF Reader para abrir PDFs no navegador.

    Desativar desativa o complemento para que ele não abra PDFs no navegador.

    Ativar o Acrobat Reader

Ativar o complemento do navegador da Adobe PDF (Firefox)

Certifique-se de que o complemento do navegador da Adobe PDF (nppdf32.dll) esteja ativado.

  1. Na barra de endereços do Firefox, digite: about:plugins

  2. Role o cursor para baixo até uma seção chamada Adobe Acrobat.

    Ativado no Firefox
  3. Certifique-se que o arquivo leia “nppdf32.dll” e “Plug-In do Adobe Acrobat para Netscape”.
    Se esta entrada não estiver disponível, instale a versão mais recente do Reader ou Acrobat.

Execute o Acrobat ou Reader em uma nova conta de administrador local

Crie uma conta de usuário que tenha as mesmas permissões que a conta usada quando ocorre o problema. Ou crie uma conta de administrador local. Caso o problema não ocorra novamente quando estiver conectado à nova conta, a conta do usuário original pode estar danificada.

Para obter mais informações sobre como configurar uma conta de usuário, consulte os seguintes recursos ou entre em contato com o administrador de rede:

Windows XP: para adicionar um novo usuário ao computador

Windows Vista/7/8: Criar uma conta de usuário

Mac OS X: Configurar usuários no Mac

Otimize arquivos PDFs grandes

Se o arquivo PDF for de 4 MB ou maior, peça ao provedor para otimizá-lo. Para obter mais informações sobre como otimizar arquivos PDF, consulte Otimizar PDFs.

Verifique o caminho de registro para o Acrobat ou Reader (Windows)

Isenção de responsabilidade: o registro contém informações relacionadas ao sistema que são cruciais para o computador e os aplicativos. Antes de modificar o registro certifique-se de fazer um backup do mesmo. A Adobe não fornece suporte para problemas que possam surgir após uma modificação inadequada do registro. A Adobe recomenda que você seja experiente na edição de arquivos antes de modificar o registro. Para obter mais informações sobre o registro, consulte a Documentação do Windows ou entre em contato com a Microsoft.

  1. Vá para Iniciar > Executar.

  2. Digite regedit e clique em OK.

  3. Navegue até a chave HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Certifique-se de que o valor (Padrão) esteja definido para o caminho onde o Acrobat ou Reader está instalado.

    • O caminho padrão do Reader é "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe".
    • O caminho padrão do Acrobat é "C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe".

    Observação:

    Se o Acrobat Reader não estiver instalado no caminho padrão, certifique-se que o valor da chave (Padrão) aponta para a localização real.

Para assistir a uma demonstração de vídeo do procedimento, consulte Verificar o caminho correto do registro.

Se o item de registro acima não existir no sistema, faça o seguinte:

  1. Vá para Iniciar > Executar.

  2. Digite regedit e clique em OK.

  3. Faça o backup do arquivo de registro atual:

    • Na caixa de diálogo Editor selecione Arquivo > Exportar.
    • Digite o nome para o arquivo e escolha a localização.
    • Para Faixa de exportação, selecione Todas.
    • Clique em Salvar.
  4. Vá para Editar > Novo > Chave e crie o HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe ausente.

  5. Siga para Editar > Novo > Valor da sequência de caracteres e nomeie esta chave (Padrão).

  6. Selecione (Padrão) e vá para Editar > Modificar. Digite o caminho padrão (listado acima) em "Dados de valor" do produto.

  7. Reinicie o computador.

Reparar a chave de registro HKCR\AcroExch.Document (Windows)

É possível que esta chave esteja danificada, que esteja direcionada a uma versão obsoleta do Acrobat ou do Reader, ou direcionada a um visualizador de PDF terceirizado.

Isenção de responsabilidade: o registro contém informações relacionadas ao sistema que são cruciais para o computador e os aplicativos. Antes de modificar o registro certifique-se de fazer um backup do mesmo. A Adobe não fornece suporte para problemas que possam surgir após uma modificação inadequada do registro. A Adobe recomenda que você seja experiente na edição de arquivos antes de modificar o registro. Para obter mais informações sobre o registro, consulte a Documentação do Windows ou entre em contato com a Microsoft.

  1. Escolha Iniciar > Executar, digite regedit no campo de texto Abrir da caixa de diálogo Executar e, a seguir, cliquem em OK.

  2. Faça o backup do arquivo de registro atual:

    • Na caixa de diálogo Editor selecione Arquivo > Exportar.
    • Digite o nome para o arquivo e escolha a localização.
    • Para Faixa de exportação, selecione Todas.
    • Clique em Salvar.
  3. Navegue por HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Clique com o botão direito do mouse em AcroExch.Document e escolha Excluir; certifique-se de que você tenha a chave correta e clique em Sim em quaisquer dos prompts.

  5. Clique com o botão direito do mouse em AcroExch.Document.7 e escolha Excluir; certifique-se de que você tenha a chave correta e clique em Sim em quaisquer dos prompts.

  6. Este vídeo demonstra as etapas.

     

Alterar o cabeçalho de tipo de conteúdo no servidor da Web (Administrador da Web)

Se você for um webmaster ou tiver direitos administrativos em um site, configure o servidor da Web para enviar cabeçalhos de tipo de conteúdo 'application/pdf' para arquivos PDF. Para obter mais instruções, consulte a documentação que acompanha o servidor da Web ou, consulte esteArtigo de suporte da Microsoft.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online