I pupazzi sono soggetti o personaggi creati da file di grafica di Photoshop o Illustrator erappresentano gli elementi che vengono controllati per creare un'interpretazione. Puoi passare in qualsiasi momento a Photoshop o a Illustrator per apportare modifiche alla grafica oppure utilizzare l'assegnazione di tag in Character Animator per controllare il comportamento.

Un pupazzo include livelli, alcuni dei quali sono gruppi. I gruppi sono livelli che presentano frecce di espansione. Puoi selezionare i livelli per modificarne le proprietà, assemblare un pupazzo da parti presenti nel pannello Progetto (incluse le parti di più pupazzi o più file di grafica), ridisporre e riposizionare i livelli, nonché nasconderli o visualizzarli.

Per creare un pupazzo, puoi usare un file di grafica correttamente strutturato oppure partire da un pupazzo vuoto e costruirlo usando parti di altri pupazzi o file di grafica importati. Puoi inoltre duplicare un pupazzo e creare una versione diversa per un lavoro aggiuntivo.

Puoi quindi selezionare livelli e maniglie e assegnare loro i tag per controllarne il comportamento. Per informazioni sull'assegnazione di tag, consulta Preparare grafica.

Characterizer, basato su Adobe Sensei, genera un pupazzo stilizzato di Character Animator in pochi secondi. L'immagine catturata dalla webcam dell'utente e qualsiasi pezzo di riferimento viene utilizzata per generare pupazzi. Per ulteriori informazioni, consulta Creare pupazzi mediante Characterizer.

Creare un pupazzo da un file di grafica in Character Animator

Per creare un pupazzo da un file PSD o AI:
  1. Scegli File > Importa (Comando/Ctrl+I).

  2. Seleziona uno o più file .psd o .ai, quindi fai clic su Apri.

    Per ogni file di grafica selezionato, nel pannello Progetto viene creato un pupazzo con lo stesso nome del file di grafica.

Creare un pupazzo da un modello

Per creare un pupazzo da un file modello PSD o AI, usa il collegamento al pupazzo Chloe nello spazio di lavoro Inizio. Una copia del file modello PSD o AI viene copiata nella cartella del progetto, importata nel progetto e aggiunta a una nuova scena. Il file PSD o AI viene aperto in Photoshop o Illustrator per apportarvi eventuali modifiche. Quando, dopo aver salvato le modifiche apportate al file, si torna a Character Animator, il pupazzo viene aggiornato di conseguenza.

Creare un pupazzo vuoto

Per creare un pupazzo vuoto, scegli Pupazzo > Nuovo pupazzo vuoto, quindi assegna un nome all'elemento pupazzo.

Nota:

A un pupazzo vuoto non è applicato alcun comportamento predefinito.

Duplicare un pupazzo

Per duplicare un pupazzo, selezionalo, quindi scegli Modifica > Duplica (Comando/Ctrl+D).

Quando si duplica un elemento pupazzo nel pannello Progetto, viene creata una copia separata di tutti i gruppi e livelli presenti nel pupazzo. Questo evita che le modifiche apportate a un pupazzo possano alterare il duplicato.

Condividere un pupazzo

Per condividere un pupazzo con altri utenti di Character Animator, puoi esportarlo come file .puppet. Si tratta di un file autonomo, predisposto per l'importazione, che include tutta la grafica associata al pupazzo.

  1. Nel pannello Progetto seleziona o apri il pupazzo.

  2. Scegli File > Esporta > Pupazzo e assegna un nome al file .puppet.

  3. Invia il file .puppet all'altro utente tramite un collegamento condiviso o un qualsiasi altro metodo di condivisione.

  4. Per aprire un pupazzo condiviso, importa il file .puppet tramite File > Importa oppure trascinandolo nel pannello Progetto.

    Nota:

    • Puoi ricollegare il pupazzo a un'istanza condivisa del file di grafica.
    • Il file .puppet non include le modifiche apportate ai parametri di un pupazzo quando è selezionato nella timeline o eventuali riprese registrate per una traccia pupazzo.
    • I comportamenti presenti nel pupazzo importato vengono aggiornati in modo da utilizzare le versioni dei comportamenti disponibili nel progetto corrente.

Pupazzi in ciclo

Crea un pupazzo abilitato per il ciclo da una sequenza di immagini (in formato PNG) da utilizzare con il comportamento Livelli in ciclo.  Questo comportamento visualizza i livelli del pupazzo in sequenza ed è quindi utile per ripetere un pattern.

Creare un pupazzo in ciclo

  1. Apri un pupazzo nel pannello Pupazzo e fai clic su Aggiungi ciclo oppure scegli File > Importa ciclo

  2. Se stai creando il pupazzo in ciclo con l'opzione Aggiungi ciclo, scegli un file PNG o JPEG dalla sequenza.

    Nota:

    Le sequenze sono file PNG contraddistinte dallo stesso nome di base e da un suffisso numerico, ad esempio Flap001.png Flap002.png e così via.

    Un pupazzo a cui è applicato il comando Livelli in ciclo e il cui nome è uguale a quello della sequenza PNG o JPEG, viene creato nel pannello Progetto e quindi aggiunto sopra il livello attualmente selezionato nel pannello Pupazzo.

  3. Se stai creando il pupazzo in ciclo con l'opzione Importa ciclo PNG, trascina il pupazzo in ciclo creato dal pannello Progetto nel pupazzo nel pannello Pupazzo.

    Nota:

    • Per i pupazzi in ciclo creati con il comando di menu Importa ciclo , il parametro Inizia del comportamento Livelli in ciclo è impostato su Immediatamente, in modo che il ciclo venga visualizzato automaticamente quando si aggiunge il pupazzo a una scena. 
    • Per i pupazzi in ciclo creati con il pulsante Aggiungi ciclo, il parametro Inizia è impostato su Quando attivato, opzione utile se il ciclo verrà attivato premendo un tasto.
    • Tutti i livelli del pupazzo in ciclo ad eccezione del primo sono disattivati per impostazione predefinita e tutti i livelli sono impostati su Nascondi altri nel gruppo. Quando si fa clic sull'icona occhio di un livello viene quindi automaticamente nascosto il livello visualizzato in precedenza.

Inserire pupazzi in una scena

Per visualizzare e controllare un pupazzo, devi prima inserirlo in una scena. Puoi inserire più pupazzi in una scena.

Per inserire un pupazzo in una scena, effettua una delle seguenti operazioni:

  • Seleziona il pupazzo nel pannello Progetto, quindi fai clic su Aggiungi a nuova scena oppure scegli Oggetto > Aggiungi a nuova scena.
  • Trascina il pupazzo dal pannello Progetto alla scena aperta nel pannello Scena o Timeline.
  • Se i pannelli Scena e Timeline sono vuoti, ovvero non ci sono scene aperte, il pupazzo trascinato viene aggiunto a una nuova scena.
  • Trascina il pupazzo in una scena esistente elencata nel pannello Progetto.

Il pupazzo viene visualizzato nella scena e un elemento traccia relativo al pupazzo viene visualizzato e selezionato nel pannello Timeline. Utilizza questo elemento traccia per regolare i parametri specifici a questa istanza del pupazzo.

Nota: per impostazione predefinita, i pupazzi importati vengono posizionati al centro della scena. Utilizza l'opzione di comportamento Trasforma per riposizionare un pupazzo nella relativa scena.

Modificare la grafica originale di un pupazzo

È possibile aggiornare la grafica di un pupazzo senza dover ricreare un pupazzo e tutti i comportamenti applicati, né le modifiche apportate ai parametri di comportamento.

Per modificare la grafica di un pupazzo, effettua le seguenti operazioni:

  1. Seleziona il pupazzo nel pannello Progetto o nel livello del pupazzo nel pannello Pupazzo, quindi scegli Modifica > Modifica originale (Comando/Ctrl+E). Se hai il file di un pupazzo aperto in Photoshop o Illustrator, puoi intervenire direttamente in quell'applicazione e le modifiche saranno automaticamente sincronizzate. Viene avviata l'applicazione predefinita associata alla grafica del pupazzo, ad esempio Photoshop per i file .psd e Illustrator per i file .ai. Apri il file di grafica.

  2. Modifica il file di grafica in base alle esigenze, quindi salva le modifiche. Affinché le modifiche vengano riportate in Character Animator è necessario salvare le modifiche nel file di grafica.

  3. Torna a Character Animator. Il file modificato dovrebbe essere rilevato e aggiornato automaticamente.

  4. Se Character Animator non rileva il file di grafica aggiornato, attendi alcuni istanti.

Video: Creazione di un pupazzo da zero

Video: Creazione di un pupazzo da zero
Dave Werner

Nota: l'esercitazione video Building A Puppet From Scratch (Creazione di un pupazzo ex-novo) spiega come creare un pupazzo in Photoshop ex-novo e impostare le opzioni per animarlo in Adobe Character Animator.

Quando un pupazzo è selezionato nel pannello Progetto o aperto nel pannello Pupazzo, la sezione Pupazzo del pannello Proprietà presenta il percorso della grafica di origine e l'elemento di descrizione comando ne indica il percorso completo. Se il file di grafica non viene trovato, il nome del file è visualizzato in giallo e la descrizione comando è preceduta dalla dicitura Mancante.

Per ricollegare o sostituire la grafica di origine, fai clic sul nome file nel pannello Proprietà, quindi seleziona il file di grafica da utilizzare.

Sostituire il pupazzo sorgente di una traccia pupazzo

Puoi aggiornare o sostituire un pupazzo in una timeline, anche dopo aver registrato delle riprese. In questo modo puoi mantenere le registrazioni esistenti mentre aggiungi nuovi contenuti a un pupazzo, purché venga mantenuta la struttura generale del pupazzo.

Per sostituire il pupazzo di origine di una traccia pupazzo, effettua una delle seguenti operazioni:

  • Seleziona la traccia del pupazzo nella timeline. Quindi, tieni premuto il tasto Opzione (Mac) o Alt (Windows) e trascina il pupazzo sulla traccia pupazzo selezionata nel pannello Timeline.
  • Seleziona il pupazzo sostitutivo nel pannello Progetto. Quindi, fai clic con il pulsante destro del mouse nel l'area dell'intestazione (a sinistra) della traccia del pupazzo e scegli Sostituisci con pupazzo selezionato nel pannello Progetto.

Tutte le riprese registrate per parti del pupazzo sorgente originale che non esistono più nel pupazzo sostitutivo vengono rimosse.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online