Attivazione e controllo dei pupazzi

I trigger sono creati per controllare il modo in cui i gruppi e i livelli vengono visualizzati o nascosti quando si preme un tasto. Puoi creare una gamma diversificata di trigger, comprese le posizioni delle mani, palle di fuoco in loop e cicli di battiti delle palpebre per controllare i pupazzi. 

Per un’esercitazione sul controllo di un personaggio con trigger, fai clic qui.

Comportamento Trigger e pannello Trigger

Per impostazione predefinita, ai nuovi pupazzi viene applicato il comportamento Trigger. Tale comportamento consente di attivare la grafica e configurare trigger con nomi personalizzati, che possono fare riferimento a livelli in altri gruppi. I trigger denominati sono elencati nel pannello Trigger, che consente di assegnare un tasto a un trigger, visualizzare l’elenco dei livelli controllati da un trigger e persino associare una nota MIDI per attivare la grafica utilizzando un dispositivo MIDI collegato. 

Pannello Trigger
Pannello Trigger

Esistono due tipi di trigger: 
• Trigger singoli – Nascondono i livelli per impostazione predefinita e li mostrano quando viene premuto un tasto o viene eseguito un controller/nota MIDI, ad esempio quando si preme H per rendere visibile il cappello di un personaggio. 
• Set di scambio – Mostrano solo un trigger alla volta, come ad esempio per diversi gesti della mano. Tale insieme di trigger è associato a un gruppo di livelli in un pupazzo. A ciascun trigger del set è associato un diverso tasto o nota MIDI di attivazione e può essere presente un trigger predefinito.

Facendo clic sul nome di un livello associato a un trigger si rivela quel livello nel pannello Pupazzo. Se desideri visualizzare un livello o un gruppo in un pupazzo senza incidere su altri livelli o gruppi, utilizza un trigger singolo. Se desideri che quel livello o gruppo nasconda anche gli altri livelli o gruppi (ad esempio, premendo B per mostrare il livello per il battito delle palpebre in un gruppo che dispone anche di livelli per la pupilla e l’occhio), utilizza un set di scambio.

Nota: il comportamento obsoleto Trigger tastiera funziona ancora, ma se desideri utilizzare il nuovo pannello Trigger e non hai nessun trigger tastiera registrato che desideri mantenere, puoi sostituirli con i trigger.

Creazione e modifica dei trigger

Per impostazione predefinita, il pannello Trigger è aperto nello spazio di lavoro Rigging. Puoi inoltre aprirlo o chiuderlo mediante il comando di menu Finestra > Trigger.

Creare un trigger singolo che mostra un livello del pupazzo

Effettua una delle seguenti operazioni:
• Fai clic nella colonna Trigger (  ) per un livello del pupazzo a cui non è stato ancora assegnato un trigger (nessuna icona in quella colonna), quindi scegli  Crea trigger.

• Fai clic con il pulsante destro del mouse sul livello nel pannello Pupazzo, quindi  scegli  Crea trigger.

• Trascina il livello dal pannello Pupazzo e rilascialo nel pannello Trigger.

Trascina il livello su un set di scambio per aggiungerlo a quel set di scambio. Trascinalo altrove per creare un trigger singolo.

• Fai clic sul pulsante Aggiungi (+) nel pannello Trigger, quindi  scegli  Crea trigger per creare un trigger vuoto. Ora, trascina o aggiungi ad esso i livelli del pupazzo.

I trigger con problemi (conflitti di tasti, nessun livello, ecc.) vengono visualizzati in arancione. Passa il puntatore del mouse sopra il trigger per visualizzarne i dettagli. La descrizione descrive inoltre l’assenza di livelli.

Creare un set di scambio di trigger

Effettua una delle seguenti operazioni:
• Fai clic nella colonna Trigger (  ) per un gruppo di pupazzi per cui non è stato ancora assegnato un set di scambio ai relativi livelli (nessuna icona in quella colonna), quindi scegli Crea set di scambio. 

• Fai clic con il pulsante destro del mouse su un gruppo di livelli nel pannello Pupazzo, quindi scegli Crea set di scambio.

• Fai clic sul pulsante Aggiungi (+) nel pannello Trigger, scegli Crea set di scambio, quindi trascina al suo interno singoli trigger o livelli del pupazzo (da usare come trigger singoli).

Nel pannello Trigger viene creato un nuovo set di trigger, ciascuno dei quali è denominato come i livelli selezionati. Se il gruppo contiene livelli del pupazzo visibili, quello più in alto diventa il trigger predefinito nel set di scambio. È possibile rinominare il set di scambio e scegliere di non avere un trigger predefinito.

Assegnare etichette ai trigger

Assegnando ai trigger delle etichette colorate puoi individuare facilmente i trigger o i set di scambio correlati nel pannello Trigger. Puoi anche filtrare il pannello Trigger in modo da visualizzare trigger e set di scambio con colori corrispondenti.

Trigger con etichette assegnate

Seleziona uno o più trigger o set di scambio, quindi fai clic con il pulsante destro del mouse su uno di essi e scegli uno dei colori di etichette elencati. Per non applicare nessuna etichetta, scegli Nessuno. Per impostazione predefinita non viene assegnata alcuna etichetta.

Fai clic con il pulsante destro del mouse sul trigger o sul set di scambio con il colore di etichetta desiderato, quindi scegli Seleziona gruppo etichetta.

Fai clic nel campo del filtro di ricerca del pannello Trigger, quindi digita etichetta:colore (ad esempio etichetta:ro per visualizzare gli elementi con un’etichetta di colore rosso o nero).

Impostare trigger predefiniti

Per impostare come predefinito uno specifico trigger in un set di scambio, effettua una delle seguenti operazioni:
• Seleziona il trigger, quindi scegli l’opzione Impostazione predefinita nella parte inferiore del pannello.
• Fai clic sull’icona del trigger accanto al nome del trigger.
• Fai doppio clic sul nome del trigger.
Il trigger predefinito ha un’icona più luminosa e piena, e un nome più luminoso. Se non desideri che alcun livello venga attivato per impostazione predefinita, ripeti il passaggio precedente per disattivare l’opzione Impostazione predefinita.

Assegnare un livello o un gruppo a un trigger esistente

Per assegnare un livello o un gruppo a un trigger esistente, effettua una delle seguenti operazioni:
• Fai clic con il pulsante destro del mouse sul livello o sul gruppo nel pannello Pupazzo,  scegli  Aggiungi a  trigger  e scegli il trigger specifico dal menu di scelta rapida.
• Trascina il livello o il gruppo sul trigger nel pannello Trigger.

Configurare le impostazioni per il richiamo di trigger

Per cambiare la modalità di richiamo del trigger, seleziona il trigger nel pannello Trigger, quindi effettua una delle seguenti operazioni:

  • Immetti un tasto nella colonna della tastiera.
  • Fai clic nel campo Nota MIDI, quindi tocca il tasto sul tuo dispositivo MIDI oppure immetti il numero della nota MIDI.
  • Per fissare il trigger in modo da non essere costretto a tenere premuto il tasto della tastiera o il tasto MIDI per mantenerlo attivato, attiva l’opzione Blocca nella parte inferiore del pannello.
  • Aggiungendo un livello o una ripetizione a un trigger esistente viene selezionato il trigger di destinazione nel pannello Trigger.

L’assegnazione di tasti e note MIDI ai trigger può essere eseguita più direttamente nella modalità layout del pannello Controlli. Per ulteriori informazioni, consulta Modalità layout.

Rinominare, ridisporre o combinare un trigger o un set di scambio

Per rinominare un trigger o un set di scambio, selezionalo nel pannello Trigger, premi Invio (sulla tastiera principale, non sul tastierino numerico) e digita il nuovo nome. Per accettare la modifica, premi Invio o fai clic fuori dal campo di testo. Per annullare le modifiche, premi invece il tasto Esc.

Per ridisporre i trigger e spostarli entro, in o da un set di scambio, seleziona uno o più trigger e trascinali nel pannello. Quando si trascina un set di scambio su un altro set, i trigger vengono combinati in un unico set di scambio. È inoltre utile ridisporre i trigger in un set di scambio per impostare la priorità dei trigger in base all’ordine in cui sono elencati.

Per combinare i livelli con trigger, trascina un trigger su un altro. I livelli del trigger rilasciato vengono riassegnati al trigger di destinazione e il trigger rilasciato viene eliminato.

Per combinare i trigger da un set di scambio in un altro set, trascina il set di scambio su oppure in un altro set. I trigger del set di scambio rilasciato vengono aggiunti al set di destinazione. Il trigger predefinito del set di scambio di destinazione rimane impostato come trigger predefinito.

 

Nota:

Se rendi condivisibile un gruppo di pupazzi, i trigger assegnati ai livelli del gruppo vengono trasferiti al pupazzo condiviso. Tutti i controlli per tali trigger (visualizzati nel pannello Controlli) sono ancora associati al  pupazzo  principale, e non a quello condiviso. Puoi generare i controlli per i trigger del pupazzo condiviso.

Visualizzare o rivelare i trigger

Per visualizzare o rivelare i trigger associati a un livello in un pupazzo, effettua una delle seguenti operazioni:

• Passa il puntatore del mouse sopra l’icona del trigger nella riga del livello nel pannello Pupazzo. L’elenco di trigger (e di eventuali tasti trigger) che rendono il livello visibile  compare  in una descrizione.
• Fai clic sull’icona del trigger nella riga del livello per visualizzare il trigger nel pannello Trigger.
• Se un livello è assegnato a più trigger, fai clic sull’icona del trigger con  la freccia  nella riga del livello, quindi seleziona il trigger specifico da visualizzare nel pannello dei Trigger.

Suggerimento: se si fa clic sull’icona occhio di un livello (nel pannello Pupazzo) associato a un trigger in un set di scambio, si disattivano automaticamente le icone occhio degli altri livelli attivati nel set di scambio. Fai clic tenendo premuto Opzione/Alt per evitare la disattivazione automatica delle icone occhio.

Configurare il comportamento dei trigger quando vengono richiamati più trigger

Per cambiare il modo in cui i trigger in un set di scambio si comportano quando vengono richiamati più trigger allo stesso tempo, seleziona un set di scambio, quindi imposta Priorità su Più recente per dare la precedenza all’ultimo trigger utilizzato, oppure su Ordine elencato per dare la precedenza al primo trigger nel pannello Trigger. Vengono visualizzati i livelli del trigger a cui viene data la precedenza.

Rimuovere i livelli

Per rimuovere i livelli associati a un trigger, seleziona il trigger nel pannello Trigger, quindi fai clic sulla “x” accanto ai livelli da rimuovere, nella parte inferiore del pannello.

Nota: se si rimuovo tutti i livelli associati a un trigger, quest’ultimo non viene automaticamente eliminato.

Eliminare un trigger o un set di scambio

Per eliminare un trigger o un set di scambio, selezionalo e scegli Modifica > Elimina (Canc o Backspace).

Nota:

Comportamenti come Ruota la testa, Sinc labiale, Trigger movimento e Volto (per chiudere gli occhi) attivano livelli diversi da quelli del comportamento trigger. Se vuoi usare questi quattro comportamenti con livelli attivati da trigger nello stesso gruppo pupazzo, imposta l’opzione Nascondi altri nel gruppo sui livelli che non vengono attivati da questi quattro comportamenti. Con questa opzione, la priorità è determinata dall’ordine dei livelli. In caso contrario, modifica la struttura nel file di grafica.

Copiare trigger tra pupazzi

Nota:

Puoi copiare i trigger da un pupazzo e incollarlo in un altro contenente set di scambio e trigger con gli stessi nomi. Copia questi set di scambio e trigger dal pupazzo originale prima di registrare le riprese per tali trigger. In caso contrario, i trigger incollati non funzioneranno.

Per impostare la compatibilità dei trigger in pupazzi diversi, effettua le seguenti operazioni:

  1. Seleziona il pupazzo da cui copiare i trigger. Nel pannello Trigger, seleziona i set di scambio e i trigger da copiare.

  2. Per copiare i trigger, seleziona Modifica > Copia. Per spostare i set di scambio o i trigger in altri pupazzi, scegli Modifica > Taglia.

  3. Seleziona il pupazzo per cui desideri copiare questi set di  pupazzo .

  4. Con il pannello Trigger attivo, scegli Modifica > Incolla.

I set di scambio e i trigger incollati appaiono nella parte inferiore dell’elenco dei trigger. Puoi spostarli in base alle tue esigenze. Ora puoi copiare una registrazione di trigger tra questi due pupazzi.

Se hai già creato dei Trigger tastiera prima della versione di ottobre 2017, puoi convertirli da Trigger tastiera in Trigger in modo da usufruire delle funzionalità di attivazione più flessibili e dell’uso del pannello Controlli. Tieni presente che i progetti e i file .puppet esistenti che utilizzano il comportamento Trigger tastiera continueranno a funzionare.

Per  i pupazzi basati su Trigger, usa il pannello Trigger o Controlli per visualizzare tutti i tasti trigger assegnati per un pupazzo.

Pannello Controlli: layout personalizzato per i trigger e i parametri di comportamento del pupazzo 

Il pannello Controlli fornisce un’interfaccia visiva, o dashboard, che consente di accedere ai trigger o ai parametri di comportamento supportati per un pupazzo. Puoi scegliere i trigger e i parametri di comportamento (valori numerici e angolari) a cui desideri accedere, e quindi controllarli da una singola posizione. Questi controlli personalizzati vengono associati al pupazzo e possono essere condivisi con altri nell’ambito di un pupazzo esportato.

Negli spazi di lavoro Registrazione e Flusso il pannello Controlli è aperto per impostazione predefinita, ma puoi aprirlo anche tramite il comando di menu Finestra > Controlli. Il pannello presenta i controlli associati al pupazzo selezionato nel pannello Progetto o Timeline oppure al pupazzo aperto nel pannello Pupazzo.

Nel pannello Controlli sono disponibili due modalità:

  • Modalità Layout: consente di personalizzare il contenuto e l’aspetto dei controlli.
Modalità Layout
Modalità Layout

  • Modalità Interpretazione: questa modalità consente di utilizzare i vari controlli facendo clic sui collegamenti nella parte superiore del pannello.
Modalità Interpretazione
Modalità Interpretazione

Modalità Layout

I trigger per un pupazzo possono essere visualizzati come pulsanti selezionabili mediante clic con la grafica per ogni trigger su di essi. Presentano inoltre un tasto o una nota MIDI associati. I parametri di comportamento per un pupazzo possono essere visualizzati sotto forma di cursore regolabile o controlli angolo, indicando anche eventuali note MIDI associate. Il layout viene memorizzato insieme al pupazzo, anche in caso di esportazione come file .puppet, per consentirti di condividere i layout dei trigger con altri utenti.

I controlli seguenti sono quelli disponibili nella modalità Layout.

Per aggiungere controlli al pannello: seleziona il pupazzo ed esegui una di queste operazioni: 

  • Se il pannello è vuoto, fai clic sul collegamento Genera controlli per “nome-pupazzo” nel pannello, per creare controlli di tipo pulsante basati sui trigger del pupazzo.
  • Se di recente sono stati aggiunti alcuni trigger nel pannello Trigger o sono stati precedentemente eliminati alcuni controlli trigger, fai clic sul pulsante Aggiorna controlli . Questa operazione consente di aggiungere pulsanti per i trigger aggiuntivi o comandi trigger eliminati in precedenza.
  • Se nel pannello Timeline è selezionata una traccia pupazzo, trascina il nome di un parametro di comportamento numerico dal pannello Proprietà al pannello Controlli. Puoi anche fare clic con il pulsante destro del mouse al di sopra del nome di tali parametri e scegliere Aggiungi al pannello Controlli.

Per creare i controlli per trigger specifici, effettua una delle seguenti operazioni:

  • Seleziona i trigger o set di scambio nel pannello Trigger, quindi trascina tali elementi nel pannello Controlli.
  • Fai clic con il pulsante destro del mouse su un trigger o un set di scambio, quindi seleziona Aggiungi al pannello Controlli dal menu di scelta rapida.

Per selezionare o deselezionare più controlli, effettua una delle seguenti operazioni: 

  • Fai clic sui controlli premendo il tasto Maiusc o Comando/Ctrl. 
  • Traccia un riquadro di selezione attorno ai controlli. Per selezionare/deselezionare i controlli inclusi nel riquadro di selezione, premi Maiusc o Comando/Ctrl. 
  • Per selezionare tutti i controlli, premi Comando/Ctrl+A.
  • Per deselezionare tutti i controlli, premi Maiusc+Comando/Ctrl+A.

Per ridisporre i controlli, effettua una delle seguenti operazioni

  • Trascina nel pannello i controlli selezionati. Il controllo potrebbe agganciarsi a una linea del layout a griglia. 
  • Premi Opzione/Alt e fai clic sul pulsante Aggiorna layout per ridisporre i controlli attuali in base alla dimensione corrente del pannello.

Per assegnare un altro tasto o controllo MIDI: seleziona il controllo e premi il tasto o tocca il controllo MIDI (pulsante, cursore o manopola) che desideri utilizzare. È come cambiare il tasto o la nota MIDI nel pannello Trigger. In modalità Layout, i controlli associati a un controllo MIDI vengono visualizzati in una sovrapposizione verde nella modalità layout.

Per armare o disarmare facilmente i parametri senza trovare i controlli nel pannello Proprietà, utilizza il pulsante Arma per registrazione mediante i controlli a manopola e cursore per i parametri di comportamento.

Nota: il controllo è disponibile solo quando è selezionata una traccia pupazzo.

Per annullare l’assegnazione del tasto o del controller/nota MIDI, effettua una delle seguenti operazioni:

  • Fai clic sul controllo con il pulsante destro del mouse e scegli Rimuovi tasto trigger, Rimuovi nota MIDI o Rimuovi controller MIDI (disponibile per i controlli dei parametri di comportamento). 
  • Elimina il contenuto del campo Nota MIDI nel pannello Trigger

Per cambiare l’icona di un pulsante per un trigger associato a più livelli del pupazzo: fai clic con il pulsante destro del mouse sul controllo pulsante e seleziona il nome di un livello.

Per modificare il colore di sfondo del controllo (per aumentare il contrasto nelle illustrazioni scure): fai clic sul controllo con il pulsante destro del mouse, quindi scegli Chiaro o Scuro. 

Per modificare l’intervallo di valori per un cursore o un controllo dei parametri di angolazione: trascina o fai clic sui valori blu minimo (a sinistra) e massimo (a destra) sul controllo. Se ad esempio hai aggiunto il parametro Trasforma > Scala, ma non hai bisogno di eseguire il ridimensionamento negativo, imposta il valore minimo su 0. 

Per rimuovere controlli: selezionali, quindi scegli Modifica > Elimina (premi Canc o Backspace) oppure fai clic sul pulsante Elimina controlli selezionati nella parte inferiore del pannello. 

 

Grafica personalizzata per i controlli di tipo pulsante

Puoi usare un elemento grafico personalizzato per i controlli di tipo pulsanti, creandoli ovunque nel file della grafica di un pupazzo. Per selezionare un elemento grafico diverso per i pulsanti che hanno più livelli assegnati ai loro trigger, fai clic con il pulsante destro del mouse su un pulsante, quindi seleziona il nome del livello nella parte superiore del menu di scelta rapida.

Se influisce sull’aspetto del pupazzo nella scena, disattiva l’icona occhio.

  • Per assegnare un elemento grafico personalizzato a un pulsante, trascina il livello dal pannello Pupazzo al controllo pulsante.

Passare dalla modalità Layout alla modalità Interpretazione

Per tornare alla modalità Interpretazione, fai doppio clic all’esterno di qualsiasi controllo nella modalità Layout.
Il tasto Tab è la scelta rapida predefinita assegnata per passare rapidamente dalla modalità Layout alla modalità Interpretazione. Puoi anche assegnare una scelta rapida utilizzando la categoria Finestra per il comando Cambia modalità layout del pannello Controlli nell’editor delle scelte rapide da tastiera.

Modalità Interpretazione

Quando desideri usare i controlli, fai clic su Interpretazione per passare a tale modalità. Per eseguire un’azione, puoi fare clic sul pulsante, premere il tasto assegnato o toccare il controllo MIDI assegnato. 

Scorrimento del contenuto

È possibile fare scorrere il contenuto del pannello Controlli per visualizzare i controlli che si trovano al di fuori dell’area visualizzabile.
Per fare scorrere il pannello Controlli, effettua una delle seguenti operazioni:

  • Utilizza le barre di scorrimento orizzontali o verticali.
  • Tieni premuto il pulsante centrale del mouse o il tasto Opzione/Alt mentre trascini nel pannello.
  • Per eseguire lo scorrimento, ruota la rotella del mouse per scorrere in verticale, oppure tieni premuto il tasto Maiusc mentre ruoti la rotella del mouse per scorrere in orizzontale.

Rinominare i controlli dei parametri di comportamento

Nel pannello Controlli, i parametri di comportamento dispongono di controlli denominati in base ai relativi parametri. Questi possono essere rinominati. Effettua le seguenti operazioni:

  1. Imposta il pannello Controlli sulla modalità Layout.

  2. Puoi selezionare il controllo del parametro di comportamento, quindi premere A capo (macOS) o Invio (Windows), oppure fare clic con il pulsante destro del mouse su un controllo del parametro di comportamento, quindi scegliere Rinomina.

  3. Digita il nome che desideri assegnare e premi A capo/Invio oppure fai clic all’esterno del campo di modifica.

Audio trigger

Rendi più vivace il tuo pupazzo con l’audio attivabile. Puoi riprodurre o registrare un audio quando un trigger viene richiamato aggiungendo audio al trigger. Ad esempio, puoi far gridare un personaggio quando viene attivata un’espressione del volto di urlo.

Per creare un audio attivabile da un file audio, effettua le seguenti operazioni:

  1. Importa il file audio nel progetto. Per alcuni file audio di esempio, fai clic qui.
  2. Trascina il file audio su un pupazzo nel pannello Progetto.

In questo modo viene creata una ripetizione audio assegnata a un nuovo trigger. Puoi assegnare un tasto a questo trigger e utilizzarlo come trigger o ripetizione. Una ripetizione audio (nella sezione Ripetizione del pannello Proprietà) presenta un’icona a forma d’onda accanto al pulsante di riproduzione e impostazioni audio specifiche nella parte inferiore del pannello.

Per includere la scena audio in una nuova ripetizione e un trigger, procedi come segue:

  1. Seleziona le tracce audio e le riprese del pupazzo da includere nella ripetizione.
  2. Fai clic con il pulsante destro su una ripresa selezionata o una determinata traccia audio, quindi scegli il comando Crea ripetizione e trigger oppure Crea ripetizione e trigger nel set di scambio.

Trigger riproduzione audio

I trigger con audio possono essere riprodotti e registrati come qualsiasi altro trigger assegnando loro un tasto. Quando registrati, vengono visualizzati come barre trigger nel pannello Timeline, non come tracce audio separate. Quando queste barre trigger vengono riprodotte, vengono riprodotti anche i file audio associati alle ripetizioni del trigger.

Nota:

L’audio associato ai trigger registrati non viene riprodotto durante lo scorrere del tempo (ad es., lo scorrere dell’audio) e non viene utilizzato quando si creano riprese dalla scena audio (ad es., la Ripresa calcola sincronizzazione labiale dal comando Scena audio). Inoltre, se dividi la barra trigger che contiene una ripetizione audio, l’audio viene avviato dall’inizio per ciascuna barra trigger poiché questo non viene diviso.

Suggerimento: se importi un pupazzo con una ripetizione audio il cui audio sorgente non è attualmente presente nel progetto, puoi aggiungerlo al progetto scegliendo Crea audio condivisibile dal menu di scelta rapida per la ripetizione audio

Dissolvenza: aumentare e ridurre l’opacità tramite trigger

Per controllare l’opacità del pupazzo, puoi utilizzare i trigger tastiera. Puoi utilizzare questo comportamento per mostrare o nascondere una parte specifica di un pupazzo, aumentando o diminuendo l’opacità di tale parte (un gruppo) tramite un trigger (ad esempio un trigger tastiera).

Configurazione

Aggiungi questo comportamento al gruppo specifico di un pupazzo da mostrare o nascondere. Questo comportamento non viene applicato per impostazione predefinita ai pupazzi. Per risultati ottimali, evita di utilizzare Dissolvenza e Trasforma sullo stesso gruppo. Puoi anche assegnare un tasto trigger al gruppo. Se desideri mostrare o nascondere il gruppo con dissolvenza toccando il tasto anziché tenendolo premuto, imposta il tasto su Blocca. 

Nota:

Se per un gruppo che contiene livelli sovrapposti è impostato il metodo di fusione Normale e il pupazzo utilizza Opacità gruppo, l’opacità dei livelli viene regolata separatamente, fino al raggiungimento del livello finale. Soluzione: imposta l’opacità del gruppo su 99,9%.

Controllo

Usa il parametro Durata per controllare la velocità (in secondi) con cui aumenta o diminuisce l’opacità.

Modifica di riprese con trigger

Le riprese registrate avviando un trigger vengono visualizzate nel pannello Timeline come barre di trigger e possono essere modificate agevolmente, come avviene per le barre dei  visemi .

Puoi ridurre lo spazio verticale nel pannello Timeline utilizzato per le barre di  ripresa  per i trigger e  visemi  in modo da ottenere un’interfaccia utente più compatta.

Riprese modificabili con trigger
Riprese modificabili con trigger

I vari parametri sono elencati di seguito.

  • Per selezionare una barra di trigger: fai clic sul centro o sull’estremità sinistra della barra. Per selezionare più barre, fai clic su di esse tenendo premuto il tasto Maiusc o Comando/Ctrl oppure racchiudile in un rettangolo di selezione. 
  • Per modificare il tempo di una barra di trigger: trascina in orizzontale il bordo sinistro della barra per regolarne il tempo di inizio; trascina il bordo destro per regolarne il tempo di fine. Il bordo sinistro si aggancia alla testina di riproduzione oppure ai tempi di inizio o di fine, per le barre di ripresa . 
  • Per passare a un altro trigger nel set di scambio: fai clic con il pulsante destro del mouse sopra la barra di trigger, quindi scegli uno degli altri trigger nel set. 

Suggerimento: se la  testina di riproduzione  si trova su una barra di trigger, disarma il pupazzo o il suo comportamento Trigger per visualizzare le modifiche apportate a un trigger. Puoi anche far scorrere la  testina di riproduzione  nel tempo per visualizzare i cambiamenti.

  • Per inserire una ripresa trigger: fai clic con il pulsante destro del mouse sopra uno spazio prima, dopo o fra le barre di trigger, quindi scegli uno dei trigger disponibili. La nuova barra di trigger inizia nel punto in cui hai fatto clic. 
  • Per dividere in due una barra di trigger, selezionala e scegli Modifica > Dividi (Comando/Ctrl+Maiusc+D), per dividere la barra in corrispondenza della  testina di riproduzione  oppure premi la barra (/) per dividerla a metà. 
  • Per eliminare le barre di trigger: selezionale e scegli Modifica > Elimina (premi Canc o Backspace) oppure fai clic con il pulsante destro del mouse su una di esse e scegli Elimina.
     

Per nascondere le barre delle riprese per i trigger e i visemi, deseleziona il comandi di menu Mostra barre ripresa per trigger e visemi.

Ripetizioni: registrazioni riutilizzabili e attivabili tramite trigger

Attiva tramite trigger le riprese registrate per un pupazzo, dal vivo o per una nuova registrazione, utilizzando le ripetizioni. Ad esempio, queste registrazioni riutilizzabili possono essere create per ripetere interpretazioni diverse durante un flusso dal vivo o uno specifico sguardo o movimento del braccio durante la registrazione. Alcuni utilizzi di un pupazzo in ciclo possono invece essere effettuati tramite la ripetizione di un’interpretazione registrata. 

Una ripetizione rappresenta delle registrazioni specificatamente selezionate ed è associata a un trigger al quale può essere assegnato un tasto o una nota MIDI per richiamarle. Le ripetizioni vengono inoltre incluse quando esporti un pupazzo, consentendoti di condividere le interpretazioni registrate che possono essere attivate dagli altri utenti. 

Ripetizioni in Character Animator

Creare e modificare le ripetizioni

Per creare una ripetizione e un trigger, procedi come segue:

  1. Seleziona una o più barre di ripresa nel pannello Timeline.

  2. Fai clic con il pulsante destro del mouse su una ripresa selezionata, quindi scegli un comando che crea una ripetizione e la associa a un trigger (un nuovo trigger, un nuovo trigger in un set di scambio esistente oppure un trigger esistente).

Le ripetizioni create per un pupazzo vengono visualizzati nella sezione Ripetizioni nel pannello Proprietà  e  mostrano la durata delle ripetizioni. Le ripetizioni create e i relativi trigger vengono denominati, per impostazione predefinita, in base al comportamento per quelle riprese. Se sono presenti più riprese per un comportamento in una ripetizione, il numero di riprese viene visualizzato tra parentesi dopo il nome del comportamento. Utilizza il filtro di ricerca nel pannello Proprietà per cercare le ripetizioni create.

Ripetizioni create
Ripetizioni create

Il trigger per la ripetizione viene visualizzato nel pannello Trigger, così come i trigger che mostrano i livelli di un pupazzo. Se si seleziona un trigger, la sezione Livelli e Ripetizioni nella parte inferiore del  pannello elenca  i livelli e le ripetizioni collegati al pupazzo. Se si fa clic sul nome di una ripetizione, questa diventa visibile nel pannello Proprietà. 

Una ripetizione contiene le copie delle riprese utilizzate per crearla, pertanto è possibile eliminare le riprese originali se necessario. 

Le ripetizioni che presentano problemi sono mostrate in arancione. Per visualizzare ulteriori informazioni in una descrizione, passa il puntatore del mouse sul nome o sull’icona arancione. Anche le ripetizioni non assegnate a un trigger vengono visualizzate in arancione. Quando passi il puntatore del mouse su tali ripetizioni, viene visualizzata la descrizione “Ripetizione senza trigger”.

Puoi anche creare delle “ripetizioni prolungate” e “ripetizioni prolungate con fusione” unitamente a diverse altre operazioni per un parametro di comportamento. Per saperne di più, consulta Menu del parametro di comportamento.

Selezionare o deselezionare le ripetizioni

  • Per selezionare una singola ripetizione, fai clic su di essa.
  • Per selezionare un intervallo di ripetizioni, fai clic sulla prima ripetizione nell’intervallo, quindi fai clic tenendo premuto il tasto Maiusc sull’ultima.
  • Per selezionare o deselezionare singole ripetizioni, fai clic su una ripetizione tenendo premuto il tasto Comando (macOS) o Ctrl (Windows).
  • Per selezionare tutte le ripetizioni, premi Comando+A (macOS) o Ctrl+A (Windows).
  • Per deselezionare tutti le ripetizioni, premi Comando+Maiusc+A (macOS) o Ctrl+Maiusc+A (Windows).

Rinominare, riordinare, eliminare e aggiungere ripetizioni a un trigger

  • Per rinominare una ripetizione, selezionala nel pannello Proprietà, premi A capo (macOS) o Invio (Windows) oppure scegli Rinomina dal menu di scelta rapida, modifica il nome, quindi premi A capo/Invio o fai clic all’esterno del campo di testo.
  • Per riordinare le ripetizioni all’interno dell’elenco Ripetizioni, selezionale, quindi trascina verticalmente una ripetizione selezionata. 
  • Per eliminare delle ripetizioni, selezionale nel pannello Proprietà, quindi premi Canc. Le riprese originali incluse nelle ripetizioni selezionate non vengono eliminate.
  • Per aggiungere delle ripetizioni a un trigger, selezionale nel pannello Proprietà, quindi trascina una ripetizione selezionata e rilasciala nel pannello Trigger. È possibile rilasciare le ripetizioni su un trigger esistente, lontano da un trigger per creare un nuovo trigger per ogni ripetizione selezionata o in un set di scambio per aggiungerli come trigger nel set di scambio.

Riprodurre e registrare ripetizioni

Le ripetizioni vengono solitamente create con trigger associati (che possono essere richiamati tramite tasto, nota MIDI o controllo pulsante), ma è possibile anche utilizzarle direttamente.

Per riprodurre una ripetizione, effettua una delle seguenti operazioni:

• Premi il tasto, la nota MIDI o il controllo pulsante (nel pannello Controlli) associati al trigger della ripetizione.

• Fai clic sul pulsante Riproduci vicino al nome della ripetizione nel pannello Proprietà.

Le riprese registrate nella ripetizione vengono riprodotte, ma la  testina di riproduzione  non si sposta. Un piccolo controllo accanto al nome della ripetizione nel pannello Proprietà mostra l’avanzamento.

Suggerimento: per annullare la riproduzione di una ripetizione, sposta la  testina di riproduzione  a un tempo diverso.

Per registrare una ripetizione, richiamala prima o dopo l’inizio della registrazione. Al termine, interrompi la registrazione. 

Nota:

Le ripetizioni vengono ignorate quando si utilizzano i controlli Registra ripresa di 1 fotogramma e Registra ripresa di 2 fotogrammi. 
Tuttavia, è possibile copiare le ripetizioni selezionate nel pannello Proprietà e incollarle nella timeline.

Utilizzo dei trigger delle ripetizione nei set di scambio

È possibile associare le ripetizioni a qualsiasi trigger, inclusi quelli in un set di scambio. Se sono associate al trigger predefinito in un set di scambio, le ripetizioni verranno riprodotte immediatamente.

Interrompere e sostenere le ripetizioni

Per impostazione predefinita, le ripetizioni riproducono l’intera durata delle riprese registrate, tuttavia è possibile controllare la riproduzione affinché avvenga fin quando la ripetizione viene attivata tramite trigger.

Nota:

Questo non si applica alle riprese che sono state create usando Comando+1, 2 o 3 in cui non sono stati modificati i valori di visemi o trigger. Queste riprese costanti vengono impostate di default su Interrompi/Sostieni.

Per controllare come una ripetizione viene riprodotta, selezionala, quindi imposta l’opzione Al termine del trigger in uno dei seguenti modi:

Consenti completamento riproduzione: viene riprodotta l’intera durata delle  riprese registrate della ripetizione  a prescindere da quanto a lungo la ripetizione viene attivata tramite trigger.

Interrompi/Sostieni ripetizione: le riprese nella ripetizione vengono riprodotte fin quando non si smette di attivarla tramite trigger. Se si continua l’attivazione tramite trigger oltre la durata della ripetizione, le riprese con il tempo di fusione in uscita più recente vengono estese automaticamente. Se ci si interrompe durante una ripresa con fusione in uscita, la ripresa eseguirà la fusione in uscita al termine dell’attivazione tramite trigger.

Conversione dei precedenti Trigger tastiera o in Trigger

Nota:

La vecchia colonna Tastiera nel pannello Pupazzo non esiste più. Puoi modificare il tasto di un trigger obsoleto nella sezione “Trigger tastiera (obsoleto)” del pannello Proprietà. Puoi anche cambiare le impostazioni Blocca e Nascondi altri del gruppo. L’impostazione Nascondi altri nel gruppo può funzionare ancora per i tasti trigger utilizzati dal comportamento Trigger.

Per convertire un pupazzo da Trigger tastiera a Trigger, procedi come segue:

IMPORTANTE: con la procedura seguente vengono eliminate le registrazioni esistenti dei trigger tastiera.

  1. Seleziona il pupazzo nel pannello Progetto.

  2. Scegli Pupazzo > Converti i tasti trigger obsoleti.

    Il comportamento Trigger sostituisce il comportamento Trigger tastiera. I tasti trigger esistenti vengono convertiti in trigger equivalenti nel pannello Trigger.

  3. (Facoltativo) Raggruppa tutti i trigger non indispensabili nel pannello Trigger trascinando un trigger su un altro.

    Se hai convertito un file .puppet importato, esporta il pupazzo in un nuovo file .puppet per mantenere le modifiche.

Logo Adobe

Accedi al tuo account