När en bild eller ett dokument har optimerats kan du exportera det (eller spara det, beroende på dess ursprungliga filtyp).

Du kan exportera (eller i vissa fall spara) ett dokument som en bild i GIF-fil, JPEG-fil eller i annat grafikfilsformat. Du kan också exportera hela dokumentet som en HTML-fil samt associerade bildfiler, enbart markerade segment eller ett särskilt område. Dessutom kan du exportera Fireworks-lägen och -lager som separata bildfiler.

Standardplats för export av filer i Fireworks avgörs av följande och i följande ordning:

  1. Dokumentets aktuella exportförval, som har definierats om du någon gång tidigare har exporterat dokumentet och sedan sparat PNG-filen

  2. Den aktuella platsen för att exportera/spara, som du definierar genom att bläddra bort från den förvalda platsen som visas i någon av dialogrutorna Spara, Spara som eller Exportera

  3. Den aktuella filens plats

  4. Förvald plats där nya dokument eller bilder sparas i operativsystemet

    Standardplatsen för att spara dokument i Fireworks fastställs av en annan uppsättning med villkor. Mer information finns i Spara Fireworks-filer.

Exportera sidor som bildfiler

  1. Välj Arkiv > Exportera.

  2. Välj en plats för exportfilerna.

  3. Gör något av följande:

    • Välj Endast bilder på snabbmenyn Exportera och markera eller avmarkera kryssrutan Endast aktuell sida. Sidorna exporteras till det sidformat som är inställt på optimeringspanelen.

    • Välj Sidor till filer på snabbmenyn Exportera och välj Bilder på snabbmenyn Exportera som. Sidorna exporteras till det sidformat som är inställt på optimeringspanelen.

    • Välj Sidor till filer på snabbmenyn Exportera och välj Fireworks PNG på snabbmenyn Exportera som. Varje sida exporteras som en separat PNG-fil som är bakåtkompatibel med Fireworks 8.

    Obs!

    Om du vill exportera alla sidor med det valda formatet markerar du alla sidor och sedan optimerar du inställningarna.

Exportera en enda bild

Om du arbetar med en befintlig bild som du har öppnat i Fireworks, kan du spara den i stället för att exportera den. Mer information finns i Spara dokuments med andra format.

Obs!

Om du vill exportera endast vissa bilder i ett dokument, måste du först segmentera dokumentet och sedan exportera endast de önskade segmenten.

  1. På optimeringspanelen väljer du ett filformat och anger formatspecifika alternativ.

  2. Välj Arkiv > Exportera.

  3. Välj en plats att exportera bildfilen till.

    För webbilder är den bästa platsen i allmänhet en mapp inom den lokala webbplatsen.

  4. Ange ett filnamn utan filnamnstillägg. Ett filnamnstillägg läggs till vid exporten baserat på filtyp.

  5. På snabbmenyn Exportera väljer du Endast bilder.

  6. Klicka på Spara.

Exportera ett segmenterat dokument

Som standard, när du exporterar ett segmenterat Fireworks-dokument, exporteras en HTML-fil och associerade bilder. Den exporterade HTML-filen kan visas i en webbläsare eller importeras till andra program för vidare redigering.

Innan du exporterar bör du försäkra dig om att rätt HTML-format är valt i dialogrutan HTML-inställningar. Se Ange alternativ för HTML-export.

Exportera alla segment

  1. Välj Arkiv > Exportera.

  2. Navigera till en mapp på hårddisken som du vill exportera till.

  3. På snabbmenyn Exportera väljer du HTML och bilder.

  4. Skriv ett filnamn i rutan Filnamn (Windows) eller rutan Spara som (Mac OS).

  5. På snabbmenyn HTML väljer du Exportera HTML-fil.

  6. På snabbmenyn Segment väljer du Exportera segment.

  7. (Valfritt) Välj Lägg bilder i undermappen.

  8. Klicka på Spara.

Exportera valda segment

  1. Skift-klicka om du vill markera flera segment.

  2. Välj Arkiv > Exportera.

  3. Välj en plats där du vill lagra de exporterade filerna, t ex en mapp inom den lokala webbplatsen.

  4. På snabbmenyn Exportera väljer du HTML och bilder.

  5. Ange ett filnamn utan filnamnstillägg. Ett filnamnstillägg läggs till vid exporten baserat på filtyp.

    Om du exporterar flera segment, används det namn i Fireworks som du anger som rotnamn för alla exporterade bilder, med undantag för de som har gett egna namn med hjälp av lagerpanelen eller egenskapskontrollen.

  6. På snabbmenyn Segment väljer du Exportera segment.

  7. Om du vill exportera endast de segment som du har markerat före exporten, väljer du Endast markerade segment och ser till att alternativet Inkludera områden utan segment inte är markerat.

  8. Klicka på Spara.

Uppdatera ett segment

Om du redan har exporterat ett segmenterat dokument och sedan har gjort ändringar i originaldokumentet i Fireworks, kan du uppdatera bara den bild eller det segment som du har ändrat. Om du vill göra det lättare att hitta ersättningssegmentet kan du ge det ett eget namn.

  1. Dölj segmenten och redigera området under det.

  2. Visa segmentet igen.

  3. Högerklicka (Windows) eller Ctrl-klicka (Mac OS) på segmentet och välj Exportera markerat segment.

  4. Välj samma mapp som originalsegmentet med samma basnamn och klicka på Spara.

  5. Klicka på OK när du tillfrågas om du vill ersätta den befintliga filen.

    Obs!

    Undvika att ändra storlek på segmentet utöver originalets exportstorlek i Fireworks, annars kan oväntade resultat uppstå i HTML-dokumentet när segmentet uppdateras.

Exportera en animering

När du har skapat och optimerat en animering kan du exportera den. Du kan exportera en animering som någon av följande filtyper:

Animerad GIF

De ger bäst resultat för clipart och tecknade bilder.

Flash SWF eller Fireworks PNG (ingen export behövs)

Exportera en animering som en SWF-fil för import i Flash. Eller hoppa över exportsteget genom att importera en PNG-källfil från Fireworks direkt i Flash. Med hjälp av direktmetoden kan du importera alla lager och lägen i animeringen och redigera dem ytterligare i Flash. Se Arbeta med Flash.

Flera filer

Att exportera lägen i animering eller lager som flera filer är användbart när du har många symboler på olika lager för samma objekt. Du kan till exempel exportera en banderollannons som flera filer om varje bokstav i företagets namn är animerad i en bild. Se Exportera lägen eller lager som flera filer.

Om dokumentet innehåller flera animeringar kan du infoga segment och exportera var och en med olika animeringsinställningar, såsom upprepning och lägesfördröjning.

Exportera en GIF-animering

  1. Välj Markera > Avmarkera om du vill avmarkera alla segment och objekt. Välj Animerad GIF som filformat på optimeringspanelen.

  2. Välj Arkiv > Exportera.

  3. Ange ett namn på filen och välj mål.

  4. Klicka på Spara.

Exportera flera animerade GIF-bilder med olika animeringsinställningar

  1. Markera animeringarna genom att Skift-klicka på dem.

  2. Välj Redigera > Infoga > Rektangulärt segment eller Polygonsegment.

  3. Klicka på Flera i meddelanderutan.

  4. Markera varje segment för sig och använd lägespanelen för att ange olika animeringsinställningar för vart och ett av dem.

  5. Markera alla segment som du vill animera, och välj Animerad GIF som filformat på optimeringspanelen.

  6. Högerklicka (Windows) eller Ctrl-klicka (Mac OS) på varje segment och exportera varje segment individuellt genom att markera det och välja Exportera markerat segment. I dialogrutan Exportera skriver du ett namn för varje fil, väljer mål och klickar på Spara.

Exportera lägen eller lager som flera filer

I Fireworks kan du exportera varje lager eller läge i ett dokument som en separat bildfil och använda optimeringsinställningar som du anger på optimeringspanelen. Lagrets eller lägets namn avgör filnamnet för varje exporterad fil. Den här exportmetoden används ibland för att exportera animeringar.

  1. Välj Arkiv > Exportera.

  2. Skriv ett filnamn och välj en målmapp.

  3. På snabbmenyn Exportera väljer du ett alternativ:

    Lägen till filer

    Exportera lägen som flera filer.

    Lager till filer

    Exportera lager som flera filer.

    Obs! Alla lager på det aktuella läget exporteras.

  4. Om du automatiskt vill beskära varje exporterad bild så att den endast innehåller objekten på varje läge, väljer du Beskär bilder. Om du i stället vill inkludera hela arbetsytan (inklusive tomma områden utöver objekten), avmarkerar du det här alternativet.

  5. Klicka på Spara.

Exportera ett område från ett dokument

  1. Välj verktyget Exportområde () i panelen Verktyg.

  2. Dra en markeringsram som definierar den del av dokumentet som ska exporteras.

    Obs!

    Du kan justera ramens placering medan du drar. Samtidigt som du håller ned musknappen, trycker du på och håller ned blankstegstangenten, och sedan drar du markeringsramen till en annan plats på arbetsytan. Släpp blankstegstangenten när du vill fortsätta rita markeringsramen.

    När du släpper musknappen förblir exportområdet markerat.

  3. Ändra exportområdets storlek om det behövs:

    • Om du vill ändra storlek på exportområdet markeringsram proportionellt, Skift-drar du i ett handtag.

    • Om du vill ändra storlek på markeringsramen från mitten Alt-drar du i ett handtag.

    • Om du vill behålla proportionerna och ändra storlek från mitten, Alt-Skift-drar du i ett handtag.

  4. Dubbelklicka inuti exportområdets markeringsram när du vill visa förhandsvisningen.

  5. Justera inställningarna i förhandsvisningen och klicka på Exportera.

  6. Skriv ett filnamn och välj en målmapp.

  7. På snabbmenyn Exportera väljer du Endast bilder.

  8. Klicka på Spara.

    Obs!

    Om du vill avbryta utan att exportera, dubbelklickar du utanför exportområdets markeringsram och trycker på Esc eller väljer ett annat verktyg.

Exportera HTML

Såvida du inte anger något annat när du exporterar ett segmenterat Fireworks-dokument, exporteras en HTML-fil och dess bilder. Om du vill definiera hur HTML ska exporteras i Fireworks, använder du dialogrutan HTML-inställningar.

I Fireworks genereras rent HTML som kan läsas i de flesta webbläsare och HTML-redigerare. Som standard, används UTF-8-kodning vid export.

Du kan exportera HTML i Fireworks på ett antal olika sätt:

  • Exportera en HTML-fil, som du senare kan öppna för redigering i en HTML-redigerare.

  • Exportera varje sida i en Fireworks-fil till en separat HTML-fil.

  • Kopiera HTML-kod till Urklipp i Fireworks och sedan klistra in koden direkt i ett befintligt HTML-dokument.

  • Exportera en HTML-fil, öppna den i en HTML-redigerare, manuellt kopiera avsnitt av koden från filen och klistra in koden i ett annat HTML-dokument.

  • Exportera HTML som CSS-lager (Cascading Style Sheet) och XHTML.

  • Använd kommandot Uppdatera HTML när du vill göra ändringar i en HTML-fil som du tidigare har skapat.

    I Fireworks kan du exportera HTML i generiskt format, Dreamweaver-format, Microsoft® FrontPage-format® och Adobe GoLive®-format.

    Obs! Adobe Dreamweaver är nära integrerat med Fireworks. I Fireworks hanteras export av HTML till Dreamweaver på ett annat sätt än export till andra HTML-redigerare. Hur du exporterar Fireworks-HTML till Dreamweaver beskrivs i Arbeta med Dreamweaver.

    Exportmetoden att ta in Fireworks-HTML i andra program är idealisk om du arbetar i en gruppmiljö. Med den här metoden delas arbetsflödet upp i segment så att en person kan utföra en uppgift i ett program, och en annan person kan ta över vid ett senare tillfälle i ett annat program.

Inkludera kommentarer i exporterad HTML

Kommentarer i Fireworks-HTML inleds med <!-- och avslutas med -->. Det som finns mellan dessa två markörer tolkas inte som HTML- eller JavaScript-kod.

  1. Innan du exporterar markerar du alternativet Inkludera HTML-kommentarer på fliken Allmänt i dialogrutan HTML-inställningar.

Resultat vid export

När du exporterar eller kopierar HTML från Fireworks genereras följande:

  • Den HTML-kod som behövs för att sätta ihop segmenterade bilder och eventuell JavaScript-kod om dokumentet innehåller interaktiva element. Fireworks-HTML innehåller länkar till de exporterade bilderna och webbsidans bakgrundsfärg anges till arbetsytans färg.

  • En eller flera bildfiler, beroende på hur många segment som finns i dokumentet och hur många lägen knapparna omfattar.

  • En fil med namnet spacer.gif, om den behövs. Spacer.gif är en genomskinlig GIF-bild om 1x1 bildpunkter som används i Fireworks för att korrigera avståndsproblem när segmenterade bilder sätts ihop i en HTML-tabell. Du kan välja om du vill exportera en sådan distans i Fireworks.

  • Om du exporterar några snabbmenyer, exporteras följande filer: mm_css_menu.js och en .css-fil som innehåller CSS-koden för snabbmenyerna. Om snabbmenyerna innehåller undermenyer, exporteras även filen arrows.gif.

  • Om du exporterar eller kopierar HTML till Dreamweaver, skapas anteckningsfiler som möjliggör integrering mellan Fireworks och Dreamweaver. Dessa filer har filnamnstillägget mno.

Exportera Fireworks-HTML

  1. Välj Arkiv > Exportera.

  2. Navigera till en mapp på hårddisken som du vill exportera till.

  3. På snabbmenyn Exportera väljer du HTML och bilder.

  4. Klicka på knappen Alternativ och välj HTML-redigerare på snabbmenyn HTML-format på fliken Allmänt i dialogrutan HTML-inställningar. Om den HTML-redigerare som du söker inte finns med väljer du Generisk.

    Obs!

    Det är viktigt att du väljer den aktuella HTML-redigeraren som HTML-format så att interaktiva element som knappar och överrullningar fungerar korrekt när de importeras till HTML-redigeraren.

  5. Klicka på OK.

  6. På snabbmenyn HTML väljer du Exportera HTML-fil.

  7. Om dokumentet innehåller segment väljer du Exportera segment på snabbmenyn Segment.

  8. Om du vill lagra bilder i en separat mapp väljer du Lägg bilder i undermappen. Du kan välja en specifik mapp eller använda Fireworks standardmapp för bilder.

  9. Om du exporterar ett flersidigt Fireworks-dokument, avmarkerar du kryssrutan Endast aktuell sida så att alla sidor exporteras till separata HTML-dokument.

  10. Klicka på Spara.

    När du är klar ser du de filer som du har exporterat i Fireworks på hårddisken. Bilder och en HTML-fil genereras på den plats som du har angett i dialogrutan Exportera.

Kopiera HTML-kod till Urklipp

Du kan kopiera HTML-kod till Urklipp i Fireworks på två olika sätt. Använd kommandot Kopiera HTML-kod eller välj Kopiera till Urklipp som ett alternativ i dialogrutan Exportera. Senare klistrar du in denna HTML-kod i ett dokument i den HTML-redigerare som du använder.

När du avgör hur Fireworks-HTML ska tas in i andra program, bör du ta hänsyn till följande nackdelar med att kopiera HTML-kod till Urklipp:

  • Du får inte möjlighet att spara bilder i en undermapp. De måste finnas i samma mapp som den HTML-fil där du klistrar in den kopierade HTML-koden. Ett undantag är när HTML-kod kopieras till Dreamweaver.

  • Eventuella länkar eller sökvägar som används för Fireworks snabbmenyer kopplas till hårddisken. HTML-kod som kopieras till Dreamweaver utgör ett undantag.

  • Om du använder en annan HTML-redigerare än Dreamweaver eller Microsoft FrontPage, kopieras JavaScript-kod som är associerad med knappar, beteenden och överrullningsbilder, men de kanske inte fungerar på rätt sätt.

    Om dessa faktorer utgör problem för dig, bör du använda alternativet Exportera HTML i stället för att kopiera HTML-koden till Urklipp.

    Obs! Innan du kopierar HTML-kod måste du försäkra dig om att du har valt lämpligt HTML-format och markerat Inkludera HTML-kommentarer på fliken Allmänt i dialogrutan HTML-inställningar.

Kopiera Fireworks-HTML med hjälp av alternativet Kopiera HTML-kod

  1. Välj Redigera > Kopiera HTML-kod.

  2. Följ guiden. När du uppmanas, anger du en mapp som mål för de exporterade bilderna. Det måste vara platsen där HTML-filen ska placeras.

    Obs!

    Om du planerar att klistra in HTML-koden i Dreamweaver spelar det inte någon roll vart du exporterar bilderna, så länge de befinner sig på samma Dreamweaver-plats som den HTML-fil där du ska klistra in koden.

Kopiera Fireworks-HTML med hjälp av dialogrutan Exportera

  1. Välj Arkiv > Exportera.

  2. I dialogrutan Exportera anger du en mapp som mål för de exporterade bilderna. Det måste vara platsen där HTML-filen ska placeras.

    Obs!

    Om du planerar att klistra in HTML-koden i Dreamweaver spelar det inte någon roll vart du exporterar bilderna, så länge de befinner sig på samma Dreamweaver-plats som den HTML-fil där du ska klistra in koden.

  3. På snabbmenyn Exportera väljer du HTML och bilder.

  4. På snabbmenyn HTML väljer du Kopiera till Urklipp.

  5. Om dokumentet innehåller segment väljer du Exportera segment på snabbmenyn Segment.

  6. Klicka på knappen Alternativ, välj HTML-redigerare i dialogrutan HTML-inställningar och klicka sedan på OK.

  7. Klicka på Spara.

Klistra in HTML-kod som har kopierats från Fireworks i ett HTML-dokument

  1. I HTML-redigeraren öppnar du ett befintligt HTML-dokument eller skapar ett nytt. Spara dokumentet till samma plats som du exporterade bilderna.

    Obs!

    Att spara HTML-filen på samma plats som de exporterade bilderna är inte nödvändigt om du använder Dreamweaver. Så länge du exporterar bilderna från Fireworks till en Dreamweaver-plats och sparar HTML-filen till en plats någonstans inom platsen, kan du lösa sökvägarna till de associerade bilderna i Dreamweaver.

  2. Visa HTML-koden och placera insättningspunkten mellan märkorden <BODY> .

    Obs!

    HTML-kod som kopieras från Fireworks innehåller inte de inledande och avslutande märkorden <HTML> och <BODY> .

  3. Klistra in HTML-koden.

    Om det är möjligt när du kopierar till Urklipp, exporterar du bilderna till den plats där de ska finnas på webbplatsen. I Fireworks används dokumentrelativa URL-adresser, så om HTML eller bilder flyttas, bryts URL-länkarna.

Kopiera kod från en exporterad Fireworks-fil och klistra in den i ett annat HTML-dokument

  1. Öppna den HTML-fil som du exporterade från Fireworks i en HTML-redigerare.

  2. Markera den nödvändiga koden och kopiera den till Urklipp.

  3. Öppna ett befintligt HTML-dokument eller skapa ett nytt.

  4. Klistra in koden i den nya HTML-filen. Du behöver inte kopiera märkorden <HTML> och <BODY>, eftersom de redan ska finnas i mål-HTML-dokumentet.

    Om du valde Inkludera HTML-kommentarer i dialogrutan HTML-inställningar i Fireworks, följer du instruktionerna i kommentarerna för hur du kopierar och klistrar in koden på lämplig plats.

  5. Om Fireworks-dokumentet innehåller interaktiva element, kopierar du JavaScript-koden.

    JavaScript-kod omges av <SCRIPT>-märkord och återfinns i avsnittet <HEAD> i dokumentet. Kopiera och klistra in hela <SCRIPT>-avsnittet, såvida inte måldokumentet redan innehåller ett <SCRIPT>-avsnitt. I det fallet bör du endast kopiera och klistra in innehållet i <SCRIPT>-avsnittet i det befintliga <SCRIPT>-avsnittet, och vara noga med att inte skriva över innehållet i det befintliga avsnittet. Se även till att det inte finns några dubbletter av JavaScript-funktioner i <SCRIPT>-avsnittet när du har klistrat in koden.

Uppdatera exporterad HTML-kod

Genom att uppdatera kan du göra ändringar i ett HTML-dokument i Fireworks som du tidigare har exporterat. Det är praktiskt om du vill uppdatera endast en del av ett dokument.

Obs!

Uppdatera HTML fungerar olika med Dreamweaver-dokument än det gör med andra HTML-dokument. Mer information finns i Arbeta med Dreamweaver.

När du uppdaterar kan du välja att ersätta endast de bilder som har ändrats eller att skriva över all kod och alla bilder. Om du väljer att ersätta endast de bilder som har ändrats, behålls alla ändringar som du har gjort i HTML-filen utanför Fireworks.

Obs!

Vid omfattande ändringar i dokumentets layout, gör du ändringarna i Fireworks och exporterar HTML-filen på nytt.

  1. Välj Arkiv > Uppdatera HTML.

  2. Välj vilken fil som ska uppdateras.

  3. Klicka på Öppna.

  4. Gör något av följande:

    • Om ingen Fireworks-genererad HTML-kod påträffas, klickar du på OK så att ny HTML-kod infogas i slutet av dokumentet.

    • Om Fireworks-genererad HTML-kod påträffas, väljer du något av följande och klickar på OK:

      Ersätt bilder och HTML

      Ersätt tidigare Fireworks-HTML

      Uppdatera endast bilder

      Skriv endast över bilder

  5. Om dialogrutan Välj bildmapp visas, väljer du en mapp och klickar på Öppna.

Exportera CSS-lager

CSS-lager kan överlappa och staplas ovanpå varandra. I Fireworks, överlappar inte normala HTML-utdata.

  1. Välj Arkiv > Exportera.

  2. Skriv ett filnamn och välj en målmapp.

  3. På snabbmenyn Exportera väljer du HTML och bilder.

    • Om du bara vill exportera det aktuella läget markerar du Endast aktuellt läge.

    • Om du bara vill exportera den aktuella sidan markerar du Endast aktuell sida.

    • Om du vill välja en mapp för bilder, markerar du Lägg bilder i undermappen.

  4. Ange HTML-sidans egenskaper genom att klicka på Alternativ.

  5. Klicka på Bläddra om du vill ange en bakgrundsbild och ställa in om bakgrundsbilden ska upprepas:

    • Välj Ingen upprepning om bilden endast ska visas en gång.

    • Välj Upprepa om du vill att bilden ska visas upprepade gånger i både vertikal och horisontell ledd.

    • Välj Upprepa x om du vill att bilden ska visas upprepade gånger i horisontell ledd.

    • Välj alternativet Upprepa y om du vill att bilden ska visas upprepade gånger i vertikal ledd.

  6. Välj sidjustering på webbläsaren som vänster, centrera eller höger.

  7. Klicka på OK och sedan på Spara.

Exportera XHTML

XHTML är en kombination av HTML, den aktuella standarden för formatering och visning av webbsidor och XML (Extensible Markup Language). XHTML är bakåtkompatibel, vilket innebär att de senaste webbläsarna kan visa den och att den kan läsas av andra enheter som visar XML-innehåll, såsom PDA-enheter, mobiltelefoner och andra handhållna enheter.

I Fireworks kan du också importera XHTML. Se Skapa Fireworks-PNG-filer från HTML-filer.

Om du vill ha mer information om XHTML läser du i XHTML-specifikationen hos W3C (World Wide Web Consortium) på www.w3.org.

  1. Välj Arkiv > HTML-inställningar, välj ett XHTML-format på snabbmenyn HTML-format på fliken Allmänt och klicka sedan på OK.

  2. Exportera dokumentet med hjälp av någon av de metoder som är tillgängliga för export eller kopiering av HTML. Se Exportera HTML.

    Obs!

    I Fireworks används UTF-8-kodning vid export till XHTML.

Exportera filer med och utan UTF-8-kodning

UTF-8 (Universal Character Set Transformation Format-8) är en textkodningsmetod som möjliggör för webbläsare att visa olika teckenuppsättningar (till exempel, kinesisk text och engelsk text) på samma HTML-sida. UTF-8-kodning är aktiverat som standard.

I Fireworks kan du även importera dokument där UTF-8-kodning används. Se Skapa Fireworks-PNG-filer från HTML-filer.

Exportera dokument utan UTF-8-kodning

  1. Välj Arkiv > HTML-inställningar.

  2. På fliken Dokumentspecifik, avmarkerar du kryssrutan UTF-8-kodning och klickar på OK.

  3. Exportera dokumentet med hjälp av någon av de metoder som är tillgängliga för export eller kopiering av HTML.

Ange alternativ för HTML-export

I dialogrutan HTML-inställningar kan du definiera hur HTML ska exporteras i Fireworks. Ändringar som görs på fliken Dokumentspecifik påverkar endast det aktuella dokumentet. Allmänna inställningar och tabellinställningar är globala inställningar och påverkar alla nya dokument.

  1. Gör något av följande:

    • Välj Arkiv > HTML-inställningar.

    • Klicka på knappen Alternativ i dialogrutan Exportera.

  2. På fliken Allmänt väljer du önskade alternativ.

    HTML-format

    Välj format för exporterad HTML-kod.

    Generisk HTML fungerar för alla HTML-redigerare. Om dokumentet däremot innehåller beteenden eller annat interaktivt innehåll, väljer du önskad specifik redigerare om den finns med i listan.

    Om du vill exportera dokumentet med XHTML-standard, väljer du lämpligt XHTML-format på snabbmenyn.

    Filnamnstillägg

    Välj ett filtillägg på snabbmenyn eller ange ett nytt.

    Inkludera HTML-kommentarer

    Välj att inkludera kommentarer om var HTML-koden ska kopieras och klistras in. Rekommenderas om dokumentet innehåller interaktiva element såsom knappar, beteenden eller överrullningsbilder.

    Filnamn med gemener

    Välj alternativet om du vill att namnet på HTML-filen och de associerade bildfilerna ska skrivas med gemener vid export.

    Obs! HTML-filens filnamnstillägg ändras inte till gemener med det här alternativet om ett filnamnstillägg med versaler har valts på snabbmenyn Tillägg.

    Använd CSS för snabbmenyer

    Välj alternativet om du vill använda CSS i stället för JavaScript för snabbmenyernas kod. Du kan använda Dreamweaver för att indexera menyerna och för att uppdatera länkarna inom koden.

    Skriv CSS till extern fil

    Välj alternativet om du vill att CSS-kod ska skrivas till en extern css-fil som exporteras till samma plats som HTML-filen. Namnet på css-filen matchar namnet på HTML-filen (med undantag för filnamnstillägget). Om du väljer det här alternativet exporteras även en fil med namnet mm_css_menu.js till samma plats som HTML-filen.

    Obs! Alternativet är endast tillgängligt om du har valt alternativet Använd CSS för snabbmenyer.

    Filskaparen (macOS)

    Välj ett associerat program på snabbmenyn. När du dubbelklickar på den exporterade HTML-filen på hårddisken, öppnas den automatiskt i det valda programmet.

  3. På fliken Tabell väljer du inställningar för HTML-tabellerna. Information finns i Definiera hur HTML-tabell ska exporteras.

  4. På fliken Dokumentspecifik väljer du något av följande alternativ:

    Segmentfilnamn

    Välj en formel för automatisk namngivning av segment på snabbmenyer. Du kan använda standardinställningarna eller välja egna alternativ.

    Obs! Om du väljer Inget för någon av de första tre menyerna, exporteras segmentfiler i Fireworks som skriver över varandra, vilket resulterar i en enda exporterad bild och en tabell där bilden visas i varje cell.

    Förvalt ALT-märke

    Ange text som ska visas i stället för alla bilder medan de hämtas från webben och i stället för bilder som inte kan hämtas. I vissa webbläsare kan den också visas i en tipsruta när pekaren passerar över bilden. Den utgör också ett hjälpmedel för personer med nedsatt syn.

    Exportera HTML-sidor med flera navigeringsfält (för användning utan ramuppsättningar)

    Välj alternativet när du exporterar ett navigeringsfält som sammanlänkar flera sidor. I Fireworks exporteras ytterligare sidor för varje knapp i navigeringsfältet.

    Inkludera områden utan segment

    Markera alternativet om du vill ta med områden av arbetsytan som inte är täckta av segment.

    UTF-8-kodning

    Aktiverat som standard. Medger att tecken från flera teckenuppsättningar kan återges i det exporterade dokumentet. Om du vill inaktivera alternativet, avmarkerar du kryssrutan.

  5. Om du vill spara inställningarna som globala standardinställningar klickar du på Ange förval.

Exportera Adobe PDF-filer

När du behöver skriva ut en Fireworks-design eller distribuera den för granskning, exporterar du till Adobe PDF. Granskare kan lägga till kommentarer och svara på kommentarer från andra i Adobe Reader ® eller Acrobat®. Information om hur du konfigurerar PDF-granskningar finns i hjälpen för Acrobat.

Exporterade PDF-filer behåller alla sidor och hyperlänkar, så att granskare kan navigera precis som de skulle på webben. I motsats till HTML-prototyper, innehåller Adobe PDF däremot säkerhetsinställningar som förhindrar granskare att redigera eller kopiera designen.

  1. Välj Arkiv > Exportera.

  2. Välj Adobe PDF från snabbmenyn Exportera.

  3. Välj vilka sidor som ska exporteras och markera Visa PDF efter export så att PDF-filen automatiskt öppnas i Adobe Reader eller Acrobat.

  4. Om du vill anpassa PDF-dokumentet, klickar du på Alternativ och justerar sedan följande inställningar:

    Kompatibilitet

    Avgör vilka Adobe PDF-program som ska kunna öppna den exporterade filen.

    Komprimering

    Avgör typ av bildkomprimering för reducering av filstorlek. I allmänhet ger JPEG- och JPEG2000-komprimering bättre resultat på bilder som fotografier med gradvisa övergångar mellan färgerna. ZIP är ett bättre val för illustrationer med stora solida enfärgade områden.

    Kvalitet

    För JPEG eller JPEG2000-komprimering, ger bildkvalitetsinställningar. Om Hög kvalitet väljs, produceras en stor fil med god bildkvalitet.

    Konvertera till gråskala

    Konvertera alla bilder till gråskala, vilket minskar filstorleken.

    Aktivera textmarkering

    Låter granskare kopiera text från den exporterade filen. Avmarkera det här alternativet för att minska filstorleken avsevärt.

    Utfallsvärde

    Avgör bildpunktsbredd för den tomma kant som omger bilden på varje sida. Med ett värde på exempelvis 20 omges varje bild med en kant om 20 bildpunkter.

    Använd lösenord för att öppna dokument

    Öppningslösenord krävs för att öppna den exporterade filen.

    Använd lösenord för att begränsa aktiviteter

    Kräver säkerhetslösenordet för att utföra följande valda funktioner: utskrift, redigering, kopiering och kommentering.

  5. Stäng dialogrutan Alternativ genom att klicka på OK.

  6. Ange ett filnamn och en plats och klicka sedan på Spara.

    Obs!

    Om det finns sidor i ditt Fireworks-dokument med genomskinliga arbetsytor kommer alla objekt med genomskinlighet att förlora de genomskinlighetsegenskaperna när du exporterar till PDF. Du undviker detta genom att ställa in arbetsytan till en icke-genomskinlig bakgrund innan du exporterar till PDF.

Videofilm

Skapa klientkorrektur som PDF- eller HTML-filer med Fireworks (00:05:32)

Läs om hur du använder menyn Exportera i Fireworks till att förbereda ett PDF- eller HTML-dokument som kunden kan godkänna eller som gruppen kan granska.

Av Tom Green

När du visar exporterade PDF-filer i Adobe Acrobat eller Adobe Reader använder du följande inställningar:

  1. I Adobe Acrobat eller Adobe Reader väljer du Redigera > Inställningar.

  2. Välj Sidvisning i den vänstra panelen.

  3. Ange anpassad upplösning med 72 bildpunkter.

  4. Ange zoomvärdet 100 %.

Exportera FXG-filer

FXG är ett filformat som stöds av Flash Catalyst, Fireworks, Illustrator och Photoshop. När du exporterar en fil som innehåller vektor- och bitmappsbilder med hjälp av FXG-export skapas en separat mapp med namnet <filnamn.assets>. Mappen innehåller de bitmappsbilder som är associerade med filen.

Om du tar bort någon av de associerade filerna från mappen kommer en eventuell import att misslyckas.

Obs!

Element, filter, blandningslägen, övertoningar och masker som det inte finns någon motsvarande mappningstagg för i FXG exporteras som bitmappsbilder.

  1. Välj Arkiv > Exportera och bläddra efter den plats där du vill spara filen.

  2. Ange ett filnamn för FXG-filen.

  3. Välj FXG och bilder på menyn Exportera i dialogrutan Exportera.

  4. Klicka på Spara.

Obs!

Objekt som utökas utanför arbetsytan i Fireworks visas helt när den exporterade FXG-filen öppnas i Flash Catalyst.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy