• Du kan importera, kopiera och klistra in, eller exportera Fireworks-vektorer, bitmappar, animeringar och flerlägesknappsgrafik som ska användas i Flash®.

  • TLF-text från Flash kopieras som en tom bitmappsbild i Fireworks på Windows. Konvertera TLF-text till ASCII-text och importera den till Fireworks.

  • Med funktionen starta-och-redigera är det enkelt att redigera Fireworks-bilder i Flash. När du arbetar i Flash används alltid de inställningar för att starta och redigera du anger i Fireworks.

  • Flash HTML-stilen stöder inte popup-menykod. Fireworks-knappars beteenden och andra typer av interaktivitet importeras inte till Flash.

Montera Fireworks-grafik i Flash

Import eller kopiering av en Fireworks-PNG-fil ger bästa kontrollen av hur grafik och animeringar läggs till i Flash. Du kan också importera JPEG-, GIF-, PNG- och SWF-filer som har exporterats från Fireworks.

Obs!

När Fireworks-grafik importeras eller kopieras och klistras in i Flash förloras vissa attribut, t.ex. direktfilter och strukturer. Du kan inte importera eller kopiera en övertoningseffekt från Fireworks till ett Flash-dokument. Flash stöder dessutom bara helfyllningar, övertoningsfyllningar och baslinjer.

Importera Fireworks-PNG-filer till Flash

Du kan importera Fireworks-PNG-källfiler direkt till Flash utan att behöva exportera till något annat grafikformat. Alla Fireworks-vektorer, bitmappar, animeringar och flerlägesknappsbilder kan importeras till Flash.

Obs!

Knappbeteenden i Fireworks och andra typer av interaktivitet importeras inte till Flash eftersom Fireworks-beteenden aktiveras av JavaScript som är externt till filformatet. Flash använder intern ActionScript-kod.

  1. Spara dokumentet i Fireworks.

  2. Byt till ett öppet dokument i Flash.

  3. (Valfritt) Klicka på nyckelläget och lagret som du vill importera Fireworks-innehållet till.

  4. Välj Arkiv > Importera.

  5. Navigera till och markera PNG-filen.

  6. Gör något av följande i dialogrutan Importera Fireworks-dokument:

    • Välj Importera som en sammanslagen bitmapp.

    • Välj ett importalternativ på de två snabbmenyerna.

  7. Välj hur texten ska importeras.

  8. Klicka på OK.

    Obs!

    Dina val i dialogrutan Importera Fireworks-dokument sparas och används som standardinställningar.

Alternativ för import av Fireworks-grafik, vektorobjekt och text

Importalternativ för bilder

Importera som en sammanslagen bitmapp

Importera en bild som det inte går att redigera.

Importera alla sidor i nya lägen som filmklipp

Importerar alla sidor i PNG-filen till ett nytt Flash-lager som får samma namn som PNG-filen. Ett nyckelläge skapas i det nya lagret på det aktuella lägets plats, den första sidan i PNG-filen placeras som ett filmklipp i det här läget och alla andra sidor placeras i lägen efter det som filmklipp. Lagerhierarkin och lägen i PNG-filen bevaras.

Importera sidan 1 i aktuellt läge som filmklipp

Innehållet i den valda sidan importeras som ett filmklipp som placeras i det aktiva läget och det aktiva lagret i Flash-filen. Lagerhierarkin och lägen i PNG-filen bevaras.

Importera alla sidor i nya scener som filmklipp

Importerar alla sidor från PNG-filen och mappar alla till en ny scen som filmklipp. Alla lager och lägen på sidorna bevaras. Om det redan finns scener i Flash-filen läggs de nya scenerna till efter de befintliga vid importen.

Importera sidan 1 i nytt lager

Den valda sidan importeras som ett nytt lager. Lägen importeras i tidslinjen som separata lägen.

Alternativ för import av vektorobjekt

Importera som bitmappar för att bevara utseende

Bevarar möjligheten till redigering av vektorobjekt, såvida de inte har speciella fyllningar, linjer eller effekter som Flash inte stöder. Om du vill bevara utseendet på sådana objekt konverteras de till icke-ändringsbara bitmappsbilder i Flash.

Importera som redigerbara banor

Bevarar ändringsbarheten av alla vektorobjekt. Om objekt har speciella fyllningar, linjer eller effekter som Flash inte stöder, kan dessa egenskaper se annorlunda ut när de importerats.

Importalternativ för text

Importera som bitmappar för att bevara utseende

Bevarar möjligheten till redigering av text, såvida den inte har speciella fyllningar, linjer eller effekter som Flash inte stöder. Om du vill bevara utseendet på sådan text konverteras den till icke-ändringsbar bitmappsbild i Flash.

Obs!

TLF-text från Flash kopieras som en tom bitmappsbild i Fireworks.

Bevara all text redigerbar

Bevarar ändringsbarheten för all text. Om textobjekt innehåller speciella fyllningar, linjer eller effekter som Flash inte stöder, kan dessa objekt se annorlunda ut när de importerats.

Kopiera eller dra Fireworks-grafik till Flash

Om du vill kopiera grafik till versioner av Flash som är tidigare än Flash 8 väljer du Redigera > Kopiera bankonturer.

Obs!

Du måste kanske dela upp objekten (Ändra > Dela upp) för att de ska kunna redigeras som separata vektorobjekt i Flash.

  1. I Fireworks markerar du de objekt som ska kopieras.

  2. Välj Redigera > Kopiera och sedan Kopiera i Flash-snabbmenyn.

  3. I Flash skapar du ett nytt dokument och väljer Redigera > Klistra in eller också drar du filen direkt från Fireworks till Flash.

  4. I dialogrutan Importera Fireworks-dokument väljer du ett Till-alternativ:

    Aktuella lägen som filmklipp

    Innehållet som klistras in importeras som ett filmklipp som placeras i det aktiva läget och det aktiva lagret i Flash-filen. Lagerhierarkin och lägen i PNG-filen bevaras.

    Nytt lager

    Det inklistrade innehållet importeras som ett nytt lager. Lägen importeras i tidslinjen som separata lägen.

  5. Välj hur vektorobjekt ska importeras.

  6. Välj hur texten ska importeras.

  7. Klicka på OK.

    Obs!

    Dina val i dialogrutan Importera Firework-dokument sparas och används som standardinställningar.

Biblioteksstrukturen i Flash

Fireworks-objekt importeras i en Fireworks-objektsmapp i Flash-biblioteket. Strukturen i mappen är så här:

Fil 1, mapp // har fått Fireworks-filnamnet

  • Sidan 1, mapp // har fått sidans namn (om det är flera sidor)

    — Sidan 1 // har fått sidans namn

    — — Läge 1 mapp // har fått lägets namn (om det är flera lägen)

    — — Läge 1 // har fått lägets namn

    — — — Symbol 1 i Läge 1 // namnet baseras på symbolnamnet

    — — — Symbol 2 i Läge 1

    ...

    — Delade lager, mapp // Delade lager i lägen på Sidan 1

    — — Delade lager, mapp // har fått namnet på det delade lagret

    — — Delat lager, symbol

  • Sidan 2, mapp

    — Sidan 2

    — Symbol 1 på Sidan 2 (för en sida utan lägen)

    ...

  • Huvudsida, mapp

    — Huvudsida

    — Symbol 1 på Huvudsida

    ...

    — Delade lager, mapp // Delade lager på sidor

    — — Delade lager, mapp // har fått namnet på det delade lagret

    — — Delat lager, symbol

Importera Fireworks-symboler till Flash

När du importerar Fireworks-symboler till Flash måste du tänka på följande:

  • Om en symbol använder 9-segmentsstödlinjer importeras de fyra stödlinjerna och bevaras i Flash. 9-segmensstödlinjer bevaras emellertid inte för animeringar. De importerade symbolerna sparas som symboler i Flash-biblioteket.

  • Mjuka redigeringar som har använts på symboler försvinner. Huvudkopian för symbolen importeras.

  • Grafiksymboler lagras som en PNG-fil och JSF-filer. Endast PNG-filen importeras. Om symbolen innehåller ett antal banor kombineras de till en symbol.

  • Om du vill ha en symbols alla funktioner i Flash ersätter du den med Flash-versionen av symbolen.

Bevara synlighet och låsning

Objekt och lager som döljs i PNG-filen importeras och förblir dolda i Flash. Icke-synliga delar av en grafiksymbol importeras inte (t.ex. knappen Över- eller Ned-läge).

Om ett lager är låst eller dolt ärver alla objekt och underlager i lagret den låsta eller dolda inställningen och behåller den när de importeras till Flash.

Om du importerar en enskild sida till ett nytt lager i Flash skapas ett lager för hela sidan och alla objekt visas. Synlighets- och låsningsattribut bevaras inte.

Photoshop-lagereffekter som stöds

Photoshop Live-effekt - Skugga

Avbildning enligt följande:

  • storleksavbildningar till oskärpaX, oskärpaY

  • avståndsavbildningar till avstånd

  • färgavbildningar till färg

  • vinkelavbildningar till 180 - (Photoshop Effect-vinkel)

Photoshop Live-effekt - Inre skugga

Avbildning enligt följande:

  • storleksavbildningar till oskärpaX, oskärpaY

  • avståndsavbildningar till avstånd

  • färgavbildningar till färg

  • vinkelavbildningar till 180 - (Photoshop Effect-vinkel)

Photoshop Live-effekt - Yttre glöd

Avbildning enligt följande:

  • opacitetsavbildningar till styrka

  • färgavbildningar till färg

  • storleksavbildningar till oskärpaX, oskärpaY

Photoshop Live-effekt - Inre glöd

Avbildning enligt följande:

  • opacitetsavbildningar till styrka

  • färgavbildningar till färg

  • storleksavbildningar till oskärpaX, oskärpaY

  • objekt med andra Photoshop-lagereffekter rastreras

Exportera Fireworks-grafik till andra format att användas i Flash

Du kan exportera Fireworks-grafik som JPEG-, GIF-, PNG- och Adobe Illustrator 8-filer (AI) och sedan importera dem till Flash.

Även om PNG är det ursprungliga filformatet för Fireworks är PNG-grafikfiler som exporterats från Fireworks annorlunda än de PNG-källfiler som du sparar i Fireworks. Exporterade PNG-filer innehåller bara bilddata, precis som GIF-filer och JPEG-filer, och ingen information om segmentlager, interaktivitet, direktfilter eller annat ändringsbart innehåll.

Exportera Fireworks-bilder och animeringar som SWF-filer

Fireworks-grafik och animeringar kan exporteras som SWF-filer i Flash. Om du vill bevara linjestorlek och färgformatering väljer du Bevara utseende i dialogrutan Exportalternativ för Flash SWF.

Följande formatering försvinner vid export till SWF-format: blandningsläge, lager, masker (används före export), segmentobjekt, bildscheman, beteenden, fyllningsmönster och övertoningar.

  1. Välj Arkiv > Spara som.

  2. Ange ett filnamn och välj en målmapp.

  3. Välj Adobe Flash SWF som format.

  4. Klicka på Alternativ. Välj Objekt:

    Bevara banor

    Med det här alternativet kan du bevara banornas ändringsbarhet. Effekter och formatering försvinner.

    Bevara utseende

    Konverterar vektorobjekt till bitmappsobjekt och bevarar utseendet på använda linjer och fyllningar. Ändringsbarheten försvinner.

  5. Välj ett textalternativ:

    Bevara ändringsbarhet

    Med det här alternativet kan du bevara textens ändringsbarhet. Effekter och formatering försvinner.

    Konvertera till banor

    Konverterar text till banor, bevarar kerning och mellanrum du angett i Fireworks. Ändringsbarheten försvinner.

  6. Ange kvalitet på JPEG-bilder med snabbskjutreglaget för JPEG-kvalitet.

  7. Välj vilka lägen som ska exporteras och lägesfrekvensen i sekunder.

  8. Klicka på OK och sedan på Spara i dialogrutan Exportera.

Exportera 8-bitars PNG-filer med genomskinlighet

Om du vill exportera 32-bitars PNG-filer med genomskinlighet importerar du Fireworks-PNG-källfiler direkt till Flash. Om du vill exportera 8-bitars PNG-filer med genomskinlighet gör du så här:

  1. Välj, i Fireworks, Fönster > Optimera så att panelen Optimera öppnas.

  2. Välj PNG 8 som exportfilsformat och Alfagenomskinlighet på snabbmenyn Genomskinlighet.

  3. Välj Arkiv > Exportera.

  4. Välj Endast bilder på snabbmenyn Spara som typ.

  5. Namnge och spara filen.

Importera exporterade Fireworks-bilder och animeringar till Flash

  1. Skapa ett nytt dokument i Flash.

    Obs!

    Om du importerar en Fireworks-bild till en befintlig Flash-fil skapar du ett nytt lager i Flash.

  2. Välj Arkiv > Importera och leta rätt på bild- eller animeringsfilen.

  3. Importera filen genom att klicka på Öppna.

Använda Fireworks till att redigera bilder i Flash

Tack vare starta-och-redigera-integration kan du använda Fireworks till att göra ändringar i en bild som du tidigare importerat till Flash, även om bilden inte har exporterats från Fireworks.

Obs!

Ursprungliga Fireworks-PNG-filer som importerats till Flash är undantag. PNG-filen måste ha importerats som en sammanslagen bitmappsbild.

Om bilden exporterats från Fireworks och du sparat den ursprungliga PNG-filen kan du redigera PNG-filen i Fireworks från Flash. När du går tillbaka till Flash uppdateras både PNG-filen och bilden i Flash.

  1. Högerklicka (Windows) eller Ctrl-klicka (Mac OS) i Flash på bildfilen i panelen Dokumentbibliotek.

  2. Välj Redigera med Fireworks på snabbmenyn.

    Obs!

    Om detta alternativ inte visas på menyn väljer du Redigera med och letar upp Fireworks-programmet.

  3. Klicka på Ja i rutan Hitta källa och leta rätt på PNG-originalfilen för Fireworks-bilden och klicka sedan på Öppna.

  4. Redigera bilden och klicka på Klar när du är färdig.

    En ny bildfil exporteras till Flash och den ursprungliga PNG-filen sparas.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy