I Fireworks importeras Photoshop (PSD)-originalfiler och bevaras många Photoshop-funktioner. Du kan också exportera Fireworks-grafik till Photoshop där du kan redigera dem.

Montera Photoshop-bilder i Fireworks

Du monterar Photoshop-bilder i Fireworks med Arkiv > Import eller Arkiv > Öppna eller genom att dra filerna till arbetsytan. Med kommandot Import får du åtkomst till unika alternativ för bakgrundslagret och lagermappar. Med kommandot Öppna och med fildragningsmetoden får du åtkomst till stödlinjer och lägen.

Photoshop-funktioner som är konverterade och inte stöds i Fireworks

När du öppnar eller importerar en Photoshop-fil konverterar Fireworks bilden till PNG-format enligt dina angivna importinställningar. (Se Inställningar för att importera och öppna i Photoshop.)

  • Enskilda lagermasker konverteras till Fireworks objektmasker. Gruppmasker stöds ej.

  • Urklippsmasker konverteras till objektmasker, men deras utseende förändras något. Markera inställningen urklippsmasker för att bevara utseendet men förlora redigeringsmöjligheterna.

  • Blandningslägen för lager konverteras till blandningslägen för Fireworks objekt om motsvarande lägen finns.

  • Lagereffekter bevaras som standardinställning. Välj inställningen i lagereffekter om du föredrar att konvertera de här effekterna till motsvarande direktfilter. Observera att liknande effekter och filter kan skilja sig något i utseende.

  • Den första alfakanalen i paletten Kanaler konverteras till genomskinliga områden i Fireworks-bilden. Fireworks stöder inte ytterligare Photoshop-alfakanaler.

  • Alla färgdjup och lägen i Photoshop konverteras till 8-bit RGB.

Dra, öppna eller importera Photoshop-bilder till Fireworks

Alla bilder du drar, öppnar eller importerar blir nya bitmappsobjekt.

Obs!

I Windows måste Photoshop-filnamn innehålla ett PSD-filnamnstillägg för att filtypen ska identifieras i Fireworks.

  1. Gör något av följande:

    • Dra en Photoshop-bild eller fil till ett öppet Fireworks-dokument.

    • Välj Arkiv > Öppna eller Arkiv > Import och navigera till en Photoshop-fil (PSD).

  2. Klicka på Öppna.

  3. I dialogrutan som visas väljer du bildalternativ och klickar sedan på OK.

  4. Om du använt Arkiv > Import visas en markör som ser ut som ett omvänt L. Klicka på arbetsytan där du vill placera bildens övre vänstra hörn.

Importalternativ för Photoshop-filer

När du importerar eller öppnar en Photoshop-fil i Fireworks visas en dialogruta där du anger hur bilden ska importeras. De alternativ du väljer avgör hur de importerade filerna ser ut och kan ändras.

  1. Ange bilddimensioner i pixlar eller procent och ange pixelupplösning. Om du vill bibehålla förhållandet mellan bredd och höjd väljer du Bibehåll proportioner.

  2. Om Photoshop-filen innehåller lagerkompositioner väljer du vilken version av bilden du vill importera. Välj Förhandsvisa om du vill visa en förhandsvisning av den valda kompositionen. I textrutan Kommentarer visas kommentarer från Photoshop-filen.

  3. Välj i snabbmenyn längst ned hur Photoshop-bilden ska öppnas i Fireworks:

    Bevara lagers redigerbarhet viktigare än utseende

    Bevarar så mycket lagerstruktur och textändringsbarhet som möjligt utan att offra bildens utseende. Om filen innehåller funktioner som Fireworks inte stöder, bevaras dokumentets utseende genom att lagren läggs samman och rasteriseras. Några exempel:

    • CMYK-lager, justeringslager och lager som använder ett Spara ur-alternativ slås samman med underliggande lager.

    • Lager som använder lagereffekter som inte stöds kan slås samman, beroende på lagrets blandningsläge och om det finns genomskinliga pixlar.

    Bevara utseende på Photoshop-lager

    Lägger samman alla objekt på alla Photoshop-lager och konverterar alla Photoshop-lager till bitmappsobjekt. Med det här alternativet tas möjligheten bort att ändra Photoshop-lager i Fireworks. Lagergrupper bibehålls emellertid.

    Använda anpassade inställningar

    Importerar filen med de anpassade filkonverteringsinställningar du anger i dialogrutan Inställningar. (Se Inställningar för att importera och öppna i Photoshop.)

    Lägg samman Photoshop-lager till en bild

    Importerar Photoshop-filen som en sammanslagen bild utan lager. Den konverterade filen bibehåller inte några individuella objekt. Opacitet bibehålles men kan inte ändras.

  4. Om du använder Arkiv > Importera kan du välja följande alternativ:

    Inkludera bakgrundslager

    Importera objekt från bildens bakgrundslager.

    Importera till ny mapp

    Importera bilden till den nya lagermappen "Photoshop Import".

  5. Om du har använt Arkiv > Öppna eller dragit Photoshop-filen till Fireworks kan du välja följande alternativ:

    Inkludera stödlinjer

    Bevara de ursprungliga positionerna för Photoshop-stödlinjer.

    Konvertera lager till lägen

    Montera alla Photoshop-lagergrupper i egna lägen.

Importera text från Photoshop

Obs!

Om du snabbt vill importera viss text till en Photoshop-fil kopierar du den direkt till Fireworks. Kopierad text behåller alla textattribut.

När du importerar Photoshop-filer som innehåller text letar Fireworks efter nödvändiga teckensnitt på systemet. Om teckensnitten inte har installerats uppmanas du att ersätta dem eller bibehålla deras utseende.

Om texten i Photoshop-filen har effekter som stöds i Fireworks används de där. Men eftersom Fireworks och Photoshop använder effekter på olika sätt, kanske de visas på olika sätt i de båda programmen.

Om filer från Photoshop 6 eller 7 som innehåller text öppnas eller importeras i Fireworks med alternativet Bevara utseende markerat, visas en cache-lagrad bild av texten så att utseendet från Photoshop bibehålls. När du redigerar texten ersätts den cache-lagrade bilden med aktuell text. Textens utseende kan variera från den ursprungliga textens. Ursprungliga teckensnittsdata lagras emellertid i PNG-filen så att du kan använda originalteckensnitten på system som har dem installerade.

Obs!

Fireworks kan inte exportera text i 6- eller 7-format. Om du ändrar ett dokument som innehåller Photoshop 6- eller 7-text och sedan exporterar tillbaka dokumentet till Photoshop, exporteras filen i Photoshop 5.5-format. Om du inte gör några ändringar i texten exporteras filen emellertid i Photoshop 6-format.

Importera/exportera Photoshop-övertoningar

Kvaliteten på övertoningen efter att du har importera eller exporterat den beror på övertoningstypen. Det kan också finnas mindre variationer i färgen och opaciteten i övertoningarna.

Övertoning

Importkvalitet

Linjär

Nästan perfekt.

Radiell

Nästan perfekt.

Speglad

Nästan perfekt.

Diamant

Ungefärlig (mappas till Rektangulär).

Vinkel

Ungefärlig (mappas till Konisk).

   

Övertoning

Exportkvalitet

Linjär

Nästan perfekt.

Radiell

Nästan perfekt.

Ränder

Nästan perfekt.

Rektangel

Ungefärlig (mappas till Diamant).

Kon

Ungefärlig (mappas till Vinkel).

Oval

Ungefärlig (mappas till Radiell).

Krusningar

Ungefärlig (mappas till Radiell).

Stjärnfall

Ofullkomlig (mappas till Stjärnfall).

Kontur, Satäng, Vågor

Ofullkomlig (mappas till Linjär).

Bevara utseendet på justeringslager efter import

När du importerar en PSD-fil som innehåller ett justeringslager bevaras utseendet på enskilda lager efter importen.

  1. Välj Photoshop - importera/öppna i dialogrutan Inställningar.

  2. Välj Bevara utseende för justerade lager.

Bevara utseende för justerade lager

När du importerar en PSD-fil som innehåller ett justeringslager bevaras utseendet på enskilda lager efter importen. Du måste välja Egna inställningar från Inställningar i dialogrutan.

Använda Photoshop-filter och -plugin-program

Du kan använda många Photoshop-filter och -plugin-program och många tredjepartsfiler och -plugin-program, antingen i fönstret Direktfilter eller på Filter-menyn.

Obs!

Plugin-program och filter för Photoshop 5.5 och tidigare versioner kan användas. Plugin-program och filter för Photoshop 6 eller senare är inte kompatibla med Fireworks.

Aktivera Photoshop-plugin-program i dialogrutan Inställningar

  1. Välj Redigera > Inställningar (Windows) eller Fireworks > Inställningar (Mac OS).

  2. Klicka på kategorin Plugin.

  3. Välj Photoshop-plugin-program.

    Dialogrutan Välj en mapp (Windows) eller Välj en mapp (Mac OS) öppnas.

    Obs!

    Klicka på Bläddra om dialogrutan inte öppnas.

  4. Navigera till mappen där Photoshop eller filter och plugin-program har installerats och klicka sedan på Välj (Windows) eller Välj (Mac OS).

  5. Klicka på OK så att dialogrutan Inställningar stängs.

  6. Starta om Fireworks.

Aktivera Photoshop-plugin-program i dialogrutan Direktfilter

  1. Välj valfria vektorobjekt eller textblock på arbetsytan och klicka på plusikonen (+) bredvid filteretiketten i egenskapskontrollen.

  2. Välj Alternativ > Hitta plugin-program på snabbmenyn.

  3. Navigera till mappen där Photoshop eller filter och plugin-program har installerats och klicka sedan på Välj (Windows) eller Välj (Mac OS). Om du uppmanas att starta om Fireworks klickar du på OK.

  4. Starta om Fireworks för att läsa in filter och plugin-program.

    Obs!

    Du kan också installera plugin-program direkt i mappen Plugin i Fireworks.

Placera Fireworks-grafik i Photoshop

Fireworks har utökat stöd för export av filer i Photoshop-format (PSD). En Fireworks-bild som exporteras till Photoshop bibehåller samma ändringsbarhet när den öppnas igen i Fireworks som andra Photoshop-bilder. Photoshop-användare kan arbeta med sina bilder i Fireworks och sedan fortsätta redigera dem i Photoshop.

Obs!

Du kan använda tillägget PSD Save till att snabbt exportera sidor och lägen i ett Fireworks-dokument som separata PSD-filer. Det här tillägget är tillgängligt på http://www.adobe.com/go/learn_fw_psdsave_se

Exportera en fil i Photoshop-format

  1. Välj Arkiv > Spara som.

  2. Namnge filen och välj Photoshop PSD på Spara som-menyn.

  3. Klicka på Alternativ om du vill ange förinställda exportalternativ för objekt, effekter och text. Välj därefter en förinställning nedan på menyn Inställningar.

    Bevara redigerbarhet viktigare än utseende

    Konverterar objekt till lager, bibehåller effekters ändringsbarhet och konverterar text till ändringsbara Photoshop-textlager. Välj det här alternativet om du tänker ändra bilden i Photoshop och inte behöver bibehålla Fireworks-bildens exakta utseende.

    Bevara Fireworks-utseende

    Konverterar alla objekt till ett separat Photoshop-lager och effekter och text blir inte ändringsbara. Välj det här alternativet om du vill bibehålla kontrollen över Fireworks-objektet i Photoshop men också om du vill bibehålla Fireworks-bildens ursprungliga utseende.

    Mindre Photoshop-fil

    Läger samman alla lager till en helt återgiven bild. Välj det här alternativet om du exporterar en fil som innehåller ett stort antal Fireworks-objekt.

    Anpassat

    Välj inställningar för objekt, effekter och text.

  4. Klicka på Spara när du vill exportera Photoshop-filen.

    Obs!

    I Photoshop 5.5 och tidigare kan inte filer med fler än 100 lager öppnas. Du måste ta bort eller slå samman objekt om det Fireworks-dokument du exporterar innehåller mer än 100 objekt.

Anpassa exportinställningar i Photoshop

  1. I dialogrutan Spara som väljer du Photoshop PSD som filtyp och därefter klickar du på Alternativ.

  2. På snabbmenyn Inställningar väljer du Egen.

  3. Välj något av följande på snabbmenyn Alternativ:

    Konvertera till Photoshop-lager

    Konvertera Fireworks-objekt till Photoshop-lager och Fireworks-masker till Photoshop-lagermasker.

    Lägg samman varje Fireworks-lager

    Lägger samman alla objekt i varje separat lager och alla Fireworks-lager blir ett lager i Photoshop. När du väljer det här alternativet förlorar du möjligheten att ändra Fireworks-objekt i Photoshop. Du förlorar också funktioner, t.ex. blandningslägen, som är kopplade till Fireworks-objekten.

  4. Välj något av följande på snabbmenyn Effekter:

    Bevara ändringsbarhet

    Konverterar Fireworks-direktfilter till deras motsvarighet i Photoshop. Om effekterna inte finns i Photoshop ignoreras de.

    Återge effekter

    Lägger samman effekter i sina objekt. Om du väljer det här alternativet bibehåller du effekternas utseende, men du kan inte ändra dem i Photoshop.

  5. Välj något av följande på snabbmenyn Text:

    Bevara ändringsbarhet

    Konverterar text till ändringsbart Photoshop-lager. Textformatering som inte stöds av Photoshop förloras.

    Återge text

    Ändrar en text till ett bildobjekt. När du väljer det här alternativet bibehåller du textens utseende, men du kan inte ändra den.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy