Choose a view layout and share view settings

The Composition panel can show one, two, or four views at a time. By default, viewer options (such as grids and rulers) affect only the currently active view.

  • To choose a view layout, choose an option from the Select View Layout menu at the bottom of the Composition panel.
  • To scroll through view layouts, place the pointer over the Select View Layout menu and roll the mouse wheel.
  • To apply view settings to all views in the current layout, choose Share View Options from the Select View Layout menu. Hold Ctrl (Windows) or Command (Mac OS) to temporarily reverse this behavior.

Note:

To activate a view without affecting the selection of layers in a composition, use the middle mouse button to click within the view’s pane in the Composition panel.

Choose a 3D view

You can view your 3D layers from several angles, using orthographic views, custom views that employ perspective, or camera views.

The working 3D views include the custom views and the fixed orthographic views (Front, Left, Top, Back, Right, or Bottom). The orthographic views show layer positions in the composition but do not show perspective. The working 3D views are not associated with a camera layer. The working 3D views are useful for placing and previewing elements in a 3D scene. 3D layers appear in working 3D views; 2D layers do not appear in working 3D views.

Note:

The Composition panel displays a label within each view (such as Top or Right) to indicate which view is associated with which camera perspective. To hide these labels, choose Show 3D Labels from the Composition panel menu.

You can adjust the point of view and direction of view for the custom views with the Camera tools, or you can look at selected layers or all layers. (See Adjust a 3D view or move a camera, light, or point of interest.)

  • Choose a view from the 3D View menu at the bottom of the Composition panel.
  • Choose View > Switch 3D View, and choose a view from the menu.
  • Choose View > Switch To Last 3D View.
  • To switch to the previous 3D view, press Esc.
  • To choose one of the 3D views with keyboard shortcuts, press F10, F11, or F12.

Note:

To change which 3D view is assigned to a keyboard shortcut, switch to a view and then press Shift and the keyboard shortcut. For example, to make F12 the shortcut for Top view, switch to Top view and then press Shift+F12. You can also use the View > Assign Shortcut To menu command for this purpose.

Show or hide layer controls in the Composition panel

You can assign different options to each view in the Composition panel, so that you can see any combination of camera and light wireframes, layer handles, mask and shape paths, effect control points, and motion path controls.

  • To choose which layer controls to show in a view, choose View > View Options, or press Ctrl+Alt+U (Windows) or Command+Option+U (Mac OS).
  • To show or hide layer controls in a view, choose View > Show Layer Controls, or press Ctrl+Shift+H (Windows) or Command+Shift+H (Mac OS). This command also shows or hides the 3D reference axes.
  • To show or hide mask paths and shape paths in a view, click the Toggle Mask And Shape Path Visibility button at the bottom of the Composition panel.

Zoom an image for preview

Note:

For information on scaling a layer, not just zooming in or out of the preview image, see Scale or flip a layer.

The Magnification Ratio control in the lower-left corner of a Composition, Layer, or Footage panel shows and controls the current magnification. By default, the magnification is set to fit the current size of the panel. When you change magnification, you change the appearance of the preview in the panel that you are previewing, not the actual resolution and pixels of the composition.

The quality of zooming for previews can be set using the Zoom Quality preference. (See Viewer Quality preferences.)

Note:

After Effects renders vector objects before zooming (scaling for preview), so some vector objects may appear jagged when you zoom in on them. This apparent pixelation for zooms does not affect scaling of layers or rendering to final output.

  • To zoom in to or out from the center of the active view, press the period (.) key or the comma (,) key. Each keypress additionally increases or decreases the magnification.
  • To zoom in to or out from the center of the view using the mouse scroll wheel, place the pointer over the panel and move the scroll wheel.
  • To zoom in on or out from a specific point using the mouse scroll wheel, place the pointer over the panel and hold Alt (Windows) or Option (Mac OS) as you move the scroll wheel.
  • To zoom in on a specific point using the Zoom tool , click the area in the panel you want to magnify. Each click additionally magnifies the image, centering the display on the point you click. You can also drag the tool to magnify a specific area.
  • To zoom out from a specific point using the Zoom tool, Alt-click (Windows) or Option-click (Mac OS) the point that you want to be the center of the zoomed-out view. Each click additionally decreases the magnification of the image, centering the display on the point you click.
  • To zoom the active view to 100%, double-click the Zoom tool button in the Tools panel.
  • To zoom to fit or to zoom to a preset magnification, choose a zoom level from the Magnification Ratio menu. To change the magnification of all views in a Composition panel, hold Ctrl (Windows) or Command (Mac OS) while choosing a zoom level from the menu. Choose Fit to make the image fit the Composition panel; choose Fit Up To 100% to limit the zoom level to 100%.

Note:

To pan around in the Composition, Layer, or Footage panel while zoomed in, drag with the Hand tool, which you can activate by holding down the spacebar, the H key, or the middle mouse button. Hold Shift, too, to pan faster.

For additional ways to zoom and scroll using the mouse scroll wheel, see Scroll or zoom with the mouse wheel.

Resolution

In the context of printing and other media with fixed linear dimensions, resolution refers to linear pixel density: the number of pixels or dots in a certain span, expressed in such terms as ppi (pixels per inch) and dpi (dots per inch).

In video, film, and computer graphics contexts, the linear measurements of the images are variable, so it doesn’t make sense to refer to the number of pixels per inch or any other linear measure. Consider, for example, that the same 640x480 movie can be shown on the tiny screen of a mobile device, the monitor of a desktop computer, and a huge motion billboard. The number of pixels per inch is different for each of these presentation devices, even though the number of pixels may be the same.

In this context, the term resolution refers to a relative quantity: a ratio of the number of pixels that are rendered to the number of pixels in a source image. For each view, there are two such ratios—one for the horizontal dimension and one for the vertical dimension.

Each composition has its own Resolution setting, which affects the image quality of the composition when it’s rendered for previews and final output. Rendering time and memory for each frame are roughly proportional to the number of pixels being rendered.

When you render a composition for final output, you can use the current Resolution settings for the composition or set a resolution value in the Render Settings dialog box that overrides the composition settings. (See Render settings.)

You can choose from the following Resolution settings in the Composition Settings (Composition > Composition Settings) dialog box or from the Resolution/Down Sample Factor menu at the bottom of the Composition panel:

Auto

(available only for previews) Adapts the resolution of the view in the Composition panel to render only the pixels necessary to preview the composition at the current zoom level. For example, if the view is zoomed out to 25%, then the resolution automatically adapts to a value of 1/4—shown as (Quarter)—as if you had manually chosen Quarter. If a panel contains multiple views, the resolution adapts to the view with the highest zoom level. This setting gives the best image quality while also avoiding rendering pixels unnecessary for the current zoom level.

Note:

The Auto setting is ignored for compositions for which the Advanced composition setting Preserve Resolution When Nested is selected.

Full

Renders each pixel in a composition. This setting gives the best image quality, but takes the longest to render.

Half

Renders one-quarter of the pixels contained in the full-resolution image—half the columns and half the rows.

Third

Renders one-ninth of the pixels contained in the full-resolution image.

Quarter

Renders one-sixteenth of the pixels contained in the full-resolution image.

Custom

Renders the image at the horizontal and vertical resolutions that you specify.

Note:

The resolution (down-sample factor) of a Layer viewer is tied to the resolution of the Composition viewer for the composition in which the layer is contained.

View a color channel or alpha channel

You can view red, green, blue, and alpha channels—together or separately—in a Footage, Layer, or Composition panel by clicking the Show Channel button at the bottom of the panel and choosing from the menu. When you view a single color channel, the image appears as a grayscale image, with the color value of each pixel mapped to a scale from black (0 value for the color) to white (maximum value for the color).

Note:

To see color values displayed in the channel’s own color instead of white, choose Colorize from the Show Channel menu.

When you preview the alpha channel, the image appears as a grayscale image, with the transparency value of each pixel mapped to a scale from black (completely transparent) to white (completely opaque).

Note:

When you choose RGB Straight, which shows straight RGB values before they are matted (premultiplied) with the alpha channel, pixels with complete transparency are undefined and therefore may contain unexpected colors.

You can view other channel values, such as saturation and hue, by applying the Channel Combiner effect and choosing Lightness from the To menu.

Note:

To switch between showing the alpha channel and showing all RGB channels, Alt-click (Windows) or Option-click (Mac OS) the Show Channel button.

Alpha Boundary and Alpha Overlay view modes are only available in the Layer panel, and they are intended for use with the Roto Brush effect. For information on these modes, see Layer panel view options.

Adjust exposure for previews

You can adjust the exposure (in f-stop units) for previews with the Adjust Exposure control, which is located to the right of the Reset Exposure button at the bottom of a Composition, Layer, or Footage panel. Each viewer can have its own Adjust Exposure setting.

When the Adjust Exposure control is set to a value other than zero, the Reset Exposure button is blue.

The Adjust Exposure control doesn’t affect final output, only how video appears during previews. To make tonal adjustments to a layer that appear in the final output, use the Exposure effect.

Note:

The Adjust Exposure control is useful for finding the black point or white point in an image. For example, drag the value control to the right (positive values) until the entire image is white except for one area; that area is the darkest area in the image.

Note:

To check the quality of a composite, drag the Adjust Exposure control far to the left and far to the right and look for places where the composited elements differ too much in color or luminance. This technique—sometimes called gamma slamming—is useful for ensuring that a composite will look good and be convincing in contexts other than the one in which you’re working. For example, a composite that is adequate in a dark scene may be less convincing when the scene is color-corrected to brighten the scene.

  • To adjust exposure for a viewer, drag the Adjust Exposure control to the left or right, or click the control and enter a value in the box.
  • To reset exposure, click the Reset Exposure button. To return to the most recent non-zero setting, click the button again.

Safe zones, grids, guides, and rulers

In the Footage, Layer, and Composition panels, you can display safe zone margins, grids, rulers, and guidelines to align and arrange visual elements. After Effects preserves guides when importing Photoshop files saved with guides.

Safe-zone margins, grids, and guides are not rendered, either for the preview options or for final output.

The size of proportional grids increases or decreases when the composition size changes; the size of standard grid squares remains the same regardless of composition size.

  • To change settings for safe-zone margins, grids, and guides, choose Edit > Preferences > Grids & Guides (Windows) or After Effects > Preferences > Grids & Guides (Mac OS).

  • To show or hide safe zones, grids, guides, or rulers, click the Grid And Guides Options button and choose the appropriate item, or use a menu command or keyboard shortcut in the View menu.

  • To toggle between showing and hiding the safe zones, Alt-click (Windows) or Option-click (Mac OS) the Grid And Guide Options button.

  • To make layer edges and mask edges snap to grids or guides, choose View > Snap To Grid or View > Snap To Guides.

  • To create a guide line, drag from either ruler.

  • To delete a guide line, drag it to a ruler using the Selection tool.

  • To delete all guide lines, choose View > Clear Guides.

  • To move a guide line, drag it using the Selection tool.

  • To lock or unlock guides, choose View > Lock Guides. Locking a guide prevents it from being accidentally moved.

  • To set the zero point (origin) for the rulers, drag the crosshair from the intersection of the two rulers (in the upper-left corner) into the image area. Reset the zero point by double-clicking the intersection of the rulers. The position of the pointer measured from the new zero point is shown in the Info panel as X' and Y' coordinates.

     

Dragging the zero-point crosshair
Dragging the zero-point crosshair

About title-safe and action-safe zones

Television sets enlarge a video image and allow some portion of its outer edges to be cut off by the edge of the screen. This kind of cropping is known as overscan. The amount of overscan is not consistent between television sets, so you should keep important parts of a video image within certain margins, in areas known as safe zones. Safe-zone margins represent the percentage of image dimensions not included in the safe zone. You should always design from one edge of the frame to the other, because computer monitors and some television sets may show the entire frame.

The conventional action-safe zone is 90% of the width and height of the frame, which corresponds to a margin of 5% on each side. Keep important visual elements within this zone.

The conventional title-safe zone is 80% of the width and height of the frame, which corresponds to a margin of 10% on each side. Keep text that you intend for the audience to read within this zone.

Compositions with a frame aspect ratio equal to or near 16:9 have two additional center-cut safe-zone indicators. The center-cut indicators show which parts of a 16:9 composition may be cut off when the image is shown on a 4:3 display. Such cropping is a concern when creating images for high-definition displays that may also be shown on standard-definition television sets. By default, the center-cut action-safe margin is 32.5% (16.25% on each side), and the center-cut title-safe margin is 40% (20% on each side).

Note:

The center-cut safe-zone margins are only shown if the frame aspect ratio for the composition is equal to or near 16:9.

Safe zones and grids in the Composition panel
Safe zones and grids in the Composition panel

A. Grid B. Center-cut title-safe zone C. Center-cut action-safe zone D. Title-safe zone E. Action-safe zone 

Aharon Rabinowitz provides a video tutorial in the Multimedia 101 series on the Creative COW website that explains safe zones.

Additional resources for viewing and previewing

When you want to view certain crucial frames in a composition—such as when showing them to a client for interim approval—you may want to create a contact sheet. Jeff Almasol provides a script that creates a contact sheet that consists of a grid of specific individual frames from a composition. You specify which frames to show by setting layer markers. For more information, go to Jeff Almasol's redefinery website.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy